* Don't run tidy with -xml as that fails if the input is not well-formed.
[ikiwiki] / debian / changelog
1 ikiwiki (1.16) UNRELEASED; urgency=low
2
3   * Try to handle relative links in aggregated feeds. However,
4     the current support is a crude hack due to limitations of XML::Feed:
5     xml:base is not supported, neither is Content-Location. And of course,
6     relative links in RSS feeds are ill-undefined..
7   * Make aggregator save permalinks and author name to pages as metadata.
8   * Add permalink and author support to meta plugin, affecting RSS feeds
9     and blog pages.
10   * Various CSS and formatting changes.
11   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
12   * Add xhtml files to the default prune regexp.
13   * Also generate rel=bookmark links for permalinks.
14   * Fix the htmltidy plugin, which wasn't working due my breaking it when
15     I added it..
16   * Don't run tidy with -xml as that fails if the input is not well-formed.
17     Run it with -asxhtml instead, so it will output well-formed xhtml no
18     matter what the input.
19   * Disable tidy warnings too.
20   * Add a new format hook, and make tidy use it, since tidy can really only
21     operate on and output complete html documents, not the body chunks
22     that sanitise gets.
23
24  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 03:33:09 -0400
25
26 ikiwiki (1.15) unstable; urgency=low
27
28   * Remove CDPATH and other env vars perl taint checking doesn't like.
29     Closes: #381279
30   * Added created_before and created_after PageSpec limits.
31
32  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
33
34 ikiwiki (1.14) unstable; urgency=low
35
36   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
37     by 10% or so.
38   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
39   * Added many unit tests for pagespec_match.
40
41  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
42
43 ikiwiki (1.13) unstable; urgency=low
44
45   * ikiwiki can now download and aggregate feeds with its new aggregate
46     plugin, so it's possible to implement a Planet using ikiwiki!
47   * Add a run_hooks function for the common task of running all hooks of a
48     given type.
49   * Add a savestate hook.
50   * Don't put blog post forms on pages if there's no cgiurl set.
51   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
52     --wrappers to do that.
53   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
54     to update pages that haven't changed on disk.
55   * Change meta tags to use html entity-escaped text for values, so that
56     quotes and such can be represented in title tags.
57   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
58     for the above.
59   * Make --rebuild also cause --aggregate to re-download and write aggregated
60     pages.
61   * Avoid outputting duplicate meta info.
62   * Include title metadata on aggregated posts for capitalised and un-munged
63     titles.
64   * Title metadata of inlined pages now shows up in blogs and rss feeds.
65   * Fix issue with unicode filenames and updating the hyper estradier search
66     index. (Aka Please Please Please, let that be the last one.)
67   * Patch from Roland Mas to support an rss=no parameter to inline directives.
68     Closes: #380743
69   * Renamed GlobLists to PageSpecs.
70   * PageSpecs can now include nested parens, "and", and "or". This remains
71     backwards compatible to the old GlobList format. It's implemented by
72     treating the GlobList as a very limited microlanguage that is transformed
73     to perl code that does the matching.
74   * The old GlobList format is deprecated, and I encourage users to switch to
75     using the new PageSpec format. Compatability with the old format will be
76     removed at some point, possibly by 2.0.
77   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
78   * Add support for creation_month and creation_year to PageSpec.
79     Closes: #380680
80   * Changes to index file encoding.
81
82  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
83
84 ikiwiki (1.12) unstable; urgency=low
85
86   "Viva l'Italia!"
87   * New pagestats plugin from Enrico, which can generate a table counting
88     the backlinks for each page, or a del.icio.us style cloud.
89   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
90     the wikiformat plugin works. Thanks, Emanuele Aina.
91   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
92     display, running them through pagetitle. This removes ugly underscores and
93     other gunk from the display, much nicer. You may want to rebuild your wiki
94     when upgrading to get the cleanup globally.
95   * Polygen plugin from Enrico.
96   * htmltidy plugin from Faidon.
97   * Locale patch from Faidon:
98     - Adds a locale setting to setup files.
99     - Proper local time, if the locale configuration option is used.
100     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
101       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
102       impossible.
103   * Add getopt hook type, this allows plugins to add new command-line options.
104   * Add --tagbase option to tag plugin.
105   * Add exclude option in setup files, works same as --exclude.
106   * Put categories in rss feeds for tagged items.
107   * Allow preprocessor directives to be expanded in inlined blog pages.
108     However, to avoid inlining loops etc, don't expand inline directives in
109     inlined pages.
110   * fortune plugin (trivial)
111   * Tag plugins according to type.
112
113  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
114
115 ikiwiki (1.11) unstable; urgency=low
116
117   * Patch from Enrico that
118     - Adds a tag plugin that allows more easily tagging pages.
119       The meta plugin can also still be used for that, but the tag plugin
120       also lists a page's tags at the bottom of the page.
121     - Allows preprocessor directives to have parameters with no specified
122       value.
123     - Fixes preprocessor directive parameter parsing so that
124       foo=bar baz now means "foo=bar" and a "baz" with no value.
125   * Run pagetemplate hooks when inlining pages so that inlined pages also
126     list their tags.
127   * Make all plugins with pagetemplate hooks check that variables exist
128     on the template before setting them, for robustness.
129   * Switch pagetemplate hooks to using named parameters.
130   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
131     This will be the page that a source page will be part of, which is
132     different than the source page for inlined pages.
133   * Audited all plugins to endure they pass (page, destpage) to htmllink
134     appropriatly. This means inlining of various plugins will not work
135     properly, with correct links generated.
136
137  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
138
139 ikiwiki (1.10) unstable; urgency=low
140
141   * Run page through any relevant filters when generating a page preview.
142   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
143     default throughout the wiki, not only on wikitext pages. Decided to call
144     this a feature, and split the camelcase support out into a separate plugin
145     that is independant of wikitext.
146   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
147
148  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
149
150 ikiwiki (1.9) unstable; urgency=low
151
152   * Improve display of parentlinks and page title of toplevel index page.
153   * Patch from Faidon to use svn --limit when possible for recentchanges,
154     speeds up recentchanges a lot for wikis with more history.
155   * Patch from Recai to fix utf8 issues in git backend.
156   * Add wikitext markup plugin, which supports ".wiki" pages written in the
157     original wiki syntax, CamelCase links and all.
158   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
159     support, to edit pages etc without a web server.
160   * Display CGI processing errors if present.
161   * Fix from Faidon for a XML parser issue that breaks utf-8 for
162     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
163     area, and also way slow.
164   * Match 'web commit from' in SVN and git, these are web commits too.
165     (Faidon)
166   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
167     readable and avoid future mistakes. The patch seems to work and for the
168     first time I have a UTF-8 username ;-) (Faidon)
169   * Use form->field consistently, not form->param.
170   * Patch from Recai to allow selection of page type when creating a new page.
171     Default page type is inherited from the link clicked on to create the new
172     page.
173
174  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
175
176 ikiwiki (1.8) unstable; urgency=low
177
178   * Fix orphans plugin to not count a link to a nonexistant page as a reason
179     for a page not being an orphan.
180   * Support pinging services such as Technorati using XML-RPC to notify them
181     about changes to rss feeds.
182   * Parse svn log as xml for improved utf8 and security. Note that this makes
183     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
184   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
185     flagged string even if the locale causes it to generate utf8 output,
186     so make sure to let perl know it should be handled as utf8. Also,
187     the optimised version used for standard time formats won't work if the
188     user has changed locale, so drop it. Thanks, Faidon Liambotis.
189   * Fix re-encoding of the comments field to utf8 if a commit fails
190     due to a conflict. Thanks, Faidon Liambotis.
191   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
192     Liambotis.
193   * Add insane double encode/decode to utf8 around call to markdown.
194     This works around a truely strange bug, which is apparently a bug in
195     perl, #376329. Also added a test case for it.
196   * Improve layout of edit page so formatting help link is always visible w/o
197     getting in the way of the preview.
198   * Centralised all calls to HTML::Template and force all the templates
199     to be read as utf8.
200   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
201   * Introduce add_plugins and disable_plugins config options in setup files.
202     This allows adding or removing plugins w/o overriding the whole list of
203     default plugins, which makes it easier to upgrade when new default plugins
204     are added.
205   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
206     default (of course!). Based on a patch by Faidon Liambotis.
207   * Add a html plugin, which can be used to write wikis in raw html,
208     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
209     defaults to not processing .html files, since w/o this plugin they would
210     be copied unsanitised. With this plugin, it will process and html
211     sanitise them, like any other page type.
212   * Rebuilding wrappers is necessary on upgrade to this version.
213   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
214     will be automatically done on all upgrades.
215   * Don't send pings if the wiki is being rebuilt.
216   * Work around very innefficient behavior in File::Spec::abs2rel. Result
217     is a savings of 2 pointless fork/execs per link calculation, which
218     results in ~25% speedup of ikiwiki building its own doc wiki, and
219     about 35% speedup displaying RecentChanges!
220   * Make RecentChanges use a table and some CSS, should be much more readable.
221     No code changes involved.
222   * Encode & in diffurl in examples, to conform to pedantic rules.
223   * Speed up RecentChanges by another 40% or so with some memoization.
224   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
225     in time to build the doc wiki.
226
227  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
228
229 ikiwiki (1.7) unstable; urgency=low
230
231   * Updated logo from Recai with some kerning and alingment tuning.
232   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
233     changed some output.
234   * Copyright update.
235
236  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
237
238 ikiwiki (1.6) unstable; urgency=low
239
240   * YA utf-8 patch from Recai, this time to fix previewing a page so that
241     the text in the input box is re-encoded back to utf-8.
242   * -CSD does not affect modules, so readfile() was not using the utf-8 input
243     layer, which led to lots of problems; make it force read files as utf-8.
244     Closes: #373203
245   * Note that as a consequence, this version of ikiwiki will actually try to
246     parse utf8 in source files for the first time, which may expose broken
247     utf8 in wiki sources that was hidden before. Most common will be
248     perl warnings like "utf8 "\xE9" does not map to Unicode"
249   * writefile() likewise needs to use the utf8 output layer.
250   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
251     there.
252   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
253     given the readfile fix.
254   * Add utf-8 testcases for readfile and htmlize.
255   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
256     safe.
257   * More utf-8 fixes from Recai, partly to things I broke above:
258     - The serious problem is that writefile() saves the content in undecoded
259       format in CGI, hence all (non-ascii) chars are corrupted permanently.
260     - Comment field in edit page is not decoded and all the non-ascii chars in
261       this field are corrupted as the result.  We should decode it as we do it
262       for the content.
263     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
264       character in print.
265   * New SVG logo from Recai.
266
267  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
268
269 ikiwiki (1.5) unstable; urgency=low
270
271   * Add --timeformat config option to allow changing how dates are displayed.
272     Note that as a side effect, dates will now be displayed using the local
273     timezone, not as GMT.
274   * More security review.
275   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
276     for some handy stuff like:
277     - Using links as a kind of tag; creating blog pages that list all pages
278       containing a given tag/link or not containing some other tag.
279     - Subscribing to mail notifications whenever a change is made to a page
280       that is a backlink of page foo. Ie, "Please notify me of changes in all
281       pages that link to my home page in the wiki"
282     - Locking any pages that are linked to from a particular page, so that
283       lists of locks can be exposed in the wiki.
284   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
285     when a todo item is done, instead of the previous moving it to a different
286     subdir.
287   * Allow pagetemplate plugins to override *anything* in the template.
288   * Add a meta plugin, which allows specifying various metadata about pages,
289     like license and author. It also allows for inserting html link and meta
290     tags into html, overriding the title, and adding hidden WikiLinks, which
291     can be useful when using link-based globbing for page categorisation.
292   * Remove preprocessor directives from inlined pages.
293   * Allow simple preprocessor directive values to be specified w/o quotes.
294   * Add support for using git instead of subversion as the RCS backend,
295     tremendous thanks to Recai Oktaş for this.
296   * Doc updates for git.
297   * Fix absolute url munging in rss generation to support https, ftp, etc urls
298     not just http urls.
299   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
300     utf-8 for edit and other fields, and for recentchanges. There may still
301     be utf-8 issues with the preferences page though.
302
303  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
304
305 ikiwiki (1.4) unstable; urgency=low
306
307   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
308     very strange way of enabling proper XHTML <br /> type tags. Output html
309     should be always valid again now.
310   * The page name and parent links has switched from using a <h1> to a styled
311     <span>, so pages can use <h1> internally instead of needing to use <h2>.
312   * Updated all of ikiwiki's own wiki pages for that.
313   * Add pagetemplate hook, which can be used by plugins that want to mess
314     around with adding new stuff to the page template.
315   * Remove headercontent; the search plugin now adds the search box to the
316     header by registering a pagetemplate hook, and other plugins should do
317     similarly.
318   * Rebuilding on upgrade to this version is recommended.
319   * Add a html validity check to the test suite, using the wdg-html-validator,
320     if available.
321   * Make the html valid when there is nothing in the actions list.
322   * Reordered some function call parameters for consistency.
323   * Enable full utf-8 support for page input and output.
324   * Add a workaround for markdown, which does not work well with utf-8
325     strings.
326   * --getctime had bitrotted (well I only ever used it the once so far..),
327     fix and make it a bit more flexible
328   * rcs_getctime is changed, now rather than needing to loop over all pages,
329     it should just use the rcs to get the ctime of the passed file.
330   * When inlining a page in another one, links from the inlined page are now
331     expanded the same as they are when rendering the inlined page as a
332     standalone page. So rather than being expanded from the POV of the
333     inlining page, they are expanded from the POV of the inlined page.
334
335     For example, a link from blog/foo to "bar" will now link to blog/bar
336     if it exists. Previously this needed to be a link explicitly to
337     "blog/bar"; such links will also continue to work.
338
339     (This was slightly complex to do as the link still has to be constructed
340     relative to the inlining page.)
341   * Make page edit textarea resize to fit browser window.
342   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
343     do not need a full rebuild, in order to update any basewiki pages.
344
345  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
346
347 ikiwiki (1.3) unstable; urgency=low
348
349   * Fix the preinst introduced in the last version. Closes: #367458
350
351  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
352
353 ikiwiki (1.2) unstable; urgency=low
354
355   * Remove dups from the brokenlinks list.
356   * Add libc6-dev to dependencies, needed to build wrappers.
357   * Install wikilist in correct location. Closes: #367371
358
359  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
360
361 ikiwiki (1.1) unstable; urgency=low
362
363   * Rename inlinepage to depends, so that it can be used to refer to more
364     dependency relationships than just inlining. This will require a rebuild
365     on upgrade to this version.
366   * Move the rss link, put it in the blogpost form if there is one and at the
367     top if not. This is both nicer because easier to find, and it cleans up
368     the code which had used inlinepage as a flag for adding the link later.
369   * Allow the depends GlobList to be built up from multiple sources (such as
370     plugins) during a page render.
371   * Which means that more than one blog is now supported to appear on a
372     single page. (With some limitations, like only the last one getting an
373     rss file.)
374   * Added a plugin system.
375   * Added a pagecount plugin, enabled by default.
376   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
377   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
378     backlinks when the backlinks hadn't really changed.
379   * Moved inline page support, rss generation etc into the inline plugin,
380     enabled by default.
381   * Added brokenlinks plugin, not enabled by default, but rather handy.
382   * Fix several broken links in the doc wiki.
383   * Smarter behavior when creating a page and a page of the same name (but
384     different location) already exists.
385   * Add an orphans plugin for finding pages that nothing links to.
386   * Removed backlinks page, which it turns out nothing used.
387   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
388     it, this will allow for adding a unit test suite.
389   * Add unit tests for several core functions, including globlist_match,
390     dirname, basename, bestlink, linkify, pagetitle, titlepage.
391   * Smart globlist merging.
392   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
393     to pave the way for adding other RCS support. This also changes the
394     setup files, where before they had svn => 1 or svn => 0, now they have
395     rcs => "svn" or rcs => "".
396   * Add a debian/NEWS file with upgrade notes.
397   * Load whatever rcs module is specified, so new ones can be just dropped in
398     as plugins and work. (Well, in theory.)
399   * Add some basic docs about writing RCS modules.
400   * Broke search capability out into a plugin, removed the --hyperestraier
401     switch.
402   * Added smiley plugin, nicely controlled and documented by the smileys page.
403   * Copied in some smileys from Moin Moin.
404   * Allow links of the form [[some page|page]], with whitespace in the link
405     text.
406   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
407     and --disable-plugin htmlscrubber.
408   * Allow discussion links on pages to be turned off with --no-discussion.
409   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
410   * Add some new config items to the estseek.conf template, which are needed
411     by hyperestraier 1.2.3.
412
413  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
414
415 ikiwiki (1.0) unstable; urgency=low
416
417   * First official release.
418
419  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400