* Remove CDPATH and other env vars perl taint checking doesn't like.
[ikiwiki] / debian / changelog
1 ikiwiki (1.15) UNRELEASED; urgency=low
2
3   * Remove CDPATH and other env vars perl taint checking doesn't like.
4     Closes: #381279
5
6  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 12:12:53 -0400
7
8 ikiwiki (1.14) unstable; urgency=low
9
10   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
11     by 10% or so.
12   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
13   * Added many unit tests for pagespec_match.
14
15  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
16
17 ikiwiki (1.13) unstable; urgency=low
18
19   * ikiwiki can now download and aggregate feeds with its new aggregate
20     plugin, so it's possible to implement a Planet using ikiwiki!
21   * Add a run_hooks function for the common task of running all hooks of a
22     given type.
23   * Add a savestate hook.
24   * Don't put blog post forms on pages if there's no cgiurl set.
25   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
26     --wrappers to do that.
27   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
28     to update pages that haven't changed on disk.
29   * Change meta tags to use html entity-escaped text for values, so that
30     quotes and such can be represented in title tags.
31   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
32     for the above.
33   * Make --rebuild also cause --aggregate to re-download and write aggregated
34     pages.
35   * Avoid outputting duplicate meta info.
36   * Include title metadata on aggregated posts for capitalised and un-munged
37     titles.
38   * Title metadata of inlined pages now shows up in blogs and rss feeds.
39   * Fix issue with unicode filenames and updating the hyper estradier search
40     index. (Aka Please Please Please, let that be the last one.)
41   * Patch from Roland Mas to support an rss=no parameter to inline directives.
42     Closes: #380743
43   * Renamed GlobLists to PageSpecs.
44   * PageSpecs can now include nested parens, "and", and "or". This remains
45     backwards compatible to the old GlobList format. It's implemented by
46     treating the GlobList as a very limited microlanguage that is transformed
47     to perl code that does the matching.
48   * The old GlobList format is deprecated, and I encourage users to switch to
49     using the new PageSpec format. Compatability with the old format will be
50     removed at some point, possibly by 2.0.
51   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
52   * Add support for creation_month and creation_year to PageSpec.
53     Closes: #380680
54   * Changes to index file encoding.
55
56  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
57
58 ikiwiki (1.12) unstable; urgency=low
59
60   "Viva l'Italia!"
61   * New pagestats plugin from Enrico, which can generate a table counting
62     the backlinks for each page, or a del.icio.us style cloud.
63   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
64     the wikiformat plugin works. Thanks, Emanuele Aina.
65   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
66     display, running them through pagetitle. This removes ugly underscores and
67     other gunk from the display, much nicer. You may want to rebuild your wiki
68     when upgrading to get the cleanup globally.
69   * Polygen plugin from Enrico.
70   * htmltidy plugin from Faidon.
71   * Locale patch from Faidon:
72     - Adds a locale setting to setup files.
73     - Proper local time, if the locale configuration option is used.
74     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
75       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
76       impossible.
77   * Add getopt hook type, this allows plugins to add new command-line options.
78   * Add --tagbase option to tag plugin.
79   * Add exclude option in setup files, works same as --exclude.
80   * Put categories in rss feeds for tagged items.
81   * Allow preprocessor directives to be expanded in inlined blog pages.
82     However, to avoid inlining loops etc, don't expand inline directives in
83     inlined pages.
84   * fortune plugin (trivial)
85   * Tag plugins according to type.
86
87  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
88
89 ikiwiki (1.11) unstable; urgency=low
90
91   * Patch from Enrico that
92     - Adds a tag plugin that allows more easily tagging pages.
93       The meta plugin can also still be used for that, but the tag plugin
94       also lists a page's tags at the bottom of the page.
95     - Allows preprocessor directives to have parameters with no specified
96       value.
97     - Fixes preprocessor directive parameter parsing so that
98       foo=bar baz now means "foo=bar" and a "baz" with no value.
99   * Run pagetemplate hooks when inlining pages so that inlined pages also
100     list their tags.
101   * Make all plugins with pagetemplate hooks check that variables exist
102     on the template before setting them, for robustness.
103   * Switch pagetemplate hooks to using named parameters.
104   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
105     This will be the page that a source page will be part of, which is
106     different than the source page for inlined pages.
107   * Audited all plugins to endure they pass (page, destpage) to htmllink
108     appropriatly. This means inlining of various plugins will not work
109     properly, with correct links generated.
110
111  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
112
113 ikiwiki (1.10) unstable; urgency=low
114
115   * Run page through any relevant filters when generating a page preview.
116   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
117     default throughout the wiki, not only on wikitext pages. Decided to call
118     this a feature, and split the camelcase support out into a separate plugin
119     that is independant of wikitext.
120   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
121
122  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
123
124 ikiwiki (1.9) unstable; urgency=low
125
126   * Improve display of parentlinks and page title of toplevel index page.
127   * Patch from Faidon to use svn --limit when possible for recentchanges,
128     speeds up recentchanges a lot for wikis with more history.
129   * Patch from Recai to fix utf8 issues in git backend.
130   * Add wikitext markup plugin, which supports ".wiki" pages written in the
131     original wiki syntax, CamelCase links and all.
132   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
133     support, to edit pages etc without a web server.
134   * Display CGI processing errors if present.
135   * Fix from Faidon for a XML parser issue that breaks utf-8 for
136     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
137     area, and also way slow.
138   * Match 'web commit from' in SVN and git, these are web commits too.
139     (Faidon)
140   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
141     readable and avoid future mistakes. The patch seems to work and for the
142     first time I have a UTF-8 username ;-) (Faidon)
143   * Use form->field consistently, not form->param.
144   * Patch from Recai to allow selection of page type when creating a new page.
145     Default page type is inherited from the link clicked on to create the new
146     page.
147
148  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
149
150 ikiwiki (1.8) unstable; urgency=low
151
152   * Fix orphans plugin to not count a link to a nonexistant page as a reason
153     for a page not being an orphan.
154   * Support pinging services such as Technorati using XML-RPC to notify them
155     about changes to rss feeds.
156   * Parse svn log as xml for improved utf8 and security. Note that this makes
157     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
158   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
159     flagged string even if the locale causes it to generate utf8 output,
160     so make sure to let perl know it should be handled as utf8. Also,
161     the optimised version used for standard time formats won't work if the
162     user has changed locale, so drop it. Thanks, Faidon Liambotis.
163   * Fix re-encoding of the comments field to utf8 if a commit fails
164     due to a conflict. Thanks, Faidon Liambotis.
165   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
166     Liambotis.
167   * Add insane double encode/decode to utf8 around call to markdown.
168     This works around a truely strange bug, which is apparently a bug in
169     perl, #376329. Also added a test case for it.
170   * Improve layout of edit page so formatting help link is always visible w/o
171     getting in the way of the preview.
172   * Centralised all calls to HTML::Template and force all the templates
173     to be read as utf8.
174   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
175   * Introduce add_plugins and disable_plugins config options in setup files.
176     This allows adding or removing plugins w/o overriding the whole list of
177     default plugins, which makes it easier to upgrade when new default plugins
178     are added.
179   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
180     default (of course!). Based on a patch by Faidon Liambotis.
181   * Add a html plugin, which can be used to write wikis in raw html,
182     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
183     defaults to not processing .html files, since w/o this plugin they would
184     be copied unsanitised. With this plugin, it will process and html
185     sanitise them, like any other page type.
186   * Rebuilding wrappers is necessary on upgrade to this version.
187   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
188     will be automatically done on all upgrades.
189   * Don't send pings if the wiki is being rebuilt.
190   * Work around very innefficient behavior in File::Spec::abs2rel. Result
191     is a savings of 2 pointless fork/execs per link calculation, which
192     results in ~25% speedup of ikiwiki building its own doc wiki, and
193     about 35% speedup displaying RecentChanges!
194   * Make RecentChanges use a table and some CSS, should be much more readable.
195     No code changes involved.
196   * Encode & in diffurl in examples, to conform to pedantic rules.
197   * Speed up RecentChanges by another 40% or so with some memoization.
198   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
199     in time to build the doc wiki.
200
201  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
202
203 ikiwiki (1.7) unstable; urgency=low
204
205   * Updated logo from Recai with some kerning and alingment tuning.
206   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
207     changed some output.
208   * Copyright update.
209
210  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
211
212 ikiwiki (1.6) unstable; urgency=low
213
214   * YA utf-8 patch from Recai, this time to fix previewing a page so that
215     the text in the input box is re-encoded back to utf-8.
216   * -CSD does not affect modules, so readfile() was not using the utf-8 input
217     layer, which led to lots of problems; make it force read files as utf-8.
218     Closes: #373203
219   * Note that as a consequence, this version of ikiwiki will actually try to
220     parse utf8 in source files for the first time, which may expose broken
221     utf8 in wiki sources that was hidden before. Most common will be
222     perl warnings like "utf8 "\xE9" does not map to Unicode"
223   * writefile() likewise needs to use the utf8 output layer.
224   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
225     there.
226   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
227     given the readfile fix.
228   * Add utf-8 testcases for readfile and htmlize.
229   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
230     safe.
231   * More utf-8 fixes from Recai, partly to things I broke above:
232     - The serious problem is that writefile() saves the content in undecoded
233       format in CGI, hence all (non-ascii) chars are corrupted permanently.
234     - Comment field in edit page is not decoded and all the non-ascii chars in
235       this field are corrupted as the result.  We should decode it as we do it
236       for the content.
237     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
238       character in print.
239   * New SVG logo from Recai.
240
241  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
242
243 ikiwiki (1.5) unstable; urgency=low
244
245   * Add --timeformat config option to allow changing how dates are displayed.
246     Note that as a side effect, dates will now be displayed using the local
247     timezone, not as GMT.
248   * More security review.
249   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
250     for some handy stuff like:
251     - Using links as a kind of tag; creating blog pages that list all pages
252       containing a given tag/link or not containing some other tag.
253     - Subscribing to mail notifications whenever a change is made to a page
254       that is a backlink of page foo. Ie, "Please notify me of changes in all
255       pages that link to my home page in the wiki"
256     - Locking any pages that are linked to from a particular page, so that
257       lists of locks can be exposed in the wiki.
258   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
259     when a todo item is done, instead of the previous moving it to a different
260     subdir.
261   * Allow pagetemplate plugins to override *anything* in the template.
262   * Add a meta plugin, which allows specifying various metadata about pages,
263     like license and author. It also allows for inserting html link and meta
264     tags into html, overriding the title, and adding hidden WikiLinks, which
265     can be useful when using link-based globbing for page categorisation.
266   * Remove preprocessor directives from inlined pages.
267   * Allow simple preprocessor directive values to be specified w/o quotes.
268   * Add support for using git instead of subversion as the RCS backend,
269     tremendous thanks to Recai Oktaş for this.
270   * Doc updates for git.
271   * Fix absolute url munging in rss generation to support https, ftp, etc urls
272     not just http urls.
273   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
274     utf-8 for edit and other fields, and for recentchanges. There may still
275     be utf-8 issues with the preferences page though.
276
277  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
278
279 ikiwiki (1.4) unstable; urgency=low
280
281   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
282     very strange way of enabling proper XHTML <br /> type tags. Output html
283     should be always valid again now.
284   * The page name and parent links has switched from using a <h1> to a styled
285     <span>, so pages can use <h1> internally instead of needing to use <h2>.
286   * Updated all of ikiwiki's own wiki pages for that.
287   * Add pagetemplate hook, which can be used by plugins that want to mess
288     around with adding new stuff to the page template.
289   * Remove headercontent; the search plugin now adds the search box to the
290     header by registering a pagetemplate hook, and other plugins should do
291     similarly.
292   * Rebuilding on upgrade to this version is recommended.
293   * Add a html validity check to the test suite, using the wdg-html-validator,
294     if available.
295   * Make the html valid when there is nothing in the actions list.
296   * Reordered some function call parameters for consistency.
297   * Enable full utf-8 support for page input and output.
298   * Add a workaround for markdown, which does not work well with utf-8
299     strings.
300   * --getctime had bitrotted (well I only ever used it the once so far..),
301     fix and make it a bit more flexible
302   * rcs_getctime is changed, now rather than needing to loop over all pages,
303     it should just use the rcs to get the ctime of the passed file.
304   * When inlining a page in another one, links from the inlined page are now
305     expanded the same as they are when rendering the inlined page as a
306     standalone page. So rather than being expanded from the POV of the
307     inlining page, they are expanded from the POV of the inlined page.
308
309     For example, a link from blog/foo to "bar" will now link to blog/bar
310     if it exists. Previously this needed to be a link explicitly to
311     "blog/bar"; such links will also continue to work.
312
313     (This was slightly complex to do as the link still has to be constructed
314     relative to the inlining page.)
315   * Make page edit textarea resize to fit browser window.
316   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
317     do not need a full rebuild, in order to update any basewiki pages.
318
319  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
320
321 ikiwiki (1.3) unstable; urgency=low
322
323   * Fix the preinst introduced in the last version. Closes: #367458
324
325  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
326
327 ikiwiki (1.2) unstable; urgency=low
328
329   * Remove dups from the brokenlinks list.
330   * Add libc6-dev to dependencies, needed to build wrappers.
331   * Install wikilist in correct location. Closes: #367371
332
333  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
334
335 ikiwiki (1.1) unstable; urgency=low
336
337   * Rename inlinepage to depends, so that it can be used to refer to more
338     dependency relationships than just inlining. This will require a rebuild
339     on upgrade to this version.
340   * Move the rss link, put it in the blogpost form if there is one and at the
341     top if not. This is both nicer because easier to find, and it cleans up
342     the code which had used inlinepage as a flag for adding the link later.
343   * Allow the depends GlobList to be built up from multiple sources (such as
344     plugins) during a page render.
345   * Which means that more than one blog is now supported to appear on a
346     single page. (With some limitations, like only the last one getting an
347     rss file.)
348   * Added a plugin system.
349   * Added a pagecount plugin, enabled by default.
350   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
351   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
352     backlinks when the backlinks hadn't really changed.
353   * Moved inline page support, rss generation etc into the inline plugin,
354     enabled by default.
355   * Added brokenlinks plugin, not enabled by default, but rather handy.
356   * Fix several broken links in the doc wiki.
357   * Smarter behavior when creating a page and a page of the same name (but
358     different location) already exists.
359   * Add an orphans plugin for finding pages that nothing links to.
360   * Removed backlinks page, which it turns out nothing used.
361   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
362     it, this will allow for adding a unit test suite.
363   * Add unit tests for several core functions, including globlist_match,
364     dirname, basename, bestlink, linkify, pagetitle, titlepage.
365   * Smart globlist merging.
366   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
367     to pave the way for adding other RCS support. This also changes the
368     setup files, where before they had svn => 1 or svn => 0, now they have
369     rcs => "svn" or rcs => "".
370   * Add a debian/NEWS file with upgrade notes.
371   * Load whatever rcs module is specified, so new ones can be just dropped in
372     as plugins and work. (Well, in theory.)
373   * Add some basic docs about writing RCS modules.
374   * Broke search capability out into a plugin, removed the --hyperestraier
375     switch.
376   * Added smiley plugin, nicely controlled and documented by the smileys page.
377   * Copied in some smileys from Moin Moin.
378   * Allow links of the form [[some page|page]], with whitespace in the link
379     text.
380   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
381     and --disable-plugin htmlscrubber.
382   * Allow discussion links on pages to be turned off with --no-discussion.
383   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
384   * Add some new config items to the estseek.conf template, which are needed
385     by hyperestraier 1.2.3.
386
387  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
388
389 ikiwiki (1.0) unstable; urgency=low
390
391   * First official release.
392
393  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400