* Support a w3mmode, which lets w3m run ikiwiki using its local CGI
[ikiwiki] / debian / changelog
1 ikiwiki (1.9) UNRELEASED; urgency=low
2
3   * Improve display of parentlinks and page title of toplevel index page.
4   * Patch from Faidon to use svn --limit when possible for recentchanges,
5     speeds up recentchanges a lot for wikis with more history.
6   * Patch from Recai to fix utf8 issues in git backend.
7   * Add wikitext markup plugin, which supports ".wiki" pages written in the
8     original wiki syntax, CamelCase links and all.
9   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
10     support, to edit pages etc without a web server.
11
12  -- Joey Hess <joeyh@debian.org>  Fri,  7 Jul 2006 14:11:50 -0400
13
14 ikiwiki (1.8) unstable; urgency=low
15
16   * Fix orphans plugin to not count a link to a nonexistant page as a reason
17     for a page not being an orphan.
18   * Support pinging services such as Technorati using XML-RPC to notify them
19     about changes to rss feeds.
20   * Parse svn log as xml for improved utf8 and security. Note that this makes
21     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
22   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
23     flagged string even if the locale causes it to generate utf8 output,
24     so make sure to let perl know it should be handled as utf8. Also,
25     the optimised version used for standard time formats won't work if the
26     user has changed locale, so drop it. Thanks, Faidon Liambotis.
27   * Fix re-encoding of the comments field to utf8 if a commit fails
28     due to a conflict. Thanks, Faidon Liambotis.
29   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
30     Liambotis.
31   * Add insane double encode/decode to utf8 around call to markdown.
32     This works around a truely strange bug, which is apparently a bug in
33     perl, #376329. Also added a test case for it.
34   * Improve layout of edit page so formatting help link is always visible w/o
35     getting in the way of the preview.
36   * Centralised all calls to HTML::Template and force all the templates
37     to be read as utf8.
38   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
39   * Introduce add_plugins and disable_plugins config options in setup files.
40     This allows adding or removing plugins w/o overriding the whole list of
41     default plugins, which makes it easier to upgrade when new default plugins
42     are added.
43   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
44     default (of course!). Based on a patch by Faidon Liambotis.
45   * Add a html plugin, which can be used to write wikis in raw html,
46     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
47     defaults to not processing .html files, since w/o this plugin they would
48     be copied unsanitised. With this plugin, it will process and html
49     sanitise them, like any other page type.
50   * Rebuilding wrappers is necessary on upgrade to this version.
51   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
52     will be automatically done on all upgrades.
53   * Don't send pings if the wiki is being rebuilt.
54   * Work around very innefficient behavior in File::Spec::abs2rel. Result
55     is a savings of 2 pointless fork/execs per link calculation, which
56     results in ~25% speedup of ikiwiki building its own doc wiki, and
57     about 35% speedup displaying RecentChanges!
58   * Make RecentChanges use a table and some CSS, should be much more readable.
59     No code changes involved.
60   * Encode & in diffurl in examples, to conform to pedantic rules.
61   * Speed up RecentChanges by another 40% or so with some memoization.
62   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
63     in time to build the doc wiki.
64
65  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
66
67 ikiwiki (1.7) unstable; urgency=low
68
69   * Updated logo from Recai with some kerning and alingment tuning.
70   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
71     changed some output.
72   * Copyright update.
73
74  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
75
76 ikiwiki (1.6) unstable; urgency=low
77
78   * YA utf-8 patch from Recai, this time to fix previewing a page so that
79     the text in the input box is re-encoded back to utf-8.
80   * -CSD does not affect modules, so readfile() was not using the utf-8 input
81     layer, which led to lots of problems; make it force read files as utf-8.
82     Closes: #373203
83   * Note that as a consequence, this version of ikiwiki will actually try to
84     parse utf8 in source files for the first time, which may expose broken
85     utf8 in wiki sources that was hidden before. Most common will be
86     perl warnings like "utf8 "\xE9" does not map to Unicode"
87   * writefile() likewise needs to use the utf8 output layer.
88   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
89     there.
90   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
91     given the readfile fix.
92   * Add utf-8 testcases for readfile and htmlize.
93   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
94     safe.
95   * More utf-8 fixes from Recai, partly to things I broke above:
96     - The serious problem is that writefile() saves the content in undecoded
97       format in CGI, hence all (non-ascii) chars are corrupted permanently.
98     - Comment field in edit page is not decoded and all the non-ascii chars in
99       this field are corrupted as the result.  We should decode it as we do it
100       for the content.
101     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
102       character in print.
103   * New SVG logo from Recai.
104
105  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
106
107 ikiwiki (1.5) unstable; urgency=low
108
109   * Add --timeformat config option to allow changing how dates are displayed.
110     Note that as a side effect, dates will now be displayed using the local
111     timezone, not as GMT.
112   * More security review.
113   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
114     for some handy stuff like:
115     - Using links as a kind of tag; creating blog pages that list all pages
116       containing a given tag/link or not containing some other tag.
117     - Subscribing to mail notifications whenever a change is made to a page
118       that is a backlink of page foo. Ie, "Please notify me of changes in all
119       pages that link to my home page in the wiki"
120     - Locking any pages that are linked to from a particular page, so that
121       lists of locks can be exposed in the wiki.
122   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
123     when a todo item is done, instead of the previous moving it to a different
124     subdir.
125   * Allow pagetemplate plugins to override *anything* in the template.
126   * Add a meta plugin, which allows specifying various metadata about pages,
127     like license and author. It also allows for inserting html link and meta
128     tags into html, overriding the title, and adding hidden WikiLinks, which
129     can be useful when using link-based globbing for page categorisation.
130   * Remove preprocessor directives from inlined pages.
131   * Allow simple preprocessor directive values to be specified w/o quotes.
132   * Add support for using git instead of subversion as the RCS backend,
133     tremendous thanks to Recai Oktaş for this.
134   * Doc updates for git.
135   * Fix absolute url munging in rss generation to support https, ftp, etc urls
136     not just http urls.
137   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
138     utf-8 for edit and other fields, and for recentchanges. There may still
139     be utf-8 issues with the preferences page though.
140
141  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
142
143 ikiwiki (1.4) unstable; urgency=low
144
145   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
146     very strange way of enabling proper XHTML <br /> type tags. Output html
147     should be always valid again now.
148   * The page name and parent links has switched from using a <h1> to a styled
149     <span>, so pages can use <h1> internally instead of needing to use <h2>.
150   * Updated all of ikiwiki's own wiki pages for that.
151   * Add pagetemplate hook, which can be used by plugins that want to mess
152     around with adding new stuff to the page template.
153   * Remove headercontent; the search plugin now adds the search box to the
154     header by registering a pagetemplate hook, and other plugins should do
155     similarly.
156   * Rebuilding on upgrade to this version is recommended.
157   * Add a html validity check to the test suite, using the wdg-html-validator,
158     if available.
159   * Make the html valid when there is nothing in the actions list.
160   * Reordered some function call parameters for consistency.
161   * Enable full utf-8 support for page input and output.
162   * Add a workaround for markdown, which does not work well with utf-8
163     strings.
164   * --getctime had bitrotted (well I only ever used it the once so far..),
165     fix and make it a bit more flexible
166   * rcs_getctime is changed, now rather than needing to loop over all pages,
167     it should just use the rcs to get the ctime of the passed file.
168   * When inlining a page in another one, links from the inlined page are now
169     expanded the same as they are when rendering the inlined page as a
170     standalone page. So rather than being expanded from the POV of the
171     inlining page, they are expanded from the POV of the inlined page.
172
173     For example, a link from blog/foo to "bar" will now link to blog/bar
174     if it exists. Previously this needed to be a link explicitly to
175     "blog/bar"; such links will also continue to work.
176
177     (This was slightly complex to do as the link still has to be constructed
178     relative to the inlining page.)
179   * Make page edit textarea resize to fit browser window.
180   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
181     do not need a full rebuild, in order to update any basewiki pages.
182
183  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
184
185 ikiwiki (1.3) unstable; urgency=low
186
187   * Fix the preinst introduced in the last version. Closes: #367458
188
189  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
190
191 ikiwiki (1.2) unstable; urgency=low
192
193   * Remove dups from the brokenlinks list.
194   * Add libc6-dev to dependencies, needed to build wrappers.
195   * Install wikilist in correct location. Closes: #367371
196
197  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
198
199 ikiwiki (1.1) unstable; urgency=low
200
201   * Rename inlinepage to depends, so that it can be used to refer to more
202     dependency relationships than just inlining. This will require a rebuild
203     on upgrade to this version.
204   * Move the rss link, put it in the blogpost form if there is one and at the
205     top if not. This is both nicer because easier to find, and it cleans up
206     the code which had used inlinepage as a flag for adding the link later.
207   * Allow the depends GlobList to be built up from multiple sources (such as
208     plugins) during a page render.
209   * Which means that more than one blog is now supported to appear on a
210     single page. (With some limitations, like only the last one getting an
211     rss file.)
212   * Added a plugin system.
213   * Added a pagecount plugin, enabled by default.
214   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
215   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
216     backlinks when the backlinks hadn't really changed.
217   * Moved inline page support, rss generation etc into the inline plugin,
218     enabled by default.
219   * Added brokenlinks plugin, not enabled by default, but rather handy.
220   * Fix several broken links in the doc wiki.
221   * Smarter behavior when creating a page and a page of the same name (but
222     different location) already exists.
223   * Add an orphans plugin for finding pages that nothing links to.
224   * Removed backlinks page, which it turns out nothing used.
225   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
226     it, this will allow for adding a unit test suite.
227   * Add unit tests for several core functions, including globlist_match,
228     dirname, basename, bestlink, linkify, pagetitle, titlepage.
229   * Smart globlist merging.
230   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
231     to pave the way for adding other RCS support. This also changes the
232     setup files, where before they had svn => 1 or svn => 0, now they have
233     rcs => "svn" or rcs => "".
234   * Add a debian/NEWS file with upgrade notes.
235   * Load whatever rcs module is specified, so new ones can be just dropped in
236     as plugins and work. (Well, in theory.)
237   * Add some basic docs about writing RCS modules.
238   * Broke search capability out into a plugin, removed the --hyperestraier
239     switch.
240   * Added smiley plugin, nicely controlled and documented by the smileys page.
241   * Copied in some smileys from Moin Moin.
242   * Allow links of the form [[some page|page]], with whitespace in the link
243     text.
244   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
245     and --disable-plugin htmlscrubber.
246   * Allow discussion links on pages to be turned off with --no-discussion.
247   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
248   * Add some new config items to the estseek.conf template, which are needed
249     by hyperestraier 1.2.3.
250
251  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
252
253 ikiwiki (1.0) unstable; urgency=low
254
255   * First official release.
256
257  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400