* Patch from Roland Mas to support an rss=no parameter to inline directives.
[ikiwiki] / debian / changelog
1 ikiwiki (1.13) UNRELEASED; urgency=low
2
3   * ikiwiki can now download and aggregate feeds with its new aggregate
4     plugin, so it's possible to implement a Planet using ikiwiki!
5   * Add a run_hooks function for the common task of running all hooks of a
6     given type.
7   * Add a savestate hook.
8   * Don't put blog post forms on pages if there's no cgiurl set.
9   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
10     --wrappers to do that.
11   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
12     to update pages that haven't changed on disk.
13   * Change meta tags to use html entity-escaped text for values, so that
14     quotes and such can be represented in title tags.
15   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
16     for the above.
17   * Make --rebuild also cause --aggregate to re-download and write aggregated
18     pages.
19   * Avoid outputting duplicate meta info.
20   * Include title metadata on aggregated posts for capitalised and un-munged
21     titles.
22   * Title metadata of inlined pages now shows up in blogs and rss feeds.
23   * Fix issue with unicode filenames and updating the hyper estradier search
24     index. (Aka Please Please Please, let that be the last one.)
25   * Patch from Roland Mas to support an rss=no parameter to inline directives.
26     Closes: #380743
27
28  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 16:00:58 -0400
29
30 ikiwiki (1.12) unstable; urgency=low
31
32   "Viva l'Italia!"
33   * New pagestats plugin from Enrico, which can generate a table counting
34     the backlinks for each page, or a del.icio.us style cloud.
35   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
36     the wikiformat plugin works. Thanks, Emanuele Aina.
37   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
38     display, running them through pagetitle. This removes ugly underscores and
39     other gunk from the display, much nicer. You may want to rebuild your wiki
40     when upgrading to get the cleanup globally.
41   * Polygen plugin from Enrico.
42   * htmltidy plugin from Faidon.
43   * Locale patch from Faidon:
44     - Adds a locale setting to setup files.
45     - Proper local time, if the locale configuration option is used.
46     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
47       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
48       impossible.
49   * Add getopt hook type, this allows plugins to add new command-line options.
50   * Add --tagbase option to tag plugin.
51   * Add exclude option in setup files, works same as --exclude.
52   * Put categories in rss feeds for tagged items.
53   * Allow preprocessor directives to be expanded in inlined blog pages.
54     However, to avoid inlining loops etc, don't expand inline directives in
55     inlined pages.
56   * fortune plugin (trivial)
57   * Tag plugins according to type.
58
59  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
60
61 ikiwiki (1.11) unstable; urgency=low
62
63   * Patch from Enrico that
64     - Adds a tag plugin that allows more easily tagging pages.
65       The meta plugin can also still be used for that, but the tag plugin
66       also lists a page's tags at the bottom of the page.
67     - Allows preprocessor directives to have parameters with no specified
68       value.
69     - Fixes preprocessor directive parameter parsing so that
70       foo=bar baz now means "foo=bar" and a "baz" with no value.
71   * Run pagetemplate hooks when inlining pages so that inlined pages also
72     list their tags.
73   * Make all plugins with pagetemplate hooks check that variables exist
74     on the template before setting them, for robustness.
75   * Switch pagetemplate hooks to using named parameters.
76   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
77     This will be the page that a source page will be part of, which is
78     different than the source page for inlined pages.
79   * Audited all plugins to endure they pass (page, destpage) to htmllink
80     appropriatly. This means inlining of various plugins will not work
81     properly, with correct links generated.
82
83  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
84
85 ikiwiki (1.10) unstable; urgency=low
86
87   * Run page through any relevant filters when generating a page preview.
88   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
89     default throughout the wiki, not only on wikitext pages. Decided to call
90     this a feature, and split the camelcase support out into a separate plugin
91     that is independant of wikitext.
92   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
93
94  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
95
96 ikiwiki (1.9) unstable; urgency=low
97
98   * Improve display of parentlinks and page title of toplevel index page.
99   * Patch from Faidon to use svn --limit when possible for recentchanges,
100     speeds up recentchanges a lot for wikis with more history.
101   * Patch from Recai to fix utf8 issues in git backend.
102   * Add wikitext markup plugin, which supports ".wiki" pages written in the
103     original wiki syntax, CamelCase links and all.
104   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
105     support, to edit pages etc without a web server.
106   * Display CGI processing errors if present.
107   * Fix from Faidon for a XML parser issue that breaks utf-8 for
108     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
109     area, and also way slow.
110   * Match 'web commit from' in SVN and git, these are web commits too.
111     (Faidon)
112   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
113     readable and avoid future mistakes. The patch seems to work and for the
114     first time I have a UTF-8 username ;-) (Faidon)
115   * Use form->field consistently, not form->param.
116   * Patch from Recai to allow selection of page type when creating a new page.
117     Default page type is inherited from the link clicked on to create the new
118     page.
119
120  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
121
122 ikiwiki (1.8) unstable; urgency=low
123
124   * Fix orphans plugin to not count a link to a nonexistant page as a reason
125     for a page not being an orphan.
126   * Support pinging services such as Technorati using XML-RPC to notify them
127     about changes to rss feeds.
128   * Parse svn log as xml for improved utf8 and security. Note that this makes
129     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
130   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
131     flagged string even if the locale causes it to generate utf8 output,
132     so make sure to let perl know it should be handled as utf8. Also,
133     the optimised version used for standard time formats won't work if the
134     user has changed locale, so drop it. Thanks, Faidon Liambotis.
135   * Fix re-encoding of the comments field to utf8 if a commit fails
136     due to a conflict. Thanks, Faidon Liambotis.
137   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
138     Liambotis.
139   * Add insane double encode/decode to utf8 around call to markdown.
140     This works around a truely strange bug, which is apparently a bug in
141     perl, #376329. Also added a test case for it.
142   * Improve layout of edit page so formatting help link is always visible w/o
143     getting in the way of the preview.
144   * Centralised all calls to HTML::Template and force all the templates
145     to be read as utf8.
146   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
147   * Introduce add_plugins and disable_plugins config options in setup files.
148     This allows adding or removing plugins w/o overriding the whole list of
149     default plugins, which makes it easier to upgrade when new default plugins
150     are added.
151   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
152     default (of course!). Based on a patch by Faidon Liambotis.
153   * Add a html plugin, which can be used to write wikis in raw html,
154     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
155     defaults to not processing .html files, since w/o this plugin they would
156     be copied unsanitised. With this plugin, it will process and html
157     sanitise them, like any other page type.
158   * Rebuilding wrappers is necessary on upgrade to this version.
159   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
160     will be automatically done on all upgrades.
161   * Don't send pings if the wiki is being rebuilt.
162   * Work around very innefficient behavior in File::Spec::abs2rel. Result
163     is a savings of 2 pointless fork/execs per link calculation, which
164     results in ~25% speedup of ikiwiki building its own doc wiki, and
165     about 35% speedup displaying RecentChanges!
166   * Make RecentChanges use a table and some CSS, should be much more readable.
167     No code changes involved.
168   * Encode & in diffurl in examples, to conform to pedantic rules.
169   * Speed up RecentChanges by another 40% or so with some memoization.
170   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
171     in time to build the doc wiki.
172
173  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
174
175 ikiwiki (1.7) unstable; urgency=low
176
177   * Updated logo from Recai with some kerning and alingment tuning.
178   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
179     changed some output.
180   * Copyright update.
181
182  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
183
184 ikiwiki (1.6) unstable; urgency=low
185
186   * YA utf-8 patch from Recai, this time to fix previewing a page so that
187     the text in the input box is re-encoded back to utf-8.
188   * -CSD does not affect modules, so readfile() was not using the utf-8 input
189     layer, which led to lots of problems; make it force read files as utf-8.
190     Closes: #373203
191   * Note that as a consequence, this version of ikiwiki will actually try to
192     parse utf8 in source files for the first time, which may expose broken
193     utf8 in wiki sources that was hidden before. Most common will be
194     perl warnings like "utf8 "\xE9" does not map to Unicode"
195   * writefile() likewise needs to use the utf8 output layer.
196   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
197     there.
198   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
199     given the readfile fix.
200   * Add utf-8 testcases for readfile and htmlize.
201   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
202     safe.
203   * More utf-8 fixes from Recai, partly to things I broke above:
204     - The serious problem is that writefile() saves the content in undecoded
205       format in CGI, hence all (non-ascii) chars are corrupted permanently.
206     - Comment field in edit page is not decoded and all the non-ascii chars in
207       this field are corrupted as the result.  We should decode it as we do it
208       for the content.
209     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
210       character in print.
211   * New SVG logo from Recai.
212
213  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
214
215 ikiwiki (1.5) unstable; urgency=low
216
217   * Add --timeformat config option to allow changing how dates are displayed.
218     Note that as a side effect, dates will now be displayed using the local
219     timezone, not as GMT.
220   * More security review.
221   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
222     for some handy stuff like:
223     - Using links as a kind of tag; creating blog pages that list all pages
224       containing a given tag/link or not containing some other tag.
225     - Subscribing to mail notifications whenever a change is made to a page
226       that is a backlink of page foo. Ie, "Please notify me of changes in all
227       pages that link to my home page in the wiki"
228     - Locking any pages that are linked to from a particular page, so that
229       lists of locks can be exposed in the wiki.
230   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
231     when a todo item is done, instead of the previous moving it to a different
232     subdir.
233   * Allow pagetemplate plugins to override *anything* in the template.
234   * Add a meta plugin, which allows specifying various metadata about pages,
235     like license and author. It also allows for inserting html link and meta
236     tags into html, overriding the title, and adding hidden WikiLinks, which
237     can be useful when using link-based globbing for page categorisation.
238   * Remove preprocessor directives from inlined pages.
239   * Allow simple preprocessor directive values to be specified w/o quotes.
240   * Add support for using git instead of subversion as the RCS backend,
241     tremendous thanks to Recai Oktaş for this.
242   * Doc updates for git.
243   * Fix absolute url munging in rss generation to support https, ftp, etc urls
244     not just http urls.
245   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
246     utf-8 for edit and other fields, and for recentchanges. There may still
247     be utf-8 issues with the preferences page though.
248
249  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
250
251 ikiwiki (1.4) unstable; urgency=low
252
253   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
254     very strange way of enabling proper XHTML <br /> type tags. Output html
255     should be always valid again now.
256   * The page name and parent links has switched from using a <h1> to a styled
257     <span>, so pages can use <h1> internally instead of needing to use <h2>.
258   * Updated all of ikiwiki's own wiki pages for that.
259   * Add pagetemplate hook, which can be used by plugins that want to mess
260     around with adding new stuff to the page template.
261   * Remove headercontent; the search plugin now adds the search box to the
262     header by registering a pagetemplate hook, and other plugins should do
263     similarly.
264   * Rebuilding on upgrade to this version is recommended.
265   * Add a html validity check to the test suite, using the wdg-html-validator,
266     if available.
267   * Make the html valid when there is nothing in the actions list.
268   * Reordered some function call parameters for consistency.
269   * Enable full utf-8 support for page input and output.
270   * Add a workaround for markdown, which does not work well with utf-8
271     strings.
272   * --getctime had bitrotted (well I only ever used it the once so far..),
273     fix and make it a bit more flexible
274   * rcs_getctime is changed, now rather than needing to loop over all pages,
275     it should just use the rcs to get the ctime of the passed file.
276   * When inlining a page in another one, links from the inlined page are now
277     expanded the same as they are when rendering the inlined page as a
278     standalone page. So rather than being expanded from the POV of the
279     inlining page, they are expanded from the POV of the inlined page.
280
281     For example, a link from blog/foo to "bar" will now link to blog/bar
282     if it exists. Previously this needed to be a link explicitly to
283     "blog/bar"; such links will also continue to work.
284
285     (This was slightly complex to do as the link still has to be constructed
286     relative to the inlining page.)
287   * Make page edit textarea resize to fit browser window.
288   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
289     do not need a full rebuild, in order to update any basewiki pages.
290
291  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
292
293 ikiwiki (1.3) unstable; urgency=low
294
295   * Fix the preinst introduced in the last version. Closes: #367458
296
297  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
298
299 ikiwiki (1.2) unstable; urgency=low
300
301   * Remove dups from the brokenlinks list.
302   * Add libc6-dev to dependencies, needed to build wrappers.
303   * Install wikilist in correct location. Closes: #367371
304
305  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
306
307 ikiwiki (1.1) unstable; urgency=low
308
309   * Rename inlinepage to depends, so that it can be used to refer to more
310     dependency relationships than just inlining. This will require a rebuild
311     on upgrade to this version.
312   * Move the rss link, put it in the blogpost form if there is one and at the
313     top if not. This is both nicer because easier to find, and it cleans up
314     the code which had used inlinepage as a flag for adding the link later.
315   * Allow the depends GlobList to be built up from multiple sources (such as
316     plugins) during a page render.
317   * Which means that more than one blog is now supported to appear on a
318     single page. (With some limitations, like only the last one getting an
319     rss file.)
320   * Added a plugin system.
321   * Added a pagecount plugin, enabled by default.
322   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
323   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
324     backlinks when the backlinks hadn't really changed.
325   * Moved inline page support, rss generation etc into the inline plugin,
326     enabled by default.
327   * Added brokenlinks plugin, not enabled by default, but rather handy.
328   * Fix several broken links in the doc wiki.
329   * Smarter behavior when creating a page and a page of the same name (but
330     different location) already exists.
331   * Add an orphans plugin for finding pages that nothing links to.
332   * Removed backlinks page, which it turns out nothing used.
333   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
334     it, this will allow for adding a unit test suite.
335   * Add unit tests for several core functions, including globlist_match,
336     dirname, basename, bestlink, linkify, pagetitle, titlepage.
337   * Smart globlist merging.
338   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
339     to pave the way for adding other RCS support. This also changes the
340     setup files, where before they had svn => 1 or svn => 0, now they have
341     rcs => "svn" or rcs => "".
342   * Add a debian/NEWS file with upgrade notes.
343   * Load whatever rcs module is specified, so new ones can be just dropped in
344     as plugins and work. (Well, in theory.)
345   * Add some basic docs about writing RCS modules.
346   * Broke search capability out into a plugin, removed the --hyperestraier
347     switch.
348   * Added smiley plugin, nicely controlled and documented by the smileys page.
349   * Copied in some smileys from Moin Moin.
350   * Allow links of the form [[some page|page]], with whitespace in the link
351     text.
352   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
353     and --disable-plugin htmlscrubber.
354   * Allow discussion links on pages to be turned off with --no-discussion.
355   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
356   * Add some new config items to the estseek.conf template, which are needed
357     by hyperestraier 1.2.3.
358
359  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
360
361 ikiwiki (1.0) unstable; urgency=low
362
363   * First official release.
364
365  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400