* Support pages with utf8 filenames. Patch by Faidon Liambotis.
[ikiwiki] / debian / changelog
1 ikiwiki (1.8) UNRELEASED; urgency=low
2
3   * Fix orphans plugin to not count a link to a nonexistant page as a reason
4     for a page not being an orphan.
5   * Support pinging services such as Technorati using XML-RPC to notify them
6     about changes to rss feeds.
7   * Parse svn log as xml for improved utf8 and security. Note that this makes
8     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
9   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
10     flagged string even if the locale causes it to generate utf8 output,
11     so make sure to let perl know it should be handled as utf8. Also,
12     the optimised version used for standard time formats won't work if the
13     user has changed locale, so drop it. Thanks, Faidon Liambotis.
14   * Fix re-encoding of the comments field to utf8 if a commit fails
15     due to a conflict. Thanks, Faidon Liambotis.
16   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
17     Liambotis.
18   * Add insane double encode/decode to utf8 around call to markdown.
19     This works around a truely strange bug, which is apparently a bug in
20     perl, #376329. Also added a test case for it.
21   * Improve layout of edit page so formatting help link is always visible w/o
22     getting in the way of the preview.
23   * Centralised all calls to HTML::Template and force all the templates
24     to be read as utf8.
25   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
26
27  -- Joey Hess <joeyh@debian.org>  Mon,  3 Jul 2006 16:09:16 -0400
28
29 ikiwiki (1.7) unstable; urgency=low
30
31   * Updated logo from Recai with some kerning and alingment tuning.
32   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
33     changed some output.
34   * Copyright update.
35
36  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
37
38 ikiwiki (1.6) unstable; urgency=low
39
40   * YA utf-8 patch from Recai, this time to fix previewing a page so that
41     the text in the input box is re-encoded back to utf-8.
42   * -CSD does not affect modules, so readfile() was not using the utf-8 input
43     layer, which led to lots of problems; make it force read files as utf-8.
44     Closes: #373203
45   * Note that as a consequence, this version of ikiwiki will actually try to
46     parse utf8 in source files for the first time, which may expose broken
47     utf8 in wiki sources that was hidden before. Most common will be
48     perl warnings like "utf8 "\xE9" does not map to Unicode"
49   * writefile() likewise needs to use the utf8 output layer.
50   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
51     there.
52   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
53     given the readfile fix.
54   * Add utf-8 testcases for readfile and htmlize.
55   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
56     safe.
57   * More utf-8 fixes from Recai, partly to things I broke above:
58     - The serious problem is that writefile() saves the content in undecoded
59       format in CGI, hence all (non-ascii) chars are corrupted permanently.
60     - Comment field in edit page is not decoded and all the non-ascii chars in
61       this field are corrupted as the result.  We should decode it as we do it
62       for the content.
63     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
64       character in print.
65   * New SVG logo from Recai.
66
67  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
68
69 ikiwiki (1.5) unstable; urgency=low
70
71   * Add --timeformat config option to allow changing how dates are displayed.
72     Note that as a side effect, dates will now be displayed using the local
73     timezone, not as GMT.
74   * More security review.
75   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
76     for some handy stuff like:
77     - Using links as a kind of tag; creating blog pages that list all pages
78       containing a given tag/link or not containing some other tag.
79     - Subscribing to mail notifications whenever a change is made to a page
80       that is a backlink of page foo. Ie, "Please notify me of changes in all
81       pages that link to my home page in the wiki"
82     - Locking any pages that are linked to from a particular page, so that
83       lists of locks can be exposed in the wiki.
84   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
85     when a todo item is done, instead of the previous moving it to a different
86     subdir.
87   * Allow pagetemplate plugins to override *anything* in the template.
88   * Add a meta plugin, which allows specifying various metadata about pages,
89     like license and author. It also allows for inserting html link and meta
90     tags into html, overriding the title, and adding hidden WikiLinks, which
91     can be useful when using link-based globbing for page categorisation.
92   * Remove preprocessor directives from inlined pages.
93   * Allow simple preprocessor directive values to be specified w/o quotes.
94   * Add support for using git instead of subversion as the RCS backend,
95     tremendous thanks to Recai Oktaş for this.
96   * Doc updates for git.
97   * Fix absolute url munging in rss generation to support https, ftp, etc urls
98     not just http urls.
99   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
100     utf-8 for edit and other fields, and for recentchanges. There may still
101     be utf-8 issues with the preferences page though.
102
103  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
104
105 ikiwiki (1.4) unstable; urgency=low
106
107   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
108     very strange way of enabling proper XHTML <br /> type tags. Output html
109     should be always valid again now.
110   * The page name and parent links has switched from using a <h1> to a styled
111     <span>, so pages can use <h1> internally instead of needing to use <h2>.
112   * Updated all of ikiwiki's own wiki pages for that.
113   * Add pagetemplate hook, which can be used by plugins that want to mess
114     around with adding new stuff to the page template.
115   * Remove headercontent; the search plugin now adds the search box to the
116     header by registering a pagetemplate hook, and other plugins should do
117     similarly.
118   * Rebuilding on upgrade to this version is recommended.
119   * Add a html validity check to the test suite, using the wdg-html-validator,
120     if available.
121   * Make the html valid when there is nothing in the actions list.
122   * Reordered some function call parameters for consistency.
123   * Enable full utf-8 support for page input and output.
124   * Add a workaround for markdown, which does not work well with utf-8
125     strings.
126   * --getctime had bitrotted (well I only ever used it the once so far..),
127     fix and make it a bit more flexible
128   * rcs_getctime is changed, now rather than needing to loop over all pages,
129     it should just use the rcs to get the ctime of the passed file.
130   * When inlining a page in another one, links from the inlined page are now
131     expanded the same as they are when rendering the inlined page as a
132     standalone page. So rather than being expanded from the POV of the
133     inlining page, they are expanded from the POV of the inlined page.
134
135     For example, a link from blog/foo to "bar" will now link to blog/bar
136     if it exists. Previously this needed to be a link explicitly to
137     "blog/bar"; such links will also continue to work.
138
139     (This was slightly complex to do as the link still has to be constructed
140     relative to the inlining page.)
141   * Make page edit textarea resize to fit browser window.
142   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
143     do not need a full rebuild, in order to update any basewiki pages.
144
145  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
146
147 ikiwiki (1.3) unstable; urgency=low
148
149   * Fix the preinst introduced in the last version. Closes: #367458
150
151  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
152
153 ikiwiki (1.2) unstable; urgency=low
154
155   * Remove dups from the brokenlinks list.
156   * Add libc6-dev to dependencies, needed to build wrappers.
157   * Install wikilist in correct location. Closes: #367371
158
159  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
160
161 ikiwiki (1.1) unstable; urgency=low
162
163   * Rename inlinepage to depends, so that it can be used to refer to more
164     dependency relationships than just inlining. This will require a rebuild
165     on upgrade to this version.
166   * Move the rss link, put it in the blogpost form if there is one and at the
167     top if not. This is both nicer because easier to find, and it cleans up
168     the code which had used inlinepage as a flag for adding the link later.
169   * Allow the depends GlobList to be built up from multiple sources (such as
170     plugins) during a page render.
171   * Which means that more than one blog is now supported to appear on a
172     single page. (With some limitations, like only the last one getting an
173     rss file.)
174   * Added a plugin system.
175   * Added a pagecount plugin, enabled by default.
176   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
177   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
178     backlinks when the backlinks hadn't really changed.
179   * Moved inline page support, rss generation etc into the inline plugin,
180     enabled by default.
181   * Added brokenlinks plugin, not enabled by default, but rather handy.
182   * Fix several broken links in the doc wiki.
183   * Smarter behavior when creating a page and a page of the same name (but
184     different location) already exists.
185   * Add an orphans plugin for finding pages that nothing links to.
186   * Removed backlinks page, which it turns out nothing used.
187   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
188     it, this will allow for adding a unit test suite.
189   * Add unit tests for several core functions, including globlist_match,
190     dirname, basename, bestlink, linkify, pagetitle, titlepage.
191   * Smart globlist merging.
192   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
193     to pave the way for adding other RCS support. This also changes the
194     setup files, where before they had svn => 1 or svn => 0, now they have
195     rcs => "svn" or rcs => "".
196   * Add a debian/NEWS file with upgrade notes.
197   * Load whatever rcs module is specified, so new ones can be just dropped in
198     as plugins and work. (Well, in theory.)
199   * Add some basic docs about writing RCS modules.
200   * Broke search capability out into a plugin, removed the --hyperestraier
201     switch.
202   * Added smiley plugin, nicely controlled and documented by the smileys page.
203   * Copied in some smileys from Moin Moin.
204   * Allow links of the form [[some page|page]], with whitespace in the link
205     text.
206   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
207     and --disable-plugin htmlscrubber.
208   * Allow discussion links on pages to be turned off with --no-discussion.
209   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
210   * Add some new config items to the estseek.conf template, which are needed
211     by hyperestraier 1.2.3.
212
213  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
214
215 ikiwiki (1.0) unstable; urgency=low
216
217   * First official release.
218
219  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400