1 ikiwiki (1.33) UNRELEASED; urgency=low
3 * Fix issue with aggregate plugin updating expired pages.
4 * Avoid syntax errors in templates used by the template plugin crashing
6 * Enable utf8 file IO in aggregate plugin.
7 * Fix some issues with the new registration form.
8 * Patch from Ethan Glasser Camp to add a skip option to the inline plugin.
9 * Make sure to check for errors from every eval.
10 * Fix img plugin's handling of adding dependencies for images that do not
12 * Work around a strange bug in CGI::FormBuilder 3.0401 that makes
13 FORM-SUBMIT unusable on customised formbuilder templates. For now,
14 hardcode the submit buttons in editpage.tmpl instead of using the
15 template variable, which is ok, since the buttons are static.
17 -- Joey Hess <joeyh@debian.org> Fri, 10 Nov 2006 02:34:49 -0500
19 ikiwiki (1.32) unstable; urgency=low
21 * Add a separate pass to find page links, and only render each page once,
22 instead of over and over. Typical speedup is ~4x. Max possible speedup:
24 * Add "scan" parameter to hook(), which is used to make the hook be called
25 during the scanning pass, as well as the render pass. The meta and tag
26 plugins need to use the new scan parameter, so will any others that modify
28 * Now that links are calculated in a separate pass, it can also
29 precalculate backlinks in one pass, which is O(N^2) instead of the
30 previous code that was O(N^3). A very nice speedup for wikis with lots
32 * Stylish update to the ikiwiki logo, thanks to Recai Oktaş and Selçuk
34 * Add a default stylesheet entry for the pagecloud.
35 * Add examples page with some examples of things that can be done using
36 ikiwiki, like a weblog. The examples can be copied into a user's wiki
37 for a quick start, without needing to learn everything about how to put
39 * Install the source of the examples into /usr/share/doc/ikiwiki/examples.
40 * Add perlmagick to build-depends so syntax check of img plugin works.
42 * Improve login/register process, the login dialog has only name and
43 password fields, which allows more web browsers to regognise it as a login
44 field, and is less confusing.
45 * Implemented expiry options for aggregate plugin.
46 * Use precalculated backlinks info when determining if files need an update
47 due to a page they link to being added/removed. Mostly significant if
48 there are lots of pages.
49 * Remove duplicate link info when saving index. In some cases it could
50 pile up rather badly. (Probably not the best way to deal with this
52 * Patch from James Westby to support podcasting, photoblogging, vidcasting,
53 or what have you, by creating enclosures for non-page items that are
56 -- Joey Hess <joeyh@debian.org> Fri, 3 Nov 2006 14:46:37 -0500
58 ikiwiki (1.31) unstable; urgency=low
60 * Patch from Pawel Tecza to cp -a the templates in the Makefile.
61 * Change the rss feed title from the wikiname to the page title, with
62 an exception for the wiki's toplevel index page, which will still use the
63 wikiname as the feed title.
64 Overriding the page title with meta title already overrode the rss feed
66 * Add an img plugin, based on Christian Mock's img plugin, but stripped
67 down to the bare essentials. Useful for handling large images on websites.
68 * Sanitize possibly problimatic characters out of the polygen grammar names,
69 just in case. Should not be exploitable anyway, since it only tries to run
70 polygen after finding the specified grammar file.
71 * Add missing dependency on the URI perl module.
72 * Add basic spam fighting tool for admins: An admin's prefs page now allows
73 editing a list of banned users.
75 -- Joey Hess <joeyh@debian.org> Fri, 27 Oct 2006 23:16:33 -0400
77 ikiwiki (1.30) unstable; urgency=low
79 * Add no_override parameter to hook().
80 * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
81 plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
82 can be configured using a page in wiki.
83 * Fix support for --pingurl at the command line.
84 * Fix a subtle bug in will_render that broke some builds, by only clearing
85 items from renderedfiles the first time per build.
86 * Wrap entire technortati ping operation in an eval to catch all possible
87 failure modes, after I observed a simple ->value crashing ikiwiki when
90 -- Joey Hess <joeyh@debian.org> Mon, 16 Oct 2006 15:17:38 -0400
92 ikiwiki (1.29) unstable; urgency=low
94 * Patch from Paul Tötterman to use CP in the Makefile.
95 * Patch from Alec Berryman adding a http_auth config item that allows
96 using HTTP Authentication instead of ikiwiki's built in authentication.
97 Useful for eg, large sites with their own previously existing user auth
98 setup. Closes: #384534
99 * Change %renderedfiles to store an array of files rendered from a given
100 source file, to allow tracking of extra rendered files like rss feeds.
101 * Note that plugins that accessed this variable will need to be updated!
102 The plugin interface has been increased to version 1.01 for this change.
103 As few plugins use %renderedfiles I haven't done anything else to ensure
104 compatability of old plugins.
105 * Add will_render function to the plugin interface, used to register that a
106 page renders a destination file, and do some security checks. Previously
107 but no longer rendered files will be cleaned up.
108 * Use will_render in the inline and linkmap plugins.
109 * You will need to rebuild your wiki on upgrade to this version.
110 * Atom feed support based on a patch by Clint Adams.
111 * Add feeds=no option to inline preprocessor directive to turn off all types
113 * $IkiWiki::version now holds the program version, and is accessible to
115 * Make the aggregate plugin emphasize error messages.
116 * Patch from Recai to limit recentchanges to displaying max 10 files for a
117 given changeset (to avoid large number of file changes excessively
120 -- Joey Hess <joeyh@debian.org> Fri, 13 Oct 2006 23:14:28 -0400
122 ikiwiki (1.28) unstable; urgency=low
124 * inline: Add ability to sort by page name, based on a patch from
126 * Fix a forkbomb in various calls to IPC::Open2, which has a highly
127 braindead interface. Closes: #389383
128 * Don't rm -rf ikiwiki on distclean, since a) there's no such file
129 and b) those poor Mac OSX users and their case insensative files!
130 * Don't fail syntax check if Text::Typography isn't installed.
133 -- Joey Hess <joeyh@debian.org> Tue, 26 Sep 2006 02:08:17 -0400
135 ikiwiki (1.27) unstable; urgency=low
137 * Work on firming up the plugin interface:
138 - Plugins should not need to load IkiWiki::Render to get commonly
139 used functions, so moved some functions from there to IkiWiki.
140 - Picked out the set of functions and variables that most plugins
141 use, documented them, and made IkiWiki export them by default,
142 like a proper perl module should.
143 - Use the other functions at your own risk.
144 - This is not quite complete, I still have to decide whether to
145 export some other things.
146 * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
147 referring to stuff now exported by the IkiWiki module.
148 * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
149 to declare which version of the interface your plugin needs.
150 * Anyone with a third-party ikiwiki plugin is strongly encouraged
151 to make like changes to it and avoid use of non-exported symbols from
153 * Link debian/changelog and debian/news to NEWS and CHANGELOG.
154 * Support hyperestradier version 1.4.2, which adds a new required phraseform
156 * If an inlined page has a permalink, link the page title to that.
157 * Patch from Recai to use utf8 when reading the setup file, so that
158 utf8 wikinames from there will be used properly.
159 * Patch from Recai to kill utf-8 on the wiki name when generating the
161 * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
162 * Fix a baseurl problem in hyperestradier search results.
163 * Add a stub local.css to avoid problems with 404's.
164 * Patch from Recai to fix a wide character warning from the search plugin
165 during setup if the wikiname contains utf8.
166 * Yet another fix for those poor case-insensative OS X users.
167 * pagetemplate hooks are now also called when generating cgi pages.
168 * Add a favicon plugin, which simply adds a link tag for an icon to each
170 * Patch from James Westby to deal with the case where you're editing a
171 new page, hit cancel, and need to be redirected to somewhere sane.
172 * Various documentation improvements by various wiki users.
173 * Support Text::Markdown from CPAN, which has a different interface from
174 the original markdown or the one in Debian.
175 * Version the libcgi-session-perl dependency, some features that need
176 the new version are used in some cases (sslcookie).
177 * Numerous tla fixes from Clint.
178 * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
179 a multi-resolution favicon.ico.
180 * README.Debian: typo Closes: #388110
181 * chomp trailing newline at the end of templates read in by the template
182 plugin, to allow use of the template preprocessor directive in
183 whitespace-sensative situations. Closes: #387073
184 * Patch from James Westby to make the location of the estseek.cgi script
186 * Add typography (SmartyPants) plugin by Recai.
187 * Add --render mode, which can be used to preview an edit at the command
188 line by test rendering a single page.
189 * Add a googlecalendar plugin. A bit special-purpose, but it shows
190 one way to to deal with user-supplied content that could cause XSS
191 issues w/o the htmlscrubber, and won't survive the scrubber.
193 -- Joey Hess <joeyh@debian.org> Sun, 24 Sep 2006 00:02:21 -0400
195 ikiwiki (1.26) unstable; urgency=low
197 * Add a missing -n to tla undo call.
198 * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
199 writes before consuming its whole stdin. Avoid this deadlock.
200 * Fix alt tags for outline checkboxes.
202 -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 16:24:16 -0400
204 ikiwiki (1.25) unstable; urgency=low
206 * Add proper waitpid calls for open2ed processes throughout to avoid
207 zombies; this hit htmltidy especially badly.
208 * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
209 subversion repos and fixing some other issues.
210 * Add support for tla, contributed by Clint Adams. Closes: #385936
211 * Add support for mercurial, contributed by Emanuele Aina.
212 * Include <link rel> tag for RSS feeds, used by some aggregators and
213 firefox to find the feed.
214 * Add a linkmap plugin (requires graphviz).
216 -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 01:54:14 -0400
218 ikiwiki (1.24) unstable; urgency=low
220 * Simplify the data structure returned by rcs_recentchanges to avoid
221 each rcs plugin needing to form complex strings on its own.
222 * Fix another destpage issue in the inline directive. Closes: #385512
225 -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 15:46:45 -0400
227 ikiwiki (1.23) unstable; urgency=low
229 * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
231 -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 12:14:45 -0400
233 ikiwiki (1.22) unstable; urgency=low
235 * Change how the stylesheet url is determined in the templates: Remove
236 STYLEURL and add BASEURL to all templates (some already had it). This
237 new more general variable can be used to link to other things (eg, images)
238 from the template, as well as stylesheets.
239 * Fix a bug introduced last version to do with nested inlines.
240 * Allow preprocessor directives to span multiple lines, both to make
241 long ones with lots of values easier to write, and to allow for ones with
242 multi-line quoted values.
243 * Allow preprocessor directives to contain python-like triple-quoted
244 text blocks, for easy nesting of quotes inside.
245 * Add a template plugin.
246 * Make pagespec merge code smarter about merging duplicate pagespecs.
247 * Patch from Jordà Polo to make Setup::Standard support hashes in config
249 * Change order of linkify and preprocess; first preprocess and then linkify.
250 This allows passing a wikilink inside a parameter to a preprocessor
251 directive without it being expanded to html, and leaking out of the
252 parameter, which had required some non-obvious use of triple-quoting
253 to avoid. Note that any preprocessor plugins that output something
254 that looks like a wikilink will now have it treated as such; AFAIK
255 this doesn't change any behavior though except for the template plugin.
256 * Enable preprocessor directives when previewing an edit.
257 * Make all pages pull in a local.css style sheet, if present. This won't
258 be included in ikiwiki, but can be created to make local styling changes
259 w/o needing to merge in every new change to the distributed style.css.
260 * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
261 * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
262 from a different directory.
263 * Generalised preprocesser loop protection code.
264 * Patch from James Westby to allow a description to be set for rss feeds.
265 * Patch from James Westby to add a template for the search form.
266 * Added a ddate plugin.
267 * Patch from James Westby to add a --sslcookie switch, which forces
268 cookies to only be sent over ssl connections to avoid interception.
269 * Fix preferences page on anonok wikis; still need to sign in to get
270 to the preferences page.
271 * Add toc (table of contents) plugin.
272 * Change htmlize, format, and sanitize hooks to use named parameters.
273 * Patch from James Westby to add an actions option to inline; this
274 adds Edit and Discussion links at the end of blog entries.
275 * Due to some css changes, you'll want to rebuild your wiki on upgrade
276 to this version. Will be handled automatically by the deb.
277 * Add processed date to aggregate preprocessor directive status output.
279 -- Joey Hess <joeyh@debian.org> Fri, 1 Sep 2006 22:03:34 -0400
281 ikiwiki (1.21) unstable; urgency=low
283 * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
284 * If a page links to itself, mark up the link text in a span with
285 class="selflink" so that it can be styled. I don't have a useful style
286 defined for that though.
287 * Call filter hooks on inlined page content.
288 * Support inlining pages raw, rather than creating a blog.
289 * Clean up yes/no parameter parsing in inline plugin.
290 * Implemented better cycle detection in the inline plugin; nested inlines
292 * Add a map plugin contributed by Alessandro Dotti Contra.
293 * Add otl format plugin, which handles files as created by vimoutliner.
294 * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
295 * Add first draft at a Restructured Text (rst) plugin, by Sergio
296 Talens-Oliag. Note that this has many known issues -- see the caveats on
298 * Credit everyone who wrote a plugin on the plugins' wiki pages.
299 * Fix utf-8 in blog post form.
301 -- Joey Hess <joeyh@debian.org> Sun, 20 Aug 2006 16:42:54 -0400
303 ikiwiki (1.20) unstable; urgency=low
305 * Relicense the templates and basewiki under the 2-clause BSD license.
306 Since these can easily become part of other people's websites, they
307 should be under as permissive a license as possible.
308 * Add --syslog config option, to log to the syslog.
309 * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
310 transient failure to fork (which I've seen happen in the wild).
311 * Fix a bug in the aggregator introduced last version that caused all
312 aggregator state to be lost during a non-aggregating build.
314 -- Joey Hess <joeyh@debian.org> Thu, 17 Aug 2006 19:05:56 -0400
316 ikiwiki (1.19) unstable; urgency=low
318 * Fix several related bugs in page type determination during online editing.
319 * Add some locking to prevent 2 aggregators from running at once.
320 * Fix an infinite loop in the aggregator when finding a unique filename.
322 -- Joey Hess <joeyh@debian.org> Wed, 16 Aug 2006 13:46:25 -0400
324 ikiwiki (1.18) unstable; urgency=low
326 * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
328 * Man page format fixups.
329 * If the meta plugin overides the page title, set a title_overridden
330 variable in the template to true. This allows doing things with the
331 templates conditional on the title being overriden.
332 * Add a %pagecase which maps lower-case page names to the actual case
333 used in the filename. Use this in bestlinks calculation instead of
334 forcing the link to lowercase.
335 * Also use %pagecase in various other places that want to check if a page
336 with a given name exists.
337 * This means that links to pages with mixed case names will now work,
338 even if the link is in some other case mixture, and mixed case pages
339 should be fully supported throughout ikiwiki.
340 * Recommend rebuilding wikis on upgrade to this version.
342 -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 22:10:48 -0400
344 ikiwiki (1.17) unstable; urgency=low
346 * Disable tidy generator tag.
347 * Move tidy back to sanitize hook, found out how to only show body.
348 * Turn off tidy indentation too.
349 * Turn on HTML::Template loop_context_vars; not actually used in stock
350 templates but can be useful for things like making comma-delimited lists
351 of tags or what have you.
352 * Remove <br> from end of aggregate preprocessor directive output.
353 * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
354 case-sensative filesystems like OSX.
355 * Improve markdown loading. First, try to load it as a proper perl module,
356 in case it was installed as one. Then fall back to trying
358 * Document in install page how to install markdown, since it has no
359 installation procedure in the upstream tarball.
360 * Set die_on_bad_params => 0 for all templates, to allow users to modify
361 them without annoyances.
362 * Suck in the page content when generating an inline archive page, to work
363 around the meta plugin's lack of caching of title metadata across runs.
365 -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 12:52:13 -0400
367 ikiwiki (1.16) unstable; urgency=low
369 * Try to handle relative links in aggregated feeds. However,
370 the current support is a crude hack due to limitations of XML::Feed:
371 xml:base is not supported, neither is Content-Location. And of course,
372 relative links in RSS feeds are ill-undefined..
373 * Make aggregator save permalinks and author name to pages as metadata.
374 * Add permalink and author support to meta plugin, affecting RSS feeds
376 * Various CSS and formatting changes.
377 * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
378 * Add xhtml files to the default prune regexp.
379 * Also generate rel=bookmark links for permalinks.
380 * Fix the htmltidy plugin, which wasn't working due my breaking it when
382 * Don't run tidy with -xml as that fails if the input is not well-formed.
383 Run it with -asxhtml instead, so it will output well-formed xhtml no
384 matter what the input.
385 * Disable tidy warnings too.
386 * Add a new format hook, and make tidy use it, since tidy can really only
387 operate on and output complete html documents, not the body chunks
389 * Fix dates in rss feeds if running localised, so they're still rfc 822.
391 -- Joey Hess <joeyh@debian.org> Fri, 4 Aug 2006 20:48:36 -0400
393 ikiwiki (1.15) unstable; urgency=low
395 * Remove CDPATH and other env vars perl taint checking doesn't like.
397 * Added created_before and created_after PageSpec limits.
399 -- Joey Hess <joeyh@debian.org> Thu, 3 Aug 2006 13:00:57 -0400
401 ikiwiki (1.14) unstable; urgency=low
403 * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
405 * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
406 * Added many unit tests for pagespec_match.
408 -- Joey Hess <joeyh@debian.org> Wed, 2 Aug 2006 11:34:06 -0400
410 ikiwiki (1.13) unstable; urgency=low
412 * ikiwiki can now download and aggregate feeds with its new aggregate
413 plugin, so it's possible to implement a Planet using ikiwiki!
414 * Add a run_hooks function for the common task of running all hooks of a
416 * Add a savestate hook.
417 * Don't put blog post forms on pages if there's no cgiurl set.
418 * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
419 --wrappers to do that.
420 * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
421 to update pages that haven't changed on disk.
422 * Change meta tags to use html entity-escaped text for values, so that
423 quotes and such can be represented in title tags.
424 * Depend and build-depend on HTML::Parser for HTML::Entities which is used
426 * Make --rebuild also cause --aggregate to re-download and write aggregated
428 * Avoid outputting duplicate meta info.
429 * Include title metadata on aggregated posts for capitalised and un-munged
431 * Title metadata of inlined pages now shows up in blogs and rss feeds.
432 * Fix issue with unicode filenames and updating the hyper estradier search
433 index. (Aka Please Please Please, let that be the last one.)
434 * Patch from Roland Mas to support an rss=no parameter to inline directives.
436 * Renamed GlobLists to PageSpecs.
437 * PageSpecs can now include nested parens, "and", and "or". This remains
438 backwards compatible to the old GlobList format. It's implemented by
439 treating the GlobList as a very limited microlanguage that is transformed
440 to perl code that does the matching.
441 * The old GlobList format is deprecated, and I encourage users to switch to
442 using the new PageSpec format. Compatability with the old format will be
443 removed at some point, possibly by 2.0.
444 * Wiki rebuild needed on upgrade to this version due to PageSpec change.
445 * Add support for creation_month and creation_year to PageSpec.
447 * Changes to index file encoding.
449 -- Joey Hess <joeyh@debian.org> Tue, 1 Aug 2006 21:21:19 -0400
451 ikiwiki (1.12) unstable; urgency=low
454 * New pagestats plugin from Enrico, which can generate a table counting
455 the backlinks for each page, or a del.icio.us style cloud.
456 * Build-depend on libtext-wikiformat-perl, so that the syntax check of
457 the wikiformat plugin works. Thanks, Emanuele Aina.
458 * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
459 display, running them through pagetitle. This removes ugly underscores and
460 other gunk from the display, much nicer. You may want to rebuild your wiki
461 when upgrading to get the cleanup globally.
462 * Polygen plugin from Enrico.
463 * htmltidy plugin from Faidon.
464 * Locale patch from Faidon:
465 - Adds a locale setting to setup files.
466 - Proper local time, if the locale configuration option is used.
467 - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
468 commiting (or even rcs_updating) on repositories with UTF-8 filenames was
470 * Add getopt hook type, this allows plugins to add new command-line options.
471 * Add --tagbase option to tag plugin.
472 * Add exclude option in setup files, works same as --exclude.
473 * Put categories in rss feeds for tagged items.
474 * Allow preprocessor directives to be expanded in inlined blog pages.
475 However, to avoid inlining loops etc, don't expand inline directives in
477 * fortune plugin (trivial)
478 * Tag plugins according to type.
480 -- Joey Hess <joeyh@debian.org> Sat, 29 Jul 2006 17:12:56 -0400
482 ikiwiki (1.11) unstable; urgency=low
484 * Patch from Enrico that
485 - Adds a tag plugin that allows more easily tagging pages.
486 The meta plugin can also still be used for that, but the tag plugin
487 also lists a page's tags at the bottom of the page.
488 - Allows preprocessor directives to have parameters with no specified
490 - Fixes preprocessor directive parameter parsing so that
491 foo=bar baz now means "foo=bar" and a "baz" with no value.
492 * Run pagetemplate hooks when inlining pages so that inlined pages also
494 * Make all plugins with pagetemplate hooks check that variables exist
495 on the template before setting them, for robustness.
496 * Switch pagetemplate hooks to using named parameters.
497 * Pass a destpage parameter to preprocessor and pagetemplate hooks.
498 This will be the page that a source page will be part of, which is
499 different than the source page for inlined pages.
500 * Audited all plugins to endure they pass (page, destpage) to htmllink
501 appropriatly. This means inlining of various plugins will not work
502 properly, with correct links generated.
504 -- Joey Hess <joeyh@debian.org> Thu, 27 Jul 2006 20:51:23 -0400
506 ikiwiki (1.10) unstable; urgency=low
508 * Run page through any relevant filters when generating a page preview.
509 * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
510 default throughout the wiki, not only on wikitext pages. Decided to call
511 this a feature, and split the camelcase support out into a separate plugin
512 that is independant of wikitext.
513 * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
515 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 18:06:35 -0400
517 ikiwiki (1.9) unstable; urgency=low
519 * Improve display of parentlinks and page title of toplevel index page.
520 * Patch from Faidon to use svn --limit when possible for recentchanges,
521 speeds up recentchanges a lot for wikis with more history.
522 * Patch from Recai to fix utf8 issues in git backend.
523 * Add wikitext markup plugin, which supports ".wiki" pages written in the
524 original wiki syntax, CamelCase links and all.
525 * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
526 support, to edit pages etc without a web server.
527 * Display CGI processing errors if present.
528 * Fix from Faidon for a XML parser issue that breaks utf-8 for
529 RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
530 area, and also way slow.
531 * Match 'web commit from' in SVN and git, these are web commits too.
533 * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
534 readable and avoid future mistakes. The patch seems to work and for the
535 first time I have a UTF-8 username ;-) (Faidon)
536 * Use form->field consistently, not form->param.
537 * Patch from Recai to allow selection of page type when creating a new page.
538 Default page type is inherited from the link clicked on to create the new
541 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 17:25:30 -0400
543 ikiwiki (1.8) unstable; urgency=low
545 * Fix orphans plugin to not count a link to a nonexistant page as a reason
546 for a page not being an orphan.
547 * Support pinging services such as Technorati using XML-RPC to notify them
548 about changes to rss feeds.
549 * Parse svn log as xml for improved utf8 and security. Note that this makes
550 ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
551 * POSIX::strftime doesn't know about encodings and doesn't return a utf8
552 flagged string even if the locale causes it to generate utf8 output,
553 so make sure to let perl know it should be handled as utf8. Also,
554 the optimised version used for standard time formats won't work if the
555 user has changed locale, so drop it. Thanks, Faidon Liambotis.
556 * Fix re-encoding of the comments field to utf8 if a commit fails
557 due to a conflict. Thanks, Faidon Liambotis.
558 * Let svn know that commits have utf8 commit messages. Thanks, Faidon
560 * Add insane double encode/decode to utf8 around call to markdown.
561 This works around a truely strange bug, which is apparently a bug in
562 perl, #376329. Also added a test case for it.
563 * Improve layout of edit page so formatting help link is always visible w/o
564 getting in the way of the preview.
565 * Centralised all calls to HTML::Template and force all the templates
567 * Support pages with utf8 filenames. Patch by Faidon Liambotis.
568 * Introduce add_plugins and disable_plugins config options in setup files.
569 This allows adding or removing plugins w/o overriding the whole list of
570 default plugins, which makes it easier to upgrade when new default plugins
572 * Support htmlize plugins and make mdwn one such plugin, which is enabled by
573 default (of course!). Based on a patch by Faidon Liambotis.
574 * Add a html plugin, which can be used to write wikis in raw html,
575 if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
576 defaults to not processing .html files, since w/o this plugin they would
577 be copied unsanitised. With this plugin, it will process and html
578 sanitise them, like any other page type.
579 * Rebuilding wrappers is necessary on upgrade to this version.
580 * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
581 will be automatically done on all upgrades.
582 * Don't send pings if the wiki is being rebuilt.
583 * Work around very innefficient behavior in File::Spec::abs2rel. Result
584 is a savings of 2 pointless fork/execs per link calculation, which
585 results in ~25% speedup of ikiwiki building its own doc wiki, and
586 about 35% speedup displaying RecentChanges!
587 * Make RecentChanges use a table and some CSS, should be much more readable.
588 No code changes involved.
589 * Encode & in diffurl in examples, to conform to pedantic rules.
590 * Speed up RecentChanges by another 40% or so with some memoization.
591 * Memoize abs2rel, which is still kinda slow, for another 30% speedup
592 in time to build the doc wiki.
594 -- Joey Hess <joeyh@debian.org> Tue, 4 Jul 2006 12:46:29 -0400
596 ikiwiki (1.7) unstable; urgency=low
598 * Updated logo from Recai with some kerning and alingment tuning.
599 * Patch from Recai to fix git recentchanges code to work with git 1.4 which
603 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
605 ikiwiki (1.6) unstable; urgency=low
607 * YA utf-8 patch from Recai, this time to fix previewing a page so that
608 the text in the input box is re-encoded back to utf-8.
609 * -CSD does not affect modules, so readfile() was not using the utf-8 input
610 layer, which led to lots of problems; make it force read files as utf-8.
612 * Note that as a consequence, this version of ikiwiki will actually try to
613 parse utf8 in source files for the first time, which may expose broken
614 utf8 in wiki sources that was hidden before. Most common will be
615 perl warnings like "utf8 "\xE9" does not map to Unicode"
616 * writefile() likewise needs to use the utf8 output layer.
617 * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
619 * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
620 given the readfile fix.
621 * Add utf-8 testcases for readfile and htmlize.
622 * Put back the encode_utf8 in the input to markdown; it's really not utf-8
624 * More utf-8 fixes from Recai, partly to things I broke above:
625 - The serious problem is that writefile() saves the content in undecoded
626 format in CGI, hence all (non-ascii) chars are corrupted permanently.
627 - Comment field in edit page is not decoded and all the non-ascii chars in
628 this field are corrupted as the result. We should decode it as we do it
630 - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
632 * New SVG logo from Recai.
634 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
636 ikiwiki (1.5) unstable; urgency=low
638 * Add --timeformat config option to allow changing how dates are displayed.
639 Note that as a side effect, dates will now be displayed using the local
640 timezone, not as GMT.
641 * More security review.
642 * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
643 for some handy stuff like:
644 - Using links as a kind of tag; creating blog pages that list all pages
645 containing a given tag/link or not containing some other tag.
646 - Subscribing to mail notifications whenever a change is made to a page
647 that is a backlink of page foo. Ie, "Please notify me of changes in all
648 pages that link to my home page in the wiki"
649 - Locking any pages that are linked to from a particular page, so that
650 lists of locks can be exposed in the wiki.
651 * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
652 when a todo item is done, instead of the previous moving it to a different
654 * Allow pagetemplate plugins to override *anything* in the template.
655 * Add a meta plugin, which allows specifying various metadata about pages,
656 like license and author. It also allows for inserting html link and meta
657 tags into html, overriding the title, and adding hidden WikiLinks, which
658 can be useful when using link-based globbing for page categorisation.
659 * Remove preprocessor directives from inlined pages.
660 * Allow simple preprocessor directive values to be specified w/o quotes.
661 * Add support for using git instead of subversion as the RCS backend,
662 tremendous thanks to Recai Oktaş for this.
663 * Doc updates for git.
664 * Fix absolute url munging in rss generation to support https, ftp, etc urls
666 * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
667 utf-8 for edit and other fields, and for recentchanges. There may still
668 be utf-8 issues with the preferences page though.
670 -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
672 ikiwiki (1.4) unstable; urgency=low
674 * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
675 very strange way of enabling proper XHTML <br /> type tags. Output html
676 should be always valid again now.
677 * The page name and parent links has switched from using a <h1> to a styled
678 <span>, so pages can use <h1> internally instead of needing to use <h2>.
679 * Updated all of ikiwiki's own wiki pages for that.
680 * Add pagetemplate hook, which can be used by plugins that want to mess
681 around with adding new stuff to the page template.
682 * Remove headercontent; the search plugin now adds the search box to the
683 header by registering a pagetemplate hook, and other plugins should do
685 * Rebuilding on upgrade to this version is recommended.
686 * Add a html validity check to the test suite, using the wdg-html-validator,
688 * Make the html valid when there is nothing in the actions list.
689 * Reordered some function call parameters for consistency.
690 * Enable full utf-8 support for page input and output.
691 * Add a workaround for markdown, which does not work well with utf-8
693 * --getctime had bitrotted (well I only ever used it the once so far..),
694 fix and make it a bit more flexible
695 * rcs_getctime is changed, now rather than needing to loop over all pages,
696 it should just use the rcs to get the ctime of the passed file.
697 * When inlining a page in another one, links from the inlined page are now
698 expanded the same as they are when rendering the inlined page as a
699 standalone page. So rather than being expanded from the POV of the
700 inlining page, they are expanded from the POV of the inlined page.
702 For example, a link from blog/foo to "bar" will now link to blog/bar
703 if it exists. Previously this needed to be a link explicitly to
704 "blog/bar"; such links will also continue to work.
706 (This was slightly complex to do as the link still has to be constructed
707 relative to the inlining page.)
708 * Make page edit textarea resize to fit browser window.
709 * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
710 do not need a full rebuild, in order to update any basewiki pages.
712 -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
714 ikiwiki (1.3) unstable; urgency=low
716 * Fix the preinst introduced in the last version. Closes: #367458
718 -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
720 ikiwiki (1.2) unstable; urgency=low
722 * Remove dups from the brokenlinks list.
723 * Add libc6-dev to dependencies, needed to build wrappers.
724 * Install wikilist in correct location. Closes: #367371
726 -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
728 ikiwiki (1.1) unstable; urgency=low
730 * Rename inlinepage to depends, so that it can be used to refer to more
731 dependency relationships than just inlining. This will require a rebuild
732 on upgrade to this version.
733 * Move the rss link, put it in the blogpost form if there is one and at the
734 top if not. This is both nicer because easier to find, and it cleans up
735 the code which had used inlinepage as a flag for adding the link later.
736 * Allow the depends GlobList to be built up from multiple sources (such as
737 plugins) during a page render.
738 * Which means that more than one blog is now supported to appear on a
739 single page. (With some limitations, like only the last one getting an
741 * Added a plugin system.
742 * Added a pagecount plugin, enabled by default.
743 * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
744 * Fixed/optimised backlinks code, to avoid rebuilding pages to update
745 backlinks when the backlinks hadn't really changed.
746 * Moved inline page support, rss generation etc into the inline plugin,
748 * Added brokenlinks plugin, not enabled by default, but rather handy.
749 * Fix several broken links in the doc wiki.
750 * Smarter behavior when creating a page and a page of the same name (but
751 different location) already exists.
752 * Add an orphans plugin for finding pages that nothing links to.
753 * Removed backlinks page, which it turns out nothing used.
754 * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
755 it, this will allow for adding a unit test suite.
756 * Add unit tests for several core functions, including globlist_match,
757 dirname, basename, bestlink, linkify, pagetitle, titlepage.
758 * Smart globlist merging.
759 * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
760 to pave the way for adding other RCS support. This also changes the
761 setup files, where before they had svn => 1 or svn => 0, now they have
762 rcs => "svn" or rcs => "".
763 * Add a debian/NEWS file with upgrade notes.
764 * Load whatever rcs module is specified, so new ones can be just dropped in
765 as plugins and work. (Well, in theory.)
766 * Add some basic docs about writing RCS modules.
767 * Broke search capability out into a plugin, removed the --hyperestraier
769 * Added smiley plugin, nicely controlled and documented by the smileys page.
770 * Copied in some smileys from Moin Moin.
771 * Allow links of the form [[some page|page]], with whitespace in the link
773 * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
774 and --disable-plugin htmlscrubber.
775 * Allow discussion links on pages to be turned off with --no-discussion.
776 * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
777 * Add some new config items to the estseek.conf template, which are needed
778 by hyperestraier 1.2.3.
780 -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
782 ikiwiki (1.0) unstable; urgency=low
784 * First official release.
786 -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400