* Allow /etc/ikiwiki/wikilist to list just the names of users, if so then
[ikiwiki] / debian / changelog
1 ikiwiki (1.34.2) UNRELEASED; urgency=low
2
3   * Allow /etc/ikiwiki/wikilist to list just the names of users, if so then 
4     ~user/.ikiwiki/wikilist will be read.
5
6  -- Joey Hess <joeyh@debian.org>  Tue, 28 Nov 2006 00:16:40 -0500
7
8 ikiwiki (1.34.1) unstable; urgency=low
9
10   * Add libtime-duraiton-perl to build deps, as it's used by the svn module
11     which is now tested at build.
12
13  -- Joey Hess <joeyh@debian.org>  Mon, 27 Nov 2006 12:26:12 -0500
14
15 ikiwiki (1.34) unstable; urgency=low
16
17   * Add an openid plugin to support logging in using OpenID.
18   * Web commits by OpenID users will record the full OpenID url for the user,
19     but in recentchanges, these urls will be converted to a simplified display
20     form+link.
21   * Modified svn, git, tla backends to recognise such web commits.
22   * Move httpauth support to a plugin.
23   * Add openidsignup config option.
24   * Make the openid plugin support the callbacks from myopenid.com via its
25     affiliate program.
26   * Add toggle plugin.
27   * Add a poll plugin.
28   * Add quick mode for archive page generation.
29   * Introduce the goodstuff bundle. This is a kind of plugin, that just enables
30     many other plugins. It's an easy way to boost ikiwiki from its default,
31     basic wiki, to a full-featured wiki, without manually picking the right
32     set of plugins. New plugins will be added to goodstuff from time to
33     time.
34   * Change how post signin actions are propigated through the signin process;
35     they're now stored in the session.
36   * Add optional "desc" parameter to shortcut definitions.
37   * Avoid locking the wiki at all when handling some basic cgi stuff
38     (searches, recentchanges).
39   * Add "last" parameter to hook function. Very basic ordering, and hopefully
40     nothing more spohisticated will be needed.
41   * Add formbuilder_setup and formbuilder hooks.
42   * Split out a passwordauth module, that holds all the traditional password
43     based authentication etc code. It's enabled by default, but can be disabled
44     if you want only openid or some other auth method.
45   * Rename ikiwiki.pl so MakeMaker doesn't see it, and install it.
46   * Add some code to the build system that tries to determine if the
47     lib installation directory is in @INC. If it's not, munge ikiwiki
48     to hardcode the path to the lib directory. This should allow installing
49     ikiwiki in nonstandard locations, including home directories, by just
50     setting PREFIX at build time.
51   * Fix nested examples directory in deb.
52   * Add a test suite for the mercurial backend, contributed by Emanuele Aina.
53   * Add a test suite for the svn backend.
54   * Add a test suite for the git backend, from Recai
55   * Daemonize before sending RPC pings, since that can take a while
56     and/or hang.
57   * Daemonize before sending commit mails, as that can also take a long
58     time/hang if the mail server is unhappy.
59   * Factor out commit mail sending code into new function.
60   * Change rcs_commit, it is now passed the name of the user doing the commit
61     and their IP address, and needs to construct its own commit message
62     containing them, or do something more appropriate for the given RCS.
63   * Add softwaresite example.
64   * Mercurial backend improvements, including --get-ctime support. (Emanuele
65     Aina)
66   * Git backend improvements, including bug fixes and better robustness,
67     from Recai.
68
69  -- Joey Hess <joeyh@debian.org>  Sun, 26 Nov 2006 20:46:56 -0500
70
71 ikiwiki (1.33) unstable; urgency=low
72
73   * Fix issue with aggregate plugin updating expired pages.
74   * Avoid syntax errors in templates used by the template plugin crashing
75     ikiwiki.
76   * Enable utf8 file IO in aggregate plugin.
77   * Fix some issues with the new registration form.
78   * Patch from Ethan Glasser Camp to add a skip option to the inline plugin.
79   * Make sure to check for errors from every eval.
80   * Fix img plugin's handling of adding dependencies for images that do not
81     yet exist.
82   * Work around a strange bug in CGI::FormBuilder 3.0401 that makes
83     FORM-SUBMIT unusable on customised formbuilder templates. For now,
84     hardcode the submit buttons in editpage.tmpl instead of using the
85     template variable, which is ok, since the buttons are static.
86   * Work with hyperestraier 1.4.9.
87
88  -- Joey Hess <joeyh@debian.org>  Wed, 15 Nov 2006 18:32:26 -0500
89
90 ikiwiki (1.32) unstable; urgency=low
91
92   * Add a separate pass to find page links, and only render each page once,
93     instead of over and over. Typical speedup is ~4x. Max possible speedup:
94     8x.
95   * Add "scan" parameter to hook(), which is used to make the hook be called
96     during the scanning pass, as well as the render pass. The meta and tag
97     plugins need to use the new scan parameter, so will any others that modify
98     %links.
99   * Now that links are calculated in a separate pass, it can also
100     precalculate backlinks in one pass, which is O(N^2) instead of the
101     previous code that was O(N^3). A very nice speedup for wikis with lots
102     (thousands) of pages.
103   * Stylish update to the ikiwiki logo, thanks to Recai Oktaş and Selçuk
104     Erdem.
105   * Add a default stylesheet entry for the pagecloud.
106   * Add examples page with some examples of things that can be done using
107     ikiwiki, like a weblog. The examples can be copied into a user's wiki
108     for a quick start, without needing to learn everything about how to put
109     them together.
110   * Install the source of the examples into /usr/share/doc/ikiwiki/examples.
111   * Add perlmagick to build-depends so syntax check of img plugin works.
112     Closes: #396702
113   * Improve login/register process, the login dialog has only name and
114     password fields, which allows more web browsers to regognise it as a login
115     field, and is less confusing.
116   * Implemented expiry options for aggregate plugin.
117   * Use precalculated backlinks info when determining if files need an update
118     due to a page they link to being added/removed. Mostly significant if
119     there are lots of pages.
120   * Remove duplicate link info when saving index. In some cases it could
121     pile up rather badly. (Probably not the best way to deal with this
122     problem.)
123   * Patch from James Westby to support podcasting, photoblogging, vidcasting,
124     or what have you, by creating enclosures for non-page items that are
125     included in feeds.
126
127  -- Joey Hess <joeyh@debian.org>  Fri,  3 Nov 2006 14:46:37 -0500
128
129 ikiwiki (1.31) unstable; urgency=low
130
131   * Patch from Pawel Tecza to cp -a the templates in the Makefile.
132   * Change the rss feed title from the wikiname to the page title, with
133     an exception for the wiki's toplevel index page, which will still use the
134     wikiname as the feed title.
135     Overriding the page title with meta title already overrode the rss feed
136     tittle.
137   * Add an img plugin, based on Christian Mock's img plugin, but stripped
138     down to the bare essentials. Useful for handling large images on websites.
139   * Sanitize possibly problimatic characters out of the polygen grammar names,
140     just in case. Should not be exploitable anyway, since it only tries to run
141     polygen after finding the specified grammar file.
142   * Add missing dependency on the URI perl module.
143   * Add basic spam fighting tool for admins: An admin's prefs page now allows
144     editing a list of banned users.
145
146  -- Joey Hess <joeyh@debian.org>  Fri, 27 Oct 2006 23:16:33 -0400
147
148 ikiwiki (1.30) unstable; urgency=low
149
150   * Add no_override parameter to hook().
151   * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
152     plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
153     can be configured using a page in wiki.
154   * Fix support for --pingurl at the command line.
155   * Fix a subtle bug in will_render that broke some builds, by only clearing
156     items from renderedfiles the first time per build.
157   * Wrap entire technortati ping operation in an eval to catch all possible
158     failure modes, after I observed a simple ->value crashing ikiwiki when
159     a ping failed.
160
161  -- Joey Hess <joeyh@debian.org>  Mon, 16 Oct 2006 15:17:38 -0400
162
163 ikiwiki (1.29) unstable; urgency=low
164
165   * Patch from Paul Tötterman to use CP in the Makefile.
166   * Patch from Alec Berryman adding a http_auth config item that allows
167     using HTTP Authentication instead of ikiwiki's built in authentication.
168     Useful for eg, large sites with their own previously existing user auth
169     setup. Closes: #384534
170   * Change %renderedfiles to store an array of files rendered from a given
171     source file, to allow tracking of extra rendered files like rss feeds.
172   * Note that plugins that accessed this variable will need to be updated!
173     The plugin interface has been increased to version 1.01 for this change.
174     As few plugins use %renderedfiles I haven't done anything else to ensure
175     compatability of old plugins.
176   * Add will_render function to the plugin interface, used to register that a
177     page renders a destination file, and do some security checks. Previously
178     but no longer rendered files will be cleaned up.
179   * Use will_render in the inline and linkmap plugins.
180   * You will need to rebuild your wiki on upgrade to this version.
181   * Atom feed support based on a patch by Clint Adams.
182   * Add feeds=no option to inline preprocessor directive to turn off all types
183     of feeds.
184   * $IkiWiki::version now holds the program version, and is accessible to
185     plugins.
186   * Make the aggregate plugin emphasize error messages.
187   * Patch from Recai to limit recentchanges to displaying max 10 files for a
188     given changeset (to avoid large number of file changes excessively
189     bloating the page).
190
191  -- Joey Hess <joeyh@debian.org>  Fri, 13 Oct 2006 23:14:28 -0400
192
193 ikiwiki (1.28) unstable; urgency=low
194
195   * inline: Add ability to sort by page name, based on a patch from
196     Benjamin A'Lee.
197   * Fix a forkbomb in various calls to IPC::Open2, which has a highly
198     braindead interface. Closes: #389383
199   * Don't rm -rf ikiwiki on distclean, since a) there's no such file
200     and b) those poor Mac OSX users and their case insensative files!
201   * Don't fail syntax check if Text::Typography isn't installed.
202     Closes: #389406
203
204  -- Joey Hess <joeyh@debian.org>  Tue, 26 Sep 2006 02:08:17 -0400
205
206 ikiwiki (1.27) unstable; urgency=low
207
208   * Work on firming up the plugin interface:
209     - Plugins should not need to load IkiWiki::Render to get commonly
210       used functions, so moved some functions from there to IkiWiki.
211     - Picked out the set of functions and variables that most plugins
212       use, documented them, and made IkiWiki export them by default,
213       like a proper perl module should.
214     - Use the other functions at your own risk.
215     - This is not quite complete, I still have to decide whether to
216       export some other things.
217   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
218     referring to stuff now exported by the IkiWiki module.
219   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
220     to declare which version of the interface your plugin needs.
221   * Anyone with a third-party ikiwiki plugin is strongly encouraged
222     to make like changes to it and avoid use of non-exported symbols from
223     "IkiWiki::".
224   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
225   * Support hyperestradier version 1.4.2, which adds a new required phraseform
226     setting.
227   * If an inlined page has a permalink, link the page title to that.
228   * Patch from Recai to use utf8 when reading the setup file, so that
229     utf8 wikinames from there will be used properly.
230   * Patch from Recai to kill utf-8 on the wiki name when generating the
231     session cookie.
232   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
233   * Fix a baseurl problem in hyperestradier search results.
234   * Add a stub local.css to avoid problems with 404's.
235   * Patch from Recai to fix a wide character warning from the search plugin
236     during setup if the wikiname contains utf8.
237   * Yet another fix for those poor case-insensative OS X users.
238   * pagetemplate hooks are now also called when generating cgi pages.
239   * Add a favicon plugin, which simply adds a link tag for an icon to each
240     page (and cgis).
241   * Patch from James Westby to deal with the case where you're editing a
242     new page, hit cancel, and need to be redirected to somewhere sane.
243   * Various documentation improvements by various wiki users.
244   * Support Text::Markdown from CPAN, which has a different interface from
245     the original markdown or the one in Debian.
246   * Version the libcgi-session-perl dependency, some features that need
247     the new version are used in some cases (sslcookie).
248   * Numerous tla fixes from Clint.
249   * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
250     a multi-resolution favicon.ico.
251   * README.Debian: typo Closes: #388110
252   * chomp trailing newline at the end of templates read in by the template
253     plugin, to allow use of the template preprocessor directive in
254     whitespace-sensative situations. Closes: #387073
255   * Patch from James Westby to make the location of the estseek.cgi script
256     configurable.
257   * Add typography (SmartyPants) plugin by Recai.
258   * Add --render mode, which can be used to preview an edit at the command
259     line by test rendering a single page.
260   * Add a googlecalendar plugin. A bit special-purpose, but it shows
261     one way to to deal with user-supplied content that could cause XSS
262     issues w/o the htmlscrubber, and won't survive the scrubber.
263
264  -- Joey Hess <joeyh@debian.org>  Sun, 24 Sep 2006 00:02:21 -0400
265
266 ikiwiki (1.26) unstable; urgency=low
267
268   * Add a missing -n to tla undo call.
269   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
270     writes before consuming its whole stdin. Avoid this deadlock.
271   * Fix alt tags for outline checkboxes.
272
273  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
274
275 ikiwiki (1.25) unstable; urgency=low
276
277   * Add proper waitpid calls for open2ed processes throughout to avoid
278     zombies; this hit htmltidy especially badly.
279   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
280     subversion repos and fixing some other issues.
281   * Add support for tla, contributed by Clint Adams. Closes: #385936
282   * Add support for mercurial, contributed by Emanuele Aina.
283   * Include <link rel> tag for RSS feeds, used by some aggregators and
284     firefox to find the feed.
285   * Add a linkmap plugin (requires graphviz).
286
287  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
288
289 ikiwiki (1.24) unstable; urgency=low
290
291   * Simplify the data structure returned by rcs_recentchanges to avoid
292     each rcs plugin needing to form complex strings on its own.
293   * Fix another destpage issue in the inline directive. Closes: #385512
294     again.
295
296  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
297
298 ikiwiki (1.23) unstable; urgency=low
299
300   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
301
302  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
303
304 ikiwiki (1.22) unstable; urgency=low
305
306   * Change how the stylesheet url is determined in the templates: Remove
307     STYLEURL and add BASEURL to all templates (some already had it). This
308     new more general variable can be used to link to other things (eg, images)
309     from the template, as well as stylesheets.
310   * Fix a bug introduced last version to do with nested inlines.
311   * Allow preprocessor directives to span multiple lines, both to make
312     long ones with lots of values easier to write, and to allow for ones with
313     multi-line quoted values.
314   * Allow preprocessor directives to contain python-like triple-quoted
315     text blocks, for easy nesting of quotes inside.
316   * Add a template plugin.
317   * Make pagespec merge code smarter about merging duplicate pagespecs.
318   * Patch from Jordà Polo to make Setup::Standard support hashes in config
319     files.
320   * Change order of linkify and preprocess; first preprocess and then linkify.
321     This allows passing a wikilink inside a parameter to a preprocessor
322     directive without it being expanded to html, and leaking out of the
323     parameter, which had required some non-obvious use of triple-quoting
324     to avoid. Note that any preprocessor plugins that output something
325     that looks like a wikilink will now have it treated as such; AFAIK
326     this doesn't change any behavior though except for the template plugin.
327   * Enable preprocessor directives when previewing an edit.
328   * Make all pages pull in a local.css style sheet, if present. This won't
329     be included in ikiwiki, but can be created to make local styling changes
330     w/o needing to merge in every new change to the distributed style.css.
331   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
332   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
333     from a different directory.
334   * Generalised preprocesser loop protection code.
335   * Patch from James Westby to allow a description to be set for rss feeds.
336   * Patch from James Westby to add a template for the search form.
337   * Added a ddate plugin.
338   * Patch from James Westby to add a --sslcookie switch, which forces
339     cookies to only be sent over ssl connections to avoid interception.
340   * Fix preferences page on anonok wikis; still need to sign in to get
341     to the preferences page.
342   * Add toc (table of contents) plugin.
343   * Change htmlize, format, and sanitize hooks to use named parameters.
344   * Patch from James Westby to add an actions option to inline; this
345     adds Edit and Discussion links at the end of blog entries.
346   * Due to some css changes, you'll want to rebuild your wiki on upgrade
347     to this version. Will be handled automatically by the deb.
348   * Add processed date to aggregate preprocessor directive status output.
349
350  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
351
352 ikiwiki (1.21) unstable; urgency=low
353
354   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
355   * If a page links to itself, mark up the link text in a span with
356     class="selflink" so that it can be styled. I don't have a useful style
357     defined for that though.
358   * Call filter hooks on inlined page content.
359   * Support inlining pages raw, rather than creating a blog.
360   * Clean up yes/no parameter parsing in inline plugin.
361   * Implemented better cycle detection in the inline plugin; nested inlines
362     will now work.
363   * Add a map plugin contributed by Alessandro Dotti Contra.
364   * Add otl format plugin, which handles files as created by vimoutliner.
365   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
366   * Add first draft at a Restructured Text (rst) plugin, by Sergio
367     Talens-Oliag. Note that this has many known issues -- see the caveats on
368     the plugin's page.
369   * Credit everyone who wrote a plugin on the plugins' wiki pages.
370   * Fix utf-8 in blog post form.
371
372  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
373
374 ikiwiki (1.20) unstable; urgency=low
375
376   * Relicense the templates and basewiki under the 2-clause BSD license.
377     Since these can easily become part of other people's websites, they
378     should be under as permissive a license as possible.
379   * Add --syslog config option, to log to the syslog.
380   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
381     transient failure to fork (which I've seen happen in the wild).
382   * Fix a bug in the aggregator introduced last version that caused all
383     aggregator state to be lost during a non-aggregating build.
384
385  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
386
387 ikiwiki (1.19) unstable; urgency=low
388
389   * Fix several related bugs in page type determination during online editing.
390   * Add some locking to prevent 2 aggregators from running at once.
391   * Fix an infinite loop in the aggregator when finding a unique filename.
392
393  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
394
395 ikiwiki (1.18) unstable; urgency=low
396
397   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
398   * Add --version.
399   * Man page format fixups.
400   * If the meta plugin overides the page title, set a title_overridden
401     variable in the template to true. This allows doing things with the
402     templates conditional on the title being overriden.
403   * Add a %pagecase which maps lower-case page names to the actual case
404     used in the filename. Use this in bestlinks calculation instead of
405     forcing the link to lowercase.
406   * Also use %pagecase in various other places that want to check if a page
407     with a given name exists.
408   * This means that links to pages with mixed case names will now work,
409     even if the link is in some other case mixture, and mixed case pages
410     should be fully supported throughout ikiwiki.
411   * Recommend rebuilding wikis on upgrade to this version.
412
413  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
414
415 ikiwiki (1.17) unstable; urgency=low
416
417   * Disable tidy generator tag.
418   * Move tidy back to sanitize hook, found out how to only show body.
419   * Turn off tidy indentation too.
420   * Turn on HTML::Template loop_context_vars; not actually used in stock
421     templates but can be useful for things like making comma-delimited lists
422     of tags or what have you.
423   * Remove <br> from end of aggregate preprocessor directive output.
424   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
425     case-sensative filesystems like OSX.
426   * Improve markdown loading. First, try to load it as a proper perl module,
427     in case it was installed as one. Then fall back to trying
428     /usr/bin/markdown.
429   * Document in install page how to install markdown, since it has no
430     installation procedure in the upstream tarball.
431   * Set die_on_bad_params => 0 for all templates, to allow users to modify
432     them without annoyances.
433   * Suck in the page content when generating an inline archive page, to work
434     around the meta plugin's lack of caching of title metadata across runs.
435
436  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
437
438 ikiwiki (1.16) unstable; urgency=low
439
440   * Try to handle relative links in aggregated feeds. However,
441     the current support is a crude hack due to limitations of XML::Feed:
442     xml:base is not supported, neither is Content-Location. And of course,
443     relative links in RSS feeds are ill-undefined..
444   * Make aggregator save permalinks and author name to pages as metadata.
445   * Add permalink and author support to meta plugin, affecting RSS feeds
446     and blog pages.
447   * Various CSS and formatting changes.
448   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
449   * Add xhtml files to the default prune regexp.
450   * Also generate rel=bookmark links for permalinks.
451   * Fix the htmltidy plugin, which wasn't working due my breaking it when
452     I added it..
453   * Don't run tidy with -xml as that fails if the input is not well-formed.
454     Run it with -asxhtml instead, so it will output well-formed xhtml no
455     matter what the input.
456   * Disable tidy warnings too.
457   * Add a new format hook, and make tidy use it, since tidy can really only
458     operate on and output complete html documents, not the body chunks
459     that sanitise gets.
460   * Fix dates in rss feeds if running localised, so they're still rfc 822.
461
462  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
463
464 ikiwiki (1.15) unstable; urgency=low
465
466   * Remove CDPATH and other env vars perl taint checking doesn't like.
467     Closes: #381279
468   * Added created_before and created_after PageSpec limits.
469
470  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
471
472 ikiwiki (1.14) unstable; urgency=low
473
474   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
475     by 10% or so.
476   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
477   * Added many unit tests for pagespec_match.
478
479  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
480
481 ikiwiki (1.13) unstable; urgency=low
482
483   * ikiwiki can now download and aggregate feeds with its new aggregate
484     plugin, so it's possible to implement a Planet using ikiwiki!
485   * Add a run_hooks function for the common task of running all hooks of a
486     given type.
487   * Add a savestate hook.
488   * Don't put blog post forms on pages if there's no cgiurl set.
489   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
490     --wrappers to do that.
491   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
492     to update pages that haven't changed on disk.
493   * Change meta tags to use html entity-escaped text for values, so that
494     quotes and such can be represented in title tags.
495   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
496     for the above.
497   * Make --rebuild also cause --aggregate to re-download and write aggregated
498     pages.
499   * Avoid outputting duplicate meta info.
500   * Include title metadata on aggregated posts for capitalised and un-munged
501     titles.
502   * Title metadata of inlined pages now shows up in blogs and rss feeds.
503   * Fix issue with unicode filenames and updating the hyper estradier search
504     index. (Aka Please Please Please, let that be the last one.)
505   * Patch from Roland Mas to support an rss=no parameter to inline directives.
506     Closes: #380743
507   * Renamed GlobLists to PageSpecs.
508   * PageSpecs can now include nested parens, "and", and "or". This remains
509     backwards compatible to the old GlobList format. It's implemented by
510     treating the GlobList as a very limited microlanguage that is transformed
511     to perl code that does the matching.
512   * The old GlobList format is deprecated, and I encourage users to switch to
513     using the new PageSpec format. Compatability with the old format will be
514     removed at some point, possibly by 2.0.
515   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
516   * Add support for creation_month and creation_year to PageSpec.
517     Closes: #380680
518   * Changes to index file encoding.
519
520  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
521
522 ikiwiki (1.12) unstable; urgency=low
523
524   "Viva l'Italia!"
525   * New pagestats plugin from Enrico, which can generate a table counting
526     the backlinks for each page, or a del.icio.us style cloud.
527   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
528     the wikiformat plugin works. Thanks, Emanuele Aina.
529   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
530     display, running them through pagetitle. This removes ugly underscores and
531     other gunk from the display, much nicer. You may want to rebuild your wiki
532     when upgrading to get the cleanup globally.
533   * Polygen plugin from Enrico.
534   * htmltidy plugin from Faidon.
535   * Locale patch from Faidon:
536     - Adds a locale setting to setup files.
537     - Proper local time, if the locale configuration option is used.
538     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
539       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
540       impossible.
541   * Add getopt hook type, this allows plugins to add new command-line options.
542   * Add --tagbase option to tag plugin.
543   * Add exclude option in setup files, works same as --exclude.
544   * Put categories in rss feeds for tagged items.
545   * Allow preprocessor directives to be expanded in inlined blog pages.
546     However, to avoid inlining loops etc, don't expand inline directives in
547     inlined pages.
548   * fortune plugin (trivial)
549   * Tag plugins according to type.
550
551  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
552
553 ikiwiki (1.11) unstable; urgency=low
554
555   * Patch from Enrico that
556     - Adds a tag plugin that allows more easily tagging pages.
557       The meta plugin can also still be used for that, but the tag plugin
558       also lists a page's tags at the bottom of the page.
559     - Allows preprocessor directives to have parameters with no specified
560       value.
561     - Fixes preprocessor directive parameter parsing so that
562       foo=bar baz now means "foo=bar" and a "baz" with no value.
563   * Run pagetemplate hooks when inlining pages so that inlined pages also
564     list their tags.
565   * Make all plugins with pagetemplate hooks check that variables exist
566     on the template before setting them, for robustness.
567   * Switch pagetemplate hooks to using named parameters.
568   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
569     This will be the page that a source page will be part of, which is
570     different than the source page for inlined pages.
571   * Audited all plugins to endure they pass (page, destpage) to htmllink
572     appropriatly. This means inlining of various plugins will not work
573     properly, with correct links generated.
574
575  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
576
577 ikiwiki (1.10) unstable; urgency=low
578
579   * Run page through any relevant filters when generating a page preview.
580   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
581     default throughout the wiki, not only on wikitext pages. Decided to call
582     this a feature, and split the camelcase support out into a separate plugin
583     that is independant of wikitext.
584   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
585
586  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
587
588 ikiwiki (1.9) unstable; urgency=low
589
590   * Improve display of parentlinks and page title of toplevel index page.
591   * Patch from Faidon to use svn --limit when possible for recentchanges,
592     speeds up recentchanges a lot for wikis with more history.
593   * Patch from Recai to fix utf8 issues in git backend.
594   * Add wikitext markup plugin, which supports ".wiki" pages written in the
595     original wiki syntax, CamelCase links and all.
596   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
597     support, to edit pages etc without a web server.
598   * Display CGI processing errors if present.
599   * Fix from Faidon for a XML parser issue that breaks utf-8 for
600     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
601     area, and also way slow.
602   * Match 'web commit from' in SVN and git, these are web commits too.
603     (Faidon)
604   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
605     readable and avoid future mistakes. The patch seems to work and for the
606     first time I have a UTF-8 username ;-) (Faidon)
607   * Use form->field consistently, not form->param.
608   * Patch from Recai to allow selection of page type when creating a new page.
609     Default page type is inherited from the link clicked on to create the new
610     page.
611
612  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
613
614 ikiwiki (1.8) unstable; urgency=low
615
616   * Fix orphans plugin to not count a link to a nonexistant page as a reason
617     for a page not being an orphan.
618   * Support pinging services such as Technorati using XML-RPC to notify them
619     about changes to rss feeds.
620   * Parse svn log as xml for improved utf8 and security. Note that this makes
621     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
622   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
623     flagged string even if the locale causes it to generate utf8 output,
624     so make sure to let perl know it should be handled as utf8. Also,
625     the optimised version used for standard time formats won't work if the
626     user has changed locale, so drop it. Thanks, Faidon Liambotis.
627   * Fix re-encoding of the comments field to utf8 if a commit fails
628     due to a conflict. Thanks, Faidon Liambotis.
629   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
630     Liambotis.
631   * Add insane double encode/decode to utf8 around call to markdown.
632     This works around a truely strange bug, which is apparently a bug in
633     perl, #376329. Also added a test case for it.
634   * Improve layout of edit page so formatting help link is always visible w/o
635     getting in the way of the preview.
636   * Centralised all calls to HTML::Template and force all the templates
637     to be read as utf8.
638   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
639   * Introduce add_plugins and disable_plugins config options in setup files.
640     This allows adding or removing plugins w/o overriding the whole list of
641     default plugins, which makes it easier to upgrade when new default plugins
642     are added.
643   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
644     default (of course!). Based on a patch by Faidon Liambotis.
645   * Add a html plugin, which can be used to write wikis in raw html,
646     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
647     defaults to not processing .html files, since w/o this plugin they would
648     be copied unsanitised. With this plugin, it will process and html
649     sanitise them, like any other page type.
650   * Rebuilding wrappers is necessary on upgrade to this version.
651   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
652     will be automatically done on all upgrades.
653   * Don't send pings if the wiki is being rebuilt.
654   * Work around very innefficient behavior in File::Spec::abs2rel. Result
655     is a savings of 2 pointless fork/execs per link calculation, which
656     results in ~25% speedup of ikiwiki building its own doc wiki, and
657     about 35% speedup displaying RecentChanges!
658   * Make RecentChanges use a table and some CSS, should be much more readable.
659     No code changes involved.
660   * Encode & in diffurl in examples, to conform to pedantic rules.
661   * Speed up RecentChanges by another 40% or so with some memoization.
662   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
663     in time to build the doc wiki.
664
665  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
666
667 ikiwiki (1.7) unstable; urgency=low
668
669   * Updated logo from Recai with some kerning and alingment tuning.
670   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
671     changed some output.
672   * Copyright update.
673
674  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
675
676 ikiwiki (1.6) unstable; urgency=low
677
678   * YA utf-8 patch from Recai, this time to fix previewing a page so that
679     the text in the input box is re-encoded back to utf-8.
680   * -CSD does not affect modules, so readfile() was not using the utf-8 input
681     layer, which led to lots of problems; make it force read files as utf-8.
682     Closes: #373203
683   * Note that as a consequence, this version of ikiwiki will actually try to
684     parse utf8 in source files for the first time, which may expose broken
685     utf8 in wiki sources that was hidden before. Most common will be
686     perl warnings like "utf8 "\xE9" does not map to Unicode"
687   * writefile() likewise needs to use the utf8 output layer.
688   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
689     there.
690   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
691     given the readfile fix.
692   * Add utf-8 testcases for readfile and htmlize.
693   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
694     safe.
695   * More utf-8 fixes from Recai, partly to things I broke above:
696     - The serious problem is that writefile() saves the content in undecoded
697       format in CGI, hence all (non-ascii) chars are corrupted permanently.
698     - Comment field in edit page is not decoded and all the non-ascii chars in
699       this field are corrupted as the result.  We should decode it as we do it
700       for the content.
701     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
702       character in print.
703   * New SVG logo from Recai.
704
705  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
706
707 ikiwiki (1.5) unstable; urgency=low
708
709   * Add --timeformat config option to allow changing how dates are displayed.
710     Note that as a side effect, dates will now be displayed using the local
711     timezone, not as GMT.
712   * More security review.
713   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
714     for some handy stuff like:
715     - Using links as a kind of tag; creating blog pages that list all pages
716       containing a given tag/link or not containing some other tag.
717     - Subscribing to mail notifications whenever a change is made to a page
718       that is a backlink of page foo. Ie, "Please notify me of changes in all
719       pages that link to my home page in the wiki"
720     - Locking any pages that are linked to from a particular page, so that
721       lists of locks can be exposed in the wiki.
722   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
723     when a todo item is done, instead of the previous moving it to a different
724     subdir.
725   * Allow pagetemplate plugins to override *anything* in the template.
726   * Add a meta plugin, which allows specifying various metadata about pages,
727     like license and author. It also allows for inserting html link and meta
728     tags into html, overriding the title, and adding hidden WikiLinks, which
729     can be useful when using link-based globbing for page categorisation.
730   * Remove preprocessor directives from inlined pages.
731   * Allow simple preprocessor directive values to be specified w/o quotes.
732   * Add support for using git instead of subversion as the RCS backend,
733     tremendous thanks to Recai Oktaş for this.
734   * Doc updates for git.
735   * Fix absolute url munging in rss generation to support https, ftp, etc urls
736     not just http urls.
737   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
738     utf-8 for edit and other fields, and for recentchanges. There may still
739     be utf-8 issues with the preferences page though.
740
741  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
742
743 ikiwiki (1.4) unstable; urgency=low
744
745   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
746     very strange way of enabling proper XHTML <br /> type tags. Output html
747     should be always valid again now.
748   * The page name and parent links has switched from using a <h1> to a styled
749     <span>, so pages can use <h1> internally instead of needing to use <h2>.
750   * Updated all of ikiwiki's own wiki pages for that.
751   * Add pagetemplate hook, which can be used by plugins that want to mess
752     around with adding new stuff to the page template.
753   * Remove headercontent; the search plugin now adds the search box to the
754     header by registering a pagetemplate hook, and other plugins should do
755     similarly.
756   * Rebuilding on upgrade to this version is recommended.
757   * Add a html validity check to the test suite, using the wdg-html-validator,
758     if available.
759   * Make the html valid when there is nothing in the actions list.
760   * Reordered some function call parameters for consistency.
761   * Enable full utf-8 support for page input and output.
762   * Add a workaround for markdown, which does not work well with utf-8
763     strings.
764   * --getctime had bitrotted (well I only ever used it the once so far..),
765     fix and make it a bit more flexible
766   * rcs_getctime is changed, now rather than needing to loop over all pages,
767     it should just use the rcs to get the ctime of the passed file.
768   * When inlining a page in another one, links from the inlined page are now
769     expanded the same as they are when rendering the inlined page as a
770     standalone page. So rather than being expanded from the POV of the
771     inlining page, they are expanded from the POV of the inlined page.
772
773     For example, a link from blog/foo to "bar" will now link to blog/bar
774     if it exists. Previously this needed to be a link explicitly to
775     "blog/bar"; such links will also continue to work.
776
777     (This was slightly complex to do as the link still has to be constructed
778     relative to the inlining page.)
779   * Make page edit textarea resize to fit browser window.
780   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
781     do not need a full rebuild, in order to update any basewiki pages.
782
783  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
784
785 ikiwiki (1.3) unstable; urgency=low
786
787   * Fix the preinst introduced in the last version. Closes: #367458
788
789  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
790
791 ikiwiki (1.2) unstable; urgency=low
792
793   * Remove dups from the brokenlinks list.
794   * Add libc6-dev to dependencies, needed to build wrappers.
795   * Install wikilist in correct location. Closes: #367371
796
797  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
798
799 ikiwiki (1.1) unstable; urgency=low
800
801   * Rename inlinepage to depends, so that it can be used to refer to more
802     dependency relationships than just inlining. This will require a rebuild
803     on upgrade to this version.
804   * Move the rss link, put it in the blogpost form if there is one and at the
805     top if not. This is both nicer because easier to find, and it cleans up
806     the code which had used inlinepage as a flag for adding the link later.
807   * Allow the depends GlobList to be built up from multiple sources (such as
808     plugins) during a page render.
809   * Which means that more than one blog is now supported to appear on a
810     single page. (With some limitations, like only the last one getting an
811     rss file.)
812   * Added a plugin system.
813   * Added a pagecount plugin, enabled by default.
814   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
815   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
816     backlinks when the backlinks hadn't really changed.
817   * Moved inline page support, rss generation etc into the inline plugin,
818     enabled by default.
819   * Added brokenlinks plugin, not enabled by default, but rather handy.
820   * Fix several broken links in the doc wiki.
821   * Smarter behavior when creating a page and a page of the same name (but
822     different location) already exists.
823   * Add an orphans plugin for finding pages that nothing links to.
824   * Removed backlinks page, which it turns out nothing used.
825   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
826     it, this will allow for adding a unit test suite.
827   * Add unit tests for several core functions, including globlist_match,
828     dirname, basename, bestlink, linkify, pagetitle, titlepage.
829   * Smart globlist merging.
830   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
831     to pave the way for adding other RCS support. This also changes the
832     setup files, where before they had svn => 1 or svn => 0, now they have
833     rcs => "svn" or rcs => "".
834   * Add a debian/NEWS file with upgrade notes.
835   * Load whatever rcs module is specified, so new ones can be just dropped in
836     as plugins and work. (Well, in theory.)
837   * Add some basic docs about writing RCS modules.
838   * Broke search capability out into a plugin, removed the --hyperestraier
839     switch.
840   * Added smiley plugin, nicely controlled and documented by the smileys page.
841   * Copied in some smileys from Moin Moin.
842   * Allow links of the form [[some page|page]], with whitespace in the link
843     text.
844   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
845     and --disable-plugin htmlscrubber.
846   * Allow discussion links on pages to be turned off with --no-discussion.
847   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
848   * Add some new config items to the estseek.conf template, which are needed
849     by hyperestraier 1.2.3.
850
851  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
852
853 ikiwiki (1.0) unstable; urgency=low
854
855   * First official release.
856
857  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400