Provide stub for SetupDiGetClassDevsW.
[wine] / dlls / wsock32 / wsock32.spec
index ed3dc93..2bcca47 100644 (file)
@@ -1,11 +1,3 @@
-name   wsock32
-type   win32
-
-import ws2_32.dll
-import ntdll.dll
-
-debug_channels (winsock)
-
   1 forward accept ws2_32.accept
   2 forward bind ws2_32.bind
   3 forward closesocket ws2_32.closesocket
@@ -35,7 +27,7 @@ debug_channels (winsock)
  54 forward getprotobynumber ws2_32.getprotobynumber
  55 forward getservbyname ws2_32.getservbyname
  56 forward getservbyport ws2_32.getservbyport
- 57 forward gethostname ws2_32.gethostname
+ 57 forward -noimport gethostname ws2_32.gethostname
 101 forward WSAAsyncSelect ws2_32.WSAAsyncSelect
 102 forward WSAAsyncGetHostByAddr ws2_32.WSAAsyncGetHostByAddr
 103 forward WSAAsyncGetHostByName ws2_32.WSAAsyncGetHostByName
@@ -59,19 +51,19 @@ debug_channels (winsock)
 # ... as it is, they don't
 #1000 stub WSApSetPostRoutine
 1001 stdcall WsControl(long long ptr ptr ptr ptr) WsControl
-1100 stdcall inet_network(str) inet_network
-1101 stdcall getnetbyname(str) getnetbyname
+1100 stdcall inet_network(str) WSOCK32_inet_network
+1101 stdcall getnetbyname(str) WSOCK32_getnetbyname
 #1102 stub rcmd
 #1103 stub rexec
 #1104 stub rresvport
 #1105 stub sethostname
 #1106 stub dn_expand
 1107 stdcall WSARecvEx(long ptr long ptr) WSARecvEx
-1108 stdcall s_perror(str) WS_s_perror
+1108 stdcall s_perror(str) s_perror
 1109 stub GetAddressByNameA
 1110 stub GetAddressByNameW
-#1111 stub EnumProtocolsA
-#1112 stub EnumProtocolsW
+1111 stdcall EnumProtocolsA(ptr ptr ptr) EnumProtocolsA
+1112 stdcall EnumProtocolsW(ptr ptr ptr) EnumProtocolsW
 #1113 stub GetTypeByNameA
 #1114 stub GetTypeByNameW
 #1115 stub GetNameByTypeA