@ cdecl _Strftime(str long str ptr ptr)
@ cdecl _XcptFilter(long ptr)
@ cdecl -i386 -norelay __CxxFrameHandler(ptr ptr ptr ptr)
-@ stub __CxxLongjmpUnwind #(ptr) stdcall
+@ stdcall -i386 __CxxLongjmpUnwind(ptr)
@ cdecl __RTCastToVoid(ptr) MSVCRT___RTCastToVoid
@ cdecl __RTDynamicCast(ptr long ptr ptr long) MSVCRT___RTDynamicCast
@ cdecl __RTtypeid(ptr) MSVCRT___RTtypeid
@ cdecl __dllonexit(ptr ptr ptr)
@ cdecl __doserrno() MSVCRT___doserrno
@ cdecl __fpecode()
+@ stub __get_app_type
@ cdecl __getmainargs(ptr ptr ptr long ptr)
@ extern __initenv MSVCRT___initenv
@ cdecl __isascii(long) MSVCRT___isascii
@ cdecl __iscsym(long) MSVCRT___iscsym
@ cdecl __iscsymf(long) MSVCRT___iscsymf
-# extern __lc_codepage
+@ extern __lc_codepage MSVCRT___lc_codepage
@ stub __lc_collate
-# extern __lc_handle
+@ extern __lc_collate_cp MSVCRT___lc_collate_cp
+@ extern __lc_handle MSVCRT___lc_handle
@ cdecl __lconv_init()
@ extern __mb_cur_max MSVCRT___mb_cur_max
@ cdecl __p___argc()
@ cdecl _assert(str str long) MSVCRT__assert
@ stub _atodbl #(ptr str)
@ cdecl -ret64 _atoi64(str) ntdll._atoi64
-@ stub _atoldbl #(ptr str)
+@ cdecl _atoldbl(ptr str) MSVCRT__atoldbl
@ cdecl _beep(long long)
@ cdecl _beginthread (ptr long ptr)
@ cdecl _beginthreadex (ptr long ptr ptr long ptr)
@ varargs _execlp(str str)
@ varargs _execlpe(str str)
@ cdecl _execv(str str)
-@ cdecl _execve(str str str)
+@ cdecl _execve(str str str) MSVCRT__execve
@ cdecl _execvp(str str)
@ cdecl _execvpe(str str str)
@ cdecl _exit(long) MSVCRT__exit
@ cdecl _fputwchar(long)
@ cdecl _fsopen(str str long) MSVCRT__fsopen
@ cdecl _fstat(long ptr) MSVCRT__fstat
+@ stub _fstat64
@ cdecl _fstati64(long ptr) MSVCRT__fstati64
@ cdecl _ftime(ptr)
@ cdecl -ret64 _ftol() ntdll._ftol
@ cdecl _gcvt(double long str)
@ cdecl _get_osfhandle(long)
@ cdecl _get_sbh_threshold()
+@ stub _get_terminate
+@ stub _get_unexpected
@ cdecl _getch()
@ cdecl _getche()
@ cdecl _getcwd(str long)
@ cdecl _getdllprocaddr(long str long)
@ cdecl _getdrive()
@ cdecl _getdrives() kernel32.GetLogicalDrives
-@ stub _getmaxstdio #()
+@ cdecl _getmaxstdio()
@ cdecl _getmbcp()
@ cdecl _getpid() kernel32.GetCurrentProcessId
@ stub _getsystime #(ptr)
@ cdecl _heapset(long)
@ stub _heapused #(ptr ptr)
@ cdecl _heapwalk(ptr)
-@ cdecl _hypot(double double) hypot
+@ cdecl _hypot(double double)
@ cdecl _i64toa(long long ptr long) ntdll._i64toa
@ cdecl _i64tow(long long ptr long) ntdll._i64tow
@ cdecl _initterm(ptr ptr)
@ cdecl _isnan( double )
@ cdecl _itoa(long ptr long) ntdll._itoa
@ cdecl _itow(long ptr long) ntdll._itow
-@ cdecl _j0(double) j0
-@ cdecl _j1(double) j1
-@ cdecl _jn(long double) jn
+@ cdecl _j0(double)
+@ cdecl _j1(double)
+@ cdecl _jn(long double)
@ cdecl _kbhit()
@ cdecl _lfind(ptr ptr ptr long ptr)
@ cdecl _loaddll(str)
@ cdecl _mbctoupper(long)
@ extern _mbctype MSVCRT_mbctype
@ stub _mbsbtype #(str long)
-@ cdecl _mbscat(str str) strcat
+@ cdecl _mbscat(str str)
@ cdecl _mbschr(str long)
@ cdecl _mbscmp(str str)
@ cdecl _mbscoll(str str)
-@ cdecl _mbscpy(ptr str) strcpy
+@ cdecl _mbscpy(ptr str)
@ cdecl _mbscspn (str str)
@ cdecl _mbsdec(ptr ptr)
@ cdecl _mbsdup(str) _strdup
@ cdecl _mbsrev(str)
@ cdecl _mbsset(str long)
@ cdecl _mbsspn(str str)
-@ stub _mbsspnp #(str str)
-@ cdecl _mbsstr(str str) strstr
+@ cdecl _mbsspnp(str str)
+@ cdecl _mbsstr(str str)
@ cdecl _mbstok(str str)
@ cdecl _mbstrlen(str)
@ cdecl _mbsupr(str)
-@ cdecl _memccpy(ptr ptr long long) memccpy
+@ cdecl _memccpy(ptr ptr long long) ntdll._memccpy
@ cdecl _memicmp(str str long) ntdll._memicmp
@ cdecl _mkdir(str)
@ cdecl _mktemp(str)
@ cdecl _seterrormode(long)
@ cdecl -i386 -norelay _setjmp(ptr) MSVCRT__setjmp
@ cdecl -i386 -norelay _setjmp3(ptr long) MSVCRT__setjmp3
-@ stub _setmaxstdio #(long)
+@ cdecl _setmaxstdio(long)
@ cdecl _setmbcp(long)
@ cdecl _setmode(long long)
@ stub _setsystime #(ptr long)
@ cdecl _sleep(long)
-@ varargs _snprintf(str long str) snprintf
-@ varargs _snwprintf(wstr long wstr) ntdll._snwprintf
+@ varargs _snprintf(str long str) MSVCRT__snprintf
+@ varargs _snwprintf(wstr long wstr) MSVCRT__snwprintf
@ varargs _sopen(str long long) MSVCRT__sopen
@ varargs _spawnl(long str str)
@ varargs _spawnle(long str str)
@ cdecl _spawnvpe(long str ptr ptr)
@ cdecl _splitpath(str ptr ptr ptr ptr) ntdll._splitpath
@ cdecl _stat(str ptr) MSVCRT__stat
+@ stub _stat64
@ cdecl _stati64(str ptr) MSVCRT__stati64
@ cdecl _statusfp()
-@ cdecl _strcmpi(str str) strcasecmp
+@ cdecl _strcmpi(str str) ntdll._strcmpi
@ cdecl _strdate(ptr)
@ cdecl _strdup(str)
@ cdecl _strerror(long)
-@ cdecl _stricmp(str str) strcasecmp
+@ cdecl _stricmp(str str) ntdll._stricmp
@ cdecl _stricoll(str str) MSVCRT__stricoll
@ cdecl _strlwr(str) ntdll._strlwr
@ stub _strncoll #(str str long)
-@ cdecl _strnicmp(str str long) strncasecmp
+@ cdecl _strnicmp(str str long) ntdll._strnicmp
@ stub _strnicoll #(str str long)
@ cdecl _strnset(str long long)
@ cdecl _strrev(str)
@ cdecl _write(long ptr long)
@ cdecl _wrmdir(wstr)
@ stub _wsearchenv #(wstr wstr ptr)
-@ stub _wsetlocale #(long wstr)
+@ cdecl _wsetlocale(long wstr) MSVCRT__wsetlocale
@ varargs _wsopen (wstr long long) MSVCRT__wsopen
@ stub _wspawnl #(long wstr wstr) varargs
@ stub _wspawnle #(long wstr wstr) varargs
@ cdecl _y1(double)
@ cdecl _yn(long double )
@ cdecl abort() MSVCRT_abort
-@ cdecl abs(long)
-@ cdecl acos(double)
+@ cdecl abs(long) ntdll.abs
+@ cdecl acos(double) MSVCRT_acos
@ cdecl asctime(ptr) MSVCRT_asctime
-@ cdecl asin(double)
-@ cdecl atan(double)
-@ cdecl atan2(double double)
+@ cdecl asin(double) MSVCRT_asin
+@ cdecl atan(double) MSVCRT_atan
+@ cdecl atan2(double double) MSVCRT_atan2
@ cdecl atexit(ptr) MSVCRT_atexit
-@ cdecl atof(str)
-@ cdecl atoi(str)
-@ cdecl atol(str)
-@ cdecl bsearch(ptr ptr long long ptr)
+@ cdecl atof(str) MSVCRT_atof
+@ cdecl atoi(str) ntdll.atoi
+@ cdecl atol(str) ntdll.atol
+@ cdecl bsearch(ptr ptr long long ptr) ntdll.bsearch
@ cdecl calloc(long long) MSVCRT_calloc
-@ cdecl ceil(double)
+@ cdecl ceil(double) MSVCRT_ceil
@ cdecl clearerr(ptr) MSVCRT_clearerr
@ cdecl clock() MSVCRT_clock
-@ cdecl cos(double)
-@ cdecl cosh(double)
+@ cdecl cos(double) MSVCRT_cos
+@ cdecl cosh(double) MSVCRT_cosh
@ cdecl ctime(ptr) MSVCRT_ctime
@ cdecl difftime(long long) MSVCRT_difftime
@ cdecl div(long long) MSVCRT_div
@ cdecl exit(long) MSVCRT_exit
-@ cdecl exp(double)
-@ cdecl fabs(double)
+@ cdecl exp(double) MSVCRT_exp
+@ cdecl fabs(double) MSVCRT_fabs
@ cdecl fclose(ptr) MSVCRT_fclose
@ cdecl feof(ptr) MSVCRT_feof
@ cdecl ferror(ptr) MSVCRT_ferror
@ cdecl fgets(ptr long ptr) MSVCRT_fgets
@ cdecl fgetwc(ptr) MSVCRT_fgetwc
@ cdecl fgetws(ptr long ptr) MSVCRT_fgetws
-@ cdecl floor(double)
-@ cdecl fmod(double double)
+@ cdecl floor(double) MSVCRT_floor
+@ cdecl fmod(double double) MSVCRT_fmod
@ cdecl fopen(str str) MSVCRT_fopen
@ varargs fprintf(ptr str) MSVCRT_fprintf
@ cdecl fputc(long ptr) MSVCRT_fputc
@ cdecl fread(ptr long long ptr) MSVCRT_fread
@ cdecl free(ptr) MSVCRT_free
@ cdecl freopen(str str ptr) MSVCRT_freopen
-@ cdecl frexp(double ptr)
+@ cdecl frexp(double ptr) MSVCRT_frexp
@ varargs fscanf(ptr str) MSVCRT_fscanf
@ cdecl fseek(ptr long long) MSVCRT_fseek
@ cdecl fsetpos(ptr ptr) MSVCRT_fsetpos
@ cdecl iswupper(long) MSVCRT_iswupper
@ cdecl iswxdigit(long) MSVCRT_iswxdigit
@ cdecl isxdigit(long) MSVCRT_isxdigit
-@ cdecl labs(long)
+@ cdecl labs(long) ntdll.labs
@ cdecl ldexp( double long) MSVCRT_ldexp
@ cdecl ldiv(long long) MSVCRT_ldiv
@ cdecl localeconv() MSVCRT_localeconv
@ cdecl localtime(ptr) MSVCRT_localtime
-@ cdecl log(double)
-@ cdecl log10(double)
+@ cdecl log(double) MSVCRT_log
+@ cdecl log10(double) MSVCRT_log10
@ cdecl -i386 longjmp(ptr long) MSVCRT_longjmp
@ cdecl malloc(long) MSVCRT_malloc
@ cdecl mblen(ptr long) MSVCRT_mblen
@ cdecl mbstowcs(ptr str long) ntdll.mbstowcs
@ cdecl mbtowc(wstr str long) MSVCRT_mbtowc
-@ cdecl memchr(ptr long long)
-@ cdecl memcmp(ptr ptr long)
-@ cdecl memcpy(ptr ptr long) memmove
-@ cdecl memmove(ptr ptr long)
-@ cdecl memset(ptr long long)
+@ cdecl memchr(ptr long long) ntdll.memchr
+@ cdecl memcmp(ptr ptr long) ntdll.memcmp
+@ cdecl memcpy(ptr ptr long) ntdll.memcpy
+@ cdecl memmove(ptr ptr long) ntdll.memmove
+@ cdecl memset(ptr long long) ntdll.memset
@ cdecl mktime(ptr) MSVCRT_mktime
-@ cdecl modf(double ptr)
+@ cdecl modf(double ptr) MSVCRT_modf
@ cdecl perror(str) MSVCRT_perror
-@ cdecl pow(double double)
+@ cdecl pow(double double) MSVCRT_pow
@ varargs printf(str) MSVCRT_printf
@ cdecl putc(long ptr) MSVCRT_putc
@ cdecl putchar(long) MSVCRT_putchar
@ cdecl puts(str) MSVCRT_puts
@ cdecl putwc(long ptr) MSVCRT_fputwc
@ cdecl putwchar(long) _fputwchar
-@ cdecl qsort(ptr long long ptr)
+@ cdecl qsort(ptr long long ptr) ntdll.qsort
@ stub raise #(long)
@ cdecl rand() MSVCRT_rand
@ cdecl realloc(ptr long) MSVCRT_realloc
@ cdecl setlocale(long str) MSVCRT_setlocale
@ cdecl setvbuf(ptr str long long) MSVCRT_setvbuf
@ cdecl signal(long long) MSVCRT_signal
-@ cdecl sin(double)
-@ cdecl sinh(double)
+@ cdecl sin(double) MSVCRT_sin
+@ cdecl sinh(double) MSVCRT_sinh
@ varargs sprintf(ptr str) MSVCRT_sprintf
-@ cdecl sqrt(double)
+@ cdecl sqrt(double) MSVCRT_sqrt
@ cdecl srand(long) MSVCRT_srand
@ varargs sscanf(str str) MSVCRT_sscanf
-@ cdecl strcat(str str)
-@ cdecl strchr(str long)
-@ cdecl strcmp(str str)
-@ cdecl strcoll(str str)
-@ cdecl strcpy(ptr str)
-@ cdecl strcspn(str str)
+@ cdecl strcat(str str) ntdll.strcat
+@ cdecl strchr(str long) ntdll.strchr
+@ cdecl strcmp(str str) ntdll.strcmp
+@ cdecl strcoll(str str) MSVCRT_strcoll
+@ cdecl strcpy(ptr str) ntdll.strcpy
+@ cdecl strcspn(str str) ntdll.strcspn
@ cdecl strerror(long) MSVCRT_strerror
@ cdecl strftime(str long str ptr) MSVCRT_strftime
-@ cdecl strlen(str)
-@ cdecl strncat(str str long)
-@ cdecl strncmp(str str long)
-@ cdecl strncpy(ptr str long)
-@ cdecl strpbrk(str str)
-@ cdecl strrchr(str long)
-@ cdecl strspn(str str)
-@ cdecl strstr(str str)
-@ cdecl strtod(str ptr)
+@ cdecl strlen(str) ntdll.strlen
+@ cdecl strncat(str str long) ntdll.strncat
+@ cdecl strncmp(str str long) ntdll.strncmp
+@ cdecl strncpy(ptr str long) ntdll.strncpy
+@ cdecl strpbrk(str str) ntdll.strpbrk
+@ cdecl strrchr(str long) ntdll.strrchr
+@ cdecl strspn(str str) ntdll.strspn
+@ cdecl strstr(str str) ntdll.strstr
+@ cdecl strtod(str ptr) MSVCRT_strtod
@ cdecl strtok(str str) MSVCRT_strtok
-@ cdecl strtol(str ptr long)
-@ cdecl strtoul(str ptr long)
-@ cdecl strxfrm(ptr str long)
+@ cdecl strtol(str ptr long) ntdll.strtol
+@ cdecl strtoul(str ptr long) ntdll.strtoul
+@ cdecl strxfrm(ptr str long) MSVCRT_strxfrm
@ varargs swprintf(wstr wstr) MSVCRT_swprintf
@ varargs swscanf(wstr wstr) MSVCRT_swscanf
@ cdecl system(str) MSVCRT_system
-@ cdecl tan(double)
-@ cdecl tanh(double)
+@ cdecl tan(double) MSVCRT_tan
+@ cdecl tanh(double) MSVCRT_tanh
@ cdecl time(ptr) MSVCRT_time
@ cdecl tmpfile() MSVCRT_tmpfile
@ cdecl tmpnam(ptr) MSVCRT_tmpnam
-@ cdecl tolower(long)
-@ cdecl toupper(long)
+@ cdecl tolower(long) ntdll.tolower
+@ cdecl toupper(long) ntdll.toupper
@ cdecl towlower(long) ntdll.towlower
@ cdecl towupper(long) ntdll.towupper
@ cdecl ungetc(long ptr) MSVCRT_ungetc
@ cdecl vfprintf(ptr str long) MSVCRT_vfprintf
@ cdecl vfwprintf(ptr wstr long) MSVCRT_vfwprintf
@ cdecl vprintf(str long) MSVCRT_vprintf
-@ cdecl vsprintf(ptr str ptr)
+@ cdecl vsprintf(ptr str ptr) MSVCRT_vsprintf
@ cdecl vswprintf(ptr wstr long) MSVCRT_vswprintf
@ cdecl vwprintf(wstr long) MSVCRT_vwprintf
@ cdecl wcscat(wstr wstr) ntdll.wcscat
@ cdecl wcscoll(wstr wstr) MSVCRT_wcscoll
@ cdecl wcscpy(ptr wstr) ntdll.wcscpy
@ cdecl wcscspn(wstr wstr) ntdll.wcscspn
-@ stub wcsftime #(ptr long wstr ptr) MSVCRT_wcsftime
+@ cdecl wcsftime(ptr long wstr ptr) MSVCRT_wcsftime
@ cdecl wcslen(wstr) ntdll.wcslen
@ cdecl wcsncat(wstr wstr long) ntdll.wcsncat
@ cdecl wcsncmp(wstr wstr long) ntdll.wcsncmp
@ cdecl wctomb(ptr long) MSVCRT_wctomb
@ varargs wprintf(wstr) MSVCRT_wprintf
@ varargs wscanf(wstr) MSVCRT_wscanf
-# extern __lc_collate_cp