* Memoize abs2rel, which is still kinda slow, for another 30% speedup
[ikiwiki] / debian / changelog
1 ikiwiki (1.8) UNRELEASED; urgency=low
2
3   * Fix orphans plugin to not count a link to a nonexistant page as a reason
4     for a page not being an orphan.
5   * Support pinging services such as Technorati using XML-RPC to notify them
6     about changes to rss feeds.
7   * Parse svn log as xml for improved utf8 and security. Note that this makes
8     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
9   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
10     flagged string even if the locale causes it to generate utf8 output,
11     so make sure to let perl know it should be handled as utf8. Also,
12     the optimised version used for standard time formats won't work if the
13     user has changed locale, so drop it. Thanks, Faidon Liambotis.
14   * Fix re-encoding of the comments field to utf8 if a commit fails
15     due to a conflict. Thanks, Faidon Liambotis.
16   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
17     Liambotis.
18   * Add insane double encode/decode to utf8 around call to markdown.
19     This works around a truely strange bug, which is apparently a bug in
20     perl, #376329. Also added a test case for it.
21   * Improve layout of edit page so formatting help link is always visible w/o
22     getting in the way of the preview.
23   * Centralised all calls to HTML::Template and force all the templates
24     to be read as utf8.
25   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
26   * Introduce add_plugins and disable_plugins config options in setup files.
27     This allows adding or removing plugins w/o overriding the whole list of
28     default plugins, which makes it easier to upgrade when new default plugins
29     are added.
30   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
31     default (of course!). Based on a patch by Faidon Liambotis.
32   * Add a html plugin, which can be used to write wikis in raw html,
33     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
34     defaults to not processing .html files, since w/o this plugin they would
35     be copied unsanitised. With this plugin, it will process and html
36     sanitise them, like any other page type.
37   * Rebuilding wrappers is necessary on upgrade to this version.
38   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
39     will be automatically done on all upgrades.
40   * Don't send pings if the wiki is being rebuilt.
41   * Work around very innefficient behavior in File::Spec::abs2rel. Result
42     is a savings of 2 pointless fork/execs per link calculation, which
43     results in ~25% speedup of ikiwiki building its own doc wiki, and
44     about 35% speedup displaying RecentChanges!
45   * Make RecentChanges use a table and some CSS, should be much more readable.
46     No code changes involved.
47   * Encode & in diffurl in examples, to conform to pedantic rules.
48   * Speed up RecentChanges by another 40% or so with some memoization.
49   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
50     in time to build the doc wiki.
51
52  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:22:57 -0400
53
54 ikiwiki (1.7) unstable; urgency=low
55
56   * Updated logo from Recai with some kerning and alingment tuning.
57   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
58     changed some output.
59   * Copyright update.
60
61  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
62
63 ikiwiki (1.6) unstable; urgency=low
64
65   * YA utf-8 patch from Recai, this time to fix previewing a page so that
66     the text in the input box is re-encoded back to utf-8.
67   * -CSD does not affect modules, so readfile() was not using the utf-8 input
68     layer, which led to lots of problems; make it force read files as utf-8.
69     Closes: #373203
70   * Note that as a consequence, this version of ikiwiki will actually try to
71     parse utf8 in source files for the first time, which may expose broken
72     utf8 in wiki sources that was hidden before. Most common will be
73     perl warnings like "utf8 "\xE9" does not map to Unicode"
74   * writefile() likewise needs to use the utf8 output layer.
75   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
76     there.
77   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
78     given the readfile fix.
79   * Add utf-8 testcases for readfile and htmlize.
80   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
81     safe.
82   * More utf-8 fixes from Recai, partly to things I broke above:
83     - The serious problem is that writefile() saves the content in undecoded
84       format in CGI, hence all (non-ascii) chars are corrupted permanently.
85     - Comment field in edit page is not decoded and all the non-ascii chars in
86       this field are corrupted as the result.  We should decode it as we do it
87       for the content.
88     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
89       character in print.
90   * New SVG logo from Recai.
91
92  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
93
94 ikiwiki (1.5) unstable; urgency=low
95
96   * Add --timeformat config option to allow changing how dates are displayed.
97     Note that as a side effect, dates will now be displayed using the local
98     timezone, not as GMT.
99   * More security review.
100   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
101     for some handy stuff like:
102     - Using links as a kind of tag; creating blog pages that list all pages
103       containing a given tag/link or not containing some other tag.
104     - Subscribing to mail notifications whenever a change is made to a page
105       that is a backlink of page foo. Ie, "Please notify me of changes in all
106       pages that link to my home page in the wiki"
107     - Locking any pages that are linked to from a particular page, so that
108       lists of locks can be exposed in the wiki.
109   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
110     when a todo item is done, instead of the previous moving it to a different
111     subdir.
112   * Allow pagetemplate plugins to override *anything* in the template.
113   * Add a meta plugin, which allows specifying various metadata about pages,
114     like license and author. It also allows for inserting html link and meta
115     tags into html, overriding the title, and adding hidden WikiLinks, which
116     can be useful when using link-based globbing for page categorisation.
117   * Remove preprocessor directives from inlined pages.
118   * Allow simple preprocessor directive values to be specified w/o quotes.
119   * Add support for using git instead of subversion as the RCS backend,
120     tremendous thanks to Recai Oktaş for this.
121   * Doc updates for git.
122   * Fix absolute url munging in rss generation to support https, ftp, etc urls
123     not just http urls.
124   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
125     utf-8 for edit and other fields, and for recentchanges. There may still
126     be utf-8 issues with the preferences page though.
127
128  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
129
130 ikiwiki (1.4) unstable; urgency=low
131
132   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
133     very strange way of enabling proper XHTML <br /> type tags. Output html
134     should be always valid again now.
135   * The page name and parent links has switched from using a <h1> to a styled
136     <span>, so pages can use <h1> internally instead of needing to use <h2>.
137   * Updated all of ikiwiki's own wiki pages for that.
138   * Add pagetemplate hook, which can be used by plugins that want to mess
139     around with adding new stuff to the page template.
140   * Remove headercontent; the search plugin now adds the search box to the
141     header by registering a pagetemplate hook, and other plugins should do
142     similarly.
143   * Rebuilding on upgrade to this version is recommended.
144   * Add a html validity check to the test suite, using the wdg-html-validator,
145     if available.
146   * Make the html valid when there is nothing in the actions list.
147   * Reordered some function call parameters for consistency.
148   * Enable full utf-8 support for page input and output.
149   * Add a workaround for markdown, which does not work well with utf-8
150     strings.
151   * --getctime had bitrotted (well I only ever used it the once so far..),
152     fix and make it a bit more flexible
153   * rcs_getctime is changed, now rather than needing to loop over all pages,
154     it should just use the rcs to get the ctime of the passed file.
155   * When inlining a page in another one, links from the inlined page are now
156     expanded the same as they are when rendering the inlined page as a
157     standalone page. So rather than being expanded from the POV of the
158     inlining page, they are expanded from the POV of the inlined page.
159
160     For example, a link from blog/foo to "bar" will now link to blog/bar
161     if it exists. Previously this needed to be a link explicitly to
162     "blog/bar"; such links will also continue to work.
163
164     (This was slightly complex to do as the link still has to be constructed
165     relative to the inlining page.)
166   * Make page edit textarea resize to fit browser window.
167   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
168     do not need a full rebuild, in order to update any basewiki pages.
169
170  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
171
172 ikiwiki (1.3) unstable; urgency=low
173
174   * Fix the preinst introduced in the last version. Closes: #367458
175
176  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
177
178 ikiwiki (1.2) unstable; urgency=low
179
180   * Remove dups from the brokenlinks list.
181   * Add libc6-dev to dependencies, needed to build wrappers.
182   * Install wikilist in correct location. Closes: #367371
183
184  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
185
186 ikiwiki (1.1) unstable; urgency=low
187
188   * Rename inlinepage to depends, so that it can be used to refer to more
189     dependency relationships than just inlining. This will require a rebuild
190     on upgrade to this version.
191   * Move the rss link, put it in the blogpost form if there is one and at the
192     top if not. This is both nicer because easier to find, and it cleans up
193     the code which had used inlinepage as a flag for adding the link later.
194   * Allow the depends GlobList to be built up from multiple sources (such as
195     plugins) during a page render.
196   * Which means that more than one blog is now supported to appear on a
197     single page. (With some limitations, like only the last one getting an
198     rss file.)
199   * Added a plugin system.
200   * Added a pagecount plugin, enabled by default.
201   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
202   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
203     backlinks when the backlinks hadn't really changed.
204   * Moved inline page support, rss generation etc into the inline plugin,
205     enabled by default.
206   * Added brokenlinks plugin, not enabled by default, but rather handy.
207   * Fix several broken links in the doc wiki.
208   * Smarter behavior when creating a page and a page of the same name (but
209     different location) already exists.
210   * Add an orphans plugin for finding pages that nothing links to.
211   * Removed backlinks page, which it turns out nothing used.
212   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
213     it, this will allow for adding a unit test suite.
214   * Add unit tests for several core functions, including globlist_match,
215     dirname, basename, bestlink, linkify, pagetitle, titlepage.
216   * Smart globlist merging.
217   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
218     to pave the way for adding other RCS support. This also changes the
219     setup files, where before they had svn => 1 or svn => 0, now they have
220     rcs => "svn" or rcs => "".
221   * Add a debian/NEWS file with upgrade notes.
222   * Load whatever rcs module is specified, so new ones can be just dropped in
223     as plugins and work. (Well, in theory.)
224   * Add some basic docs about writing RCS modules.
225   * Broke search capability out into a plugin, removed the --hyperestraier
226     switch.
227   * Added smiley plugin, nicely controlled and documented by the smileys page.
228   * Copied in some smileys from Moin Moin.
229   * Allow links of the form [[some page|page]], with whitespace in the link
230     text.
231   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
232     and --disable-plugin htmlscrubber.
233   * Allow discussion links on pages to be turned off with --no-discussion.
234   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
235   * Add some new config items to the estseek.conf template, which are needed
236     by hyperestraier 1.2.3.
237
238  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
239
240 ikiwiki (1.0) unstable; urgency=low
241
242   * First official release.
243
244  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400