updates
[ikiwiki] / debian / changelog
1 ikiwiki (1.34) UNRELEASED; urgency=low
2
3   * Add an openid plugin to support logging in using OpenID.
4   * Web commits by OpenID users will record the full OpenID url for the user,
5     but in recentchanges, these urls will be converted to a simplified display
6     form+link.
7   * Modified svn, git, tla backends to recognise such web commits.
8   * Move httpauth support to a plugin.
9   * Add openidsignup config option.
10   * Make the openid plugin support the callbacks from myopenid.com via its
11     affiliate program.
12   * Add toggle plugin.
13   * Introduce the goodstuff bundle. This is a kind of plugin, that just enables
14     many other plugins. It's an easy way to boost ikiwiki from its default,
15     basic wiki, to a full-featured wiki, without manually picking the right
16     set of plugins. New plugins will be added to goodstuff from time to
17     time.
18   * Change how post signin actions are propigated through the signin process;
19     they're now stored in the session.
20   * Add optional "desc" parameter to shortcut definitions.
21   * Avoid locking the wiki at all when handling some basic cgi stuff
22     (searches, recentchanges).
23   * Add "last" parameter to hook function. Very basic ordering, and hopefully
24     nothing more spohisticated will be needed.
25   * Add formbuilder_setup and formbuilder hooks.
26   * Split out a passwordauth module, that holds all the traditional password
27     based authentication etc code. It's enabled by default, but can be disabled
28     if you want only openid or some other auth method.
29   * Rename ikiwiki.pl so MakeMaker doesn't see it, and install it.
30   * Add some code to the build system that tries to determine if the
31     lib installation directory is in @INC. If it's not, munge ikiwiki
32     to hardcode the path to the lib directory. This should allow installing
33     ikiwiki in nonstandard locations, including home directories, by just
34     setting PREFIX at build time.
35   * Fix nested examples directory in deb.
36   * Add a test suite for the mercurial backend, contributed by Emanuele Aina.
37   * Add a test suite for the svn backend.
38   * Daemonize before sending RPC pings, since that can take a while
39     and/or hang.
40   * Daemonize before sending commit mails, as that can also take a long
41     time/hang if the mail server is unhappy.
42   * Factor out commit mail sending code into new function.
43   * Change rcs_commit, it is now passed the name of the user doing the commit
44     and their IP address, and needs to construct its own commit message
45     containing them, or do something more appropriate for the given RCS.
46
47  -- Joey Hess <joeyh@debian.org>  Wed, 22 Nov 2006 09:08:37 -0500
48
49 ikiwiki (1.33) unstable; urgency=low
50
51   * Fix issue with aggregate plugin updating expired pages.
52   * Avoid syntax errors in templates used by the template plugin crashing
53     ikiwiki.
54   * Enable utf8 file IO in aggregate plugin.
55   * Fix some issues with the new registration form.
56   * Patch from Ethan Glasser Camp to add a skip option to the inline plugin.
57   * Make sure to check for errors from every eval.
58   * Fix img plugin's handling of adding dependencies for images that do not
59     yet exist.
60   * Work around a strange bug in CGI::FormBuilder 3.0401 that makes
61     FORM-SUBMIT unusable on customised formbuilder templates. For now,
62     hardcode the submit buttons in editpage.tmpl instead of using the
63     template variable, which is ok, since the buttons are static.
64   * Work with hyperestraier 1.4.9.
65
66  -- Joey Hess <joeyh@debian.org>  Wed, 15 Nov 2006 18:32:26 -0500
67
68 ikiwiki (1.32) unstable; urgency=low
69
70   * Add a separate pass to find page links, and only render each page once,
71     instead of over and over. Typical speedup is ~4x. Max possible speedup:
72     8x.
73   * Add "scan" parameter to hook(), which is used to make the hook be called
74     during the scanning pass, as well as the render pass. The meta and tag
75     plugins need to use the new scan parameter, so will any others that modify
76     %links.
77   * Now that links are calculated in a separate pass, it can also
78     precalculate backlinks in one pass, which is O(N^2) instead of the
79     previous code that was O(N^3). A very nice speedup for wikis with lots
80     (thousands) of pages.
81   * Stylish update to the ikiwiki logo, thanks to Recai Oktaş and Selçuk
82     Erdem.
83   * Add a default stylesheet entry for the pagecloud.
84   * Add examples page with some examples of things that can be done using
85     ikiwiki, like a weblog. The examples can be copied into a user's wiki
86     for a quick start, without needing to learn everything about how to put
87     them together.
88   * Install the source of the examples into /usr/share/doc/ikiwiki/examples.
89   * Add perlmagick to build-depends so syntax check of img plugin works.
90     Closes: #396702
91   * Improve login/register process, the login dialog has only name and
92     password fields, which allows more web browsers to regognise it as a login
93     field, and is less confusing.
94   * Implemented expiry options for aggregate plugin.
95   * Use precalculated backlinks info when determining if files need an update
96     due to a page they link to being added/removed. Mostly significant if
97     there are lots of pages.
98   * Remove duplicate link info when saving index. In some cases it could
99     pile up rather badly. (Probably not the best way to deal with this
100     problem.)
101   * Patch from James Westby to support podcasting, photoblogging, vidcasting,
102     or what have you, by creating enclosures for non-page items that are
103     included in feeds.
104
105  -- Joey Hess <joeyh@debian.org>  Fri,  3 Nov 2006 14:46:37 -0500
106
107 ikiwiki (1.31) unstable; urgency=low
108
109   * Patch from Pawel Tecza to cp -a the templates in the Makefile.
110   * Change the rss feed title from the wikiname to the page title, with
111     an exception for the wiki's toplevel index page, which will still use the
112     wikiname as the feed title.
113     Overriding the page title with meta title already overrode the rss feed
114     tittle.
115   * Add an img plugin, based on Christian Mock's img plugin, but stripped
116     down to the bare essentials. Useful for handling large images on websites.
117   * Sanitize possibly problimatic characters out of the polygen grammar names,
118     just in case. Should not be exploitable anyway, since it only tries to run
119     polygen after finding the specified grammar file.
120   * Add missing dependency on the URI perl module.
121   * Add basic spam fighting tool for admins: An admin's prefs page now allows
122     editing a list of banned users.
123
124  -- Joey Hess <joeyh@debian.org>  Fri, 27 Oct 2006 23:16:33 -0400
125
126 ikiwiki (1.30) unstable; urgency=low
127
128   * Add no_override parameter to hook().
129   * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
130     plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
131     can be configured using a page in wiki.
132   * Fix support for --pingurl at the command line.
133   * Fix a subtle bug in will_render that broke some builds, by only clearing
134     items from renderedfiles the first time per build.
135   * Wrap entire technortati ping operation in an eval to catch all possible
136     failure modes, after I observed a simple ->value crashing ikiwiki when
137     a ping failed.
138
139  -- Joey Hess <joeyh@debian.org>  Mon, 16 Oct 2006 15:17:38 -0400
140
141 ikiwiki (1.29) unstable; urgency=low
142
143   * Patch from Paul Tötterman to use CP in the Makefile.
144   * Patch from Alec Berryman adding a http_auth config item that allows
145     using HTTP Authentication instead of ikiwiki's built in authentication.
146     Useful for eg, large sites with their own previously existing user auth
147     setup. Closes: #384534
148   * Change %renderedfiles to store an array of files rendered from a given
149     source file, to allow tracking of extra rendered files like rss feeds.
150   * Note that plugins that accessed this variable will need to be updated!
151     The plugin interface has been increased to version 1.01 for this change.
152     As few plugins use %renderedfiles I haven't done anything else to ensure
153     compatability of old plugins.
154   * Add will_render function to the plugin interface, used to register that a
155     page renders a destination file, and do some security checks. Previously
156     but no longer rendered files will be cleaned up.
157   * Use will_render in the inline and linkmap plugins.
158   * You will need to rebuild your wiki on upgrade to this version.
159   * Atom feed support based on a patch by Clint Adams.
160   * Add feeds=no option to inline preprocessor directive to turn off all types
161     of feeds.
162   * $IkiWiki::version now holds the program version, and is accessible to
163     plugins.
164   * Make the aggregate plugin emphasize error messages.
165   * Patch from Recai to limit recentchanges to displaying max 10 files for a
166     given changeset (to avoid large number of file changes excessively
167     bloating the page).
168
169  -- Joey Hess <joeyh@debian.org>  Fri, 13 Oct 2006 23:14:28 -0400
170
171 ikiwiki (1.28) unstable; urgency=low
172
173   * inline: Add ability to sort by page name, based on a patch from
174     Benjamin A'Lee.
175   * Fix a forkbomb in various calls to IPC::Open2, which has a highly
176     braindead interface. Closes: #389383
177   * Don't rm -rf ikiwiki on distclean, since a) there's no such file
178     and b) those poor Mac OSX users and their case insensative files!
179   * Don't fail syntax check if Text::Typography isn't installed.
180     Closes: #389406
181
182  -- Joey Hess <joeyh@debian.org>  Tue, 26 Sep 2006 02:08:17 -0400
183
184 ikiwiki (1.27) unstable; urgency=low
185
186   * Work on firming up the plugin interface:
187     - Plugins should not need to load IkiWiki::Render to get commonly
188       used functions, so moved some functions from there to IkiWiki.
189     - Picked out the set of functions and variables that most plugins
190       use, documented them, and made IkiWiki export them by default,
191       like a proper perl module should.
192     - Use the other functions at your own risk.
193     - This is not quite complete, I still have to decide whether to
194       export some other things.
195   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
196     referring to stuff now exported by the IkiWiki module.
197   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
198     to declare which version of the interface your plugin needs.
199   * Anyone with a third-party ikiwiki plugin is strongly encouraged
200     to make like changes to it and avoid use of non-exported symbols from
201     "IkiWiki::".
202   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
203   * Support hyperestradier version 1.4.2, which adds a new required phraseform
204     setting.
205   * If an inlined page has a permalink, link the page title to that.
206   * Patch from Recai to use utf8 when reading the setup file, so that
207     utf8 wikinames from there will be used properly.
208   * Patch from Recai to kill utf-8 on the wiki name when generating the
209     session cookie.
210   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
211   * Fix a baseurl problem in hyperestradier search results.
212   * Add a stub local.css to avoid problems with 404's.
213   * Patch from Recai to fix a wide character warning from the search plugin
214     during setup if the wikiname contains utf8.
215   * Yet another fix for those poor case-insensative OS X users.
216   * pagetemplate hooks are now also called when generating cgi pages.
217   * Add a favicon plugin, which simply adds a link tag for an icon to each
218     page (and cgis).
219   * Patch from James Westby to deal with the case where you're editing a
220     new page, hit cancel, and need to be redirected to somewhere sane.
221   * Various documentation improvements by various wiki users.
222   * Support Text::Markdown from CPAN, which has a different interface from
223     the original markdown or the one in Debian.
224   * Version the libcgi-session-perl dependency, some features that need
225     the new version are used in some cases (sslcookie).
226   * Numerous tla fixes from Clint.
227   * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
228     a multi-resolution favicon.ico.
229   * README.Debian: typo Closes: #388110
230   * chomp trailing newline at the end of templates read in by the template
231     plugin, to allow use of the template preprocessor directive in
232     whitespace-sensative situations. Closes: #387073
233   * Patch from James Westby to make the location of the estseek.cgi script
234     configurable.
235   * Add typography (SmartyPants) plugin by Recai.
236   * Add --render mode, which can be used to preview an edit at the command
237     line by test rendering a single page.
238   * Add a googlecalendar plugin. A bit special-purpose, but it shows
239     one way to to deal with user-supplied content that could cause XSS
240     issues w/o the htmlscrubber, and won't survive the scrubber.
241
242  -- Joey Hess <joeyh@debian.org>  Sun, 24 Sep 2006 00:02:21 -0400
243
244 ikiwiki (1.26) unstable; urgency=low
245
246   * Add a missing -n to tla undo call.
247   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
248     writes before consuming its whole stdin. Avoid this deadlock.
249   * Fix alt tags for outline checkboxes.
250
251  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
252
253 ikiwiki (1.25) unstable; urgency=low
254
255   * Add proper waitpid calls for open2ed processes throughout to avoid
256     zombies; this hit htmltidy especially badly.
257   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
258     subversion repos and fixing some other issues.
259   * Add support for tla, contributed by Clint Adams. Closes: #385936
260   * Add support for mercurial, contributed by Emanuele Aina.
261   * Include <link rel> tag for RSS feeds, used by some aggregators and
262     firefox to find the feed.
263   * Add a linkmap plugin (requires graphviz).
264
265  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
266
267 ikiwiki (1.24) unstable; urgency=low
268
269   * Simplify the data structure returned by rcs_recentchanges to avoid
270     each rcs plugin needing to form complex strings on its own.
271   * Fix another destpage issue in the inline directive. Closes: #385512
272     again.
273
274  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
275
276 ikiwiki (1.23) unstable; urgency=low
277
278   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
279
280  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
281
282 ikiwiki (1.22) unstable; urgency=low
283
284   * Change how the stylesheet url is determined in the templates: Remove
285     STYLEURL and add BASEURL to all templates (some already had it). This
286     new more general variable can be used to link to other things (eg, images)
287     from the template, as well as stylesheets.
288   * Fix a bug introduced last version to do with nested inlines.
289   * Allow preprocessor directives to span multiple lines, both to make
290     long ones with lots of values easier to write, and to allow for ones with
291     multi-line quoted values.
292   * Allow preprocessor directives to contain python-like triple-quoted
293     text blocks, for easy nesting of quotes inside.
294   * Add a template plugin.
295   * Make pagespec merge code smarter about merging duplicate pagespecs.
296   * Patch from Jordà Polo to make Setup::Standard support hashes in config
297     files.
298   * Change order of linkify and preprocess; first preprocess and then linkify.
299     This allows passing a wikilink inside a parameter to a preprocessor
300     directive without it being expanded to html, and leaking out of the
301     parameter, which had required some non-obvious use of triple-quoting
302     to avoid. Note that any preprocessor plugins that output something
303     that looks like a wikilink will now have it treated as such; AFAIK
304     this doesn't change any behavior though except for the template plugin.
305   * Enable preprocessor directives when previewing an edit.
306   * Make all pages pull in a local.css style sheet, if present. This won't
307     be included in ikiwiki, but can be created to make local styling changes
308     w/o needing to merge in every new change to the distributed style.css.
309   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
310   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
311     from a different directory.
312   * Generalised preprocesser loop protection code.
313   * Patch from James Westby to allow a description to be set for rss feeds.
314   * Patch from James Westby to add a template for the search form.
315   * Added a ddate plugin.
316   * Patch from James Westby to add a --sslcookie switch, which forces
317     cookies to only be sent over ssl connections to avoid interception.
318   * Fix preferences page on anonok wikis; still need to sign in to get
319     to the preferences page.
320   * Add toc (table of contents) plugin.
321   * Change htmlize, format, and sanitize hooks to use named parameters.
322   * Patch from James Westby to add an actions option to inline; this
323     adds Edit and Discussion links at the end of blog entries.
324   * Due to some css changes, you'll want to rebuild your wiki on upgrade
325     to this version. Will be handled automatically by the deb.
326   * Add processed date to aggregate preprocessor directive status output.
327
328  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
329
330 ikiwiki (1.21) unstable; urgency=low
331
332   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
333   * If a page links to itself, mark up the link text in a span with
334     class="selflink" so that it can be styled. I don't have a useful style
335     defined for that though.
336   * Call filter hooks on inlined page content.
337   * Support inlining pages raw, rather than creating a blog.
338   * Clean up yes/no parameter parsing in inline plugin.
339   * Implemented better cycle detection in the inline plugin; nested inlines
340     will now work.
341   * Add a map plugin contributed by Alessandro Dotti Contra.
342   * Add otl format plugin, which handles files as created by vimoutliner.
343   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
344   * Add first draft at a Restructured Text (rst) plugin, by Sergio
345     Talens-Oliag. Note that this has many known issues -- see the caveats on
346     the plugin's page.
347   * Credit everyone who wrote a plugin on the plugins' wiki pages.
348   * Fix utf-8 in blog post form.
349
350  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
351
352 ikiwiki (1.20) unstable; urgency=low
353
354   * Relicense the templates and basewiki under the 2-clause BSD license.
355     Since these can easily become part of other people's websites, they
356     should be under as permissive a license as possible.
357   * Add --syslog config option, to log to the syslog.
358   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
359     transient failure to fork (which I've seen happen in the wild).
360   * Fix a bug in the aggregator introduced last version that caused all
361     aggregator state to be lost during a non-aggregating build.
362
363  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
364
365 ikiwiki (1.19) unstable; urgency=low
366
367   * Fix several related bugs in page type determination during online editing.
368   * Add some locking to prevent 2 aggregators from running at once.
369   * Fix an infinite loop in the aggregator when finding a unique filename.
370
371  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
372
373 ikiwiki (1.18) unstable; urgency=low
374
375   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
376   * Add --version.
377   * Man page format fixups.
378   * If the meta plugin overides the page title, set a title_overridden
379     variable in the template to true. This allows doing things with the
380     templates conditional on the title being overriden.
381   * Add a %pagecase which maps lower-case page names to the actual case
382     used in the filename. Use this in bestlinks calculation instead of
383     forcing the link to lowercase.
384   * Also use %pagecase in various other places that want to check if a page
385     with a given name exists.
386   * This means that links to pages with mixed case names will now work,
387     even if the link is in some other case mixture, and mixed case pages
388     should be fully supported throughout ikiwiki.
389   * Recommend rebuilding wikis on upgrade to this version.
390
391  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
392
393 ikiwiki (1.17) unstable; urgency=low
394
395   * Disable tidy generator tag.
396   * Move tidy back to sanitize hook, found out how to only show body.
397   * Turn off tidy indentation too.
398   * Turn on HTML::Template loop_context_vars; not actually used in stock
399     templates but can be useful for things like making comma-delimited lists
400     of tags or what have you.
401   * Remove <br> from end of aggregate preprocessor directive output.
402   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
403     case-sensative filesystems like OSX.
404   * Improve markdown loading. First, try to load it as a proper perl module,
405     in case it was installed as one. Then fall back to trying
406     /usr/bin/markdown.
407   * Document in install page how to install markdown, since it has no
408     installation procedure in the upstream tarball.
409   * Set die_on_bad_params => 0 for all templates, to allow users to modify
410     them without annoyances.
411   * Suck in the page content when generating an inline archive page, to work
412     around the meta plugin's lack of caching of title metadata across runs.
413
414  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
415
416 ikiwiki (1.16) unstable; urgency=low
417
418   * Try to handle relative links in aggregated feeds. However,
419     the current support is a crude hack due to limitations of XML::Feed:
420     xml:base is not supported, neither is Content-Location. And of course,
421     relative links in RSS feeds are ill-undefined..
422   * Make aggregator save permalinks and author name to pages as metadata.
423   * Add permalink and author support to meta plugin, affecting RSS feeds
424     and blog pages.
425   * Various CSS and formatting changes.
426   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
427   * Add xhtml files to the default prune regexp.
428   * Also generate rel=bookmark links for permalinks.
429   * Fix the htmltidy plugin, which wasn't working due my breaking it when
430     I added it..
431   * Don't run tidy with -xml as that fails if the input is not well-formed.
432     Run it with -asxhtml instead, so it will output well-formed xhtml no
433     matter what the input.
434   * Disable tidy warnings too.
435   * Add a new format hook, and make tidy use it, since tidy can really only
436     operate on and output complete html documents, not the body chunks
437     that sanitise gets.
438   * Fix dates in rss feeds if running localised, so they're still rfc 822.
439
440  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
441
442 ikiwiki (1.15) unstable; urgency=low
443
444   * Remove CDPATH and other env vars perl taint checking doesn't like.
445     Closes: #381279
446   * Added created_before and created_after PageSpec limits.
447
448  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
449
450 ikiwiki (1.14) unstable; urgency=low
451
452   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
453     by 10% or so.
454   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
455   * Added many unit tests for pagespec_match.
456
457  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
458
459 ikiwiki (1.13) unstable; urgency=low
460
461   * ikiwiki can now download and aggregate feeds with its new aggregate
462     plugin, so it's possible to implement a Planet using ikiwiki!
463   * Add a run_hooks function for the common task of running all hooks of a
464     given type.
465   * Add a savestate hook.
466   * Don't put blog post forms on pages if there's no cgiurl set.
467   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
468     --wrappers to do that.
469   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
470     to update pages that haven't changed on disk.
471   * Change meta tags to use html entity-escaped text for values, so that
472     quotes and such can be represented in title tags.
473   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
474     for the above.
475   * Make --rebuild also cause --aggregate to re-download and write aggregated
476     pages.
477   * Avoid outputting duplicate meta info.
478   * Include title metadata on aggregated posts for capitalised and un-munged
479     titles.
480   * Title metadata of inlined pages now shows up in blogs and rss feeds.
481   * Fix issue with unicode filenames and updating the hyper estradier search
482     index. (Aka Please Please Please, let that be the last one.)
483   * Patch from Roland Mas to support an rss=no parameter to inline directives.
484     Closes: #380743
485   * Renamed GlobLists to PageSpecs.
486   * PageSpecs can now include nested parens, "and", and "or". This remains
487     backwards compatible to the old GlobList format. It's implemented by
488     treating the GlobList as a very limited microlanguage that is transformed
489     to perl code that does the matching.
490   * The old GlobList format is deprecated, and I encourage users to switch to
491     using the new PageSpec format. Compatability with the old format will be
492     removed at some point, possibly by 2.0.
493   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
494   * Add support for creation_month and creation_year to PageSpec.
495     Closes: #380680
496   * Changes to index file encoding.
497
498  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
499
500 ikiwiki (1.12) unstable; urgency=low
501
502   "Viva l'Italia!"
503   * New pagestats plugin from Enrico, which can generate a table counting
504     the backlinks for each page, or a del.icio.us style cloud.
505   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
506     the wikiformat plugin works. Thanks, Emanuele Aina.
507   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
508     display, running them through pagetitle. This removes ugly underscores and
509     other gunk from the display, much nicer. You may want to rebuild your wiki
510     when upgrading to get the cleanup globally.
511   * Polygen plugin from Enrico.
512   * htmltidy plugin from Faidon.
513   * Locale patch from Faidon:
514     - Adds a locale setting to setup files.
515     - Proper local time, if the locale configuration option is used.
516     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
517       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
518       impossible.
519   * Add getopt hook type, this allows plugins to add new command-line options.
520   * Add --tagbase option to tag plugin.
521   * Add exclude option in setup files, works same as --exclude.
522   * Put categories in rss feeds for tagged items.
523   * Allow preprocessor directives to be expanded in inlined blog pages.
524     However, to avoid inlining loops etc, don't expand inline directives in
525     inlined pages.
526   * fortune plugin (trivial)
527   * Tag plugins according to type.
528
529  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
530
531 ikiwiki (1.11) unstable; urgency=low
532
533   * Patch from Enrico that
534     - Adds a tag plugin that allows more easily tagging pages.
535       The meta plugin can also still be used for that, but the tag plugin
536       also lists a page's tags at the bottom of the page.
537     - Allows preprocessor directives to have parameters with no specified
538       value.
539     - Fixes preprocessor directive parameter parsing so that
540       foo=bar baz now means "foo=bar" and a "baz" with no value.
541   * Run pagetemplate hooks when inlining pages so that inlined pages also
542     list their tags.
543   * Make all plugins with pagetemplate hooks check that variables exist
544     on the template before setting them, for robustness.
545   * Switch pagetemplate hooks to using named parameters.
546   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
547     This will be the page that a source page will be part of, which is
548     different than the source page for inlined pages.
549   * Audited all plugins to endure they pass (page, destpage) to htmllink
550     appropriatly. This means inlining of various plugins will not work
551     properly, with correct links generated.
552
553  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
554
555 ikiwiki (1.10) unstable; urgency=low
556
557   * Run page through any relevant filters when generating a page preview.
558   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
559     default throughout the wiki, not only on wikitext pages. Decided to call
560     this a feature, and split the camelcase support out into a separate plugin
561     that is independant of wikitext.
562   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
563
564  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
565
566 ikiwiki (1.9) unstable; urgency=low
567
568   * Improve display of parentlinks and page title of toplevel index page.
569   * Patch from Faidon to use svn --limit when possible for recentchanges,
570     speeds up recentchanges a lot for wikis with more history.
571   * Patch from Recai to fix utf8 issues in git backend.
572   * Add wikitext markup plugin, which supports ".wiki" pages written in the
573     original wiki syntax, CamelCase links and all.
574   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
575     support, to edit pages etc without a web server.
576   * Display CGI processing errors if present.
577   * Fix from Faidon for a XML parser issue that breaks utf-8 for
578     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
579     area, and also way slow.
580   * Match 'web commit from' in SVN and git, these are web commits too.
581     (Faidon)
582   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
583     readable and avoid future mistakes. The patch seems to work and for the
584     first time I have a UTF-8 username ;-) (Faidon)
585   * Use form->field consistently, not form->param.
586   * Patch from Recai to allow selection of page type when creating a new page.
587     Default page type is inherited from the link clicked on to create the new
588     page.
589
590  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
591
592 ikiwiki (1.8) unstable; urgency=low
593
594   * Fix orphans plugin to not count a link to a nonexistant page as a reason
595     for a page not being an orphan.
596   * Support pinging services such as Technorati using XML-RPC to notify them
597     about changes to rss feeds.
598   * Parse svn log as xml for improved utf8 and security. Note that this makes
599     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
600   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
601     flagged string even if the locale causes it to generate utf8 output,
602     so make sure to let perl know it should be handled as utf8. Also,
603     the optimised version used for standard time formats won't work if the
604     user has changed locale, so drop it. Thanks, Faidon Liambotis.
605   * Fix re-encoding of the comments field to utf8 if a commit fails
606     due to a conflict. Thanks, Faidon Liambotis.
607   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
608     Liambotis.
609   * Add insane double encode/decode to utf8 around call to markdown.
610     This works around a truely strange bug, which is apparently a bug in
611     perl, #376329. Also added a test case for it.
612   * Improve layout of edit page so formatting help link is always visible w/o
613     getting in the way of the preview.
614   * Centralised all calls to HTML::Template and force all the templates
615     to be read as utf8.
616   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
617   * Introduce add_plugins and disable_plugins config options in setup files.
618     This allows adding or removing plugins w/o overriding the whole list of
619     default plugins, which makes it easier to upgrade when new default plugins
620     are added.
621   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
622     default (of course!). Based on a patch by Faidon Liambotis.
623   * Add a html plugin, which can be used to write wikis in raw html,
624     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
625     defaults to not processing .html files, since w/o this plugin they would
626     be copied unsanitised. With this plugin, it will process and html
627     sanitise them, like any other page type.
628   * Rebuilding wrappers is necessary on upgrade to this version.
629   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
630     will be automatically done on all upgrades.
631   * Don't send pings if the wiki is being rebuilt.
632   * Work around very innefficient behavior in File::Spec::abs2rel. Result
633     is a savings of 2 pointless fork/execs per link calculation, which
634     results in ~25% speedup of ikiwiki building its own doc wiki, and
635     about 35% speedup displaying RecentChanges!
636   * Make RecentChanges use a table and some CSS, should be much more readable.
637     No code changes involved.
638   * Encode & in diffurl in examples, to conform to pedantic rules.
639   * Speed up RecentChanges by another 40% or so with some memoization.
640   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
641     in time to build the doc wiki.
642
643  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
644
645 ikiwiki (1.7) unstable; urgency=low
646
647   * Updated logo from Recai with some kerning and alingment tuning.
648   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
649     changed some output.
650   * Copyright update.
651
652  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
653
654 ikiwiki (1.6) unstable; urgency=low
655
656   * YA utf-8 patch from Recai, this time to fix previewing a page so that
657     the text in the input box is re-encoded back to utf-8.
658   * -CSD does not affect modules, so readfile() was not using the utf-8 input
659     layer, which led to lots of problems; make it force read files as utf-8.
660     Closes: #373203
661   * Note that as a consequence, this version of ikiwiki will actually try to
662     parse utf8 in source files for the first time, which may expose broken
663     utf8 in wiki sources that was hidden before. Most common will be
664     perl warnings like "utf8 "\xE9" does not map to Unicode"
665   * writefile() likewise needs to use the utf8 output layer.
666   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
667     there.
668   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
669     given the readfile fix.
670   * Add utf-8 testcases for readfile and htmlize.
671   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
672     safe.
673   * More utf-8 fixes from Recai, partly to things I broke above:
674     - The serious problem is that writefile() saves the content in undecoded
675       format in CGI, hence all (non-ascii) chars are corrupted permanently.
676     - Comment field in edit page is not decoded and all the non-ascii chars in
677       this field are corrupted as the result.  We should decode it as we do it
678       for the content.
679     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
680       character in print.
681   * New SVG logo from Recai.
682
683  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
684
685 ikiwiki (1.5) unstable; urgency=low
686
687   * Add --timeformat config option to allow changing how dates are displayed.
688     Note that as a side effect, dates will now be displayed using the local
689     timezone, not as GMT.
690   * More security review.
691   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
692     for some handy stuff like:
693     - Using links as a kind of tag; creating blog pages that list all pages
694       containing a given tag/link or not containing some other tag.
695     - Subscribing to mail notifications whenever a change is made to a page
696       that is a backlink of page foo. Ie, "Please notify me of changes in all
697       pages that link to my home page in the wiki"
698     - Locking any pages that are linked to from a particular page, so that
699       lists of locks can be exposed in the wiki.
700   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
701     when a todo item is done, instead of the previous moving it to a different
702     subdir.
703   * Allow pagetemplate plugins to override *anything* in the template.
704   * Add a meta plugin, which allows specifying various metadata about pages,
705     like license and author. It also allows for inserting html link and meta
706     tags into html, overriding the title, and adding hidden WikiLinks, which
707     can be useful when using link-based globbing for page categorisation.
708   * Remove preprocessor directives from inlined pages.
709   * Allow simple preprocessor directive values to be specified w/o quotes.
710   * Add support for using git instead of subversion as the RCS backend,
711     tremendous thanks to Recai Oktaş for this.
712   * Doc updates for git.
713   * Fix absolute url munging in rss generation to support https, ftp, etc urls
714     not just http urls.
715   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
716     utf-8 for edit and other fields, and for recentchanges. There may still
717     be utf-8 issues with the preferences page though.
718
719  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
720
721 ikiwiki (1.4) unstable; urgency=low
722
723   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
724     very strange way of enabling proper XHTML <br /> type tags. Output html
725     should be always valid again now.
726   * The page name and parent links has switched from using a <h1> to a styled
727     <span>, so pages can use <h1> internally instead of needing to use <h2>.
728   * Updated all of ikiwiki's own wiki pages for that.
729   * Add pagetemplate hook, which can be used by plugins that want to mess
730     around with adding new stuff to the page template.
731   * Remove headercontent; the search plugin now adds the search box to the
732     header by registering a pagetemplate hook, and other plugins should do
733     similarly.
734   * Rebuilding on upgrade to this version is recommended.
735   * Add a html validity check to the test suite, using the wdg-html-validator,
736     if available.
737   * Make the html valid when there is nothing in the actions list.
738   * Reordered some function call parameters for consistency.
739   * Enable full utf-8 support for page input and output.
740   * Add a workaround for markdown, which does not work well with utf-8
741     strings.
742   * --getctime had bitrotted (well I only ever used it the once so far..),
743     fix and make it a bit more flexible
744   * rcs_getctime is changed, now rather than needing to loop over all pages,
745     it should just use the rcs to get the ctime of the passed file.
746   * When inlining a page in another one, links from the inlined page are now
747     expanded the same as they are when rendering the inlined page as a
748     standalone page. So rather than being expanded from the POV of the
749     inlining page, they are expanded from the POV of the inlined page.
750
751     For example, a link from blog/foo to "bar" will now link to blog/bar
752     if it exists. Previously this needed to be a link explicitly to
753     "blog/bar"; such links will also continue to work.
754
755     (This was slightly complex to do as the link still has to be constructed
756     relative to the inlining page.)
757   * Make page edit textarea resize to fit browser window.
758   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
759     do not need a full rebuild, in order to update any basewiki pages.
760
761  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
762
763 ikiwiki (1.3) unstable; urgency=low
764
765   * Fix the preinst introduced in the last version. Closes: #367458
766
767  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
768
769 ikiwiki (1.2) unstable; urgency=low
770
771   * Remove dups from the brokenlinks list.
772   * Add libc6-dev to dependencies, needed to build wrappers.
773   * Install wikilist in correct location. Closes: #367371
774
775  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
776
777 ikiwiki (1.1) unstable; urgency=low
778
779   * Rename inlinepage to depends, so that it can be used to refer to more
780     dependency relationships than just inlining. This will require a rebuild
781     on upgrade to this version.
782   * Move the rss link, put it in the blogpost form if there is one and at the
783     top if not. This is both nicer because easier to find, and it cleans up
784     the code which had used inlinepage as a flag for adding the link later.
785   * Allow the depends GlobList to be built up from multiple sources (such as
786     plugins) during a page render.
787   * Which means that more than one blog is now supported to appear on a
788     single page. (With some limitations, like only the last one getting an
789     rss file.)
790   * Added a plugin system.
791   * Added a pagecount plugin, enabled by default.
792   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
793   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
794     backlinks when the backlinks hadn't really changed.
795   * Moved inline page support, rss generation etc into the inline plugin,
796     enabled by default.
797   * Added brokenlinks plugin, not enabled by default, but rather handy.
798   * Fix several broken links in the doc wiki.
799   * Smarter behavior when creating a page and a page of the same name (but
800     different location) already exists.
801   * Add an orphans plugin for finding pages that nothing links to.
802   * Removed backlinks page, which it turns out nothing used.
803   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
804     it, this will allow for adding a unit test suite.
805   * Add unit tests for several core functions, including globlist_match,
806     dirname, basename, bestlink, linkify, pagetitle, titlepage.
807   * Smart globlist merging.
808   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
809     to pave the way for adding other RCS support. This also changes the
810     setup files, where before they had svn => 1 or svn => 0, now they have
811     rcs => "svn" or rcs => "".
812   * Add a debian/NEWS file with upgrade notes.
813   * Load whatever rcs module is specified, so new ones can be just dropped in
814     as plugins and work. (Well, in theory.)
815   * Add some basic docs about writing RCS modules.
816   * Broke search capability out into a plugin, removed the --hyperestraier
817     switch.
818   * Added smiley plugin, nicely controlled and documented by the smileys page.
819   * Copied in some smileys from Moin Moin.
820   * Allow links of the form [[some page|page]], with whitespace in the link
821     text.
822   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
823     and --disable-plugin htmlscrubber.
824   * Allow discussion links on pages to be turned off with --no-discussion.
825   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
826   * Add some new config items to the estseek.conf template, which are needed
827     by hyperestraier 1.2.3.
828
829  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
830
831 ikiwiki (1.0) unstable; urgency=low
832
833   * First official release.
834
835  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400