* Parse svn log as xml for improved utf8 and security. Note that this makes
[ikiwiki] / debian / changelog
1 ikiwiki (1.8) UNRELEASED; urgency=low
2
3   * Fix orphans plugin to not count a link to a nonexistant page as a reason
4     for a page not being an orphan.
5   * Support pinging services such as Technorati using XML-RPC to notify them
6     about changes to rss feeds.
7   * Honor LC_CTIME when formatting a time for display. Thanks, Faidon
8     Liambotis.
9   * Parse svn log as xml for improved utf8 and security. Note that this makes
10     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
11
12  -- Joey Hess <joeyh@debian.org>  Sat,  1 Jul 2006 20:41:55 -0400
13
14 ikiwiki (1.7) unstable; urgency=low
15
16   * Updated logo from Recai with some kerning and alingment tuning.
17   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
18     changed some output.
19   * Copyright update.
20
21  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
22
23 ikiwiki (1.6) unstable; urgency=low
24
25   * YA utf-8 patch from Recai, this time to fix previewing a page so that
26     the text in the input box is re-encoded back to utf-8.
27   * -CSD does not affect modules, so readfile() was not using the utf-8 input
28     layer, which led to lots of problems; make it force read files as utf-8.
29     Closes: #373203
30   * Note that as a consequence, this version of ikiwiki will actually try to
31     parse utf8 in source files for the first time, which may expose broken
32     utf8 in wiki sources that was hidden before. Most common will be
33     perl warnings like "utf8 "\xE9" does not map to Unicode"
34   * writefile() likewise needs to use the utf8 output layer.
35   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
36     there.
37   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
38     given the readfile fix.
39   * Add utf-8 testcases for readfile and htmlize.
40   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
41     safe.
42   * More utf-8 fixes from Recai, partly to things I broke above:
43     - The serious problem is that writefile() saves the content in undecoded
44       format in CGI, hence all (non-ascii) chars are corrupted permanently.
45     - Comment field in edit page is not decoded and all the non-ascii chars in
46       this field are corrupted as the result.  We should decode it as we do it
47       for the content.
48     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
49       character in print.
50   * New SVG logo from Recai.
51
52  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
53
54 ikiwiki (1.5) unstable; urgency=low
55
56   * Add --timeformat config option to allow changing how dates are displayed.
57     Note that as a side effect, dates will now be displayed using the local
58     timezone, not as GMT.
59   * More security review.
60   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
61     for some handy stuff like:
62     - Using links as a kind of tag; creating blog pages that list all pages
63       containing a given tag/link or not containing some other tag.
64     - Subscribing to mail notifications whenever a change is made to a page
65       that is a backlink of page foo. Ie, "Please notify me of changes in all
66       pages that link to my home page in the wiki"
67     - Locking any pages that are linked to from a particular page, so that
68       lists of locks can be exposed in the wiki.
69   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
70     when a todo item is done, instead of the previous moving it to a different
71     subdir.
72   * Allow pagetemplate plugins to override *anything* in the template.
73   * Add a meta plugin, which allows specifying various metadata about pages,
74     like license and author. It also allows for inserting html link and meta
75     tags into html, overriding the title, and adding hidden WikiLinks, which
76     can be useful when using link-based globbing for page categorisation.
77   * Remove preprocessor directives from inlined pages.
78   * Allow simple preprocessor directive values to be specified w/o quotes.
79   * Add support for using git instead of subversion as the RCS backend,
80     tremendous thanks to Recai Oktaş for this.
81   * Doc updates for git.
82   * Fix absolute url munging in rss generation to support https, ftp, etc urls
83     not just http urls.
84   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
85     utf-8 for edit and other fields, and for recentchanges. There may still
86     be utf-8 issues with the preferences page though.
87
88  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
89
90 ikiwiki (1.4) unstable; urgency=low
91
92   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
93     very strange way of enabling proper XHTML <br /> type tags. Output html
94     should be always valid again now.
95   * The page name and parent links has switched from using a <h1> to a styled
96     <span>, so pages can use <h1> internally instead of needing to use <h2>.
97   * Updated all of ikiwiki's own wiki pages for that.
98   * Add pagetemplate hook, which can be used by plugins that want to mess
99     around with adding new stuff to the page template.
100   * Remove headercontent; the search plugin now adds the search box to the
101     header by registering a pagetemplate hook, and other plugins should do
102     similarly.
103   * Rebuilding on upgrade to this version is recommended.
104   * Add a html validity check to the test suite, using the wdg-html-validator,
105     if available.
106   * Make the html valid when there is nothing in the actions list.
107   * Reordered some function call parameters for consistency.
108   * Enable full utf-8 support for page input and output.
109   * Add a workaround for markdown, which does not work well with utf-8
110     strings.
111   * --getctime had bitrotted (well I only ever used it the once so far..),
112     fix and make it a bit more flexible
113   * rcs_getctime is changed, now rather than needing to loop over all pages,
114     it should just use the rcs to get the ctime of the passed file.
115   * When inlining a page in another one, links from the inlined page are now
116     expanded the same as they are when rendering the inlined page as a
117     standalone page. So rather than being expanded from the POV of the
118     inlining page, they are expanded from the POV of the inlined page.
119
120     For example, a link from blog/foo to "bar" will now link to blog/bar
121     if it exists. Previously this needed to be a link explicitly to
122     "blog/bar"; such links will also continue to work.
123
124     (This was slightly complex to do as the link still has to be constructed
125     relative to the inlining page.)
126   * Make page edit textarea resize to fit browser window.
127   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
128     do not need a full rebuild, in order to update any basewiki pages.
129
130  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
131
132 ikiwiki (1.3) unstable; urgency=low
133
134   * Fix the preinst introduced in the last version. Closes: #367458
135
136  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
137
138 ikiwiki (1.2) unstable; urgency=low
139
140   * Remove dups from the brokenlinks list.
141   * Add libc6-dev to dependencies, needed to build wrappers.
142   * Install wikilist in correct location. Closes: #367371
143
144  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
145
146 ikiwiki (1.1) unstable; urgency=low
147
148   * Rename inlinepage to depends, so that it can be used to refer to more
149     dependency relationships than just inlining. This will require a rebuild
150     on upgrade to this version.
151   * Move the rss link, put it in the blogpost form if there is one and at the
152     top if not. This is both nicer because easier to find, and it cleans up
153     the code which had used inlinepage as a flag for adding the link later.
154   * Allow the depends GlobList to be built up from multiple sources (such as
155     plugins) during a page render.
156   * Which means that more than one blog is now supported to appear on a
157     single page. (With some limitations, like only the last one getting an
158     rss file.)
159   * Added a plugin system.
160   * Added a pagecount plugin, enabled by default.
161   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
162   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
163     backlinks when the backlinks hadn't really changed.
164   * Moved inline page support, rss generation etc into the inline plugin,
165     enabled by default.
166   * Added brokenlinks plugin, not enabled by default, but rather handy.
167   * Fix several broken links in the doc wiki.
168   * Smarter behavior when creating a page and a page of the same name (but
169     different location) already exists.
170   * Add an orphans plugin for finding pages that nothing links to.
171   * Removed backlinks page, which it turns out nothing used.
172   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
173     it, this will allow for adding a unit test suite.
174   * Add unit tests for several core functions, including globlist_match,
175     dirname, basename, bestlink, linkify, pagetitle, titlepage.
176   * Smart globlist merging.
177   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
178     to pave the way for adding other RCS support. This also changes the
179     setup files, where before they had svn => 1 or svn => 0, now they have
180     rcs => "svn" or rcs => "".
181   * Add a debian/NEWS file with upgrade notes.
182   * Load whatever rcs module is specified, so new ones can be just dropped in
183     as plugins and work. (Well, in theory.)
184   * Add some basic docs about writing RCS modules.
185   * Broke search capability out into a plugin, removed the --hyperestraier
186     switch.
187   * Added smiley plugin, nicely controlled and documented by the smileys page.
188   * Copied in some smileys from Moin Moin.
189   * Allow links of the form [[some page|page]], with whitespace in the link
190     text.
191   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
192     and --disable-plugin htmlscrubber.
193   * Allow discussion links on pages to be turned off with --no-discussion.
194   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
195   * Add some new config items to the estseek.conf template, which are needed
196     by hyperestraier 1.2.3.
197
198  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
199
200 ikiwiki (1.0) unstable; urgency=low
201
202   * First official release.
203
204  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400