* Put back the encode_utf8 in the input to markdown; it's really not utf-8
[ikiwiki] / debian / changelog
1 ikiwiki (1.6) UNRELEASED; urgency=low
2
3   * YA utf-8 patch from Recai, this time to fix previewing a page so that
4     the text in the input box is re-encoded back to utf-8.
5   * -CSD does not affect modules, so readfile() was not using the utf-8 input
6     layer, which led to lots of problems; make it force read files as utf-8.
7     Closes: #373203
8   * writefile() likewise needs to use the utf8 output layer.
9   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
10     there.
11   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
12     given the readfile fix.
13   * Add utf-8 testcases for readfile and htmlize.
14   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
15     safe.
16
17  -- Joey Hess <joeyh@debian.org>  Fri, 16 Jun 2006 00:41:25 -0400
18
19 ikiwiki (1.5) unstable; urgency=low
20
21   * Add --timeformat config option to allow changing how dates are displayed.
22     Note that as a side effect, dates will now be displayed using the local
23     timezone, not as GMT.
24   * More security review.
25   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
26     for some handy stuff like:
27     - Using links as a kind of tag; creating blog pages that list all pages
28       containing a given tag/link or not containing some other tag.
29     - Subscribing to mail notifications whenever a change is made to a page
30       that is a backlink of page foo. Ie, "Please notify me of changes in all
31       pages that link to my home page in the wiki"
32     - Locking any pages that are linked to from a particular page, so that
33       lists of locks can be exposed in the wiki.
34   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
35     when a todo item is done, instead of the previous moving it to a different
36     subdir.
37   * Allow pagetemplate plugins to override *anything* in the template.
38   * Add a meta plugin, which allows specifying various metadata about pages,
39     like license and author. It also allows for inserting html link and meta
40     tags into html, overriding the title, and adding hidden WikiLinks, which
41     can be useful when using link-based globbing for page categorisation.
42   * Remove preprocessor directives from inlined pages.
43   * Allow simple preprocessor directive values to be specified w/o quotes.
44   * Add support for using git instead of subversion as the RCS backend,
45     tremendous thanks to Recai Oktaş for this.
46   * Doc updates for git.
47   * Fix absolute url munging in rss generation to support https, ftp, etc urls
48     not just http urls.
49   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
50     utf-8 for edit and other fields, and for recentchanges. There may still
51     be utf-8 issues with the preferences page though.
52
53  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
54
55 ikiwiki (1.4) unstable; urgency=low
56
57   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
58     very strange way of enabling proper XHTML <br /> type tags. Output html
59     should be always valid again now.
60   * The page name and parent links has switched from using a <h1> to a styled
61     <span>, so pages can use <h1> internally instead of needing to use <h2>.
62   * Updated all of ikiwiki's own wiki pages for that.
63   * Add pagetemplate hook, which can be used by plugins that want to mess
64     around with adding new stuff to the page template.
65   * Remove headercontent; the search plugin now adds the search box to the
66     header by registering a pagetemplate hook, and other plugins should do
67     similarly.
68   * Rebuilding on upgrade to this version is recommended.
69   * Add a html validity check to the test suite, using the wdg-html-validator,
70     if available.
71   * Make the html valid when there is nothing in the actions list.
72   * Reordered some function call parameters for consistency.
73   * Enable full utf-8 support for page input and output.
74   * Add a workaround for markdown, which does not work well with utf-8
75     strings.
76   * --getctime had bitrotted (well I only ever used it the once so far..),
77     fix and make it a bit more flexible
78   * rcs_getctime is changed, now rather than needing to loop over all pages,
79     it should just use the rcs to get the ctime of the passed file.
80   * When inlining a page in another one, links from the inlined page are now
81     expanded the same as they are when rendering the inlined page as a
82     standalone page. So rather than being expanded from the POV of the
83     inlining page, they are expanded from the POV of the inlined page.
84
85     For example, a link from blog/foo to "bar" will now link to blog/bar
86     if it exists. Previously this needed to be a link explicitly to
87     "blog/bar"; such links will also continue to work.
88
89     (This was slightly complex to do as the link still has to be constructed
90     relative to the inlining page.)
91   * Make page edit textarea resize to fit browser window.
92   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
93     do not need a full rebuild, in order to update any basewiki pages.
94
95  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
96
97 ikiwiki (1.3) unstable; urgency=low
98
99   * Fix the preinst introduced in the last version. Closes: #367458
100
101  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
102
103 ikiwiki (1.2) unstable; urgency=low
104
105   * Remove dups from the brokenlinks list.
106   * Add libc6-dev to dependencies, needed to build wrappers.
107   * Install wikilist in correct location. Closes: #367371
108
109  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
110
111 ikiwiki (1.1) unstable; urgency=low
112
113   * Rename inlinepage to depends, so that it can be used to refer to more
114     dependency relationships than just inlining. This will require a rebuild
115     on upgrade to this version.
116   * Move the rss link, put it in the blogpost form if there is one and at the
117     top if not. This is both nicer because easier to find, and it cleans up
118     the code which had used inlinepage as a flag for adding the link later.
119   * Allow the depends GlobList to be built up from multiple sources (such as
120     plugins) during a page render.
121   * Which means that more than one blog is now supported to appear on a
122     single page. (With some limitations, like only the last one getting an
123     rss file.)
124   * Added a plugin system.
125   * Added a pagecount plugin, enabled by default.
126   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
127   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
128     backlinks when the backlinks hadn't really changed.
129   * Moved inline page support, rss generation etc into the inline plugin,
130     enabled by default.
131   * Added brokenlinks plugin, not enabled by default, but rather handy.
132   * Fix several broken links in the doc wiki.
133   * Smarter behavior when creating a page and a page of the same name (but
134     different location) already exists.
135   * Add an orphans plugin for finding pages that nothing links to.
136   * Removed backlinks page, which it turns out nothing used.
137   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
138     it, this will allow for adding a unit test suite.
139   * Add unit tests for several core functions, including globlist_match,
140     dirname, basename, bestlink, linkify, pagetitle, titlepage.
141   * Smart globlist merging.
142   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
143     to pave the way for adding other RCS support. This also changes the
144     setup files, where before they had svn => 1 or svn => 0, now they have
145     rcs => "svn" or rcs => "".
146   * Add a debian/NEWS file with upgrade notes.
147   * Load whatever rcs module is specified, so new ones can be just dropped in
148     as plugins and work. (Well, in theory.)
149   * Add some basic docs about writing RCS modules.
150   * Broke search capability out into a plugin, removed the --hyperestraier
151     switch.
152   * Added smiley plugin, nicely controlled and documented by the smileys page.
153   * Copied in some smileys from Moin Moin.
154   * Allow links of the form [[some page|page]], with whitespace in the link
155     text.
156   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
157     and --disable-plugin htmlscrubber.
158   * Allow discussion links on pages to be turned off with --no-discussion.
159   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
160   * Add some new config items to the estseek.conf template, which are needed
161     by hyperestraier 1.2.3.
162
163  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
164
165 ikiwiki (1.0) unstable; urgency=low
166
167   * First official release.
168
169  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400