* -CSD does not affect modules, so readfile() was not using the utf-8 input
[ikiwiki] / debian / changelog
1 ikiwiki (1.6) UNRELEASED; urgency=low
2
3   * YA utf-8 patch from Recai, this time to fix previewing a page so that
4     the text in the input box is re-encoded back to utf-8.
5   * -CSD does not affect modules, so readfile() was not using the utf-8 input
6     layer, which led to lots of problems; make it force read files as utf-8.
7     Closes: #373203
8   * writefile() likewise needs to use the utf8 output layer.
9   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
10     there.
11   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
12     given the readfile fix.
13   * Add utf-8 testcases for readfile and htmlize.
14
15  -- Joey Hess <joeyh@debian.org>  Thu, 15 Jun 2006 01:46:03 -0400
16
17 ikiwiki (1.5) unstable; urgency=low
18
19   * Add --timeformat config option to allow changing how dates are displayed.
20     Note that as a side effect, dates will now be displayed using the local
21     timezone, not as GMT.
22   * More security review.
23   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
24     for some handy stuff like:
25     - Using links as a kind of tag; creating blog pages that list all pages
26       containing a given tag/link or not containing some other tag.
27     - Subscribing to mail notifications whenever a change is made to a page
28       that is a backlink of page foo. Ie, "Please notify me of changes in all
29       pages that link to my home page in the wiki"
30     - Locking any pages that are linked to from a particular page, so that
31       lists of locks can be exposed in the wiki.
32   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
33     when a todo item is done, instead of the previous moving it to a different
34     subdir.
35   * Allow pagetemplate plugins to override *anything* in the template.
36   * Add a meta plugin, which allows specifying various metadata about pages,
37     like license and author. It also allows for inserting html link and meta
38     tags into html, overriding the title, and adding hidden WikiLinks, which
39     can be useful when using link-based globbing for page categorisation.
40   * Remove preprocessor directives from inlined pages.
41   * Allow simple preprocessor directive values to be specified w/o quotes.
42   * Add support for using git instead of subversion as the RCS backend,
43     tremendous thanks to Recai Oktaş for this.
44   * Doc updates for git.
45   * Fix absolute url munging in rss generation to support https, ftp, etc urls
46     not just http urls.
47   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
48     utf-8 for edit and other fields, and for recentchanges. There may still
49     be utf-8 issues with the preferences page though.
50
51  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
52
53 ikiwiki (1.4) unstable; urgency=low
54
55   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
56     very strange way of enabling proper XHTML <br /> type tags. Output html
57     should be always valid again now.
58   * The page name and parent links has switched from using a <h1> to a styled
59     <span>, so pages can use <h1> internally instead of needing to use <h2>.
60   * Updated all of ikiwiki's own wiki pages for that.
61   * Add pagetemplate hook, which can be used by plugins that want to mess
62     around with adding new stuff to the page template.
63   * Remove headercontent; the search plugin now adds the search box to the
64     header by registering a pagetemplate hook, and other plugins should do
65     similarly.
66   * Rebuilding on upgrade to this version is recommended.
67   * Add a html validity check to the test suite, using the wdg-html-validator,
68     if available.
69   * Make the html valid when there is nothing in the actions list.
70   * Reordered some function call parameters for consistency.
71   * Enable full utf-8 support for page input and output.
72   * Add a workaround for markdown, which does not work well with utf-8
73     strings.
74   * --getctime had bitrotted (well I only ever used it the once so far..),
75     fix and make it a bit more flexible
76   * rcs_getctime is changed, now rather than needing to loop over all pages,
77     it should just use the rcs to get the ctime of the passed file.
78   * When inlining a page in another one, links from the inlined page are now
79     expanded the same as they are when rendering the inlined page as a
80     standalone page. So rather than being expanded from the POV of the
81     inlining page, they are expanded from the POV of the inlined page.
82
83     For example, a link from blog/foo to "bar" will now link to blog/bar
84     if it exists. Previously this needed to be a link explicitly to
85     "blog/bar"; such links will also continue to work.
86
87     (This was slightly complex to do as the link still has to be constructed
88     relative to the inlining page.)
89   * Make page edit textarea resize to fit browser window.
90   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
91     do not need a full rebuild, in order to update any basewiki pages.
92
93  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
94
95 ikiwiki (1.3) unstable; urgency=low
96
97   * Fix the preinst introduced in the last version. Closes: #367458
98
99  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
100
101 ikiwiki (1.2) unstable; urgency=low
102
103   * Remove dups from the brokenlinks list.
104   * Add libc6-dev to dependencies, needed to build wrappers.
105   * Install wikilist in correct location. Closes: #367371
106
107  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
108
109 ikiwiki (1.1) unstable; urgency=low
110
111   * Rename inlinepage to depends, so that it can be used to refer to more
112     dependency relationships than just inlining. This will require a rebuild
113     on upgrade to this version.
114   * Move the rss link, put it in the blogpost form if there is one and at the
115     top if not. This is both nicer because easier to find, and it cleans up
116     the code which had used inlinepage as a flag for adding the link later.
117   * Allow the depends GlobList to be built up from multiple sources (such as
118     plugins) during a page render.
119   * Which means that more than one blog is now supported to appear on a
120     single page. (With some limitations, like only the last one getting an
121     rss file.)
122   * Added a plugin system.
123   * Added a pagecount plugin, enabled by default.
124   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
125   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
126     backlinks when the backlinks hadn't really changed.
127   * Moved inline page support, rss generation etc into the inline plugin,
128     enabled by default.
129   * Added brokenlinks plugin, not enabled by default, but rather handy.
130   * Fix several broken links in the doc wiki.
131   * Smarter behavior when creating a page and a page of the same name (but
132     different location) already exists.
133   * Add an orphans plugin for finding pages that nothing links to.
134   * Removed backlinks page, which it turns out nothing used.
135   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
136     it, this will allow for adding a unit test suite.
137   * Add unit tests for several core functions, including globlist_match,
138     dirname, basename, bestlink, linkify, pagetitle, titlepage.
139   * Smart globlist merging.
140   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
141     to pave the way for adding other RCS support. This also changes the
142     setup files, where before they had svn => 1 or svn => 0, now they have
143     rcs => "svn" or rcs => "".
144   * Add a debian/NEWS file with upgrade notes.
145   * Load whatever rcs module is specified, so new ones can be just dropped in
146     as plugins and work. (Well, in theory.)
147   * Add some basic docs about writing RCS modules.
148   * Broke search capability out into a plugin, removed the --hyperestraier
149     switch.
150   * Added smiley plugin, nicely controlled and documented by the smileys page.
151   * Copied in some smileys from Moin Moin.
152   * Allow links of the form [[some page|page]], with whitespace in the link
153     text.
154   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
155     and --disable-plugin htmlscrubber.
156   * Allow discussion links on pages to be turned off with --no-discussion.
157   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
158   * Add some new config items to the estseek.conf template, which are needed
159     by hyperestraier 1.2.3.
160
161  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
162
163 ikiwiki (1.0) unstable; urgency=low
164
165   * First official release.
166
167  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400