* Numerous tla fixes from Clint.
[ikiwiki] / debian / changelog
1 ikiwiki (1.27) UNRELEASED; urgency=low
2
3   * Add a googlecalendar plugin. A bit special-purpose, but it shows
4     one way to to deal with user-supplied content that could cause XSS
5     issues w/o the htmlscrubber, and won't survive the scrubber.
6   * Work on firming up the plugin interface:
7     - Plugins should not need to load IkiWiki::Render to get commonly
8       used functions, so moved some functions from there to IkiWiki.
9     - Picked out the set of functions and variables that most plugins
10       use, documented them, and made IkiWiki export them by default,
11       like a proper perl module should.
12     - Use the other functions at your own risk.
13     - This is not quite complete, I still have to decide whether to
14       export some other things.
15   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
16     referring to stuff now exported by the IkiWiki module.
17   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
18     to declare which version of the interface your plugin needs.
19   * Anyone with a third-party ikiwiki plugin is strongly encouraged
20     to make like changes to it and avoid use of non-exported symboles from
21     "IkiWiki::".
22   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
23   * Support hyperestradier version 1.4.2, which adds a new required phraseform
24     setting.
25   * If an inlined page has a permalink, link the page title to that.
26   * Patch from Recai to use utf8 when reading the setup file, so that
27     utf8 wikinames from there will be used properly.
28   * Patch from Recai to kill utf-8 on the wiki name when generating the
29     session cookie.
30   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
31   * Fix a baseurl problem in hyperestradier search results.
32   * Add a stub local.css to avoid problems with 404's.
33   * Patch from Recai to fix a wide character warning from the search plugin
34     during setup if the wikiname contains utf8.
35   * Yet another fix for those poor case-insensative OSX users.
36   * pagetemplate hooks are now also called when generating cgi pages.
37   * Add a favicon plugin, which simply adds a link tag for an icon to each
38     page (and cgis).
39   * Patch from James Westby to deal with the case where you're editing a
40     new page, hit cancel, and need to be redirected to somewhere sane.
41   * Various documentation improvements by various wiki users.
42   * Support Text::Markdown from CPAN, which has a different interface from
43     the original markdown or the one in Debian.
44   * Version the libcgi-session-perl dependency, some features that need
45     the new version are used in some cases (sslcookie).
46   * Numerous tla fixes from Clint.
47
48  -- Joey Hess <joeyh@debian.org>  Fri, 15 Sep 2006 22:28:31 -0400
49
50 ikiwiki (1.26) unstable; urgency=low
51
52   * Add a missing -n to tla undo call.
53   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
54     writes before consuming its whole stdin. Avoid this deadlock.
55   * Fix alt tags for outline checkboxes.
56
57  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
58
59 ikiwiki (1.25) unstable; urgency=low
60
61   * Add proper waitpid calls for open2ed processes throughout to avoid
62     zombies; this hit htmltidy especially badly.
63   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
64     subversion repos and fixing some other issues.
65   * Add support for tla, contributed by Clint Adams. Closes: #385936
66   * Add support for mercurial, contributed by Emanuele Aina.
67   * Include <link rel> tag for RSS feeds, used by some aggregators and
68     firefox to find the feed.
69   * Add a linkmap plugin (requires graphviz).
70
71  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
72
73 ikiwiki (1.24) unstable; urgency=low
74
75   * Simplify the data structure returned by rcs_recentchanges to avoid
76     each rcs plugin needing to form complex strings on its own.
77   * Fix another destpage issue in the inline directive. Closes: #385512
78     again.
79
80  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
81
82 ikiwiki (1.23) unstable; urgency=low
83
84   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
85
86  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
87
88 ikiwiki (1.22) unstable; urgency=low
89
90   * Change how the stylesheet url is determined in the templates: Remove
91     STYLEURL and add BASEURL to all templates (some already had it). This
92     new more general variable can be used to link to other things (eg, images)
93     from the template, as well as stylesheets.
94   * Fix a bug introduced last version to do with nested inlines.
95   * Allow preprocessor directives to span multiple lines, both to make
96     long ones with lots of values easier to write, and to allow for ones with
97     multi-line quoted values.
98   * Allow preprocessor directives to contain python-like triple-quoted
99     text blocks, for easy nesting of quotes inside.
100   * Add a template plugin.
101   * Make pagespec merge code smarter about merging duplicate pagespecs.
102   * Patch from Jordà Polo to make Setup::Standard support hashes in config
103     files.
104   * Change order of linkify and preprocess; first preprocess and then linkify.
105     This allows passing a wikilink inside a parameter to a preprocessor
106     directive without it being expanded to html, and leaking out of the
107     parameter, which had required some non-obvious use of triple-quoting
108     to avoid. Note that any preprocessor plugins that output something
109     that looks like a wikilink will now have it treated as such; AFAIK
110     this doesn't change any behavior though except for the template plugin.
111   * Enable preprocessor directives when previewing an edit.
112   * Make all pages pull in a local.css style sheet, if present. This won't
113     be included in ikiwiki, but can be created to make local styling changes
114     w/o needing to merge in every new change to the distributed style.css.
115   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
116   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
117     from a different directory.
118   * Generalised preprocesser loop protection code.
119   * Patch from James Westby to allow a description to be set for rss feeds.
120   * Patch from James Westby to add a template for the search form.
121   * Added a ddate plugin.
122   * Patch from James Westby to add a --sslcookie switch, which forces
123     cookies to only be sent over ssl connections to avoid interception.
124   * Fix preferences page on anonok wikis; still need to sign in to get
125     to the preferences page.
126   * Add toc (table of contents) plugin.
127   * Change htmlize, format, and sanitize hooks to use named parameters.
128   * Patch from James Westby to add an actions option to inline; this
129     adds Edit and Discussion links at the end of blog entries.
130   * Due to some css changes, you'll want to rebuild your wiki on upgrade
131     to this version. Will be handled automatically by the deb.
132   * Add processed date to aggregate preprocessor directive status output.
133
134  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
135
136 ikiwiki (1.21) unstable; urgency=low
137
138   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
139   * If a page links to itself, mark up the link text in a span with
140     class="selflink" so that it can be styled. I don't have a useful style
141     defined for that though.
142   * Call filter hooks on inlined page content.
143   * Support inlining pages raw, rather than creating a blog.
144   * Clean up yes/no parameter parsing in inline plugin.
145   * Implemented better cycle detection in the inline plugin; nested inlines
146     will now work.
147   * Add a map plugin contributed by Alessandro Dotti Contra.
148   * Add otl format plugin, which handles files as created by vimoutliner.
149   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
150   * Add first draft at a Restructured Text (rst) plugin, by Sergio
151     Talens-Oliag. Note that this has many known issues -- see the caveats on
152     the plugin's page.
153   * Credit everyone who wrote a plugin on the plugins' wiki pages.
154   * Fix utf-8 in blog post form.
155
156  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
157
158 ikiwiki (1.20) unstable; urgency=low
159
160   * Relicense the templates and basewiki under the 2-clause BSD license.
161     Since these can easily become part of other people's websites, they
162     should be under as permissive a license as possible.
163   * Add --syslog config option, to log to the syslog.
164   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
165     transient failure to fork (which I've seen happen in the wild).
166   * Fix a bug in the aggregator introduced last version that caused all
167     aggregator state to be lost during a non-aggregating build.
168
169  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
170
171 ikiwiki (1.19) unstable; urgency=low
172
173   * Fix several related bugs in page type determination during online editing.
174   * Add some locking to prevent 2 aggregators from running at once.
175   * Fix an infinite loop in the aggregator when finding a unique filename.
176
177  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
178
179 ikiwiki (1.18) unstable; urgency=low
180
181   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
182   * Add --version.
183   * Man page format fixups.
184   * If the meta plugin overides the page title, set a title_overridden
185     variable in the template to true. This allows doing things with the
186     templates conditional on the title being overriden.
187   * Add a %pagecase which maps lower-case page names to the actual case
188     used in the filename. Use this in bestlinks calculation instead of
189     forcing the link to lowercase.
190   * Also use %pagecase in various other places that want to check if a page
191     with a given name exists.
192   * This means that links to pages with mixed case names will now work,
193     even if the link is in some other case mixture, and mixed case pages
194     should be fully supported throughout ikiwiki.
195   * Recommend rebuilding wikis on upgrade to this version.
196
197  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
198
199 ikiwiki (1.17) unstable; urgency=low
200
201   * Disable tidy generator tag.
202   * Move tidy back to sanitize hook, found out how to only show body.
203   * Turn off tidy indentation too.
204   * Turn on HTML::Template loop_context_vars; not actually used in stock
205     templates but can be useful for things like making comma-delimited lists
206     of tags or what have you.
207   * Remove <br> from end of aggregate preprocessor directive output.
208   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
209     case-sensative filesystems like OSX.
210   * Improve markdown loading. First, try to load it as a proper perl module,
211     in case it was installed as one. Then fall back to trying
212     /usr/bin/markdown.
213   * Document in install page how to install markdown, since it has no
214     installation procedure in the upstream tarball.
215   * Set die_on_bad_params => 0 for all templates, to allow users to modify
216     them without annoyances.
217   * Suck in the page content when generating an inline archive page, to work
218     around the meta plugin's lack of caching of title metadata across runs.
219
220  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
221
222 ikiwiki (1.16) unstable; urgency=low
223
224   * Try to handle relative links in aggregated feeds. However,
225     the current support is a crude hack due to limitations of XML::Feed:
226     xml:base is not supported, neither is Content-Location. And of course,
227     relative links in RSS feeds are ill-undefined..
228   * Make aggregator save permalinks and author name to pages as metadata.
229   * Add permalink and author support to meta plugin, affecting RSS feeds
230     and blog pages.
231   * Various CSS and formatting changes.
232   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
233   * Add xhtml files to the default prune regexp.
234   * Also generate rel=bookmark links for permalinks.
235   * Fix the htmltidy plugin, which wasn't working due my breaking it when
236     I added it..
237   * Don't run tidy with -xml as that fails if the input is not well-formed.
238     Run it with -asxhtml instead, so it will output well-formed xhtml no
239     matter what the input.
240   * Disable tidy warnings too.
241   * Add a new format hook, and make tidy use it, since tidy can really only
242     operate on and output complete html documents, not the body chunks
243     that sanitise gets.
244   * Fix dates in rss feeds if running localised, so they're still rfc 822.
245
246  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
247
248 ikiwiki (1.15) unstable; urgency=low
249
250   * Remove CDPATH and other env vars perl taint checking doesn't like.
251     Closes: #381279
252   * Added created_before and created_after PageSpec limits.
253
254  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
255
256 ikiwiki (1.14) unstable; urgency=low
257
258   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
259     by 10% or so.
260   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
261   * Added many unit tests for pagespec_match.
262
263  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
264
265 ikiwiki (1.13) unstable; urgency=low
266
267   * ikiwiki can now download and aggregate feeds with its new aggregate
268     plugin, so it's possible to implement a Planet using ikiwiki!
269   * Add a run_hooks function for the common task of running all hooks of a
270     given type.
271   * Add a savestate hook.
272   * Don't put blog post forms on pages if there's no cgiurl set.
273   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
274     --wrappers to do that.
275   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
276     to update pages that haven't changed on disk.
277   * Change meta tags to use html entity-escaped text for values, so that
278     quotes and such can be represented in title tags.
279   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
280     for the above.
281   * Make --rebuild also cause --aggregate to re-download and write aggregated
282     pages.
283   * Avoid outputting duplicate meta info.
284   * Include title metadata on aggregated posts for capitalised and un-munged
285     titles.
286   * Title metadata of inlined pages now shows up in blogs and rss feeds.
287   * Fix issue with unicode filenames and updating the hyper estradier search
288     index. (Aka Please Please Please, let that be the last one.)
289   * Patch from Roland Mas to support an rss=no parameter to inline directives.
290     Closes: #380743
291   * Renamed GlobLists to PageSpecs.
292   * PageSpecs can now include nested parens, "and", and "or". This remains
293     backwards compatible to the old GlobList format. It's implemented by
294     treating the GlobList as a very limited microlanguage that is transformed
295     to perl code that does the matching.
296   * The old GlobList format is deprecated, and I encourage users to switch to
297     using the new PageSpec format. Compatability with the old format will be
298     removed at some point, possibly by 2.0.
299   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
300   * Add support for creation_month and creation_year to PageSpec.
301     Closes: #380680
302   * Changes to index file encoding.
303
304  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
305
306 ikiwiki (1.12) unstable; urgency=low
307
308   "Viva l'Italia!"
309   * New pagestats plugin from Enrico, which can generate a table counting
310     the backlinks for each page, or a del.icio.us style cloud.
311   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
312     the wikiformat plugin works. Thanks, Emanuele Aina.
313   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
314     display, running them through pagetitle. This removes ugly underscores and
315     other gunk from the display, much nicer. You may want to rebuild your wiki
316     when upgrading to get the cleanup globally.
317   * Polygen plugin from Enrico.
318   * htmltidy plugin from Faidon.
319   * Locale patch from Faidon:
320     - Adds a locale setting to setup files.
321     - Proper local time, if the locale configuration option is used.
322     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
323       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
324       impossible.
325   * Add getopt hook type, this allows plugins to add new command-line options.
326   * Add --tagbase option to tag plugin.
327   * Add exclude option in setup files, works same as --exclude.
328   * Put categories in rss feeds for tagged items.
329   * Allow preprocessor directives to be expanded in inlined blog pages.
330     However, to avoid inlining loops etc, don't expand inline directives in
331     inlined pages.
332   * fortune plugin (trivial)
333   * Tag plugins according to type.
334
335  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
336
337 ikiwiki (1.11) unstable; urgency=low
338
339   * Patch from Enrico that
340     - Adds a tag plugin that allows more easily tagging pages.
341       The meta plugin can also still be used for that, but the tag plugin
342       also lists a page's tags at the bottom of the page.
343     - Allows preprocessor directives to have parameters with no specified
344       value.
345     - Fixes preprocessor directive parameter parsing so that
346       foo=bar baz now means "foo=bar" and a "baz" with no value.
347   * Run pagetemplate hooks when inlining pages so that inlined pages also
348     list their tags.
349   * Make all plugins with pagetemplate hooks check that variables exist
350     on the template before setting them, for robustness.
351   * Switch pagetemplate hooks to using named parameters.
352   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
353     This will be the page that a source page will be part of, which is
354     different than the source page for inlined pages.
355   * Audited all plugins to endure they pass (page, destpage) to htmllink
356     appropriatly. This means inlining of various plugins will not work
357     properly, with correct links generated.
358
359  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
360
361 ikiwiki (1.10) unstable; urgency=low
362
363   * Run page through any relevant filters when generating a page preview.
364   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
365     default throughout the wiki, not only on wikitext pages. Decided to call
366     this a feature, and split the camelcase support out into a separate plugin
367     that is independant of wikitext.
368   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
369
370  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
371
372 ikiwiki (1.9) unstable; urgency=low
373
374   * Improve display of parentlinks and page title of toplevel index page.
375   * Patch from Faidon to use svn --limit when possible for recentchanges,
376     speeds up recentchanges a lot for wikis with more history.
377   * Patch from Recai to fix utf8 issues in git backend.
378   * Add wikitext markup plugin, which supports ".wiki" pages written in the
379     original wiki syntax, CamelCase links and all.
380   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
381     support, to edit pages etc without a web server.
382   * Display CGI processing errors if present.
383   * Fix from Faidon for a XML parser issue that breaks utf-8 for
384     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
385     area, and also way slow.
386   * Match 'web commit from' in SVN and git, these are web commits too.
387     (Faidon)
388   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
389     readable and avoid future mistakes. The patch seems to work and for the
390     first time I have a UTF-8 username ;-) (Faidon)
391   * Use form->field consistently, not form->param.
392   * Patch from Recai to allow selection of page type when creating a new page.
393     Default page type is inherited from the link clicked on to create the new
394     page.
395
396  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
397
398 ikiwiki (1.8) unstable; urgency=low
399
400   * Fix orphans plugin to not count a link to a nonexistant page as a reason
401     for a page not being an orphan.
402   * Support pinging services such as Technorati using XML-RPC to notify them
403     about changes to rss feeds.
404   * Parse svn log as xml for improved utf8 and security. Note that this makes
405     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
406   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
407     flagged string even if the locale causes it to generate utf8 output,
408     so make sure to let perl know it should be handled as utf8. Also,
409     the optimised version used for standard time formats won't work if the
410     user has changed locale, so drop it. Thanks, Faidon Liambotis.
411   * Fix re-encoding of the comments field to utf8 if a commit fails
412     due to a conflict. Thanks, Faidon Liambotis.
413   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
414     Liambotis.
415   * Add insane double encode/decode to utf8 around call to markdown.
416     This works around a truely strange bug, which is apparently a bug in
417     perl, #376329. Also added a test case for it.
418   * Improve layout of edit page so formatting help link is always visible w/o
419     getting in the way of the preview.
420   * Centralised all calls to HTML::Template and force all the templates
421     to be read as utf8.
422   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
423   * Introduce add_plugins and disable_plugins config options in setup files.
424     This allows adding or removing plugins w/o overriding the whole list of
425     default plugins, which makes it easier to upgrade when new default plugins
426     are added.
427   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
428     default (of course!). Based on a patch by Faidon Liambotis.
429   * Add a html plugin, which can be used to write wikis in raw html,
430     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
431     defaults to not processing .html files, since w/o this plugin they would
432     be copied unsanitised. With this plugin, it will process and html
433     sanitise them, like any other page type.
434   * Rebuilding wrappers is necessary on upgrade to this version.
435   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
436     will be automatically done on all upgrades.
437   * Don't send pings if the wiki is being rebuilt.
438   * Work around very innefficient behavior in File::Spec::abs2rel. Result
439     is a savings of 2 pointless fork/execs per link calculation, which
440     results in ~25% speedup of ikiwiki building its own doc wiki, and
441     about 35% speedup displaying RecentChanges!
442   * Make RecentChanges use a table and some CSS, should be much more readable.
443     No code changes involved.
444   * Encode & in diffurl in examples, to conform to pedantic rules.
445   * Speed up RecentChanges by another 40% or so with some memoization.
446   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
447     in time to build the doc wiki.
448
449  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
450
451 ikiwiki (1.7) unstable; urgency=low
452
453   * Updated logo from Recai with some kerning and alingment tuning.
454   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
455     changed some output.
456   * Copyright update.
457
458  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
459
460 ikiwiki (1.6) unstable; urgency=low
461
462   * YA utf-8 patch from Recai, this time to fix previewing a page so that
463     the text in the input box is re-encoded back to utf-8.
464   * -CSD does not affect modules, so readfile() was not using the utf-8 input
465     layer, which led to lots of problems; make it force read files as utf-8.
466     Closes: #373203
467   * Note that as a consequence, this version of ikiwiki will actually try to
468     parse utf8 in source files for the first time, which may expose broken
469     utf8 in wiki sources that was hidden before. Most common will be
470     perl warnings like "utf8 "\xE9" does not map to Unicode"
471   * writefile() likewise needs to use the utf8 output layer.
472   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
473     there.
474   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
475     given the readfile fix.
476   * Add utf-8 testcases for readfile and htmlize.
477   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
478     safe.
479   * More utf-8 fixes from Recai, partly to things I broke above:
480     - The serious problem is that writefile() saves the content in undecoded
481       format in CGI, hence all (non-ascii) chars are corrupted permanently.
482     - Comment field in edit page is not decoded and all the non-ascii chars in
483       this field are corrupted as the result.  We should decode it as we do it
484       for the content.
485     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
486       character in print.
487   * New SVG logo from Recai.
488
489  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
490
491 ikiwiki (1.5) unstable; urgency=low
492
493   * Add --timeformat config option to allow changing how dates are displayed.
494     Note that as a side effect, dates will now be displayed using the local
495     timezone, not as GMT.
496   * More security review.
497   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
498     for some handy stuff like:
499     - Using links as a kind of tag; creating blog pages that list all pages
500       containing a given tag/link or not containing some other tag.
501     - Subscribing to mail notifications whenever a change is made to a page
502       that is a backlink of page foo. Ie, "Please notify me of changes in all
503       pages that link to my home page in the wiki"
504     - Locking any pages that are linked to from a particular page, so that
505       lists of locks can be exposed in the wiki.
506   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
507     when a todo item is done, instead of the previous moving it to a different
508     subdir.
509   * Allow pagetemplate plugins to override *anything* in the template.
510   * Add a meta plugin, which allows specifying various metadata about pages,
511     like license and author. It also allows for inserting html link and meta
512     tags into html, overriding the title, and adding hidden WikiLinks, which
513     can be useful when using link-based globbing for page categorisation.
514   * Remove preprocessor directives from inlined pages.
515   * Allow simple preprocessor directive values to be specified w/o quotes.
516   * Add support for using git instead of subversion as the RCS backend,
517     tremendous thanks to Recai Oktaş for this.
518   * Doc updates for git.
519   * Fix absolute url munging in rss generation to support https, ftp, etc urls
520     not just http urls.
521   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
522     utf-8 for edit and other fields, and for recentchanges. There may still
523     be utf-8 issues with the preferences page though.
524
525  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
526
527 ikiwiki (1.4) unstable; urgency=low
528
529   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
530     very strange way of enabling proper XHTML <br /> type tags. Output html
531     should be always valid again now.
532   * The page name and parent links has switched from using a <h1> to a styled
533     <span>, so pages can use <h1> internally instead of needing to use <h2>.
534   * Updated all of ikiwiki's own wiki pages for that.
535   * Add pagetemplate hook, which can be used by plugins that want to mess
536     around with adding new stuff to the page template.
537   * Remove headercontent; the search plugin now adds the search box to the
538     header by registering a pagetemplate hook, and other plugins should do
539     similarly.
540   * Rebuilding on upgrade to this version is recommended.
541   * Add a html validity check to the test suite, using the wdg-html-validator,
542     if available.
543   * Make the html valid when there is nothing in the actions list.
544   * Reordered some function call parameters for consistency.
545   * Enable full utf-8 support for page input and output.
546   * Add a workaround for markdown, which does not work well with utf-8
547     strings.
548   * --getctime had bitrotted (well I only ever used it the once so far..),
549     fix and make it a bit more flexible
550   * rcs_getctime is changed, now rather than needing to loop over all pages,
551     it should just use the rcs to get the ctime of the passed file.
552   * When inlining a page in another one, links from the inlined page are now
553     expanded the same as they are when rendering the inlined page as a
554     standalone page. So rather than being expanded from the POV of the
555     inlining page, they are expanded from the POV of the inlined page.
556
557     For example, a link from blog/foo to "bar" will now link to blog/bar
558     if it exists. Previously this needed to be a link explicitly to
559     "blog/bar"; such links will also continue to work.
560
561     (This was slightly complex to do as the link still has to be constructed
562     relative to the inlining page.)
563   * Make page edit textarea resize to fit browser window.
564   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
565     do not need a full rebuild, in order to update any basewiki pages.
566
567  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
568
569 ikiwiki (1.3) unstable; urgency=low
570
571   * Fix the preinst introduced in the last version. Closes: #367458
572
573  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
574
575 ikiwiki (1.2) unstable; urgency=low
576
577   * Remove dups from the brokenlinks list.
578   * Add libc6-dev to dependencies, needed to build wrappers.
579   * Install wikilist in correct location. Closes: #367371
580
581  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
582
583 ikiwiki (1.1) unstable; urgency=low
584
585   * Rename inlinepage to depends, so that it can be used to refer to more
586     dependency relationships than just inlining. This will require a rebuild
587     on upgrade to this version.
588   * Move the rss link, put it in the blogpost form if there is one and at the
589     top if not. This is both nicer because easier to find, and it cleans up
590     the code which had used inlinepage as a flag for adding the link later.
591   * Allow the depends GlobList to be built up from multiple sources (such as
592     plugins) during a page render.
593   * Which means that more than one blog is now supported to appear on a
594     single page. (With some limitations, like only the last one getting an
595     rss file.)
596   * Added a plugin system.
597   * Added a pagecount plugin, enabled by default.
598   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
599   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
600     backlinks when the backlinks hadn't really changed.
601   * Moved inline page support, rss generation etc into the inline plugin,
602     enabled by default.
603   * Added brokenlinks plugin, not enabled by default, but rather handy.
604   * Fix several broken links in the doc wiki.
605   * Smarter behavior when creating a page and a page of the same name (but
606     different location) already exists.
607   * Add an orphans plugin for finding pages that nothing links to.
608   * Removed backlinks page, which it turns out nothing used.
609   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
610     it, this will allow for adding a unit test suite.
611   * Add unit tests for several core functions, including globlist_match,
612     dirname, basename, bestlink, linkify, pagetitle, titlepage.
613   * Smart globlist merging.
614   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
615     to pave the way for adding other RCS support. This also changes the
616     setup files, where before they had svn => 1 or svn => 0, now they have
617     rcs => "svn" or rcs => "".
618   * Add a debian/NEWS file with upgrade notes.
619   * Load whatever rcs module is specified, so new ones can be just dropped in
620     as plugins and work. (Well, in theory.)
621   * Add some basic docs about writing RCS modules.
622   * Broke search capability out into a plugin, removed the --hyperestraier
623     switch.
624   * Added smiley plugin, nicely controlled and documented by the smileys page.
625   * Copied in some smileys from Moin Moin.
626   * Allow links of the form [[some page|page]], with whitespace in the link
627     text.
628   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
629     and --disable-plugin htmlscrubber.
630   * Allow discussion links on pages to be turned off with --no-discussion.
631   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
632   * Add some new config items to the estseek.conf template, which are needed
633     by hyperestraier 1.2.3.
634
635  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
636
637 ikiwiki (1.0) unstable; urgency=low
638
639   * First official release.
640
641  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400