1 ikiwiki (1.8) UNRELEASED; urgency=low
3 * Fix orphans plugin to not count a link to a nonexistant page as a reason
4 for a page not being an orphan.
5 * Support pinging services such as Technorati using XML-RPC to notify them
6 about changes to rss feeds.
7 * Parse svn log as xml for improved utf8 and security. Note that this makes
8 ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
9 * POSIX::strftime doesn't know about encodings and doesn't return a utf8
10 flagged string even if the locale causes it to generate utf8 output,
11 so make sure to let perl know it should be handled as utf8. Also,
12 the optimised version used for standard time formats won't work if the
13 user has changed locale, so drop it. Thanks, Faidon Liambotis.
14 * Fix re-encoding of the comments field to utf8 if a commit fails
15 due to a conflict. Thanks, Faidon Liambotis.
16 * Let svn know that commits have utf8 commit messages. Thanks, Faidon
18 * Add insane double encode/decode to utf8 around call to markdown.
19 This works around a truely strange bug, which is apparently a bug in
20 perl, #376329. Also added a test case for it.
21 * Improve layout of edit page so formatting help link is always visible w/o
22 getting in the way of the preview.
23 * Centralised all calls to HTML::Template and force all the templates
26 -- Joey Hess <joeyh@debian.org> Sun, 2 Jul 2006 14:55:40 -0400
28 ikiwiki (1.7) unstable; urgency=low
30 * Updated logo from Recai with some kerning and alingment tuning.
31 * Patch from Recai to fix git recentchanges code to work with git 1.4 which
35 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
37 ikiwiki (1.6) unstable; urgency=low
39 * YA utf-8 patch from Recai, this time to fix previewing a page so that
40 the text in the input box is re-encoded back to utf-8.
41 * -CSD does not affect modules, so readfile() was not using the utf-8 input
42 layer, which led to lots of problems; make it force read files as utf-8.
44 * Note that as a consequence, this version of ikiwiki will actually try to
45 parse utf8 in source files for the first time, which may expose broken
46 utf8 in wiki sources that was hidden before. Most common will be
47 perl warnings like "utf8 "\xE9" does not map to Unicode"
48 * writefile() likewise needs to use the utf8 output layer.
49 * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
51 * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
52 given the readfile fix.
53 * Add utf-8 testcases for readfile and htmlize.
54 * Put back the encode_utf8 in the input to markdown; it's really not utf-8
56 * More utf-8 fixes from Recai, partly to things I broke above:
57 - The serious problem is that writefile() saves the content in undecoded
58 format in CGI, hence all (non-ascii) chars are corrupted permanently.
59 - Comment field in edit page is not decoded and all the non-ascii chars in
60 this field are corrupted as the result. We should decode it as we do it
62 - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
64 * New SVG logo from Recai.
66 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
68 ikiwiki (1.5) unstable; urgency=low
70 * Add --timeformat config option to allow changing how dates are displayed.
71 Note that as a side effect, dates will now be displayed using the local
73 * More security review.
74 * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
75 for some handy stuff like:
76 - Using links as a kind of tag; creating blog pages that list all pages
77 containing a given tag/link or not containing some other tag.
78 - Subscribing to mail notifications whenever a change is made to a page
79 that is a backlink of page foo. Ie, "Please notify me of changes in all
80 pages that link to my home page in the wiki"
81 - Locking any pages that are linked to from a particular page, so that
82 lists of locks can be exposed in the wiki.
83 * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
84 when a todo item is done, instead of the previous moving it to a different
86 * Allow pagetemplate plugins to override *anything* in the template.
87 * Add a meta plugin, which allows specifying various metadata about pages,
88 like license and author. It also allows for inserting html link and meta
89 tags into html, overriding the title, and adding hidden WikiLinks, which
90 can be useful when using link-based globbing for page categorisation.
91 * Remove preprocessor directives from inlined pages.
92 * Allow simple preprocessor directive values to be specified w/o quotes.
93 * Add support for using git instead of subversion as the RCS backend,
94 tremendous thanks to Recai Oktaş for this.
95 * Doc updates for git.
96 * Fix absolute url munging in rss generation to support https, ftp, etc urls
98 * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
99 utf-8 for edit and other fields, and for recentchanges. There may still
100 be utf-8 issues with the preferences page though.
102 -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
104 ikiwiki (1.4) unstable; urgency=low
106 * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
107 very strange way of enabling proper XHTML <br /> type tags. Output html
108 should be always valid again now.
109 * The page name and parent links has switched from using a <h1> to a styled
110 <span>, so pages can use <h1> internally instead of needing to use <h2>.
111 * Updated all of ikiwiki's own wiki pages for that.
112 * Add pagetemplate hook, which can be used by plugins that want to mess
113 around with adding new stuff to the page template.
114 * Remove headercontent; the search plugin now adds the search box to the
115 header by registering a pagetemplate hook, and other plugins should do
117 * Rebuilding on upgrade to this version is recommended.
118 * Add a html validity check to the test suite, using the wdg-html-validator,
120 * Make the html valid when there is nothing in the actions list.
121 * Reordered some function call parameters for consistency.
122 * Enable full utf-8 support for page input and output.
123 * Add a workaround for markdown, which does not work well with utf-8
125 * --getctime had bitrotted (well I only ever used it the once so far..),
126 fix and make it a bit more flexible
127 * rcs_getctime is changed, now rather than needing to loop over all pages,
128 it should just use the rcs to get the ctime of the passed file.
129 * When inlining a page in another one, links from the inlined page are now
130 expanded the same as they are when rendering the inlined page as a
131 standalone page. So rather than being expanded from the POV of the
132 inlining page, they are expanded from the POV of the inlined page.
134 For example, a link from blog/foo to "bar" will now link to blog/bar
135 if it exists. Previously this needed to be a link explicitly to
136 "blog/bar"; such links will also continue to work.
138 (This was slightly complex to do as the link still has to be constructed
139 relative to the inlining page.)
140 * Make page edit textarea resize to fit browser window.
141 * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
142 do not need a full rebuild, in order to update any basewiki pages.
144 -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
146 ikiwiki (1.3) unstable; urgency=low
148 * Fix the preinst introduced in the last version. Closes: #367458
150 -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
152 ikiwiki (1.2) unstable; urgency=low
154 * Remove dups from the brokenlinks list.
155 * Add libc6-dev to dependencies, needed to build wrappers.
156 * Install wikilist in correct location. Closes: #367371
158 -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
160 ikiwiki (1.1) unstable; urgency=low
162 * Rename inlinepage to depends, so that it can be used to refer to more
163 dependency relationships than just inlining. This will require a rebuild
164 on upgrade to this version.
165 * Move the rss link, put it in the blogpost form if there is one and at the
166 top if not. This is both nicer because easier to find, and it cleans up
167 the code which had used inlinepage as a flag for adding the link later.
168 * Allow the depends GlobList to be built up from multiple sources (such as
169 plugins) during a page render.
170 * Which means that more than one blog is now supported to appear on a
171 single page. (With some limitations, like only the last one getting an
173 * Added a plugin system.
174 * Added a pagecount plugin, enabled by default.
175 * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
176 * Fixed/optimised backlinks code, to avoid rebuilding pages to update
177 backlinks when the backlinks hadn't really changed.
178 * Moved inline page support, rss generation etc into the inline plugin,
180 * Added brokenlinks plugin, not enabled by default, but rather handy.
181 * Fix several broken links in the doc wiki.
182 * Smarter behavior when creating a page and a page of the same name (but
183 different location) already exists.
184 * Add an orphans plugin for finding pages that nothing links to.
185 * Removed backlinks page, which it turns out nothing used.
186 * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
187 it, this will allow for adding a unit test suite.
188 * Add unit tests for several core functions, including globlist_match,
189 dirname, basename, bestlink, linkify, pagetitle, titlepage.
190 * Smart globlist merging.
191 * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
192 to pave the way for adding other RCS support. This also changes the
193 setup files, where before they had svn => 1 or svn => 0, now they have
194 rcs => "svn" or rcs => "".
195 * Add a debian/NEWS file with upgrade notes.
196 * Load whatever rcs module is specified, so new ones can be just dropped in
197 as plugins and work. (Well, in theory.)
198 * Add some basic docs about writing RCS modules.
199 * Broke search capability out into a plugin, removed the --hyperestraier
201 * Added smiley plugin, nicely controlled and documented by the smileys page.
202 * Copied in some smileys from Moin Moin.
203 * Allow links of the form [[some page|page]], with whitespace in the link
205 * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
206 and --disable-plugin htmlscrubber.
207 * Allow discussion links on pages to be turned off with --no-discussion.
208 * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
209 * Add some new config items to the estseek.conf template, which are needed
210 by hyperestraier 1.2.3.
212 -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
214 ikiwiki (1.0) unstable; urgency=low
216 * First official release.
218 -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400