* Add --syslog config option, to log to the syslog.
[ikiwiki] / debian / changelog
1 ikiwiki (1.20) UNRELEASED; urgency=low
2
3   * Relicense the templates and basewiki under the 2-clause BSD license.
4     Since these can easily become part of other people's websites, they
5     should be under as permissive a license as possible.
6   * Add --syslog config option, to log to the syslog.
7
8  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 17:07:35 -0400
9
10 ikiwiki (1.19) unstable; urgency=low
11
12   * Fix several related bugs in page type determination during online editing.
13   * Add some locking to prevent 2 aggregators from running at once.
14   * Fix an infinite loop in the aggregator when finding a unique filename.
15
16  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
17
18 ikiwiki (1.18) unstable; urgency=low
19
20   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
21   * Add --version.
22   * Man page format fixups.
23   * If the meta plugin overides the page title, set a title_overridden
24     variable in the template to true. This allows doing things with the
25     templates conditional on the title being overriden.
26   * Add a %pagecase which maps lower-case page names to the actual case
27     used in the filename. Use this in bestlinks calculation instead of
28     forcing the link to lowercase.
29   * Also use %pagecase in various other places that want to check if a page
30     with a given name exists.
31   * This means that links to pages with mixed case names will now work,
32     even if the link is in some other case mixture, and mixed case pages
33     should be fully supported throughout ikiwiki.
34   * Recommend rebuilding wikis on upgrade to this version.
35
36  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
37
38 ikiwiki (1.17) unstable; urgency=low
39
40   * Disable tidy generator tag.
41   * Move tidy back to sanitize hook, found out how to only show body.
42   * Turn off tidy indentation too.
43   * Turn on HTML::Template loop_context_vars; not actually used in stock
44     templates but can be useful for things like making comma-delimited lists
45     of tags or what have you.
46   * Remove <br> from end of aggregate preprocessor directive output.
47   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
48     case-sensative filesystems like OSX.
49   * Improve markdown loading. First, try to load it as a proper perl module,
50     in case it was installed as one. Then fall back to trying
51     /usr/bin/markdown.
52   * Document in install page how to install markdown, since it has no
53     installation procedure in the upstream tarball.
54   * Set die_on_bad_params => 0 for all templates, to allow users to modify
55     them without annoyances.
56   * Suck in the page content when generating an inline archive page, to work
57     around the meta plugin's lack of caching of title metadata across runs.
58
59  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
60
61 ikiwiki (1.16) unstable; urgency=low
62
63   * Try to handle relative links in aggregated feeds. However,
64     the current support is a crude hack due to limitations of XML::Feed:
65     xml:base is not supported, neither is Content-Location. And of course,
66     relative links in RSS feeds are ill-undefined..
67   * Make aggregator save permalinks and author name to pages as metadata.
68   * Add permalink and author support to meta plugin, affecting RSS feeds
69     and blog pages.
70   * Various CSS and formatting changes.
71   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
72   * Add xhtml files to the default prune regexp.
73   * Also generate rel=bookmark links for permalinks.
74   * Fix the htmltidy plugin, which wasn't working due my breaking it when
75     I added it..
76   * Don't run tidy with -xml as that fails if the input is not well-formed.
77     Run it with -asxhtml instead, so it will output well-formed xhtml no
78     matter what the input.
79   * Disable tidy warnings too.
80   * Add a new format hook, and make tidy use it, since tidy can really only
81     operate on and output complete html documents, not the body chunks
82     that sanitise gets.
83   * Fix dates in rss feeds if running localised, so they're still rfc 822.
84
85  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
86
87 ikiwiki (1.15) unstable; urgency=low
88
89   * Remove CDPATH and other env vars perl taint checking doesn't like.
90     Closes: #381279
91   * Added created_before and created_after PageSpec limits.
92
93  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
94
95 ikiwiki (1.14) unstable; urgency=low
96
97   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
98     by 10% or so.
99   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
100   * Added many unit tests for pagespec_match.
101
102  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
103
104 ikiwiki (1.13) unstable; urgency=low
105
106   * ikiwiki can now download and aggregate feeds with its new aggregate
107     plugin, so it's possible to implement a Planet using ikiwiki!
108   * Add a run_hooks function for the common task of running all hooks of a
109     given type.
110   * Add a savestate hook.
111   * Don't put blog post forms on pages if there's no cgiurl set.
112   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
113     --wrappers to do that.
114   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
115     to update pages that haven't changed on disk.
116   * Change meta tags to use html entity-escaped text for values, so that
117     quotes and such can be represented in title tags.
118   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
119     for the above.
120   * Make --rebuild also cause --aggregate to re-download and write aggregated
121     pages.
122   * Avoid outputting duplicate meta info.
123   * Include title metadata on aggregated posts for capitalised and un-munged
124     titles.
125   * Title metadata of inlined pages now shows up in blogs and rss feeds.
126   * Fix issue with unicode filenames and updating the hyper estradier search
127     index. (Aka Please Please Please, let that be the last one.)
128   * Patch from Roland Mas to support an rss=no parameter to inline directives.
129     Closes: #380743
130   * Renamed GlobLists to PageSpecs.
131   * PageSpecs can now include nested parens, "and", and "or". This remains
132     backwards compatible to the old GlobList format. It's implemented by
133     treating the GlobList as a very limited microlanguage that is transformed
134     to perl code that does the matching.
135   * The old GlobList format is deprecated, and I encourage users to switch to
136     using the new PageSpec format. Compatability with the old format will be
137     removed at some point, possibly by 2.0.
138   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
139   * Add support for creation_month and creation_year to PageSpec.
140     Closes: #380680
141   * Changes to index file encoding.
142
143  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
144
145 ikiwiki (1.12) unstable; urgency=low
146
147   "Viva l'Italia!"
148   * New pagestats plugin from Enrico, which can generate a table counting
149     the backlinks for each page, or a del.icio.us style cloud.
150   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
151     the wikiformat plugin works. Thanks, Emanuele Aina.
152   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
153     display, running them through pagetitle. This removes ugly underscores and
154     other gunk from the display, much nicer. You may want to rebuild your wiki
155     when upgrading to get the cleanup globally.
156   * Polygen plugin from Enrico.
157   * htmltidy plugin from Faidon.
158   * Locale patch from Faidon:
159     - Adds a locale setting to setup files.
160     - Proper local time, if the locale configuration option is used.
161     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
162       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
163       impossible.
164   * Add getopt hook type, this allows plugins to add new command-line options.
165   * Add --tagbase option to tag plugin.
166   * Add exclude option in setup files, works same as --exclude.
167   * Put categories in rss feeds for tagged items.
168   * Allow preprocessor directives to be expanded in inlined blog pages.
169     However, to avoid inlining loops etc, don't expand inline directives in
170     inlined pages.
171   * fortune plugin (trivial)
172   * Tag plugins according to type.
173
174  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
175
176 ikiwiki (1.11) unstable; urgency=low
177
178   * Patch from Enrico that
179     - Adds a tag plugin that allows more easily tagging pages.
180       The meta plugin can also still be used for that, but the tag plugin
181       also lists a page's tags at the bottom of the page.
182     - Allows preprocessor directives to have parameters with no specified
183       value.
184     - Fixes preprocessor directive parameter parsing so that
185       foo=bar baz now means "foo=bar" and a "baz" with no value.
186   * Run pagetemplate hooks when inlining pages so that inlined pages also
187     list their tags.
188   * Make all plugins with pagetemplate hooks check that variables exist
189     on the template before setting them, for robustness.
190   * Switch pagetemplate hooks to using named parameters.
191   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
192     This will be the page that a source page will be part of, which is
193     different than the source page for inlined pages.
194   * Audited all plugins to endure they pass (page, destpage) to htmllink
195     appropriatly. This means inlining of various plugins will not work
196     properly, with correct links generated.
197
198  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
199
200 ikiwiki (1.10) unstable; urgency=low
201
202   * Run page through any relevant filters when generating a page preview.
203   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
204     default throughout the wiki, not only on wikitext pages. Decided to call
205     this a feature, and split the camelcase support out into a separate plugin
206     that is independant of wikitext.
207   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
208
209  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
210
211 ikiwiki (1.9) unstable; urgency=low
212
213   * Improve display of parentlinks and page title of toplevel index page.
214   * Patch from Faidon to use svn --limit when possible for recentchanges,
215     speeds up recentchanges a lot for wikis with more history.
216   * Patch from Recai to fix utf8 issues in git backend.
217   * Add wikitext markup plugin, which supports ".wiki" pages written in the
218     original wiki syntax, CamelCase links and all.
219   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
220     support, to edit pages etc without a web server.
221   * Display CGI processing errors if present.
222   * Fix from Faidon for a XML parser issue that breaks utf-8 for
223     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
224     area, and also way slow.
225   * Match 'web commit from' in SVN and git, these are web commits too.
226     (Faidon)
227   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
228     readable and avoid future mistakes. The patch seems to work and for the
229     first time I have a UTF-8 username ;-) (Faidon)
230   * Use form->field consistently, not form->param.
231   * Patch from Recai to allow selection of page type when creating a new page.
232     Default page type is inherited from the link clicked on to create the new
233     page.
234
235  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
236
237 ikiwiki (1.8) unstable; urgency=low
238
239   * Fix orphans plugin to not count a link to a nonexistant page as a reason
240     for a page not being an orphan.
241   * Support pinging services such as Technorati using XML-RPC to notify them
242     about changes to rss feeds.
243   * Parse svn log as xml for improved utf8 and security. Note that this makes
244     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
245   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
246     flagged string even if the locale causes it to generate utf8 output,
247     so make sure to let perl know it should be handled as utf8. Also,
248     the optimised version used for standard time formats won't work if the
249     user has changed locale, so drop it. Thanks, Faidon Liambotis.
250   * Fix re-encoding of the comments field to utf8 if a commit fails
251     due to a conflict. Thanks, Faidon Liambotis.
252   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
253     Liambotis.
254   * Add insane double encode/decode to utf8 around call to markdown.
255     This works around a truely strange bug, which is apparently a bug in
256     perl, #376329. Also added a test case for it.
257   * Improve layout of edit page so formatting help link is always visible w/o
258     getting in the way of the preview.
259   * Centralised all calls to HTML::Template and force all the templates
260     to be read as utf8.
261   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
262   * Introduce add_plugins and disable_plugins config options in setup files.
263     This allows adding or removing plugins w/o overriding the whole list of
264     default plugins, which makes it easier to upgrade when new default plugins
265     are added.
266   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
267     default (of course!). Based on a patch by Faidon Liambotis.
268   * Add a html plugin, which can be used to write wikis in raw html,
269     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
270     defaults to not processing .html files, since w/o this plugin they would
271     be copied unsanitised. With this plugin, it will process and html
272     sanitise them, like any other page type.
273   * Rebuilding wrappers is necessary on upgrade to this version.
274   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
275     will be automatically done on all upgrades.
276   * Don't send pings if the wiki is being rebuilt.
277   * Work around very innefficient behavior in File::Spec::abs2rel. Result
278     is a savings of 2 pointless fork/execs per link calculation, which
279     results in ~25% speedup of ikiwiki building its own doc wiki, and
280     about 35% speedup displaying RecentChanges!
281   * Make RecentChanges use a table and some CSS, should be much more readable.
282     No code changes involved.
283   * Encode & in diffurl in examples, to conform to pedantic rules.
284   * Speed up RecentChanges by another 40% or so with some memoization.
285   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
286     in time to build the doc wiki.
287
288  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
289
290 ikiwiki (1.7) unstable; urgency=low
291
292   * Updated logo from Recai with some kerning and alingment tuning.
293   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
294     changed some output.
295   * Copyright update.
296
297  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
298
299 ikiwiki (1.6) unstable; urgency=low
300
301   * YA utf-8 patch from Recai, this time to fix previewing a page so that
302     the text in the input box is re-encoded back to utf-8.
303   * -CSD does not affect modules, so readfile() was not using the utf-8 input
304     layer, which led to lots of problems; make it force read files as utf-8.
305     Closes: #373203
306   * Note that as a consequence, this version of ikiwiki will actually try to
307     parse utf8 in source files for the first time, which may expose broken
308     utf8 in wiki sources that was hidden before. Most common will be
309     perl warnings like "utf8 "\xE9" does not map to Unicode"
310   * writefile() likewise needs to use the utf8 output layer.
311   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
312     there.
313   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
314     given the readfile fix.
315   * Add utf-8 testcases for readfile and htmlize.
316   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
317     safe.
318   * More utf-8 fixes from Recai, partly to things I broke above:
319     - The serious problem is that writefile() saves the content in undecoded
320       format in CGI, hence all (non-ascii) chars are corrupted permanently.
321     - Comment field in edit page is not decoded and all the non-ascii chars in
322       this field are corrupted as the result.  We should decode it as we do it
323       for the content.
324     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
325       character in print.
326   * New SVG logo from Recai.
327
328  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
329
330 ikiwiki (1.5) unstable; urgency=low
331
332   * Add --timeformat config option to allow changing how dates are displayed.
333     Note that as a side effect, dates will now be displayed using the local
334     timezone, not as GMT.
335   * More security review.
336   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
337     for some handy stuff like:
338     - Using links as a kind of tag; creating blog pages that list all pages
339       containing a given tag/link or not containing some other tag.
340     - Subscribing to mail notifications whenever a change is made to a page
341       that is a backlink of page foo. Ie, "Please notify me of changes in all
342       pages that link to my home page in the wiki"
343     - Locking any pages that are linked to from a particular page, so that
344       lists of locks can be exposed in the wiki.
345   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
346     when a todo item is done, instead of the previous moving it to a different
347     subdir.
348   * Allow pagetemplate plugins to override *anything* in the template.
349   * Add a meta plugin, which allows specifying various metadata about pages,
350     like license and author. It also allows for inserting html link and meta
351     tags into html, overriding the title, and adding hidden WikiLinks, which
352     can be useful when using link-based globbing for page categorisation.
353   * Remove preprocessor directives from inlined pages.
354   * Allow simple preprocessor directive values to be specified w/o quotes.
355   * Add support for using git instead of subversion as the RCS backend,
356     tremendous thanks to Recai Oktaş for this.
357   * Doc updates for git.
358   * Fix absolute url munging in rss generation to support https, ftp, etc urls
359     not just http urls.
360   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
361     utf-8 for edit and other fields, and for recentchanges. There may still
362     be utf-8 issues with the preferences page though.
363
364  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
365
366 ikiwiki (1.4) unstable; urgency=low
367
368   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
369     very strange way of enabling proper XHTML <br /> type tags. Output html
370     should be always valid again now.
371   * The page name and parent links has switched from using a <h1> to a styled
372     <span>, so pages can use <h1> internally instead of needing to use <h2>.
373   * Updated all of ikiwiki's own wiki pages for that.
374   * Add pagetemplate hook, which can be used by plugins that want to mess
375     around with adding new stuff to the page template.
376   * Remove headercontent; the search plugin now adds the search box to the
377     header by registering a pagetemplate hook, and other plugins should do
378     similarly.
379   * Rebuilding on upgrade to this version is recommended.
380   * Add a html validity check to the test suite, using the wdg-html-validator,
381     if available.
382   * Make the html valid when there is nothing in the actions list.
383   * Reordered some function call parameters for consistency.
384   * Enable full utf-8 support for page input and output.
385   * Add a workaround for markdown, which does not work well with utf-8
386     strings.
387   * --getctime had bitrotted (well I only ever used it the once so far..),
388     fix and make it a bit more flexible
389   * rcs_getctime is changed, now rather than needing to loop over all pages,
390     it should just use the rcs to get the ctime of the passed file.
391   * When inlining a page in another one, links from the inlined page are now
392     expanded the same as they are when rendering the inlined page as a
393     standalone page. So rather than being expanded from the POV of the
394     inlining page, they are expanded from the POV of the inlined page.
395
396     For example, a link from blog/foo to "bar" will now link to blog/bar
397     if it exists. Previously this needed to be a link explicitly to
398     "blog/bar"; such links will also continue to work.
399
400     (This was slightly complex to do as the link still has to be constructed
401     relative to the inlining page.)
402   * Make page edit textarea resize to fit browser window.
403   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
404     do not need a full rebuild, in order to update any basewiki pages.
405
406  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
407
408 ikiwiki (1.3) unstable; urgency=low
409
410   * Fix the preinst introduced in the last version. Closes: #367458
411
412  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
413
414 ikiwiki (1.2) unstable; urgency=low
415
416   * Remove dups from the brokenlinks list.
417   * Add libc6-dev to dependencies, needed to build wrappers.
418   * Install wikilist in correct location. Closes: #367371
419
420  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
421
422 ikiwiki (1.1) unstable; urgency=low
423
424   * Rename inlinepage to depends, so that it can be used to refer to more
425     dependency relationships than just inlining. This will require a rebuild
426     on upgrade to this version.
427   * Move the rss link, put it in the blogpost form if there is one and at the
428     top if not. This is both nicer because easier to find, and it cleans up
429     the code which had used inlinepage as a flag for adding the link later.
430   * Allow the depends GlobList to be built up from multiple sources (such as
431     plugins) during a page render.
432   * Which means that more than one blog is now supported to appear on a
433     single page. (With some limitations, like only the last one getting an
434     rss file.)
435   * Added a plugin system.
436   * Added a pagecount plugin, enabled by default.
437   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
438   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
439     backlinks when the backlinks hadn't really changed.
440   * Moved inline page support, rss generation etc into the inline plugin,
441     enabled by default.
442   * Added brokenlinks plugin, not enabled by default, but rather handy.
443   * Fix several broken links in the doc wiki.
444   * Smarter behavior when creating a page and a page of the same name (but
445     different location) already exists.
446   * Add an orphans plugin for finding pages that nothing links to.
447   * Removed backlinks page, which it turns out nothing used.
448   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
449     it, this will allow for adding a unit test suite.
450   * Add unit tests for several core functions, including globlist_match,
451     dirname, basename, bestlink, linkify, pagetitle, titlepage.
452   * Smart globlist merging.
453   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
454     to pave the way for adding other RCS support. This also changes the
455     setup files, where before they had svn => 1 or svn => 0, now they have
456     rcs => "svn" or rcs => "".
457   * Add a debian/NEWS file with upgrade notes.
458   * Load whatever rcs module is specified, so new ones can be just dropped in
459     as plugins and work. (Well, in theory.)
460   * Add some basic docs about writing RCS modules.
461   * Broke search capability out into a plugin, removed the --hyperestraier
462     switch.
463   * Added smiley plugin, nicely controlled and documented by the smileys page.
464   * Copied in some smileys from Moin Moin.
465   * Allow links of the form [[some page|page]], with whitespace in the link
466     text.
467   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
468     and --disable-plugin htmlscrubber.
469   * Allow discussion links on pages to be turned off with --no-discussion.
470   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
471   * Add some new config items to the estseek.conf template, which are needed
472     by hyperestraier 1.2.3.
473
474  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
475
476 ikiwiki (1.0) unstable; urgency=low
477
478   * First official release.
479
480  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400