* Patch from James Westby to support podcasting, photoblogging, vidcasting,
[ikiwiki] / debian / changelog
1 ikiwiki (1.32) UNRELEASED; urgency=low
2
3   * Add a separate pass to find page links, and only render each page once,
4     instead of over and over. Typical speedup is ~4x. Max possible speedup:
5     8x.
6   * Add "scan" parameter to hook(), which is used to make the hook be called
7     during the scanning pass, as well as the render pass. The meta and tag
8     plugins need to use the new scan parameter, so will any others that modify
9     %links.
10   * Now that links are calculated in a separate pass, it can also
11     precalculate backlinks in one pass, which is O(N^2) instead of the
12     previous code that was O(N^3). A very nice speedup for wikis with lots
13     (thousands) of pages.
14   * Stylish update to the ikiwiki logo, thanks to Recai Oktaş and Selçuk
15     Erdem.
16   * Add a default stylesheet entry for the pagecloud.
17   * Add examples page with some examples of things that can be done using
18     ikiwiki, like a weblog. The examples can be copied into a user's wiki
19     for a quick start, without needing to learn everything about how to put
20     them together.
21   * Install the source of the examples into /usr/share/doc/ikiwiki/examples.
22   * Add perlmagick to build-depends so syntax check of img plugin works.
23   * Improve login/register process, the login dialog has only name and
24     password fields, which allows more web browsers to regognise it as a login
25     field, and is less confusing.
26   * Implemented expiry options for aggregate plugin.
27   * Use precalculated backlinks info when determining if files need an update
28     due to a page they link to being added/removed. Mostly significant if
29     there are lots of pages.
30   * Remove duplicate link info when saving index. In some cases it could
31     pile up rather badly. (Probably not the best way to deal with this
32     problem.)
33   * Patch from James Westby to support podcasting, photoblogging, vidcasting,
34     or what have you, by creating enclosures for non-page items that are
35     included in feeds.
36
37  -- Joey Hess <joeyh@debian.org>  Wed,  1 Nov 2006 01:11:10 -0500
38
39 ikiwiki (1.31) unstable; urgency=low
40
41   * Patch from Pawel Tecza to cp -a the templates in the Makefile.
42   * Change the rss feed title from the wikiname to the page title, with
43     an exception for the wiki's toplevel index page, which will still use the
44     wikiname as the feed title.
45     Overriding the page title with meta title already overrode the rss feed
46     tittle.
47   * Add an img plugin, based on Christian Mock's img plugin, but stripped
48     down to the bare essentials. Useful for handling large images on websites.
49   * Sanitize possibly problimatic characters out of the polygen grammar names,
50     just in case. Should not be exploitable anyway, since it only tries to run
51     polygen after finding the specified grammar file.
52   * Add missing dependency on the URI perl module.
53   * Add basic spam fighting tool for admins: An admin's prefs page now allows
54     editing a list of banned users.
55
56  -- Joey Hess <joeyh@debian.org>  Fri, 27 Oct 2006 23:16:33 -0400
57
58 ikiwiki (1.30) unstable; urgency=low
59
60   * Add no_override parameter to hook().
61   * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
62     plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
63     can be configured using a page in wiki.
64   * Fix support for --pingurl at the command line.
65   * Fix a subtle bug in will_render that broke some builds, by only clearing
66     items from renderedfiles the first time per build.
67   * Wrap entire technortati ping operation in an eval to catch all possible
68     failure modes, after I observed a simple ->value crashing ikiwiki when
69     a ping failed.
70
71  -- Joey Hess <joeyh@debian.org>  Mon, 16 Oct 2006 15:17:38 -0400
72
73 ikiwiki (1.29) unstable; urgency=low
74
75   * Patch from Paul Tötterman to use CP in the Makefile.
76   * Patch from Alec Berryman adding a http_auth config item that allows
77     using HTTP Authentication instead of ikiwiki's built in authentication.
78     Useful for eg, large sites with their own previously existing user auth
79     setup. Closes: #384534
80   * Change %renderedfiles to store an array of files rendered from a given
81     source file, to allow tracking of extra rendered files like rss feeds.
82   * Note that plugins that accessed this variable will need to be updated!
83     The plugin interface has been increased to version 1.01 for this change.
84     As few plugins use %renderedfiles I haven't done anything else to ensure
85     compatability of old plugins.
86   * Add will_render function to the plugin interface, used to register that a
87     page renders a destination file, and do some security checks. Previously
88     but no longer rendered files will be cleaned up.
89   * Use will_render in the inline and linkmap plugins.
90   * You will need to rebuild your wiki on upgrade to this version.
91   * Atom feed support based on a patch by Clint Adams.
92   * Add feeds=no option to inline preprocessor directive to turn off all types
93     of feeds.
94   * $IkiWiki::version now holds the program version, and is accessible to
95     plugins.
96   * Make the aggregate plugin emphasize error messages.
97   * Patch from Recai to limit recentchanges to displaying max 10 files for a
98     given changeset (to avoid large number of file changes excessively
99     bloating the page).
100
101  -- Joey Hess <joeyh@debian.org>  Fri, 13 Oct 2006 23:14:28 -0400
102
103 ikiwiki (1.28) unstable; urgency=low
104
105   * inline: Add ability to sort by page name, based on a patch from
106     Benjamin A'Lee.
107   * Fix a forkbomb in various calls to IPC::Open2, which has a highly
108     braindead interface. Closes: #389383
109   * Don't rm -rf ikiwiki on distclean, since a) there's no such file
110     and b) those poor Mac OSX users and their case insensative files!
111   * Don't fail syntax check if Text::Typography isn't installed.
112     Closes: #389406
113
114  -- Joey Hess <joeyh@debian.org>  Tue, 26 Sep 2006 02:08:17 -0400
115
116 ikiwiki (1.27) unstable; urgency=low
117
118   * Work on firming up the plugin interface:
119     - Plugins should not need to load IkiWiki::Render to get commonly
120       used functions, so moved some functions from there to IkiWiki.
121     - Picked out the set of functions and variables that most plugins
122       use, documented them, and made IkiWiki export them by default,
123       like a proper perl module should.
124     - Use the other functions at your own risk.
125     - This is not quite complete, I still have to decide whether to
126       export some other things.
127   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
128     referring to stuff now exported by the IkiWiki module.
129   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
130     to declare which version of the interface your plugin needs.
131   * Anyone with a third-party ikiwiki plugin is strongly encouraged
132     to make like changes to it and avoid use of non-exported symbols from
133     "IkiWiki::".
134   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
135   * Support hyperestradier version 1.4.2, which adds a new required phraseform
136     setting.
137   * If an inlined page has a permalink, link the page title to that.
138   * Patch from Recai to use utf8 when reading the setup file, so that
139     utf8 wikinames from there will be used properly.
140   * Patch from Recai to kill utf-8 on the wiki name when generating the
141     session cookie.
142   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
143   * Fix a baseurl problem in hyperestradier search results.
144   * Add a stub local.css to avoid problems with 404's.
145   * Patch from Recai to fix a wide character warning from the search plugin
146     during setup if the wikiname contains utf8.
147   * Yet another fix for those poor case-insensative OS X users.
148   * pagetemplate hooks are now also called when generating cgi pages.
149   * Add a favicon plugin, which simply adds a link tag for an icon to each
150     page (and cgis).
151   * Patch from James Westby to deal with the case where you're editing a
152     new page, hit cancel, and need to be redirected to somewhere sane.
153   * Various documentation improvements by various wiki users.
154   * Support Text::Markdown from CPAN, which has a different interface from
155     the original markdown or the one in Debian.
156   * Version the libcgi-session-perl dependency, some features that need
157     the new version are used in some cases (sslcookie).
158   * Numerous tla fixes from Clint.
159   * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
160     a multi-resolution favicon.ico.
161   * README.Debian: typo Closes: #388110
162   * chomp trailing newline at the end of templates read in by the template
163     plugin, to allow use of the template preprocessor directive in
164     whitespace-sensative situations. Closes: #387073
165   * Patch from James Westby to make the location of the estseek.cgi script
166     configurable.
167   * Add typography (SmartyPants) plugin by Recai.
168   * Add --render mode, which can be used to preview an edit at the command
169     line by test rendering a single page.
170   * Add a googlecalendar plugin. A bit special-purpose, but it shows
171     one way to to deal with user-supplied content that could cause XSS
172     issues w/o the htmlscrubber, and won't survive the scrubber.
173
174  -- Joey Hess <joeyh@debian.org>  Sun, 24 Sep 2006 00:02:21 -0400
175
176 ikiwiki (1.26) unstable; urgency=low
177
178   * Add a missing -n to tla undo call.
179   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
180     writes before consuming its whole stdin. Avoid this deadlock.
181   * Fix alt tags for outline checkboxes.
182
183  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
184
185 ikiwiki (1.25) unstable; urgency=low
186
187   * Add proper waitpid calls for open2ed processes throughout to avoid
188     zombies; this hit htmltidy especially badly.
189   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
190     subversion repos and fixing some other issues.
191   * Add support for tla, contributed by Clint Adams. Closes: #385936
192   * Add support for mercurial, contributed by Emanuele Aina.
193   * Include <link rel> tag for RSS feeds, used by some aggregators and
194     firefox to find the feed.
195   * Add a linkmap plugin (requires graphviz).
196
197  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
198
199 ikiwiki (1.24) unstable; urgency=low
200
201   * Simplify the data structure returned by rcs_recentchanges to avoid
202     each rcs plugin needing to form complex strings on its own.
203   * Fix another destpage issue in the inline directive. Closes: #385512
204     again.
205
206  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
207
208 ikiwiki (1.23) unstable; urgency=low
209
210   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
211
212  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
213
214 ikiwiki (1.22) unstable; urgency=low
215
216   * Change how the stylesheet url is determined in the templates: Remove
217     STYLEURL and add BASEURL to all templates (some already had it). This
218     new more general variable can be used to link to other things (eg, images)
219     from the template, as well as stylesheets.
220   * Fix a bug introduced last version to do with nested inlines.
221   * Allow preprocessor directives to span multiple lines, both to make
222     long ones with lots of values easier to write, and to allow for ones with
223     multi-line quoted values.
224   * Allow preprocessor directives to contain python-like triple-quoted
225     text blocks, for easy nesting of quotes inside.
226   * Add a template plugin.
227   * Make pagespec merge code smarter about merging duplicate pagespecs.
228   * Patch from Jordà Polo to make Setup::Standard support hashes in config
229     files.
230   * Change order of linkify and preprocess; first preprocess and then linkify.
231     This allows passing a wikilink inside a parameter to a preprocessor
232     directive without it being expanded to html, and leaking out of the
233     parameter, which had required some non-obvious use of triple-quoting
234     to avoid. Note that any preprocessor plugins that output something
235     that looks like a wikilink will now have it treated as such; AFAIK
236     this doesn't change any behavior though except for the template plugin.
237   * Enable preprocessor directives when previewing an edit.
238   * Make all pages pull in a local.css style sheet, if present. This won't
239     be included in ikiwiki, but can be created to make local styling changes
240     w/o needing to merge in every new change to the distributed style.css.
241   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
242   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
243     from a different directory.
244   * Generalised preprocesser loop protection code.
245   * Patch from James Westby to allow a description to be set for rss feeds.
246   * Patch from James Westby to add a template for the search form.
247   * Added a ddate plugin.
248   * Patch from James Westby to add a --sslcookie switch, which forces
249     cookies to only be sent over ssl connections to avoid interception.
250   * Fix preferences page on anonok wikis; still need to sign in to get
251     to the preferences page.
252   * Add toc (table of contents) plugin.
253   * Change htmlize, format, and sanitize hooks to use named parameters.
254   * Patch from James Westby to add an actions option to inline; this
255     adds Edit and Discussion links at the end of blog entries.
256   * Due to some css changes, you'll want to rebuild your wiki on upgrade
257     to this version. Will be handled automatically by the deb.
258   * Add processed date to aggregate preprocessor directive status output.
259
260  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
261
262 ikiwiki (1.21) unstable; urgency=low
263
264   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
265   * If a page links to itself, mark up the link text in a span with
266     class="selflink" so that it can be styled. I don't have a useful style
267     defined for that though.
268   * Call filter hooks on inlined page content.
269   * Support inlining pages raw, rather than creating a blog.
270   * Clean up yes/no parameter parsing in inline plugin.
271   * Implemented better cycle detection in the inline plugin; nested inlines
272     will now work.
273   * Add a map plugin contributed by Alessandro Dotti Contra.
274   * Add otl format plugin, which handles files as created by vimoutliner.
275   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
276   * Add first draft at a Restructured Text (rst) plugin, by Sergio
277     Talens-Oliag. Note that this has many known issues -- see the caveats on
278     the plugin's page.
279   * Credit everyone who wrote a plugin on the plugins' wiki pages.
280   * Fix utf-8 in blog post form.
281
282  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
283
284 ikiwiki (1.20) unstable; urgency=low
285
286   * Relicense the templates and basewiki under the 2-clause BSD license.
287     Since these can easily become part of other people's websites, they
288     should be under as permissive a license as possible.
289   * Add --syslog config option, to log to the syslog.
290   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
291     transient failure to fork (which I've seen happen in the wild).
292   * Fix a bug in the aggregator introduced last version that caused all
293     aggregator state to be lost during a non-aggregating build.
294
295  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
296
297 ikiwiki (1.19) unstable; urgency=low
298
299   * Fix several related bugs in page type determination during online editing.
300   * Add some locking to prevent 2 aggregators from running at once.
301   * Fix an infinite loop in the aggregator when finding a unique filename.
302
303  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
304
305 ikiwiki (1.18) unstable; urgency=low
306
307   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
308   * Add --version.
309   * Man page format fixups.
310   * If the meta plugin overides the page title, set a title_overridden
311     variable in the template to true. This allows doing things with the
312     templates conditional on the title being overriden.
313   * Add a %pagecase which maps lower-case page names to the actual case
314     used in the filename. Use this in bestlinks calculation instead of
315     forcing the link to lowercase.
316   * Also use %pagecase in various other places that want to check if a page
317     with a given name exists.
318   * This means that links to pages with mixed case names will now work,
319     even if the link is in some other case mixture, and mixed case pages
320     should be fully supported throughout ikiwiki.
321   * Recommend rebuilding wikis on upgrade to this version.
322
323  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
324
325 ikiwiki (1.17) unstable; urgency=low
326
327   * Disable tidy generator tag.
328   * Move tidy back to sanitize hook, found out how to only show body.
329   * Turn off tidy indentation too.
330   * Turn on HTML::Template loop_context_vars; not actually used in stock
331     templates but can be useful for things like making comma-delimited lists
332     of tags or what have you.
333   * Remove <br> from end of aggregate preprocessor directive output.
334   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
335     case-sensative filesystems like OSX.
336   * Improve markdown loading. First, try to load it as a proper perl module,
337     in case it was installed as one. Then fall back to trying
338     /usr/bin/markdown.
339   * Document in install page how to install markdown, since it has no
340     installation procedure in the upstream tarball.
341   * Set die_on_bad_params => 0 for all templates, to allow users to modify
342     them without annoyances.
343   * Suck in the page content when generating an inline archive page, to work
344     around the meta plugin's lack of caching of title metadata across runs.
345
346  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
347
348 ikiwiki (1.16) unstable; urgency=low
349
350   * Try to handle relative links in aggregated feeds. However,
351     the current support is a crude hack due to limitations of XML::Feed:
352     xml:base is not supported, neither is Content-Location. And of course,
353     relative links in RSS feeds are ill-undefined..
354   * Make aggregator save permalinks and author name to pages as metadata.
355   * Add permalink and author support to meta plugin, affecting RSS feeds
356     and blog pages.
357   * Various CSS and formatting changes.
358   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
359   * Add xhtml files to the default prune regexp.
360   * Also generate rel=bookmark links for permalinks.
361   * Fix the htmltidy plugin, which wasn't working due my breaking it when
362     I added it..
363   * Don't run tidy with -xml as that fails if the input is not well-formed.
364     Run it with -asxhtml instead, so it will output well-formed xhtml no
365     matter what the input.
366   * Disable tidy warnings too.
367   * Add a new format hook, and make tidy use it, since tidy can really only
368     operate on and output complete html documents, not the body chunks
369     that sanitise gets.
370   * Fix dates in rss feeds if running localised, so they're still rfc 822.
371
372  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
373
374 ikiwiki (1.15) unstable; urgency=low
375
376   * Remove CDPATH and other env vars perl taint checking doesn't like.
377     Closes: #381279
378   * Added created_before and created_after PageSpec limits.
379
380  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
381
382 ikiwiki (1.14) unstable; urgency=low
383
384   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
385     by 10% or so.
386   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
387   * Added many unit tests for pagespec_match.
388
389  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
390
391 ikiwiki (1.13) unstable; urgency=low
392
393   * ikiwiki can now download and aggregate feeds with its new aggregate
394     plugin, so it's possible to implement a Planet using ikiwiki!
395   * Add a run_hooks function for the common task of running all hooks of a
396     given type.
397   * Add a savestate hook.
398   * Don't put blog post forms on pages if there's no cgiurl set.
399   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
400     --wrappers to do that.
401   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
402     to update pages that haven't changed on disk.
403   * Change meta tags to use html entity-escaped text for values, so that
404     quotes and such can be represented in title tags.
405   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
406     for the above.
407   * Make --rebuild also cause --aggregate to re-download and write aggregated
408     pages.
409   * Avoid outputting duplicate meta info.
410   * Include title metadata on aggregated posts for capitalised and un-munged
411     titles.
412   * Title metadata of inlined pages now shows up in blogs and rss feeds.
413   * Fix issue with unicode filenames and updating the hyper estradier search
414     index. (Aka Please Please Please, let that be the last one.)
415   * Patch from Roland Mas to support an rss=no parameter to inline directives.
416     Closes: #380743
417   * Renamed GlobLists to PageSpecs.
418   * PageSpecs can now include nested parens, "and", and "or". This remains
419     backwards compatible to the old GlobList format. It's implemented by
420     treating the GlobList as a very limited microlanguage that is transformed
421     to perl code that does the matching.
422   * The old GlobList format is deprecated, and I encourage users to switch to
423     using the new PageSpec format. Compatability with the old format will be
424     removed at some point, possibly by 2.0.
425   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
426   * Add support for creation_month and creation_year to PageSpec.
427     Closes: #380680
428   * Changes to index file encoding.
429
430  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
431
432 ikiwiki (1.12) unstable; urgency=low
433
434   "Viva l'Italia!"
435   * New pagestats plugin from Enrico, which can generate a table counting
436     the backlinks for each page, or a del.icio.us style cloud.
437   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
438     the wikiformat plugin works. Thanks, Emanuele Aina.
439   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
440     display, running them through pagetitle. This removes ugly underscores and
441     other gunk from the display, much nicer. You may want to rebuild your wiki
442     when upgrading to get the cleanup globally.
443   * Polygen plugin from Enrico.
444   * htmltidy plugin from Faidon.
445   * Locale patch from Faidon:
446     - Adds a locale setting to setup files.
447     - Proper local time, if the locale configuration option is used.
448     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
449       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
450       impossible.
451   * Add getopt hook type, this allows plugins to add new command-line options.
452   * Add --tagbase option to tag plugin.
453   * Add exclude option in setup files, works same as --exclude.
454   * Put categories in rss feeds for tagged items.
455   * Allow preprocessor directives to be expanded in inlined blog pages.
456     However, to avoid inlining loops etc, don't expand inline directives in
457     inlined pages.
458   * fortune plugin (trivial)
459   * Tag plugins according to type.
460
461  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
462
463 ikiwiki (1.11) unstable; urgency=low
464
465   * Patch from Enrico that
466     - Adds a tag plugin that allows more easily tagging pages.
467       The meta plugin can also still be used for that, but the tag plugin
468       also lists a page's tags at the bottom of the page.
469     - Allows preprocessor directives to have parameters with no specified
470       value.
471     - Fixes preprocessor directive parameter parsing so that
472       foo=bar baz now means "foo=bar" and a "baz" with no value.
473   * Run pagetemplate hooks when inlining pages so that inlined pages also
474     list their tags.
475   * Make all plugins with pagetemplate hooks check that variables exist
476     on the template before setting them, for robustness.
477   * Switch pagetemplate hooks to using named parameters.
478   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
479     This will be the page that a source page will be part of, which is
480     different than the source page for inlined pages.
481   * Audited all plugins to endure they pass (page, destpage) to htmllink
482     appropriatly. This means inlining of various plugins will not work
483     properly, with correct links generated.
484
485  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
486
487 ikiwiki (1.10) unstable; urgency=low
488
489   * Run page through any relevant filters when generating a page preview.
490   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
491     default throughout the wiki, not only on wikitext pages. Decided to call
492     this a feature, and split the camelcase support out into a separate plugin
493     that is independant of wikitext.
494   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
495
496  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
497
498 ikiwiki (1.9) unstable; urgency=low
499
500   * Improve display of parentlinks and page title of toplevel index page.
501   * Patch from Faidon to use svn --limit when possible for recentchanges,
502     speeds up recentchanges a lot for wikis with more history.
503   * Patch from Recai to fix utf8 issues in git backend.
504   * Add wikitext markup plugin, which supports ".wiki" pages written in the
505     original wiki syntax, CamelCase links and all.
506   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
507     support, to edit pages etc without a web server.
508   * Display CGI processing errors if present.
509   * Fix from Faidon for a XML parser issue that breaks utf-8 for
510     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
511     area, and also way slow.
512   * Match 'web commit from' in SVN and git, these are web commits too.
513     (Faidon)
514   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
515     readable and avoid future mistakes. The patch seems to work and for the
516     first time I have a UTF-8 username ;-) (Faidon)
517   * Use form->field consistently, not form->param.
518   * Patch from Recai to allow selection of page type when creating a new page.
519     Default page type is inherited from the link clicked on to create the new
520     page.
521
522  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
523
524 ikiwiki (1.8) unstable; urgency=low
525
526   * Fix orphans plugin to not count a link to a nonexistant page as a reason
527     for a page not being an orphan.
528   * Support pinging services such as Technorati using XML-RPC to notify them
529     about changes to rss feeds.
530   * Parse svn log as xml for improved utf8 and security. Note that this makes
531     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
532   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
533     flagged string even if the locale causes it to generate utf8 output,
534     so make sure to let perl know it should be handled as utf8. Also,
535     the optimised version used for standard time formats won't work if the
536     user has changed locale, so drop it. Thanks, Faidon Liambotis.
537   * Fix re-encoding of the comments field to utf8 if a commit fails
538     due to a conflict. Thanks, Faidon Liambotis.
539   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
540     Liambotis.
541   * Add insane double encode/decode to utf8 around call to markdown.
542     This works around a truely strange bug, which is apparently a bug in
543     perl, #376329. Also added a test case for it.
544   * Improve layout of edit page so formatting help link is always visible w/o
545     getting in the way of the preview.
546   * Centralised all calls to HTML::Template and force all the templates
547     to be read as utf8.
548   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
549   * Introduce add_plugins and disable_plugins config options in setup files.
550     This allows adding or removing plugins w/o overriding the whole list of
551     default plugins, which makes it easier to upgrade when new default plugins
552     are added.
553   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
554     default (of course!). Based on a patch by Faidon Liambotis.
555   * Add a html plugin, which can be used to write wikis in raw html,
556     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
557     defaults to not processing .html files, since w/o this plugin they would
558     be copied unsanitised. With this plugin, it will process and html
559     sanitise them, like any other page type.
560   * Rebuilding wrappers is necessary on upgrade to this version.
561   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
562     will be automatically done on all upgrades.
563   * Don't send pings if the wiki is being rebuilt.
564   * Work around very innefficient behavior in File::Spec::abs2rel. Result
565     is a savings of 2 pointless fork/execs per link calculation, which
566     results in ~25% speedup of ikiwiki building its own doc wiki, and
567     about 35% speedup displaying RecentChanges!
568   * Make RecentChanges use a table and some CSS, should be much more readable.
569     No code changes involved.
570   * Encode & in diffurl in examples, to conform to pedantic rules.
571   * Speed up RecentChanges by another 40% or so with some memoization.
572   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
573     in time to build the doc wiki.
574
575  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
576
577 ikiwiki (1.7) unstable; urgency=low
578
579   * Updated logo from Recai with some kerning and alingment tuning.
580   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
581     changed some output.
582   * Copyright update.
583
584  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
585
586 ikiwiki (1.6) unstable; urgency=low
587
588   * YA utf-8 patch from Recai, this time to fix previewing a page so that
589     the text in the input box is re-encoded back to utf-8.
590   * -CSD does not affect modules, so readfile() was not using the utf-8 input
591     layer, which led to lots of problems; make it force read files as utf-8.
592     Closes: #373203
593   * Note that as a consequence, this version of ikiwiki will actually try to
594     parse utf8 in source files for the first time, which may expose broken
595     utf8 in wiki sources that was hidden before. Most common will be
596     perl warnings like "utf8 "\xE9" does not map to Unicode"
597   * writefile() likewise needs to use the utf8 output layer.
598   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
599     there.
600   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
601     given the readfile fix.
602   * Add utf-8 testcases for readfile and htmlize.
603   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
604     safe.
605   * More utf-8 fixes from Recai, partly to things I broke above:
606     - The serious problem is that writefile() saves the content in undecoded
607       format in CGI, hence all (non-ascii) chars are corrupted permanently.
608     - Comment field in edit page is not decoded and all the non-ascii chars in
609       this field are corrupted as the result.  We should decode it as we do it
610       for the content.
611     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
612       character in print.
613   * New SVG logo from Recai.
614
615  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
616
617 ikiwiki (1.5) unstable; urgency=low
618
619   * Add --timeformat config option to allow changing how dates are displayed.
620     Note that as a side effect, dates will now be displayed using the local
621     timezone, not as GMT.
622   * More security review.
623   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
624     for some handy stuff like:
625     - Using links as a kind of tag; creating blog pages that list all pages
626       containing a given tag/link or not containing some other tag.
627     - Subscribing to mail notifications whenever a change is made to a page
628       that is a backlink of page foo. Ie, "Please notify me of changes in all
629       pages that link to my home page in the wiki"
630     - Locking any pages that are linked to from a particular page, so that
631       lists of locks can be exposed in the wiki.
632   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
633     when a todo item is done, instead of the previous moving it to a different
634     subdir.
635   * Allow pagetemplate plugins to override *anything* in the template.
636   * Add a meta plugin, which allows specifying various metadata about pages,
637     like license and author. It also allows for inserting html link and meta
638     tags into html, overriding the title, and adding hidden WikiLinks, which
639     can be useful when using link-based globbing for page categorisation.
640   * Remove preprocessor directives from inlined pages.
641   * Allow simple preprocessor directive values to be specified w/o quotes.
642   * Add support for using git instead of subversion as the RCS backend,
643     tremendous thanks to Recai Oktaş for this.
644   * Doc updates for git.
645   * Fix absolute url munging in rss generation to support https, ftp, etc urls
646     not just http urls.
647   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
648     utf-8 for edit and other fields, and for recentchanges. There may still
649     be utf-8 issues with the preferences page though.
650
651  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
652
653 ikiwiki (1.4) unstable; urgency=low
654
655   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
656     very strange way of enabling proper XHTML <br /> type tags. Output html
657     should be always valid again now.
658   * The page name and parent links has switched from using a <h1> to a styled
659     <span>, so pages can use <h1> internally instead of needing to use <h2>.
660   * Updated all of ikiwiki's own wiki pages for that.
661   * Add pagetemplate hook, which can be used by plugins that want to mess
662     around with adding new stuff to the page template.
663   * Remove headercontent; the search plugin now adds the search box to the
664     header by registering a pagetemplate hook, and other plugins should do
665     similarly.
666   * Rebuilding on upgrade to this version is recommended.
667   * Add a html validity check to the test suite, using the wdg-html-validator,
668     if available.
669   * Make the html valid when there is nothing in the actions list.
670   * Reordered some function call parameters for consistency.
671   * Enable full utf-8 support for page input and output.
672   * Add a workaround for markdown, which does not work well with utf-8
673     strings.
674   * --getctime had bitrotted (well I only ever used it the once so far..),
675     fix and make it a bit more flexible
676   * rcs_getctime is changed, now rather than needing to loop over all pages,
677     it should just use the rcs to get the ctime of the passed file.
678   * When inlining a page in another one, links from the inlined page are now
679     expanded the same as they are when rendering the inlined page as a
680     standalone page. So rather than being expanded from the POV of the
681     inlining page, they are expanded from the POV of the inlined page.
682
683     For example, a link from blog/foo to "bar" will now link to blog/bar
684     if it exists. Previously this needed to be a link explicitly to
685     "blog/bar"; such links will also continue to work.
686
687     (This was slightly complex to do as the link still has to be constructed
688     relative to the inlining page.)
689   * Make page edit textarea resize to fit browser window.
690   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
691     do not need a full rebuild, in order to update any basewiki pages.
692
693  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
694
695 ikiwiki (1.3) unstable; urgency=low
696
697   * Fix the preinst introduced in the last version. Closes: #367458
698
699  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
700
701 ikiwiki (1.2) unstable; urgency=low
702
703   * Remove dups from the brokenlinks list.
704   * Add libc6-dev to dependencies, needed to build wrappers.
705   * Install wikilist in correct location. Closes: #367371
706
707  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
708
709 ikiwiki (1.1) unstable; urgency=low
710
711   * Rename inlinepage to depends, so that it can be used to refer to more
712     dependency relationships than just inlining. This will require a rebuild
713     on upgrade to this version.
714   * Move the rss link, put it in the blogpost form if there is one and at the
715     top if not. This is both nicer because easier to find, and it cleans up
716     the code which had used inlinepage as a flag for adding the link later.
717   * Allow the depends GlobList to be built up from multiple sources (such as
718     plugins) during a page render.
719   * Which means that more than one blog is now supported to appear on a
720     single page. (With some limitations, like only the last one getting an
721     rss file.)
722   * Added a plugin system.
723   * Added a pagecount plugin, enabled by default.
724   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
725   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
726     backlinks when the backlinks hadn't really changed.
727   * Moved inline page support, rss generation etc into the inline plugin,
728     enabled by default.
729   * Added brokenlinks plugin, not enabled by default, but rather handy.
730   * Fix several broken links in the doc wiki.
731   * Smarter behavior when creating a page and a page of the same name (but
732     different location) already exists.
733   * Add an orphans plugin for finding pages that nothing links to.
734   * Removed backlinks page, which it turns out nothing used.
735   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
736     it, this will allow for adding a unit test suite.
737   * Add unit tests for several core functions, including globlist_match,
738     dirname, basename, bestlink, linkify, pagetitle, titlepage.
739   * Smart globlist merging.
740   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
741     to pave the way for adding other RCS support. This also changes the
742     setup files, where before they had svn => 1 or svn => 0, now they have
743     rcs => "svn" or rcs => "".
744   * Add a debian/NEWS file with upgrade notes.
745   * Load whatever rcs module is specified, so new ones can be just dropped in
746     as plugins and work. (Well, in theory.)
747   * Add some basic docs about writing RCS modules.
748   * Broke search capability out into a plugin, removed the --hyperestraier
749     switch.
750   * Added smiley plugin, nicely controlled and documented by the smileys page.
751   * Copied in some smileys from Moin Moin.
752   * Allow links of the form [[some page|page]], with whitespace in the link
753     text.
754   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
755     and --disable-plugin htmlscrubber.
756   * Allow discussion links on pages to be turned off with --no-discussion.
757   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
758   * Add some new config items to the estseek.conf template, which are needed
759     by hyperestraier 1.2.3.
760
761  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
762
763 ikiwiki (1.0) unstable; urgency=low
764
765   * First official release.
766
767  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400