* Deal with CPAN installing Markdown as Text::Markdown, while it's
[ikiwiki] / debian / changelog
1 ikiwiki (1.27) UNRELEASED; urgency=low
2
3   * Add a googlecalendar plugin. A bit special-purpose, but it shows
4     one way to to deal with user-supplied content that could cause XSS
5     issues w/o the htmlscrubber, and won't survive the scrubber.
6   * Work on firming up the plugin interface:
7     - Plugins should not need to load IkiWiki::Render to get commonly
8       used functions, so moved some functions from there to IkiWiki.
9     - Picked out the set of functions and variables that most plugins
10       use, documented them, and made IkiWiki export them by default,
11       like a proper perl module should.
12     - Use the other functions at your own risk.
13     - This is not quite complete, I still have to decide whether to
14       export some other things.
15   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
16     referring to stuff now exported by the IkiWiki module.
17   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
18     to declare which version of the interface your plugin needs.
19   * Anyone with a third-party ikiwiki plugin is strongly encouraged
20     to make like changes to it and avoid use of non-exported symboles from
21     "IkiWiki::".
22   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
23   * Support hyperestradier version 1.4.2, which adds a new required phraseform
24     setting.
25   * If an inlined page has a permalink, link the page title to that.
26   * Patch from Recai to use utf8 when reading the setup file, so that
27     utf8 wikinames from there will be used properly.
28   * Patch from Recai to kill utf-8 on the wiki name when generating the
29     session cookie.
30   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
31   * Fix a baseurl problem in hyperestradier search results.
32   * Add a stub local.css to avoid problems with 404's.
33   * Patch from Recai to fix a wide character warning from the search plugin
34     during setup if the wikiname contains utf8.
35   * Yet another fix for those poor case-insensative OSX users.
36   * pagetemplate hooks are now also called when generating cgi pages.
37   * Add a favicon plugin, which simply adds a link tag for an icon to each
38     page (and cgis).
39   * Deal with CPAN installing Markdown as Text::Markdown, while it's 
40     installed as just Markdown by apt.
41
42  -- Joey Hess <joeyh@debian.org>  Fri, 15 Sep 2006 21:13:35 -0400
43
44 ikiwiki (1.26) unstable; urgency=low
45
46   * Add a missing -n to tla undo call.
47   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
48     writes before consuming its whole stdin. Avoid this deadlock.
49   * Fix alt tags for outline checkboxes.
50
51  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
52
53 ikiwiki (1.25) unstable; urgency=low
54
55   * Add proper waitpid calls for open2ed processes throughout to avoid
56     zombies; this hit htmltidy especially badly.
57   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
58     subversion repos and fixing some other issues.
59   * Add support for tla, contributed by Clint Adams. Closes: #385936
60   * Add support for mercurial, contributed by Emanuele Aina.
61   * Include <link rel> tag for RSS feeds, used by some aggregators and
62     firefox to find the feed.
63   * Add a linkmap plugin (requires graphviz).
64
65  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
66
67 ikiwiki (1.24) unstable; urgency=low
68
69   * Simplify the data structure returned by rcs_recentchanges to avoid
70     each rcs plugin needing to form complex strings on its own.
71   * Fix another destpage issue in the inline directive. Closes: #385512
72     again.
73
74  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
75
76 ikiwiki (1.23) unstable; urgency=low
77
78   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
79
80  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
81
82 ikiwiki (1.22) unstable; urgency=low
83
84   * Change how the stylesheet url is determined in the templates: Remove
85     STYLEURL and add BASEURL to all templates (some already had it). This
86     new more general variable can be used to link to other things (eg, images)
87     from the template, as well as stylesheets.
88   * Fix a bug introduced last version to do with nested inlines.
89   * Allow preprocessor directives to span multiple lines, both to make
90     long ones with lots of values easier to write, and to allow for ones with
91     multi-line quoted values.
92   * Allow preprocessor directives to contain python-like triple-quoted
93     text blocks, for easy nesting of quotes inside.
94   * Add a template plugin.
95   * Make pagespec merge code smarter about merging duplicate pagespecs.
96   * Patch from Jordà Polo to make Setup::Standard support hashes in config
97     files.
98   * Change order of linkify and preprocess; first preprocess and then linkify.
99     This allows passing a wikilink inside a parameter to a preprocessor
100     directive without it being expanded to html, and leaking out of the
101     parameter, which had required some non-obvious use of triple-quoting
102     to avoid. Note that any preprocessor plugins that output something
103     that looks like a wikilink will now have it treated as such; AFAIK
104     this doesn't change any behavior though except for the template plugin.
105   * Enable preprocessor directives when previewing an edit.
106   * Make all pages pull in a local.css style sheet, if present. This won't
107     be included in ikiwiki, but can be created to make local styling changes
108     w/o needing to merge in every new change to the distributed style.css.
109   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
110   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
111     from a different directory.
112   * Generalised preprocesser loop protection code.
113   * Patch from James Westby to allow a description to be set for rss feeds.
114   * Patch from James Westby to add a template for the search form.
115   * Added a ddate plugin.
116   * Patch from James Westby to add a --sslcookie switch, which forces
117     cookies to only be sent over ssl connections to avoid interception.
118   * Fix preferences page on anonok wikis; still need to sign in to get
119     to the preferences page.
120   * Add toc (table of contents) plugin.
121   * Change htmlize, format, and sanitize hooks to use named parameters.
122   * Patch from James Westby to add an actions option to inline; this
123     adds Edit and Discussion links at the end of blog entries.
124   * Due to some css changes, you'll want to rebuild your wiki on upgrade
125     to this version. Will be handled automatically by the deb.
126   * Add processed date to aggregate preprocessor directive status output.
127
128  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
129
130 ikiwiki (1.21) unstable; urgency=low
131
132   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
133   * If a page links to itself, mark up the link text in a span with
134     class="selflink" so that it can be styled. I don't have a useful style
135     defined for that though.
136   * Call filter hooks on inlined page content.
137   * Support inlining pages raw, rather than creating a blog.
138   * Clean up yes/no parameter parsing in inline plugin.
139   * Implemented better cycle detection in the inline plugin; nested inlines
140     will now work.
141   * Add a map plugin contributed by Alessandro Dotti Contra.
142   * Add otl format plugin, which handles files as created by vimoutliner.
143   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
144   * Add first draft at a Restructured Text (rst) plugin, by Sergio
145     Talens-Oliag. Note that this has many known issues -- see the caveats on
146     the plugin's page.
147   * Credit everyone who wrote a plugin on the plugins' wiki pages.
148   * Fix utf-8 in blog post form.
149
150  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
151
152 ikiwiki (1.20) unstable; urgency=low
153
154   * Relicense the templates and basewiki under the 2-clause BSD license.
155     Since these can easily become part of other people's websites, they
156     should be under as permissive a license as possible.
157   * Add --syslog config option, to log to the syslog.
158   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
159     transient failure to fork (which I've seen happen in the wild).
160   * Fix a bug in the aggregator introduced last version that caused all
161     aggregator state to be lost during a non-aggregating build.
162
163  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
164
165 ikiwiki (1.19) unstable; urgency=low
166
167   * Fix several related bugs in page type determination during online editing.
168   * Add some locking to prevent 2 aggregators from running at once.
169   * Fix an infinite loop in the aggregator when finding a unique filename.
170
171  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
172
173 ikiwiki (1.18) unstable; urgency=low
174
175   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
176   * Add --version.
177   * Man page format fixups.
178   * If the meta plugin overides the page title, set a title_overridden
179     variable in the template to true. This allows doing things with the
180     templates conditional on the title being overriden.
181   * Add a %pagecase which maps lower-case page names to the actual case
182     used in the filename. Use this in bestlinks calculation instead of
183     forcing the link to lowercase.
184   * Also use %pagecase in various other places that want to check if a page
185     with a given name exists.
186   * This means that links to pages with mixed case names will now work,
187     even if the link is in some other case mixture, and mixed case pages
188     should be fully supported throughout ikiwiki.
189   * Recommend rebuilding wikis on upgrade to this version.
190
191  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
192
193 ikiwiki (1.17) unstable; urgency=low
194
195   * Disable tidy generator tag.
196   * Move tidy back to sanitize hook, found out how to only show body.
197   * Turn off tidy indentation too.
198   * Turn on HTML::Template loop_context_vars; not actually used in stock
199     templates but can be useful for things like making comma-delimited lists
200     of tags or what have you.
201   * Remove <br> from end of aggregate preprocessor directive output.
202   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
203     case-sensative filesystems like OSX.
204   * Improve markdown loading. First, try to load it as a proper perl module,
205     in case it was installed as one. Then fall back to trying
206     /usr/bin/markdown.
207   * Document in install page how to install markdown, since it has no
208     installation procedure in the upstream tarball.
209   * Set die_on_bad_params => 0 for all templates, to allow users to modify
210     them without annoyances.
211   * Suck in the page content when generating an inline archive page, to work
212     around the meta plugin's lack of caching of title metadata across runs.
213
214  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
215
216 ikiwiki (1.16) unstable; urgency=low
217
218   * Try to handle relative links in aggregated feeds. However,
219     the current support is a crude hack due to limitations of XML::Feed:
220     xml:base is not supported, neither is Content-Location. And of course,
221     relative links in RSS feeds are ill-undefined..
222   * Make aggregator save permalinks and author name to pages as metadata.
223   * Add permalink and author support to meta plugin, affecting RSS feeds
224     and blog pages.
225   * Various CSS and formatting changes.
226   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
227   * Add xhtml files to the default prune regexp.
228   * Also generate rel=bookmark links for permalinks.
229   * Fix the htmltidy plugin, which wasn't working due my breaking it when
230     I added it..
231   * Don't run tidy with -xml as that fails if the input is not well-formed.
232     Run it with -asxhtml instead, so it will output well-formed xhtml no
233     matter what the input.
234   * Disable tidy warnings too.
235   * Add a new format hook, and make tidy use it, since tidy can really only
236     operate on and output complete html documents, not the body chunks
237     that sanitise gets.
238   * Fix dates in rss feeds if running localised, so they're still rfc 822.
239
240  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
241
242 ikiwiki (1.15) unstable; urgency=low
243
244   * Remove CDPATH and other env vars perl taint checking doesn't like.
245     Closes: #381279
246   * Added created_before and created_after PageSpec limits.
247
248  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
249
250 ikiwiki (1.14) unstable; urgency=low
251
252   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
253     by 10% or so.
254   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
255   * Added many unit tests for pagespec_match.
256
257  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
258
259 ikiwiki (1.13) unstable; urgency=low
260
261   * ikiwiki can now download and aggregate feeds with its new aggregate
262     plugin, so it's possible to implement a Planet using ikiwiki!
263   * Add a run_hooks function for the common task of running all hooks of a
264     given type.
265   * Add a savestate hook.
266   * Don't put blog post forms on pages if there's no cgiurl set.
267   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
268     --wrappers to do that.
269   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
270     to update pages that haven't changed on disk.
271   * Change meta tags to use html entity-escaped text for values, so that
272     quotes and such can be represented in title tags.
273   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
274     for the above.
275   * Make --rebuild also cause --aggregate to re-download and write aggregated
276     pages.
277   * Avoid outputting duplicate meta info.
278   * Include title metadata on aggregated posts for capitalised and un-munged
279     titles.
280   * Title metadata of inlined pages now shows up in blogs and rss feeds.
281   * Fix issue with unicode filenames and updating the hyper estradier search
282     index. (Aka Please Please Please, let that be the last one.)
283   * Patch from Roland Mas to support an rss=no parameter to inline directives.
284     Closes: #380743
285   * Renamed GlobLists to PageSpecs.
286   * PageSpecs can now include nested parens, "and", and "or". This remains
287     backwards compatible to the old GlobList format. It's implemented by
288     treating the GlobList as a very limited microlanguage that is transformed
289     to perl code that does the matching.
290   * The old GlobList format is deprecated, and I encourage users to switch to
291     using the new PageSpec format. Compatability with the old format will be
292     removed at some point, possibly by 2.0.
293   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
294   * Add support for creation_month and creation_year to PageSpec.
295     Closes: #380680
296   * Changes to index file encoding.
297
298  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
299
300 ikiwiki (1.12) unstable; urgency=low
301
302   "Viva l'Italia!"
303   * New pagestats plugin from Enrico, which can generate a table counting
304     the backlinks for each page, or a del.icio.us style cloud.
305   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
306     the wikiformat plugin works. Thanks, Emanuele Aina.
307   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
308     display, running them through pagetitle. This removes ugly underscores and
309     other gunk from the display, much nicer. You may want to rebuild your wiki
310     when upgrading to get the cleanup globally.
311   * Polygen plugin from Enrico.
312   * htmltidy plugin from Faidon.
313   * Locale patch from Faidon:
314     - Adds a locale setting to setup files.
315     - Proper local time, if the locale configuration option is used.
316     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
317       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
318       impossible.
319   * Add getopt hook type, this allows plugins to add new command-line options.
320   * Add --tagbase option to tag plugin.
321   * Add exclude option in setup files, works same as --exclude.
322   * Put categories in rss feeds for tagged items.
323   * Allow preprocessor directives to be expanded in inlined blog pages.
324     However, to avoid inlining loops etc, don't expand inline directives in
325     inlined pages.
326   * fortune plugin (trivial)
327   * Tag plugins according to type.
328
329  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
330
331 ikiwiki (1.11) unstable; urgency=low
332
333   * Patch from Enrico that
334     - Adds a tag plugin that allows more easily tagging pages.
335       The meta plugin can also still be used for that, but the tag plugin
336       also lists a page's tags at the bottom of the page.
337     - Allows preprocessor directives to have parameters with no specified
338       value.
339     - Fixes preprocessor directive parameter parsing so that
340       foo=bar baz now means "foo=bar" and a "baz" with no value.
341   * Run pagetemplate hooks when inlining pages so that inlined pages also
342     list their tags.
343   * Make all plugins with pagetemplate hooks check that variables exist
344     on the template before setting them, for robustness.
345   * Switch pagetemplate hooks to using named parameters.
346   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
347     This will be the page that a source page will be part of, which is
348     different than the source page for inlined pages.
349   * Audited all plugins to endure they pass (page, destpage) to htmllink
350     appropriatly. This means inlining of various plugins will not work
351     properly, with correct links generated.
352
353  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
354
355 ikiwiki (1.10) unstable; urgency=low
356
357   * Run page through any relevant filters when generating a page preview.
358   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
359     default throughout the wiki, not only on wikitext pages. Decided to call
360     this a feature, and split the camelcase support out into a separate plugin
361     that is independant of wikitext.
362   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
363
364  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
365
366 ikiwiki (1.9) unstable; urgency=low
367
368   * Improve display of parentlinks and page title of toplevel index page.
369   * Patch from Faidon to use svn --limit when possible for recentchanges,
370     speeds up recentchanges a lot for wikis with more history.
371   * Patch from Recai to fix utf8 issues in git backend.
372   * Add wikitext markup plugin, which supports ".wiki" pages written in the
373     original wiki syntax, CamelCase links and all.
374   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
375     support, to edit pages etc without a web server.
376   * Display CGI processing errors if present.
377   * Fix from Faidon for a XML parser issue that breaks utf-8 for
378     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
379     area, and also way slow.
380   * Match 'web commit from' in SVN and git, these are web commits too.
381     (Faidon)
382   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
383     readable and avoid future mistakes. The patch seems to work and for the
384     first time I have a UTF-8 username ;-) (Faidon)
385   * Use form->field consistently, not form->param.
386   * Patch from Recai to allow selection of page type when creating a new page.
387     Default page type is inherited from the link clicked on to create the new
388     page.
389
390  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
391
392 ikiwiki (1.8) unstable; urgency=low
393
394   * Fix orphans plugin to not count a link to a nonexistant page as a reason
395     for a page not being an orphan.
396   * Support pinging services such as Technorati using XML-RPC to notify them
397     about changes to rss feeds.
398   * Parse svn log as xml for improved utf8 and security. Note that this makes
399     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
400   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
401     flagged string even if the locale causes it to generate utf8 output,
402     so make sure to let perl know it should be handled as utf8. Also,
403     the optimised version used for standard time formats won't work if the
404     user has changed locale, so drop it. Thanks, Faidon Liambotis.
405   * Fix re-encoding of the comments field to utf8 if a commit fails
406     due to a conflict. Thanks, Faidon Liambotis.
407   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
408     Liambotis.
409   * Add insane double encode/decode to utf8 around call to markdown.
410     This works around a truely strange bug, which is apparently a bug in
411     perl, #376329. Also added a test case for it.
412   * Improve layout of edit page so formatting help link is always visible w/o
413     getting in the way of the preview.
414   * Centralised all calls to HTML::Template and force all the templates
415     to be read as utf8.
416   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
417   * Introduce add_plugins and disable_plugins config options in setup files.
418     This allows adding or removing plugins w/o overriding the whole list of
419     default plugins, which makes it easier to upgrade when new default plugins
420     are added.
421   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
422     default (of course!). Based on a patch by Faidon Liambotis.
423   * Add a html plugin, which can be used to write wikis in raw html,
424     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
425     defaults to not processing .html files, since w/o this plugin they would
426     be copied unsanitised. With this plugin, it will process and html
427     sanitise them, like any other page type.
428   * Rebuilding wrappers is necessary on upgrade to this version.
429   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
430     will be automatically done on all upgrades.
431   * Don't send pings if the wiki is being rebuilt.
432   * Work around very innefficient behavior in File::Spec::abs2rel. Result
433     is a savings of 2 pointless fork/execs per link calculation, which
434     results in ~25% speedup of ikiwiki building its own doc wiki, and
435     about 35% speedup displaying RecentChanges!
436   * Make RecentChanges use a table and some CSS, should be much more readable.
437     No code changes involved.
438   * Encode & in diffurl in examples, to conform to pedantic rules.
439   * Speed up RecentChanges by another 40% or so with some memoization.
440   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
441     in time to build the doc wiki.
442
443  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
444
445 ikiwiki (1.7) unstable; urgency=low
446
447   * Updated logo from Recai with some kerning and alingment tuning.
448   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
449     changed some output.
450   * Copyright update.
451
452  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
453
454 ikiwiki (1.6) unstable; urgency=low
455
456   * YA utf-8 patch from Recai, this time to fix previewing a page so that
457     the text in the input box is re-encoded back to utf-8.
458   * -CSD does not affect modules, so readfile() was not using the utf-8 input
459     layer, which led to lots of problems; make it force read files as utf-8.
460     Closes: #373203
461   * Note that as a consequence, this version of ikiwiki will actually try to
462     parse utf8 in source files for the first time, which may expose broken
463     utf8 in wiki sources that was hidden before. Most common will be
464     perl warnings like "utf8 "\xE9" does not map to Unicode"
465   * writefile() likewise needs to use the utf8 output layer.
466   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
467     there.
468   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
469     given the readfile fix.
470   * Add utf-8 testcases for readfile and htmlize.
471   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
472     safe.
473   * More utf-8 fixes from Recai, partly to things I broke above:
474     - The serious problem is that writefile() saves the content in undecoded
475       format in CGI, hence all (non-ascii) chars are corrupted permanently.
476     - Comment field in edit page is not decoded and all the non-ascii chars in
477       this field are corrupted as the result.  We should decode it as we do it
478       for the content.
479     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
480       character in print.
481   * New SVG logo from Recai.
482
483  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
484
485 ikiwiki (1.5) unstable; urgency=low
486
487   * Add --timeformat config option to allow changing how dates are displayed.
488     Note that as a side effect, dates will now be displayed using the local
489     timezone, not as GMT.
490   * More security review.
491   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
492     for some handy stuff like:
493     - Using links as a kind of tag; creating blog pages that list all pages
494       containing a given tag/link or not containing some other tag.
495     - Subscribing to mail notifications whenever a change is made to a page
496       that is a backlink of page foo. Ie, "Please notify me of changes in all
497       pages that link to my home page in the wiki"
498     - Locking any pages that are linked to from a particular page, so that
499       lists of locks can be exposed in the wiki.
500   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
501     when a todo item is done, instead of the previous moving it to a different
502     subdir.
503   * Allow pagetemplate plugins to override *anything* in the template.
504   * Add a meta plugin, which allows specifying various metadata about pages,
505     like license and author. It also allows for inserting html link and meta
506     tags into html, overriding the title, and adding hidden WikiLinks, which
507     can be useful when using link-based globbing for page categorisation.
508   * Remove preprocessor directives from inlined pages.
509   * Allow simple preprocessor directive values to be specified w/o quotes.
510   * Add support for using git instead of subversion as the RCS backend,
511     tremendous thanks to Recai Oktaş for this.
512   * Doc updates for git.
513   * Fix absolute url munging in rss generation to support https, ftp, etc urls
514     not just http urls.
515   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
516     utf-8 for edit and other fields, and for recentchanges. There may still
517     be utf-8 issues with the preferences page though.
518
519  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
520
521 ikiwiki (1.4) unstable; urgency=low
522
523   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
524     very strange way of enabling proper XHTML <br /> type tags. Output html
525     should be always valid again now.
526   * The page name and parent links has switched from using a <h1> to a styled
527     <span>, so pages can use <h1> internally instead of needing to use <h2>.
528   * Updated all of ikiwiki's own wiki pages for that.
529   * Add pagetemplate hook, which can be used by plugins that want to mess
530     around with adding new stuff to the page template.
531   * Remove headercontent; the search plugin now adds the search box to the
532     header by registering a pagetemplate hook, and other plugins should do
533     similarly.
534   * Rebuilding on upgrade to this version is recommended.
535   * Add a html validity check to the test suite, using the wdg-html-validator,
536     if available.
537   * Make the html valid when there is nothing in the actions list.
538   * Reordered some function call parameters for consistency.
539   * Enable full utf-8 support for page input and output.
540   * Add a workaround for markdown, which does not work well with utf-8
541     strings.
542   * --getctime had bitrotted (well I only ever used it the once so far..),
543     fix and make it a bit more flexible
544   * rcs_getctime is changed, now rather than needing to loop over all pages,
545     it should just use the rcs to get the ctime of the passed file.
546   * When inlining a page in another one, links from the inlined page are now
547     expanded the same as they are when rendering the inlined page as a
548     standalone page. So rather than being expanded from the POV of the
549     inlining page, they are expanded from the POV of the inlined page.
550
551     For example, a link from blog/foo to "bar" will now link to blog/bar
552     if it exists. Previously this needed to be a link explicitly to
553     "blog/bar"; such links will also continue to work.
554
555     (This was slightly complex to do as the link still has to be constructed
556     relative to the inlining page.)
557   * Make page edit textarea resize to fit browser window.
558   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
559     do not need a full rebuild, in order to update any basewiki pages.
560
561  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
562
563 ikiwiki (1.3) unstable; urgency=low
564
565   * Fix the preinst introduced in the last version. Closes: #367458
566
567  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
568
569 ikiwiki (1.2) unstable; urgency=low
570
571   * Remove dups from the brokenlinks list.
572   * Add libc6-dev to dependencies, needed to build wrappers.
573   * Install wikilist in correct location. Closes: #367371
574
575  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
576
577 ikiwiki (1.1) unstable; urgency=low
578
579   * Rename inlinepage to depends, so that it can be used to refer to more
580     dependency relationships than just inlining. This will require a rebuild
581     on upgrade to this version.
582   * Move the rss link, put it in the blogpost form if there is one and at the
583     top if not. This is both nicer because easier to find, and it cleans up
584     the code which had used inlinepage as a flag for adding the link later.
585   * Allow the depends GlobList to be built up from multiple sources (such as
586     plugins) during a page render.
587   * Which means that more than one blog is now supported to appear on a
588     single page. (With some limitations, like only the last one getting an
589     rss file.)
590   * Added a plugin system.
591   * Added a pagecount plugin, enabled by default.
592   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
593   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
594     backlinks when the backlinks hadn't really changed.
595   * Moved inline page support, rss generation etc into the inline plugin,
596     enabled by default.
597   * Added brokenlinks plugin, not enabled by default, but rather handy.
598   * Fix several broken links in the doc wiki.
599   * Smarter behavior when creating a page and a page of the same name (but
600     different location) already exists.
601   * Add an orphans plugin for finding pages that nothing links to.
602   * Removed backlinks page, which it turns out nothing used.
603   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
604     it, this will allow for adding a unit test suite.
605   * Add unit tests for several core functions, including globlist_match,
606     dirname, basename, bestlink, linkify, pagetitle, titlepage.
607   * Smart globlist merging.
608   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
609     to pave the way for adding other RCS support. This also changes the
610     setup files, where before they had svn => 1 or svn => 0, now they have
611     rcs => "svn" or rcs => "".
612   * Add a debian/NEWS file with upgrade notes.
613   * Load whatever rcs module is specified, so new ones can be just dropped in
614     as plugins and work. (Well, in theory.)
615   * Add some basic docs about writing RCS modules.
616   * Broke search capability out into a plugin, removed the --hyperestraier
617     switch.
618   * Added smiley plugin, nicely controlled and documented by the smileys page.
619   * Copied in some smileys from Moin Moin.
620   * Allow links of the form [[some page|page]], with whitespace in the link
621     text.
622   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
623     and --disable-plugin htmlscrubber.
624   * Allow discussion links on pages to be turned off with --no-discussion.
625   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
626   * Add some new config items to the estseek.conf template, which are needed
627     by hyperestraier 1.2.3.
628
629  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
630
631 ikiwiki (1.0) unstable; urgency=low
632
633   * First official release.
634
635  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400