* Add a default stylesheet entry for the pagecloud.
[ikiwiki] / debian / changelog
1 ikiwiki (1.32) UNRELEASED; urgency=low
2
3   * Add a separate pass to find page links, and only render each page once,
4     instead of over and over. Typical speedup is ~4x. Max possible speedup:
5     8x.
6   * Add "scan" parameter to hook(), which is used to make the hook be called
7     during the scanning pass, as well as the render pass. The meta and tag
8     plugins need to use the new scan parameter, so will any others that modify
9     %links.
10   * Now that links are calculated in a separate pass, it can also
11     precalculate backlinks in one pass, which is O(N^2) instead of the
12     previous code that was O(N^3). A very nice speedup for wikis with lots
13     (thousands) of pages.
14   * Stylish update to the ikiwiki logo, thanks to Recai Oktaş and Selçuk
15     Erdem.
16   * Add a default stylesheet entry for the pagecloud.
17   * Add examples page with some examples of things that can be done using
18     ikiwiki, like a weblog. The examples can be copied into a user's wiki
19     for a quick start, without needing to learn everything about how to put
20     them together.
21
22  -- Joey Hess <joeyh@debian.org>  Sat, 28 Oct 2006 19:23:03 -0400
23
24 ikiwiki (1.31) unstable; urgency=low
25
26   * Patch from Pawel Tecza to cp -a the templates in the Makefile.
27   * Change the rss feed title from the wikiname to the page title, with
28     an exception for the wiki's toplevel index page, which will still use the
29     wikiname as the feed title.
30     Overriding the page title with meta title already overrode the rss feed
31     tittle.
32   * Add an img plugin, based on Christian Mock's img plugin, but stripped
33     down to the bare essentials. Useful for handling large images on websites.
34   * Sanitize possibly problimatic characters out of the polygen grammar names,
35     just in case. Should not be exploitable anyway, since it only tries to run
36     polygen after finding the specified grammar file.
37   * Add missing dependency on the URI perl module.
38   * Add basic spam fighting tool for admins: An admin's prefs page now allows
39     editing a list of banned users.
40
41  -- Joey Hess <joeyh@debian.org>  Fri, 27 Oct 2006 23:16:33 -0400
42
43 ikiwiki (1.30) unstable; urgency=low
44
45   * Add no_override parameter to hook().
46   * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
47     plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
48     can be configured using a page in wiki.
49   * Fix support for --pingurl at the command line.
50   * Fix a subtle bug in will_render that broke some builds, by only clearing
51     items from renderedfiles the first time per build.
52   * Wrap entire technortati ping operation in an eval to catch all possible
53     failure modes, after I observed a simple ->value crashing ikiwiki when
54     a ping failed.
55
56  -- Joey Hess <joeyh@debian.org>  Mon, 16 Oct 2006 15:17:38 -0400
57
58 ikiwiki (1.29) unstable; urgency=low
59
60   * Patch from Paul Tötterman to use CP in the Makefile.
61   * Patch from Alec Berryman adding a http_auth config item that allows
62     using HTTP Authentication instead of ikiwiki's built in authentication.
63     Useful for eg, large sites with their own previously existing user auth
64     setup. Closes: #384534
65   * Change %renderedfiles to store an array of files rendered from a given
66     source file, to allow tracking of extra rendered files like rss feeds.
67   * Note that plugins that accessed this variable will need to be updated!
68     The plugin interface has been increased to version 1.01 for this change.
69     As few plugins use %renderedfiles I haven't done anything else to ensure
70     compatability of old plugins.
71   * Add will_render function to the plugin interface, used to register that a
72     page renders a destination file, and do some security checks. Previously
73     but no longer rendered files will be cleaned up.
74   * Use will_render in the inline and linkmap plugins.
75   * You will need to rebuild your wiki on upgrade to this version.
76   * Atom feed support based on a patch by Clint Adams.
77   * Add feeds=no option to inline preprocessor directive to turn off all types
78     of feeds.
79   * $IkiWiki::version now holds the program version, and is accessible to
80     plugins.
81   * Make the aggregate plugin emphasize error messages.
82   * Patch from Recai to limit recentchanges to displaying max 10 files for a
83     given changeset (to avoid large number of file changes excessively
84     bloating the page).
85
86  -- Joey Hess <joeyh@debian.org>  Fri, 13 Oct 2006 23:14:28 -0400
87
88 ikiwiki (1.28) unstable; urgency=low
89
90   * inline: Add ability to sort by page name, based on a patch from
91     Benjamin A'Lee.
92   * Fix a forkbomb in various calls to IPC::Open2, which has a highly
93     braindead interface. Closes: #389383
94   * Don't rm -rf ikiwiki on distclean, since a) there's no such file
95     and b) those poor Mac OSX users and their case insensative files!
96   * Don't fail syntax check if Text::Typography isn't installed.
97     Closes: #389406
98
99  -- Joey Hess <joeyh@debian.org>  Tue, 26 Sep 2006 02:08:17 -0400
100
101 ikiwiki (1.27) unstable; urgency=low
102
103   * Work on firming up the plugin interface:
104     - Plugins should not need to load IkiWiki::Render to get commonly
105       used functions, so moved some functions from there to IkiWiki.
106     - Picked out the set of functions and variables that most plugins
107       use, documented them, and made IkiWiki export them by default,
108       like a proper perl module should.
109     - Use the other functions at your own risk.
110     - This is not quite complete, I still have to decide whether to
111       export some other things.
112   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
113     referring to stuff now exported by the IkiWiki module.
114   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
115     to declare which version of the interface your plugin needs.
116   * Anyone with a third-party ikiwiki plugin is strongly encouraged
117     to make like changes to it and avoid use of non-exported symbols from
118     "IkiWiki::".
119   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
120   * Support hyperestradier version 1.4.2, which adds a new required phraseform
121     setting.
122   * If an inlined page has a permalink, link the page title to that.
123   * Patch from Recai to use utf8 when reading the setup file, so that
124     utf8 wikinames from there will be used properly.
125   * Patch from Recai to kill utf-8 on the wiki name when generating the
126     session cookie.
127   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
128   * Fix a baseurl problem in hyperestradier search results.
129   * Add a stub local.css to avoid problems with 404's.
130   * Patch from Recai to fix a wide character warning from the search plugin
131     during setup if the wikiname contains utf8.
132   * Yet another fix for those poor case-insensative OS X users.
133   * pagetemplate hooks are now also called when generating cgi pages.
134   * Add a favicon plugin, which simply adds a link tag for an icon to each
135     page (and cgis).
136   * Patch from James Westby to deal with the case where you're editing a
137     new page, hit cancel, and need to be redirected to somewhere sane.
138   * Various documentation improvements by various wiki users.
139   * Support Text::Markdown from CPAN, which has a different interface from
140     the original markdown or the one in Debian.
141   * Version the libcgi-session-perl dependency, some features that need
142     the new version are used in some cases (sslcookie).
143   * Numerous tla fixes from Clint.
144   * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
145     a multi-resolution favicon.ico.
146   * README.Debian: typo Closes: #388110
147   * chomp trailing newline at the end of templates read in by the template
148     plugin, to allow use of the template preprocessor directive in
149     whitespace-sensative situations. Closes: #387073
150   * Patch from James Westby to make the location of the estseek.cgi script
151     configurable.
152   * Add typography (SmartyPants) plugin by Recai.
153   * Add --render mode, which can be used to preview an edit at the command
154     line by test rendering a single page.
155   * Add a googlecalendar plugin. A bit special-purpose, but it shows
156     one way to to deal with user-supplied content that could cause XSS
157     issues w/o the htmlscrubber, and won't survive the scrubber.
158
159  -- Joey Hess <joeyh@debian.org>  Sun, 24 Sep 2006 00:02:21 -0400
160
161 ikiwiki (1.26) unstable; urgency=low
162
163   * Add a missing -n to tla undo call.
164   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
165     writes before consuming its whole stdin. Avoid this deadlock.
166   * Fix alt tags for outline checkboxes.
167
168  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
169
170 ikiwiki (1.25) unstable; urgency=low
171
172   * Add proper waitpid calls for open2ed processes throughout to avoid
173     zombies; this hit htmltidy especially badly.
174   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
175     subversion repos and fixing some other issues.
176   * Add support for tla, contributed by Clint Adams. Closes: #385936
177   * Add support for mercurial, contributed by Emanuele Aina.
178   * Include <link rel> tag for RSS feeds, used by some aggregators and
179     firefox to find the feed.
180   * Add a linkmap plugin (requires graphviz).
181
182  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
183
184 ikiwiki (1.24) unstable; urgency=low
185
186   * Simplify the data structure returned by rcs_recentchanges to avoid
187     each rcs plugin needing to form complex strings on its own.
188   * Fix another destpage issue in the inline directive. Closes: #385512
189     again.
190
191  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
192
193 ikiwiki (1.23) unstable; urgency=low
194
195   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
196
197  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
198
199 ikiwiki (1.22) unstable; urgency=low
200
201   * Change how the stylesheet url is determined in the templates: Remove
202     STYLEURL and add BASEURL to all templates (some already had it). This
203     new more general variable can be used to link to other things (eg, images)
204     from the template, as well as stylesheets.
205   * Fix a bug introduced last version to do with nested inlines.
206   * Allow preprocessor directives to span multiple lines, both to make
207     long ones with lots of values easier to write, and to allow for ones with
208     multi-line quoted values.
209   * Allow preprocessor directives to contain python-like triple-quoted
210     text blocks, for easy nesting of quotes inside.
211   * Add a template plugin.
212   * Make pagespec merge code smarter about merging duplicate pagespecs.
213   * Patch from Jordà Polo to make Setup::Standard support hashes in config
214     files.
215   * Change order of linkify and preprocess; first preprocess and then linkify.
216     This allows passing a wikilink inside a parameter to a preprocessor
217     directive without it being expanded to html, and leaking out of the
218     parameter, which had required some non-obvious use of triple-quoting
219     to avoid. Note that any preprocessor plugins that output something
220     that looks like a wikilink will now have it treated as such; AFAIK
221     this doesn't change any behavior though except for the template plugin.
222   * Enable preprocessor directives when previewing an edit.
223   * Make all pages pull in a local.css style sheet, if present. This won't
224     be included in ikiwiki, but can be created to make local styling changes
225     w/o needing to merge in every new change to the distributed style.css.
226   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
227   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
228     from a different directory.
229   * Generalised preprocesser loop protection code.
230   * Patch from James Westby to allow a description to be set for rss feeds.
231   * Patch from James Westby to add a template for the search form.
232   * Added a ddate plugin.
233   * Patch from James Westby to add a --sslcookie switch, which forces
234     cookies to only be sent over ssl connections to avoid interception.
235   * Fix preferences page on anonok wikis; still need to sign in to get
236     to the preferences page.
237   * Add toc (table of contents) plugin.
238   * Change htmlize, format, and sanitize hooks to use named parameters.
239   * Patch from James Westby to add an actions option to inline; this
240     adds Edit and Discussion links at the end of blog entries.
241   * Due to some css changes, you'll want to rebuild your wiki on upgrade
242     to this version. Will be handled automatically by the deb.
243   * Add processed date to aggregate preprocessor directive status output.
244
245  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
246
247 ikiwiki (1.21) unstable; urgency=low
248
249   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
250   * If a page links to itself, mark up the link text in a span with
251     class="selflink" so that it can be styled. I don't have a useful style
252     defined for that though.
253   * Call filter hooks on inlined page content.
254   * Support inlining pages raw, rather than creating a blog.
255   * Clean up yes/no parameter parsing in inline plugin.
256   * Implemented better cycle detection in the inline plugin; nested inlines
257     will now work.
258   * Add a map plugin contributed by Alessandro Dotti Contra.
259   * Add otl format plugin, which handles files as created by vimoutliner.
260   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
261   * Add first draft at a Restructured Text (rst) plugin, by Sergio
262     Talens-Oliag. Note that this has many known issues -- see the caveats on
263     the plugin's page.
264   * Credit everyone who wrote a plugin on the plugins' wiki pages.
265   * Fix utf-8 in blog post form.
266
267  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
268
269 ikiwiki (1.20) unstable; urgency=low
270
271   * Relicense the templates and basewiki under the 2-clause BSD license.
272     Since these can easily become part of other people's websites, they
273     should be under as permissive a license as possible.
274   * Add --syslog config option, to log to the syslog.
275   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
276     transient failure to fork (which I've seen happen in the wild).
277   * Fix a bug in the aggregator introduced last version that caused all
278     aggregator state to be lost during a non-aggregating build.
279
280  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
281
282 ikiwiki (1.19) unstable; urgency=low
283
284   * Fix several related bugs in page type determination during online editing.
285   * Add some locking to prevent 2 aggregators from running at once.
286   * Fix an infinite loop in the aggregator when finding a unique filename.
287
288  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
289
290 ikiwiki (1.18) unstable; urgency=low
291
292   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
293   * Add --version.
294   * Man page format fixups.
295   * If the meta plugin overides the page title, set a title_overridden
296     variable in the template to true. This allows doing things with the
297     templates conditional on the title being overriden.
298   * Add a %pagecase which maps lower-case page names to the actual case
299     used in the filename. Use this in bestlinks calculation instead of
300     forcing the link to lowercase.
301   * Also use %pagecase in various other places that want to check if a page
302     with a given name exists.
303   * This means that links to pages with mixed case names will now work,
304     even if the link is in some other case mixture, and mixed case pages
305     should be fully supported throughout ikiwiki.
306   * Recommend rebuilding wikis on upgrade to this version.
307
308  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
309
310 ikiwiki (1.17) unstable; urgency=low
311
312   * Disable tidy generator tag.
313   * Move tidy back to sanitize hook, found out how to only show body.
314   * Turn off tidy indentation too.
315   * Turn on HTML::Template loop_context_vars; not actually used in stock
316     templates but can be useful for things like making comma-delimited lists
317     of tags or what have you.
318   * Remove <br> from end of aggregate preprocessor directive output.
319   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
320     case-sensative filesystems like OSX.
321   * Improve markdown loading. First, try to load it as a proper perl module,
322     in case it was installed as one. Then fall back to trying
323     /usr/bin/markdown.
324   * Document in install page how to install markdown, since it has no
325     installation procedure in the upstream tarball.
326   * Set die_on_bad_params => 0 for all templates, to allow users to modify
327     them without annoyances.
328   * Suck in the page content when generating an inline archive page, to work
329     around the meta plugin's lack of caching of title metadata across runs.
330
331  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
332
333 ikiwiki (1.16) unstable; urgency=low
334
335   * Try to handle relative links in aggregated feeds. However,
336     the current support is a crude hack due to limitations of XML::Feed:
337     xml:base is not supported, neither is Content-Location. And of course,
338     relative links in RSS feeds are ill-undefined..
339   * Make aggregator save permalinks and author name to pages as metadata.
340   * Add permalink and author support to meta plugin, affecting RSS feeds
341     and blog pages.
342   * Various CSS and formatting changes.
343   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
344   * Add xhtml files to the default prune regexp.
345   * Also generate rel=bookmark links for permalinks.
346   * Fix the htmltidy plugin, which wasn't working due my breaking it when
347     I added it..
348   * Don't run tidy with -xml as that fails if the input is not well-formed.
349     Run it with -asxhtml instead, so it will output well-formed xhtml no
350     matter what the input.
351   * Disable tidy warnings too.
352   * Add a new format hook, and make tidy use it, since tidy can really only
353     operate on and output complete html documents, not the body chunks
354     that sanitise gets.
355   * Fix dates in rss feeds if running localised, so they're still rfc 822.
356
357  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
358
359 ikiwiki (1.15) unstable; urgency=low
360
361   * Remove CDPATH and other env vars perl taint checking doesn't like.
362     Closes: #381279
363   * Added created_before and created_after PageSpec limits.
364
365  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
366
367 ikiwiki (1.14) unstable; urgency=low
368
369   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
370     by 10% or so.
371   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
372   * Added many unit tests for pagespec_match.
373
374  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
375
376 ikiwiki (1.13) unstable; urgency=low
377
378   * ikiwiki can now download and aggregate feeds with its new aggregate
379     plugin, so it's possible to implement a Planet using ikiwiki!
380   * Add a run_hooks function for the common task of running all hooks of a
381     given type.
382   * Add a savestate hook.
383   * Don't put blog post forms on pages if there's no cgiurl set.
384   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
385     --wrappers to do that.
386   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
387     to update pages that haven't changed on disk.
388   * Change meta tags to use html entity-escaped text for values, so that
389     quotes and such can be represented in title tags.
390   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
391     for the above.
392   * Make --rebuild also cause --aggregate to re-download and write aggregated
393     pages.
394   * Avoid outputting duplicate meta info.
395   * Include title metadata on aggregated posts for capitalised and un-munged
396     titles.
397   * Title metadata of inlined pages now shows up in blogs and rss feeds.
398   * Fix issue with unicode filenames and updating the hyper estradier search
399     index. (Aka Please Please Please, let that be the last one.)
400   * Patch from Roland Mas to support an rss=no parameter to inline directives.
401     Closes: #380743
402   * Renamed GlobLists to PageSpecs.
403   * PageSpecs can now include nested parens, "and", and "or". This remains
404     backwards compatible to the old GlobList format. It's implemented by
405     treating the GlobList as a very limited microlanguage that is transformed
406     to perl code that does the matching.
407   * The old GlobList format is deprecated, and I encourage users to switch to
408     using the new PageSpec format. Compatability with the old format will be
409     removed at some point, possibly by 2.0.
410   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
411   * Add support for creation_month and creation_year to PageSpec.
412     Closes: #380680
413   * Changes to index file encoding.
414
415  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
416
417 ikiwiki (1.12) unstable; urgency=low
418
419   "Viva l'Italia!"
420   * New pagestats plugin from Enrico, which can generate a table counting
421     the backlinks for each page, or a del.icio.us style cloud.
422   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
423     the wikiformat plugin works. Thanks, Emanuele Aina.
424   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
425     display, running them through pagetitle. This removes ugly underscores and
426     other gunk from the display, much nicer. You may want to rebuild your wiki
427     when upgrading to get the cleanup globally.
428   * Polygen plugin from Enrico.
429   * htmltidy plugin from Faidon.
430   * Locale patch from Faidon:
431     - Adds a locale setting to setup files.
432     - Proper local time, if the locale configuration option is used.
433     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
434       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
435       impossible.
436   * Add getopt hook type, this allows plugins to add new command-line options.
437   * Add --tagbase option to tag plugin.
438   * Add exclude option in setup files, works same as --exclude.
439   * Put categories in rss feeds for tagged items.
440   * Allow preprocessor directives to be expanded in inlined blog pages.
441     However, to avoid inlining loops etc, don't expand inline directives in
442     inlined pages.
443   * fortune plugin (trivial)
444   * Tag plugins according to type.
445
446  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
447
448 ikiwiki (1.11) unstable; urgency=low
449
450   * Patch from Enrico that
451     - Adds a tag plugin that allows more easily tagging pages.
452       The meta plugin can also still be used for that, but the tag plugin
453       also lists a page's tags at the bottom of the page.
454     - Allows preprocessor directives to have parameters with no specified
455       value.
456     - Fixes preprocessor directive parameter parsing so that
457       foo=bar baz now means "foo=bar" and a "baz" with no value.
458   * Run pagetemplate hooks when inlining pages so that inlined pages also
459     list their tags.
460   * Make all plugins with pagetemplate hooks check that variables exist
461     on the template before setting them, for robustness.
462   * Switch pagetemplate hooks to using named parameters.
463   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
464     This will be the page that a source page will be part of, which is
465     different than the source page for inlined pages.
466   * Audited all plugins to endure they pass (page, destpage) to htmllink
467     appropriatly. This means inlining of various plugins will not work
468     properly, with correct links generated.
469
470  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
471
472 ikiwiki (1.10) unstable; urgency=low
473
474   * Run page through any relevant filters when generating a page preview.
475   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
476     default throughout the wiki, not only on wikitext pages. Decided to call
477     this a feature, and split the camelcase support out into a separate plugin
478     that is independant of wikitext.
479   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
480
481  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
482
483 ikiwiki (1.9) unstable; urgency=low
484
485   * Improve display of parentlinks and page title of toplevel index page.
486   * Patch from Faidon to use svn --limit when possible for recentchanges,
487     speeds up recentchanges a lot for wikis with more history.
488   * Patch from Recai to fix utf8 issues in git backend.
489   * Add wikitext markup plugin, which supports ".wiki" pages written in the
490     original wiki syntax, CamelCase links and all.
491   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
492     support, to edit pages etc without a web server.
493   * Display CGI processing errors if present.
494   * Fix from Faidon for a XML parser issue that breaks utf-8 for
495     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
496     area, and also way slow.
497   * Match 'web commit from' in SVN and git, these are web commits too.
498     (Faidon)
499   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
500     readable and avoid future mistakes. The patch seems to work and for the
501     first time I have a UTF-8 username ;-) (Faidon)
502   * Use form->field consistently, not form->param.
503   * Patch from Recai to allow selection of page type when creating a new page.
504     Default page type is inherited from the link clicked on to create the new
505     page.
506
507  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
508
509 ikiwiki (1.8) unstable; urgency=low
510
511   * Fix orphans plugin to not count a link to a nonexistant page as a reason
512     for a page not being an orphan.
513   * Support pinging services such as Technorati using XML-RPC to notify them
514     about changes to rss feeds.
515   * Parse svn log as xml for improved utf8 and security. Note that this makes
516     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
517   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
518     flagged string even if the locale causes it to generate utf8 output,
519     so make sure to let perl know it should be handled as utf8. Also,
520     the optimised version used for standard time formats won't work if the
521     user has changed locale, so drop it. Thanks, Faidon Liambotis.
522   * Fix re-encoding of the comments field to utf8 if a commit fails
523     due to a conflict. Thanks, Faidon Liambotis.
524   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
525     Liambotis.
526   * Add insane double encode/decode to utf8 around call to markdown.
527     This works around a truely strange bug, which is apparently a bug in
528     perl, #376329. Also added a test case for it.
529   * Improve layout of edit page so formatting help link is always visible w/o
530     getting in the way of the preview.
531   * Centralised all calls to HTML::Template and force all the templates
532     to be read as utf8.
533   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
534   * Introduce add_plugins and disable_plugins config options in setup files.
535     This allows adding or removing plugins w/o overriding the whole list of
536     default plugins, which makes it easier to upgrade when new default plugins
537     are added.
538   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
539     default (of course!). Based on a patch by Faidon Liambotis.
540   * Add a html plugin, which can be used to write wikis in raw html,
541     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
542     defaults to not processing .html files, since w/o this plugin they would
543     be copied unsanitised. With this plugin, it will process and html
544     sanitise them, like any other page type.
545   * Rebuilding wrappers is necessary on upgrade to this version.
546   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
547     will be automatically done on all upgrades.
548   * Don't send pings if the wiki is being rebuilt.
549   * Work around very innefficient behavior in File::Spec::abs2rel. Result
550     is a savings of 2 pointless fork/execs per link calculation, which
551     results in ~25% speedup of ikiwiki building its own doc wiki, and
552     about 35% speedup displaying RecentChanges!
553   * Make RecentChanges use a table and some CSS, should be much more readable.
554     No code changes involved.
555   * Encode & in diffurl in examples, to conform to pedantic rules.
556   * Speed up RecentChanges by another 40% or so with some memoization.
557   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
558     in time to build the doc wiki.
559
560  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
561
562 ikiwiki (1.7) unstable; urgency=low
563
564   * Updated logo from Recai with some kerning and alingment tuning.
565   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
566     changed some output.
567   * Copyright update.
568
569  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
570
571 ikiwiki (1.6) unstable; urgency=low
572
573   * YA utf-8 patch from Recai, this time to fix previewing a page so that
574     the text in the input box is re-encoded back to utf-8.
575   * -CSD does not affect modules, so readfile() was not using the utf-8 input
576     layer, which led to lots of problems; make it force read files as utf-8.
577     Closes: #373203
578   * Note that as a consequence, this version of ikiwiki will actually try to
579     parse utf8 in source files for the first time, which may expose broken
580     utf8 in wiki sources that was hidden before. Most common will be
581     perl warnings like "utf8 "\xE9" does not map to Unicode"
582   * writefile() likewise needs to use the utf8 output layer.
583   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
584     there.
585   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
586     given the readfile fix.
587   * Add utf-8 testcases for readfile and htmlize.
588   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
589     safe.
590   * More utf-8 fixes from Recai, partly to things I broke above:
591     - The serious problem is that writefile() saves the content in undecoded
592       format in CGI, hence all (non-ascii) chars are corrupted permanently.
593     - Comment field in edit page is not decoded and all the non-ascii chars in
594       this field are corrupted as the result.  We should decode it as we do it
595       for the content.
596     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
597       character in print.
598   * New SVG logo from Recai.
599
600  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
601
602 ikiwiki (1.5) unstable; urgency=low
603
604   * Add --timeformat config option to allow changing how dates are displayed.
605     Note that as a side effect, dates will now be displayed using the local
606     timezone, not as GMT.
607   * More security review.
608   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
609     for some handy stuff like:
610     - Using links as a kind of tag; creating blog pages that list all pages
611       containing a given tag/link or not containing some other tag.
612     - Subscribing to mail notifications whenever a change is made to a page
613       that is a backlink of page foo. Ie, "Please notify me of changes in all
614       pages that link to my home page in the wiki"
615     - Locking any pages that are linked to from a particular page, so that
616       lists of locks can be exposed in the wiki.
617   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
618     when a todo item is done, instead of the previous moving it to a different
619     subdir.
620   * Allow pagetemplate plugins to override *anything* in the template.
621   * Add a meta plugin, which allows specifying various metadata about pages,
622     like license and author. It also allows for inserting html link and meta
623     tags into html, overriding the title, and adding hidden WikiLinks, which
624     can be useful when using link-based globbing for page categorisation.
625   * Remove preprocessor directives from inlined pages.
626   * Allow simple preprocessor directive values to be specified w/o quotes.
627   * Add support for using git instead of subversion as the RCS backend,
628     tremendous thanks to Recai Oktaş for this.
629   * Doc updates for git.
630   * Fix absolute url munging in rss generation to support https, ftp, etc urls
631     not just http urls.
632   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
633     utf-8 for edit and other fields, and for recentchanges. There may still
634     be utf-8 issues with the preferences page though.
635
636  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
637
638 ikiwiki (1.4) unstable; urgency=low
639
640   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
641     very strange way of enabling proper XHTML <br /> type tags. Output html
642     should be always valid again now.
643   * The page name and parent links has switched from using a <h1> to a styled
644     <span>, so pages can use <h1> internally instead of needing to use <h2>.
645   * Updated all of ikiwiki's own wiki pages for that.
646   * Add pagetemplate hook, which can be used by plugins that want to mess
647     around with adding new stuff to the page template.
648   * Remove headercontent; the search plugin now adds the search box to the
649     header by registering a pagetemplate hook, and other plugins should do
650     similarly.
651   * Rebuilding on upgrade to this version is recommended.
652   * Add a html validity check to the test suite, using the wdg-html-validator,
653     if available.
654   * Make the html valid when there is nothing in the actions list.
655   * Reordered some function call parameters for consistency.
656   * Enable full utf-8 support for page input and output.
657   * Add a workaround for markdown, which does not work well with utf-8
658     strings.
659   * --getctime had bitrotted (well I only ever used it the once so far..),
660     fix and make it a bit more flexible
661   * rcs_getctime is changed, now rather than needing to loop over all pages,
662     it should just use the rcs to get the ctime of the passed file.
663   * When inlining a page in another one, links from the inlined page are now
664     expanded the same as they are when rendering the inlined page as a
665     standalone page. So rather than being expanded from the POV of the
666     inlining page, they are expanded from the POV of the inlined page.
667
668     For example, a link from blog/foo to "bar" will now link to blog/bar
669     if it exists. Previously this needed to be a link explicitly to
670     "blog/bar"; such links will also continue to work.
671
672     (This was slightly complex to do as the link still has to be constructed
673     relative to the inlining page.)
674   * Make page edit textarea resize to fit browser window.
675   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
676     do not need a full rebuild, in order to update any basewiki pages.
677
678  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
679
680 ikiwiki (1.3) unstable; urgency=low
681
682   * Fix the preinst introduced in the last version. Closes: #367458
683
684  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
685
686 ikiwiki (1.2) unstable; urgency=low
687
688   * Remove dups from the brokenlinks list.
689   * Add libc6-dev to dependencies, needed to build wrappers.
690   * Install wikilist in correct location. Closes: #367371
691
692  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
693
694 ikiwiki (1.1) unstable; urgency=low
695
696   * Rename inlinepage to depends, so that it can be used to refer to more
697     dependency relationships than just inlining. This will require a rebuild
698     on upgrade to this version.
699   * Move the rss link, put it in the blogpost form if there is one and at the
700     top if not. This is both nicer because easier to find, and it cleans up
701     the code which had used inlinepage as a flag for adding the link later.
702   * Allow the depends GlobList to be built up from multiple sources (such as
703     plugins) during a page render.
704   * Which means that more than one blog is now supported to appear on a
705     single page. (With some limitations, like only the last one getting an
706     rss file.)
707   * Added a plugin system.
708   * Added a pagecount plugin, enabled by default.
709   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
710   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
711     backlinks when the backlinks hadn't really changed.
712   * Moved inline page support, rss generation etc into the inline plugin,
713     enabled by default.
714   * Added brokenlinks plugin, not enabled by default, but rather handy.
715   * Fix several broken links in the doc wiki.
716   * Smarter behavior when creating a page and a page of the same name (but
717     different location) already exists.
718   * Add an orphans plugin for finding pages that nothing links to.
719   * Removed backlinks page, which it turns out nothing used.
720   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
721     it, this will allow for adding a unit test suite.
722   * Add unit tests for several core functions, including globlist_match,
723     dirname, basename, bestlink, linkify, pagetitle, titlepage.
724   * Smart globlist merging.
725   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
726     to pave the way for adding other RCS support. This also changes the
727     setup files, where before they had svn => 1 or svn => 0, now they have
728     rcs => "svn" or rcs => "".
729   * Add a debian/NEWS file with upgrade notes.
730   * Load whatever rcs module is specified, so new ones can be just dropped in
731     as plugins and work. (Well, in theory.)
732   * Add some basic docs about writing RCS modules.
733   * Broke search capability out into a plugin, removed the --hyperestraier
734     switch.
735   * Added smiley plugin, nicely controlled and documented by the smileys page.
736   * Copied in some smileys from Moin Moin.
737   * Allow links of the form [[some page|page]], with whitespace in the link
738     text.
739   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
740     and --disable-plugin htmlscrubber.
741   * Allow discussion links on pages to be turned off with --no-discussion.
742   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
743   * Add some new config items to the estseek.conf template, which are needed
744     by hyperestraier 1.2.3.
745
746  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
747
748 ikiwiki (1.0) unstable; urgency=low
749
750   * First official release.
751
752  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400