* Catch failing IPC::Open2 in tidy plugin and retry in case this is a
[ikiwiki] / debian / changelog
1 ikiwiki (1.20) UNRELEASED; urgency=low
2
3   * Relicense the templates and basewiki under the 2-clause BSD license.
4     Since these can easily become part of other people's websites, they
5     should be under as permissive a license as possible.
6   * Add --syslog config option, to log to the syslog.
7   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
8     transient failure to fork (which I've seen happen in the wild).
9
10  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 14:43:02 -0400
11
12 ikiwiki (1.19) unstable; urgency=low
13
14   * Fix several related bugs in page type determination during online editing.
15   * Add some locking to prevent 2 aggregators from running at once.
16   * Fix an infinite loop in the aggregator when finding a unique filename.
17
18  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
19
20 ikiwiki (1.18) unstable; urgency=low
21
22   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
23   * Add --version.
24   * Man page format fixups.
25   * If the meta plugin overides the page title, set a title_overridden
26     variable in the template to true. This allows doing things with the
27     templates conditional on the title being overriden.
28   * Add a %pagecase which maps lower-case page names to the actual case
29     used in the filename. Use this in bestlinks calculation instead of
30     forcing the link to lowercase.
31   * Also use %pagecase in various other places that want to check if a page
32     with a given name exists.
33   * This means that links to pages with mixed case names will now work,
34     even if the link is in some other case mixture, and mixed case pages
35     should be fully supported throughout ikiwiki.
36   * Recommend rebuilding wikis on upgrade to this version.
37
38  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
39
40 ikiwiki (1.17) unstable; urgency=low
41
42   * Disable tidy generator tag.
43   * Move tidy back to sanitize hook, found out how to only show body.
44   * Turn off tidy indentation too.
45   * Turn on HTML::Template loop_context_vars; not actually used in stock
46     templates but can be useful for things like making comma-delimited lists
47     of tags or what have you.
48   * Remove <br> from end of aggregate preprocessor directive output.
49   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
50     case-sensative filesystems like OSX.
51   * Improve markdown loading. First, try to load it as a proper perl module,
52     in case it was installed as one. Then fall back to trying
53     /usr/bin/markdown.
54   * Document in install page how to install markdown, since it has no
55     installation procedure in the upstream tarball.
56   * Set die_on_bad_params => 0 for all templates, to allow users to modify
57     them without annoyances.
58   * Suck in the page content when generating an inline archive page, to work
59     around the meta plugin's lack of caching of title metadata across runs.
60
61  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
62
63 ikiwiki (1.16) unstable; urgency=low
64
65   * Try to handle relative links in aggregated feeds. However,
66     the current support is a crude hack due to limitations of XML::Feed:
67     xml:base is not supported, neither is Content-Location. And of course,
68     relative links in RSS feeds are ill-undefined..
69   * Make aggregator save permalinks and author name to pages as metadata.
70   * Add permalink and author support to meta plugin, affecting RSS feeds
71     and blog pages.
72   * Various CSS and formatting changes.
73   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
74   * Add xhtml files to the default prune regexp.
75   * Also generate rel=bookmark links for permalinks.
76   * Fix the htmltidy plugin, which wasn't working due my breaking it when
77     I added it..
78   * Don't run tidy with -xml as that fails if the input is not well-formed.
79     Run it with -asxhtml instead, so it will output well-formed xhtml no
80     matter what the input.
81   * Disable tidy warnings too.
82   * Add a new format hook, and make tidy use it, since tidy can really only
83     operate on and output complete html documents, not the body chunks
84     that sanitise gets.
85   * Fix dates in rss feeds if running localised, so they're still rfc 822.
86
87  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
88
89 ikiwiki (1.15) unstable; urgency=low
90
91   * Remove CDPATH and other env vars perl taint checking doesn't like.
92     Closes: #381279
93   * Added created_before and created_after PageSpec limits.
94
95  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
96
97 ikiwiki (1.14) unstable; urgency=low
98
99   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
100     by 10% or so.
101   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
102   * Added many unit tests for pagespec_match.
103
104  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
105
106 ikiwiki (1.13) unstable; urgency=low
107
108   * ikiwiki can now download and aggregate feeds with its new aggregate
109     plugin, so it's possible to implement a Planet using ikiwiki!
110   * Add a run_hooks function for the common task of running all hooks of a
111     given type.
112   * Add a savestate hook.
113   * Don't put blog post forms on pages if there's no cgiurl set.
114   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
115     --wrappers to do that.
116   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
117     to update pages that haven't changed on disk.
118   * Change meta tags to use html entity-escaped text for values, so that
119     quotes and such can be represented in title tags.
120   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
121     for the above.
122   * Make --rebuild also cause --aggregate to re-download and write aggregated
123     pages.
124   * Avoid outputting duplicate meta info.
125   * Include title metadata on aggregated posts for capitalised and un-munged
126     titles.
127   * Title metadata of inlined pages now shows up in blogs and rss feeds.
128   * Fix issue with unicode filenames and updating the hyper estradier search
129     index. (Aka Please Please Please, let that be the last one.)
130   * Patch from Roland Mas to support an rss=no parameter to inline directives.
131     Closes: #380743
132   * Renamed GlobLists to PageSpecs.
133   * PageSpecs can now include nested parens, "and", and "or". This remains
134     backwards compatible to the old GlobList format. It's implemented by
135     treating the GlobList as a very limited microlanguage that is transformed
136     to perl code that does the matching.
137   * The old GlobList format is deprecated, and I encourage users to switch to
138     using the new PageSpec format. Compatability with the old format will be
139     removed at some point, possibly by 2.0.
140   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
141   * Add support for creation_month and creation_year to PageSpec.
142     Closes: #380680
143   * Changes to index file encoding.
144
145  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
146
147 ikiwiki (1.12) unstable; urgency=low
148
149   "Viva l'Italia!"
150   * New pagestats plugin from Enrico, which can generate a table counting
151     the backlinks for each page, or a del.icio.us style cloud.
152   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
153     the wikiformat plugin works. Thanks, Emanuele Aina.
154   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
155     display, running them through pagetitle. This removes ugly underscores and
156     other gunk from the display, much nicer. You may want to rebuild your wiki
157     when upgrading to get the cleanup globally.
158   * Polygen plugin from Enrico.
159   * htmltidy plugin from Faidon.
160   * Locale patch from Faidon:
161     - Adds a locale setting to setup files.
162     - Proper local time, if the locale configuration option is used.
163     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
164       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
165       impossible.
166   * Add getopt hook type, this allows plugins to add new command-line options.
167   * Add --tagbase option to tag plugin.
168   * Add exclude option in setup files, works same as --exclude.
169   * Put categories in rss feeds for tagged items.
170   * Allow preprocessor directives to be expanded in inlined blog pages.
171     However, to avoid inlining loops etc, don't expand inline directives in
172     inlined pages.
173   * fortune plugin (trivial)
174   * Tag plugins according to type.
175
176  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
177
178 ikiwiki (1.11) unstable; urgency=low
179
180   * Patch from Enrico that
181     - Adds a tag plugin that allows more easily tagging pages.
182       The meta plugin can also still be used for that, but the tag plugin
183       also lists a page's tags at the bottom of the page.
184     - Allows preprocessor directives to have parameters with no specified
185       value.
186     - Fixes preprocessor directive parameter parsing so that
187       foo=bar baz now means "foo=bar" and a "baz" with no value.
188   * Run pagetemplate hooks when inlining pages so that inlined pages also
189     list their tags.
190   * Make all plugins with pagetemplate hooks check that variables exist
191     on the template before setting them, for robustness.
192   * Switch pagetemplate hooks to using named parameters.
193   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
194     This will be the page that a source page will be part of, which is
195     different than the source page for inlined pages.
196   * Audited all plugins to endure they pass (page, destpage) to htmllink
197     appropriatly. This means inlining of various plugins will not work
198     properly, with correct links generated.
199
200  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
201
202 ikiwiki (1.10) unstable; urgency=low
203
204   * Run page through any relevant filters when generating a page preview.
205   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
206     default throughout the wiki, not only on wikitext pages. Decided to call
207     this a feature, and split the camelcase support out into a separate plugin
208     that is independant of wikitext.
209   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
210
211  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
212
213 ikiwiki (1.9) unstable; urgency=low
214
215   * Improve display of parentlinks and page title of toplevel index page.
216   * Patch from Faidon to use svn --limit when possible for recentchanges,
217     speeds up recentchanges a lot for wikis with more history.
218   * Patch from Recai to fix utf8 issues in git backend.
219   * Add wikitext markup plugin, which supports ".wiki" pages written in the
220     original wiki syntax, CamelCase links and all.
221   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
222     support, to edit pages etc without a web server.
223   * Display CGI processing errors if present.
224   * Fix from Faidon for a XML parser issue that breaks utf-8 for
225     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
226     area, and also way slow.
227   * Match 'web commit from' in SVN and git, these are web commits too.
228     (Faidon)
229   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
230     readable and avoid future mistakes. The patch seems to work and for the
231     first time I have a UTF-8 username ;-) (Faidon)
232   * Use form->field consistently, not form->param.
233   * Patch from Recai to allow selection of page type when creating a new page.
234     Default page type is inherited from the link clicked on to create the new
235     page.
236
237  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
238
239 ikiwiki (1.8) unstable; urgency=low
240
241   * Fix orphans plugin to not count a link to a nonexistant page as a reason
242     for a page not being an orphan.
243   * Support pinging services such as Technorati using XML-RPC to notify them
244     about changes to rss feeds.
245   * Parse svn log as xml for improved utf8 and security. Note that this makes
246     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
247   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
248     flagged string even if the locale causes it to generate utf8 output,
249     so make sure to let perl know it should be handled as utf8. Also,
250     the optimised version used for standard time formats won't work if the
251     user has changed locale, so drop it. Thanks, Faidon Liambotis.
252   * Fix re-encoding of the comments field to utf8 if a commit fails
253     due to a conflict. Thanks, Faidon Liambotis.
254   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
255     Liambotis.
256   * Add insane double encode/decode to utf8 around call to markdown.
257     This works around a truely strange bug, which is apparently a bug in
258     perl, #376329. Also added a test case for it.
259   * Improve layout of edit page so formatting help link is always visible w/o
260     getting in the way of the preview.
261   * Centralised all calls to HTML::Template and force all the templates
262     to be read as utf8.
263   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
264   * Introduce add_plugins and disable_plugins config options in setup files.
265     This allows adding or removing plugins w/o overriding the whole list of
266     default plugins, which makes it easier to upgrade when new default plugins
267     are added.
268   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
269     default (of course!). Based on a patch by Faidon Liambotis.
270   * Add a html plugin, which can be used to write wikis in raw html,
271     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
272     defaults to not processing .html files, since w/o this plugin they would
273     be copied unsanitised. With this plugin, it will process and html
274     sanitise them, like any other page type.
275   * Rebuilding wrappers is necessary on upgrade to this version.
276   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
277     will be automatically done on all upgrades.
278   * Don't send pings if the wiki is being rebuilt.
279   * Work around very innefficient behavior in File::Spec::abs2rel. Result
280     is a savings of 2 pointless fork/execs per link calculation, which
281     results in ~25% speedup of ikiwiki building its own doc wiki, and
282     about 35% speedup displaying RecentChanges!
283   * Make RecentChanges use a table and some CSS, should be much more readable.
284     No code changes involved.
285   * Encode & in diffurl in examples, to conform to pedantic rules.
286   * Speed up RecentChanges by another 40% or so with some memoization.
287   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
288     in time to build the doc wiki.
289
290  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
291
292 ikiwiki (1.7) unstable; urgency=low
293
294   * Updated logo from Recai with some kerning and alingment tuning.
295   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
296     changed some output.
297   * Copyright update.
298
299  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
300
301 ikiwiki (1.6) unstable; urgency=low
302
303   * YA utf-8 patch from Recai, this time to fix previewing a page so that
304     the text in the input box is re-encoded back to utf-8.
305   * -CSD does not affect modules, so readfile() was not using the utf-8 input
306     layer, which led to lots of problems; make it force read files as utf-8.
307     Closes: #373203
308   * Note that as a consequence, this version of ikiwiki will actually try to
309     parse utf8 in source files for the first time, which may expose broken
310     utf8 in wiki sources that was hidden before. Most common will be
311     perl warnings like "utf8 "\xE9" does not map to Unicode"
312   * writefile() likewise needs to use the utf8 output layer.
313   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
314     there.
315   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
316     given the readfile fix.
317   * Add utf-8 testcases for readfile and htmlize.
318   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
319     safe.
320   * More utf-8 fixes from Recai, partly to things I broke above:
321     - The serious problem is that writefile() saves the content in undecoded
322       format in CGI, hence all (non-ascii) chars are corrupted permanently.
323     - Comment field in edit page is not decoded and all the non-ascii chars in
324       this field are corrupted as the result.  We should decode it as we do it
325       for the content.
326     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
327       character in print.
328   * New SVG logo from Recai.
329
330  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
331
332 ikiwiki (1.5) unstable; urgency=low
333
334   * Add --timeformat config option to allow changing how dates are displayed.
335     Note that as a side effect, dates will now be displayed using the local
336     timezone, not as GMT.
337   * More security review.
338   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
339     for some handy stuff like:
340     - Using links as a kind of tag; creating blog pages that list all pages
341       containing a given tag/link or not containing some other tag.
342     - Subscribing to mail notifications whenever a change is made to a page
343       that is a backlink of page foo. Ie, "Please notify me of changes in all
344       pages that link to my home page in the wiki"
345     - Locking any pages that are linked to from a particular page, so that
346       lists of locks can be exposed in the wiki.
347   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
348     when a todo item is done, instead of the previous moving it to a different
349     subdir.
350   * Allow pagetemplate plugins to override *anything* in the template.
351   * Add a meta plugin, which allows specifying various metadata about pages,
352     like license and author. It also allows for inserting html link and meta
353     tags into html, overriding the title, and adding hidden WikiLinks, which
354     can be useful when using link-based globbing for page categorisation.
355   * Remove preprocessor directives from inlined pages.
356   * Allow simple preprocessor directive values to be specified w/o quotes.
357   * Add support for using git instead of subversion as the RCS backend,
358     tremendous thanks to Recai Oktaş for this.
359   * Doc updates for git.
360   * Fix absolute url munging in rss generation to support https, ftp, etc urls
361     not just http urls.
362   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
363     utf-8 for edit and other fields, and for recentchanges. There may still
364     be utf-8 issues with the preferences page though.
365
366  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
367
368 ikiwiki (1.4) unstable; urgency=low
369
370   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
371     very strange way of enabling proper XHTML <br /> type tags. Output html
372     should be always valid again now.
373   * The page name and parent links has switched from using a <h1> to a styled
374     <span>, so pages can use <h1> internally instead of needing to use <h2>.
375   * Updated all of ikiwiki's own wiki pages for that.
376   * Add pagetemplate hook, which can be used by plugins that want to mess
377     around with adding new stuff to the page template.
378   * Remove headercontent; the search plugin now adds the search box to the
379     header by registering a pagetemplate hook, and other plugins should do
380     similarly.
381   * Rebuilding on upgrade to this version is recommended.
382   * Add a html validity check to the test suite, using the wdg-html-validator,
383     if available.
384   * Make the html valid when there is nothing in the actions list.
385   * Reordered some function call parameters for consistency.
386   * Enable full utf-8 support for page input and output.
387   * Add a workaround for markdown, which does not work well with utf-8
388     strings.
389   * --getctime had bitrotted (well I only ever used it the once so far..),
390     fix and make it a bit more flexible
391   * rcs_getctime is changed, now rather than needing to loop over all pages,
392     it should just use the rcs to get the ctime of the passed file.
393   * When inlining a page in another one, links from the inlined page are now
394     expanded the same as they are when rendering the inlined page as a
395     standalone page. So rather than being expanded from the POV of the
396     inlining page, they are expanded from the POV of the inlined page.
397
398     For example, a link from blog/foo to "bar" will now link to blog/bar
399     if it exists. Previously this needed to be a link explicitly to
400     "blog/bar"; such links will also continue to work.
401
402     (This was slightly complex to do as the link still has to be constructed
403     relative to the inlining page.)
404   * Make page edit textarea resize to fit browser window.
405   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
406     do not need a full rebuild, in order to update any basewiki pages.
407
408  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
409
410 ikiwiki (1.3) unstable; urgency=low
411
412   * Fix the preinst introduced in the last version. Closes: #367458
413
414  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
415
416 ikiwiki (1.2) unstable; urgency=low
417
418   * Remove dups from the brokenlinks list.
419   * Add libc6-dev to dependencies, needed to build wrappers.
420   * Install wikilist in correct location. Closes: #367371
421
422  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
423
424 ikiwiki (1.1) unstable; urgency=low
425
426   * Rename inlinepage to depends, so that it can be used to refer to more
427     dependency relationships than just inlining. This will require a rebuild
428     on upgrade to this version.
429   * Move the rss link, put it in the blogpost form if there is one and at the
430     top if not. This is both nicer because easier to find, and it cleans up
431     the code which had used inlinepage as a flag for adding the link later.
432   * Allow the depends GlobList to be built up from multiple sources (such as
433     plugins) during a page render.
434   * Which means that more than one blog is now supported to appear on a
435     single page. (With some limitations, like only the last one getting an
436     rss file.)
437   * Added a plugin system.
438   * Added a pagecount plugin, enabled by default.
439   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
440   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
441     backlinks when the backlinks hadn't really changed.
442   * Moved inline page support, rss generation etc into the inline plugin,
443     enabled by default.
444   * Added brokenlinks plugin, not enabled by default, but rather handy.
445   * Fix several broken links in the doc wiki.
446   * Smarter behavior when creating a page and a page of the same name (but
447     different location) already exists.
448   * Add an orphans plugin for finding pages that nothing links to.
449   * Removed backlinks page, which it turns out nothing used.
450   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
451     it, this will allow for adding a unit test suite.
452   * Add unit tests for several core functions, including globlist_match,
453     dirname, basename, bestlink, linkify, pagetitle, titlepage.
454   * Smart globlist merging.
455   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
456     to pave the way for adding other RCS support. This also changes the
457     setup files, where before they had svn => 1 or svn => 0, now they have
458     rcs => "svn" or rcs => "".
459   * Add a debian/NEWS file with upgrade notes.
460   * Load whatever rcs module is specified, so new ones can be just dropped in
461     as plugins and work. (Well, in theory.)
462   * Add some basic docs about writing RCS modules.
463   * Broke search capability out into a plugin, removed the --hyperestraier
464     switch.
465   * Added smiley plugin, nicely controlled and documented by the smileys page.
466   * Copied in some smileys from Moin Moin.
467   * Allow links of the form [[some page|page]], with whitespace in the link
468     text.
469   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
470     and --disable-plugin htmlscrubber.
471   * Allow discussion links on pages to be turned off with --no-discussion.
472   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
473   * Add some new config items to the estseek.conf template, which are needed
474     by hyperestraier 1.2.3.
475
476  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
477
478 ikiwiki (1.0) unstable; urgency=low
479
480   * First official release.
481
482  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400