* inline: Add ability to sort by page name, based on a patch from
[ikiwiki] / debian / changelog
1 ikiwiki (1.28) UNRELEASED; urgency=low
2
3   * inline: Add ability to sort by page name, based on a patch from
4     Benjamin A'Lee.
5
6  -- Joey Hess <joeyh@debian.org>  Mon, 25 Sep 2006 17:06:39 -0400
7
8 ikiwiki (1.27) unstable; urgency=low
9
10   * Work on firming up the plugin interface:
11     - Plugins should not need to load IkiWiki::Render to get commonly
12       used functions, so moved some functions from there to IkiWiki.
13     - Picked out the set of functions and variables that most plugins
14       use, documented them, and made IkiWiki export them by default,
15       like a proper perl module should.
16     - Use the other functions at your own risk.
17     - This is not quite complete, I still have to decide whether to
18       export some other things.
19   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
20     referring to stuff now exported by the IkiWiki module.
21   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
22     to declare which version of the interface your plugin needs.
23   * Anyone with a third-party ikiwiki plugin is strongly encouraged
24     to make like changes to it and avoid use of non-exported symbols from
25     "IkiWiki::".
26   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
27   * Support hyperestradier version 1.4.2, which adds a new required phraseform
28     setting.
29   * If an inlined page has a permalink, link the page title to that.
30   * Patch from Recai to use utf8 when reading the setup file, so that
31     utf8 wikinames from there will be used properly.
32   * Patch from Recai to kill utf-8 on the wiki name when generating the
33     session cookie.
34   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
35   * Fix a baseurl problem in hyperestradier search results.
36   * Add a stub local.css to avoid problems with 404's.
37   * Patch from Recai to fix a wide character warning from the search plugin
38     during setup if the wikiname contains utf8.
39   * Yet another fix for those poor case-insensative OS X users.
40   * pagetemplate hooks are now also called when generating cgi pages.
41   * Add a favicon plugin, which simply adds a link tag for an icon to each
42     page (and cgis).
43   * Patch from James Westby to deal with the case where you're editing a
44     new page, hit cancel, and need to be redirected to somewhere sane.
45   * Various documentation improvements by various wiki users.
46   * Support Text::Markdown from CPAN, which has a different interface from
47     the original markdown or the one in Debian.
48   * Version the libcgi-session-perl dependency, some features that need
49     the new version are used in some cases (sslcookie).
50   * Numerous tla fixes from Clint.
51   * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
52     a multi-resolution favicon.ico.
53   * README.Debian: typo Closes: #388110
54   * chomp trailing newline at the end of templates read in by the template
55     plugin, to allow use of the template preprocessor directive in
56     whitespace-sensative situations. Closes: #387073
57   * Patch from James Westby to make the location of the estseek.cgi script
58     configurable.
59   * Add typography (SmartyPants) plugin by Recai.
60   * Add --render mode, which can be used to preview an edit at the command
61     line by test rendering a single page.
62   * Add a googlecalendar plugin. A bit special-purpose, but it shows
63     one way to to deal with user-supplied content that could cause XSS
64     issues w/o the htmlscrubber, and won't survive the scrubber.
65
66  -- Joey Hess <joeyh@debian.org>  Sun, 24 Sep 2006 00:02:21 -0400
67
68 ikiwiki (1.26) unstable; urgency=low
69
70   * Add a missing -n to tla undo call.
71   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
72     writes before consuming its whole stdin. Avoid this deadlock.
73   * Fix alt tags for outline checkboxes.
74
75  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
76
77 ikiwiki (1.25) unstable; urgency=low
78
79   * Add proper waitpid calls for open2ed processes throughout to avoid
80     zombies; this hit htmltidy especially badly.
81   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
82     subversion repos and fixing some other issues.
83   * Add support for tla, contributed by Clint Adams. Closes: #385936
84   * Add support for mercurial, contributed by Emanuele Aina.
85   * Include <link rel> tag for RSS feeds, used by some aggregators and
86     firefox to find the feed.
87   * Add a linkmap plugin (requires graphviz).
88
89  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
90
91 ikiwiki (1.24) unstable; urgency=low
92
93   * Simplify the data structure returned by rcs_recentchanges to avoid
94     each rcs plugin needing to form complex strings on its own.
95   * Fix another destpage issue in the inline directive. Closes: #385512
96     again.
97
98  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
99
100 ikiwiki (1.23) unstable; urgency=low
101
102   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
103
104  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
105
106 ikiwiki (1.22) unstable; urgency=low
107
108   * Change how the stylesheet url is determined in the templates: Remove
109     STYLEURL and add BASEURL to all templates (some already had it). This
110     new more general variable can be used to link to other things (eg, images)
111     from the template, as well as stylesheets.
112   * Fix a bug introduced last version to do with nested inlines.
113   * Allow preprocessor directives to span multiple lines, both to make
114     long ones with lots of values easier to write, and to allow for ones with
115     multi-line quoted values.
116   * Allow preprocessor directives to contain python-like triple-quoted
117     text blocks, for easy nesting of quotes inside.
118   * Add a template plugin.
119   * Make pagespec merge code smarter about merging duplicate pagespecs.
120   * Patch from Jordà Polo to make Setup::Standard support hashes in config
121     files.
122   * Change order of linkify and preprocess; first preprocess and then linkify.
123     This allows passing a wikilink inside a parameter to a preprocessor
124     directive without it being expanded to html, and leaking out of the
125     parameter, which had required some non-obvious use of triple-quoting
126     to avoid. Note that any preprocessor plugins that output something
127     that looks like a wikilink will now have it treated as such; AFAIK
128     this doesn't change any behavior though except for the template plugin.
129   * Enable preprocessor directives when previewing an edit.
130   * Make all pages pull in a local.css style sheet, if present. This won't
131     be included in ikiwiki, but can be created to make local styling changes
132     w/o needing to merge in every new change to the distributed style.css.
133   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
134   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
135     from a different directory.
136   * Generalised preprocesser loop protection code.
137   * Patch from James Westby to allow a description to be set for rss feeds.
138   * Patch from James Westby to add a template for the search form.
139   * Added a ddate plugin.
140   * Patch from James Westby to add a --sslcookie switch, which forces
141     cookies to only be sent over ssl connections to avoid interception.
142   * Fix preferences page on anonok wikis; still need to sign in to get
143     to the preferences page.
144   * Add toc (table of contents) plugin.
145   * Change htmlize, format, and sanitize hooks to use named parameters.
146   * Patch from James Westby to add an actions option to inline; this
147     adds Edit and Discussion links at the end of blog entries.
148   * Due to some css changes, you'll want to rebuild your wiki on upgrade
149     to this version. Will be handled automatically by the deb.
150   * Add processed date to aggregate preprocessor directive status output.
151
152  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
153
154 ikiwiki (1.21) unstable; urgency=low
155
156   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
157   * If a page links to itself, mark up the link text in a span with
158     class="selflink" so that it can be styled. I don't have a useful style
159     defined for that though.
160   * Call filter hooks on inlined page content.
161   * Support inlining pages raw, rather than creating a blog.
162   * Clean up yes/no parameter parsing in inline plugin.
163   * Implemented better cycle detection in the inline plugin; nested inlines
164     will now work.
165   * Add a map plugin contributed by Alessandro Dotti Contra.
166   * Add otl format plugin, which handles files as created by vimoutliner.
167   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
168   * Add first draft at a Restructured Text (rst) plugin, by Sergio
169     Talens-Oliag. Note that this has many known issues -- see the caveats on
170     the plugin's page.
171   * Credit everyone who wrote a plugin on the plugins' wiki pages.
172   * Fix utf-8 in blog post form.
173
174  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
175
176 ikiwiki (1.20) unstable; urgency=low
177
178   * Relicense the templates and basewiki under the 2-clause BSD license.
179     Since these can easily become part of other people's websites, they
180     should be under as permissive a license as possible.
181   * Add --syslog config option, to log to the syslog.
182   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
183     transient failure to fork (which I've seen happen in the wild).
184   * Fix a bug in the aggregator introduced last version that caused all
185     aggregator state to be lost during a non-aggregating build.
186
187  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
188
189 ikiwiki (1.19) unstable; urgency=low
190
191   * Fix several related bugs in page type determination during online editing.
192   * Add some locking to prevent 2 aggregators from running at once.
193   * Fix an infinite loop in the aggregator when finding a unique filename.
194
195  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
196
197 ikiwiki (1.18) unstable; urgency=low
198
199   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
200   * Add --version.
201   * Man page format fixups.
202   * If the meta plugin overides the page title, set a title_overridden
203     variable in the template to true. This allows doing things with the
204     templates conditional on the title being overriden.
205   * Add a %pagecase which maps lower-case page names to the actual case
206     used in the filename. Use this in bestlinks calculation instead of
207     forcing the link to lowercase.
208   * Also use %pagecase in various other places that want to check if a page
209     with a given name exists.
210   * This means that links to pages with mixed case names will now work,
211     even if the link is in some other case mixture, and mixed case pages
212     should be fully supported throughout ikiwiki.
213   * Recommend rebuilding wikis on upgrade to this version.
214
215  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
216
217 ikiwiki (1.17) unstable; urgency=low
218
219   * Disable tidy generator tag.
220   * Move tidy back to sanitize hook, found out how to only show body.
221   * Turn off tidy indentation too.
222   * Turn on HTML::Template loop_context_vars; not actually used in stock
223     templates but can be useful for things like making comma-delimited lists
224     of tags or what have you.
225   * Remove <br> from end of aggregate preprocessor directive output.
226   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
227     case-sensative filesystems like OSX.
228   * Improve markdown loading. First, try to load it as a proper perl module,
229     in case it was installed as one. Then fall back to trying
230     /usr/bin/markdown.
231   * Document in install page how to install markdown, since it has no
232     installation procedure in the upstream tarball.
233   * Set die_on_bad_params => 0 for all templates, to allow users to modify
234     them without annoyances.
235   * Suck in the page content when generating an inline archive page, to work
236     around the meta plugin's lack of caching of title metadata across runs.
237
238  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
239
240 ikiwiki (1.16) unstable; urgency=low
241
242   * Try to handle relative links in aggregated feeds. However,
243     the current support is a crude hack due to limitations of XML::Feed:
244     xml:base is not supported, neither is Content-Location. And of course,
245     relative links in RSS feeds are ill-undefined..
246   * Make aggregator save permalinks and author name to pages as metadata.
247   * Add permalink and author support to meta plugin, affecting RSS feeds
248     and blog pages.
249   * Various CSS and formatting changes.
250   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
251   * Add xhtml files to the default prune regexp.
252   * Also generate rel=bookmark links for permalinks.
253   * Fix the htmltidy plugin, which wasn't working due my breaking it when
254     I added it..
255   * Don't run tidy with -xml as that fails if the input is not well-formed.
256     Run it with -asxhtml instead, so it will output well-formed xhtml no
257     matter what the input.
258   * Disable tidy warnings too.
259   * Add a new format hook, and make tidy use it, since tidy can really only
260     operate on and output complete html documents, not the body chunks
261     that sanitise gets.
262   * Fix dates in rss feeds if running localised, so they're still rfc 822.
263
264  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
265
266 ikiwiki (1.15) unstable; urgency=low
267
268   * Remove CDPATH and other env vars perl taint checking doesn't like.
269     Closes: #381279
270   * Added created_before and created_after PageSpec limits.
271
272  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
273
274 ikiwiki (1.14) unstable; urgency=low
275
276   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
277     by 10% or so.
278   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
279   * Added many unit tests for pagespec_match.
280
281  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
282
283 ikiwiki (1.13) unstable; urgency=low
284
285   * ikiwiki can now download and aggregate feeds with its new aggregate
286     plugin, so it's possible to implement a Planet using ikiwiki!
287   * Add a run_hooks function for the common task of running all hooks of a
288     given type.
289   * Add a savestate hook.
290   * Don't put blog post forms on pages if there's no cgiurl set.
291   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
292     --wrappers to do that.
293   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
294     to update pages that haven't changed on disk.
295   * Change meta tags to use html entity-escaped text for values, so that
296     quotes and such can be represented in title tags.
297   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
298     for the above.
299   * Make --rebuild also cause --aggregate to re-download and write aggregated
300     pages.
301   * Avoid outputting duplicate meta info.
302   * Include title metadata on aggregated posts for capitalised and un-munged
303     titles.
304   * Title metadata of inlined pages now shows up in blogs and rss feeds.
305   * Fix issue with unicode filenames and updating the hyper estradier search
306     index. (Aka Please Please Please, let that be the last one.)
307   * Patch from Roland Mas to support an rss=no parameter to inline directives.
308     Closes: #380743
309   * Renamed GlobLists to PageSpecs.
310   * PageSpecs can now include nested parens, "and", and "or". This remains
311     backwards compatible to the old GlobList format. It's implemented by
312     treating the GlobList as a very limited microlanguage that is transformed
313     to perl code that does the matching.
314   * The old GlobList format is deprecated, and I encourage users to switch to
315     using the new PageSpec format. Compatability with the old format will be
316     removed at some point, possibly by 2.0.
317   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
318   * Add support for creation_month and creation_year to PageSpec.
319     Closes: #380680
320   * Changes to index file encoding.
321
322  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
323
324 ikiwiki (1.12) unstable; urgency=low
325
326   "Viva l'Italia!"
327   * New pagestats plugin from Enrico, which can generate a table counting
328     the backlinks for each page, or a del.icio.us style cloud.
329   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
330     the wikiformat plugin works. Thanks, Emanuele Aina.
331   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
332     display, running them through pagetitle. This removes ugly underscores and
333     other gunk from the display, much nicer. You may want to rebuild your wiki
334     when upgrading to get the cleanup globally.
335   * Polygen plugin from Enrico.
336   * htmltidy plugin from Faidon.
337   * Locale patch from Faidon:
338     - Adds a locale setting to setup files.
339     - Proper local time, if the locale configuration option is used.
340     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
341       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
342       impossible.
343   * Add getopt hook type, this allows plugins to add new command-line options.
344   * Add --tagbase option to tag plugin.
345   * Add exclude option in setup files, works same as --exclude.
346   * Put categories in rss feeds for tagged items.
347   * Allow preprocessor directives to be expanded in inlined blog pages.
348     However, to avoid inlining loops etc, don't expand inline directives in
349     inlined pages.
350   * fortune plugin (trivial)
351   * Tag plugins according to type.
352
353  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
354
355 ikiwiki (1.11) unstable; urgency=low
356
357   * Patch from Enrico that
358     - Adds a tag plugin that allows more easily tagging pages.
359       The meta plugin can also still be used for that, but the tag plugin
360       also lists a page's tags at the bottom of the page.
361     - Allows preprocessor directives to have parameters with no specified
362       value.
363     - Fixes preprocessor directive parameter parsing so that
364       foo=bar baz now means "foo=bar" and a "baz" with no value.
365   * Run pagetemplate hooks when inlining pages so that inlined pages also
366     list their tags.
367   * Make all plugins with pagetemplate hooks check that variables exist
368     on the template before setting them, for robustness.
369   * Switch pagetemplate hooks to using named parameters.
370   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
371     This will be the page that a source page will be part of, which is
372     different than the source page for inlined pages.
373   * Audited all plugins to endure they pass (page, destpage) to htmllink
374     appropriatly. This means inlining of various plugins will not work
375     properly, with correct links generated.
376
377  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
378
379 ikiwiki (1.10) unstable; urgency=low
380
381   * Run page through any relevant filters when generating a page preview.
382   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
383     default throughout the wiki, not only on wikitext pages. Decided to call
384     this a feature, and split the camelcase support out into a separate plugin
385     that is independant of wikitext.
386   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
387
388  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
389
390 ikiwiki (1.9) unstable; urgency=low
391
392   * Improve display of parentlinks and page title of toplevel index page.
393   * Patch from Faidon to use svn --limit when possible for recentchanges,
394     speeds up recentchanges a lot for wikis with more history.
395   * Patch from Recai to fix utf8 issues in git backend.
396   * Add wikitext markup plugin, which supports ".wiki" pages written in the
397     original wiki syntax, CamelCase links and all.
398   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
399     support, to edit pages etc without a web server.
400   * Display CGI processing errors if present.
401   * Fix from Faidon for a XML parser issue that breaks utf-8 for
402     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
403     area, and also way slow.
404   * Match 'web commit from' in SVN and git, these are web commits too.
405     (Faidon)
406   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
407     readable and avoid future mistakes. The patch seems to work and for the
408     first time I have a UTF-8 username ;-) (Faidon)
409   * Use form->field consistently, not form->param.
410   * Patch from Recai to allow selection of page type when creating a new page.
411     Default page type is inherited from the link clicked on to create the new
412     page.
413
414  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
415
416 ikiwiki (1.8) unstable; urgency=low
417
418   * Fix orphans plugin to not count a link to a nonexistant page as a reason
419     for a page not being an orphan.
420   * Support pinging services such as Technorati using XML-RPC to notify them
421     about changes to rss feeds.
422   * Parse svn log as xml for improved utf8 and security. Note that this makes
423     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
424   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
425     flagged string even if the locale causes it to generate utf8 output,
426     so make sure to let perl know it should be handled as utf8. Also,
427     the optimised version used for standard time formats won't work if the
428     user has changed locale, so drop it. Thanks, Faidon Liambotis.
429   * Fix re-encoding of the comments field to utf8 if a commit fails
430     due to a conflict. Thanks, Faidon Liambotis.
431   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
432     Liambotis.
433   * Add insane double encode/decode to utf8 around call to markdown.
434     This works around a truely strange bug, which is apparently a bug in
435     perl, #376329. Also added a test case for it.
436   * Improve layout of edit page so formatting help link is always visible w/o
437     getting in the way of the preview.
438   * Centralised all calls to HTML::Template and force all the templates
439     to be read as utf8.
440   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
441   * Introduce add_plugins and disable_plugins config options in setup files.
442     This allows adding or removing plugins w/o overriding the whole list of
443     default plugins, which makes it easier to upgrade when new default plugins
444     are added.
445   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
446     default (of course!). Based on a patch by Faidon Liambotis.
447   * Add a html plugin, which can be used to write wikis in raw html,
448     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
449     defaults to not processing .html files, since w/o this plugin they would
450     be copied unsanitised. With this plugin, it will process and html
451     sanitise them, like any other page type.
452   * Rebuilding wrappers is necessary on upgrade to this version.
453   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
454     will be automatically done on all upgrades.
455   * Don't send pings if the wiki is being rebuilt.
456   * Work around very innefficient behavior in File::Spec::abs2rel. Result
457     is a savings of 2 pointless fork/execs per link calculation, which
458     results in ~25% speedup of ikiwiki building its own doc wiki, and
459     about 35% speedup displaying RecentChanges!
460   * Make RecentChanges use a table and some CSS, should be much more readable.
461     No code changes involved.
462   * Encode & in diffurl in examples, to conform to pedantic rules.
463   * Speed up RecentChanges by another 40% or so with some memoization.
464   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
465     in time to build the doc wiki.
466
467  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
468
469 ikiwiki (1.7) unstable; urgency=low
470
471   * Updated logo from Recai with some kerning and alingment tuning.
472   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
473     changed some output.
474   * Copyright update.
475
476  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
477
478 ikiwiki (1.6) unstable; urgency=low
479
480   * YA utf-8 patch from Recai, this time to fix previewing a page so that
481     the text in the input box is re-encoded back to utf-8.
482   * -CSD does not affect modules, so readfile() was not using the utf-8 input
483     layer, which led to lots of problems; make it force read files as utf-8.
484     Closes: #373203
485   * Note that as a consequence, this version of ikiwiki will actually try to
486     parse utf8 in source files for the first time, which may expose broken
487     utf8 in wiki sources that was hidden before. Most common will be
488     perl warnings like "utf8 "\xE9" does not map to Unicode"
489   * writefile() likewise needs to use the utf8 output layer.
490   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
491     there.
492   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
493     given the readfile fix.
494   * Add utf-8 testcases for readfile and htmlize.
495   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
496     safe.
497   * More utf-8 fixes from Recai, partly to things I broke above:
498     - The serious problem is that writefile() saves the content in undecoded
499       format in CGI, hence all (non-ascii) chars are corrupted permanently.
500     - Comment field in edit page is not decoded and all the non-ascii chars in
501       this field are corrupted as the result.  We should decode it as we do it
502       for the content.
503     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
504       character in print.
505   * New SVG logo from Recai.
506
507  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
508
509 ikiwiki (1.5) unstable; urgency=low
510
511   * Add --timeformat config option to allow changing how dates are displayed.
512     Note that as a side effect, dates will now be displayed using the local
513     timezone, not as GMT.
514   * More security review.
515   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
516     for some handy stuff like:
517     - Using links as a kind of tag; creating blog pages that list all pages
518       containing a given tag/link or not containing some other tag.
519     - Subscribing to mail notifications whenever a change is made to a page
520       that is a backlink of page foo. Ie, "Please notify me of changes in all
521       pages that link to my home page in the wiki"
522     - Locking any pages that are linked to from a particular page, so that
523       lists of locks can be exposed in the wiki.
524   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
525     when a todo item is done, instead of the previous moving it to a different
526     subdir.
527   * Allow pagetemplate plugins to override *anything* in the template.
528   * Add a meta plugin, which allows specifying various metadata about pages,
529     like license and author. It also allows for inserting html link and meta
530     tags into html, overriding the title, and adding hidden WikiLinks, which
531     can be useful when using link-based globbing for page categorisation.
532   * Remove preprocessor directives from inlined pages.
533   * Allow simple preprocessor directive values to be specified w/o quotes.
534   * Add support for using git instead of subversion as the RCS backend,
535     tremendous thanks to Recai Oktaş for this.
536   * Doc updates for git.
537   * Fix absolute url munging in rss generation to support https, ftp, etc urls
538     not just http urls.
539   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
540     utf-8 for edit and other fields, and for recentchanges. There may still
541     be utf-8 issues with the preferences page though.
542
543  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
544
545 ikiwiki (1.4) unstable; urgency=low
546
547   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
548     very strange way of enabling proper XHTML <br /> type tags. Output html
549     should be always valid again now.
550   * The page name and parent links has switched from using a <h1> to a styled
551     <span>, so pages can use <h1> internally instead of needing to use <h2>.
552   * Updated all of ikiwiki's own wiki pages for that.
553   * Add pagetemplate hook, which can be used by plugins that want to mess
554     around with adding new stuff to the page template.
555   * Remove headercontent; the search plugin now adds the search box to the
556     header by registering a pagetemplate hook, and other plugins should do
557     similarly.
558   * Rebuilding on upgrade to this version is recommended.
559   * Add a html validity check to the test suite, using the wdg-html-validator,
560     if available.
561   * Make the html valid when there is nothing in the actions list.
562   * Reordered some function call parameters for consistency.
563   * Enable full utf-8 support for page input and output.
564   * Add a workaround for markdown, which does not work well with utf-8
565     strings.
566   * --getctime had bitrotted (well I only ever used it the once so far..),
567     fix and make it a bit more flexible
568   * rcs_getctime is changed, now rather than needing to loop over all pages,
569     it should just use the rcs to get the ctime of the passed file.
570   * When inlining a page in another one, links from the inlined page are now
571     expanded the same as they are when rendering the inlined page as a
572     standalone page. So rather than being expanded from the POV of the
573     inlining page, they are expanded from the POV of the inlined page.
574
575     For example, a link from blog/foo to "bar" will now link to blog/bar
576     if it exists. Previously this needed to be a link explicitly to
577     "blog/bar"; such links will also continue to work.
578
579     (This was slightly complex to do as the link still has to be constructed
580     relative to the inlining page.)
581   * Make page edit textarea resize to fit browser window.
582   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
583     do not need a full rebuild, in order to update any basewiki pages.
584
585  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
586
587 ikiwiki (1.3) unstable; urgency=low
588
589   * Fix the preinst introduced in the last version. Closes: #367458
590
591  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
592
593 ikiwiki (1.2) unstable; urgency=low
594
595   * Remove dups from the brokenlinks list.
596   * Add libc6-dev to dependencies, needed to build wrappers.
597   * Install wikilist in correct location. Closes: #367371
598
599  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
600
601 ikiwiki (1.1) unstable; urgency=low
602
603   * Rename inlinepage to depends, so that it can be used to refer to more
604     dependency relationships than just inlining. This will require a rebuild
605     on upgrade to this version.
606   * Move the rss link, put it in the blogpost form if there is one and at the
607     top if not. This is both nicer because easier to find, and it cleans up
608     the code which had used inlinepage as a flag for adding the link later.
609   * Allow the depends GlobList to be built up from multiple sources (such as
610     plugins) during a page render.
611   * Which means that more than one blog is now supported to appear on a
612     single page. (With some limitations, like only the last one getting an
613     rss file.)
614   * Added a plugin system.
615   * Added a pagecount plugin, enabled by default.
616   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
617   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
618     backlinks when the backlinks hadn't really changed.
619   * Moved inline page support, rss generation etc into the inline plugin,
620     enabled by default.
621   * Added brokenlinks plugin, not enabled by default, but rather handy.
622   * Fix several broken links in the doc wiki.
623   * Smarter behavior when creating a page and a page of the same name (but
624     different location) already exists.
625   * Add an orphans plugin for finding pages that nothing links to.
626   * Removed backlinks page, which it turns out nothing used.
627   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
628     it, this will allow for adding a unit test suite.
629   * Add unit tests for several core functions, including globlist_match,
630     dirname, basename, bestlink, linkify, pagetitle, titlepage.
631   * Smart globlist merging.
632   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
633     to pave the way for adding other RCS support. This also changes the
634     setup files, where before they had svn => 1 or svn => 0, now they have
635     rcs => "svn" or rcs => "".
636   * Add a debian/NEWS file with upgrade notes.
637   * Load whatever rcs module is specified, so new ones can be just dropped in
638     as plugins and work. (Well, in theory.)
639   * Add some basic docs about writing RCS modules.
640   * Broke search capability out into a plugin, removed the --hyperestraier
641     switch.
642   * Added smiley plugin, nicely controlled and documented by the smileys page.
643   * Copied in some smileys from Moin Moin.
644   * Allow links of the form [[some page|page]], with whitespace in the link
645     text.
646   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
647     and --disable-plugin htmlscrubber.
648   * Allow discussion links on pages to be turned off with --no-discussion.
649   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
650   * Add some new config items to the estseek.conf template, which are needed
651     by hyperestraier 1.2.3.
652
653  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
654
655 ikiwiki (1.0) unstable; urgency=low
656
657   * First official release.
658
659  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400