* Patch from James Westby to add a --sslcookie switch, which forces
[ikiwiki] / debian / changelog
1 ikiwiki (1.22) UNRELEASED; urgency=low
2
3   * Change how the stylesheet url is determined in the templates: Remove
4     STYLEURL and add BASEURL to all templates (some already had it). This
5     new more general variable can be used to link to other things (eg, images)
6     from the template, as well as stylesheets.
7   * Fix a bug introduced last version to do with nested inlines.
8   * Allow preprocessor directives to span multiple lines, both to make
9     long ones with lots of values easier to write, and to allow for ones with
10     multi-line quoted values.
11   * Allow preprocessor directives to contain python-like triple-quoted
12     text blocks, for easy nesting of quotes inside.
13   * Add a template plugin.
14   * Use the template plugin to add infoboxes to each plugin page listing basic
15     info about the plugin.
16   * Make pagespec merge code smarter about merging duplicate pagespecs.
17   * Patch from Jordà Polo to make Setup::Standard support hashes in config
18     files.
19   * Change order of linkify and preprocess; first preprocess and then linkify.
20     This allows passing a wikilink inside a parameter to a preprocessor
21     directive without it being expanded to html, and leaking out of the
22     parameter, which had required some non-obvious use of triple-quoting
23     to avoid. Note that any preprocessor plugins that output something
24     that looks like a wikilink will now have it treated as such; AFAIK
25     this doesn't change any behavior though except for the template plugin.
26   * Enable preprocessor directives when previewing an edit.
27   * Make all pages pull in a local.css style sheet, if present. This won't
28     be included in ikiwiki, but can be created to make local styling changes
29     w/o needing to merge in every new change to the distributed style.css.
30   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
31   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
32     from a different directory.
33   * Generalised preprocesser loop protection code.
34   * Patch from James Westby to allow a description to be set for rss feeds.
35   * Patch from James Westby to add a template for the search form.
36   * Cache search form for speedup.
37   * Added a ddate plugin.
38   * Patch from James Westby to add a --sslcookie switch, which forces
39     cookies to only be sent over ssl connections to avoid interception.
40   * Factor out the cgi header printing code into a new function.
41   * Fix preferences page on anonok wikis; still need to sign in to get
42     to the preferences page.
43
44  -- Joey Hess <joeyh@debian.org>  Sun, 27 Aug 2006 16:17:21 -0400
45
46 ikiwiki (1.21) unstable; urgency=low
47
48   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
49   * If a page links to itself, mark up the link text in a span with
50     class="selflink" so that it can be styled. I don't have a useful style
51     defined for that though.
52   * Call filter hooks on inlined page content.
53   * Support inlining pages raw, rather than creating a blog.
54   * Clean up yes/no parameter parsing in inline plugin.
55   * Implemented better cycle detection in the inline plugin; nested inlines
56     will now work.
57   * Add a map plugin contributed by Alessandro Dotti Contra.
58   * Add otl format plugin, which handles files as created by vimoutliner.
59   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
60   * Add first draft at a Restructured Text (rst) plugin, by Sergio
61     Talens-Oliag. Note that this has many known issues -- see the caveats on
62     the plugin's page.
63   * Credit everyone who wrote a plugin on the plugins' wiki pages.
64   * Fix utf-8 in blog post form.
65
66  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
67
68 ikiwiki (1.20) unstable; urgency=low
69
70   * Relicense the templates and basewiki under the 2-clause BSD license.
71     Since these can easily become part of other people's websites, they
72     should be under as permissive a license as possible.
73   * Add --syslog config option, to log to the syslog.
74   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
75     transient failure to fork (which I've seen happen in the wild).
76   * Fix a bug in the aggregator introduced last version that caused all
77     aggregator state to be lost during a non-aggregating build.
78
79  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
80
81 ikiwiki (1.19) unstable; urgency=low
82
83   * Fix several related bugs in page type determination during online editing.
84   * Add some locking to prevent 2 aggregators from running at once.
85   * Fix an infinite loop in the aggregator when finding a unique filename.
86
87  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
88
89 ikiwiki (1.18) unstable; urgency=low
90
91   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
92   * Add --version.
93   * Man page format fixups.
94   * If the meta plugin overides the page title, set a title_overridden
95     variable in the template to true. This allows doing things with the
96     templates conditional on the title being overriden.
97   * Add a %pagecase which maps lower-case page names to the actual case
98     used in the filename. Use this in bestlinks calculation instead of
99     forcing the link to lowercase.
100   * Also use %pagecase in various other places that want to check if a page
101     with a given name exists.
102   * This means that links to pages with mixed case names will now work,
103     even if the link is in some other case mixture, and mixed case pages
104     should be fully supported throughout ikiwiki.
105   * Recommend rebuilding wikis on upgrade to this version.
106
107  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
108
109 ikiwiki (1.17) unstable; urgency=low
110
111   * Disable tidy generator tag.
112   * Move tidy back to sanitize hook, found out how to only show body.
113   * Turn off tidy indentation too.
114   * Turn on HTML::Template loop_context_vars; not actually used in stock
115     templates but can be useful for things like making comma-delimited lists
116     of tags or what have you.
117   * Remove <br> from end of aggregate preprocessor directive output.
118   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
119     case-sensative filesystems like OSX.
120   * Improve markdown loading. First, try to load it as a proper perl module,
121     in case it was installed as one. Then fall back to trying
122     /usr/bin/markdown.
123   * Document in install page how to install markdown, since it has no
124     installation procedure in the upstream tarball.
125   * Set die_on_bad_params => 0 for all templates, to allow users to modify
126     them without annoyances.
127   * Suck in the page content when generating an inline archive page, to work
128     around the meta plugin's lack of caching of title metadata across runs.
129
130  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
131
132 ikiwiki (1.16) unstable; urgency=low
133
134   * Try to handle relative links in aggregated feeds. However,
135     the current support is a crude hack due to limitations of XML::Feed:
136     xml:base is not supported, neither is Content-Location. And of course,
137     relative links in RSS feeds are ill-undefined..
138   * Make aggregator save permalinks and author name to pages as metadata.
139   * Add permalink and author support to meta plugin, affecting RSS feeds
140     and blog pages.
141   * Various CSS and formatting changes.
142   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
143   * Add xhtml files to the default prune regexp.
144   * Also generate rel=bookmark links for permalinks.
145   * Fix the htmltidy plugin, which wasn't working due my breaking it when
146     I added it..
147   * Don't run tidy with -xml as that fails if the input is not well-formed.
148     Run it with -asxhtml instead, so it will output well-formed xhtml no
149     matter what the input.
150   * Disable tidy warnings too.
151   * Add a new format hook, and make tidy use it, since tidy can really only
152     operate on and output complete html documents, not the body chunks
153     that sanitise gets.
154   * Fix dates in rss feeds if running localised, so they're still rfc 822.
155
156  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
157
158 ikiwiki (1.15) unstable; urgency=low
159
160   * Remove CDPATH and other env vars perl taint checking doesn't like.
161     Closes: #381279
162   * Added created_before and created_after PageSpec limits.
163
164  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
165
166 ikiwiki (1.14) unstable; urgency=low
167
168   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
169     by 10% or so.
170   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
171   * Added many unit tests for pagespec_match.
172
173  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
174
175 ikiwiki (1.13) unstable; urgency=low
176
177   * ikiwiki can now download and aggregate feeds with its new aggregate
178     plugin, so it's possible to implement a Planet using ikiwiki!
179   * Add a run_hooks function for the common task of running all hooks of a
180     given type.
181   * Add a savestate hook.
182   * Don't put blog post forms on pages if there's no cgiurl set.
183   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
184     --wrappers to do that.
185   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
186     to update pages that haven't changed on disk.
187   * Change meta tags to use html entity-escaped text for values, so that
188     quotes and such can be represented in title tags.
189   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
190     for the above.
191   * Make --rebuild also cause --aggregate to re-download and write aggregated
192     pages.
193   * Avoid outputting duplicate meta info.
194   * Include title metadata on aggregated posts for capitalised and un-munged
195     titles.
196   * Title metadata of inlined pages now shows up in blogs and rss feeds.
197   * Fix issue with unicode filenames and updating the hyper estradier search
198     index. (Aka Please Please Please, let that be the last one.)
199   * Patch from Roland Mas to support an rss=no parameter to inline directives.
200     Closes: #380743
201   * Renamed GlobLists to PageSpecs.
202   * PageSpecs can now include nested parens, "and", and "or". This remains
203     backwards compatible to the old GlobList format. It's implemented by
204     treating the GlobList as a very limited microlanguage that is transformed
205     to perl code that does the matching.
206   * The old GlobList format is deprecated, and I encourage users to switch to
207     using the new PageSpec format. Compatability with the old format will be
208     removed at some point, possibly by 2.0.
209   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
210   * Add support for creation_month and creation_year to PageSpec.
211     Closes: #380680
212   * Changes to index file encoding.
213
214  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
215
216 ikiwiki (1.12) unstable; urgency=low
217
218   "Viva l'Italia!"
219   * New pagestats plugin from Enrico, which can generate a table counting
220     the backlinks for each page, or a del.icio.us style cloud.
221   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
222     the wikiformat plugin works. Thanks, Emanuele Aina.
223   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
224     display, running them through pagetitle. This removes ugly underscores and
225     other gunk from the display, much nicer. You may want to rebuild your wiki
226     when upgrading to get the cleanup globally.
227   * Polygen plugin from Enrico.
228   * htmltidy plugin from Faidon.
229   * Locale patch from Faidon:
230     - Adds a locale setting to setup files.
231     - Proper local time, if the locale configuration option is used.
232     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
233       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
234       impossible.
235   * Add getopt hook type, this allows plugins to add new command-line options.
236   * Add --tagbase option to tag plugin.
237   * Add exclude option in setup files, works same as --exclude.
238   * Put categories in rss feeds for tagged items.
239   * Allow preprocessor directives to be expanded in inlined blog pages.
240     However, to avoid inlining loops etc, don't expand inline directives in
241     inlined pages.
242   * fortune plugin (trivial)
243   * Tag plugins according to type.
244
245  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
246
247 ikiwiki (1.11) unstable; urgency=low
248
249   * Patch from Enrico that
250     - Adds a tag plugin that allows more easily tagging pages.
251       The meta plugin can also still be used for that, but the tag plugin
252       also lists a page's tags at the bottom of the page.
253     - Allows preprocessor directives to have parameters with no specified
254       value.
255     - Fixes preprocessor directive parameter parsing so that
256       foo=bar baz now means "foo=bar" and a "baz" with no value.
257   * Run pagetemplate hooks when inlining pages so that inlined pages also
258     list their tags.
259   * Make all plugins with pagetemplate hooks check that variables exist
260     on the template before setting them, for robustness.
261   * Switch pagetemplate hooks to using named parameters.
262   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
263     This will be the page that a source page will be part of, which is
264     different than the source page for inlined pages.
265   * Audited all plugins to endure they pass (page, destpage) to htmllink
266     appropriatly. This means inlining of various plugins will not work
267     properly, with correct links generated.
268
269  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
270
271 ikiwiki (1.10) unstable; urgency=low
272
273   * Run page through any relevant filters when generating a page preview.
274   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
275     default throughout the wiki, not only on wikitext pages. Decided to call
276     this a feature, and split the camelcase support out into a separate plugin
277     that is independant of wikitext.
278   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
279
280  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
281
282 ikiwiki (1.9) unstable; urgency=low
283
284   * Improve display of parentlinks and page title of toplevel index page.
285   * Patch from Faidon to use svn --limit when possible for recentchanges,
286     speeds up recentchanges a lot for wikis with more history.
287   * Patch from Recai to fix utf8 issues in git backend.
288   * Add wikitext markup plugin, which supports ".wiki" pages written in the
289     original wiki syntax, CamelCase links and all.
290   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
291     support, to edit pages etc without a web server.
292   * Display CGI processing errors if present.
293   * Fix from Faidon for a XML parser issue that breaks utf-8 for
294     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
295     area, and also way slow.
296   * Match 'web commit from' in SVN and git, these are web commits too.
297     (Faidon)
298   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
299     readable and avoid future mistakes. The patch seems to work and for the
300     first time I have a UTF-8 username ;-) (Faidon)
301   * Use form->field consistently, not form->param.
302   * Patch from Recai to allow selection of page type when creating a new page.
303     Default page type is inherited from the link clicked on to create the new
304     page.
305
306  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
307
308 ikiwiki (1.8) unstable; urgency=low
309
310   * Fix orphans plugin to not count a link to a nonexistant page as a reason
311     for a page not being an orphan.
312   * Support pinging services such as Technorati using XML-RPC to notify them
313     about changes to rss feeds.
314   * Parse svn log as xml for improved utf8 and security. Note that this makes
315     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
316   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
317     flagged string even if the locale causes it to generate utf8 output,
318     so make sure to let perl know it should be handled as utf8. Also,
319     the optimised version used for standard time formats won't work if the
320     user has changed locale, so drop it. Thanks, Faidon Liambotis.
321   * Fix re-encoding of the comments field to utf8 if a commit fails
322     due to a conflict. Thanks, Faidon Liambotis.
323   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
324     Liambotis.
325   * Add insane double encode/decode to utf8 around call to markdown.
326     This works around a truely strange bug, which is apparently a bug in
327     perl, #376329. Also added a test case for it.
328   * Improve layout of edit page so formatting help link is always visible w/o
329     getting in the way of the preview.
330   * Centralised all calls to HTML::Template and force all the templates
331     to be read as utf8.
332   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
333   * Introduce add_plugins and disable_plugins config options in setup files.
334     This allows adding or removing plugins w/o overriding the whole list of
335     default plugins, which makes it easier to upgrade when new default plugins
336     are added.
337   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
338     default (of course!). Based on a patch by Faidon Liambotis.
339   * Add a html plugin, which can be used to write wikis in raw html,
340     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
341     defaults to not processing .html files, since w/o this plugin they would
342     be copied unsanitised. With this plugin, it will process and html
343     sanitise them, like any other page type.
344   * Rebuilding wrappers is necessary on upgrade to this version.
345   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
346     will be automatically done on all upgrades.
347   * Don't send pings if the wiki is being rebuilt.
348   * Work around very innefficient behavior in File::Spec::abs2rel. Result
349     is a savings of 2 pointless fork/execs per link calculation, which
350     results in ~25% speedup of ikiwiki building its own doc wiki, and
351     about 35% speedup displaying RecentChanges!
352   * Make RecentChanges use a table and some CSS, should be much more readable.
353     No code changes involved.
354   * Encode & in diffurl in examples, to conform to pedantic rules.
355   * Speed up RecentChanges by another 40% or so with some memoization.
356   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
357     in time to build the doc wiki.
358
359  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
360
361 ikiwiki (1.7) unstable; urgency=low
362
363   * Updated logo from Recai with some kerning and alingment tuning.
364   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
365     changed some output.
366   * Copyright update.
367
368  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
369
370 ikiwiki (1.6) unstable; urgency=low
371
372   * YA utf-8 patch from Recai, this time to fix previewing a page so that
373     the text in the input box is re-encoded back to utf-8.
374   * -CSD does not affect modules, so readfile() was not using the utf-8 input
375     layer, which led to lots of problems; make it force read files as utf-8.
376     Closes: #373203
377   * Note that as a consequence, this version of ikiwiki will actually try to
378     parse utf8 in source files for the first time, which may expose broken
379     utf8 in wiki sources that was hidden before. Most common will be
380     perl warnings like "utf8 "\xE9" does not map to Unicode"
381   * writefile() likewise needs to use the utf8 output layer.
382   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
383     there.
384   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
385     given the readfile fix.
386   * Add utf-8 testcases for readfile and htmlize.
387   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
388     safe.
389   * More utf-8 fixes from Recai, partly to things I broke above:
390     - The serious problem is that writefile() saves the content in undecoded
391       format in CGI, hence all (non-ascii) chars are corrupted permanently.
392     - Comment field in edit page is not decoded and all the non-ascii chars in
393       this field are corrupted as the result.  We should decode it as we do it
394       for the content.
395     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
396       character in print.
397   * New SVG logo from Recai.
398
399  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
400
401 ikiwiki (1.5) unstable; urgency=low
402
403   * Add --timeformat config option to allow changing how dates are displayed.
404     Note that as a side effect, dates will now be displayed using the local
405     timezone, not as GMT.
406   * More security review.
407   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
408     for some handy stuff like:
409     - Using links as a kind of tag; creating blog pages that list all pages
410       containing a given tag/link or not containing some other tag.
411     - Subscribing to mail notifications whenever a change is made to a page
412       that is a backlink of page foo. Ie, "Please notify me of changes in all
413       pages that link to my home page in the wiki"
414     - Locking any pages that are linked to from a particular page, so that
415       lists of locks can be exposed in the wiki.
416   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
417     when a todo item is done, instead of the previous moving it to a different
418     subdir.
419   * Allow pagetemplate plugins to override *anything* in the template.
420   * Add a meta plugin, which allows specifying various metadata about pages,
421     like license and author. It also allows for inserting html link and meta
422     tags into html, overriding the title, and adding hidden WikiLinks, which
423     can be useful when using link-based globbing for page categorisation.
424   * Remove preprocessor directives from inlined pages.
425   * Allow simple preprocessor directive values to be specified w/o quotes.
426   * Add support for using git instead of subversion as the RCS backend,
427     tremendous thanks to Recai Oktaş for this.
428   * Doc updates for git.
429   * Fix absolute url munging in rss generation to support https, ftp, etc urls
430     not just http urls.
431   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
432     utf-8 for edit and other fields, and for recentchanges. There may still
433     be utf-8 issues with the preferences page though.
434
435  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
436
437 ikiwiki (1.4) unstable; urgency=low
438
439   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
440     very strange way of enabling proper XHTML <br /> type tags. Output html
441     should be always valid again now.
442   * The page name and parent links has switched from using a <h1> to a styled
443     <span>, so pages can use <h1> internally instead of needing to use <h2>.
444   * Updated all of ikiwiki's own wiki pages for that.
445   * Add pagetemplate hook, which can be used by plugins that want to mess
446     around with adding new stuff to the page template.
447   * Remove headercontent; the search plugin now adds the search box to the
448     header by registering a pagetemplate hook, and other plugins should do
449     similarly.
450   * Rebuilding on upgrade to this version is recommended.
451   * Add a html validity check to the test suite, using the wdg-html-validator,
452     if available.
453   * Make the html valid when there is nothing in the actions list.
454   * Reordered some function call parameters for consistency.
455   * Enable full utf-8 support for page input and output.
456   * Add a workaround for markdown, which does not work well with utf-8
457     strings.
458   * --getctime had bitrotted (well I only ever used it the once so far..),
459     fix and make it a bit more flexible
460   * rcs_getctime is changed, now rather than needing to loop over all pages,
461     it should just use the rcs to get the ctime of the passed file.
462   * When inlining a page in another one, links from the inlined page are now
463     expanded the same as they are when rendering the inlined page as a
464     standalone page. So rather than being expanded from the POV of the
465     inlining page, they are expanded from the POV of the inlined page.
466
467     For example, a link from blog/foo to "bar" will now link to blog/bar
468     if it exists. Previously this needed to be a link explicitly to
469     "blog/bar"; such links will also continue to work.
470
471     (This was slightly complex to do as the link still has to be constructed
472     relative to the inlining page.)
473   * Make page edit textarea resize to fit browser window.
474   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
475     do not need a full rebuild, in order to update any basewiki pages.
476
477  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
478
479 ikiwiki (1.3) unstable; urgency=low
480
481   * Fix the preinst introduced in the last version. Closes: #367458
482
483  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
484
485 ikiwiki (1.2) unstable; urgency=low
486
487   * Remove dups from the brokenlinks list.
488   * Add libc6-dev to dependencies, needed to build wrappers.
489   * Install wikilist in correct location. Closes: #367371
490
491  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
492
493 ikiwiki (1.1) unstable; urgency=low
494
495   * Rename inlinepage to depends, so that it can be used to refer to more
496     dependency relationships than just inlining. This will require a rebuild
497     on upgrade to this version.
498   * Move the rss link, put it in the blogpost form if there is one and at the
499     top if not. This is both nicer because easier to find, and it cleans up
500     the code which had used inlinepage as a flag for adding the link later.
501   * Allow the depends GlobList to be built up from multiple sources (such as
502     plugins) during a page render.
503   * Which means that more than one blog is now supported to appear on a
504     single page. (With some limitations, like only the last one getting an
505     rss file.)
506   * Added a plugin system.
507   * Added a pagecount plugin, enabled by default.
508   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
509   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
510     backlinks when the backlinks hadn't really changed.
511   * Moved inline page support, rss generation etc into the inline plugin,
512     enabled by default.
513   * Added brokenlinks plugin, not enabled by default, but rather handy.
514   * Fix several broken links in the doc wiki.
515   * Smarter behavior when creating a page and a page of the same name (but
516     different location) already exists.
517   * Add an orphans plugin for finding pages that nothing links to.
518   * Removed backlinks page, which it turns out nothing used.
519   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
520     it, this will allow for adding a unit test suite.
521   * Add unit tests for several core functions, including globlist_match,
522     dirname, basename, bestlink, linkify, pagetitle, titlepage.
523   * Smart globlist merging.
524   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
525     to pave the way for adding other RCS support. This also changes the
526     setup files, where before they had svn => 1 or svn => 0, now they have
527     rcs => "svn" or rcs => "".
528   * Add a debian/NEWS file with upgrade notes.
529   * Load whatever rcs module is specified, so new ones can be just dropped in
530     as plugins and work. (Well, in theory.)
531   * Add some basic docs about writing RCS modules.
532   * Broke search capability out into a plugin, removed the --hyperestraier
533     switch.
534   * Added smiley plugin, nicely controlled and documented by the smileys page.
535   * Copied in some smileys from Moin Moin.
536   * Allow links of the form [[some page|page]], with whitespace in the link
537     text.
538   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
539     and --disable-plugin htmlscrubber.
540   * Allow discussion links on pages to be turned off with --no-discussion.
541   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
542   * Add some new config items to the estseek.conf template, which are needed
543     by hyperestraier 1.2.3.
544
545  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
546
547 ikiwiki (1.0) unstable; urgency=low
548
549   * First official release.
550
551  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400