* Patch from Enrico that
[ikiwiki] / debian / changelog
1 ikiwiki (1.11) UNRELEASED; urgency=low
2
3   * Patch from Enrico that
4     - allows preprocessor directives to have parameters with no specified
5       value
6     - fixes preprocessor directive parameter parsing so that
7       foo=bar baz now means "foo=bar" and a "baz" with no value
8     - Add a tag plugin that allows more easily tagging pages.
9       The meta plugin can also still be used for this.
10
11  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 17:03:09 -0400
12
13 ikiwiki (1.10) unstable; urgency=low
14
15   * Run page through any relevant filters when generating a page preview.
16   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
17     default throughout the wiki, not only on wikitext pages. Decided to call
18     this a feature, and split the camelcase support out into a separate plugin
19     that is independant of wikitext.
20   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
21
22  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
23
24 ikiwiki (1.9) unstable; urgency=low
25
26   * Improve display of parentlinks and page title of toplevel index page.
27   * Patch from Faidon to use svn --limit when possible for recentchanges,
28     speeds up recentchanges a lot for wikis with more history.
29   * Patch from Recai to fix utf8 issues in git backend.
30   * Add wikitext markup plugin, which supports ".wiki" pages written in the
31     original wiki syntax, CamelCase links and all.
32   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
33     support, to edit pages etc without a web server.
34   * Display CGI processing errors if present.
35   * Fix from Faidon for a XML parser issue that breaks utf-8 for
36     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
37     area, and also way slow.
38   * Match 'web commit from' in SVN and git, these are web commits too.
39     (Faidon)
40   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
41     readable and avoid future mistakes. The patch seems to work and for the
42     first time I have a UTF-8 username ;-) (Faidon)
43   * Use form->field consistently, not form->param.
44   * Patch from Recai to allow selection of page type when creating a new page.
45     Default page type is inherited from the link clicked on to create the new
46     page.
47
48  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
49
50 ikiwiki (1.8) unstable; urgency=low
51
52   * Fix orphans plugin to not count a link to a nonexistant page as a reason
53     for a page not being an orphan.
54   * Support pinging services such as Technorati using XML-RPC to notify them
55     about changes to rss feeds.
56   * Parse svn log as xml for improved utf8 and security. Note that this makes
57     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
58   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
59     flagged string even if the locale causes it to generate utf8 output,
60     so make sure to let perl know it should be handled as utf8. Also,
61     the optimised version used for standard time formats won't work if the
62     user has changed locale, so drop it. Thanks, Faidon Liambotis.
63   * Fix re-encoding of the comments field to utf8 if a commit fails
64     due to a conflict. Thanks, Faidon Liambotis.
65   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
66     Liambotis.
67   * Add insane double encode/decode to utf8 around call to markdown.
68     This works around a truely strange bug, which is apparently a bug in
69     perl, #376329. Also added a test case for it.
70   * Improve layout of edit page so formatting help link is always visible w/o
71     getting in the way of the preview.
72   * Centralised all calls to HTML::Template and force all the templates
73     to be read as utf8.
74   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
75   * Introduce add_plugins and disable_plugins config options in setup files.
76     This allows adding or removing plugins w/o overriding the whole list of
77     default plugins, which makes it easier to upgrade when new default plugins
78     are added.
79   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
80     default (of course!). Based on a patch by Faidon Liambotis.
81   * Add a html plugin, which can be used to write wikis in raw html,
82     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
83     defaults to not processing .html files, since w/o this plugin they would
84     be copied unsanitised. With this plugin, it will process and html
85     sanitise them, like any other page type.
86   * Rebuilding wrappers is necessary on upgrade to this version.
87   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
88     will be automatically done on all upgrades.
89   * Don't send pings if the wiki is being rebuilt.
90   * Work around very innefficient behavior in File::Spec::abs2rel. Result
91     is a savings of 2 pointless fork/execs per link calculation, which
92     results in ~25% speedup of ikiwiki building its own doc wiki, and
93     about 35% speedup displaying RecentChanges!
94   * Make RecentChanges use a table and some CSS, should be much more readable.
95     No code changes involved.
96   * Encode & in diffurl in examples, to conform to pedantic rules.
97   * Speed up RecentChanges by another 40% or so with some memoization.
98   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
99     in time to build the doc wiki.
100
101  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
102
103 ikiwiki (1.7) unstable; urgency=low
104
105   * Updated logo from Recai with some kerning and alingment tuning.
106   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
107     changed some output.
108   * Copyright update.
109
110  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
111
112 ikiwiki (1.6) unstable; urgency=low
113
114   * YA utf-8 patch from Recai, this time to fix previewing a page so that
115     the text in the input box is re-encoded back to utf-8.
116   * -CSD does not affect modules, so readfile() was not using the utf-8 input
117     layer, which led to lots of problems; make it force read files as utf-8.
118     Closes: #373203
119   * Note that as a consequence, this version of ikiwiki will actually try to
120     parse utf8 in source files for the first time, which may expose broken
121     utf8 in wiki sources that was hidden before. Most common will be
122     perl warnings like "utf8 "\xE9" does not map to Unicode"
123   * writefile() likewise needs to use the utf8 output layer.
124   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
125     there.
126   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
127     given the readfile fix.
128   * Add utf-8 testcases for readfile and htmlize.
129   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
130     safe.
131   * More utf-8 fixes from Recai, partly to things I broke above:
132     - The serious problem is that writefile() saves the content in undecoded
133       format in CGI, hence all (non-ascii) chars are corrupted permanently.
134     - Comment field in edit page is not decoded and all the non-ascii chars in
135       this field are corrupted as the result.  We should decode it as we do it
136       for the content.
137     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
138       character in print.
139   * New SVG logo from Recai.
140
141  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
142
143 ikiwiki (1.5) unstable; urgency=low
144
145   * Add --timeformat config option to allow changing how dates are displayed.
146     Note that as a side effect, dates will now be displayed using the local
147     timezone, not as GMT.
148   * More security review.
149   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
150     for some handy stuff like:
151     - Using links as a kind of tag; creating blog pages that list all pages
152       containing a given tag/link or not containing some other tag.
153     - Subscribing to mail notifications whenever a change is made to a page
154       that is a backlink of page foo. Ie, "Please notify me of changes in all
155       pages that link to my home page in the wiki"
156     - Locking any pages that are linked to from a particular page, so that
157       lists of locks can be exposed in the wiki.
158   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
159     when a todo item is done, instead of the previous moving it to a different
160     subdir.
161   * Allow pagetemplate plugins to override *anything* in the template.
162   * Add a meta plugin, which allows specifying various metadata about pages,
163     like license and author. It also allows for inserting html link and meta
164     tags into html, overriding the title, and adding hidden WikiLinks, which
165     can be useful when using link-based globbing for page categorisation.
166   * Remove preprocessor directives from inlined pages.
167   * Allow simple preprocessor directive values to be specified w/o quotes.
168   * Add support for using git instead of subversion as the RCS backend,
169     tremendous thanks to Recai Oktaş for this.
170   * Doc updates for git.
171   * Fix absolute url munging in rss generation to support https, ftp, etc urls
172     not just http urls.
173   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
174     utf-8 for edit and other fields, and for recentchanges. There may still
175     be utf-8 issues with the preferences page though.
176
177  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
178
179 ikiwiki (1.4) unstable; urgency=low
180
181   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
182     very strange way of enabling proper XHTML <br /> type tags. Output html
183     should be always valid again now.
184   * The page name and parent links has switched from using a <h1> to a styled
185     <span>, so pages can use <h1> internally instead of needing to use <h2>.
186   * Updated all of ikiwiki's own wiki pages for that.
187   * Add pagetemplate hook, which can be used by plugins that want to mess
188     around with adding new stuff to the page template.
189   * Remove headercontent; the search plugin now adds the search box to the
190     header by registering a pagetemplate hook, and other plugins should do
191     similarly.
192   * Rebuilding on upgrade to this version is recommended.
193   * Add a html validity check to the test suite, using the wdg-html-validator,
194     if available.
195   * Make the html valid when there is nothing in the actions list.
196   * Reordered some function call parameters for consistency.
197   * Enable full utf-8 support for page input and output.
198   * Add a workaround for markdown, which does not work well with utf-8
199     strings.
200   * --getctime had bitrotted (well I only ever used it the once so far..),
201     fix and make it a bit more flexible
202   * rcs_getctime is changed, now rather than needing to loop over all pages,
203     it should just use the rcs to get the ctime of the passed file.
204   * When inlining a page in another one, links from the inlined page are now
205     expanded the same as they are when rendering the inlined page as a
206     standalone page. So rather than being expanded from the POV of the
207     inlining page, they are expanded from the POV of the inlined page.
208
209     For example, a link from blog/foo to "bar" will now link to blog/bar
210     if it exists. Previously this needed to be a link explicitly to
211     "blog/bar"; such links will also continue to work.
212
213     (This was slightly complex to do as the link still has to be constructed
214     relative to the inlining page.)
215   * Make page edit textarea resize to fit browser window.
216   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
217     do not need a full rebuild, in order to update any basewiki pages.
218
219  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
220
221 ikiwiki (1.3) unstable; urgency=low
222
223   * Fix the preinst introduced in the last version. Closes: #367458
224
225  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
226
227 ikiwiki (1.2) unstable; urgency=low
228
229   * Remove dups from the brokenlinks list.
230   * Add libc6-dev to dependencies, needed to build wrappers.
231   * Install wikilist in correct location. Closes: #367371
232
233  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
234
235 ikiwiki (1.1) unstable; urgency=low
236
237   * Rename inlinepage to depends, so that it can be used to refer to more
238     dependency relationships than just inlining. This will require a rebuild
239     on upgrade to this version.
240   * Move the rss link, put it in the blogpost form if there is one and at the
241     top if not. This is both nicer because easier to find, and it cleans up
242     the code which had used inlinepage as a flag for adding the link later.
243   * Allow the depends GlobList to be built up from multiple sources (such as
244     plugins) during a page render.
245   * Which means that more than one blog is now supported to appear on a
246     single page. (With some limitations, like only the last one getting an
247     rss file.)
248   * Added a plugin system.
249   * Added a pagecount plugin, enabled by default.
250   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
251   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
252     backlinks when the backlinks hadn't really changed.
253   * Moved inline page support, rss generation etc into the inline plugin,
254     enabled by default.
255   * Added brokenlinks plugin, not enabled by default, but rather handy.
256   * Fix several broken links in the doc wiki.
257   * Smarter behavior when creating a page and a page of the same name (but
258     different location) already exists.
259   * Add an orphans plugin for finding pages that nothing links to.
260   * Removed backlinks page, which it turns out nothing used.
261   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
262     it, this will allow for adding a unit test suite.
263   * Add unit tests for several core functions, including globlist_match,
264     dirname, basename, bestlink, linkify, pagetitle, titlepage.
265   * Smart globlist merging.
266   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
267     to pave the way for adding other RCS support. This also changes the
268     setup files, where before they had svn => 1 or svn => 0, now they have
269     rcs => "svn" or rcs => "".
270   * Add a debian/NEWS file with upgrade notes.
271   * Load whatever rcs module is specified, so new ones can be just dropped in
272     as plugins and work. (Well, in theory.)
273   * Add some basic docs about writing RCS modules.
274   * Broke search capability out into a plugin, removed the --hyperestraier
275     switch.
276   * Added smiley plugin, nicely controlled and documented by the smileys page.
277   * Copied in some smileys from Moin Moin.
278   * Allow links of the form [[some page|page]], with whitespace in the link
279     text.
280   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
281     and --disable-plugin htmlscrubber.
282   * Allow discussion links on pages to be turned off with --no-discussion.
283   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
284   * Add some new config items to the estseek.conf template, which are needed
285     by hyperestraier 1.2.3.
286
287  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
288
289 ikiwiki (1.0) unstable; urgency=low
290
291   * First official release.
292
293  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400