* Display CGI processing errors if present.
[ikiwiki] / debian / changelog
1 ikiwiki (1.9) UNRELEASED; urgency=low
2
3   * Improve display of parentlinks and page title of toplevel index page.
4   * Patch from Faidon to use svn --limit when possible for recentchanges,
5     speeds up recentchanges a lot for wikis with more history.
6   * Patch from Recai to fix utf8 issues in git backend.
7   * Add wikitext markup plugin, which supports ".wiki" pages written in the
8     original wiki syntax, CamelCase links and all.
9   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
10     support, to edit pages etc without a web server.
11   * Display CGI processing errors if present.
12
13  -- Joey Hess <joeyh@debian.org>  Mon, 10 Jul 2006 17:12:57 -0400
14
15 ikiwiki (1.8) unstable; urgency=low
16
17   * Fix orphans plugin to not count a link to a nonexistant page as a reason
18     for a page not being an orphan.
19   * Support pinging services such as Technorati using XML-RPC to notify them
20     about changes to rss feeds.
21   * Parse svn log as xml for improved utf8 and security. Note that this makes
22     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
23   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
24     flagged string even if the locale causes it to generate utf8 output,
25     so make sure to let perl know it should be handled as utf8. Also,
26     the optimised version used for standard time formats won't work if the
27     user has changed locale, so drop it. Thanks, Faidon Liambotis.
28   * Fix re-encoding of the comments field to utf8 if a commit fails
29     due to a conflict. Thanks, Faidon Liambotis.
30   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
31     Liambotis.
32   * Add insane double encode/decode to utf8 around call to markdown.
33     This works around a truely strange bug, which is apparently a bug in
34     perl, #376329. Also added a test case for it.
35   * Improve layout of edit page so formatting help link is always visible w/o
36     getting in the way of the preview.
37   * Centralised all calls to HTML::Template and force all the templates
38     to be read as utf8.
39   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
40   * Introduce add_plugins and disable_plugins config options in setup files.
41     This allows adding or removing plugins w/o overriding the whole list of
42     default plugins, which makes it easier to upgrade when new default plugins
43     are added.
44   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
45     default (of course!). Based on a patch by Faidon Liambotis.
46   * Add a html plugin, which can be used to write wikis in raw html,
47     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
48     defaults to not processing .html files, since w/o this plugin they would
49     be copied unsanitised. With this plugin, it will process and html
50     sanitise them, like any other page type.
51   * Rebuilding wrappers is necessary on upgrade to this version.
52   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
53     will be automatically done on all upgrades.
54   * Don't send pings if the wiki is being rebuilt.
55   * Work around very innefficient behavior in File::Spec::abs2rel. Result
56     is a savings of 2 pointless fork/execs per link calculation, which
57     results in ~25% speedup of ikiwiki building its own doc wiki, and
58     about 35% speedup displaying RecentChanges!
59   * Make RecentChanges use a table and some CSS, should be much more readable.
60     No code changes involved.
61   * Encode & in diffurl in examples, to conform to pedantic rules.
62   * Speed up RecentChanges by another 40% or so with some memoization.
63   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
64     in time to build the doc wiki.
65
66  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
67
68 ikiwiki (1.7) unstable; urgency=low
69
70   * Updated logo from Recai with some kerning and alingment tuning.
71   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
72     changed some output.
73   * Copyright update.
74
75  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
76
77 ikiwiki (1.6) unstable; urgency=low
78
79   * YA utf-8 patch from Recai, this time to fix previewing a page so that
80     the text in the input box is re-encoded back to utf-8.
81   * -CSD does not affect modules, so readfile() was not using the utf-8 input
82     layer, which led to lots of problems; make it force read files as utf-8.
83     Closes: #373203
84   * Note that as a consequence, this version of ikiwiki will actually try to
85     parse utf8 in source files for the first time, which may expose broken
86     utf8 in wiki sources that was hidden before. Most common will be
87     perl warnings like "utf8 "\xE9" does not map to Unicode"
88   * writefile() likewise needs to use the utf8 output layer.
89   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
90     there.
91   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
92     given the readfile fix.
93   * Add utf-8 testcases for readfile and htmlize.
94   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
95     safe.
96   * More utf-8 fixes from Recai, partly to things I broke above:
97     - The serious problem is that writefile() saves the content in undecoded
98       format in CGI, hence all (non-ascii) chars are corrupted permanently.
99     - Comment field in edit page is not decoded and all the non-ascii chars in
100       this field are corrupted as the result.  We should decode it as we do it
101       for the content.
102     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
103       character in print.
104   * New SVG logo from Recai.
105
106  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
107
108 ikiwiki (1.5) unstable; urgency=low
109
110   * Add --timeformat config option to allow changing how dates are displayed.
111     Note that as a side effect, dates will now be displayed using the local
112     timezone, not as GMT.
113   * More security review.
114   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
115     for some handy stuff like:
116     - Using links as a kind of tag; creating blog pages that list all pages
117       containing a given tag/link or not containing some other tag.
118     - Subscribing to mail notifications whenever a change is made to a page
119       that is a backlink of page foo. Ie, "Please notify me of changes in all
120       pages that link to my home page in the wiki"
121     - Locking any pages that are linked to from a particular page, so that
122       lists of locks can be exposed in the wiki.
123   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
124     when a todo item is done, instead of the previous moving it to a different
125     subdir.
126   * Allow pagetemplate plugins to override *anything* in the template.
127   * Add a meta plugin, which allows specifying various metadata about pages,
128     like license and author. It also allows for inserting html link and meta
129     tags into html, overriding the title, and adding hidden WikiLinks, which
130     can be useful when using link-based globbing for page categorisation.
131   * Remove preprocessor directives from inlined pages.
132   * Allow simple preprocessor directive values to be specified w/o quotes.
133   * Add support for using git instead of subversion as the RCS backend,
134     tremendous thanks to Recai Oktaş for this.
135   * Doc updates for git.
136   * Fix absolute url munging in rss generation to support https, ftp, etc urls
137     not just http urls.
138   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
139     utf-8 for edit and other fields, and for recentchanges. There may still
140     be utf-8 issues with the preferences page though.
141
142  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
143
144 ikiwiki (1.4) unstable; urgency=low
145
146   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
147     very strange way of enabling proper XHTML <br /> type tags. Output html
148     should be always valid again now.
149   * The page name and parent links has switched from using a <h1> to a styled
150     <span>, so pages can use <h1> internally instead of needing to use <h2>.
151   * Updated all of ikiwiki's own wiki pages for that.
152   * Add pagetemplate hook, which can be used by plugins that want to mess
153     around with adding new stuff to the page template.
154   * Remove headercontent; the search plugin now adds the search box to the
155     header by registering a pagetemplate hook, and other plugins should do
156     similarly.
157   * Rebuilding on upgrade to this version is recommended.
158   * Add a html validity check to the test suite, using the wdg-html-validator,
159     if available.
160   * Make the html valid when there is nothing in the actions list.
161   * Reordered some function call parameters for consistency.
162   * Enable full utf-8 support for page input and output.
163   * Add a workaround for markdown, which does not work well with utf-8
164     strings.
165   * --getctime had bitrotted (well I only ever used it the once so far..),
166     fix and make it a bit more flexible
167   * rcs_getctime is changed, now rather than needing to loop over all pages,
168     it should just use the rcs to get the ctime of the passed file.
169   * When inlining a page in another one, links from the inlined page are now
170     expanded the same as they are when rendering the inlined page as a
171     standalone page. So rather than being expanded from the POV of the
172     inlining page, they are expanded from the POV of the inlined page.
173
174     For example, a link from blog/foo to "bar" will now link to blog/bar
175     if it exists. Previously this needed to be a link explicitly to
176     "blog/bar"; such links will also continue to work.
177
178     (This was slightly complex to do as the link still has to be constructed
179     relative to the inlining page.)
180   * Make page edit textarea resize to fit browser window.
181   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
182     do not need a full rebuild, in order to update any basewiki pages.
183
184  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
185
186 ikiwiki (1.3) unstable; urgency=low
187
188   * Fix the preinst introduced in the last version. Closes: #367458
189
190  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
191
192 ikiwiki (1.2) unstable; urgency=low
193
194   * Remove dups from the brokenlinks list.
195   * Add libc6-dev to dependencies, needed to build wrappers.
196   * Install wikilist in correct location. Closes: #367371
197
198  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
199
200 ikiwiki (1.1) unstable; urgency=low
201
202   * Rename inlinepage to depends, so that it can be used to refer to more
203     dependency relationships than just inlining. This will require a rebuild
204     on upgrade to this version.
205   * Move the rss link, put it in the blogpost form if there is one and at the
206     top if not. This is both nicer because easier to find, and it cleans up
207     the code which had used inlinepage as a flag for adding the link later.
208   * Allow the depends GlobList to be built up from multiple sources (such as
209     plugins) during a page render.
210   * Which means that more than one blog is now supported to appear on a
211     single page. (With some limitations, like only the last one getting an
212     rss file.)
213   * Added a plugin system.
214   * Added a pagecount plugin, enabled by default.
215   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
216   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
217     backlinks when the backlinks hadn't really changed.
218   * Moved inline page support, rss generation etc into the inline plugin,
219     enabled by default.
220   * Added brokenlinks plugin, not enabled by default, but rather handy.
221   * Fix several broken links in the doc wiki.
222   * Smarter behavior when creating a page and a page of the same name (but
223     different location) already exists.
224   * Add an orphans plugin for finding pages that nothing links to.
225   * Removed backlinks page, which it turns out nothing used.
226   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
227     it, this will allow for adding a unit test suite.
228   * Add unit tests for several core functions, including globlist_match,
229     dirname, basename, bestlink, linkify, pagetitle, titlepage.
230   * Smart globlist merging.
231   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
232     to pave the way for adding other RCS support. This also changes the
233     setup files, where before they had svn => 1 or svn => 0, now they have
234     rcs => "svn" or rcs => "".
235   * Add a debian/NEWS file with upgrade notes.
236   * Load whatever rcs module is specified, so new ones can be just dropped in
237     as plugins and work. (Well, in theory.)
238   * Add some basic docs about writing RCS modules.
239   * Broke search capability out into a plugin, removed the --hyperestraier
240     switch.
241   * Added smiley plugin, nicely controlled and documented by the smileys page.
242   * Copied in some smileys from Moin Moin.
243   * Allow links of the form [[some page|page]], with whitespace in the link
244     text.
245   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
246     and --disable-plugin htmlscrubber.
247   * Allow discussion links on pages to be turned off with --no-discussion.
248   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
249   * Add some new config items to the estseek.conf template, which are needed
250     by hyperestraier 1.2.3.
251
252  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
253
254 ikiwiki (1.0) unstable; urgency=low
255
256   * First official release.
257
258  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400