1 ikiwiki (1.9) unstable; urgency=low
3 * Improve display of parentlinks and page title of toplevel index page.
4 * Patch from Faidon to use svn --limit when possible for recentchanges,
5 speeds up recentchanges a lot for wikis with more history.
6 * Patch from Recai to fix utf8 issues in git backend.
7 * Add wikitext markup plugin, which supports ".wiki" pages written in the
8 original wiki syntax, CamelCase links and all.
9 * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
10 support, to edit pages etc without a web server.
11 * Display CGI processing errors if present.
12 * Fix from Faidon for a XML parser issue that breaks utf-8 for
13 RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
14 area, and also way slow.
15 * Match 'web commit from' in SVN and git, these are web commits too.
17 * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
18 readable and avoid future mistakes. The patch seems to work and for the
19 first time I have a UTF-8 username ;-) (Faidon)
20 * Use form->field consistently, not form->param.
21 * Patch from Recai to allow selection of page type when creating a new page.
22 Default page type is inherited from the link clicked on to create the new
25 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 17:25:30 -0400
27 ikiwiki (1.8) unstable; urgency=low
29 * Fix orphans plugin to not count a link to a nonexistant page as a reason
30 for a page not being an orphan.
31 * Support pinging services such as Technorati using XML-RPC to notify them
32 about changes to rss feeds.
33 * Parse svn log as xml for improved utf8 and security. Note that this makes
34 ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
35 * POSIX::strftime doesn't know about encodings and doesn't return a utf8
36 flagged string even if the locale causes it to generate utf8 output,
37 so make sure to let perl know it should be handled as utf8. Also,
38 the optimised version used for standard time formats won't work if the
39 user has changed locale, so drop it. Thanks, Faidon Liambotis.
40 * Fix re-encoding of the comments field to utf8 if a commit fails
41 due to a conflict. Thanks, Faidon Liambotis.
42 * Let svn know that commits have utf8 commit messages. Thanks, Faidon
44 * Add insane double encode/decode to utf8 around call to markdown.
45 This works around a truely strange bug, which is apparently a bug in
46 perl, #376329. Also added a test case for it.
47 * Improve layout of edit page so formatting help link is always visible w/o
48 getting in the way of the preview.
49 * Centralised all calls to HTML::Template and force all the templates
51 * Support pages with utf8 filenames. Patch by Faidon Liambotis.
52 * Introduce add_plugins and disable_plugins config options in setup files.
53 This allows adding or removing plugins w/o overriding the whole list of
54 default plugins, which makes it easier to upgrade when new default plugins
56 * Support htmlize plugins and make mdwn one such plugin, which is enabled by
57 default (of course!). Based on a patch by Faidon Liambotis.
58 * Add a html plugin, which can be used to write wikis in raw html,
59 if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
60 defaults to not processing .html files, since w/o this plugin they would
61 be copied unsanitised. With this plugin, it will process and html
62 sanitise them, like any other page type.
63 * Rebuilding wrappers is necessary on upgrade to this version.
64 * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
65 will be automatically done on all upgrades.
66 * Don't send pings if the wiki is being rebuilt.
67 * Work around very innefficient behavior in File::Spec::abs2rel. Result
68 is a savings of 2 pointless fork/execs per link calculation, which
69 results in ~25% speedup of ikiwiki building its own doc wiki, and
70 about 35% speedup displaying RecentChanges!
71 * Make RecentChanges use a table and some CSS, should be much more readable.
72 No code changes involved.
73 * Encode & in diffurl in examples, to conform to pedantic rules.
74 * Speed up RecentChanges by another 40% or so with some memoization.
75 * Memoize abs2rel, which is still kinda slow, for another 30% speedup
76 in time to build the doc wiki.
78 -- Joey Hess <joeyh@debian.org> Tue, 4 Jul 2006 12:46:29 -0400
80 ikiwiki (1.7) unstable; urgency=low
82 * Updated logo from Recai with some kerning and alingment tuning.
83 * Patch from Recai to fix git recentchanges code to work with git 1.4 which
87 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
89 ikiwiki (1.6) unstable; urgency=low
91 * YA utf-8 patch from Recai, this time to fix previewing a page so that
92 the text in the input box is re-encoded back to utf-8.
93 * -CSD does not affect modules, so readfile() was not using the utf-8 input
94 layer, which led to lots of problems; make it force read files as utf-8.
96 * Note that as a consequence, this version of ikiwiki will actually try to
97 parse utf8 in source files for the first time, which may expose broken
98 utf8 in wiki sources that was hidden before. Most common will be
99 perl warnings like "utf8 "\xE9" does not map to Unicode"
100 * writefile() likewise needs to use the utf8 output layer.
101 * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
103 * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
104 given the readfile fix.
105 * Add utf-8 testcases for readfile and htmlize.
106 * Put back the encode_utf8 in the input to markdown; it's really not utf-8
108 * More utf-8 fixes from Recai, partly to things I broke above:
109 - The serious problem is that writefile() saves the content in undecoded
110 format in CGI, hence all (non-ascii) chars are corrupted permanently.
111 - Comment field in edit page is not decoded and all the non-ascii chars in
112 this field are corrupted as the result. We should decode it as we do it
114 - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
116 * New SVG logo from Recai.
118 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
120 ikiwiki (1.5) unstable; urgency=low
122 * Add --timeformat config option to allow changing how dates are displayed.
123 Note that as a side effect, dates will now be displayed using the local
124 timezone, not as GMT.
125 * More security review.
126 * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
127 for some handy stuff like:
128 - Using links as a kind of tag; creating blog pages that list all pages
129 containing a given tag/link or not containing some other tag.
130 - Subscribing to mail notifications whenever a change is made to a page
131 that is a backlink of page foo. Ie, "Please notify me of changes in all
132 pages that link to my home page in the wiki"
133 - Locking any pages that are linked to from a particular page, so that
134 lists of locks can be exposed in the wiki.
135 * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
136 when a todo item is done, instead of the previous moving it to a different
138 * Allow pagetemplate plugins to override *anything* in the template.
139 * Add a meta plugin, which allows specifying various metadata about pages,
140 like license and author. It also allows for inserting html link and meta
141 tags into html, overriding the title, and adding hidden WikiLinks, which
142 can be useful when using link-based globbing for page categorisation.
143 * Remove preprocessor directives from inlined pages.
144 * Allow simple preprocessor directive values to be specified w/o quotes.
145 * Add support for using git instead of subversion as the RCS backend,
146 tremendous thanks to Recai Oktaş for this.
147 * Doc updates for git.
148 * Fix absolute url munging in rss generation to support https, ftp, etc urls
150 * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
151 utf-8 for edit and other fields, and for recentchanges. There may still
152 be utf-8 issues with the preferences page though.
154 -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
156 ikiwiki (1.4) unstable; urgency=low
158 * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
159 very strange way of enabling proper XHTML <br /> type tags. Output html
160 should be always valid again now.
161 * The page name and parent links has switched from using a <h1> to a styled
162 <span>, so pages can use <h1> internally instead of needing to use <h2>.
163 * Updated all of ikiwiki's own wiki pages for that.
164 * Add pagetemplate hook, which can be used by plugins that want to mess
165 around with adding new stuff to the page template.
166 * Remove headercontent; the search plugin now adds the search box to the
167 header by registering a pagetemplate hook, and other plugins should do
169 * Rebuilding on upgrade to this version is recommended.
170 * Add a html validity check to the test suite, using the wdg-html-validator,
172 * Make the html valid when there is nothing in the actions list.
173 * Reordered some function call parameters for consistency.
174 * Enable full utf-8 support for page input and output.
175 * Add a workaround for markdown, which does not work well with utf-8
177 * --getctime had bitrotted (well I only ever used it the once so far..),
178 fix and make it a bit more flexible
179 * rcs_getctime is changed, now rather than needing to loop over all pages,
180 it should just use the rcs to get the ctime of the passed file.
181 * When inlining a page in another one, links from the inlined page are now
182 expanded the same as they are when rendering the inlined page as a
183 standalone page. So rather than being expanded from the POV of the
184 inlining page, they are expanded from the POV of the inlined page.
186 For example, a link from blog/foo to "bar" will now link to blog/bar
187 if it exists. Previously this needed to be a link explicitly to
188 "blog/bar"; such links will also continue to work.
190 (This was slightly complex to do as the link still has to be constructed
191 relative to the inlining page.)
192 * Make page edit textarea resize to fit browser window.
193 * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
194 do not need a full rebuild, in order to update any basewiki pages.
196 -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
198 ikiwiki (1.3) unstable; urgency=low
200 * Fix the preinst introduced in the last version. Closes: #367458
202 -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
204 ikiwiki (1.2) unstable; urgency=low
206 * Remove dups from the brokenlinks list.
207 * Add libc6-dev to dependencies, needed to build wrappers.
208 * Install wikilist in correct location. Closes: #367371
210 -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
212 ikiwiki (1.1) unstable; urgency=low
214 * Rename inlinepage to depends, so that it can be used to refer to more
215 dependency relationships than just inlining. This will require a rebuild
216 on upgrade to this version.
217 * Move the rss link, put it in the blogpost form if there is one and at the
218 top if not. This is both nicer because easier to find, and it cleans up
219 the code which had used inlinepage as a flag for adding the link later.
220 * Allow the depends GlobList to be built up from multiple sources (such as
221 plugins) during a page render.
222 * Which means that more than one blog is now supported to appear on a
223 single page. (With some limitations, like only the last one getting an
225 * Added a plugin system.
226 * Added a pagecount plugin, enabled by default.
227 * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
228 * Fixed/optimised backlinks code, to avoid rebuilding pages to update
229 backlinks when the backlinks hadn't really changed.
230 * Moved inline page support, rss generation etc into the inline plugin,
232 * Added brokenlinks plugin, not enabled by default, but rather handy.
233 * Fix several broken links in the doc wiki.
234 * Smarter behavior when creating a page and a page of the same name (but
235 different location) already exists.
236 * Add an orphans plugin for finding pages that nothing links to.
237 * Removed backlinks page, which it turns out nothing used.
238 * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
239 it, this will allow for adding a unit test suite.
240 * Add unit tests for several core functions, including globlist_match,
241 dirname, basename, bestlink, linkify, pagetitle, titlepage.
242 * Smart globlist merging.
243 * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
244 to pave the way for adding other RCS support. This also changes the
245 setup files, where before they had svn => 1 or svn => 0, now they have
246 rcs => "svn" or rcs => "".
247 * Add a debian/NEWS file with upgrade notes.
248 * Load whatever rcs module is specified, so new ones can be just dropped in
249 as plugins and work. (Well, in theory.)
250 * Add some basic docs about writing RCS modules.
251 * Broke search capability out into a plugin, removed the --hyperestraier
253 * Added smiley plugin, nicely controlled and documented by the smileys page.
254 * Copied in some smileys from Moin Moin.
255 * Allow links of the form [[some page|page]], with whitespace in the link
257 * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
258 and --disable-plugin htmlscrubber.
259 * Allow discussion links on pages to be turned off with --no-discussion.
260 * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
261 * Add some new config items to the estseek.conf template, which are needed
262 by hyperestraier 1.2.3.
264 -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
266 ikiwiki (1.0) unstable; urgency=low
268 * First official release.
270 -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400