* Make auth methods pluggable.
[ikiwiki] / debian / changelog
1 ikiwiki (1.34) UNRELEASED; urgency=low
2
3   * Make auth methods pluggable.
4   * Move httpauth support to a plugin.
5   * Add an openid plugin to support logging in using OpenID.
6
7  -- Joey Hess <joeyh@debian.org>  Sun, 19 Nov 2006 16:40:26 -0500
8
9 ikiwiki (1.33) unstable; urgency=low
10
11   * Fix issue with aggregate plugin updating expired pages.
12   * Avoid syntax errors in templates used by the template plugin crashing
13     ikiwiki.
14   * Enable utf8 file IO in aggregate plugin.
15   * Fix some issues with the new registration form.
16   * Patch from Ethan Glasser Camp to add a skip option to the inline plugin.
17   * Make sure to check for errors from every eval.
18   * Fix img plugin's handling of adding dependencies for images that do not
19     yet exist.
20   * Work around a strange bug in CGI::FormBuilder 3.0401 that makes
21     FORM-SUBMIT unusable on customised formbuilder templates. For now,
22     hardcode the submit buttons in editpage.tmpl instead of using the
23     template variable, which is ok, since the buttons are static.
24   * Work with hyperestraier 1.4.9.
25
26  -- Joey Hess <joeyh@debian.org>  Wed, 15 Nov 2006 18:32:26 -0500
27
28 ikiwiki (1.32) unstable; urgency=low
29
30   * Add a separate pass to find page links, and only render each page once,
31     instead of over and over. Typical speedup is ~4x. Max possible speedup:
32     8x.
33   * Add "scan" parameter to hook(), which is used to make the hook be called
34     during the scanning pass, as well as the render pass. The meta and tag
35     plugins need to use the new scan parameter, so will any others that modify
36     %links.
37   * Now that links are calculated in a separate pass, it can also
38     precalculate backlinks in one pass, which is O(N^2) instead of the
39     previous code that was O(N^3). A very nice speedup for wikis with lots
40     (thousands) of pages.
41   * Stylish update to the ikiwiki logo, thanks to Recai Oktaş and Selçuk
42     Erdem.
43   * Add a default stylesheet entry for the pagecloud.
44   * Add examples page with some examples of things that can be done using
45     ikiwiki, like a weblog. The examples can be copied into a user's wiki
46     for a quick start, without needing to learn everything about how to put
47     them together.
48   * Install the source of the examples into /usr/share/doc/ikiwiki/examples.
49   * Add perlmagick to build-depends so syntax check of img plugin works.
50     Closes: #396702
51   * Improve login/register process, the login dialog has only name and
52     password fields, which allows more web browsers to regognise it as a login
53     field, and is less confusing.
54   * Implemented expiry options for aggregate plugin.
55   * Use precalculated backlinks info when determining if files need an update
56     due to a page they link to being added/removed. Mostly significant if
57     there are lots of pages.
58   * Remove duplicate link info when saving index. In some cases it could
59     pile up rather badly. (Probably not the best way to deal with this
60     problem.)
61   * Patch from James Westby to support podcasting, photoblogging, vidcasting,
62     or what have you, by creating enclosures for non-page items that are
63     included in feeds.
64
65  -- Joey Hess <joeyh@debian.org>  Fri,  3 Nov 2006 14:46:37 -0500
66
67 ikiwiki (1.31) unstable; urgency=low
68
69   * Patch from Pawel Tecza to cp -a the templates in the Makefile.
70   * Change the rss feed title from the wikiname to the page title, with
71     an exception for the wiki's toplevel index page, which will still use the
72     wikiname as the feed title.
73     Overriding the page title with meta title already overrode the rss feed
74     tittle.
75   * Add an img plugin, based on Christian Mock's img plugin, but stripped
76     down to the bare essentials. Useful for handling large images on websites.
77   * Sanitize possibly problimatic characters out of the polygen grammar names,
78     just in case. Should not be exploitable anyway, since it only tries to run
79     polygen after finding the specified grammar file.
80   * Add missing dependency on the URI perl module.
81   * Add basic spam fighting tool for admins: An admin's prefs page now allows
82     editing a list of banned users.
83
84  -- Joey Hess <joeyh@debian.org>  Fri, 27 Oct 2006 23:16:33 -0400
85
86 ikiwiki (1.30) unstable; urgency=low
87
88   * Add no_override parameter to hook().
89   * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
90     plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
91     can be configured using a page in wiki.
92   * Fix support for --pingurl at the command line.
93   * Fix a subtle bug in will_render that broke some builds, by only clearing
94     items from renderedfiles the first time per build.
95   * Wrap entire technortati ping operation in an eval to catch all possible
96     failure modes, after I observed a simple ->value crashing ikiwiki when
97     a ping failed.
98
99  -- Joey Hess <joeyh@debian.org>  Mon, 16 Oct 2006 15:17:38 -0400
100
101 ikiwiki (1.29) unstable; urgency=low
102
103   * Patch from Paul Tötterman to use CP in the Makefile.
104   * Patch from Alec Berryman adding a http_auth config item that allows
105     using HTTP Authentication instead of ikiwiki's built in authentication.
106     Useful for eg, large sites with their own previously existing user auth
107     setup. Closes: #384534
108   * Change %renderedfiles to store an array of files rendered from a given
109     source file, to allow tracking of extra rendered files like rss feeds.
110   * Note that plugins that accessed this variable will need to be updated!
111     The plugin interface has been increased to version 1.01 for this change.
112     As few plugins use %renderedfiles I haven't done anything else to ensure
113     compatability of old plugins.
114   * Add will_render function to the plugin interface, used to register that a
115     page renders a destination file, and do some security checks. Previously
116     but no longer rendered files will be cleaned up.
117   * Use will_render in the inline and linkmap plugins.
118   * You will need to rebuild your wiki on upgrade to this version.
119   * Atom feed support based on a patch by Clint Adams.
120   * Add feeds=no option to inline preprocessor directive to turn off all types
121     of feeds.
122   * $IkiWiki::version now holds the program version, and is accessible to
123     plugins.
124   * Make the aggregate plugin emphasize error messages.
125   * Patch from Recai to limit recentchanges to displaying max 10 files for a
126     given changeset (to avoid large number of file changes excessively
127     bloating the page).
128
129  -- Joey Hess <joeyh@debian.org>  Fri, 13 Oct 2006 23:14:28 -0400
130
131 ikiwiki (1.28) unstable; urgency=low
132
133   * inline: Add ability to sort by page name, based on a patch from
134     Benjamin A'Lee.
135   * Fix a forkbomb in various calls to IPC::Open2, which has a highly
136     braindead interface. Closes: #389383
137   * Don't rm -rf ikiwiki on distclean, since a) there's no such file
138     and b) those poor Mac OSX users and their case insensative files!
139   * Don't fail syntax check if Text::Typography isn't installed.
140     Closes: #389406
141
142  -- Joey Hess <joeyh@debian.org>  Tue, 26 Sep 2006 02:08:17 -0400
143
144 ikiwiki (1.27) unstable; urgency=low
145
146   * Work on firming up the plugin interface:
147     - Plugins should not need to load IkiWiki::Render to get commonly
148       used functions, so moved some functions from there to IkiWiki.
149     - Picked out the set of functions and variables that most plugins
150       use, documented them, and made IkiWiki export them by default,
151       like a proper perl module should.
152     - Use the other functions at your own risk.
153     - This is not quite complete, I still have to decide whether to
154       export some other things.
155   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
156     referring to stuff now exported by the IkiWiki module.
157   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
158     to declare which version of the interface your plugin needs.
159   * Anyone with a third-party ikiwiki plugin is strongly encouraged
160     to make like changes to it and avoid use of non-exported symbols from
161     "IkiWiki::".
162   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
163   * Support hyperestradier version 1.4.2, which adds a new required phraseform
164     setting.
165   * If an inlined page has a permalink, link the page title to that.
166   * Patch from Recai to use utf8 when reading the setup file, so that
167     utf8 wikinames from there will be used properly.
168   * Patch from Recai to kill utf-8 on the wiki name when generating the
169     session cookie.
170   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
171   * Fix a baseurl problem in hyperestradier search results.
172   * Add a stub local.css to avoid problems with 404's.
173   * Patch from Recai to fix a wide character warning from the search plugin
174     during setup if the wikiname contains utf8.
175   * Yet another fix for those poor case-insensative OS X users.
176   * pagetemplate hooks are now also called when generating cgi pages.
177   * Add a favicon plugin, which simply adds a link tag for an icon to each
178     page (and cgis).
179   * Patch from James Westby to deal with the case where you're editing a
180     new page, hit cancel, and need to be redirected to somewhere sane.
181   * Various documentation improvements by various wiki users.
182   * Support Text::Markdown from CPAN, which has a different interface from
183     the original markdown or the one in Debian.
184   * Version the libcgi-session-perl dependency, some features that need
185     the new version are used in some cases (sslcookie).
186   * Numerous tla fixes from Clint.
187   * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
188     a multi-resolution favicon.ico.
189   * README.Debian: typo Closes: #388110
190   * chomp trailing newline at the end of templates read in by the template
191     plugin, to allow use of the template preprocessor directive in
192     whitespace-sensative situations. Closes: #387073
193   * Patch from James Westby to make the location of the estseek.cgi script
194     configurable.
195   * Add typography (SmartyPants) plugin by Recai.
196   * Add --render mode, which can be used to preview an edit at the command
197     line by test rendering a single page.
198   * Add a googlecalendar plugin. A bit special-purpose, but it shows
199     one way to to deal with user-supplied content that could cause XSS
200     issues w/o the htmlscrubber, and won't survive the scrubber.
201
202  -- Joey Hess <joeyh@debian.org>  Sun, 24 Sep 2006 00:02:21 -0400
203
204 ikiwiki (1.26) unstable; urgency=low
205
206   * Add a missing -n to tla undo call.
207   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
208     writes before consuming its whole stdin. Avoid this deadlock.
209   * Fix alt tags for outline checkboxes.
210
211  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
212
213 ikiwiki (1.25) unstable; urgency=low
214
215   * Add proper waitpid calls for open2ed processes throughout to avoid
216     zombies; this hit htmltidy especially badly.
217   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
218     subversion repos and fixing some other issues.
219   * Add support for tla, contributed by Clint Adams. Closes: #385936
220   * Add support for mercurial, contributed by Emanuele Aina.
221   * Include <link rel> tag for RSS feeds, used by some aggregators and
222     firefox to find the feed.
223   * Add a linkmap plugin (requires graphviz).
224
225  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
226
227 ikiwiki (1.24) unstable; urgency=low
228
229   * Simplify the data structure returned by rcs_recentchanges to avoid
230     each rcs plugin needing to form complex strings on its own.
231   * Fix another destpage issue in the inline directive. Closes: #385512
232     again.
233
234  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
235
236 ikiwiki (1.23) unstable; urgency=low
237
238   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
239
240  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
241
242 ikiwiki (1.22) unstable; urgency=low
243
244   * Change how the stylesheet url is determined in the templates: Remove
245     STYLEURL and add BASEURL to all templates (some already had it). This
246     new more general variable can be used to link to other things (eg, images)
247     from the template, as well as stylesheets.
248   * Fix a bug introduced last version to do with nested inlines.
249   * Allow preprocessor directives to span multiple lines, both to make
250     long ones with lots of values easier to write, and to allow for ones with
251     multi-line quoted values.
252   * Allow preprocessor directives to contain python-like triple-quoted
253     text blocks, for easy nesting of quotes inside.
254   * Add a template plugin.
255   * Make pagespec merge code smarter about merging duplicate pagespecs.
256   * Patch from Jordà Polo to make Setup::Standard support hashes in config
257     files.
258   * Change order of linkify and preprocess; first preprocess and then linkify.
259     This allows passing a wikilink inside a parameter to a preprocessor
260     directive without it being expanded to html, and leaking out of the
261     parameter, which had required some non-obvious use of triple-quoting
262     to avoid. Note that any preprocessor plugins that output something
263     that looks like a wikilink will now have it treated as such; AFAIK
264     this doesn't change any behavior though except for the template plugin.
265   * Enable preprocessor directives when previewing an edit.
266   * Make all pages pull in a local.css style sheet, if present. This won't
267     be included in ikiwiki, but can be created to make local styling changes
268     w/o needing to merge in every new change to the distributed style.css.
269   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
270   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
271     from a different directory.
272   * Generalised preprocesser loop protection code.
273   * Patch from James Westby to allow a description to be set for rss feeds.
274   * Patch from James Westby to add a template for the search form.
275   * Added a ddate plugin.
276   * Patch from James Westby to add a --sslcookie switch, which forces
277     cookies to only be sent over ssl connections to avoid interception.
278   * Fix preferences page on anonok wikis; still need to sign in to get
279     to the preferences page.
280   * Add toc (table of contents) plugin.
281   * Change htmlize, format, and sanitize hooks to use named parameters.
282   * Patch from James Westby to add an actions option to inline; this
283     adds Edit and Discussion links at the end of blog entries.
284   * Due to some css changes, you'll want to rebuild your wiki on upgrade
285     to this version. Will be handled automatically by the deb.
286   * Add processed date to aggregate preprocessor directive status output.
287
288  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
289
290 ikiwiki (1.21) unstable; urgency=low
291
292   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
293   * If a page links to itself, mark up the link text in a span with
294     class="selflink" so that it can be styled. I don't have a useful style
295     defined for that though.
296   * Call filter hooks on inlined page content.
297   * Support inlining pages raw, rather than creating a blog.
298   * Clean up yes/no parameter parsing in inline plugin.
299   * Implemented better cycle detection in the inline plugin; nested inlines
300     will now work.
301   * Add a map plugin contributed by Alessandro Dotti Contra.
302   * Add otl format plugin, which handles files as created by vimoutliner.
303   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
304   * Add first draft at a Restructured Text (rst) plugin, by Sergio
305     Talens-Oliag. Note that this has many known issues -- see the caveats on
306     the plugin's page.
307   * Credit everyone who wrote a plugin on the plugins' wiki pages.
308   * Fix utf-8 in blog post form.
309
310  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
311
312 ikiwiki (1.20) unstable; urgency=low
313
314   * Relicense the templates and basewiki under the 2-clause BSD license.
315     Since these can easily become part of other people's websites, they
316     should be under as permissive a license as possible.
317   * Add --syslog config option, to log to the syslog.
318   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
319     transient failure to fork (which I've seen happen in the wild).
320   * Fix a bug in the aggregator introduced last version that caused all
321     aggregator state to be lost during a non-aggregating build.
322
323  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
324
325 ikiwiki (1.19) unstable; urgency=low
326
327   * Fix several related bugs in page type determination during online editing.
328   * Add some locking to prevent 2 aggregators from running at once.
329   * Fix an infinite loop in the aggregator when finding a unique filename.
330
331  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
332
333 ikiwiki (1.18) unstable; urgency=low
334
335   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
336   * Add --version.
337   * Man page format fixups.
338   * If the meta plugin overides the page title, set a title_overridden
339     variable in the template to true. This allows doing things with the
340     templates conditional on the title being overriden.
341   * Add a %pagecase which maps lower-case page names to the actual case
342     used in the filename. Use this in bestlinks calculation instead of
343     forcing the link to lowercase.
344   * Also use %pagecase in various other places that want to check if a page
345     with a given name exists.
346   * This means that links to pages with mixed case names will now work,
347     even if the link is in some other case mixture, and mixed case pages
348     should be fully supported throughout ikiwiki.
349   * Recommend rebuilding wikis on upgrade to this version.
350
351  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
352
353 ikiwiki (1.17) unstable; urgency=low
354
355   * Disable tidy generator tag.
356   * Move tidy back to sanitize hook, found out how to only show body.
357   * Turn off tidy indentation too.
358   * Turn on HTML::Template loop_context_vars; not actually used in stock
359     templates but can be useful for things like making comma-delimited lists
360     of tags or what have you.
361   * Remove <br> from end of aggregate preprocessor directive output.
362   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
363     case-sensative filesystems like OSX.
364   * Improve markdown loading. First, try to load it as a proper perl module,
365     in case it was installed as one. Then fall back to trying
366     /usr/bin/markdown.
367   * Document in install page how to install markdown, since it has no
368     installation procedure in the upstream tarball.
369   * Set die_on_bad_params => 0 for all templates, to allow users to modify
370     them without annoyances.
371   * Suck in the page content when generating an inline archive page, to work
372     around the meta plugin's lack of caching of title metadata across runs.
373
374  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
375
376 ikiwiki (1.16) unstable; urgency=low
377
378   * Try to handle relative links in aggregated feeds. However,
379     the current support is a crude hack due to limitations of XML::Feed:
380     xml:base is not supported, neither is Content-Location. And of course,
381     relative links in RSS feeds are ill-undefined..
382   * Make aggregator save permalinks and author name to pages as metadata.
383   * Add permalink and author support to meta plugin, affecting RSS feeds
384     and blog pages.
385   * Various CSS and formatting changes.
386   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
387   * Add xhtml files to the default prune regexp.
388   * Also generate rel=bookmark links for permalinks.
389   * Fix the htmltidy plugin, which wasn't working due my breaking it when
390     I added it..
391   * Don't run tidy with -xml as that fails if the input is not well-formed.
392     Run it with -asxhtml instead, so it will output well-formed xhtml no
393     matter what the input.
394   * Disable tidy warnings too.
395   * Add a new format hook, and make tidy use it, since tidy can really only
396     operate on and output complete html documents, not the body chunks
397     that sanitise gets.
398   * Fix dates in rss feeds if running localised, so they're still rfc 822.
399
400  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
401
402 ikiwiki (1.15) unstable; urgency=low
403
404   * Remove CDPATH and other env vars perl taint checking doesn't like.
405     Closes: #381279
406   * Added created_before and created_after PageSpec limits.
407
408  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
409
410 ikiwiki (1.14) unstable; urgency=low
411
412   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
413     by 10% or so.
414   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
415   * Added many unit tests for pagespec_match.
416
417  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
418
419 ikiwiki (1.13) unstable; urgency=low
420
421   * ikiwiki can now download and aggregate feeds with its new aggregate
422     plugin, so it's possible to implement a Planet using ikiwiki!
423   * Add a run_hooks function for the common task of running all hooks of a
424     given type.
425   * Add a savestate hook.
426   * Don't put blog post forms on pages if there's no cgiurl set.
427   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
428     --wrappers to do that.
429   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
430     to update pages that haven't changed on disk.
431   * Change meta tags to use html entity-escaped text for values, so that
432     quotes and such can be represented in title tags.
433   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
434     for the above.
435   * Make --rebuild also cause --aggregate to re-download and write aggregated
436     pages.
437   * Avoid outputting duplicate meta info.
438   * Include title metadata on aggregated posts for capitalised and un-munged
439     titles.
440   * Title metadata of inlined pages now shows up in blogs and rss feeds.
441   * Fix issue with unicode filenames and updating the hyper estradier search
442     index. (Aka Please Please Please, let that be the last one.)
443   * Patch from Roland Mas to support an rss=no parameter to inline directives.
444     Closes: #380743
445   * Renamed GlobLists to PageSpecs.
446   * PageSpecs can now include nested parens, "and", and "or". This remains
447     backwards compatible to the old GlobList format. It's implemented by
448     treating the GlobList as a very limited microlanguage that is transformed
449     to perl code that does the matching.
450   * The old GlobList format is deprecated, and I encourage users to switch to
451     using the new PageSpec format. Compatability with the old format will be
452     removed at some point, possibly by 2.0.
453   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
454   * Add support for creation_month and creation_year to PageSpec.
455     Closes: #380680
456   * Changes to index file encoding.
457
458  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
459
460 ikiwiki (1.12) unstable; urgency=low
461
462   "Viva l'Italia!"
463   * New pagestats plugin from Enrico, which can generate a table counting
464     the backlinks for each page, or a del.icio.us style cloud.
465   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
466     the wikiformat plugin works. Thanks, Emanuele Aina.
467   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
468     display, running them through pagetitle. This removes ugly underscores and
469     other gunk from the display, much nicer. You may want to rebuild your wiki
470     when upgrading to get the cleanup globally.
471   * Polygen plugin from Enrico.
472   * htmltidy plugin from Faidon.
473   * Locale patch from Faidon:
474     - Adds a locale setting to setup files.
475     - Proper local time, if the locale configuration option is used.
476     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
477       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
478       impossible.
479   * Add getopt hook type, this allows plugins to add new command-line options.
480   * Add --tagbase option to tag plugin.
481   * Add exclude option in setup files, works same as --exclude.
482   * Put categories in rss feeds for tagged items.
483   * Allow preprocessor directives to be expanded in inlined blog pages.
484     However, to avoid inlining loops etc, don't expand inline directives in
485     inlined pages.
486   * fortune plugin (trivial)
487   * Tag plugins according to type.
488
489  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
490
491 ikiwiki (1.11) unstable; urgency=low
492
493   * Patch from Enrico that
494     - Adds a tag plugin that allows more easily tagging pages.
495       The meta plugin can also still be used for that, but the tag plugin
496       also lists a page's tags at the bottom of the page.
497     - Allows preprocessor directives to have parameters with no specified
498       value.
499     - Fixes preprocessor directive parameter parsing so that
500       foo=bar baz now means "foo=bar" and a "baz" with no value.
501   * Run pagetemplate hooks when inlining pages so that inlined pages also
502     list their tags.
503   * Make all plugins with pagetemplate hooks check that variables exist
504     on the template before setting them, for robustness.
505   * Switch pagetemplate hooks to using named parameters.
506   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
507     This will be the page that a source page will be part of, which is
508     different than the source page for inlined pages.
509   * Audited all plugins to endure they pass (page, destpage) to htmllink
510     appropriatly. This means inlining of various plugins will not work
511     properly, with correct links generated.
512
513  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
514
515 ikiwiki (1.10) unstable; urgency=low
516
517   * Run page through any relevant filters when generating a page preview.
518   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
519     default throughout the wiki, not only on wikitext pages. Decided to call
520     this a feature, and split the camelcase support out into a separate plugin
521     that is independant of wikitext.
522   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
523
524  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
525
526 ikiwiki (1.9) unstable; urgency=low
527
528   * Improve display of parentlinks and page title of toplevel index page.
529   * Patch from Faidon to use svn --limit when possible for recentchanges,
530     speeds up recentchanges a lot for wikis with more history.
531   * Patch from Recai to fix utf8 issues in git backend.
532   * Add wikitext markup plugin, which supports ".wiki" pages written in the
533     original wiki syntax, CamelCase links and all.
534   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
535     support, to edit pages etc without a web server.
536   * Display CGI processing errors if present.
537   * Fix from Faidon for a XML parser issue that breaks utf-8 for
538     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
539     area, and also way slow.
540   * Match 'web commit from' in SVN and git, these are web commits too.
541     (Faidon)
542   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
543     readable and avoid future mistakes. The patch seems to work and for the
544     first time I have a UTF-8 username ;-) (Faidon)
545   * Use form->field consistently, not form->param.
546   * Patch from Recai to allow selection of page type when creating a new page.
547     Default page type is inherited from the link clicked on to create the new
548     page.
549
550  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
551
552 ikiwiki (1.8) unstable; urgency=low
553
554   * Fix orphans plugin to not count a link to a nonexistant page as a reason
555     for a page not being an orphan.
556   * Support pinging services such as Technorati using XML-RPC to notify them
557     about changes to rss feeds.
558   * Parse svn log as xml for improved utf8 and security. Note that this makes
559     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
560   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
561     flagged string even if the locale causes it to generate utf8 output,
562     so make sure to let perl know it should be handled as utf8. Also,
563     the optimised version used for standard time formats won't work if the
564     user has changed locale, so drop it. Thanks, Faidon Liambotis.
565   * Fix re-encoding of the comments field to utf8 if a commit fails
566     due to a conflict. Thanks, Faidon Liambotis.
567   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
568     Liambotis.
569   * Add insane double encode/decode to utf8 around call to markdown.
570     This works around a truely strange bug, which is apparently a bug in
571     perl, #376329. Also added a test case for it.
572   * Improve layout of edit page so formatting help link is always visible w/o
573     getting in the way of the preview.
574   * Centralised all calls to HTML::Template and force all the templates
575     to be read as utf8.
576   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
577   * Introduce add_plugins and disable_plugins config options in setup files.
578     This allows adding or removing plugins w/o overriding the whole list of
579     default plugins, which makes it easier to upgrade when new default plugins
580     are added.
581   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
582     default (of course!). Based on a patch by Faidon Liambotis.
583   * Add a html plugin, which can be used to write wikis in raw html,
584     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
585     defaults to not processing .html files, since w/o this plugin they would
586     be copied unsanitised. With this plugin, it will process and html
587     sanitise them, like any other page type.
588   * Rebuilding wrappers is necessary on upgrade to this version.
589   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
590     will be automatically done on all upgrades.
591   * Don't send pings if the wiki is being rebuilt.
592   * Work around very innefficient behavior in File::Spec::abs2rel. Result
593     is a savings of 2 pointless fork/execs per link calculation, which
594     results in ~25% speedup of ikiwiki building its own doc wiki, and
595     about 35% speedup displaying RecentChanges!
596   * Make RecentChanges use a table and some CSS, should be much more readable.
597     No code changes involved.
598   * Encode & in diffurl in examples, to conform to pedantic rules.
599   * Speed up RecentChanges by another 40% or so with some memoization.
600   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
601     in time to build the doc wiki.
602
603  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
604
605 ikiwiki (1.7) unstable; urgency=low
606
607   * Updated logo from Recai with some kerning and alingment tuning.
608   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
609     changed some output.
610   * Copyright update.
611
612  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
613
614 ikiwiki (1.6) unstable; urgency=low
615
616   * YA utf-8 patch from Recai, this time to fix previewing a page so that
617     the text in the input box is re-encoded back to utf-8.
618   * -CSD does not affect modules, so readfile() was not using the utf-8 input
619     layer, which led to lots of problems; make it force read files as utf-8.
620     Closes: #373203
621   * Note that as a consequence, this version of ikiwiki will actually try to
622     parse utf8 in source files for the first time, which may expose broken
623     utf8 in wiki sources that was hidden before. Most common will be
624     perl warnings like "utf8 "\xE9" does not map to Unicode"
625   * writefile() likewise needs to use the utf8 output layer.
626   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
627     there.
628   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
629     given the readfile fix.
630   * Add utf-8 testcases for readfile and htmlize.
631   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
632     safe.
633   * More utf-8 fixes from Recai, partly to things I broke above:
634     - The serious problem is that writefile() saves the content in undecoded
635       format in CGI, hence all (non-ascii) chars are corrupted permanently.
636     - Comment field in edit page is not decoded and all the non-ascii chars in
637       this field are corrupted as the result.  We should decode it as we do it
638       for the content.
639     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
640       character in print.
641   * New SVG logo from Recai.
642
643  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
644
645 ikiwiki (1.5) unstable; urgency=low
646
647   * Add --timeformat config option to allow changing how dates are displayed.
648     Note that as a side effect, dates will now be displayed using the local
649     timezone, not as GMT.
650   * More security review.
651   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
652     for some handy stuff like:
653     - Using links as a kind of tag; creating blog pages that list all pages
654       containing a given tag/link or not containing some other tag.
655     - Subscribing to mail notifications whenever a change is made to a page
656       that is a backlink of page foo. Ie, "Please notify me of changes in all
657       pages that link to my home page in the wiki"
658     - Locking any pages that are linked to from a particular page, so that
659       lists of locks can be exposed in the wiki.
660   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
661     when a todo item is done, instead of the previous moving it to a different
662     subdir.
663   * Allow pagetemplate plugins to override *anything* in the template.
664   * Add a meta plugin, which allows specifying various metadata about pages,
665     like license and author. It also allows for inserting html link and meta
666     tags into html, overriding the title, and adding hidden WikiLinks, which
667     can be useful when using link-based globbing for page categorisation.
668   * Remove preprocessor directives from inlined pages.
669   * Allow simple preprocessor directive values to be specified w/o quotes.
670   * Add support for using git instead of subversion as the RCS backend,
671     tremendous thanks to Recai Oktaş for this.
672   * Doc updates for git.
673   * Fix absolute url munging in rss generation to support https, ftp, etc urls
674     not just http urls.
675   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
676     utf-8 for edit and other fields, and for recentchanges. There may still
677     be utf-8 issues with the preferences page though.
678
679  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
680
681 ikiwiki (1.4) unstable; urgency=low
682
683   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
684     very strange way of enabling proper XHTML <br /> type tags. Output html
685     should be always valid again now.
686   * The page name and parent links has switched from using a <h1> to a styled
687     <span>, so pages can use <h1> internally instead of needing to use <h2>.
688   * Updated all of ikiwiki's own wiki pages for that.
689   * Add pagetemplate hook, which can be used by plugins that want to mess
690     around with adding new stuff to the page template.
691   * Remove headercontent; the search plugin now adds the search box to the
692     header by registering a pagetemplate hook, and other plugins should do
693     similarly.
694   * Rebuilding on upgrade to this version is recommended.
695   * Add a html validity check to the test suite, using the wdg-html-validator,
696     if available.
697   * Make the html valid when there is nothing in the actions list.
698   * Reordered some function call parameters for consistency.
699   * Enable full utf-8 support for page input and output.
700   * Add a workaround for markdown, which does not work well with utf-8
701     strings.
702   * --getctime had bitrotted (well I only ever used it the once so far..),
703     fix and make it a bit more flexible
704   * rcs_getctime is changed, now rather than needing to loop over all pages,
705     it should just use the rcs to get the ctime of the passed file.
706   * When inlining a page in another one, links from the inlined page are now
707     expanded the same as they are when rendering the inlined page as a
708     standalone page. So rather than being expanded from the POV of the
709     inlining page, they are expanded from the POV of the inlined page.
710
711     For example, a link from blog/foo to "bar" will now link to blog/bar
712     if it exists. Previously this needed to be a link explicitly to
713     "blog/bar"; such links will also continue to work.
714
715     (This was slightly complex to do as the link still has to be constructed
716     relative to the inlining page.)
717   * Make page edit textarea resize to fit browser window.
718   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
719     do not need a full rebuild, in order to update any basewiki pages.
720
721  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
722
723 ikiwiki (1.3) unstable; urgency=low
724
725   * Fix the preinst introduced in the last version. Closes: #367458
726
727  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
728
729 ikiwiki (1.2) unstable; urgency=low
730
731   * Remove dups from the brokenlinks list.
732   * Add libc6-dev to dependencies, needed to build wrappers.
733   * Install wikilist in correct location. Closes: #367371
734
735  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
736
737 ikiwiki (1.1) unstable; urgency=low
738
739   * Rename inlinepage to depends, so that it can be used to refer to more
740     dependency relationships than just inlining. This will require a rebuild
741     on upgrade to this version.
742   * Move the rss link, put it in the blogpost form if there is one and at the
743     top if not. This is both nicer because easier to find, and it cleans up
744     the code which had used inlinepage as a flag for adding the link later.
745   * Allow the depends GlobList to be built up from multiple sources (such as
746     plugins) during a page render.
747   * Which means that more than one blog is now supported to appear on a
748     single page. (With some limitations, like only the last one getting an
749     rss file.)
750   * Added a plugin system.
751   * Added a pagecount plugin, enabled by default.
752   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
753   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
754     backlinks when the backlinks hadn't really changed.
755   * Moved inline page support, rss generation etc into the inline plugin,
756     enabled by default.
757   * Added brokenlinks plugin, not enabled by default, but rather handy.
758   * Fix several broken links in the doc wiki.
759   * Smarter behavior when creating a page and a page of the same name (but
760     different location) already exists.
761   * Add an orphans plugin for finding pages that nothing links to.
762   * Removed backlinks page, which it turns out nothing used.
763   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
764     it, this will allow for adding a unit test suite.
765   * Add unit tests for several core functions, including globlist_match,
766     dirname, basename, bestlink, linkify, pagetitle, titlepage.
767   * Smart globlist merging.
768   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
769     to pave the way for adding other RCS support. This also changes the
770     setup files, where before they had svn => 1 or svn => 0, now they have
771     rcs => "svn" or rcs => "".
772   * Add a debian/NEWS file with upgrade notes.
773   * Load whatever rcs module is specified, so new ones can be just dropped in
774     as plugins and work. (Well, in theory.)
775   * Add some basic docs about writing RCS modules.
776   * Broke search capability out into a plugin, removed the --hyperestraier
777     switch.
778   * Added smiley plugin, nicely controlled and documented by the smileys page.
779   * Copied in some smileys from Moin Moin.
780   * Allow links of the form [[some page|page]], with whitespace in the link
781     text.
782   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
783     and --disable-plugin htmlscrubber.
784   * Allow discussion links on pages to be turned off with --no-discussion.
785   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
786   * Add some new config items to the estseek.conf template, which are needed
787     by hyperestraier 1.2.3.
788
789  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
790
791 ikiwiki (1.0) unstable; urgency=low
792
793   * First official release.
794
795  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400