* README.Debian: typo Closes: #388110
[ikiwiki] / debian / changelog
1 ikiwiki (1.27) UNRELEASED; urgency=low
2
3   * Add a googlecalendar plugin. A bit special-purpose, but it shows
4     one way to to deal with user-supplied content that could cause XSS
5     issues w/o the htmlscrubber, and won't survive the scrubber.
6   * Work on firming up the plugin interface:
7     - Plugins should not need to load IkiWiki::Render to get commonly
8       used functions, so moved some functions from there to IkiWiki.
9     - Picked out the set of functions and variables that most plugins
10       use, documented them, and made IkiWiki export them by default,
11       like a proper perl module should.
12     - Use the other functions at your own risk.
13     - This is not quite complete, I still have to decide whether to
14       export some other things.
15   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
16     referring to stuff now exported by the IkiWiki module.
17   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
18     to declare which version of the interface your plugin needs.
19   * Anyone with a third-party ikiwiki plugin is strongly encouraged
20     to make like changes to it and avoid use of non-exported symboles from
21     "IkiWiki::".
22   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
23   * Support hyperestradier version 1.4.2, which adds a new required phraseform
24     setting.
25   * If an inlined page has a permalink, link the page title to that.
26   * Patch from Recai to use utf8 when reading the setup file, so that
27     utf8 wikinames from there will be used properly.
28   * Patch from Recai to kill utf-8 on the wiki name when generating the
29     session cookie.
30   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
31   * Fix a baseurl problem in hyperestradier search results.
32   * Add a stub local.css to avoid problems with 404's.
33   * Patch from Recai to fix a wide character warning from the search plugin
34     during setup if the wikiname contains utf8.
35   * Yet another fix for those poor case-insensative OSX users.
36   * pagetemplate hooks are now also called when generating cgi pages.
37   * Add a favicon plugin, which simply adds a link tag for an icon to each
38     page (and cgis).
39   * Patch from James Westby to deal with the case where you're editing a
40     new page, hit cancel, and need to be redirected to somewhere sane.
41   * Various documentation improvements by various wiki users.
42   * Support Text::Markdown from CPAN, which has a different interface from
43     the original markdown or the one in Debian.
44   * Version the libcgi-session-perl dependency, some features that need
45     the new version are used in some cases (sslcookie).
46   * Numerous tla fixes from Clint.
47   * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
48     a multi-resolution favicon.ico.
49   * README.Debian: typo Closes: #388110
50
51  -- Joey Hess <joeyh@debian.org>  Mon, 18 Sep 2006 14:03:42 -0400
52
53 ikiwiki (1.26) unstable; urgency=low
54
55   * Add a missing -n to tla undo call.
56   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
57     writes before consuming its whole stdin. Avoid this deadlock.
58   * Fix alt tags for outline checkboxes.
59
60  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
61
62 ikiwiki (1.25) unstable; urgency=low
63
64   * Add proper waitpid calls for open2ed processes throughout to avoid
65     zombies; this hit htmltidy especially badly.
66   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
67     subversion repos and fixing some other issues.
68   * Add support for tla, contributed by Clint Adams. Closes: #385936
69   * Add support for mercurial, contributed by Emanuele Aina.
70   * Include <link rel> tag for RSS feeds, used by some aggregators and
71     firefox to find the feed.
72   * Add a linkmap plugin (requires graphviz).
73
74  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
75
76 ikiwiki (1.24) unstable; urgency=low
77
78   * Simplify the data structure returned by rcs_recentchanges to avoid
79     each rcs plugin needing to form complex strings on its own.
80   * Fix another destpage issue in the inline directive. Closes: #385512
81     again.
82
83  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
84
85 ikiwiki (1.23) unstable; urgency=low
86
87   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
88
89  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
90
91 ikiwiki (1.22) unstable; urgency=low
92
93   * Change how the stylesheet url is determined in the templates: Remove
94     STYLEURL and add BASEURL to all templates (some already had it). This
95     new more general variable can be used to link to other things (eg, images)
96     from the template, as well as stylesheets.
97   * Fix a bug introduced last version to do with nested inlines.
98   * Allow preprocessor directives to span multiple lines, both to make
99     long ones with lots of values easier to write, and to allow for ones with
100     multi-line quoted values.
101   * Allow preprocessor directives to contain python-like triple-quoted
102     text blocks, for easy nesting of quotes inside.
103   * Add a template plugin.
104   * Make pagespec merge code smarter about merging duplicate pagespecs.
105   * Patch from Jordà Polo to make Setup::Standard support hashes in config
106     files.
107   * Change order of linkify and preprocess; first preprocess and then linkify.
108     This allows passing a wikilink inside a parameter to a preprocessor
109     directive without it being expanded to html, and leaking out of the
110     parameter, which had required some non-obvious use of triple-quoting
111     to avoid. Note that any preprocessor plugins that output something
112     that looks like a wikilink will now have it treated as such; AFAIK
113     this doesn't change any behavior though except for the template plugin.
114   * Enable preprocessor directives when previewing an edit.
115   * Make all pages pull in a local.css style sheet, if present. This won't
116     be included in ikiwiki, but can be created to make local styling changes
117     w/o needing to merge in every new change to the distributed style.css.
118   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
119   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
120     from a different directory.
121   * Generalised preprocesser loop protection code.
122   * Patch from James Westby to allow a description to be set for rss feeds.
123   * Patch from James Westby to add a template for the search form.
124   * Added a ddate plugin.
125   * Patch from James Westby to add a --sslcookie switch, which forces
126     cookies to only be sent over ssl connections to avoid interception.
127   * Fix preferences page on anonok wikis; still need to sign in to get
128     to the preferences page.
129   * Add toc (table of contents) plugin.
130   * Change htmlize, format, and sanitize hooks to use named parameters.
131   * Patch from James Westby to add an actions option to inline; this
132     adds Edit and Discussion links at the end of blog entries.
133   * Due to some css changes, you'll want to rebuild your wiki on upgrade
134     to this version. Will be handled automatically by the deb.
135   * Add processed date to aggregate preprocessor directive status output.
136
137  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
138
139 ikiwiki (1.21) unstable; urgency=low
140
141   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
142   * If a page links to itself, mark up the link text in a span with
143     class="selflink" so that it can be styled. I don't have a useful style
144     defined for that though.
145   * Call filter hooks on inlined page content.
146   * Support inlining pages raw, rather than creating a blog.
147   * Clean up yes/no parameter parsing in inline plugin.
148   * Implemented better cycle detection in the inline plugin; nested inlines
149     will now work.
150   * Add a map plugin contributed by Alessandro Dotti Contra.
151   * Add otl format plugin, which handles files as created by vimoutliner.
152   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
153   * Add first draft at a Restructured Text (rst) plugin, by Sergio
154     Talens-Oliag. Note that this has many known issues -- see the caveats on
155     the plugin's page.
156   * Credit everyone who wrote a plugin on the plugins' wiki pages.
157   * Fix utf-8 in blog post form.
158
159  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
160
161 ikiwiki (1.20) unstable; urgency=low
162
163   * Relicense the templates and basewiki under the 2-clause BSD license.
164     Since these can easily become part of other people's websites, they
165     should be under as permissive a license as possible.
166   * Add --syslog config option, to log to the syslog.
167   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
168     transient failure to fork (which I've seen happen in the wild).
169   * Fix a bug in the aggregator introduced last version that caused all
170     aggregator state to be lost during a non-aggregating build.
171
172  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
173
174 ikiwiki (1.19) unstable; urgency=low
175
176   * Fix several related bugs in page type determination during online editing.
177   * Add some locking to prevent 2 aggregators from running at once.
178   * Fix an infinite loop in the aggregator when finding a unique filename.
179
180  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
181
182 ikiwiki (1.18) unstable; urgency=low
183
184   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
185   * Add --version.
186   * Man page format fixups.
187   * If the meta plugin overides the page title, set a title_overridden
188     variable in the template to true. This allows doing things with the
189     templates conditional on the title being overriden.
190   * Add a %pagecase which maps lower-case page names to the actual case
191     used in the filename. Use this in bestlinks calculation instead of
192     forcing the link to lowercase.
193   * Also use %pagecase in various other places that want to check if a page
194     with a given name exists.
195   * This means that links to pages with mixed case names will now work,
196     even if the link is in some other case mixture, and mixed case pages
197     should be fully supported throughout ikiwiki.
198   * Recommend rebuilding wikis on upgrade to this version.
199
200  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
201
202 ikiwiki (1.17) unstable; urgency=low
203
204   * Disable tidy generator tag.
205   * Move tidy back to sanitize hook, found out how to only show body.
206   * Turn off tidy indentation too.
207   * Turn on HTML::Template loop_context_vars; not actually used in stock
208     templates but can be useful for things like making comma-delimited lists
209     of tags or what have you.
210   * Remove <br> from end of aggregate preprocessor directive output.
211   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
212     case-sensative filesystems like OSX.
213   * Improve markdown loading. First, try to load it as a proper perl module,
214     in case it was installed as one. Then fall back to trying
215     /usr/bin/markdown.
216   * Document in install page how to install markdown, since it has no
217     installation procedure in the upstream tarball.
218   * Set die_on_bad_params => 0 for all templates, to allow users to modify
219     them without annoyances.
220   * Suck in the page content when generating an inline archive page, to work
221     around the meta plugin's lack of caching of title metadata across runs.
222
223  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
224
225 ikiwiki (1.16) unstable; urgency=low
226
227   * Try to handle relative links in aggregated feeds. However,
228     the current support is a crude hack due to limitations of XML::Feed:
229     xml:base is not supported, neither is Content-Location. And of course,
230     relative links in RSS feeds are ill-undefined..
231   * Make aggregator save permalinks and author name to pages as metadata.
232   * Add permalink and author support to meta plugin, affecting RSS feeds
233     and blog pages.
234   * Various CSS and formatting changes.
235   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
236   * Add xhtml files to the default prune regexp.
237   * Also generate rel=bookmark links for permalinks.
238   * Fix the htmltidy plugin, which wasn't working due my breaking it when
239     I added it..
240   * Don't run tidy with -xml as that fails if the input is not well-formed.
241     Run it with -asxhtml instead, so it will output well-formed xhtml no
242     matter what the input.
243   * Disable tidy warnings too.
244   * Add a new format hook, and make tidy use it, since tidy can really only
245     operate on and output complete html documents, not the body chunks
246     that sanitise gets.
247   * Fix dates in rss feeds if running localised, so they're still rfc 822.
248
249  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
250
251 ikiwiki (1.15) unstable; urgency=low
252
253   * Remove CDPATH and other env vars perl taint checking doesn't like.
254     Closes: #381279
255   * Added created_before and created_after PageSpec limits.
256
257  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
258
259 ikiwiki (1.14) unstable; urgency=low
260
261   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
262     by 10% or so.
263   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
264   * Added many unit tests for pagespec_match.
265
266  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
267
268 ikiwiki (1.13) unstable; urgency=low
269
270   * ikiwiki can now download and aggregate feeds with its new aggregate
271     plugin, so it's possible to implement a Planet using ikiwiki!
272   * Add a run_hooks function for the common task of running all hooks of a
273     given type.
274   * Add a savestate hook.
275   * Don't put blog post forms on pages if there's no cgiurl set.
276   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
277     --wrappers to do that.
278   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
279     to update pages that haven't changed on disk.
280   * Change meta tags to use html entity-escaped text for values, so that
281     quotes and such can be represented in title tags.
282   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
283     for the above.
284   * Make --rebuild also cause --aggregate to re-download and write aggregated
285     pages.
286   * Avoid outputting duplicate meta info.
287   * Include title metadata on aggregated posts for capitalised and un-munged
288     titles.
289   * Title metadata of inlined pages now shows up in blogs and rss feeds.
290   * Fix issue with unicode filenames and updating the hyper estradier search
291     index. (Aka Please Please Please, let that be the last one.)
292   * Patch from Roland Mas to support an rss=no parameter to inline directives.
293     Closes: #380743
294   * Renamed GlobLists to PageSpecs.
295   * PageSpecs can now include nested parens, "and", and "or". This remains
296     backwards compatible to the old GlobList format. It's implemented by
297     treating the GlobList as a very limited microlanguage that is transformed
298     to perl code that does the matching.
299   * The old GlobList format is deprecated, and I encourage users to switch to
300     using the new PageSpec format. Compatability with the old format will be
301     removed at some point, possibly by 2.0.
302   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
303   * Add support for creation_month and creation_year to PageSpec.
304     Closes: #380680
305   * Changes to index file encoding.
306
307  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
308
309 ikiwiki (1.12) unstable; urgency=low
310
311   "Viva l'Italia!"
312   * New pagestats plugin from Enrico, which can generate a table counting
313     the backlinks for each page, or a del.icio.us style cloud.
314   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
315     the wikiformat plugin works. Thanks, Emanuele Aina.
316   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
317     display, running them through pagetitle. This removes ugly underscores and
318     other gunk from the display, much nicer. You may want to rebuild your wiki
319     when upgrading to get the cleanup globally.
320   * Polygen plugin from Enrico.
321   * htmltidy plugin from Faidon.
322   * Locale patch from Faidon:
323     - Adds a locale setting to setup files.
324     - Proper local time, if the locale configuration option is used.
325     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
326       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
327       impossible.
328   * Add getopt hook type, this allows plugins to add new command-line options.
329   * Add --tagbase option to tag plugin.
330   * Add exclude option in setup files, works same as --exclude.
331   * Put categories in rss feeds for tagged items.
332   * Allow preprocessor directives to be expanded in inlined blog pages.
333     However, to avoid inlining loops etc, don't expand inline directives in
334     inlined pages.
335   * fortune plugin (trivial)
336   * Tag plugins according to type.
337
338  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
339
340 ikiwiki (1.11) unstable; urgency=low
341
342   * Patch from Enrico that
343     - Adds a tag plugin that allows more easily tagging pages.
344       The meta plugin can also still be used for that, but the tag plugin
345       also lists a page's tags at the bottom of the page.
346     - Allows preprocessor directives to have parameters with no specified
347       value.
348     - Fixes preprocessor directive parameter parsing so that
349       foo=bar baz now means "foo=bar" and a "baz" with no value.
350   * Run pagetemplate hooks when inlining pages so that inlined pages also
351     list their tags.
352   * Make all plugins with pagetemplate hooks check that variables exist
353     on the template before setting them, for robustness.
354   * Switch pagetemplate hooks to using named parameters.
355   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
356     This will be the page that a source page will be part of, which is
357     different than the source page for inlined pages.
358   * Audited all plugins to endure they pass (page, destpage) to htmllink
359     appropriatly. This means inlining of various plugins will not work
360     properly, with correct links generated.
361
362  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
363
364 ikiwiki (1.10) unstable; urgency=low
365
366   * Run page through any relevant filters when generating a page preview.
367   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
368     default throughout the wiki, not only on wikitext pages. Decided to call
369     this a feature, and split the camelcase support out into a separate plugin
370     that is independant of wikitext.
371   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
372
373  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
374
375 ikiwiki (1.9) unstable; urgency=low
376
377   * Improve display of parentlinks and page title of toplevel index page.
378   * Patch from Faidon to use svn --limit when possible for recentchanges,
379     speeds up recentchanges a lot for wikis with more history.
380   * Patch from Recai to fix utf8 issues in git backend.
381   * Add wikitext markup plugin, which supports ".wiki" pages written in the
382     original wiki syntax, CamelCase links and all.
383   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
384     support, to edit pages etc without a web server.
385   * Display CGI processing errors if present.
386   * Fix from Faidon for a XML parser issue that breaks utf-8 for
387     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
388     area, and also way slow.
389   * Match 'web commit from' in SVN and git, these are web commits too.
390     (Faidon)
391   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
392     readable and avoid future mistakes. The patch seems to work and for the
393     first time I have a UTF-8 username ;-) (Faidon)
394   * Use form->field consistently, not form->param.
395   * Patch from Recai to allow selection of page type when creating a new page.
396     Default page type is inherited from the link clicked on to create the new
397     page.
398
399  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
400
401 ikiwiki (1.8) unstable; urgency=low
402
403   * Fix orphans plugin to not count a link to a nonexistant page as a reason
404     for a page not being an orphan.
405   * Support pinging services such as Technorati using XML-RPC to notify them
406     about changes to rss feeds.
407   * Parse svn log as xml for improved utf8 and security. Note that this makes
408     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
409   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
410     flagged string even if the locale causes it to generate utf8 output,
411     so make sure to let perl know it should be handled as utf8. Also,
412     the optimised version used for standard time formats won't work if the
413     user has changed locale, so drop it. Thanks, Faidon Liambotis.
414   * Fix re-encoding of the comments field to utf8 if a commit fails
415     due to a conflict. Thanks, Faidon Liambotis.
416   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
417     Liambotis.
418   * Add insane double encode/decode to utf8 around call to markdown.
419     This works around a truely strange bug, which is apparently a bug in
420     perl, #376329. Also added a test case for it.
421   * Improve layout of edit page so formatting help link is always visible w/o
422     getting in the way of the preview.
423   * Centralised all calls to HTML::Template and force all the templates
424     to be read as utf8.
425   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
426   * Introduce add_plugins and disable_plugins config options in setup files.
427     This allows adding or removing plugins w/o overriding the whole list of
428     default plugins, which makes it easier to upgrade when new default plugins
429     are added.
430   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
431     default (of course!). Based on a patch by Faidon Liambotis.
432   * Add a html plugin, which can be used to write wikis in raw html,
433     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
434     defaults to not processing .html files, since w/o this plugin they would
435     be copied unsanitised. With this plugin, it will process and html
436     sanitise them, like any other page type.
437   * Rebuilding wrappers is necessary on upgrade to this version.
438   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
439     will be automatically done on all upgrades.
440   * Don't send pings if the wiki is being rebuilt.
441   * Work around very innefficient behavior in File::Spec::abs2rel. Result
442     is a savings of 2 pointless fork/execs per link calculation, which
443     results in ~25% speedup of ikiwiki building its own doc wiki, and
444     about 35% speedup displaying RecentChanges!
445   * Make RecentChanges use a table and some CSS, should be much more readable.
446     No code changes involved.
447   * Encode & in diffurl in examples, to conform to pedantic rules.
448   * Speed up RecentChanges by another 40% or so with some memoization.
449   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
450     in time to build the doc wiki.
451
452  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
453
454 ikiwiki (1.7) unstable; urgency=low
455
456   * Updated logo from Recai with some kerning and alingment tuning.
457   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
458     changed some output.
459   * Copyright update.
460
461  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
462
463 ikiwiki (1.6) unstable; urgency=low
464
465   * YA utf-8 patch from Recai, this time to fix previewing a page so that
466     the text in the input box is re-encoded back to utf-8.
467   * -CSD does not affect modules, so readfile() was not using the utf-8 input
468     layer, which led to lots of problems; make it force read files as utf-8.
469     Closes: #373203
470   * Note that as a consequence, this version of ikiwiki will actually try to
471     parse utf8 in source files for the first time, which may expose broken
472     utf8 in wiki sources that was hidden before. Most common will be
473     perl warnings like "utf8 "\xE9" does not map to Unicode"
474   * writefile() likewise needs to use the utf8 output layer.
475   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
476     there.
477   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
478     given the readfile fix.
479   * Add utf-8 testcases for readfile and htmlize.
480   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
481     safe.
482   * More utf-8 fixes from Recai, partly to things I broke above:
483     - The serious problem is that writefile() saves the content in undecoded
484       format in CGI, hence all (non-ascii) chars are corrupted permanently.
485     - Comment field in edit page is not decoded and all the non-ascii chars in
486       this field are corrupted as the result.  We should decode it as we do it
487       for the content.
488     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
489       character in print.
490   * New SVG logo from Recai.
491
492  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
493
494 ikiwiki (1.5) unstable; urgency=low
495
496   * Add --timeformat config option to allow changing how dates are displayed.
497     Note that as a side effect, dates will now be displayed using the local
498     timezone, not as GMT.
499   * More security review.
500   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
501     for some handy stuff like:
502     - Using links as a kind of tag; creating blog pages that list all pages
503       containing a given tag/link or not containing some other tag.
504     - Subscribing to mail notifications whenever a change is made to a page
505       that is a backlink of page foo. Ie, "Please notify me of changes in all
506       pages that link to my home page in the wiki"
507     - Locking any pages that are linked to from a particular page, so that
508       lists of locks can be exposed in the wiki.
509   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
510     when a todo item is done, instead of the previous moving it to a different
511     subdir.
512   * Allow pagetemplate plugins to override *anything* in the template.
513   * Add a meta plugin, which allows specifying various metadata about pages,
514     like license and author. It also allows for inserting html link and meta
515     tags into html, overriding the title, and adding hidden WikiLinks, which
516     can be useful when using link-based globbing for page categorisation.
517   * Remove preprocessor directives from inlined pages.
518   * Allow simple preprocessor directive values to be specified w/o quotes.
519   * Add support for using git instead of subversion as the RCS backend,
520     tremendous thanks to Recai Oktaş for this.
521   * Doc updates for git.
522   * Fix absolute url munging in rss generation to support https, ftp, etc urls
523     not just http urls.
524   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
525     utf-8 for edit and other fields, and for recentchanges. There may still
526     be utf-8 issues with the preferences page though.
527
528  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
529
530 ikiwiki (1.4) unstable; urgency=low
531
532   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
533     very strange way of enabling proper XHTML <br /> type tags. Output html
534     should be always valid again now.
535   * The page name and parent links has switched from using a <h1> to a styled
536     <span>, so pages can use <h1> internally instead of needing to use <h2>.
537   * Updated all of ikiwiki's own wiki pages for that.
538   * Add pagetemplate hook, which can be used by plugins that want to mess
539     around with adding new stuff to the page template.
540   * Remove headercontent; the search plugin now adds the search box to the
541     header by registering a pagetemplate hook, and other plugins should do
542     similarly.
543   * Rebuilding on upgrade to this version is recommended.
544   * Add a html validity check to the test suite, using the wdg-html-validator,
545     if available.
546   * Make the html valid when there is nothing in the actions list.
547   * Reordered some function call parameters for consistency.
548   * Enable full utf-8 support for page input and output.
549   * Add a workaround for markdown, which does not work well with utf-8
550     strings.
551   * --getctime had bitrotted (well I only ever used it the once so far..),
552     fix and make it a bit more flexible
553   * rcs_getctime is changed, now rather than needing to loop over all pages,
554     it should just use the rcs to get the ctime of the passed file.
555   * When inlining a page in another one, links from the inlined page are now
556     expanded the same as they are when rendering the inlined page as a
557     standalone page. So rather than being expanded from the POV of the
558     inlining page, they are expanded from the POV of the inlined page.
559
560     For example, a link from blog/foo to "bar" will now link to blog/bar
561     if it exists. Previously this needed to be a link explicitly to
562     "blog/bar"; such links will also continue to work.
563
564     (This was slightly complex to do as the link still has to be constructed
565     relative to the inlining page.)
566   * Make page edit textarea resize to fit browser window.
567   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
568     do not need a full rebuild, in order to update any basewiki pages.
569
570  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
571
572 ikiwiki (1.3) unstable; urgency=low
573
574   * Fix the preinst introduced in the last version. Closes: #367458
575
576  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
577
578 ikiwiki (1.2) unstable; urgency=low
579
580   * Remove dups from the brokenlinks list.
581   * Add libc6-dev to dependencies, needed to build wrappers.
582   * Install wikilist in correct location. Closes: #367371
583
584  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
585
586 ikiwiki (1.1) unstable; urgency=low
587
588   * Rename inlinepage to depends, so that it can be used to refer to more
589     dependency relationships than just inlining. This will require a rebuild
590     on upgrade to this version.
591   * Move the rss link, put it in the blogpost form if there is one and at the
592     top if not. This is both nicer because easier to find, and it cleans up
593     the code which had used inlinepage as a flag for adding the link later.
594   * Allow the depends GlobList to be built up from multiple sources (such as
595     plugins) during a page render.
596   * Which means that more than one blog is now supported to appear on a
597     single page. (With some limitations, like only the last one getting an
598     rss file.)
599   * Added a plugin system.
600   * Added a pagecount plugin, enabled by default.
601   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
602   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
603     backlinks when the backlinks hadn't really changed.
604   * Moved inline page support, rss generation etc into the inline plugin,
605     enabled by default.
606   * Added brokenlinks plugin, not enabled by default, but rather handy.
607   * Fix several broken links in the doc wiki.
608   * Smarter behavior when creating a page and a page of the same name (but
609     different location) already exists.
610   * Add an orphans plugin for finding pages that nothing links to.
611   * Removed backlinks page, which it turns out nothing used.
612   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
613     it, this will allow for adding a unit test suite.
614   * Add unit tests for several core functions, including globlist_match,
615     dirname, basename, bestlink, linkify, pagetitle, titlepage.
616   * Smart globlist merging.
617   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
618     to pave the way for adding other RCS support. This also changes the
619     setup files, where before they had svn => 1 or svn => 0, now they have
620     rcs => "svn" or rcs => "".
621   * Add a debian/NEWS file with upgrade notes.
622   * Load whatever rcs module is specified, so new ones can be just dropped in
623     as plugins and work. (Well, in theory.)
624   * Add some basic docs about writing RCS modules.
625   * Broke search capability out into a plugin, removed the --hyperestraier
626     switch.
627   * Added smiley plugin, nicely controlled and documented by the smileys page.
628   * Copied in some smileys from Moin Moin.
629   * Allow links of the form [[some page|page]], with whitespace in the link
630     text.
631   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
632     and --disable-plugin htmlscrubber.
633   * Allow discussion links on pages to be turned off with --no-discussion.
634   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
635   * Add some new config items to the estseek.conf template, which are needed
636     by hyperestraier 1.2.3.
637
638  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
639
640 ikiwiki (1.0) unstable; urgency=low
641
642   * First official release.
643
644  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400