* Fix absolute url munging in rss generation to support https, ftp, etc urls
[ikiwiki] / debian / changelog
1 ikiwiki (1.5) UNRELEASED; urgency=low
2
3   * Add --timeformat config option to allow changing how dates are displayed.
4     Note that as a side effect, dates will now be displayed using the local
5     timezone, not as GMT.
6   * More security review.
7   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
8     for some handy stuff like:
9     - Using links as a kind of tag; creating blog pages that list all pages
10       containing a given tag/link or not containing some other tag.
11     - Subscribing to mail notifications whenever a change is made to a page
12       that is a backlink of page foo. Ie, "Please notify me of changes in all
13       pages that link to my home page in the wiki"
14     - Locking any pages that are linked to from a particular page, so that
15       lists of locks can be exposed in the wiki.
16   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
17     when a todo item is done, instead of the previous moving it to a different
18     subdir.
19   * Allow pagetemplate plugins to override *anything* in the template.
20   * Add a meta plugin, which allows specifying various metadata about pages,
21     like license and author. It also allows for inserting html link and meta
22     tags into html, overriding the title, and adding hidden WikiLinks, which
23     can be useful when using link-based globbing for page categorisation.
24   * Remove preprocessor directives from inlined pages.
25   * Allow simple preprocessor directive values to be specified w/o quotes.
26   * Add support for using git instead of subversion as the RCS backend,
27     tremendous thanks to Recai Oktaş for this.
28   * Doc updates for git.
29   * Fix absolute url munging in rss generation to support https, ftp, etc urls
30     not just http urls.
31
32  -- Joey Hess <joeyh@debian.org>  Thu,  8 Jun 2006 02:05:57 -0400
33
34 ikiwiki (1.4) unstable; urgency=low
35
36   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
37     very strange way of enabling proper XHTML <br /> type tags. Output html
38     should be always valid again now.
39   * The page name and parent links has switched from using a <h1> to a styled
40     <span>, so pages can use <h1> internally instead of needing to use <h2>.
41   * Updated all of ikiwiki's own wiki pages for that.
42   * Add pagetemplate hook, which can be used by plugins that want to mess
43     around with adding new stuff to the page template.
44   * Remove headercontent; the search plugin now adds the search box to the
45     header by registering a pagetemplate hook, and other plugins should do
46     similarly.
47   * Rebuilding on upgrade to this version is recommended.
48   * Add a html validity check to the test suite, using the wdg-html-validator,
49     if available.
50   * Make the html valid when there is nothing in the actions list.
51   * Reordered some function call parameters for consistency.
52   * Enable full utf-8 support for page input and output.
53   * Add a workaround for markdown, which does not work well with utf-8
54     strings.
55   * --getctime had bitrotted (well I only ever used it the once so far..),
56     fix and make it a bit more flexible
57   * rcs_getctime is changed, now rather than needing to loop over all pages,
58     it should just use the rcs to get the ctime of the passed file.
59   * When inlining a page in another one, links from the inlined page are now
60     expanded the same as they are when rendering the inlined page as a
61     standalone page. So rather than being expanded from the POV of the
62     inlining page, they are expanded from the POV of the inlined page.
63
64     For example, a link from blog/foo to "bar" will now link to blog/bar
65     if it exists. Previously this needed to be a link explicitly to
66     "blog/bar"; such links will also continue to work.
67
68     (This was slightly complex to do as the link still has to be constructed
69     relative to the inlining page.)
70   * Make page edit textarea resize to fit browser window.
71   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
72     do not need a full rebuild, in order to update any basewiki pages.
73
74  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
75
76 ikiwiki (1.3) unstable; urgency=low
77
78   * Fix the preinst introduced in the last version. Closes: #367458
79
80  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
81
82 ikiwiki (1.2) unstable; urgency=low
83
84   * Remove dups from the brokenlinks list.
85   * Add libc6-dev to dependencies, needed to build wrappers.
86   * Install wikilist in correct location. Closes: #367371
87
88  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
89
90 ikiwiki (1.1) unstable; urgency=low
91
92   * Rename inlinepage to depends, so that it can be used to refer to more
93     dependency relationships than just inlining. This will require a rebuild
94     on upgrade to this version.
95   * Move the rss link, put it in the blogpost form if there is one and at the
96     top if not. This is both nicer because easier to find, and it cleans up
97     the code which had used inlinepage as a flag for adding the link later.
98   * Allow the depends GlobList to be built up from multiple sources (such as
99     plugins) during a page render.
100   * Which means that more than one blog is now supported to appear on a
101     single page. (With some limitations, like only the last one getting an
102     rss file.)
103   * Added a plugin system.
104   * Added a pagecount plugin, enabled by default.
105   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
106   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
107     backlinks when the backlinks hadn't really changed.
108   * Moved inline page support, rss generation etc into the inline plugin,
109     enabled by default.
110   * Added brokenlinks plugin, not enabled by default, but rather handy.
111   * Fix several broken links in the doc wiki.
112   * Smarter behavior when creating a page and a page of the same name (but
113     different location) already exists.
114   * Add an orphans plugin for finding pages that nothing links to.
115   * Removed backlinks page, which it turns out nothing used.
116   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
117     it, this will allow for adding a unit test suite.
118   * Add unit tests for several core functions, including globlist_match,
119     dirname, basename, bestlink, linkify, pagetitle, titlepage.
120   * Smart globlist merging.
121   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
122     to pave the way for adding other RCS support. This also changes the
123     setup files, where before they had svn => 1 or svn => 0, now they have
124     rcs => "svn" or rcs => "".
125   * Add a debian/NEWS file with upgrade notes.
126   * Load whatever rcs module is specified, so new ones can be just dropped in
127     as plugins and work. (Well, in theory.)
128   * Add some basic docs about writing RCS modules.
129   * Broke search capability out into a plugin, removed the --hyperestraier
130     switch.
131   * Added smiley plugin, nicely controlled and documented by the smileys page.
132   * Copied in some smileys from Moin Moin.
133   * Allow links of the form [[some page|page]], with whitespace in the link
134     text.
135   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
136     and --disable-plugin htmlscrubber.
137   * Allow discussion links on pages to be turned off with --no-discussion.
138   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
139   * Add some new config items to the estseek.conf template, which are needed
140     by hyperestraier 1.2.3.
141
142  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
143
144 ikiwiki (1.0) unstable; urgency=low
145
146   * First official release.
147
148  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400