add a poll plugin
[ikiwiki] / debian / changelog
1 ikiwiki (1.34) UNRELEASED; urgency=low
2
3   * Add an openid plugin to support logging in using OpenID.
4   * Web commits by OpenID users will record the full OpenID url for the user,
5     but in recentchanges, these urls will be converted to a simplified display
6     form+link.
7   * Modified svn, git, tla backends to recognise such web commits.
8   * Move httpauth support to a plugin.
9   * Add openidsignup config option.
10   * Make the openid plugin support the callbacks from myopenid.com via its
11     affiliate program.
12   * Add toggle plugin.
13   * Introduce the goodstuff bundle. This is a kind of plugin, that just enables
14     many other plugins. It's an easy way to boost ikiwiki from its default,
15     basic wiki, to a full-featured wiki, without manually picking the right
16     set of plugins. New plugins will be added to goodstuff from time to
17     time.
18   * Change how post signin actions are propigated through the signin process;
19     they're now stored in the session.
20   * Add optional "desc" parameter to shortcut definitions.
21   * Avoid locking the wiki at all when handling some basic cgi stuff
22     (searches, recentchanges).
23   * Add "last" parameter to hook function. Very basic ordering, and hopefully
24     nothing more spohisticated will be needed.
25   * Add formbuilder_setup and formbuilder hooks.
26   * Split out a passwordauth module, that holds all the traditional password
27     based authentication etc code. It's enabled by default, but can be disabled
28     if you want only openid or some other auth method.
29   * Rename ikiwiki.pl so MakeMaker doesn't see it, and install it.
30   * Add some code to the build system that tries to determine if the
31     lib installation directory is in @INC. If it's not, munge ikiwiki
32     to hardcode the path to the lib directory. This should allow installing
33     ikiwiki in nonstandard locations, including home directories, by just
34     setting PREFIX at build time.
35   * Fix nested examples directory in deb.
36   * Add a test suite for the mercurial backend, contributed by Emanuele Aina.
37   * Add a test suite for the svn backend.
38   * Daemonize before sending RPC pings, since that can take a while
39     and/or hang.
40   * Daemonize before sending commit mails, as that can also take a long
41     time/hang if the mail server is unhappy.
42   * Factor out commit mail sending code into new function.
43   * Change rcs_commit, it is now passed the name of the user doing the commit
44     and their IP address, and needs to construct its own commit message
45     containing them, or do something more appropriate for the given RCS.
46   * Add softwaresite example.
47   * Add a poll plugin.
48   * Add quick mode for archive page generation.
49
50  -- Joey Hess <joeyh@debian.org>  Thu, 23 Nov 2006 17:13:32 -0500
51
52 ikiwiki (1.33) unstable; urgency=low
53
54   * Fix issue with aggregate plugin updating expired pages.
55   * Avoid syntax errors in templates used by the template plugin crashing
56     ikiwiki.
57   * Enable utf8 file IO in aggregate plugin.
58   * Fix some issues with the new registration form.
59   * Patch from Ethan Glasser Camp to add a skip option to the inline plugin.
60   * Make sure to check for errors from every eval.
61   * Fix img plugin's handling of adding dependencies for images that do not
62     yet exist.
63   * Work around a strange bug in CGI::FormBuilder 3.0401 that makes
64     FORM-SUBMIT unusable on customised formbuilder templates. For now,
65     hardcode the submit buttons in editpage.tmpl instead of using the
66     template variable, which is ok, since the buttons are static.
67   * Work with hyperestraier 1.4.9.
68
69  -- Joey Hess <joeyh@debian.org>  Wed, 15 Nov 2006 18:32:26 -0500
70
71 ikiwiki (1.32) unstable; urgency=low
72
73   * Add a separate pass to find page links, and only render each page once,
74     instead of over and over. Typical speedup is ~4x. Max possible speedup:
75     8x.
76   * Add "scan" parameter to hook(), which is used to make the hook be called
77     during the scanning pass, as well as the render pass. The meta and tag
78     plugins need to use the new scan parameter, so will any others that modify
79     %links.
80   * Now that links are calculated in a separate pass, it can also
81     precalculate backlinks in one pass, which is O(N^2) instead of the
82     previous code that was O(N^3). A very nice speedup for wikis with lots
83     (thousands) of pages.
84   * Stylish update to the ikiwiki logo, thanks to Recai Oktaş and Selçuk
85     Erdem.
86   * Add a default stylesheet entry for the pagecloud.
87   * Add examples page with some examples of things that can be done using
88     ikiwiki, like a weblog. The examples can be copied into a user's wiki
89     for a quick start, without needing to learn everything about how to put
90     them together.
91   * Install the source of the examples into /usr/share/doc/ikiwiki/examples.
92   * Add perlmagick to build-depends so syntax check of img plugin works.
93     Closes: #396702
94   * Improve login/register process, the login dialog has only name and
95     password fields, which allows more web browsers to regognise it as a login
96     field, and is less confusing.
97   * Implemented expiry options for aggregate plugin.
98   * Use precalculated backlinks info when determining if files need an update
99     due to a page they link to being added/removed. Mostly significant if
100     there are lots of pages.
101   * Remove duplicate link info when saving index. In some cases it could
102     pile up rather badly. (Probably not the best way to deal with this
103     problem.)
104   * Patch from James Westby to support podcasting, photoblogging, vidcasting,
105     or what have you, by creating enclosures for non-page items that are
106     included in feeds.
107
108  -- Joey Hess <joeyh@debian.org>  Fri,  3 Nov 2006 14:46:37 -0500
109
110 ikiwiki (1.31) unstable; urgency=low
111
112   * Patch from Pawel Tecza to cp -a the templates in the Makefile.
113   * Change the rss feed title from the wikiname to the page title, with
114     an exception for the wiki's toplevel index page, which will still use the
115     wikiname as the feed title.
116     Overriding the page title with meta title already overrode the rss feed
117     tittle.
118   * Add an img plugin, based on Christian Mock's img plugin, but stripped
119     down to the bare essentials. Useful for handling large images on websites.
120   * Sanitize possibly problimatic characters out of the polygen grammar names,
121     just in case. Should not be exploitable anyway, since it only tries to run
122     polygen after finding the specified grammar file.
123   * Add missing dependency on the URI perl module.
124   * Add basic spam fighting tool for admins: An admin's prefs page now allows
125     editing a list of banned users.
126
127  -- Joey Hess <joeyh@debian.org>  Fri, 27 Oct 2006 23:16:33 -0400
128
129 ikiwiki (1.30) unstable; urgency=low
130
131   * Add no_override parameter to hook().
132   * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
133     plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
134     can be configured using a page in wiki.
135   * Fix support for --pingurl at the command line.
136   * Fix a subtle bug in will_render that broke some builds, by only clearing
137     items from renderedfiles the first time per build.
138   * Wrap entire technortati ping operation in an eval to catch all possible
139     failure modes, after I observed a simple ->value crashing ikiwiki when
140     a ping failed.
141
142  -- Joey Hess <joeyh@debian.org>  Mon, 16 Oct 2006 15:17:38 -0400
143
144 ikiwiki (1.29) unstable; urgency=low
145
146   * Patch from Paul Tötterman to use CP in the Makefile.
147   * Patch from Alec Berryman adding a http_auth config item that allows
148     using HTTP Authentication instead of ikiwiki's built in authentication.
149     Useful for eg, large sites with their own previously existing user auth
150     setup. Closes: #384534
151   * Change %renderedfiles to store an array of files rendered from a given
152     source file, to allow tracking of extra rendered files like rss feeds.
153   * Note that plugins that accessed this variable will need to be updated!
154     The plugin interface has been increased to version 1.01 for this change.
155     As few plugins use %renderedfiles I haven't done anything else to ensure
156     compatability of old plugins.
157   * Add will_render function to the plugin interface, used to register that a
158     page renders a destination file, and do some security checks. Previously
159     but no longer rendered files will be cleaned up.
160   * Use will_render in the inline and linkmap plugins.
161   * You will need to rebuild your wiki on upgrade to this version.
162   * Atom feed support based on a patch by Clint Adams.
163   * Add feeds=no option to inline preprocessor directive to turn off all types
164     of feeds.
165   * $IkiWiki::version now holds the program version, and is accessible to
166     plugins.
167   * Make the aggregate plugin emphasize error messages.
168   * Patch from Recai to limit recentchanges to displaying max 10 files for a
169     given changeset (to avoid large number of file changes excessively
170     bloating the page).
171
172  -- Joey Hess <joeyh@debian.org>  Fri, 13 Oct 2006 23:14:28 -0400
173
174 ikiwiki (1.28) unstable; urgency=low
175
176   * inline: Add ability to sort by page name, based on a patch from
177     Benjamin A'Lee.
178   * Fix a forkbomb in various calls to IPC::Open2, which has a highly
179     braindead interface. Closes: #389383
180   * Don't rm -rf ikiwiki on distclean, since a) there's no such file
181     and b) those poor Mac OSX users and their case insensative files!
182   * Don't fail syntax check if Text::Typography isn't installed.
183     Closes: #389406
184
185  -- Joey Hess <joeyh@debian.org>  Tue, 26 Sep 2006 02:08:17 -0400
186
187 ikiwiki (1.27) unstable; urgency=low
188
189   * Work on firming up the plugin interface:
190     - Plugins should not need to load IkiWiki::Render to get commonly
191       used functions, so moved some functions from there to IkiWiki.
192     - Picked out the set of functions and variables that most plugins
193       use, documented them, and made IkiWiki export them by default,
194       like a proper perl module should.
195     - Use the other functions at your own risk.
196     - This is not quite complete, I still have to decide whether to
197       export some other things.
198   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
199     referring to stuff now exported by the IkiWiki module.
200   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
201     to declare which version of the interface your plugin needs.
202   * Anyone with a third-party ikiwiki plugin is strongly encouraged
203     to make like changes to it and avoid use of non-exported symbols from
204     "IkiWiki::".
205   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
206   * Support hyperestradier version 1.4.2, which adds a new required phraseform
207     setting.
208   * If an inlined page has a permalink, link the page title to that.
209   * Patch from Recai to use utf8 when reading the setup file, so that
210     utf8 wikinames from there will be used properly.
211   * Patch from Recai to kill utf-8 on the wiki name when generating the
212     session cookie.
213   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
214   * Fix a baseurl problem in hyperestradier search results.
215   * Add a stub local.css to avoid problems with 404's.
216   * Patch from Recai to fix a wide character warning from the search plugin
217     during setup if the wikiname contains utf8.
218   * Yet another fix for those poor case-insensative OS X users.
219   * pagetemplate hooks are now also called when generating cgi pages.
220   * Add a favicon plugin, which simply adds a link tag for an icon to each
221     page (and cgis).
222   * Patch from James Westby to deal with the case where you're editing a
223     new page, hit cancel, and need to be redirected to somewhere sane.
224   * Various documentation improvements by various wiki users.
225   * Support Text::Markdown from CPAN, which has a different interface from
226     the original markdown or the one in Debian.
227   * Version the libcgi-session-perl dependency, some features that need
228     the new version are used in some cases (sslcookie).
229   * Numerous tla fixes from Clint.
230   * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
231     a multi-resolution favicon.ico.
232   * README.Debian: typo Closes: #388110
233   * chomp trailing newline at the end of templates read in by the template
234     plugin, to allow use of the template preprocessor directive in
235     whitespace-sensative situations. Closes: #387073
236   * Patch from James Westby to make the location of the estseek.cgi script
237     configurable.
238   * Add typography (SmartyPants) plugin by Recai.
239   * Add --render mode, which can be used to preview an edit at the command
240     line by test rendering a single page.
241   * Add a googlecalendar plugin. A bit special-purpose, but it shows
242     one way to to deal with user-supplied content that could cause XSS
243     issues w/o the htmlscrubber, and won't survive the scrubber.
244
245  -- Joey Hess <joeyh@debian.org>  Sun, 24 Sep 2006 00:02:21 -0400
246
247 ikiwiki (1.26) unstable; urgency=low
248
249   * Add a missing -n to tla undo call.
250   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
251     writes before consuming its whole stdin. Avoid this deadlock.
252   * Fix alt tags for outline checkboxes.
253
254  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
255
256 ikiwiki (1.25) unstable; urgency=low
257
258   * Add proper waitpid calls for open2ed processes throughout to avoid
259     zombies; this hit htmltidy especially badly.
260   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
261     subversion repos and fixing some other issues.
262   * Add support for tla, contributed by Clint Adams. Closes: #385936
263   * Add support for mercurial, contributed by Emanuele Aina.
264   * Include <link rel> tag for RSS feeds, used by some aggregators and
265     firefox to find the feed.
266   * Add a linkmap plugin (requires graphviz).
267
268  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
269
270 ikiwiki (1.24) unstable; urgency=low
271
272   * Simplify the data structure returned by rcs_recentchanges to avoid
273     each rcs plugin needing to form complex strings on its own.
274   * Fix another destpage issue in the inline directive. Closes: #385512
275     again.
276
277  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
278
279 ikiwiki (1.23) unstable; urgency=low
280
281   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
282
283  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
284
285 ikiwiki (1.22) unstable; urgency=low
286
287   * Change how the stylesheet url is determined in the templates: Remove
288     STYLEURL and add BASEURL to all templates (some already had it). This
289     new more general variable can be used to link to other things (eg, images)
290     from the template, as well as stylesheets.
291   * Fix a bug introduced last version to do with nested inlines.
292   * Allow preprocessor directives to span multiple lines, both to make
293     long ones with lots of values easier to write, and to allow for ones with
294     multi-line quoted values.
295   * Allow preprocessor directives to contain python-like triple-quoted
296     text blocks, for easy nesting of quotes inside.
297   * Add a template plugin.
298   * Make pagespec merge code smarter about merging duplicate pagespecs.
299   * Patch from Jordà Polo to make Setup::Standard support hashes in config
300     files.
301   * Change order of linkify and preprocess; first preprocess and then linkify.
302     This allows passing a wikilink inside a parameter to a preprocessor
303     directive without it being expanded to html, and leaking out of the
304     parameter, which had required some non-obvious use of triple-quoting
305     to avoid. Note that any preprocessor plugins that output something
306     that looks like a wikilink will now have it treated as such; AFAIK
307     this doesn't change any behavior though except for the template plugin.
308   * Enable preprocessor directives when previewing an edit.
309   * Make all pages pull in a local.css style sheet, if present. This won't
310     be included in ikiwiki, but can be created to make local styling changes
311     w/o needing to merge in every new change to the distributed style.css.
312   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
313   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
314     from a different directory.
315   * Generalised preprocesser loop protection code.
316   * Patch from James Westby to allow a description to be set for rss feeds.
317   * Patch from James Westby to add a template for the search form.
318   * Added a ddate plugin.
319   * Patch from James Westby to add a --sslcookie switch, which forces
320     cookies to only be sent over ssl connections to avoid interception.
321   * Fix preferences page on anonok wikis; still need to sign in to get
322     to the preferences page.
323   * Add toc (table of contents) plugin.
324   * Change htmlize, format, and sanitize hooks to use named parameters.
325   * Patch from James Westby to add an actions option to inline; this
326     adds Edit and Discussion links at the end of blog entries.
327   * Due to some css changes, you'll want to rebuild your wiki on upgrade
328     to this version. Will be handled automatically by the deb.
329   * Add processed date to aggregate preprocessor directive status output.
330
331  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
332
333 ikiwiki (1.21) unstable; urgency=low
334
335   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
336   * If a page links to itself, mark up the link text in a span with
337     class="selflink" so that it can be styled. I don't have a useful style
338     defined for that though.
339   * Call filter hooks on inlined page content.
340   * Support inlining pages raw, rather than creating a blog.
341   * Clean up yes/no parameter parsing in inline plugin.
342   * Implemented better cycle detection in the inline plugin; nested inlines
343     will now work.
344   * Add a map plugin contributed by Alessandro Dotti Contra.
345   * Add otl format plugin, which handles files as created by vimoutliner.
346   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
347   * Add first draft at a Restructured Text (rst) plugin, by Sergio
348     Talens-Oliag. Note that this has many known issues -- see the caveats on
349     the plugin's page.
350   * Credit everyone who wrote a plugin on the plugins' wiki pages.
351   * Fix utf-8 in blog post form.
352
353  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
354
355 ikiwiki (1.20) unstable; urgency=low
356
357   * Relicense the templates and basewiki under the 2-clause BSD license.
358     Since these can easily become part of other people's websites, they
359     should be under as permissive a license as possible.
360   * Add --syslog config option, to log to the syslog.
361   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
362     transient failure to fork (which I've seen happen in the wild).
363   * Fix a bug in the aggregator introduced last version that caused all
364     aggregator state to be lost during a non-aggregating build.
365
366  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
367
368 ikiwiki (1.19) unstable; urgency=low
369
370   * Fix several related bugs in page type determination during online editing.
371   * Add some locking to prevent 2 aggregators from running at once.
372   * Fix an infinite loop in the aggregator when finding a unique filename.
373
374  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
375
376 ikiwiki (1.18) unstable; urgency=low
377
378   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
379   * Add --version.
380   * Man page format fixups.
381   * If the meta plugin overides the page title, set a title_overridden
382     variable in the template to true. This allows doing things with the
383     templates conditional on the title being overriden.
384   * Add a %pagecase which maps lower-case page names to the actual case
385     used in the filename. Use this in bestlinks calculation instead of
386     forcing the link to lowercase.
387   * Also use %pagecase in various other places that want to check if a page
388     with a given name exists.
389   * This means that links to pages with mixed case names will now work,
390     even if the link is in some other case mixture, and mixed case pages
391     should be fully supported throughout ikiwiki.
392   * Recommend rebuilding wikis on upgrade to this version.
393
394  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
395
396 ikiwiki (1.17) unstable; urgency=low
397
398   * Disable tidy generator tag.
399   * Move tidy back to sanitize hook, found out how to only show body.
400   * Turn off tidy indentation too.
401   * Turn on HTML::Template loop_context_vars; not actually used in stock
402     templates but can be useful for things like making comma-delimited lists
403     of tags or what have you.
404   * Remove <br> from end of aggregate preprocessor directive output.
405   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
406     case-sensative filesystems like OSX.
407   * Improve markdown loading. First, try to load it as a proper perl module,
408     in case it was installed as one. Then fall back to trying
409     /usr/bin/markdown.
410   * Document in install page how to install markdown, since it has no
411     installation procedure in the upstream tarball.
412   * Set die_on_bad_params => 0 for all templates, to allow users to modify
413     them without annoyances.
414   * Suck in the page content when generating an inline archive page, to work
415     around the meta plugin's lack of caching of title metadata across runs.
416
417  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
418
419 ikiwiki (1.16) unstable; urgency=low
420
421   * Try to handle relative links in aggregated feeds. However,
422     the current support is a crude hack due to limitations of XML::Feed:
423     xml:base is not supported, neither is Content-Location. And of course,
424     relative links in RSS feeds are ill-undefined..
425   * Make aggregator save permalinks and author name to pages as metadata.
426   * Add permalink and author support to meta plugin, affecting RSS feeds
427     and blog pages.
428   * Various CSS and formatting changes.
429   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
430   * Add xhtml files to the default prune regexp.
431   * Also generate rel=bookmark links for permalinks.
432   * Fix the htmltidy plugin, which wasn't working due my breaking it when
433     I added it..
434   * Don't run tidy with -xml as that fails if the input is not well-formed.
435     Run it with -asxhtml instead, so it will output well-formed xhtml no
436     matter what the input.
437   * Disable tidy warnings too.
438   * Add a new format hook, and make tidy use it, since tidy can really only
439     operate on and output complete html documents, not the body chunks
440     that sanitise gets.
441   * Fix dates in rss feeds if running localised, so they're still rfc 822.
442
443  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
444
445 ikiwiki (1.15) unstable; urgency=low
446
447   * Remove CDPATH and other env vars perl taint checking doesn't like.
448     Closes: #381279
449   * Added created_before and created_after PageSpec limits.
450
451  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
452
453 ikiwiki (1.14) unstable; urgency=low
454
455   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
456     by 10% or so.
457   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
458   * Added many unit tests for pagespec_match.
459
460  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
461
462 ikiwiki (1.13) unstable; urgency=low
463
464   * ikiwiki can now download and aggregate feeds with its new aggregate
465     plugin, so it's possible to implement a Planet using ikiwiki!
466   * Add a run_hooks function for the common task of running all hooks of a
467     given type.
468   * Add a savestate hook.
469   * Don't put blog post forms on pages if there's no cgiurl set.
470   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
471     --wrappers to do that.
472   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
473     to update pages that haven't changed on disk.
474   * Change meta tags to use html entity-escaped text for values, so that
475     quotes and such can be represented in title tags.
476   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
477     for the above.
478   * Make --rebuild also cause --aggregate to re-download and write aggregated
479     pages.
480   * Avoid outputting duplicate meta info.
481   * Include title metadata on aggregated posts for capitalised and un-munged
482     titles.
483   * Title metadata of inlined pages now shows up in blogs and rss feeds.
484   * Fix issue with unicode filenames and updating the hyper estradier search
485     index. (Aka Please Please Please, let that be the last one.)
486   * Patch from Roland Mas to support an rss=no parameter to inline directives.
487     Closes: #380743
488   * Renamed GlobLists to PageSpecs.
489   * PageSpecs can now include nested parens, "and", and "or". This remains
490     backwards compatible to the old GlobList format. It's implemented by
491     treating the GlobList as a very limited microlanguage that is transformed
492     to perl code that does the matching.
493   * The old GlobList format is deprecated, and I encourage users to switch to
494     using the new PageSpec format. Compatability with the old format will be
495     removed at some point, possibly by 2.0.
496   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
497   * Add support for creation_month and creation_year to PageSpec.
498     Closes: #380680
499   * Changes to index file encoding.
500
501  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
502
503 ikiwiki (1.12) unstable; urgency=low
504
505   "Viva l'Italia!"
506   * New pagestats plugin from Enrico, which can generate a table counting
507     the backlinks for each page, or a del.icio.us style cloud.
508   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
509     the wikiformat plugin works. Thanks, Emanuele Aina.
510   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
511     display, running them through pagetitle. This removes ugly underscores and
512     other gunk from the display, much nicer. You may want to rebuild your wiki
513     when upgrading to get the cleanup globally.
514   * Polygen plugin from Enrico.
515   * htmltidy plugin from Faidon.
516   * Locale patch from Faidon:
517     - Adds a locale setting to setup files.
518     - Proper local time, if the locale configuration option is used.
519     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
520       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
521       impossible.
522   * Add getopt hook type, this allows plugins to add new command-line options.
523   * Add --tagbase option to tag plugin.
524   * Add exclude option in setup files, works same as --exclude.
525   * Put categories in rss feeds for tagged items.
526   * Allow preprocessor directives to be expanded in inlined blog pages.
527     However, to avoid inlining loops etc, don't expand inline directives in
528     inlined pages.
529   * fortune plugin (trivial)
530   * Tag plugins according to type.
531
532  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
533
534 ikiwiki (1.11) unstable; urgency=low
535
536   * Patch from Enrico that
537     - Adds a tag plugin that allows more easily tagging pages.
538       The meta plugin can also still be used for that, but the tag plugin
539       also lists a page's tags at the bottom of the page.
540     - Allows preprocessor directives to have parameters with no specified
541       value.
542     - Fixes preprocessor directive parameter parsing so that
543       foo=bar baz now means "foo=bar" and a "baz" with no value.
544   * Run pagetemplate hooks when inlining pages so that inlined pages also
545     list their tags.
546   * Make all plugins with pagetemplate hooks check that variables exist
547     on the template before setting them, for robustness.
548   * Switch pagetemplate hooks to using named parameters.
549   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
550     This will be the page that a source page will be part of, which is
551     different than the source page for inlined pages.
552   * Audited all plugins to endure they pass (page, destpage) to htmllink
553     appropriatly. This means inlining of various plugins will not work
554     properly, with correct links generated.
555
556  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
557
558 ikiwiki (1.10) unstable; urgency=low
559
560   * Run page through any relevant filters when generating a page preview.
561   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
562     default throughout the wiki, not only on wikitext pages. Decided to call
563     this a feature, and split the camelcase support out into a separate plugin
564     that is independant of wikitext.
565   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
566
567  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
568
569 ikiwiki (1.9) unstable; urgency=low
570
571   * Improve display of parentlinks and page title of toplevel index page.
572   * Patch from Faidon to use svn --limit when possible for recentchanges,
573     speeds up recentchanges a lot for wikis with more history.
574   * Patch from Recai to fix utf8 issues in git backend.
575   * Add wikitext markup plugin, which supports ".wiki" pages written in the
576     original wiki syntax, CamelCase links and all.
577   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
578     support, to edit pages etc without a web server.
579   * Display CGI processing errors if present.
580   * Fix from Faidon for a XML parser issue that breaks utf-8 for
581     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
582     area, and also way slow.
583   * Match 'web commit from' in SVN and git, these are web commits too.
584     (Faidon)
585   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
586     readable and avoid future mistakes. The patch seems to work and for the
587     first time I have a UTF-8 username ;-) (Faidon)
588   * Use form->field consistently, not form->param.
589   * Patch from Recai to allow selection of page type when creating a new page.
590     Default page type is inherited from the link clicked on to create the new
591     page.
592
593  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
594
595 ikiwiki (1.8) unstable; urgency=low
596
597   * Fix orphans plugin to not count a link to a nonexistant page as a reason
598     for a page not being an orphan.
599   * Support pinging services such as Technorati using XML-RPC to notify them
600     about changes to rss feeds.
601   * Parse svn log as xml for improved utf8 and security. Note that this makes
602     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
603   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
604     flagged string even if the locale causes it to generate utf8 output,
605     so make sure to let perl know it should be handled as utf8. Also,
606     the optimised version used for standard time formats won't work if the
607     user has changed locale, so drop it. Thanks, Faidon Liambotis.
608   * Fix re-encoding of the comments field to utf8 if a commit fails
609     due to a conflict. Thanks, Faidon Liambotis.
610   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
611     Liambotis.
612   * Add insane double encode/decode to utf8 around call to markdown.
613     This works around a truely strange bug, which is apparently a bug in
614     perl, #376329. Also added a test case for it.
615   * Improve layout of edit page so formatting help link is always visible w/o
616     getting in the way of the preview.
617   * Centralised all calls to HTML::Template and force all the templates
618     to be read as utf8.
619   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
620   * Introduce add_plugins and disable_plugins config options in setup files.
621     This allows adding or removing plugins w/o overriding the whole list of
622     default plugins, which makes it easier to upgrade when new default plugins
623     are added.
624   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
625     default (of course!). Based on a patch by Faidon Liambotis.
626   * Add a html plugin, which can be used to write wikis in raw html,
627     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
628     defaults to not processing .html files, since w/o this plugin they would
629     be copied unsanitised. With this plugin, it will process and html
630     sanitise them, like any other page type.
631   * Rebuilding wrappers is necessary on upgrade to this version.
632   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
633     will be automatically done on all upgrades.
634   * Don't send pings if the wiki is being rebuilt.
635   * Work around very innefficient behavior in File::Spec::abs2rel. Result
636     is a savings of 2 pointless fork/execs per link calculation, which
637     results in ~25% speedup of ikiwiki building its own doc wiki, and
638     about 35% speedup displaying RecentChanges!
639   * Make RecentChanges use a table and some CSS, should be much more readable.
640     No code changes involved.
641   * Encode & in diffurl in examples, to conform to pedantic rules.
642   * Speed up RecentChanges by another 40% or so with some memoization.
643   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
644     in time to build the doc wiki.
645
646  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
647
648 ikiwiki (1.7) unstable; urgency=low
649
650   * Updated logo from Recai with some kerning and alingment tuning.
651   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
652     changed some output.
653   * Copyright update.
654
655  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
656
657 ikiwiki (1.6) unstable; urgency=low
658
659   * YA utf-8 patch from Recai, this time to fix previewing a page so that
660     the text in the input box is re-encoded back to utf-8.
661   * -CSD does not affect modules, so readfile() was not using the utf-8 input
662     layer, which led to lots of problems; make it force read files as utf-8.
663     Closes: #373203
664   * Note that as a consequence, this version of ikiwiki will actually try to
665     parse utf8 in source files for the first time, which may expose broken
666     utf8 in wiki sources that was hidden before. Most common will be
667     perl warnings like "utf8 "\xE9" does not map to Unicode"
668   * writefile() likewise needs to use the utf8 output layer.
669   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
670     there.
671   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
672     given the readfile fix.
673   * Add utf-8 testcases for readfile and htmlize.
674   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
675     safe.
676   * More utf-8 fixes from Recai, partly to things I broke above:
677     - The serious problem is that writefile() saves the content in undecoded
678       format in CGI, hence all (non-ascii) chars are corrupted permanently.
679     - Comment field in edit page is not decoded and all the non-ascii chars in
680       this field are corrupted as the result.  We should decode it as we do it
681       for the content.
682     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
683       character in print.
684   * New SVG logo from Recai.
685
686  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
687
688 ikiwiki (1.5) unstable; urgency=low
689
690   * Add --timeformat config option to allow changing how dates are displayed.
691     Note that as a side effect, dates will now be displayed using the local
692     timezone, not as GMT.
693   * More security review.
694   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
695     for some handy stuff like:
696     - Using links as a kind of tag; creating blog pages that list all pages
697       containing a given tag/link or not containing some other tag.
698     - Subscribing to mail notifications whenever a change is made to a page
699       that is a backlink of page foo. Ie, "Please notify me of changes in all
700       pages that link to my home page in the wiki"
701     - Locking any pages that are linked to from a particular page, so that
702       lists of locks can be exposed in the wiki.
703   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
704     when a todo item is done, instead of the previous moving it to a different
705     subdir.
706   * Allow pagetemplate plugins to override *anything* in the template.
707   * Add a meta plugin, which allows specifying various metadata about pages,
708     like license and author. It also allows for inserting html link and meta
709     tags into html, overriding the title, and adding hidden WikiLinks, which
710     can be useful when using link-based globbing for page categorisation.
711   * Remove preprocessor directives from inlined pages.
712   * Allow simple preprocessor directive values to be specified w/o quotes.
713   * Add support for using git instead of subversion as the RCS backend,
714     tremendous thanks to Recai Oktaş for this.
715   * Doc updates for git.
716   * Fix absolute url munging in rss generation to support https, ftp, etc urls
717     not just http urls.
718   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
719     utf-8 for edit and other fields, and for recentchanges. There may still
720     be utf-8 issues with the preferences page though.
721
722  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
723
724 ikiwiki (1.4) unstable; urgency=low
725
726   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
727     very strange way of enabling proper XHTML <br /> type tags. Output html
728     should be always valid again now.
729   * The page name and parent links has switched from using a <h1> to a styled
730     <span>, so pages can use <h1> internally instead of needing to use <h2>.
731   * Updated all of ikiwiki's own wiki pages for that.
732   * Add pagetemplate hook, which can be used by plugins that want to mess
733     around with adding new stuff to the page template.
734   * Remove headercontent; the search plugin now adds the search box to the
735     header by registering a pagetemplate hook, and other plugins should do
736     similarly.
737   * Rebuilding on upgrade to this version is recommended.
738   * Add a html validity check to the test suite, using the wdg-html-validator,
739     if available.
740   * Make the html valid when there is nothing in the actions list.
741   * Reordered some function call parameters for consistency.
742   * Enable full utf-8 support for page input and output.
743   * Add a workaround for markdown, which does not work well with utf-8
744     strings.
745   * --getctime had bitrotted (well I only ever used it the once so far..),
746     fix and make it a bit more flexible
747   * rcs_getctime is changed, now rather than needing to loop over all pages,
748     it should just use the rcs to get the ctime of the passed file.
749   * When inlining a page in another one, links from the inlined page are now
750     expanded the same as they are when rendering the inlined page as a
751     standalone page. So rather than being expanded from the POV of the
752     inlining page, they are expanded from the POV of the inlined page.
753
754     For example, a link from blog/foo to "bar" will now link to blog/bar
755     if it exists. Previously this needed to be a link explicitly to
756     "blog/bar"; such links will also continue to work.
757
758     (This was slightly complex to do as the link still has to be constructed
759     relative to the inlining page.)
760   * Make page edit textarea resize to fit browser window.
761   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
762     do not need a full rebuild, in order to update any basewiki pages.
763
764  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
765
766 ikiwiki (1.3) unstable; urgency=low
767
768   * Fix the preinst introduced in the last version. Closes: #367458
769
770  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
771
772 ikiwiki (1.2) unstable; urgency=low
773
774   * Remove dups from the brokenlinks list.
775   * Add libc6-dev to dependencies, needed to build wrappers.
776   * Install wikilist in correct location. Closes: #367371
777
778  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
779
780 ikiwiki (1.1) unstable; urgency=low
781
782   * Rename inlinepage to depends, so that it can be used to refer to more
783     dependency relationships than just inlining. This will require a rebuild
784     on upgrade to this version.
785   * Move the rss link, put it in the blogpost form if there is one and at the
786     top if not. This is both nicer because easier to find, and it cleans up
787     the code which had used inlinepage as a flag for adding the link later.
788   * Allow the depends GlobList to be built up from multiple sources (such as
789     plugins) during a page render.
790   * Which means that more than one blog is now supported to appear on a
791     single page. (With some limitations, like only the last one getting an
792     rss file.)
793   * Added a plugin system.
794   * Added a pagecount plugin, enabled by default.
795   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
796   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
797     backlinks when the backlinks hadn't really changed.
798   * Moved inline page support, rss generation etc into the inline plugin,
799     enabled by default.
800   * Added brokenlinks plugin, not enabled by default, but rather handy.
801   * Fix several broken links in the doc wiki.
802   * Smarter behavior when creating a page and a page of the same name (but
803     different location) already exists.
804   * Add an orphans plugin for finding pages that nothing links to.
805   * Removed backlinks page, which it turns out nothing used.
806   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
807     it, this will allow for adding a unit test suite.
808   * Add unit tests for several core functions, including globlist_match,
809     dirname, basename, bestlink, linkify, pagetitle, titlepage.
810   * Smart globlist merging.
811   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
812     to pave the way for adding other RCS support. This also changes the
813     setup files, where before they had svn => 1 or svn => 0, now they have
814     rcs => "svn" or rcs => "".
815   * Add a debian/NEWS file with upgrade notes.
816   * Load whatever rcs module is specified, so new ones can be just dropped in
817     as plugins and work. (Well, in theory.)
818   * Add some basic docs about writing RCS modules.
819   * Broke search capability out into a plugin, removed the --hyperestraier
820     switch.
821   * Added smiley plugin, nicely controlled and documented by the smileys page.
822   * Copied in some smileys from Moin Moin.
823   * Allow links of the form [[some page|page]], with whitespace in the link
824     text.
825   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
826     and --disable-plugin htmlscrubber.
827   * Allow discussion links on pages to be turned off with --no-discussion.
828   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
829   * Add some new config items to the estseek.conf template, which are needed
830     by hyperestraier 1.2.3.
831
832  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
833
834 ikiwiki (1.0) unstable; urgency=low
835
836   * First official release.
837
838  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400