* Implemented expiry options for aggregate plugin.
[ikiwiki] / debian / changelog
1 ikiwiki (1.32) UNRELEASED; urgency=low
2
3   * Add a separate pass to find page links, and only render each page once,
4     instead of over and over. Typical speedup is ~4x. Max possible speedup:
5     8x.
6   * Add "scan" parameter to hook(), which is used to make the hook be called
7     during the scanning pass, as well as the render pass. The meta and tag
8     plugins need to use the new scan parameter, so will any others that modify
9     %links.
10   * Now that links are calculated in a separate pass, it can also
11     precalculate backlinks in one pass, which is O(N^2) instead of the
12     previous code that was O(N^3). A very nice speedup for wikis with lots
13     (thousands) of pages.
14   * Stylish update to the ikiwiki logo, thanks to Recai Oktaş and Selçuk
15     Erdem.
16   * Add a default stylesheet entry for the pagecloud.
17   * Add examples page with some examples of things that can be done using
18     ikiwiki, like a weblog. The examples can be copied into a user's wiki
19     for a quick start, without needing to learn everything about how to put
20     them together.
21   * Install the source of the examples into /usr/share/doc/ikiwiki/examples.
22   * Add perlmagick to build-depends so syntax check of img plugin works.
23   * Improve login/register process, the login dialog has only name and
24     password fields, which allows more web browsers to regognise it as a login
25     field, and is less confusing.
26   * Implemented expiry options for aggregate plugin.
27   * Use precalculated backlinks info when determining if files need an update
28     due to a page they link to being added/removed. Mostly significant if
29     there are lots of pages.
30   * Remove duplicate link info when saving index. In some cases it could
31     pile up rather badly. (Probably not the best way to deal with this
32     problem.)
33
34  -- Joey Hess <joeyh@debian.org>  Wed,  1 Nov 2006 00:00:10 -0500
35
36 ikiwiki (1.31) unstable; urgency=low
37
38   * Patch from Pawel Tecza to cp -a the templates in the Makefile.
39   * Change the rss feed title from the wikiname to the page title, with
40     an exception for the wiki's toplevel index page, which will still use the
41     wikiname as the feed title.
42     Overriding the page title with meta title already overrode the rss feed
43     tittle.
44   * Add an img plugin, based on Christian Mock's img plugin, but stripped
45     down to the bare essentials. Useful for handling large images on websites.
46   * Sanitize possibly problimatic characters out of the polygen grammar names,
47     just in case. Should not be exploitable anyway, since it only tries to run
48     polygen after finding the specified grammar file.
49   * Add missing dependency on the URI perl module.
50   * Add basic spam fighting tool for admins: An admin's prefs page now allows
51     editing a list of banned users.
52
53  -- Joey Hess <joeyh@debian.org>  Fri, 27 Oct 2006 23:16:33 -0400
54
55 ikiwiki (1.30) unstable; urgency=low
56
57   * Add no_override parameter to hook().
58   * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
59     plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
60     can be configured using a page in wiki.
61   * Fix support for --pingurl at the command line.
62   * Fix a subtle bug in will_render that broke some builds, by only clearing
63     items from renderedfiles the first time per build.
64   * Wrap entire technortati ping operation in an eval to catch all possible
65     failure modes, after I observed a simple ->value crashing ikiwiki when
66     a ping failed.
67
68  -- Joey Hess <joeyh@debian.org>  Mon, 16 Oct 2006 15:17:38 -0400
69
70 ikiwiki (1.29) unstable; urgency=low
71
72   * Patch from Paul Tötterman to use CP in the Makefile.
73   * Patch from Alec Berryman adding a http_auth config item that allows
74     using HTTP Authentication instead of ikiwiki's built in authentication.
75     Useful for eg, large sites with their own previously existing user auth
76     setup. Closes: #384534
77   * Change %renderedfiles to store an array of files rendered from a given
78     source file, to allow tracking of extra rendered files like rss feeds.
79   * Note that plugins that accessed this variable will need to be updated!
80     The plugin interface has been increased to version 1.01 for this change.
81     As few plugins use %renderedfiles I haven't done anything else to ensure
82     compatability of old plugins.
83   * Add will_render function to the plugin interface, used to register that a
84     page renders a destination file, and do some security checks. Previously
85     but no longer rendered files will be cleaned up.
86   * Use will_render in the inline and linkmap plugins.
87   * You will need to rebuild your wiki on upgrade to this version.
88   * Atom feed support based on a patch by Clint Adams.
89   * Add feeds=no option to inline preprocessor directive to turn off all types
90     of feeds.
91   * $IkiWiki::version now holds the program version, and is accessible to
92     plugins.
93   * Make the aggregate plugin emphasize error messages.
94   * Patch from Recai to limit recentchanges to displaying max 10 files for a
95     given changeset (to avoid large number of file changes excessively
96     bloating the page).
97
98  -- Joey Hess <joeyh@debian.org>  Fri, 13 Oct 2006 23:14:28 -0400
99
100 ikiwiki (1.28) unstable; urgency=low
101
102   * inline: Add ability to sort by page name, based on a patch from
103     Benjamin A'Lee.
104   * Fix a forkbomb in various calls to IPC::Open2, which has a highly
105     braindead interface. Closes: #389383
106   * Don't rm -rf ikiwiki on distclean, since a) there's no such file
107     and b) those poor Mac OSX users and their case insensative files!
108   * Don't fail syntax check if Text::Typography isn't installed.
109     Closes: #389406
110
111  -- Joey Hess <joeyh@debian.org>  Tue, 26 Sep 2006 02:08:17 -0400
112
113 ikiwiki (1.27) unstable; urgency=low
114
115   * Work on firming up the plugin interface:
116     - Plugins should not need to load IkiWiki::Render to get commonly
117       used functions, so moved some functions from there to IkiWiki.
118     - Picked out the set of functions and variables that most plugins
119       use, documented them, and made IkiWiki export them by default,
120       like a proper perl module should.
121     - Use the other functions at your own risk.
122     - This is not quite complete, I still have to decide whether to
123       export some other things.
124   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
125     referring to stuff now exported by the IkiWiki module.
126   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
127     to declare which version of the interface your plugin needs.
128   * Anyone with a third-party ikiwiki plugin is strongly encouraged
129     to make like changes to it and avoid use of non-exported symbols from
130     "IkiWiki::".
131   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
132   * Support hyperestradier version 1.4.2, which adds a new required phraseform
133     setting.
134   * If an inlined page has a permalink, link the page title to that.
135   * Patch from Recai to use utf8 when reading the setup file, so that
136     utf8 wikinames from there will be used properly.
137   * Patch from Recai to kill utf-8 on the wiki name when generating the
138     session cookie.
139   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
140   * Fix a baseurl problem in hyperestradier search results.
141   * Add a stub local.css to avoid problems with 404's.
142   * Patch from Recai to fix a wide character warning from the search plugin
143     during setup if the wikiname contains utf8.
144   * Yet another fix for those poor case-insensative OS X users.
145   * pagetemplate hooks are now also called when generating cgi pages.
146   * Add a favicon plugin, which simply adds a link tag for an icon to each
147     page (and cgis).
148   * Patch from James Westby to deal with the case where you're editing a
149     new page, hit cancel, and need to be redirected to somewhere sane.
150   * Various documentation improvements by various wiki users.
151   * Support Text::Markdown from CPAN, which has a different interface from
152     the original markdown or the one in Debian.
153   * Version the libcgi-session-perl dependency, some features that need
154     the new version are used in some cases (sslcookie).
155   * Numerous tla fixes from Clint.
156   * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
157     a multi-resolution favicon.ico.
158   * README.Debian: typo Closes: #388110
159   * chomp trailing newline at the end of templates read in by the template
160     plugin, to allow use of the template preprocessor directive in
161     whitespace-sensative situations. Closes: #387073
162   * Patch from James Westby to make the location of the estseek.cgi script
163     configurable.
164   * Add typography (SmartyPants) plugin by Recai.
165   * Add --render mode, which can be used to preview an edit at the command
166     line by test rendering a single page.
167   * Add a googlecalendar plugin. A bit special-purpose, but it shows
168     one way to to deal with user-supplied content that could cause XSS
169     issues w/o the htmlscrubber, and won't survive the scrubber.
170
171  -- Joey Hess <joeyh@debian.org>  Sun, 24 Sep 2006 00:02:21 -0400
172
173 ikiwiki (1.26) unstable; urgency=low
174
175   * Add a missing -n to tla undo call.
176   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
177     writes before consuming its whole stdin. Avoid this deadlock.
178   * Fix alt tags for outline checkboxes.
179
180  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
181
182 ikiwiki (1.25) unstable; urgency=low
183
184   * Add proper waitpid calls for open2ed processes throughout to avoid
185     zombies; this hit htmltidy especially badly.
186   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
187     subversion repos and fixing some other issues.
188   * Add support for tla, contributed by Clint Adams. Closes: #385936
189   * Add support for mercurial, contributed by Emanuele Aina.
190   * Include <link rel> tag for RSS feeds, used by some aggregators and
191     firefox to find the feed.
192   * Add a linkmap plugin (requires graphviz).
193
194  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
195
196 ikiwiki (1.24) unstable; urgency=low
197
198   * Simplify the data structure returned by rcs_recentchanges to avoid
199     each rcs plugin needing to form complex strings on its own.
200   * Fix another destpage issue in the inline directive. Closes: #385512
201     again.
202
203  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
204
205 ikiwiki (1.23) unstable; urgency=low
206
207   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
208
209  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
210
211 ikiwiki (1.22) unstable; urgency=low
212
213   * Change how the stylesheet url is determined in the templates: Remove
214     STYLEURL and add BASEURL to all templates (some already had it). This
215     new more general variable can be used to link to other things (eg, images)
216     from the template, as well as stylesheets.
217   * Fix a bug introduced last version to do with nested inlines.
218   * Allow preprocessor directives to span multiple lines, both to make
219     long ones with lots of values easier to write, and to allow for ones with
220     multi-line quoted values.
221   * Allow preprocessor directives to contain python-like triple-quoted
222     text blocks, for easy nesting of quotes inside.
223   * Add a template plugin.
224   * Make pagespec merge code smarter about merging duplicate pagespecs.
225   * Patch from Jordà Polo to make Setup::Standard support hashes in config
226     files.
227   * Change order of linkify and preprocess; first preprocess and then linkify.
228     This allows passing a wikilink inside a parameter to a preprocessor
229     directive without it being expanded to html, and leaking out of the
230     parameter, which had required some non-obvious use of triple-quoting
231     to avoid. Note that any preprocessor plugins that output something
232     that looks like a wikilink will now have it treated as such; AFAIK
233     this doesn't change any behavior though except for the template plugin.
234   * Enable preprocessor directives when previewing an edit.
235   * Make all pages pull in a local.css style sheet, if present. This won't
236     be included in ikiwiki, but can be created to make local styling changes
237     w/o needing to merge in every new change to the distributed style.css.
238   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
239   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
240     from a different directory.
241   * Generalised preprocesser loop protection code.
242   * Patch from James Westby to allow a description to be set for rss feeds.
243   * Patch from James Westby to add a template for the search form.
244   * Added a ddate plugin.
245   * Patch from James Westby to add a --sslcookie switch, which forces
246     cookies to only be sent over ssl connections to avoid interception.
247   * Fix preferences page on anonok wikis; still need to sign in to get
248     to the preferences page.
249   * Add toc (table of contents) plugin.
250   * Change htmlize, format, and sanitize hooks to use named parameters.
251   * Patch from James Westby to add an actions option to inline; this
252     adds Edit and Discussion links at the end of blog entries.
253   * Due to some css changes, you'll want to rebuild your wiki on upgrade
254     to this version. Will be handled automatically by the deb.
255   * Add processed date to aggregate preprocessor directive status output.
256
257  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
258
259 ikiwiki (1.21) unstable; urgency=low
260
261   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
262   * If a page links to itself, mark up the link text in a span with
263     class="selflink" so that it can be styled. I don't have a useful style
264     defined for that though.
265   * Call filter hooks on inlined page content.
266   * Support inlining pages raw, rather than creating a blog.
267   * Clean up yes/no parameter parsing in inline plugin.
268   * Implemented better cycle detection in the inline plugin; nested inlines
269     will now work.
270   * Add a map plugin contributed by Alessandro Dotti Contra.
271   * Add otl format plugin, which handles files as created by vimoutliner.
272   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
273   * Add first draft at a Restructured Text (rst) plugin, by Sergio
274     Talens-Oliag. Note that this has many known issues -- see the caveats on
275     the plugin's page.
276   * Credit everyone who wrote a plugin on the plugins' wiki pages.
277   * Fix utf-8 in blog post form.
278
279  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
280
281 ikiwiki (1.20) unstable; urgency=low
282
283   * Relicense the templates and basewiki under the 2-clause BSD license.
284     Since these can easily become part of other people's websites, they
285     should be under as permissive a license as possible.
286   * Add --syslog config option, to log to the syslog.
287   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
288     transient failure to fork (which I've seen happen in the wild).
289   * Fix a bug in the aggregator introduced last version that caused all
290     aggregator state to be lost during a non-aggregating build.
291
292  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
293
294 ikiwiki (1.19) unstable; urgency=low
295
296   * Fix several related bugs in page type determination during online editing.
297   * Add some locking to prevent 2 aggregators from running at once.
298   * Fix an infinite loop in the aggregator when finding a unique filename.
299
300  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
301
302 ikiwiki (1.18) unstable; urgency=low
303
304   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
305   * Add --version.
306   * Man page format fixups.
307   * If the meta plugin overides the page title, set a title_overridden
308     variable in the template to true. This allows doing things with the
309     templates conditional on the title being overriden.
310   * Add a %pagecase which maps lower-case page names to the actual case
311     used in the filename. Use this in bestlinks calculation instead of
312     forcing the link to lowercase.
313   * Also use %pagecase in various other places that want to check if a page
314     with a given name exists.
315   * This means that links to pages with mixed case names will now work,
316     even if the link is in some other case mixture, and mixed case pages
317     should be fully supported throughout ikiwiki.
318   * Recommend rebuilding wikis on upgrade to this version.
319
320  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
321
322 ikiwiki (1.17) unstable; urgency=low
323
324   * Disable tidy generator tag.
325   * Move tidy back to sanitize hook, found out how to only show body.
326   * Turn off tidy indentation too.
327   * Turn on HTML::Template loop_context_vars; not actually used in stock
328     templates but can be useful for things like making comma-delimited lists
329     of tags or what have you.
330   * Remove <br> from end of aggregate preprocessor directive output.
331   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
332     case-sensative filesystems like OSX.
333   * Improve markdown loading. First, try to load it as a proper perl module,
334     in case it was installed as one. Then fall back to trying
335     /usr/bin/markdown.
336   * Document in install page how to install markdown, since it has no
337     installation procedure in the upstream tarball.
338   * Set die_on_bad_params => 0 for all templates, to allow users to modify
339     them without annoyances.
340   * Suck in the page content when generating an inline archive page, to work
341     around the meta plugin's lack of caching of title metadata across runs.
342
343  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
344
345 ikiwiki (1.16) unstable; urgency=low
346
347   * Try to handle relative links in aggregated feeds. However,
348     the current support is a crude hack due to limitations of XML::Feed:
349     xml:base is not supported, neither is Content-Location. And of course,
350     relative links in RSS feeds are ill-undefined..
351   * Make aggregator save permalinks and author name to pages as metadata.
352   * Add permalink and author support to meta plugin, affecting RSS feeds
353     and blog pages.
354   * Various CSS and formatting changes.
355   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
356   * Add xhtml files to the default prune regexp.
357   * Also generate rel=bookmark links for permalinks.
358   * Fix the htmltidy plugin, which wasn't working due my breaking it when
359     I added it..
360   * Don't run tidy with -xml as that fails if the input is not well-formed.
361     Run it with -asxhtml instead, so it will output well-formed xhtml no
362     matter what the input.
363   * Disable tidy warnings too.
364   * Add a new format hook, and make tidy use it, since tidy can really only
365     operate on and output complete html documents, not the body chunks
366     that sanitise gets.
367   * Fix dates in rss feeds if running localised, so they're still rfc 822.
368
369  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
370
371 ikiwiki (1.15) unstable; urgency=low
372
373   * Remove CDPATH and other env vars perl taint checking doesn't like.
374     Closes: #381279
375   * Added created_before and created_after PageSpec limits.
376
377  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
378
379 ikiwiki (1.14) unstable; urgency=low
380
381   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
382     by 10% or so.
383   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
384   * Added many unit tests for pagespec_match.
385
386  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
387
388 ikiwiki (1.13) unstable; urgency=low
389
390   * ikiwiki can now download and aggregate feeds with its new aggregate
391     plugin, so it's possible to implement a Planet using ikiwiki!
392   * Add a run_hooks function for the common task of running all hooks of a
393     given type.
394   * Add a savestate hook.
395   * Don't put blog post forms on pages if there's no cgiurl set.
396   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
397     --wrappers to do that.
398   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
399     to update pages that haven't changed on disk.
400   * Change meta tags to use html entity-escaped text for values, so that
401     quotes and such can be represented in title tags.
402   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
403     for the above.
404   * Make --rebuild also cause --aggregate to re-download and write aggregated
405     pages.
406   * Avoid outputting duplicate meta info.
407   * Include title metadata on aggregated posts for capitalised and un-munged
408     titles.
409   * Title metadata of inlined pages now shows up in blogs and rss feeds.
410   * Fix issue with unicode filenames and updating the hyper estradier search
411     index. (Aka Please Please Please, let that be the last one.)
412   * Patch from Roland Mas to support an rss=no parameter to inline directives.
413     Closes: #380743
414   * Renamed GlobLists to PageSpecs.
415   * PageSpecs can now include nested parens, "and", and "or". This remains
416     backwards compatible to the old GlobList format. It's implemented by
417     treating the GlobList as a very limited microlanguage that is transformed
418     to perl code that does the matching.
419   * The old GlobList format is deprecated, and I encourage users to switch to
420     using the new PageSpec format. Compatability with the old format will be
421     removed at some point, possibly by 2.0.
422   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
423   * Add support for creation_month and creation_year to PageSpec.
424     Closes: #380680
425   * Changes to index file encoding.
426
427  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
428
429 ikiwiki (1.12) unstable; urgency=low
430
431   "Viva l'Italia!"
432   * New pagestats plugin from Enrico, which can generate a table counting
433     the backlinks for each page, or a del.icio.us style cloud.
434   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
435     the wikiformat plugin works. Thanks, Emanuele Aina.
436   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
437     display, running them through pagetitle. This removes ugly underscores and
438     other gunk from the display, much nicer. You may want to rebuild your wiki
439     when upgrading to get the cleanup globally.
440   * Polygen plugin from Enrico.
441   * htmltidy plugin from Faidon.
442   * Locale patch from Faidon:
443     - Adds a locale setting to setup files.
444     - Proper local time, if the locale configuration option is used.
445     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
446       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
447       impossible.
448   * Add getopt hook type, this allows plugins to add new command-line options.
449   * Add --tagbase option to tag plugin.
450   * Add exclude option in setup files, works same as --exclude.
451   * Put categories in rss feeds for tagged items.
452   * Allow preprocessor directives to be expanded in inlined blog pages.
453     However, to avoid inlining loops etc, don't expand inline directives in
454     inlined pages.
455   * fortune plugin (trivial)
456   * Tag plugins according to type.
457
458  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
459
460 ikiwiki (1.11) unstable; urgency=low
461
462   * Patch from Enrico that
463     - Adds a tag plugin that allows more easily tagging pages.
464       The meta plugin can also still be used for that, but the tag plugin
465       also lists a page's tags at the bottom of the page.
466     - Allows preprocessor directives to have parameters with no specified
467       value.
468     - Fixes preprocessor directive parameter parsing so that
469       foo=bar baz now means "foo=bar" and a "baz" with no value.
470   * Run pagetemplate hooks when inlining pages so that inlined pages also
471     list their tags.
472   * Make all plugins with pagetemplate hooks check that variables exist
473     on the template before setting them, for robustness.
474   * Switch pagetemplate hooks to using named parameters.
475   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
476     This will be the page that a source page will be part of, which is
477     different than the source page for inlined pages.
478   * Audited all plugins to endure they pass (page, destpage) to htmllink
479     appropriatly. This means inlining of various plugins will not work
480     properly, with correct links generated.
481
482  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
483
484 ikiwiki (1.10) unstable; urgency=low
485
486   * Run page through any relevant filters when generating a page preview.
487   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
488     default throughout the wiki, not only on wikitext pages. Decided to call
489     this a feature, and split the camelcase support out into a separate plugin
490     that is independant of wikitext.
491   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
492
493  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
494
495 ikiwiki (1.9) unstable; urgency=low
496
497   * Improve display of parentlinks and page title of toplevel index page.
498   * Patch from Faidon to use svn --limit when possible for recentchanges,
499     speeds up recentchanges a lot for wikis with more history.
500   * Patch from Recai to fix utf8 issues in git backend.
501   * Add wikitext markup plugin, which supports ".wiki" pages written in the
502     original wiki syntax, CamelCase links and all.
503   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
504     support, to edit pages etc without a web server.
505   * Display CGI processing errors if present.
506   * Fix from Faidon for a XML parser issue that breaks utf-8 for
507     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
508     area, and also way slow.
509   * Match 'web commit from' in SVN and git, these are web commits too.
510     (Faidon)
511   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
512     readable and avoid future mistakes. The patch seems to work and for the
513     first time I have a UTF-8 username ;-) (Faidon)
514   * Use form->field consistently, not form->param.
515   * Patch from Recai to allow selection of page type when creating a new page.
516     Default page type is inherited from the link clicked on to create the new
517     page.
518
519  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
520
521 ikiwiki (1.8) unstable; urgency=low
522
523   * Fix orphans plugin to not count a link to a nonexistant page as a reason
524     for a page not being an orphan.
525   * Support pinging services such as Technorati using XML-RPC to notify them
526     about changes to rss feeds.
527   * Parse svn log as xml for improved utf8 and security. Note that this makes
528     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
529   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
530     flagged string even if the locale causes it to generate utf8 output,
531     so make sure to let perl know it should be handled as utf8. Also,
532     the optimised version used for standard time formats won't work if the
533     user has changed locale, so drop it. Thanks, Faidon Liambotis.
534   * Fix re-encoding of the comments field to utf8 if a commit fails
535     due to a conflict. Thanks, Faidon Liambotis.
536   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
537     Liambotis.
538   * Add insane double encode/decode to utf8 around call to markdown.
539     This works around a truely strange bug, which is apparently a bug in
540     perl, #376329. Also added a test case for it.
541   * Improve layout of edit page so formatting help link is always visible w/o
542     getting in the way of the preview.
543   * Centralised all calls to HTML::Template and force all the templates
544     to be read as utf8.
545   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
546   * Introduce add_plugins and disable_plugins config options in setup files.
547     This allows adding or removing plugins w/o overriding the whole list of
548     default plugins, which makes it easier to upgrade when new default plugins
549     are added.
550   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
551     default (of course!). Based on a patch by Faidon Liambotis.
552   * Add a html plugin, which can be used to write wikis in raw html,
553     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
554     defaults to not processing .html files, since w/o this plugin they would
555     be copied unsanitised. With this plugin, it will process and html
556     sanitise them, like any other page type.
557   * Rebuilding wrappers is necessary on upgrade to this version.
558   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
559     will be automatically done on all upgrades.
560   * Don't send pings if the wiki is being rebuilt.
561   * Work around very innefficient behavior in File::Spec::abs2rel. Result
562     is a savings of 2 pointless fork/execs per link calculation, which
563     results in ~25% speedup of ikiwiki building its own doc wiki, and
564     about 35% speedup displaying RecentChanges!
565   * Make RecentChanges use a table and some CSS, should be much more readable.
566     No code changes involved.
567   * Encode & in diffurl in examples, to conform to pedantic rules.
568   * Speed up RecentChanges by another 40% or so with some memoization.
569   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
570     in time to build the doc wiki.
571
572  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
573
574 ikiwiki (1.7) unstable; urgency=low
575
576   * Updated logo from Recai with some kerning and alingment tuning.
577   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
578     changed some output.
579   * Copyright update.
580
581  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
582
583 ikiwiki (1.6) unstable; urgency=low
584
585   * YA utf-8 patch from Recai, this time to fix previewing a page so that
586     the text in the input box is re-encoded back to utf-8.
587   * -CSD does not affect modules, so readfile() was not using the utf-8 input
588     layer, which led to lots of problems; make it force read files as utf-8.
589     Closes: #373203
590   * Note that as a consequence, this version of ikiwiki will actually try to
591     parse utf8 in source files for the first time, which may expose broken
592     utf8 in wiki sources that was hidden before. Most common will be
593     perl warnings like "utf8 "\xE9" does not map to Unicode"
594   * writefile() likewise needs to use the utf8 output layer.
595   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
596     there.
597   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
598     given the readfile fix.
599   * Add utf-8 testcases for readfile and htmlize.
600   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
601     safe.
602   * More utf-8 fixes from Recai, partly to things I broke above:
603     - The serious problem is that writefile() saves the content in undecoded
604       format in CGI, hence all (non-ascii) chars are corrupted permanently.
605     - Comment field in edit page is not decoded and all the non-ascii chars in
606       this field are corrupted as the result.  We should decode it as we do it
607       for the content.
608     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
609       character in print.
610   * New SVG logo from Recai.
611
612  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
613
614 ikiwiki (1.5) unstable; urgency=low
615
616   * Add --timeformat config option to allow changing how dates are displayed.
617     Note that as a side effect, dates will now be displayed using the local
618     timezone, not as GMT.
619   * More security review.
620   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
621     for some handy stuff like:
622     - Using links as a kind of tag; creating blog pages that list all pages
623       containing a given tag/link or not containing some other tag.
624     - Subscribing to mail notifications whenever a change is made to a page
625       that is a backlink of page foo. Ie, "Please notify me of changes in all
626       pages that link to my home page in the wiki"
627     - Locking any pages that are linked to from a particular page, so that
628       lists of locks can be exposed in the wiki.
629   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
630     when a todo item is done, instead of the previous moving it to a different
631     subdir.
632   * Allow pagetemplate plugins to override *anything* in the template.
633   * Add a meta plugin, which allows specifying various metadata about pages,
634     like license and author. It also allows for inserting html link and meta
635     tags into html, overriding the title, and adding hidden WikiLinks, which
636     can be useful when using link-based globbing for page categorisation.
637   * Remove preprocessor directives from inlined pages.
638   * Allow simple preprocessor directive values to be specified w/o quotes.
639   * Add support for using git instead of subversion as the RCS backend,
640     tremendous thanks to Recai Oktaş for this.
641   * Doc updates for git.
642   * Fix absolute url munging in rss generation to support https, ftp, etc urls
643     not just http urls.
644   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
645     utf-8 for edit and other fields, and for recentchanges. There may still
646     be utf-8 issues with the preferences page though.
647
648  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
649
650 ikiwiki (1.4) unstable; urgency=low
651
652   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
653     very strange way of enabling proper XHTML <br /> type tags. Output html
654     should be always valid again now.
655   * The page name and parent links has switched from using a <h1> to a styled
656     <span>, so pages can use <h1> internally instead of needing to use <h2>.
657   * Updated all of ikiwiki's own wiki pages for that.
658   * Add pagetemplate hook, which can be used by plugins that want to mess
659     around with adding new stuff to the page template.
660   * Remove headercontent; the search plugin now adds the search box to the
661     header by registering a pagetemplate hook, and other plugins should do
662     similarly.
663   * Rebuilding on upgrade to this version is recommended.
664   * Add a html validity check to the test suite, using the wdg-html-validator,
665     if available.
666   * Make the html valid when there is nothing in the actions list.
667   * Reordered some function call parameters for consistency.
668   * Enable full utf-8 support for page input and output.
669   * Add a workaround for markdown, which does not work well with utf-8
670     strings.
671   * --getctime had bitrotted (well I only ever used it the once so far..),
672     fix and make it a bit more flexible
673   * rcs_getctime is changed, now rather than needing to loop over all pages,
674     it should just use the rcs to get the ctime of the passed file.
675   * When inlining a page in another one, links from the inlined page are now
676     expanded the same as they are when rendering the inlined page as a
677     standalone page. So rather than being expanded from the POV of the
678     inlining page, they are expanded from the POV of the inlined page.
679
680     For example, a link from blog/foo to "bar" will now link to blog/bar
681     if it exists. Previously this needed to be a link explicitly to
682     "blog/bar"; such links will also continue to work.
683
684     (This was slightly complex to do as the link still has to be constructed
685     relative to the inlining page.)
686   * Make page edit textarea resize to fit browser window.
687   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
688     do not need a full rebuild, in order to update any basewiki pages.
689
690  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
691
692 ikiwiki (1.3) unstable; urgency=low
693
694   * Fix the preinst introduced in the last version. Closes: #367458
695
696  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
697
698 ikiwiki (1.2) unstable; urgency=low
699
700   * Remove dups from the brokenlinks list.
701   * Add libc6-dev to dependencies, needed to build wrappers.
702   * Install wikilist in correct location. Closes: #367371
703
704  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
705
706 ikiwiki (1.1) unstable; urgency=low
707
708   * Rename inlinepage to depends, so that it can be used to refer to more
709     dependency relationships than just inlining. This will require a rebuild
710     on upgrade to this version.
711   * Move the rss link, put it in the blogpost form if there is one and at the
712     top if not. This is both nicer because easier to find, and it cleans up
713     the code which had used inlinepage as a flag for adding the link later.
714   * Allow the depends GlobList to be built up from multiple sources (such as
715     plugins) during a page render.
716   * Which means that more than one blog is now supported to appear on a
717     single page. (With some limitations, like only the last one getting an
718     rss file.)
719   * Added a plugin system.
720   * Added a pagecount plugin, enabled by default.
721   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
722   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
723     backlinks when the backlinks hadn't really changed.
724   * Moved inline page support, rss generation etc into the inline plugin,
725     enabled by default.
726   * Added brokenlinks plugin, not enabled by default, but rather handy.
727   * Fix several broken links in the doc wiki.
728   * Smarter behavior when creating a page and a page of the same name (but
729     different location) already exists.
730   * Add an orphans plugin for finding pages that nothing links to.
731   * Removed backlinks page, which it turns out nothing used.
732   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
733     it, this will allow for adding a unit test suite.
734   * Add unit tests for several core functions, including globlist_match,
735     dirname, basename, bestlink, linkify, pagetitle, titlepage.
736   * Smart globlist merging.
737   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
738     to pave the way for adding other RCS support. This also changes the
739     setup files, where before they had svn => 1 or svn => 0, now they have
740     rcs => "svn" or rcs => "".
741   * Add a debian/NEWS file with upgrade notes.
742   * Load whatever rcs module is specified, so new ones can be just dropped in
743     as plugins and work. (Well, in theory.)
744   * Add some basic docs about writing RCS modules.
745   * Broke search capability out into a plugin, removed the --hyperestraier
746     switch.
747   * Added smiley plugin, nicely controlled and documented by the smileys page.
748   * Copied in some smileys from Moin Moin.
749   * Allow links of the form [[some page|page]], with whitespace in the link
750     text.
751   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
752     and --disable-plugin htmlscrubber.
753   * Allow discussion links on pages to be turned off with --no-discussion.
754   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
755   * Add some new config items to the estseek.conf template, which are needed
756     by hyperestraier 1.2.3.
757
758  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
759
760 ikiwiki (1.0) unstable; urgency=low
761
762   * First official release.
763
764  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400