* Support htmlize plugins and make mdwn one such plugin, which is enabled by
[ikiwiki] / debian / changelog
1 ikiwiki (1.8) UNRELEASED; urgency=low
2
3   * Fix orphans plugin to not count a link to a nonexistant page as a reason
4     for a page not being an orphan.
5   * Support pinging services such as Technorati using XML-RPC to notify them
6     about changes to rss feeds.
7   * Parse svn log as xml for improved utf8 and security. Note that this makes
8     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
9   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
10     flagged string even if the locale causes it to generate utf8 output,
11     so make sure to let perl know it should be handled as utf8. Also,
12     the optimised version used for standard time formats won't work if the
13     user has changed locale, so drop it. Thanks, Faidon Liambotis.
14   * Fix re-encoding of the comments field to utf8 if a commit fails
15     due to a conflict. Thanks, Faidon Liambotis.
16   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
17     Liambotis.
18   * Add insane double encode/decode to utf8 around call to markdown.
19     This works around a truely strange bug, which is apparently a bug in
20     perl, #376329. Also added a test case for it.
21   * Improve layout of edit page so formatting help link is always visible w/o
22     getting in the way of the preview.
23   * Centralised all calls to HTML::Template and force all the templates
24     to be read as utf8.
25   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
26   * Introduce add_plugins and disable_plugins config options in setup files.
27     This allows adding or removing plugins w/o overriding the whole list of
28     default plugins, which makes it easier to upgrade when new default plugins
29     are added.
30   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
31     default (of course!). Based on a patch by Faidon Liambotis.
32
33  -- Joey Hess <joeyh@debian.org>  Mon,  3 Jul 2006 18:06:49 -0400
34
35 ikiwiki (1.7) unstable; urgency=low
36
37   * Updated logo from Recai with some kerning and alingment tuning.
38   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
39     changed some output.
40   * Copyright update.
41
42  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
43
44 ikiwiki (1.6) unstable; urgency=low
45
46   * YA utf-8 patch from Recai, this time to fix previewing a page so that
47     the text in the input box is re-encoded back to utf-8.
48   * -CSD does not affect modules, so readfile() was not using the utf-8 input
49     layer, which led to lots of problems; make it force read files as utf-8.
50     Closes: #373203
51   * Note that as a consequence, this version of ikiwiki will actually try to
52     parse utf8 in source files for the first time, which may expose broken
53     utf8 in wiki sources that was hidden before. Most common will be
54     perl warnings like "utf8 "\xE9" does not map to Unicode"
55   * writefile() likewise needs to use the utf8 output layer.
56   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
57     there.
58   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
59     given the readfile fix.
60   * Add utf-8 testcases for readfile and htmlize.
61   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
62     safe.
63   * More utf-8 fixes from Recai, partly to things I broke above:
64     - The serious problem is that writefile() saves the content in undecoded
65       format in CGI, hence all (non-ascii) chars are corrupted permanently.
66     - Comment field in edit page is not decoded and all the non-ascii chars in
67       this field are corrupted as the result.  We should decode it as we do it
68       for the content.
69     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
70       character in print.
71   * New SVG logo from Recai.
72
73  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
74
75 ikiwiki (1.5) unstable; urgency=low
76
77   * Add --timeformat config option to allow changing how dates are displayed.
78     Note that as a side effect, dates will now be displayed using the local
79     timezone, not as GMT.
80   * More security review.
81   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
82     for some handy stuff like:
83     - Using links as a kind of tag; creating blog pages that list all pages
84       containing a given tag/link or not containing some other tag.
85     - Subscribing to mail notifications whenever a change is made to a page
86       that is a backlink of page foo. Ie, "Please notify me of changes in all
87       pages that link to my home page in the wiki"
88     - Locking any pages that are linked to from a particular page, so that
89       lists of locks can be exposed in the wiki.
90   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
91     when a todo item is done, instead of the previous moving it to a different
92     subdir.
93   * Allow pagetemplate plugins to override *anything* in the template.
94   * Add a meta plugin, which allows specifying various metadata about pages,
95     like license and author. It also allows for inserting html link and meta
96     tags into html, overriding the title, and adding hidden WikiLinks, which
97     can be useful when using link-based globbing for page categorisation.
98   * Remove preprocessor directives from inlined pages.
99   * Allow simple preprocessor directive values to be specified w/o quotes.
100   * Add support for using git instead of subversion as the RCS backend,
101     tremendous thanks to Recai Oktaş for this.
102   * Doc updates for git.
103   * Fix absolute url munging in rss generation to support https, ftp, etc urls
104     not just http urls.
105   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
106     utf-8 for edit and other fields, and for recentchanges. There may still
107     be utf-8 issues with the preferences page though.
108
109  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
110
111 ikiwiki (1.4) unstable; urgency=low
112
113   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
114     very strange way of enabling proper XHTML <br /> type tags. Output html
115     should be always valid again now.
116   * The page name and parent links has switched from using a <h1> to a styled
117     <span>, so pages can use <h1> internally instead of needing to use <h2>.
118   * Updated all of ikiwiki's own wiki pages for that.
119   * Add pagetemplate hook, which can be used by plugins that want to mess
120     around with adding new stuff to the page template.
121   * Remove headercontent; the search plugin now adds the search box to the
122     header by registering a pagetemplate hook, and other plugins should do
123     similarly.
124   * Rebuilding on upgrade to this version is recommended.
125   * Add a html validity check to the test suite, using the wdg-html-validator,
126     if available.
127   * Make the html valid when there is nothing in the actions list.
128   * Reordered some function call parameters for consistency.
129   * Enable full utf-8 support for page input and output.
130   * Add a workaround for markdown, which does not work well with utf-8
131     strings.
132   * --getctime had bitrotted (well I only ever used it the once so far..),
133     fix and make it a bit more flexible
134   * rcs_getctime is changed, now rather than needing to loop over all pages,
135     it should just use the rcs to get the ctime of the passed file.
136   * When inlining a page in another one, links from the inlined page are now
137     expanded the same as they are when rendering the inlined page as a
138     standalone page. So rather than being expanded from the POV of the
139     inlining page, they are expanded from the POV of the inlined page.
140
141     For example, a link from blog/foo to "bar" will now link to blog/bar
142     if it exists. Previously this needed to be a link explicitly to
143     "blog/bar"; such links will also continue to work.
144
145     (This was slightly complex to do as the link still has to be constructed
146     relative to the inlining page.)
147   * Make page edit textarea resize to fit browser window.
148   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
149     do not need a full rebuild, in order to update any basewiki pages.
150
151  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
152
153 ikiwiki (1.3) unstable; urgency=low
154
155   * Fix the preinst introduced in the last version. Closes: #367458
156
157  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
158
159 ikiwiki (1.2) unstable; urgency=low
160
161   * Remove dups from the brokenlinks list.
162   * Add libc6-dev to dependencies, needed to build wrappers.
163   * Install wikilist in correct location. Closes: #367371
164
165  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
166
167 ikiwiki (1.1) unstable; urgency=low
168
169   * Rename inlinepage to depends, so that it can be used to refer to more
170     dependency relationships than just inlining. This will require a rebuild
171     on upgrade to this version.
172   * Move the rss link, put it in the blogpost form if there is one and at the
173     top if not. This is both nicer because easier to find, and it cleans up
174     the code which had used inlinepage as a flag for adding the link later.
175   * Allow the depends GlobList to be built up from multiple sources (such as
176     plugins) during a page render.
177   * Which means that more than one blog is now supported to appear on a
178     single page. (With some limitations, like only the last one getting an
179     rss file.)
180   * Added a plugin system.
181   * Added a pagecount plugin, enabled by default.
182   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
183   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
184     backlinks when the backlinks hadn't really changed.
185   * Moved inline page support, rss generation etc into the inline plugin,
186     enabled by default.
187   * Added brokenlinks plugin, not enabled by default, but rather handy.
188   * Fix several broken links in the doc wiki.
189   * Smarter behavior when creating a page and a page of the same name (but
190     different location) already exists.
191   * Add an orphans plugin for finding pages that nothing links to.
192   * Removed backlinks page, which it turns out nothing used.
193   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
194     it, this will allow for adding a unit test suite.
195   * Add unit tests for several core functions, including globlist_match,
196     dirname, basename, bestlink, linkify, pagetitle, titlepage.
197   * Smart globlist merging.
198   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
199     to pave the way for adding other RCS support. This also changes the
200     setup files, where before they had svn => 1 or svn => 0, now they have
201     rcs => "svn" or rcs => "".
202   * Add a debian/NEWS file with upgrade notes.
203   * Load whatever rcs module is specified, so new ones can be just dropped in
204     as plugins and work. (Well, in theory.)
205   * Add some basic docs about writing RCS modules.
206   * Broke search capability out into a plugin, removed the --hyperestraier
207     switch.
208   * Added smiley plugin, nicely controlled and documented by the smileys page.
209   * Copied in some smileys from Moin Moin.
210   * Allow links of the form [[some page|page]], with whitespace in the link
211     text.
212   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
213     and --disable-plugin htmlscrubber.
214   * Allow discussion links on pages to be turned off with --no-discussion.
215   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
216   * Add some new config items to the estseek.conf template, which are needed
217     by hyperestraier 1.2.3.
218
219  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
220
221 ikiwiki (1.0) unstable; urgency=low
222
223   * First official release.
224
225  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400