Fix support for --pingurl at the command line.
[ikiwiki] / debian / changelog
1 ikiwiki (1.30) UNRELEASED; urgency=low
2
3   * Add no_override parameter to hook().
4   * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
5     plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
6     can be configured using a page in wiki.
7   * Fix support for --pingurl at the command line.
8
9  -- Joey Hess <joeyh@debian.org>  Mon, 16 Oct 2006 14:32:56 -0400
10
11 ikiwiki (1.29) unstable; urgency=low
12
13   * Patch from Paul Tötterman to use CP in the Makefile.
14   * Patch from Alec Berryman adding a http_auth config item that allows
15     using HTTP Authentication instead of ikiwiki's built in authentication.
16     Useful for eg, large sites with their own previously existing user auth
17     setup. Closes: #384534
18   * Change %renderedfiles to store an array of files rendered from a given
19     source file, to allow tracking of extra rendered files like rss feeds.
20   * Note that plugins that accessed this variable will need to be updated!
21     The plugin interface has been increased to version 1.01 for this change.
22     As few plugins use %renderedfiles I haven't done anything else to ensure
23     compatability of old plugins.
24   * Add will_render function to the plugin interface, used to register that a
25     page renders a destination file, and do some security checks. Previously
26     but no longer rendered files will be cleaned up.
27   * Use will_render in the inline and linkmap plugins.
28   * You will need to rebuild your wiki on upgrade to this version.
29   * Atom feed support based on a patch by Clint Adams.
30   * Add feeds=no option to inline preprocessor directive to turn off all types
31     of feeds.
32   * $IkiWiki::version now holds the program version, and is accessible to
33     plugins.
34   * Make the aggregate plugin emphasize error messages.
35   * Patch from Recai to limit recentchanges to displaying max 10 files for a
36     given changeset (to avoid large number of file changes excessively
37     bloating the page).
38
39  -- Joey Hess <joeyh@debian.org>  Fri, 13 Oct 2006 23:14:28 -0400
40
41 ikiwiki (1.28) unstable; urgency=low
42
43   * inline: Add ability to sort by page name, based on a patch from
44     Benjamin A'Lee.
45   * Fix a forkbomb in various calls to IPC::Open2, which has a highly
46     braindead interface. Closes: #389383
47   * Don't rm -rf ikiwiki on distclean, since a) there's no such file
48     and b) those poor Mac OSX users and their case insensative files!
49   * Don't fail syntax check if Text::Typography isn't installed.
50     Closes: #389406
51
52  -- Joey Hess <joeyh@debian.org>  Tue, 26 Sep 2006 02:08:17 -0400
53
54 ikiwiki (1.27) unstable; urgency=low
55
56   * Work on firming up the plugin interface:
57     - Plugins should not need to load IkiWiki::Render to get commonly
58       used functions, so moved some functions from there to IkiWiki.
59     - Picked out the set of functions and variables that most plugins
60       use, documented them, and made IkiWiki export them by default,
61       like a proper perl module should.
62     - Use the other functions at your own risk.
63     - This is not quite complete, I still have to decide whether to
64       export some other things.
65   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
66     referring to stuff now exported by the IkiWiki module.
67   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
68     to declare which version of the interface your plugin needs.
69   * Anyone with a third-party ikiwiki plugin is strongly encouraged
70     to make like changes to it and avoid use of non-exported symbols from
71     "IkiWiki::".
72   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
73   * Support hyperestradier version 1.4.2, which adds a new required phraseform
74     setting.
75   * If an inlined page has a permalink, link the page title to that.
76   * Patch from Recai to use utf8 when reading the setup file, so that
77     utf8 wikinames from there will be used properly.
78   * Patch from Recai to kill utf-8 on the wiki name when generating the
79     session cookie.
80   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
81   * Fix a baseurl problem in hyperestradier search results.
82   * Add a stub local.css to avoid problems with 404's.
83   * Patch from Recai to fix a wide character warning from the search plugin
84     during setup if the wikiname contains utf8.
85   * Yet another fix for those poor case-insensative OS X users.
86   * pagetemplate hooks are now also called when generating cgi pages.
87   * Add a favicon plugin, which simply adds a link tag for an icon to each
88     page (and cgis).
89   * Patch from James Westby to deal with the case where you're editing a
90     new page, hit cancel, and need to be redirected to somewhere sane.
91   * Various documentation improvements by various wiki users.
92   * Support Text::Markdown from CPAN, which has a different interface from
93     the original markdown or the one in Debian.
94   * Version the libcgi-session-perl dependency, some features that need
95     the new version are used in some cases (sslcookie).
96   * Numerous tla fixes from Clint.
97   * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
98     a multi-resolution favicon.ico.
99   * README.Debian: typo Closes: #388110
100   * chomp trailing newline at the end of templates read in by the template
101     plugin, to allow use of the template preprocessor directive in
102     whitespace-sensative situations. Closes: #387073
103   * Patch from James Westby to make the location of the estseek.cgi script
104     configurable.
105   * Add typography (SmartyPants) plugin by Recai.
106   * Add --render mode, which can be used to preview an edit at the command
107     line by test rendering a single page.
108   * Add a googlecalendar plugin. A bit special-purpose, but it shows
109     one way to to deal with user-supplied content that could cause XSS
110     issues w/o the htmlscrubber, and won't survive the scrubber.
111
112  -- Joey Hess <joeyh@debian.org>  Sun, 24 Sep 2006 00:02:21 -0400
113
114 ikiwiki (1.26) unstable; urgency=low
115
116   * Add a missing -n to tla undo call.
117   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
118     writes before consuming its whole stdin. Avoid this deadlock.
119   * Fix alt tags for outline checkboxes.
120
121  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
122
123 ikiwiki (1.25) unstable; urgency=low
124
125   * Add proper waitpid calls for open2ed processes throughout to avoid
126     zombies; this hit htmltidy especially badly.
127   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
128     subversion repos and fixing some other issues.
129   * Add support for tla, contributed by Clint Adams. Closes: #385936
130   * Add support for mercurial, contributed by Emanuele Aina.
131   * Include <link rel> tag for RSS feeds, used by some aggregators and
132     firefox to find the feed.
133   * Add a linkmap plugin (requires graphviz).
134
135  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
136
137 ikiwiki (1.24) unstable; urgency=low
138
139   * Simplify the data structure returned by rcs_recentchanges to avoid
140     each rcs plugin needing to form complex strings on its own.
141   * Fix another destpage issue in the inline directive. Closes: #385512
142     again.
143
144  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
145
146 ikiwiki (1.23) unstable; urgency=low
147
148   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
149
150  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
151
152 ikiwiki (1.22) unstable; urgency=low
153
154   * Change how the stylesheet url is determined in the templates: Remove
155     STYLEURL and add BASEURL to all templates (some already had it). This
156     new more general variable can be used to link to other things (eg, images)
157     from the template, as well as stylesheets.
158   * Fix a bug introduced last version to do with nested inlines.
159   * Allow preprocessor directives to span multiple lines, both to make
160     long ones with lots of values easier to write, and to allow for ones with
161     multi-line quoted values.
162   * Allow preprocessor directives to contain python-like triple-quoted
163     text blocks, for easy nesting of quotes inside.
164   * Add a template plugin.
165   * Make pagespec merge code smarter about merging duplicate pagespecs.
166   * Patch from Jordà Polo to make Setup::Standard support hashes in config
167     files.
168   * Change order of linkify and preprocess; first preprocess and then linkify.
169     This allows passing a wikilink inside a parameter to a preprocessor
170     directive without it being expanded to html, and leaking out of the
171     parameter, which had required some non-obvious use of triple-quoting
172     to avoid. Note that any preprocessor plugins that output something
173     that looks like a wikilink will now have it treated as such; AFAIK
174     this doesn't change any behavior though except for the template plugin.
175   * Enable preprocessor directives when previewing an edit.
176   * Make all pages pull in a local.css style sheet, if present. This won't
177     be included in ikiwiki, but can be created to make local styling changes
178     w/o needing to merge in every new change to the distributed style.css.
179   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
180   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
181     from a different directory.
182   * Generalised preprocesser loop protection code.
183   * Patch from James Westby to allow a description to be set for rss feeds.
184   * Patch from James Westby to add a template for the search form.
185   * Added a ddate plugin.
186   * Patch from James Westby to add a --sslcookie switch, which forces
187     cookies to only be sent over ssl connections to avoid interception.
188   * Fix preferences page on anonok wikis; still need to sign in to get
189     to the preferences page.
190   * Add toc (table of contents) plugin.
191   * Change htmlize, format, and sanitize hooks to use named parameters.
192   * Patch from James Westby to add an actions option to inline; this
193     adds Edit and Discussion links at the end of blog entries.
194   * Due to some css changes, you'll want to rebuild your wiki on upgrade
195     to this version. Will be handled automatically by the deb.
196   * Add processed date to aggregate preprocessor directive status output.
197
198  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
199
200 ikiwiki (1.21) unstable; urgency=low
201
202   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
203   * If a page links to itself, mark up the link text in a span with
204     class="selflink" so that it can be styled. I don't have a useful style
205     defined for that though.
206   * Call filter hooks on inlined page content.
207   * Support inlining pages raw, rather than creating a blog.
208   * Clean up yes/no parameter parsing in inline plugin.
209   * Implemented better cycle detection in the inline plugin; nested inlines
210     will now work.
211   * Add a map plugin contributed by Alessandro Dotti Contra.
212   * Add otl format plugin, which handles files as created by vimoutliner.
213   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
214   * Add first draft at a Restructured Text (rst) plugin, by Sergio
215     Talens-Oliag. Note that this has many known issues -- see the caveats on
216     the plugin's page.
217   * Credit everyone who wrote a plugin on the plugins' wiki pages.
218   * Fix utf-8 in blog post form.
219
220  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
221
222 ikiwiki (1.20) unstable; urgency=low
223
224   * Relicense the templates and basewiki under the 2-clause BSD license.
225     Since these can easily become part of other people's websites, they
226     should be under as permissive a license as possible.
227   * Add --syslog config option, to log to the syslog.
228   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
229     transient failure to fork (which I've seen happen in the wild).
230   * Fix a bug in the aggregator introduced last version that caused all
231     aggregator state to be lost during a non-aggregating build.
232
233  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
234
235 ikiwiki (1.19) unstable; urgency=low
236
237   * Fix several related bugs in page type determination during online editing.
238   * Add some locking to prevent 2 aggregators from running at once.
239   * Fix an infinite loop in the aggregator when finding a unique filename.
240
241  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
242
243 ikiwiki (1.18) unstable; urgency=low
244
245   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
246   * Add --version.
247   * Man page format fixups.
248   * If the meta plugin overides the page title, set a title_overridden
249     variable in the template to true. This allows doing things with the
250     templates conditional on the title being overriden.
251   * Add a %pagecase which maps lower-case page names to the actual case
252     used in the filename. Use this in bestlinks calculation instead of
253     forcing the link to lowercase.
254   * Also use %pagecase in various other places that want to check if a page
255     with a given name exists.
256   * This means that links to pages with mixed case names will now work,
257     even if the link is in some other case mixture, and mixed case pages
258     should be fully supported throughout ikiwiki.
259   * Recommend rebuilding wikis on upgrade to this version.
260
261  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
262
263 ikiwiki (1.17) unstable; urgency=low
264
265   * Disable tidy generator tag.
266   * Move tidy back to sanitize hook, found out how to only show body.
267   * Turn off tidy indentation too.
268   * Turn on HTML::Template loop_context_vars; not actually used in stock
269     templates but can be useful for things like making comma-delimited lists
270     of tags or what have you.
271   * Remove <br> from end of aggregate preprocessor directive output.
272   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
273     case-sensative filesystems like OSX.
274   * Improve markdown loading. First, try to load it as a proper perl module,
275     in case it was installed as one. Then fall back to trying
276     /usr/bin/markdown.
277   * Document in install page how to install markdown, since it has no
278     installation procedure in the upstream tarball.
279   * Set die_on_bad_params => 0 for all templates, to allow users to modify
280     them without annoyances.
281   * Suck in the page content when generating an inline archive page, to work
282     around the meta plugin's lack of caching of title metadata across runs.
283
284  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
285
286 ikiwiki (1.16) unstable; urgency=low
287
288   * Try to handle relative links in aggregated feeds. However,
289     the current support is a crude hack due to limitations of XML::Feed:
290     xml:base is not supported, neither is Content-Location. And of course,
291     relative links in RSS feeds are ill-undefined..
292   * Make aggregator save permalinks and author name to pages as metadata.
293   * Add permalink and author support to meta plugin, affecting RSS feeds
294     and blog pages.
295   * Various CSS and formatting changes.
296   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
297   * Add xhtml files to the default prune regexp.
298   * Also generate rel=bookmark links for permalinks.
299   * Fix the htmltidy plugin, which wasn't working due my breaking it when
300     I added it..
301   * Don't run tidy with -xml as that fails if the input is not well-formed.
302     Run it with -asxhtml instead, so it will output well-formed xhtml no
303     matter what the input.
304   * Disable tidy warnings too.
305   * Add a new format hook, and make tidy use it, since tidy can really only
306     operate on and output complete html documents, not the body chunks
307     that sanitise gets.
308   * Fix dates in rss feeds if running localised, so they're still rfc 822.
309
310  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
311
312 ikiwiki (1.15) unstable; urgency=low
313
314   * Remove CDPATH and other env vars perl taint checking doesn't like.
315     Closes: #381279
316   * Added created_before and created_after PageSpec limits.
317
318  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
319
320 ikiwiki (1.14) unstable; urgency=low
321
322   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
323     by 10% or so.
324   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
325   * Added many unit tests for pagespec_match.
326
327  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
328
329 ikiwiki (1.13) unstable; urgency=low
330
331   * ikiwiki can now download and aggregate feeds with its new aggregate
332     plugin, so it's possible to implement a Planet using ikiwiki!
333   * Add a run_hooks function for the common task of running all hooks of a
334     given type.
335   * Add a savestate hook.
336   * Don't put blog post forms on pages if there's no cgiurl set.
337   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
338     --wrappers to do that.
339   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
340     to update pages that haven't changed on disk.
341   * Change meta tags to use html entity-escaped text for values, so that
342     quotes and such can be represented in title tags.
343   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
344     for the above.
345   * Make --rebuild also cause --aggregate to re-download and write aggregated
346     pages.
347   * Avoid outputting duplicate meta info.
348   * Include title metadata on aggregated posts for capitalised and un-munged
349     titles.
350   * Title metadata of inlined pages now shows up in blogs and rss feeds.
351   * Fix issue with unicode filenames and updating the hyper estradier search
352     index. (Aka Please Please Please, let that be the last one.)
353   * Patch from Roland Mas to support an rss=no parameter to inline directives.
354     Closes: #380743
355   * Renamed GlobLists to PageSpecs.
356   * PageSpecs can now include nested parens, "and", and "or". This remains
357     backwards compatible to the old GlobList format. It's implemented by
358     treating the GlobList as a very limited microlanguage that is transformed
359     to perl code that does the matching.
360   * The old GlobList format is deprecated, and I encourage users to switch to
361     using the new PageSpec format. Compatability with the old format will be
362     removed at some point, possibly by 2.0.
363   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
364   * Add support for creation_month and creation_year to PageSpec.
365     Closes: #380680
366   * Changes to index file encoding.
367
368  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
369
370 ikiwiki (1.12) unstable; urgency=low
371
372   "Viva l'Italia!"
373   * New pagestats plugin from Enrico, which can generate a table counting
374     the backlinks for each page, or a del.icio.us style cloud.
375   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
376     the wikiformat plugin works. Thanks, Emanuele Aina.
377   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
378     display, running them through pagetitle. This removes ugly underscores and
379     other gunk from the display, much nicer. You may want to rebuild your wiki
380     when upgrading to get the cleanup globally.
381   * Polygen plugin from Enrico.
382   * htmltidy plugin from Faidon.
383   * Locale patch from Faidon:
384     - Adds a locale setting to setup files.
385     - Proper local time, if the locale configuration option is used.
386     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
387       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
388       impossible.
389   * Add getopt hook type, this allows plugins to add new command-line options.
390   * Add --tagbase option to tag plugin.
391   * Add exclude option in setup files, works same as --exclude.
392   * Put categories in rss feeds for tagged items.
393   * Allow preprocessor directives to be expanded in inlined blog pages.
394     However, to avoid inlining loops etc, don't expand inline directives in
395     inlined pages.
396   * fortune plugin (trivial)
397   * Tag plugins according to type.
398
399  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
400
401 ikiwiki (1.11) unstable; urgency=low
402
403   * Patch from Enrico that
404     - Adds a tag plugin that allows more easily tagging pages.
405       The meta plugin can also still be used for that, but the tag plugin
406       also lists a page's tags at the bottom of the page.
407     - Allows preprocessor directives to have parameters with no specified
408       value.
409     - Fixes preprocessor directive parameter parsing so that
410       foo=bar baz now means "foo=bar" and a "baz" with no value.
411   * Run pagetemplate hooks when inlining pages so that inlined pages also
412     list their tags.
413   * Make all plugins with pagetemplate hooks check that variables exist
414     on the template before setting them, for robustness.
415   * Switch pagetemplate hooks to using named parameters.
416   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
417     This will be the page that a source page will be part of, which is
418     different than the source page for inlined pages.
419   * Audited all plugins to endure they pass (page, destpage) to htmllink
420     appropriatly. This means inlining of various plugins will not work
421     properly, with correct links generated.
422
423  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
424
425 ikiwiki (1.10) unstable; urgency=low
426
427   * Run page through any relevant filters when generating a page preview.
428   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
429     default throughout the wiki, not only on wikitext pages. Decided to call
430     this a feature, and split the camelcase support out into a separate plugin
431     that is independant of wikitext.
432   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
433
434  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
435
436 ikiwiki (1.9) unstable; urgency=low
437
438   * Improve display of parentlinks and page title of toplevel index page.
439   * Patch from Faidon to use svn --limit when possible for recentchanges,
440     speeds up recentchanges a lot for wikis with more history.
441   * Patch from Recai to fix utf8 issues in git backend.
442   * Add wikitext markup plugin, which supports ".wiki" pages written in the
443     original wiki syntax, CamelCase links and all.
444   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
445     support, to edit pages etc without a web server.
446   * Display CGI processing errors if present.
447   * Fix from Faidon for a XML parser issue that breaks utf-8 for
448     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
449     area, and also way slow.
450   * Match 'web commit from' in SVN and git, these are web commits too.
451     (Faidon)
452   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
453     readable and avoid future mistakes. The patch seems to work and for the
454     first time I have a UTF-8 username ;-) (Faidon)
455   * Use form->field consistently, not form->param.
456   * Patch from Recai to allow selection of page type when creating a new page.
457     Default page type is inherited from the link clicked on to create the new
458     page.
459
460  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
461
462 ikiwiki (1.8) unstable; urgency=low
463
464   * Fix orphans plugin to not count a link to a nonexistant page as a reason
465     for a page not being an orphan.
466   * Support pinging services such as Technorati using XML-RPC to notify them
467     about changes to rss feeds.
468   * Parse svn log as xml for improved utf8 and security. Note that this makes
469     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
470   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
471     flagged string even if the locale causes it to generate utf8 output,
472     so make sure to let perl know it should be handled as utf8. Also,
473     the optimised version used for standard time formats won't work if the
474     user has changed locale, so drop it. Thanks, Faidon Liambotis.
475   * Fix re-encoding of the comments field to utf8 if a commit fails
476     due to a conflict. Thanks, Faidon Liambotis.
477   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
478     Liambotis.
479   * Add insane double encode/decode to utf8 around call to markdown.
480     This works around a truely strange bug, which is apparently a bug in
481     perl, #376329. Also added a test case for it.
482   * Improve layout of edit page so formatting help link is always visible w/o
483     getting in the way of the preview.
484   * Centralised all calls to HTML::Template and force all the templates
485     to be read as utf8.
486   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
487   * Introduce add_plugins and disable_plugins config options in setup files.
488     This allows adding or removing plugins w/o overriding the whole list of
489     default plugins, which makes it easier to upgrade when new default plugins
490     are added.
491   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
492     default (of course!). Based on a patch by Faidon Liambotis.
493   * Add a html plugin, which can be used to write wikis in raw html,
494     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
495     defaults to not processing .html files, since w/o this plugin they would
496     be copied unsanitised. With this plugin, it will process and html
497     sanitise them, like any other page type.
498   * Rebuilding wrappers is necessary on upgrade to this version.
499   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
500     will be automatically done on all upgrades.
501   * Don't send pings if the wiki is being rebuilt.
502   * Work around very innefficient behavior in File::Spec::abs2rel. Result
503     is a savings of 2 pointless fork/execs per link calculation, which
504     results in ~25% speedup of ikiwiki building its own doc wiki, and
505     about 35% speedup displaying RecentChanges!
506   * Make RecentChanges use a table and some CSS, should be much more readable.
507     No code changes involved.
508   * Encode & in diffurl in examples, to conform to pedantic rules.
509   * Speed up RecentChanges by another 40% or so with some memoization.
510   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
511     in time to build the doc wiki.
512
513  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
514
515 ikiwiki (1.7) unstable; urgency=low
516
517   * Updated logo from Recai with some kerning and alingment tuning.
518   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
519     changed some output.
520   * Copyright update.
521
522  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
523
524 ikiwiki (1.6) unstable; urgency=low
525
526   * YA utf-8 patch from Recai, this time to fix previewing a page so that
527     the text in the input box is re-encoded back to utf-8.
528   * -CSD does not affect modules, so readfile() was not using the utf-8 input
529     layer, which led to lots of problems; make it force read files as utf-8.
530     Closes: #373203
531   * Note that as a consequence, this version of ikiwiki will actually try to
532     parse utf8 in source files for the first time, which may expose broken
533     utf8 in wiki sources that was hidden before. Most common will be
534     perl warnings like "utf8 "\xE9" does not map to Unicode"
535   * writefile() likewise needs to use the utf8 output layer.
536   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
537     there.
538   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
539     given the readfile fix.
540   * Add utf-8 testcases for readfile and htmlize.
541   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
542     safe.
543   * More utf-8 fixes from Recai, partly to things I broke above:
544     - The serious problem is that writefile() saves the content in undecoded
545       format in CGI, hence all (non-ascii) chars are corrupted permanently.
546     - Comment field in edit page is not decoded and all the non-ascii chars in
547       this field are corrupted as the result.  We should decode it as we do it
548       for the content.
549     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
550       character in print.
551   * New SVG logo from Recai.
552
553  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
554
555 ikiwiki (1.5) unstable; urgency=low
556
557   * Add --timeformat config option to allow changing how dates are displayed.
558     Note that as a side effect, dates will now be displayed using the local
559     timezone, not as GMT.
560   * More security review.
561   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
562     for some handy stuff like:
563     - Using links as a kind of tag; creating blog pages that list all pages
564       containing a given tag/link or not containing some other tag.
565     - Subscribing to mail notifications whenever a change is made to a page
566       that is a backlink of page foo. Ie, "Please notify me of changes in all
567       pages that link to my home page in the wiki"
568     - Locking any pages that are linked to from a particular page, so that
569       lists of locks can be exposed in the wiki.
570   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
571     when a todo item is done, instead of the previous moving it to a different
572     subdir.
573   * Allow pagetemplate plugins to override *anything* in the template.
574   * Add a meta plugin, which allows specifying various metadata about pages,
575     like license and author. It also allows for inserting html link and meta
576     tags into html, overriding the title, and adding hidden WikiLinks, which
577     can be useful when using link-based globbing for page categorisation.
578   * Remove preprocessor directives from inlined pages.
579   * Allow simple preprocessor directive values to be specified w/o quotes.
580   * Add support for using git instead of subversion as the RCS backend,
581     tremendous thanks to Recai Oktaş for this.
582   * Doc updates for git.
583   * Fix absolute url munging in rss generation to support https, ftp, etc urls
584     not just http urls.
585   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
586     utf-8 for edit and other fields, and for recentchanges. There may still
587     be utf-8 issues with the preferences page though.
588
589  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
590
591 ikiwiki (1.4) unstable; urgency=low
592
593   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
594     very strange way of enabling proper XHTML <br /> type tags. Output html
595     should be always valid again now.
596   * The page name and parent links has switched from using a <h1> to a styled
597     <span>, so pages can use <h1> internally instead of needing to use <h2>.
598   * Updated all of ikiwiki's own wiki pages for that.
599   * Add pagetemplate hook, which can be used by plugins that want to mess
600     around with adding new stuff to the page template.
601   * Remove headercontent; the search plugin now adds the search box to the
602     header by registering a pagetemplate hook, and other plugins should do
603     similarly.
604   * Rebuilding on upgrade to this version is recommended.
605   * Add a html validity check to the test suite, using the wdg-html-validator,
606     if available.
607   * Make the html valid when there is nothing in the actions list.
608   * Reordered some function call parameters for consistency.
609   * Enable full utf-8 support for page input and output.
610   * Add a workaround for markdown, which does not work well with utf-8
611     strings.
612   * --getctime had bitrotted (well I only ever used it the once so far..),
613     fix and make it a bit more flexible
614   * rcs_getctime is changed, now rather than needing to loop over all pages,
615     it should just use the rcs to get the ctime of the passed file.
616   * When inlining a page in another one, links from the inlined page are now
617     expanded the same as they are when rendering the inlined page as a
618     standalone page. So rather than being expanded from the POV of the
619     inlining page, they are expanded from the POV of the inlined page.
620
621     For example, a link from blog/foo to "bar" will now link to blog/bar
622     if it exists. Previously this needed to be a link explicitly to
623     "blog/bar"; such links will also continue to work.
624
625     (This was slightly complex to do as the link still has to be constructed
626     relative to the inlining page.)
627   * Make page edit textarea resize to fit browser window.
628   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
629     do not need a full rebuild, in order to update any basewiki pages.
630
631  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
632
633 ikiwiki (1.3) unstable; urgency=low
634
635   * Fix the preinst introduced in the last version. Closes: #367458
636
637  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
638
639 ikiwiki (1.2) unstable; urgency=low
640
641   * Remove dups from the brokenlinks list.
642   * Add libc6-dev to dependencies, needed to build wrappers.
643   * Install wikilist in correct location. Closes: #367371
644
645  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
646
647 ikiwiki (1.1) unstable; urgency=low
648
649   * Rename inlinepage to depends, so that it can be used to refer to more
650     dependency relationships than just inlining. This will require a rebuild
651     on upgrade to this version.
652   * Move the rss link, put it in the blogpost form if there is one and at the
653     top if not. This is both nicer because easier to find, and it cleans up
654     the code which had used inlinepage as a flag for adding the link later.
655   * Allow the depends GlobList to be built up from multiple sources (such as
656     plugins) during a page render.
657   * Which means that more than one blog is now supported to appear on a
658     single page. (With some limitations, like only the last one getting an
659     rss file.)
660   * Added a plugin system.
661   * Added a pagecount plugin, enabled by default.
662   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
663   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
664     backlinks when the backlinks hadn't really changed.
665   * Moved inline page support, rss generation etc into the inline plugin,
666     enabled by default.
667   * Added brokenlinks plugin, not enabled by default, but rather handy.
668   * Fix several broken links in the doc wiki.
669   * Smarter behavior when creating a page and a page of the same name (but
670     different location) already exists.
671   * Add an orphans plugin for finding pages that nothing links to.
672   * Removed backlinks page, which it turns out nothing used.
673   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
674     it, this will allow for adding a unit test suite.
675   * Add unit tests for several core functions, including globlist_match,
676     dirname, basename, bestlink, linkify, pagetitle, titlepage.
677   * Smart globlist merging.
678   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
679     to pave the way for adding other RCS support. This also changes the
680     setup files, where before they had svn => 1 or svn => 0, now they have
681     rcs => "svn" or rcs => "".
682   * Add a debian/NEWS file with upgrade notes.
683   * Load whatever rcs module is specified, so new ones can be just dropped in
684     as plugins and work. (Well, in theory.)
685   * Add some basic docs about writing RCS modules.
686   * Broke search capability out into a plugin, removed the --hyperestraier
687     switch.
688   * Added smiley plugin, nicely controlled and documented by the smileys page.
689   * Copied in some smileys from Moin Moin.
690   * Allow links of the form [[some page|page]], with whitespace in the link
691     text.
692   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
693     and --disable-plugin htmlscrubber.
694   * Allow discussion links on pages to be turned off with --no-discussion.
695   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
696   * Add some new config items to the estseek.conf template, which are needed
697     by hyperestraier 1.2.3.
698
699  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
700
701 ikiwiki (1.0) unstable; urgency=low
702
703   * First official release.
704
705  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400