typo
[ikiwiki] / debian / changelog
1 ikiwiki (1.27) UNRELEASED; urgency=low
2
3   * Add a googlecalendar plugin. A bit special-purpose, but it shows
4     one way to to deal with user-supplied content that could cause XSS
5     issues w/o the htmlscrubber, and won't survive the scrubber.
6   * Work on firming up the plugin interface:
7     - Plugins should not need to load IkiWiki::Render to get commonly
8       used functions, so moved some functions from there to IkiWiki.
9     - Picked out the set of functions and variables that most plugins
10       use, documented them, and made IkiWiki export them by default,
11       like a proper perl module should.
12     - Use the other functions at your own risk.
13     - This is not quite complete, I still have to decide whether to
14       export some other things.
15   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
16     referring to stuff now exported by the IkiWiki module.
17   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
18     to declare which version of the interface your plugin needs.
19   * Anyone with a third-party ikiwiki plugin is strongly encouraged
20     to make like changes to it and avoid use of non-exported symboles from
21     "IkiWiki::".
22   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
23   * Support hyperestradier version 1.4.2, which adds a new required phraseform
24     setting.
25
26  -- Joey Hess <joeyh@debian.org>  Sat,  9 Sep 2006 18:56:10 -0400
27
28 ikiwiki (1.26) unstable; urgency=low
29
30   * Add a missing -n to tla undo call.
31   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
32     writes before consuming its whole stdin. Avoid this deadlock.
33   * Fix alt tags for outline checkboxes.
34
35  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
36
37 ikiwiki (1.25) unstable; urgency=low
38
39   * Add proper waitpid calls for open2ed processes throughout to avoid
40     zombies; this hit htmltidy especially badly.
41   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
42     subversion repos and fixing some other issues.
43   * Add support for tla, contributed by Clint Adams. Closes: #385936
44   * Add support for mercurial, contributed by Emanuele Aina.
45   * Include <link rel> tag for RSS feeds, used by some aggregators and
46     firefox to find the feed.
47   * Add a linkmap plugin (requires graphviz).
48
49  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
50
51 ikiwiki (1.24) unstable; urgency=low
52
53   * Simplify the data structure returned by rcs_recentchanges to avoid
54     each rcs plugin needing to form complex strings on its own.
55   * Fix another destpage issue in the inline directive. Closes: #385512
56     again.
57
58  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
59
60 ikiwiki (1.23) unstable; urgency=low
61
62   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
63
64  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
65
66 ikiwiki (1.22) unstable; urgency=low
67
68   * Change how the stylesheet url is determined in the templates: Remove
69     STYLEURL and add BASEURL to all templates (some already had it). This
70     new more general variable can be used to link to other things (eg, images)
71     from the template, as well as stylesheets.
72   * Fix a bug introduced last version to do with nested inlines.
73   * Allow preprocessor directives to span multiple lines, both to make
74     long ones with lots of values easier to write, and to allow for ones with
75     multi-line quoted values.
76   * Allow preprocessor directives to contain python-like triple-quoted
77     text blocks, for easy nesting of quotes inside.
78   * Add a template plugin.
79   * Make pagespec merge code smarter about merging duplicate pagespecs.
80   * Patch from Jordà Polo to make Setup::Standard support hashes in config
81     files.
82   * Change order of linkify and preprocess; first preprocess and then linkify.
83     This allows passing a wikilink inside a parameter to a preprocessor
84     directive without it being expanded to html, and leaking out of the
85     parameter, which had required some non-obvious use of triple-quoting
86     to avoid. Note that any preprocessor plugins that output something
87     that looks like a wikilink will now have it treated as such; AFAIK
88     this doesn't change any behavior though except for the template plugin.
89   * Enable preprocessor directives when previewing an edit.
90   * Make all pages pull in a local.css style sheet, if present. This won't
91     be included in ikiwiki, but can be created to make local styling changes
92     w/o needing to merge in every new change to the distributed style.css.
93   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
94   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
95     from a different directory.
96   * Generalised preprocesser loop protection code.
97   * Patch from James Westby to allow a description to be set for rss feeds.
98   * Patch from James Westby to add a template for the search form.
99   * Added a ddate plugin.
100   * Patch from James Westby to add a --sslcookie switch, which forces
101     cookies to only be sent over ssl connections to avoid interception.
102   * Fix preferences page on anonok wikis; still need to sign in to get
103     to the preferences page.
104   * Add toc (table of contents) plugin.
105   * Change htmlize, format, and sanitize hooks to use named parameters.
106   * Patch from James Westby to add an actions option to inline; this
107     adds Edit and Discussion links at the end of blog entries.
108   * Due to some css changes, you'll want to rebuild your wiki on upgrade
109     to this version. Will be handled automatically by the deb.
110   * Add processed date to aggregate preprocessor directive status output.
111
112  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
113
114 ikiwiki (1.21) unstable; urgency=low
115
116   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
117   * If a page links to itself, mark up the link text in a span with
118     class="selflink" so that it can be styled. I don't have a useful style
119     defined for that though.
120   * Call filter hooks on inlined page content.
121   * Support inlining pages raw, rather than creating a blog.
122   * Clean up yes/no parameter parsing in inline plugin.
123   * Implemented better cycle detection in the inline plugin; nested inlines
124     will now work.
125   * Add a map plugin contributed by Alessandro Dotti Contra.
126   * Add otl format plugin, which handles files as created by vimoutliner.
127   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
128   * Add first draft at a Restructured Text (rst) plugin, by Sergio
129     Talens-Oliag. Note that this has many known issues -- see the caveats on
130     the plugin's page.
131   * Credit everyone who wrote a plugin on the plugins' wiki pages.
132   * Fix utf-8 in blog post form.
133
134  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
135
136 ikiwiki (1.20) unstable; urgency=low
137
138   * Relicense the templates and basewiki under the 2-clause BSD license.
139     Since these can easily become part of other people's websites, they
140     should be under as permissive a license as possible.
141   * Add --syslog config option, to log to the syslog.
142   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
143     transient failure to fork (which I've seen happen in the wild).
144   * Fix a bug in the aggregator introduced last version that caused all
145     aggregator state to be lost during a non-aggregating build.
146
147  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
148
149 ikiwiki (1.19) unstable; urgency=low
150
151   * Fix several related bugs in page type determination during online editing.
152   * Add some locking to prevent 2 aggregators from running at once.
153   * Fix an infinite loop in the aggregator when finding a unique filename.
154
155  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
156
157 ikiwiki (1.18) unstable; urgency=low
158
159   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
160   * Add --version.
161   * Man page format fixups.
162   * If the meta plugin overides the page title, set a title_overridden
163     variable in the template to true. This allows doing things with the
164     templates conditional on the title being overriden.
165   * Add a %pagecase which maps lower-case page names to the actual case
166     used in the filename. Use this in bestlinks calculation instead of
167     forcing the link to lowercase.
168   * Also use %pagecase in various other places that want to check if a page
169     with a given name exists.
170   * This means that links to pages with mixed case names will now work,
171     even if the link is in some other case mixture, and mixed case pages
172     should be fully supported throughout ikiwiki.
173   * Recommend rebuilding wikis on upgrade to this version.
174
175  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
176
177 ikiwiki (1.17) unstable; urgency=low
178
179   * Disable tidy generator tag.
180   * Move tidy back to sanitize hook, found out how to only show body.
181   * Turn off tidy indentation too.
182   * Turn on HTML::Template loop_context_vars; not actually used in stock
183     templates but can be useful for things like making comma-delimited lists
184     of tags or what have you.
185   * Remove <br> from end of aggregate preprocessor directive output.
186   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
187     case-sensative filesystems like OSX.
188   * Improve markdown loading. First, try to load it as a proper perl module,
189     in case it was installed as one. Then fall back to trying
190     /usr/bin/markdown.
191   * Document in install page how to install markdown, since it has no
192     installation procedure in the upstream tarball.
193   * Set die_on_bad_params => 0 for all templates, to allow users to modify
194     them without annoyances.
195   * Suck in the page content when generating an inline archive page, to work
196     around the meta plugin's lack of caching of title metadata across runs.
197
198  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
199
200 ikiwiki (1.16) unstable; urgency=low
201
202   * Try to handle relative links in aggregated feeds. However,
203     the current support is a crude hack due to limitations of XML::Feed:
204     xml:base is not supported, neither is Content-Location. And of course,
205     relative links in RSS feeds are ill-undefined..
206   * Make aggregator save permalinks and author name to pages as metadata.
207   * Add permalink and author support to meta plugin, affecting RSS feeds
208     and blog pages.
209   * Various CSS and formatting changes.
210   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
211   * Add xhtml files to the default prune regexp.
212   * Also generate rel=bookmark links for permalinks.
213   * Fix the htmltidy plugin, which wasn't working due my breaking it when
214     I added it..
215   * Don't run tidy with -xml as that fails if the input is not well-formed.
216     Run it with -asxhtml instead, so it will output well-formed xhtml no
217     matter what the input.
218   * Disable tidy warnings too.
219   * Add a new format hook, and make tidy use it, since tidy can really only
220     operate on and output complete html documents, not the body chunks
221     that sanitise gets.
222   * Fix dates in rss feeds if running localised, so they're still rfc 822.
223
224  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
225
226 ikiwiki (1.15) unstable; urgency=low
227
228   * Remove CDPATH and other env vars perl taint checking doesn't like.
229     Closes: #381279
230   * Added created_before and created_after PageSpec limits.
231
232  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
233
234 ikiwiki (1.14) unstable; urgency=low
235
236   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
237     by 10% or so.
238   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
239   * Added many unit tests for pagespec_match.
240
241  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
242
243 ikiwiki (1.13) unstable; urgency=low
244
245   * ikiwiki can now download and aggregate feeds with its new aggregate
246     plugin, so it's possible to implement a Planet using ikiwiki!
247   * Add a run_hooks function for the common task of running all hooks of a
248     given type.
249   * Add a savestate hook.
250   * Don't put blog post forms on pages if there's no cgiurl set.
251   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
252     --wrappers to do that.
253   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
254     to update pages that haven't changed on disk.
255   * Change meta tags to use html entity-escaped text for values, so that
256     quotes and such can be represented in title tags.
257   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
258     for the above.
259   * Make --rebuild also cause --aggregate to re-download and write aggregated
260     pages.
261   * Avoid outputting duplicate meta info.
262   * Include title metadata on aggregated posts for capitalised and un-munged
263     titles.
264   * Title metadata of inlined pages now shows up in blogs and rss feeds.
265   * Fix issue with unicode filenames and updating the hyper estradier search
266     index. (Aka Please Please Please, let that be the last one.)
267   * Patch from Roland Mas to support an rss=no parameter to inline directives.
268     Closes: #380743
269   * Renamed GlobLists to PageSpecs.
270   * PageSpecs can now include nested parens, "and", and "or". This remains
271     backwards compatible to the old GlobList format. It's implemented by
272     treating the GlobList as a very limited microlanguage that is transformed
273     to perl code that does the matching.
274   * The old GlobList format is deprecated, and I encourage users to switch to
275     using the new PageSpec format. Compatability with the old format will be
276     removed at some point, possibly by 2.0.
277   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
278   * Add support for creation_month and creation_year to PageSpec.
279     Closes: #380680
280   * Changes to index file encoding.
281
282  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
283
284 ikiwiki (1.12) unstable; urgency=low
285
286   "Viva l'Italia!"
287   * New pagestats plugin from Enrico, which can generate a table counting
288     the backlinks for each page, or a del.icio.us style cloud.
289   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
290     the wikiformat plugin works. Thanks, Emanuele Aina.
291   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
292     display, running them through pagetitle. This removes ugly underscores and
293     other gunk from the display, much nicer. You may want to rebuild your wiki
294     when upgrading to get the cleanup globally.
295   * Polygen plugin from Enrico.
296   * htmltidy plugin from Faidon.
297   * Locale patch from Faidon:
298     - Adds a locale setting to setup files.
299     - Proper local time, if the locale configuration option is used.
300     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
301       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
302       impossible.
303   * Add getopt hook type, this allows plugins to add new command-line options.
304   * Add --tagbase option to tag plugin.
305   * Add exclude option in setup files, works same as --exclude.
306   * Put categories in rss feeds for tagged items.
307   * Allow preprocessor directives to be expanded in inlined blog pages.
308     However, to avoid inlining loops etc, don't expand inline directives in
309     inlined pages.
310   * fortune plugin (trivial)
311   * Tag plugins according to type.
312
313  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
314
315 ikiwiki (1.11) unstable; urgency=low
316
317   * Patch from Enrico that
318     - Adds a tag plugin that allows more easily tagging pages.
319       The meta plugin can also still be used for that, but the tag plugin
320       also lists a page's tags at the bottom of the page.
321     - Allows preprocessor directives to have parameters with no specified
322       value.
323     - Fixes preprocessor directive parameter parsing so that
324       foo=bar baz now means "foo=bar" and a "baz" with no value.
325   * Run pagetemplate hooks when inlining pages so that inlined pages also
326     list their tags.
327   * Make all plugins with pagetemplate hooks check that variables exist
328     on the template before setting them, for robustness.
329   * Switch pagetemplate hooks to using named parameters.
330   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
331     This will be the page that a source page will be part of, which is
332     different than the source page for inlined pages.
333   * Audited all plugins to endure they pass (page, destpage) to htmllink
334     appropriatly. This means inlining of various plugins will not work
335     properly, with correct links generated.
336
337  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
338
339 ikiwiki (1.10) unstable; urgency=low
340
341   * Run page through any relevant filters when generating a page preview.
342   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
343     default throughout the wiki, not only on wikitext pages. Decided to call
344     this a feature, and split the camelcase support out into a separate plugin
345     that is independant of wikitext.
346   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
347
348  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
349
350 ikiwiki (1.9) unstable; urgency=low
351
352   * Improve display of parentlinks and page title of toplevel index page.
353   * Patch from Faidon to use svn --limit when possible for recentchanges,
354     speeds up recentchanges a lot for wikis with more history.
355   * Patch from Recai to fix utf8 issues in git backend.
356   * Add wikitext markup plugin, which supports ".wiki" pages written in the
357     original wiki syntax, CamelCase links and all.
358   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
359     support, to edit pages etc without a web server.
360   * Display CGI processing errors if present.
361   * Fix from Faidon for a XML parser issue that breaks utf-8 for
362     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
363     area, and also way slow.
364   * Match 'web commit from' in SVN and git, these are web commits too.
365     (Faidon)
366   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
367     readable and avoid future mistakes. The patch seems to work and for the
368     first time I have a UTF-8 username ;-) (Faidon)
369   * Use form->field consistently, not form->param.
370   * Patch from Recai to allow selection of page type when creating a new page.
371     Default page type is inherited from the link clicked on to create the new
372     page.
373
374  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
375
376 ikiwiki (1.8) unstable; urgency=low
377
378   * Fix orphans plugin to not count a link to a nonexistant page as a reason
379     for a page not being an orphan.
380   * Support pinging services such as Technorati using XML-RPC to notify them
381     about changes to rss feeds.
382   * Parse svn log as xml for improved utf8 and security. Note that this makes
383     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
384   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
385     flagged string even if the locale causes it to generate utf8 output,
386     so make sure to let perl know it should be handled as utf8. Also,
387     the optimised version used for standard time formats won't work if the
388     user has changed locale, so drop it. Thanks, Faidon Liambotis.
389   * Fix re-encoding of the comments field to utf8 if a commit fails
390     due to a conflict. Thanks, Faidon Liambotis.
391   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
392     Liambotis.
393   * Add insane double encode/decode to utf8 around call to markdown.
394     This works around a truely strange bug, which is apparently a bug in
395     perl, #376329. Also added a test case for it.
396   * Improve layout of edit page so formatting help link is always visible w/o
397     getting in the way of the preview.
398   * Centralised all calls to HTML::Template and force all the templates
399     to be read as utf8.
400   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
401   * Introduce add_plugins and disable_plugins config options in setup files.
402     This allows adding or removing plugins w/o overriding the whole list of
403     default plugins, which makes it easier to upgrade when new default plugins
404     are added.
405   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
406     default (of course!). Based on a patch by Faidon Liambotis.
407   * Add a html plugin, which can be used to write wikis in raw html,
408     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
409     defaults to not processing .html files, since w/o this plugin they would
410     be copied unsanitised. With this plugin, it will process and html
411     sanitise them, like any other page type.
412   * Rebuilding wrappers is necessary on upgrade to this version.
413   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
414     will be automatically done on all upgrades.
415   * Don't send pings if the wiki is being rebuilt.
416   * Work around very innefficient behavior in File::Spec::abs2rel. Result
417     is a savings of 2 pointless fork/execs per link calculation, which
418     results in ~25% speedup of ikiwiki building its own doc wiki, and
419     about 35% speedup displaying RecentChanges!
420   * Make RecentChanges use a table and some CSS, should be much more readable.
421     No code changes involved.
422   * Encode & in diffurl in examples, to conform to pedantic rules.
423   * Speed up RecentChanges by another 40% or so with some memoization.
424   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
425     in time to build the doc wiki.
426
427  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
428
429 ikiwiki (1.7) unstable; urgency=low
430
431   * Updated logo from Recai with some kerning and alingment tuning.
432   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
433     changed some output.
434   * Copyright update.
435
436  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
437
438 ikiwiki (1.6) unstable; urgency=low
439
440   * YA utf-8 patch from Recai, this time to fix previewing a page so that
441     the text in the input box is re-encoded back to utf-8.
442   * -CSD does not affect modules, so readfile() was not using the utf-8 input
443     layer, which led to lots of problems; make it force read files as utf-8.
444     Closes: #373203
445   * Note that as a consequence, this version of ikiwiki will actually try to
446     parse utf8 in source files for the first time, which may expose broken
447     utf8 in wiki sources that was hidden before. Most common will be
448     perl warnings like "utf8 "\xE9" does not map to Unicode"
449   * writefile() likewise needs to use the utf8 output layer.
450   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
451     there.
452   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
453     given the readfile fix.
454   * Add utf-8 testcases for readfile and htmlize.
455   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
456     safe.
457   * More utf-8 fixes from Recai, partly to things I broke above:
458     - The serious problem is that writefile() saves the content in undecoded
459       format in CGI, hence all (non-ascii) chars are corrupted permanently.
460     - Comment field in edit page is not decoded and all the non-ascii chars in
461       this field are corrupted as the result.  We should decode it as we do it
462       for the content.
463     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
464       character in print.
465   * New SVG logo from Recai.
466
467  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
468
469 ikiwiki (1.5) unstable; urgency=low
470
471   * Add --timeformat config option to allow changing how dates are displayed.
472     Note that as a side effect, dates will now be displayed using the local
473     timezone, not as GMT.
474   * More security review.
475   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
476     for some handy stuff like:
477     - Using links as a kind of tag; creating blog pages that list all pages
478       containing a given tag/link or not containing some other tag.
479     - Subscribing to mail notifications whenever a change is made to a page
480       that is a backlink of page foo. Ie, "Please notify me of changes in all
481       pages that link to my home page in the wiki"
482     - Locking any pages that are linked to from a particular page, so that
483       lists of locks can be exposed in the wiki.
484   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
485     when a todo item is done, instead of the previous moving it to a different
486     subdir.
487   * Allow pagetemplate plugins to override *anything* in the template.
488   * Add a meta plugin, which allows specifying various metadata about pages,
489     like license and author. It also allows for inserting html link and meta
490     tags into html, overriding the title, and adding hidden WikiLinks, which
491     can be useful when using link-based globbing for page categorisation.
492   * Remove preprocessor directives from inlined pages.
493   * Allow simple preprocessor directive values to be specified w/o quotes.
494   * Add support for using git instead of subversion as the RCS backend,
495     tremendous thanks to Recai Oktaş for this.
496   * Doc updates for git.
497   * Fix absolute url munging in rss generation to support https, ftp, etc urls
498     not just http urls.
499   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
500     utf-8 for edit and other fields, and for recentchanges. There may still
501     be utf-8 issues with the preferences page though.
502
503  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
504
505 ikiwiki (1.4) unstable; urgency=low
506
507   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
508     very strange way of enabling proper XHTML <br /> type tags. Output html
509     should be always valid again now.
510   * The page name and parent links has switched from using a <h1> to a styled
511     <span>, so pages can use <h1> internally instead of needing to use <h2>.
512   * Updated all of ikiwiki's own wiki pages for that.
513   * Add pagetemplate hook, which can be used by plugins that want to mess
514     around with adding new stuff to the page template.
515   * Remove headercontent; the search plugin now adds the search box to the
516     header by registering a pagetemplate hook, and other plugins should do
517     similarly.
518   * Rebuilding on upgrade to this version is recommended.
519   * Add a html validity check to the test suite, using the wdg-html-validator,
520     if available.
521   * Make the html valid when there is nothing in the actions list.
522   * Reordered some function call parameters for consistency.
523   * Enable full utf-8 support for page input and output.
524   * Add a workaround for markdown, which does not work well with utf-8
525     strings.
526   * --getctime had bitrotted (well I only ever used it the once so far..),
527     fix and make it a bit more flexible
528   * rcs_getctime is changed, now rather than needing to loop over all pages,
529     it should just use the rcs to get the ctime of the passed file.
530   * When inlining a page in another one, links from the inlined page are now
531     expanded the same as they are when rendering the inlined page as a
532     standalone page. So rather than being expanded from the POV of the
533     inlining page, they are expanded from the POV of the inlined page.
534
535     For example, a link from blog/foo to "bar" will now link to blog/bar
536     if it exists. Previously this needed to be a link explicitly to
537     "blog/bar"; such links will also continue to work.
538
539     (This was slightly complex to do as the link still has to be constructed
540     relative to the inlining page.)
541   * Make page edit textarea resize to fit browser window.
542   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
543     do not need a full rebuild, in order to update any basewiki pages.
544
545  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
546
547 ikiwiki (1.3) unstable; urgency=low
548
549   * Fix the preinst introduced in the last version. Closes: #367458
550
551  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
552
553 ikiwiki (1.2) unstable; urgency=low
554
555   * Remove dups from the brokenlinks list.
556   * Add libc6-dev to dependencies, needed to build wrappers.
557   * Install wikilist in correct location. Closes: #367371
558
559  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
560
561 ikiwiki (1.1) unstable; urgency=low
562
563   * Rename inlinepage to depends, so that it can be used to refer to more
564     dependency relationships than just inlining. This will require a rebuild
565     on upgrade to this version.
566   * Move the rss link, put it in the blogpost form if there is one and at the
567     top if not. This is both nicer because easier to find, and it cleans up
568     the code which had used inlinepage as a flag for adding the link later.
569   * Allow the depends GlobList to be built up from multiple sources (such as
570     plugins) during a page render.
571   * Which means that more than one blog is now supported to appear on a
572     single page. (With some limitations, like only the last one getting an
573     rss file.)
574   * Added a plugin system.
575   * Added a pagecount plugin, enabled by default.
576   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
577   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
578     backlinks when the backlinks hadn't really changed.
579   * Moved inline page support, rss generation etc into the inline plugin,
580     enabled by default.
581   * Added brokenlinks plugin, not enabled by default, but rather handy.
582   * Fix several broken links in the doc wiki.
583   * Smarter behavior when creating a page and a page of the same name (but
584     different location) already exists.
585   * Add an orphans plugin for finding pages that nothing links to.
586   * Removed backlinks page, which it turns out nothing used.
587   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
588     it, this will allow for adding a unit test suite.
589   * Add unit tests for several core functions, including globlist_match,
590     dirname, basename, bestlink, linkify, pagetitle, titlepage.
591   * Smart globlist merging.
592   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
593     to pave the way for adding other RCS support. This also changes the
594     setup files, where before they had svn => 1 or svn => 0, now they have
595     rcs => "svn" or rcs => "".
596   * Add a debian/NEWS file with upgrade notes.
597   * Load whatever rcs module is specified, so new ones can be just dropped in
598     as plugins and work. (Well, in theory.)
599   * Add some basic docs about writing RCS modules.
600   * Broke search capability out into a plugin, removed the --hyperestraier
601     switch.
602   * Added smiley plugin, nicely controlled and documented by the smileys page.
603   * Copied in some smileys from Moin Moin.
604   * Allow links of the form [[some page|page]], with whitespace in the link
605     text.
606   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
607     and --disable-plugin htmlscrubber.
608   * Allow discussion links on pages to be turned off with --no-discussion.
609   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
610   * Add some new config items to the estseek.conf template, which are needed
611     by hyperestraier 1.2.3.
612
613  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
614
615 ikiwiki (1.0) unstable; urgency=low
616
617   * First official release.
618
619  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400