* Add a textile format plugin contributed by mazirian.
[ikiwiki] / debian / changelog
1 ikiwiki (1.37) UNRELEASED; urgency=low
2
3   * Add mirrorlist plugin.
4   * Fixed permissions of some files that were 600 in the tarball. (Did not
5     affect the deb).
6   * Avoid creating edit links when the cgi url is not known.
7   * Avoid displaying discussion links at all, if there's not a discussion
8     page, when the cgi url isn't known.
9   * Before, svn was used as the RCS by default unless configured otherwise,
10     now it defaults to using no RCS unless configured to do so, to avoid some
11     suprising behavior when using a setup file and not uncommenting any RCS
12     options.
13   * Fix some bugs in the commit email sending code.
14   * Improve code that ignores files in the underlaydir if the srcdir has a
15     file building the same page. Now it will work even if the extensions of
16     the source files differ.
17   * Initial work on internationalization of the program code. po/ikiwiki.pot
18     is available for translation.
19   * Export gettext() from IkiWiki module.
20   * Don't put discussion links on discussion pages.
21   * Allow disabling of plugins included in goodstuff.
22   * Add a textile format plugin contributed by mazirian.
23
24  -- Joey Hess <joeyh@debian.org>  Fri, 29 Dec 2006 00:17:58 -0500
25
26 ikiwiki (1.36) unstable; urgency=low
27
28   * Fix various links on the hyperestraier pages.
29   * Use POST for poll to avoid some robots.
30   * Fix sometimes broken links to Discussion pages from blog pages.
31   * Add userdir config setting.
32   * Fix man page perms in install.
33   * Fix an issue with inlining a page with a rss feed inside another
34     page with an rss feed.
35   * Turn $config{wiki_file_prune_regexps} into an array that is easier to
36     manipulate.
37   * Only exclude rss and atom files from processing if the inline plugin
38     is enabled and that feed type is enabled. Else it's just a copyable file
39     type.
40   * Move rss and atom option handling code into the inline plugin.
41   * Applied a rather old patch from Recai to fix the "pruning is too strict"
42     issue. Now you can have wiki source directories inside dotdirs and the
43     like, if you want.
44   * Patch from Emanuele Aina to fix modification time code in mercurual
45     backend.
46   * Add support for links of the form [[/foo]]
47   * Fix code to make absolute urls for rss feeds, was missing some urls.
48   * Fix double-escaping of html entities in titles etc in rss feeds
49     that occured if escaped characters were present in the page filename.
50
51  -- Joey Hess <joeyh@debian.org>  Fri, 22 Dec 2006 15:55:05 -0500
52
53 ikiwiki (1.35) unstable; urgency=low
54
55   * Fix daemonisation code to only do daemon setup things after forking the
56     child process.
57   * The hack used to make the pagetemplate hook have access to the editpage
58     template won't work with CGI::FormBuilder 3.0401, so disable it for now.
59   * CGI::FormBuilder 3.0401 seems to work ok now with ikiwiki, although
60     there might still be bugs lurking..
61
62  -- Joey Hess <joeyh@debian.org>  Fri,  1 Dec 2006 19:14:36 -0500
63
64 ikiwiki (1.34.2) unstable; urgency=low
65
66   * Allow /etc/ikiwiki/wikilist to list just the names of users, if so then
67     ~user/.ikiwiki/wikilist will be read.
68   * Fix url absolution code in inline plugin to support class and id fields in
69     links and imgs, and to support anchor urls.
70   * More build deps updates.
71   * /dev/null fortune failures
72
73  -- Joey Hess <joeyh@debian.org>  Tue, 28 Nov 2006 12:58:47 -0500
74
75 ikiwiki (1.34.1) unstable; urgency=low
76
77   * Add libtime-duration-perl to build deps, as it's used by the svn module
78     which is now tested at build.
79
80  -- Joey Hess <joeyh@debian.org>  Mon, 27 Nov 2006 12:26:12 -0500
81
82 ikiwiki (1.34) unstable; urgency=low
83
84   * Add an openid plugin to support logging in using OpenID.
85   * Web commits by OpenID users will record the full OpenID url for the user,
86     but in recentchanges, these urls will be converted to a simplified display
87     form+link.
88   * Modified svn, git, tla backends to recognise such web commits.
89   * Move httpauth support to a plugin.
90   * Add openidsignup config option.
91   * Make the openid plugin support the callbacks from myopenid.com via its
92     affiliate program.
93   * Add toggle plugin.
94   * Add a poll plugin.
95   * Add quick mode for archive page generation.
96   * Introduce the goodstuff bundle. This is a kind of plugin, that just enables
97     many other plugins. It's an easy way to boost ikiwiki from its default,
98     basic wiki, to a full-featured wiki, without manually picking the right
99     set of plugins. New plugins will be added to goodstuff from time to
100     time.
101   * Change how post signin actions are propigated through the signin process;
102     they're now stored in the session.
103   * Add optional "desc" parameter to shortcut definitions.
104   * Avoid locking the wiki at all when handling some basic cgi stuff
105     (searches, recentchanges).
106   * Add "last" parameter to hook function. Very basic ordering, and hopefully
107     nothing more spohisticated will be needed.
108   * Add formbuilder_setup and formbuilder hooks.
109   * Split out a passwordauth module, that holds all the traditional password
110     based authentication etc code. It's enabled by default, but can be disabled
111     if you want only openid or some other auth method.
112   * Rename ikiwiki.pl so MakeMaker doesn't see it, and install it.
113   * Add some code to the build system that tries to determine if the
114     lib installation directory is in @INC. If it's not, munge ikiwiki
115     to hardcode the path to the lib directory. This should allow installing
116     ikiwiki in nonstandard locations, including home directories, by just
117     setting PREFIX at build time.
118   * Fix nested examples directory in deb.
119   * Add a test suite for the mercurial backend, contributed by Emanuele Aina.
120   * Add a test suite for the svn backend.
121   * Add a test suite for the git backend, from Recai
122   * Daemonize before sending RPC pings, since that can take a while
123     and/or hang.
124   * Daemonize before sending commit mails, as that can also take a long
125     time/hang if the mail server is unhappy.
126   * Factor out commit mail sending code into new function.
127   * Change rcs_commit, it is now passed the name of the user doing the commit
128     and their IP address, and needs to construct its own commit message
129     containing them, or do something more appropriate for the given RCS.
130   * Add softwaresite example.
131   * Mercurial backend improvements, including --get-ctime support. (Emanuele
132     Aina)
133   * Git backend improvements, including bug fixes and better robustness,
134     from Recai.
135
136  -- Joey Hess <joeyh@debian.org>  Sun, 26 Nov 2006 20:46:56 -0500
137
138 ikiwiki (1.33) unstable; urgency=low
139
140   * Fix issue with aggregate plugin updating expired pages.
141   * Avoid syntax errors in templates used by the template plugin crashing
142     ikiwiki.
143   * Enable utf8 file IO in aggregate plugin.
144   * Fix some issues with the new registration form.
145   * Patch from Ethan Glasser Camp to add a skip option to the inline plugin.
146   * Make sure to check for errors from every eval.
147   * Fix img plugin's handling of adding dependencies for images that do not
148     yet exist.
149   * Work around a strange bug in CGI::FormBuilder 3.0401 that makes
150     FORM-SUBMIT unusable on customised formbuilder templates. For now,
151     hardcode the submit buttons in editpage.tmpl instead of using the
152     template variable, which is ok, since the buttons are static.
153   * Work with hyperestraier 1.4.9.
154
155  -- Joey Hess <joeyh@debian.org>  Wed, 15 Nov 2006 18:32:26 -0500
156
157 ikiwiki (1.32) unstable; urgency=low
158
159   * Add a separate pass to find page links, and only render each page once,
160     instead of over and over. Typical speedup is ~4x. Max possible speedup:
161     8x.
162   * Add "scan" parameter to hook(), which is used to make the hook be called
163     during the scanning pass, as well as the render pass. The meta and tag
164     plugins need to use the new scan parameter, so will any others that modify
165     %links.
166   * Now that links are calculated in a separate pass, it can also
167     precalculate backlinks in one pass, which is O(N^2) instead of the
168     previous code that was O(N^3). A very nice speedup for wikis with lots
169     (thousands) of pages.
170   * Stylish update to the ikiwiki logo, thanks to Recai Oktaş and Selçuk
171     Erdem.
172   * Add a default stylesheet entry for the pagecloud.
173   * Add examples page with some examples of things that can be done using
174     ikiwiki, like a weblog. The examples can be copied into a user's wiki
175     for a quick start, without needing to learn everything about how to put
176     them together.
177   * Install the source of the examples into /usr/share/doc/ikiwiki/examples.
178   * Add perlmagick to build-depends so syntax check of img plugin works.
179     Closes: #396702
180   * Improve login/register process, the login dialog has only name and
181     password fields, which allows more web browsers to regognise it as a login
182     field, and is less confusing.
183   * Implemented expiry options for aggregate plugin.
184   * Use precalculated backlinks info when determining if files need an update
185     due to a page they link to being added/removed. Mostly significant if
186     there are lots of pages.
187   * Remove duplicate link info when saving index. In some cases it could
188     pile up rather badly. (Probably not the best way to deal with this
189     problem.)
190   * Patch from James Westby to support podcasting, photoblogging, vidcasting,
191     or what have you, by creating enclosures for non-page items that are
192     included in feeds.
193
194  -- Joey Hess <joeyh@debian.org>  Fri,  3 Nov 2006 14:46:37 -0500
195
196 ikiwiki (1.31) unstable; urgency=low
197
198   * Patch from Pawel Tecza to cp -a the templates in the Makefile.
199   * Change the rss feed title from the wikiname to the page title, with
200     an exception for the wiki's toplevel index page, which will still use the
201     wikiname as the feed title.
202     Overriding the page title with meta title already overrode the rss feed
203     tittle.
204   * Add an img plugin, based on Christian Mock's img plugin, but stripped
205     down to the bare essentials. Useful for handling large images on websites.
206   * Sanitize possibly problimatic characters out of the polygen grammar names,
207     just in case. Should not be exploitable anyway, since it only tries to run
208     polygen after finding the specified grammar file.
209   * Add missing dependency on the URI perl module.
210   * Add basic spam fighting tool for admins: An admin's prefs page now allows
211     editing a list of banned users.
212
213  -- Joey Hess <joeyh@debian.org>  Fri, 27 Oct 2006 23:16:33 -0400
214
215 ikiwiki (1.30) unstable; urgency=low
216
217   * Add no_override parameter to hook().
218   * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
219     plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
220     can be configured using a page in wiki.
221   * Fix support for --pingurl at the command line.
222   * Fix a subtle bug in will_render that broke some builds, by only clearing
223     items from renderedfiles the first time per build.
224   * Wrap entire technortati ping operation in an eval to catch all possible
225     failure modes, after I observed a simple ->value crashing ikiwiki when
226     a ping failed.
227
228  -- Joey Hess <joeyh@debian.org>  Mon, 16 Oct 2006 15:17:38 -0400
229
230 ikiwiki (1.29) unstable; urgency=low
231
232   * Patch from Paul Tötterman to use CP in the Makefile.
233   * Patch from Alec Berryman adding a http_auth config item that allows
234     using HTTP Authentication instead of ikiwiki's built in authentication.
235     Useful for eg, large sites with their own previously existing user auth
236     setup. Closes: #384534
237   * Change %renderedfiles to store an array of files rendered from a given
238     source file, to allow tracking of extra rendered files like rss feeds.
239   * Note that plugins that accessed this variable will need to be updated!
240     The plugin interface has been increased to version 1.01 for this change.
241     As few plugins use %renderedfiles I haven't done anything else to ensure
242     compatability of old plugins.
243   * Add will_render function to the plugin interface, used to register that a
244     page renders a destination file, and do some security checks. Previously
245     but no longer rendered files will be cleaned up.
246   * Use will_render in the inline and linkmap plugins.
247   * You will need to rebuild your wiki on upgrade to this version.
248   * Atom feed support based on a patch by Clint Adams.
249   * Add feeds=no option to inline preprocessor directive to turn off all types
250     of feeds.
251   * $IkiWiki::version now holds the program version, and is accessible to
252     plugins.
253   * Make the aggregate plugin emphasize error messages.
254   * Patch from Recai to limit recentchanges to displaying max 10 files for a
255     given changeset (to avoid large number of file changes excessively
256     bloating the page).
257
258  -- Joey Hess <joeyh@debian.org>  Fri, 13 Oct 2006 23:14:28 -0400
259
260 ikiwiki (1.28) unstable; urgency=low
261
262   * inline: Add ability to sort by page name, based on a patch from
263     Benjamin A'Lee.
264   * Fix a forkbomb in various calls to IPC::Open2, which has a highly
265     braindead interface. Closes: #389383
266   * Don't rm -rf ikiwiki on distclean, since a) there's no such file
267     and b) those poor Mac OSX users and their case insensative files!
268   * Don't fail syntax check if Text::Typography isn't installed.
269     Closes: #389406
270
271  -- Joey Hess <joeyh@debian.org>  Tue, 26 Sep 2006 02:08:17 -0400
272
273 ikiwiki (1.27) unstable; urgency=low
274
275   * Work on firming up the plugin interface:
276     - Plugins should not need to load IkiWiki::Render to get commonly
277       used functions, so moved some functions from there to IkiWiki.
278     - Picked out the set of functions and variables that most plugins
279       use, documented them, and made IkiWiki export them by default,
280       like a proper perl module should.
281     - Use the other functions at your own risk.
282     - This is not quite complete, I still have to decide whether to
283       export some other things.
284   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
285     referring to stuff now exported by the IkiWiki module.
286   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
287     to declare which version of the interface your plugin needs.
288   * Anyone with a third-party ikiwiki plugin is strongly encouraged
289     to make like changes to it and avoid use of non-exported symbols from
290     "IkiWiki::".
291   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
292   * Support hyperestradier version 1.4.2, which adds a new required phraseform
293     setting.
294   * If an inlined page has a permalink, link the page title to that.
295   * Patch from Recai to use utf8 when reading the setup file, so that
296     utf8 wikinames from there will be used properly.
297   * Patch from Recai to kill utf-8 on the wiki name when generating the
298     session cookie.
299   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
300   * Fix a baseurl problem in hyperestradier search results.
301   * Add a stub local.css to avoid problems with 404's.
302   * Patch from Recai to fix a wide character warning from the search plugin
303     during setup if the wikiname contains utf8.
304   * Yet another fix for those poor case-insensative OS X users.
305   * pagetemplate hooks are now also called when generating cgi pages.
306   * Add a favicon plugin, which simply adds a link tag for an icon to each
307     page (and cgis).
308   * Patch from James Westby to deal with the case where you're editing a
309     new page, hit cancel, and need to be redirected to somewhere sane.
310   * Various documentation improvements by various wiki users.
311   * Support Text::Markdown from CPAN, which has a different interface from
312     the original markdown or the one in Debian.
313   * Version the libcgi-session-perl dependency, some features that need
314     the new version are used in some cases (sslcookie).
315   * Numerous tla fixes from Clint.
316   * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
317     a multi-resolution favicon.ico.
318   * README.Debian: typo Closes: #388110
319   * chomp trailing newline at the end of templates read in by the template
320     plugin, to allow use of the template preprocessor directive in
321     whitespace-sensative situations. Closes: #387073
322   * Patch from James Westby to make the location of the estseek.cgi script
323     configurable.
324   * Add typography (SmartyPants) plugin by Recai.
325   * Add --render mode, which can be used to preview an edit at the command
326     line by test rendering a single page.
327   * Add a googlecalendar plugin. A bit special-purpose, but it shows
328     one way to to deal with user-supplied content that could cause XSS
329     issues w/o the htmlscrubber, and won't survive the scrubber.
330
331  -- Joey Hess <joeyh@debian.org>  Sun, 24 Sep 2006 00:02:21 -0400
332
333 ikiwiki (1.26) unstable; urgency=low
334
335   * Add a missing -n to tla undo call.
336   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
337     writes before consuming its whole stdin. Avoid this deadlock.
338   * Fix alt tags for outline checkboxes.
339
340  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
341
342 ikiwiki (1.25) unstable; urgency=low
343
344   * Add proper waitpid calls for open2ed processes throughout to avoid
345     zombies; this hit htmltidy especially badly.
346   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
347     subversion repos and fixing some other issues.
348   * Add support for tla, contributed by Clint Adams. Closes: #385936
349   * Add support for mercurial, contributed by Emanuele Aina.
350   * Include <link rel> tag for RSS feeds, used by some aggregators and
351     firefox to find the feed.
352   * Add a linkmap plugin (requires graphviz).
353
354  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
355
356 ikiwiki (1.24) unstable; urgency=low
357
358   * Simplify the data structure returned by rcs_recentchanges to avoid
359     each rcs plugin needing to form complex strings on its own.
360   * Fix another destpage issue in the inline directive. Closes: #385512
361     again.
362
363  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
364
365 ikiwiki (1.23) unstable; urgency=low
366
367   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
368
369  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
370
371 ikiwiki (1.22) unstable; urgency=low
372
373   * Change how the stylesheet url is determined in the templates: Remove
374     STYLEURL and add BASEURL to all templates (some already had it). This
375     new more general variable can be used to link to other things (eg, images)
376     from the template, as well as stylesheets.
377   * Fix a bug introduced last version to do with nested inlines.
378   * Allow preprocessor directives to span multiple lines, both to make
379     long ones with lots of values easier to write, and to allow for ones with
380     multi-line quoted values.
381   * Allow preprocessor directives to contain python-like triple-quoted
382     text blocks, for easy nesting of quotes inside.
383   * Add a template plugin.
384   * Make pagespec merge code smarter about merging duplicate pagespecs.
385   * Patch from Jordà Polo to make Setup::Standard support hashes in config
386     files.
387   * Change order of linkify and preprocess; first preprocess and then linkify.
388     This allows passing a wikilink inside a parameter to a preprocessor
389     directive without it being expanded to html, and leaking out of the
390     parameter, which had required some non-obvious use of triple-quoting
391     to avoid. Note that any preprocessor plugins that output something
392     that looks like a wikilink will now have it treated as such; AFAIK
393     this doesn't change any behavior though except for the template plugin.
394   * Enable preprocessor directives when previewing an edit.
395   * Make all pages pull in a local.css style sheet, if present. This won't
396     be included in ikiwiki, but can be created to make local styling changes
397     w/o needing to merge in every new change to the distributed style.css.
398   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
399   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
400     from a different directory.
401   * Generalised preprocesser loop protection code.
402   * Patch from James Westby to allow a description to be set for rss feeds.
403   * Patch from James Westby to add a template for the search form.
404   * Added a ddate plugin.
405   * Patch from James Westby to add a --sslcookie switch, which forces
406     cookies to only be sent over ssl connections to avoid interception.
407   * Fix preferences page on anonok wikis; still need to sign in to get
408     to the preferences page.
409   * Add toc (table of contents) plugin.
410   * Change htmlize, format, and sanitize hooks to use named parameters.
411   * Patch from James Westby to add an actions option to inline; this
412     adds Edit and Discussion links at the end of blog entries.
413   * Due to some css changes, you'll want to rebuild your wiki on upgrade
414     to this version. Will be handled automatically by the deb.
415   * Add processed date to aggregate preprocessor directive status output.
416
417  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
418
419 ikiwiki (1.21) unstable; urgency=low
420
421   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
422   * If a page links to itself, mark up the link text in a span with
423     class="selflink" so that it can be styled. I don't have a useful style
424     defined for that though.
425   * Call filter hooks on inlined page content.
426   * Support inlining pages raw, rather than creating a blog.
427   * Clean up yes/no parameter parsing in inline plugin.
428   * Implemented better cycle detection in the inline plugin; nested inlines
429     will now work.
430   * Add a map plugin contributed by Alessandro Dotti Contra.
431   * Add otl format plugin, which handles files as created by vimoutliner.
432   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
433   * Add first draft at a Restructured Text (rst) plugin, by Sergio
434     Talens-Oliag. Note that this has many known issues -- see the caveats on
435     the plugin's page.
436   * Credit everyone who wrote a plugin on the plugins' wiki pages.
437   * Fix utf-8 in blog post form.
438
439  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
440
441 ikiwiki (1.20) unstable; urgency=low
442
443   * Relicense the templates and basewiki under the 2-clause BSD license.
444     Since these can easily become part of other people's websites, they
445     should be under as permissive a license as possible.
446   * Add --syslog config option, to log to the syslog.
447   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
448     transient failure to fork (which I've seen happen in the wild).
449   * Fix a bug in the aggregator introduced last version that caused all
450     aggregator state to be lost during a non-aggregating build.
451
452  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
453
454 ikiwiki (1.19) unstable; urgency=low
455
456   * Fix several related bugs in page type determination during online editing.
457   * Add some locking to prevent 2 aggregators from running at once.
458   * Fix an infinite loop in the aggregator when finding a unique filename.
459
460  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
461
462 ikiwiki (1.18) unstable; urgency=low
463
464   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
465   * Add --version.
466   * Man page format fixups.
467   * If the meta plugin overides the page title, set a title_overridden
468     variable in the template to true. This allows doing things with the
469     templates conditional on the title being overriden.
470   * Add a %pagecase which maps lower-case page names to the actual case
471     used in the filename. Use this in bestlinks calculation instead of
472     forcing the link to lowercase.
473   * Also use %pagecase in various other places that want to check if a page
474     with a given name exists.
475   * This means that links to pages with mixed case names will now work,
476     even if the link is in some other case mixture, and mixed case pages
477     should be fully supported throughout ikiwiki.
478   * Recommend rebuilding wikis on upgrade to this version.
479
480  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
481
482 ikiwiki (1.17) unstable; urgency=low
483
484   * Disable tidy generator tag.
485   * Move tidy back to sanitize hook, found out how to only show body.
486   * Turn off tidy indentation too.
487   * Turn on HTML::Template loop_context_vars; not actually used in stock
488     templates but can be useful for things like making comma-delimited lists
489     of tags or what have you.
490   * Remove <br> from end of aggregate preprocessor directive output.
491   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
492     case-sensative filesystems like OSX.
493   * Improve markdown loading. First, try to load it as a proper perl module,
494     in case it was installed as one. Then fall back to trying
495     /usr/bin/markdown.
496   * Document in install page how to install markdown, since it has no
497     installation procedure in the upstream tarball.
498   * Set die_on_bad_params => 0 for all templates, to allow users to modify
499     them without annoyances.
500   * Suck in the page content when generating an inline archive page, to work
501     around the meta plugin's lack of caching of title metadata across runs.
502
503  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
504
505 ikiwiki (1.16) unstable; urgency=low
506
507   * Try to handle relative links in aggregated feeds. However,
508     the current support is a crude hack due to limitations of XML::Feed:
509     xml:base is not supported, neither is Content-Location. And of course,
510     relative links in RSS feeds are ill-undefined..
511   * Make aggregator save permalinks and author name to pages as metadata.
512   * Add permalink and author support to meta plugin, affecting RSS feeds
513     and blog pages.
514   * Various CSS and formatting changes.
515   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
516   * Add xhtml files to the default prune regexp.
517   * Also generate rel=bookmark links for permalinks.
518   * Fix the htmltidy plugin, which wasn't working due my breaking it when
519     I added it..
520   * Don't run tidy with -xml as that fails if the input is not well-formed.
521     Run it with -asxhtml instead, so it will output well-formed xhtml no
522     matter what the input.
523   * Disable tidy warnings too.
524   * Add a new format hook, and make tidy use it, since tidy can really only
525     operate on and output complete html documents, not the body chunks
526     that sanitise gets.
527   * Fix dates in rss feeds if running localised, so they're still rfc 822.
528
529  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
530
531 ikiwiki (1.15) unstable; urgency=low
532
533   * Remove CDPATH and other env vars perl taint checking doesn't like.
534     Closes: #381279
535   * Added created_before and created_after PageSpec limits.
536
537  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
538
539 ikiwiki (1.14) unstable; urgency=low
540
541   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
542     by 10% or so.
543   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
544   * Added many unit tests for pagespec_match.
545
546  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
547
548 ikiwiki (1.13) unstable; urgency=low
549
550   * ikiwiki can now download and aggregate feeds with its new aggregate
551     plugin, so it's possible to implement a Planet using ikiwiki!
552   * Add a run_hooks function for the common task of running all hooks of a
553     given type.
554   * Add a savestate hook.
555   * Don't put blog post forms on pages if there's no cgiurl set.
556   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
557     --wrappers to do that.
558   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
559     to update pages that haven't changed on disk.
560   * Change meta tags to use html entity-escaped text for values, so that
561     quotes and such can be represented in title tags.
562   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
563     for the above.
564   * Make --rebuild also cause --aggregate to re-download and write aggregated
565     pages.
566   * Avoid outputting duplicate meta info.
567   * Include title metadata on aggregated posts for capitalised and un-munged
568     titles.
569   * Title metadata of inlined pages now shows up in blogs and rss feeds.
570   * Fix issue with unicode filenames and updating the hyper estradier search
571     index. (Aka Please Please Please, let that be the last one.)
572   * Patch from Roland Mas to support an rss=no parameter to inline directives.
573     Closes: #380743
574   * Renamed GlobLists to PageSpecs.
575   * PageSpecs can now include nested parens, "and", and "or". This remains
576     backwards compatible to the old GlobList format. It's implemented by
577     treating the GlobList as a very limited microlanguage that is transformed
578     to perl code that does the matching.
579   * The old GlobList format is deprecated, and I encourage users to switch to
580     using the new PageSpec format. Compatability with the old format will be
581     removed at some point, possibly by 2.0.
582   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
583   * Add support for creation_month and creation_year to PageSpec.
584     Closes: #380680
585   * Changes to index file encoding.
586
587  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
588
589 ikiwiki (1.12) unstable; urgency=low
590
591   "Viva l'Italia!"
592   * New pagestats plugin from Enrico, which can generate a table counting
593     the backlinks for each page, or a del.icio.us style cloud.
594   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
595     the wikiformat plugin works. Thanks, Emanuele Aina.
596   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
597     display, running them through pagetitle. This removes ugly underscores and
598     other gunk from the display, much nicer. You may want to rebuild your wiki
599     when upgrading to get the cleanup globally.
600   * Polygen plugin from Enrico.
601   * htmltidy plugin from Faidon.
602   * Locale patch from Faidon:
603     - Adds a locale setting to setup files.
604     - Proper local time, if the locale configuration option is used.
605     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
606       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
607       impossible.
608   * Add getopt hook type, this allows plugins to add new command-line options.
609   * Add --tagbase option to tag plugin.
610   * Add exclude option in setup files, works same as --exclude.
611   * Put categories in rss feeds for tagged items.
612   * Allow preprocessor directives to be expanded in inlined blog pages.
613     However, to avoid inlining loops etc, don't expand inline directives in
614     inlined pages.
615   * fortune plugin (trivial)
616   * Tag plugins according to type.
617
618  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
619
620 ikiwiki (1.11) unstable; urgency=low
621
622   * Patch from Enrico that
623     - Adds a tag plugin that allows more easily tagging pages.
624       The meta plugin can also still be used for that, but the tag plugin
625       also lists a page's tags at the bottom of the page.
626     - Allows preprocessor directives to have parameters with no specified
627       value.
628     - Fixes preprocessor directive parameter parsing so that
629       foo=bar baz now means "foo=bar" and a "baz" with no value.
630   * Run pagetemplate hooks when inlining pages so that inlined pages also
631     list their tags.
632   * Make all plugins with pagetemplate hooks check that variables exist
633     on the template before setting them, for robustness.
634   * Switch pagetemplate hooks to using named parameters.
635   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
636     This will be the page that a source page will be part of, which is
637     different than the source page for inlined pages.
638   * Audited all plugins to endure they pass (page, destpage) to htmllink
639     appropriatly. This means inlining of various plugins will not work
640     properly, with correct links generated.
641
642  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
643
644 ikiwiki (1.10) unstable; urgency=low
645
646   * Run page through any relevant filters when generating a page preview.
647   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
648     default throughout the wiki, not only on wikitext pages. Decided to call
649     this a feature, and split the camelcase support out into a separate plugin
650     that is independant of wikitext.
651   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
652
653  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
654
655 ikiwiki (1.9) unstable; urgency=low
656
657   * Improve display of parentlinks and page title of toplevel index page.
658   * Patch from Faidon to use svn --limit when possible for recentchanges,
659     speeds up recentchanges a lot for wikis with more history.
660   * Patch from Recai to fix utf8 issues in git backend.
661   * Add wikitext markup plugin, which supports ".wiki" pages written in the
662     original wiki syntax, CamelCase links and all.
663   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
664     support, to edit pages etc without a web server.
665   * Display CGI processing errors if present.
666   * Fix from Faidon for a XML parser issue that breaks utf-8 for
667     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
668     area, and also way slow.
669   * Match 'web commit from' in SVN and git, these are web commits too.
670     (Faidon)
671   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
672     readable and avoid future mistakes. The patch seems to work and for the
673     first time I have a UTF-8 username ;-) (Faidon)
674   * Use form->field consistently, not form->param.
675   * Patch from Recai to allow selection of page type when creating a new page.
676     Default page type is inherited from the link clicked on to create the new
677     page.
678
679  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
680
681 ikiwiki (1.8) unstable; urgency=low
682
683   * Fix orphans plugin to not count a link to a nonexistant page as a reason
684     for a page not being an orphan.
685   * Support pinging services such as Technorati using XML-RPC to notify them
686     about changes to rss feeds.
687   * Parse svn log as xml for improved utf8 and security. Note that this makes
688     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
689   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
690     flagged string even if the locale causes it to generate utf8 output,
691     so make sure to let perl know it should be handled as utf8. Also,
692     the optimised version used for standard time formats won't work if the
693     user has changed locale, so drop it. Thanks, Faidon Liambotis.
694   * Fix re-encoding of the comments field to utf8 if a commit fails
695     due to a conflict. Thanks, Faidon Liambotis.
696   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
697     Liambotis.
698   * Add insane double encode/decode to utf8 around call to markdown.
699     This works around a truely strange bug, which is apparently a bug in
700     perl, #376329. Also added a test case for it.
701   * Improve layout of edit page so formatting help link is always visible w/o
702     getting in the way of the preview.
703   * Centralised all calls to HTML::Template and force all the templates
704     to be read as utf8.
705   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
706   * Introduce add_plugins and disable_plugins config options in setup files.
707     This allows adding or removing plugins w/o overriding the whole list of
708     default plugins, which makes it easier to upgrade when new default plugins
709     are added.
710   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
711     default (of course!). Based on a patch by Faidon Liambotis.
712   * Add a html plugin, which can be used to write wikis in raw html,
713     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
714     defaults to not processing .html files, since w/o this plugin they would
715     be copied unsanitised. With this plugin, it will process and html
716     sanitise them, like any other page type.
717   * Rebuilding wrappers is necessary on upgrade to this version.
718   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
719     will be automatically done on all upgrades.
720   * Don't send pings if the wiki is being rebuilt.
721   * Work around very innefficient behavior in File::Spec::abs2rel. Result
722     is a savings of 2 pointless fork/execs per link calculation, which
723     results in ~25% speedup of ikiwiki building its own doc wiki, and
724     about 35% speedup displaying RecentChanges!
725   * Make RecentChanges use a table and some CSS, should be much more readable.
726     No code changes involved.
727   * Encode & in diffurl in examples, to conform to pedantic rules.
728   * Speed up RecentChanges by another 40% or so with some memoization.
729   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
730     in time to build the doc wiki.
731
732  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
733
734 ikiwiki (1.7) unstable; urgency=low
735
736   * Updated logo from Recai with some kerning and alingment tuning.
737   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
738     changed some output.
739   * Copyright update.
740
741  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
742
743 ikiwiki (1.6) unstable; urgency=low
744
745   * YA utf-8 patch from Recai, this time to fix previewing a page so that
746     the text in the input box is re-encoded back to utf-8.
747   * -CSD does not affect modules, so readfile() was not using the utf-8 input
748     layer, which led to lots of problems; make it force read files as utf-8.
749     Closes: #373203
750   * Note that as a consequence, this version of ikiwiki will actually try to
751     parse utf8 in source files for the first time, which may expose broken
752     utf8 in wiki sources that was hidden before. Most common will be
753     perl warnings like "utf8 "\xE9" does not map to Unicode"
754   * writefile() likewise needs to use the utf8 output layer.
755   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
756     there.
757   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
758     given the readfile fix.
759   * Add utf-8 testcases for readfile and htmlize.
760   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
761     safe.
762   * More utf-8 fixes from Recai, partly to things I broke above:
763     - The serious problem is that writefile() saves the content in undecoded
764       format in CGI, hence all (non-ascii) chars are corrupted permanently.
765     - Comment field in edit page is not decoded and all the non-ascii chars in
766       this field are corrupted as the result.  We should decode it as we do it
767       for the content.
768     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
769       character in print.
770   * New SVG logo from Recai.
771
772  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
773
774 ikiwiki (1.5) unstable; urgency=low
775
776   * Add --timeformat config option to allow changing how dates are displayed.
777     Note that as a side effect, dates will now be displayed using the local
778     timezone, not as GMT.
779   * More security review.
780   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
781     for some handy stuff like:
782     - Using links as a kind of tag; creating blog pages that list all pages
783       containing a given tag/link or not containing some other tag.
784     - Subscribing to mail notifications whenever a change is made to a page
785       that is a backlink of page foo. Ie, "Please notify me of changes in all
786       pages that link to my home page in the wiki"
787     - Locking any pages that are linked to from a particular page, so that
788       lists of locks can be exposed in the wiki.
789   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
790     when a todo item is done, instead of the previous moving it to a different
791     subdir.
792   * Allow pagetemplate plugins to override *anything* in the template.
793   * Add a meta plugin, which allows specifying various metadata about pages,
794     like license and author. It also allows for inserting html link and meta
795     tags into html, overriding the title, and adding hidden WikiLinks, which
796     can be useful when using link-based globbing for page categorisation.
797   * Remove preprocessor directives from inlined pages.
798   * Allow simple preprocessor directive values to be specified w/o quotes.
799   * Add support for using git instead of subversion as the RCS backend,
800     tremendous thanks to Recai Oktaş for this.
801   * Doc updates for git.
802   * Fix absolute url munging in rss generation to support https, ftp, etc urls
803     not just http urls.
804   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
805     utf-8 for edit and other fields, and for recentchanges. There may still
806     be utf-8 issues with the preferences page though.
807
808  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
809
810 ikiwiki (1.4) unstable; urgency=low
811
812   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
813     very strange way of enabling proper XHTML <br /> type tags. Output html
814     should be always valid again now.
815   * The page name and parent links has switched from using a <h1> to a styled
816     <span>, so pages can use <h1> internally instead of needing to use <h2>.
817   * Updated all of ikiwiki's own wiki pages for that.
818   * Add pagetemplate hook, which can be used by plugins that want to mess
819     around with adding new stuff to the page template.
820   * Remove headercontent; the search plugin now adds the search box to the
821     header by registering a pagetemplate hook, and other plugins should do
822     similarly.
823   * Rebuilding on upgrade to this version is recommended.
824   * Add a html validity check to the test suite, using the wdg-html-validator,
825     if available.
826   * Make the html valid when there is nothing in the actions list.
827   * Reordered some function call parameters for consistency.
828   * Enable full utf-8 support for page input and output.
829   * Add a workaround for markdown, which does not work well with utf-8
830     strings.
831   * --getctime had bitrotted (well I only ever used it the once so far..),
832     fix and make it a bit more flexible
833   * rcs_getctime is changed, now rather than needing to loop over all pages,
834     it should just use the rcs to get the ctime of the passed file.
835   * When inlining a page in another one, links from the inlined page are now
836     expanded the same as they are when rendering the inlined page as a
837     standalone page. So rather than being expanded from the POV of the
838     inlining page, they are expanded from the POV of the inlined page.
839
840     For example, a link from blog/foo to "bar" will now link to blog/bar
841     if it exists. Previously this needed to be a link explicitly to
842     "blog/bar"; such links will also continue to work.
843
844     (This was slightly complex to do as the link still has to be constructed
845     relative to the inlining page.)
846   * Make page edit textarea resize to fit browser window.
847   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
848     do not need a full rebuild, in order to update any basewiki pages.
849
850  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
851
852 ikiwiki (1.3) unstable; urgency=low
853
854   * Fix the preinst introduced in the last version. Closes: #367458
855
856  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
857
858 ikiwiki (1.2) unstable; urgency=low
859
860   * Remove dups from the brokenlinks list.
861   * Add libc6-dev to dependencies, needed to build wrappers.
862   * Install wikilist in correct location. Closes: #367371
863
864  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
865
866 ikiwiki (1.1) unstable; urgency=low
867
868   * Rename inlinepage to depends, so that it can be used to refer to more
869     dependency relationships than just inlining. This will require a rebuild
870     on upgrade to this version.
871   * Move the rss link, put it in the blogpost form if there is one and at the
872     top if not. This is both nicer because easier to find, and it cleans up
873     the code which had used inlinepage as a flag for adding the link later.
874   * Allow the depends GlobList to be built up from multiple sources (such as
875     plugins) during a page render.
876   * Which means that more than one blog is now supported to appear on a
877     single page. (With some limitations, like only the last one getting an
878     rss file.)
879   * Added a plugin system.
880   * Added a pagecount plugin, enabled by default.
881   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
882   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
883     backlinks when the backlinks hadn't really changed.
884   * Moved inline page support, rss generation etc into the inline plugin,
885     enabled by default.
886   * Added brokenlinks plugin, not enabled by default, but rather handy.
887   * Fix several broken links in the doc wiki.
888   * Smarter behavior when creating a page and a page of the same name (but
889     different location) already exists.
890   * Add an orphans plugin for finding pages that nothing links to.
891   * Removed backlinks page, which it turns out nothing used.
892   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
893     it, this will allow for adding a unit test suite.
894   * Add unit tests for several core functions, including globlist_match,
895     dirname, basename, bestlink, linkify, pagetitle, titlepage.
896   * Smart globlist merging.
897   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
898     to pave the way for adding other RCS support. This also changes the
899     setup files, where before they had svn => 1 or svn => 0, now they have
900     rcs => "svn" or rcs => "".
901   * Add a debian/NEWS file with upgrade notes.
902   * Load whatever rcs module is specified, so new ones can be just dropped in
903     as plugins and work. (Well, in theory.)
904   * Add some basic docs about writing RCS modules.
905   * Broke search capability out into a plugin, removed the --hyperestraier
906     switch.
907   * Added smiley plugin, nicely controlled and documented by the smileys page.
908   * Copied in some smileys from Moin Moin.
909   * Allow links of the form [[some page|page]], with whitespace in the link
910     text.
911   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
912     and --disable-plugin htmlscrubber.
913   * Allow discussion links on pages to be turned off with --no-discussion.
914   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
915   * Add some new config items to the estseek.conf template, which are needed
916     by hyperestraier 1.2.3.
917
918  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
919
920 ikiwiki (1.0) unstable; urgency=low
921
922   * First official release.
923
924  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400