* Tag plugins according to type.
[ikiwiki] / debian / changelog
1 ikiwiki (1.12) unstable; urgency=low
2
3   "Viva l'Italia!"
4   * New pagestats plugin from Enrico, which can generate a table counting
5     the backlinks for each page, or a del.icio.us style cloud.
6   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
7     the wikiformat plugin works. Thanks, Emanuele Aina.
8   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
9     display, running them through pagetitle. This removes ugly underscores and
10     other gunk from the display, much nicer. You may want to rebuild your wiki
11     when upgrading to get the cleanup globally.
12   * Polygen plugin from Enrico.
13   * htmltidy plugin from Faidon.
14   * Locale patch from Faidon:
15     - Adds a locale setting to setup files.
16     - Proper local time, if the locale configuration option is used.
17     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
18       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
19       impossible.
20   * Add getopt hook type, this allows plugins to add new command-line options.
21   * Add --tagbase option to tag plugin.
22   * Add exclude option in setup files, works same as --exclude.
23   * Put categories in rss feeds for tagged items.
24   * Allow preprocessor directives to be expanded in inlined blog pages.
25     However, to avoid inlining loops etc, don't expand inline directives in
26     inlined pages.
27   * fortune plugin (trivial)
28   * Tag plugins according to type.
29
30  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
31
32 ikiwiki (1.11) unstable; urgency=low
33
34   * Patch from Enrico that
35     - Adds a tag plugin that allows more easily tagging pages.
36       The meta plugin can also still be used for that, but the tag plugin
37       also lists a page's tags at the bottom of the page.
38     - Allows preprocessor directives to have parameters with no specified
39       value.
40     - Fixes preprocessor directive parameter parsing so that
41       foo=bar baz now means "foo=bar" and a "baz" with no value.
42   * Run pagetemplate hooks when inlining pages so that inlined pages also
43     list their tags.
44   * Make all plugins with pagetemplate hooks check that variables exist
45     on the template before setting them, for robustness.
46   * Switch pagetemplate hooks to using named parameters.
47   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
48     This will be the page that a source page will be part of, which is
49     different than the source page for inlined pages.
50   * Audited all plugins to endure they pass (page, destpage) to htmllink
51     appropriatly. This means inlining of various plugins will not work
52     properly, with correct links generated.
53
54  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
55
56 ikiwiki (1.10) unstable; urgency=low
57
58   * Run page through any relevant filters when generating a page preview.
59   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
60     default throughout the wiki, not only on wikitext pages. Decided to call
61     this a feature, and split the camelcase support out into a separate plugin
62     that is independant of wikitext.
63   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
64
65  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
66
67 ikiwiki (1.9) unstable; urgency=low
68
69   * Improve display of parentlinks and page title of toplevel index page.
70   * Patch from Faidon to use svn --limit when possible for recentchanges,
71     speeds up recentchanges a lot for wikis with more history.
72   * Patch from Recai to fix utf8 issues in git backend.
73   * Add wikitext markup plugin, which supports ".wiki" pages written in the
74     original wiki syntax, CamelCase links and all.
75   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
76     support, to edit pages etc without a web server.
77   * Display CGI processing errors if present.
78   * Fix from Faidon for a XML parser issue that breaks utf-8 for
79     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
80     area, and also way slow.
81   * Match 'web commit from' in SVN and git, these are web commits too.
82     (Faidon)
83   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
84     readable and avoid future mistakes. The patch seems to work and for the
85     first time I have a UTF-8 username ;-) (Faidon)
86   * Use form->field consistently, not form->param.
87   * Patch from Recai to allow selection of page type when creating a new page.
88     Default page type is inherited from the link clicked on to create the new
89     page.
90
91  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
92
93 ikiwiki (1.8) unstable; urgency=low
94
95   * Fix orphans plugin to not count a link to a nonexistant page as a reason
96     for a page not being an orphan.
97   * Support pinging services such as Technorati using XML-RPC to notify them
98     about changes to rss feeds.
99   * Parse svn log as xml for improved utf8 and security. Note that this makes
100     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
101   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
102     flagged string even if the locale causes it to generate utf8 output,
103     so make sure to let perl know it should be handled as utf8. Also,
104     the optimised version used for standard time formats won't work if the
105     user has changed locale, so drop it. Thanks, Faidon Liambotis.
106   * Fix re-encoding of the comments field to utf8 if a commit fails
107     due to a conflict. Thanks, Faidon Liambotis.
108   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
109     Liambotis.
110   * Add insane double encode/decode to utf8 around call to markdown.
111     This works around a truely strange bug, which is apparently a bug in
112     perl, #376329. Also added a test case for it.
113   * Improve layout of edit page so formatting help link is always visible w/o
114     getting in the way of the preview.
115   * Centralised all calls to HTML::Template and force all the templates
116     to be read as utf8.
117   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
118   * Introduce add_plugins and disable_plugins config options in setup files.
119     This allows adding or removing plugins w/o overriding the whole list of
120     default plugins, which makes it easier to upgrade when new default plugins
121     are added.
122   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
123     default (of course!). Based on a patch by Faidon Liambotis.
124   * Add a html plugin, which can be used to write wikis in raw html,
125     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
126     defaults to not processing .html files, since w/o this plugin they would
127     be copied unsanitised. With this plugin, it will process and html
128     sanitise them, like any other page type.
129   * Rebuilding wrappers is necessary on upgrade to this version.
130   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
131     will be automatically done on all upgrades.
132   * Don't send pings if the wiki is being rebuilt.
133   * Work around very innefficient behavior in File::Spec::abs2rel. Result
134     is a savings of 2 pointless fork/execs per link calculation, which
135     results in ~25% speedup of ikiwiki building its own doc wiki, and
136     about 35% speedup displaying RecentChanges!
137   * Make RecentChanges use a table and some CSS, should be much more readable.
138     No code changes involved.
139   * Encode & in diffurl in examples, to conform to pedantic rules.
140   * Speed up RecentChanges by another 40% or so with some memoization.
141   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
142     in time to build the doc wiki.
143
144  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
145
146 ikiwiki (1.7) unstable; urgency=low
147
148   * Updated logo from Recai with some kerning and alingment tuning.
149   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
150     changed some output.
151   * Copyright update.
152
153  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
154
155 ikiwiki (1.6) unstable; urgency=low
156
157   * YA utf-8 patch from Recai, this time to fix previewing a page so that
158     the text in the input box is re-encoded back to utf-8.
159   * -CSD does not affect modules, so readfile() was not using the utf-8 input
160     layer, which led to lots of problems; make it force read files as utf-8.
161     Closes: #373203
162   * Note that as a consequence, this version of ikiwiki will actually try to
163     parse utf8 in source files for the first time, which may expose broken
164     utf8 in wiki sources that was hidden before. Most common will be
165     perl warnings like "utf8 "\xE9" does not map to Unicode"
166   * writefile() likewise needs to use the utf8 output layer.
167   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
168     there.
169   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
170     given the readfile fix.
171   * Add utf-8 testcases for readfile and htmlize.
172   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
173     safe.
174   * More utf-8 fixes from Recai, partly to things I broke above:
175     - The serious problem is that writefile() saves the content in undecoded
176       format in CGI, hence all (non-ascii) chars are corrupted permanently.
177     - Comment field in edit page is not decoded and all the non-ascii chars in
178       this field are corrupted as the result.  We should decode it as we do it
179       for the content.
180     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
181       character in print.
182   * New SVG logo from Recai.
183
184  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
185
186 ikiwiki (1.5) unstable; urgency=low
187
188   * Add --timeformat config option to allow changing how dates are displayed.
189     Note that as a side effect, dates will now be displayed using the local
190     timezone, not as GMT.
191   * More security review.
192   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
193     for some handy stuff like:
194     - Using links as a kind of tag; creating blog pages that list all pages
195       containing a given tag/link or not containing some other tag.
196     - Subscribing to mail notifications whenever a change is made to a page
197       that is a backlink of page foo. Ie, "Please notify me of changes in all
198       pages that link to my home page in the wiki"
199     - Locking any pages that are linked to from a particular page, so that
200       lists of locks can be exposed in the wiki.
201   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
202     when a todo item is done, instead of the previous moving it to a different
203     subdir.
204   * Allow pagetemplate plugins to override *anything* in the template.
205   * Add a meta plugin, which allows specifying various metadata about pages,
206     like license and author. It also allows for inserting html link and meta
207     tags into html, overriding the title, and adding hidden WikiLinks, which
208     can be useful when using link-based globbing for page categorisation.
209   * Remove preprocessor directives from inlined pages.
210   * Allow simple preprocessor directive values to be specified w/o quotes.
211   * Add support for using git instead of subversion as the RCS backend,
212     tremendous thanks to Recai Oktaş for this.
213   * Doc updates for git.
214   * Fix absolute url munging in rss generation to support https, ftp, etc urls
215     not just http urls.
216   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
217     utf-8 for edit and other fields, and for recentchanges. There may still
218     be utf-8 issues with the preferences page though.
219
220  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
221
222 ikiwiki (1.4) unstable; urgency=low
223
224   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
225     very strange way of enabling proper XHTML <br /> type tags. Output html
226     should be always valid again now.
227   * The page name and parent links has switched from using a <h1> to a styled
228     <span>, so pages can use <h1> internally instead of needing to use <h2>.
229   * Updated all of ikiwiki's own wiki pages for that.
230   * Add pagetemplate hook, which can be used by plugins that want to mess
231     around with adding new stuff to the page template.
232   * Remove headercontent; the search plugin now adds the search box to the
233     header by registering a pagetemplate hook, and other plugins should do
234     similarly.
235   * Rebuilding on upgrade to this version is recommended.
236   * Add a html validity check to the test suite, using the wdg-html-validator,
237     if available.
238   * Make the html valid when there is nothing in the actions list.
239   * Reordered some function call parameters for consistency.
240   * Enable full utf-8 support for page input and output.
241   * Add a workaround for markdown, which does not work well with utf-8
242     strings.
243   * --getctime had bitrotted (well I only ever used it the once so far..),
244     fix and make it a bit more flexible
245   * rcs_getctime is changed, now rather than needing to loop over all pages,
246     it should just use the rcs to get the ctime of the passed file.
247   * When inlining a page in another one, links from the inlined page are now
248     expanded the same as they are when rendering the inlined page as a
249     standalone page. So rather than being expanded from the POV of the
250     inlining page, they are expanded from the POV of the inlined page.
251
252     For example, a link from blog/foo to "bar" will now link to blog/bar
253     if it exists. Previously this needed to be a link explicitly to
254     "blog/bar"; such links will also continue to work.
255
256     (This was slightly complex to do as the link still has to be constructed
257     relative to the inlining page.)
258   * Make page edit textarea resize to fit browser window.
259   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
260     do not need a full rebuild, in order to update any basewiki pages.
261
262  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
263
264 ikiwiki (1.3) unstable; urgency=low
265
266   * Fix the preinst introduced in the last version. Closes: #367458
267
268  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
269
270 ikiwiki (1.2) unstable; urgency=low
271
272   * Remove dups from the brokenlinks list.
273   * Add libc6-dev to dependencies, needed to build wrappers.
274   * Install wikilist in correct location. Closes: #367371
275
276  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
277
278 ikiwiki (1.1) unstable; urgency=low
279
280   * Rename inlinepage to depends, so that it can be used to refer to more
281     dependency relationships than just inlining. This will require a rebuild
282     on upgrade to this version.
283   * Move the rss link, put it in the blogpost form if there is one and at the
284     top if not. This is both nicer because easier to find, and it cleans up
285     the code which had used inlinepage as a flag for adding the link later.
286   * Allow the depends GlobList to be built up from multiple sources (such as
287     plugins) during a page render.
288   * Which means that more than one blog is now supported to appear on a
289     single page. (With some limitations, like only the last one getting an
290     rss file.)
291   * Added a plugin system.
292   * Added a pagecount plugin, enabled by default.
293   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
294   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
295     backlinks when the backlinks hadn't really changed.
296   * Moved inline page support, rss generation etc into the inline plugin,
297     enabled by default.
298   * Added brokenlinks plugin, not enabled by default, but rather handy.
299   * Fix several broken links in the doc wiki.
300   * Smarter behavior when creating a page and a page of the same name (but
301     different location) already exists.
302   * Add an orphans plugin for finding pages that nothing links to.
303   * Removed backlinks page, which it turns out nothing used.
304   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
305     it, this will allow for adding a unit test suite.
306   * Add unit tests for several core functions, including globlist_match,
307     dirname, basename, bestlink, linkify, pagetitle, titlepage.
308   * Smart globlist merging.
309   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
310     to pave the way for adding other RCS support. This also changes the
311     setup files, where before they had svn => 1 or svn => 0, now they have
312     rcs => "svn" or rcs => "".
313   * Add a debian/NEWS file with upgrade notes.
314   * Load whatever rcs module is specified, so new ones can be just dropped in
315     as plugins and work. (Well, in theory.)
316   * Add some basic docs about writing RCS modules.
317   * Broke search capability out into a plugin, removed the --hyperestraier
318     switch.
319   * Added smiley plugin, nicely controlled and documented by the smileys page.
320   * Copied in some smileys from Moin Moin.
321   * Allow links of the form [[some page|page]], with whitespace in the link
322     text.
323   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
324     and --disable-plugin htmlscrubber.
325   * Allow discussion links on pages to be turned off with --no-discussion.
326   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
327   * Add some new config items to the estseek.conf template, which are needed
328     by hyperestraier 1.2.3.
329
330  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
331
332 ikiwiki (1.0) unstable; urgency=low
333
334   * First official release.
335
336  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400