* Fix issue with unicode filenames and updating the hyper estradier search
[ikiwiki] / debian / changelog
1 ikiwiki (1.13) UNRELEASED; urgency=low
2
3   * ikiwiki can now download and aggregate feeds with its new aggregate
4     plugin, so it's possible to implement a Planet using ikiwiki!
5   * Add a run_hooks function for the common task of running all hooks of a
6     given type.
7   * Add a savestate hook.
8   * Don't put blog post forms on pages if there's no cgiurl set.
9   * Reformat front page.
10   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
11     --wrappers to do that.
12   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
13     to update pages that haven't changed on disk.
14   * Change meta tags to use html entity-escaped text for values, so that
15     quotes and such can be represented in title tags.
16   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
17     for the above.
18   * Make --rebuild also cause --aggregate to re-download and write aggregated
19     pages.
20   * Avoid outputting duplicate meta info.
21   * Include title metadata on aggregated posts for capitalised and un-munged
22     titles.
23   * Title metadata of inlined pages now shows up in blogs and rss feeds.
24   * Fix issue with unicode filenames and updating the hyper estradier search
25     index. (Aka Please Please Please, let that be the last one.)
26
27  -- Joey Hess <joeyh@debian.org>  Sun, 30 Jul 2006 21:18:16 -0400
28
29 ikiwiki (1.12) unstable; urgency=low
30
31   "Viva l'Italia!"
32   * New pagestats plugin from Enrico, which can generate a table counting
33     the backlinks for each page, or a del.icio.us style cloud.
34   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
35     the wikiformat plugin works. Thanks, Emanuele Aina.
36   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
37     display, running them through pagetitle. This removes ugly underscores and
38     other gunk from the display, much nicer. You may want to rebuild your wiki
39     when upgrading to get the cleanup globally.
40   * Polygen plugin from Enrico.
41   * htmltidy plugin from Faidon.
42   * Locale patch from Faidon:
43     - Adds a locale setting to setup files.
44     - Proper local time, if the locale configuration option is used.
45     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
46       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
47       impossible.
48   * Add getopt hook type, this allows plugins to add new command-line options.
49   * Add --tagbase option to tag plugin.
50   * Add exclude option in setup files, works same as --exclude.
51   * Put categories in rss feeds for tagged items.
52   * Allow preprocessor directives to be expanded in inlined blog pages.
53     However, to avoid inlining loops etc, don't expand inline directives in
54     inlined pages.
55   * fortune plugin (trivial)
56   * Tag plugins according to type.
57
58  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
59
60 ikiwiki (1.11) unstable; urgency=low
61
62   * Patch from Enrico that
63     - Adds a tag plugin that allows more easily tagging pages.
64       The meta plugin can also still be used for that, but the tag plugin
65       also lists a page's tags at the bottom of the page.
66     - Allows preprocessor directives to have parameters with no specified
67       value.
68     - Fixes preprocessor directive parameter parsing so that
69       foo=bar baz now means "foo=bar" and a "baz" with no value.
70   * Run pagetemplate hooks when inlining pages so that inlined pages also
71     list their tags.
72   * Make all plugins with pagetemplate hooks check that variables exist
73     on the template before setting them, for robustness.
74   * Switch pagetemplate hooks to using named parameters.
75   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
76     This will be the page that a source page will be part of, which is
77     different than the source page for inlined pages.
78   * Audited all plugins to endure they pass (page, destpage) to htmllink
79     appropriatly. This means inlining of various plugins will not work
80     properly, with correct links generated.
81
82  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
83
84 ikiwiki (1.10) unstable; urgency=low
85
86   * Run page through any relevant filters when generating a page preview.
87   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
88     default throughout the wiki, not only on wikitext pages. Decided to call
89     this a feature, and split the camelcase support out into a separate plugin
90     that is independant of wikitext.
91   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
92
93  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
94
95 ikiwiki (1.9) unstable; urgency=low
96
97   * Improve display of parentlinks and page title of toplevel index page.
98   * Patch from Faidon to use svn --limit when possible for recentchanges,
99     speeds up recentchanges a lot for wikis with more history.
100   * Patch from Recai to fix utf8 issues in git backend.
101   * Add wikitext markup plugin, which supports ".wiki" pages written in the
102     original wiki syntax, CamelCase links and all.
103   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
104     support, to edit pages etc without a web server.
105   * Display CGI processing errors if present.
106   * Fix from Faidon for a XML parser issue that breaks utf-8 for
107     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
108     area, and also way slow.
109   * Match 'web commit from' in SVN and git, these are web commits too.
110     (Faidon)
111   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
112     readable and avoid future mistakes. The patch seems to work and for the
113     first time I have a UTF-8 username ;-) (Faidon)
114   * Use form->field consistently, not form->param.
115   * Patch from Recai to allow selection of page type when creating a new page.
116     Default page type is inherited from the link clicked on to create the new
117     page.
118
119  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
120
121 ikiwiki (1.8) unstable; urgency=low
122
123   * Fix orphans plugin to not count a link to a nonexistant page as a reason
124     for a page not being an orphan.
125   * Support pinging services such as Technorati using XML-RPC to notify them
126     about changes to rss feeds.
127   * Parse svn log as xml for improved utf8 and security. Note that this makes
128     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
129   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
130     flagged string even if the locale causes it to generate utf8 output,
131     so make sure to let perl know it should be handled as utf8. Also,
132     the optimised version used for standard time formats won't work if the
133     user has changed locale, so drop it. Thanks, Faidon Liambotis.
134   * Fix re-encoding of the comments field to utf8 if a commit fails
135     due to a conflict. Thanks, Faidon Liambotis.
136   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
137     Liambotis.
138   * Add insane double encode/decode to utf8 around call to markdown.
139     This works around a truely strange bug, which is apparently a bug in
140     perl, #376329. Also added a test case for it.
141   * Improve layout of edit page so formatting help link is always visible w/o
142     getting in the way of the preview.
143   * Centralised all calls to HTML::Template and force all the templates
144     to be read as utf8.
145   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
146   * Introduce add_plugins and disable_plugins config options in setup files.
147     This allows adding or removing plugins w/o overriding the whole list of
148     default plugins, which makes it easier to upgrade when new default plugins
149     are added.
150   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
151     default (of course!). Based on a patch by Faidon Liambotis.
152   * Add a html plugin, which can be used to write wikis in raw html,
153     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
154     defaults to not processing .html files, since w/o this plugin they would
155     be copied unsanitised. With this plugin, it will process and html
156     sanitise them, like any other page type.
157   * Rebuilding wrappers is necessary on upgrade to this version.
158   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
159     will be automatically done on all upgrades.
160   * Don't send pings if the wiki is being rebuilt.
161   * Work around very innefficient behavior in File::Spec::abs2rel. Result
162     is a savings of 2 pointless fork/execs per link calculation, which
163     results in ~25% speedup of ikiwiki building its own doc wiki, and
164     about 35% speedup displaying RecentChanges!
165   * Make RecentChanges use a table and some CSS, should be much more readable.
166     No code changes involved.
167   * Encode & in diffurl in examples, to conform to pedantic rules.
168   * Speed up RecentChanges by another 40% or so with some memoization.
169   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
170     in time to build the doc wiki.
171
172  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
173
174 ikiwiki (1.7) unstable; urgency=low
175
176   * Updated logo from Recai with some kerning and alingment tuning.
177   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
178     changed some output.
179   * Copyright update.
180
181  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
182
183 ikiwiki (1.6) unstable; urgency=low
184
185   * YA utf-8 patch from Recai, this time to fix previewing a page so that
186     the text in the input box is re-encoded back to utf-8.
187   * -CSD does not affect modules, so readfile() was not using the utf-8 input
188     layer, which led to lots of problems; make it force read files as utf-8.
189     Closes: #373203
190   * Note that as a consequence, this version of ikiwiki will actually try to
191     parse utf8 in source files for the first time, which may expose broken
192     utf8 in wiki sources that was hidden before. Most common will be
193     perl warnings like "utf8 "\xE9" does not map to Unicode"
194   * writefile() likewise needs to use the utf8 output layer.
195   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
196     there.
197   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
198     given the readfile fix.
199   * Add utf-8 testcases for readfile and htmlize.
200   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
201     safe.
202   * More utf-8 fixes from Recai, partly to things I broke above:
203     - The serious problem is that writefile() saves the content in undecoded
204       format in CGI, hence all (non-ascii) chars are corrupted permanently.
205     - Comment field in edit page is not decoded and all the non-ascii chars in
206       this field are corrupted as the result.  We should decode it as we do it
207       for the content.
208     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
209       character in print.
210   * New SVG logo from Recai.
211
212  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
213
214 ikiwiki (1.5) unstable; urgency=low
215
216   * Add --timeformat config option to allow changing how dates are displayed.
217     Note that as a side effect, dates will now be displayed using the local
218     timezone, not as GMT.
219   * More security review.
220   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
221     for some handy stuff like:
222     - Using links as a kind of tag; creating blog pages that list all pages
223       containing a given tag/link or not containing some other tag.
224     - Subscribing to mail notifications whenever a change is made to a page
225       that is a backlink of page foo. Ie, "Please notify me of changes in all
226       pages that link to my home page in the wiki"
227     - Locking any pages that are linked to from a particular page, so that
228       lists of locks can be exposed in the wiki.
229   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
230     when a todo item is done, instead of the previous moving it to a different
231     subdir.
232   * Allow pagetemplate plugins to override *anything* in the template.
233   * Add a meta plugin, which allows specifying various metadata about pages,
234     like license and author. It also allows for inserting html link and meta
235     tags into html, overriding the title, and adding hidden WikiLinks, which
236     can be useful when using link-based globbing for page categorisation.
237   * Remove preprocessor directives from inlined pages.
238   * Allow simple preprocessor directive values to be specified w/o quotes.
239   * Add support for using git instead of subversion as the RCS backend,
240     tremendous thanks to Recai Oktaş for this.
241   * Doc updates for git.
242   * Fix absolute url munging in rss generation to support https, ftp, etc urls
243     not just http urls.
244   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
245     utf-8 for edit and other fields, and for recentchanges. There may still
246     be utf-8 issues with the preferences page though.
247
248  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
249
250 ikiwiki (1.4) unstable; urgency=low
251
252   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
253     very strange way of enabling proper XHTML <br /> type tags. Output html
254     should be always valid again now.
255   * The page name and parent links has switched from using a <h1> to a styled
256     <span>, so pages can use <h1> internally instead of needing to use <h2>.
257   * Updated all of ikiwiki's own wiki pages for that.
258   * Add pagetemplate hook, which can be used by plugins that want to mess
259     around with adding new stuff to the page template.
260   * Remove headercontent; the search plugin now adds the search box to the
261     header by registering a pagetemplate hook, and other plugins should do
262     similarly.
263   * Rebuilding on upgrade to this version is recommended.
264   * Add a html validity check to the test suite, using the wdg-html-validator,
265     if available.
266   * Make the html valid when there is nothing in the actions list.
267   * Reordered some function call parameters for consistency.
268   * Enable full utf-8 support for page input and output.
269   * Add a workaround for markdown, which does not work well with utf-8
270     strings.
271   * --getctime had bitrotted (well I only ever used it the once so far..),
272     fix and make it a bit more flexible
273   * rcs_getctime is changed, now rather than needing to loop over all pages,
274     it should just use the rcs to get the ctime of the passed file.
275   * When inlining a page in another one, links from the inlined page are now
276     expanded the same as they are when rendering the inlined page as a
277     standalone page. So rather than being expanded from the POV of the
278     inlining page, they are expanded from the POV of the inlined page.
279
280     For example, a link from blog/foo to "bar" will now link to blog/bar
281     if it exists. Previously this needed to be a link explicitly to
282     "blog/bar"; such links will also continue to work.
283
284     (This was slightly complex to do as the link still has to be constructed
285     relative to the inlining page.)
286   * Make page edit textarea resize to fit browser window.
287   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
288     do not need a full rebuild, in order to update any basewiki pages.
289
290  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
291
292 ikiwiki (1.3) unstable; urgency=low
293
294   * Fix the preinst introduced in the last version. Closes: #367458
295
296  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
297
298 ikiwiki (1.2) unstable; urgency=low
299
300   * Remove dups from the brokenlinks list.
301   * Add libc6-dev to dependencies, needed to build wrappers.
302   * Install wikilist in correct location. Closes: #367371
303
304  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
305
306 ikiwiki (1.1) unstable; urgency=low
307
308   * Rename inlinepage to depends, so that it can be used to refer to more
309     dependency relationships than just inlining. This will require a rebuild
310     on upgrade to this version.
311   * Move the rss link, put it in the blogpost form if there is one and at the
312     top if not. This is both nicer because easier to find, and it cleans up
313     the code which had used inlinepage as a flag for adding the link later.
314   * Allow the depends GlobList to be built up from multiple sources (such as
315     plugins) during a page render.
316   * Which means that more than one blog is now supported to appear on a
317     single page. (With some limitations, like only the last one getting an
318     rss file.)
319   * Added a plugin system.
320   * Added a pagecount plugin, enabled by default.
321   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
322   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
323     backlinks when the backlinks hadn't really changed.
324   * Moved inline page support, rss generation etc into the inline plugin,
325     enabled by default.
326   * Added brokenlinks plugin, not enabled by default, but rather handy.
327   * Fix several broken links in the doc wiki.
328   * Smarter behavior when creating a page and a page of the same name (but
329     different location) already exists.
330   * Add an orphans plugin for finding pages that nothing links to.
331   * Removed backlinks page, which it turns out nothing used.
332   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
333     it, this will allow for adding a unit test suite.
334   * Add unit tests for several core functions, including globlist_match,
335     dirname, basename, bestlink, linkify, pagetitle, titlepage.
336   * Smart globlist merging.
337   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
338     to pave the way for adding other RCS support. This also changes the
339     setup files, where before they had svn => 1 or svn => 0, now they have
340     rcs => "svn" or rcs => "".
341   * Add a debian/NEWS file with upgrade notes.
342   * Load whatever rcs module is specified, so new ones can be just dropped in
343     as plugins and work. (Well, in theory.)
344   * Add some basic docs about writing RCS modules.
345   * Broke search capability out into a plugin, removed the --hyperestraier
346     switch.
347   * Added smiley plugin, nicely controlled and documented by the smileys page.
348   * Copied in some smileys from Moin Moin.
349   * Allow links of the form [[some page|page]], with whitespace in the link
350     text.
351   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
352     and --disable-plugin htmlscrubber.
353   * Allow discussion links on pages to be turned off with --no-discussion.
354   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
355   * Add some new config items to the estseek.conf template, which are needed
356     by hyperestraier 1.2.3.
357
358  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
359
360 ikiwiki (1.0) unstable; urgency=low
361
362   * First official release.
363
364  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400