* Fix a forkbomb in various calls to IPC::Open2, which has a highly
[ikiwiki] / debian / changelog
1 ikiwiki (1.28) UNRELEASED; urgency=low
2
3   * inline: Add ability to sort by page name, based on a patch from
4     Benjamin A'Lee.
5   * Fix a forkbomb in various calls to IPC::Open2, which has a highly
6     braindead interface. Closes: #389383
7
8  -- Joey Hess <joeyh@debian.org>  Mon, 25 Sep 2006 17:22:52 -0400
9
10 ikiwiki (1.27) unstable; urgency=low
11
12   * Work on firming up the plugin interface:
13     - Plugins should not need to load IkiWiki::Render to get commonly
14       used functions, so moved some functions from there to IkiWiki.
15     - Picked out the set of functions and variables that most plugins
16       use, documented them, and made IkiWiki export them by default,
17       like a proper perl module should.
18     - Use the other functions at your own risk.
19     - This is not quite complete, I still have to decide whether to
20       export some other things.
21   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
22     referring to stuff now exported by the IkiWiki module.
23   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
24     to declare which version of the interface your plugin needs.
25   * Anyone with a third-party ikiwiki plugin is strongly encouraged
26     to make like changes to it and avoid use of non-exported symbols from
27     "IkiWiki::".
28   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
29   * Support hyperestradier version 1.4.2, which adds a new required phraseform
30     setting.
31   * If an inlined page has a permalink, link the page title to that.
32   * Patch from Recai to use utf8 when reading the setup file, so that
33     utf8 wikinames from there will be used properly.
34   * Patch from Recai to kill utf-8 on the wiki name when generating the
35     session cookie.
36   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
37   * Fix a baseurl problem in hyperestradier search results.
38   * Add a stub local.css to avoid problems with 404's.
39   * Patch from Recai to fix a wide character warning from the search plugin
40     during setup if the wikiname contains utf8.
41   * Yet another fix for those poor case-insensative OS X users.
42   * pagetemplate hooks are now also called when generating cgi pages.
43   * Add a favicon plugin, which simply adds a link tag for an icon to each
44     page (and cgis).
45   * Patch from James Westby to deal with the case where you're editing a
46     new page, hit cancel, and need to be redirected to somewhere sane.
47   * Various documentation improvements by various wiki users.
48   * Support Text::Markdown from CPAN, which has a different interface from
49     the original markdown or the one in Debian.
50   * Version the libcgi-session-perl dependency, some features that need
51     the new version are used in some cases (sslcookie).
52   * Numerous tla fixes from Clint.
53   * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
54     a multi-resolution favicon.ico.
55   * README.Debian: typo Closes: #388110
56   * chomp trailing newline at the end of templates read in by the template
57     plugin, to allow use of the template preprocessor directive in
58     whitespace-sensative situations. Closes: #387073
59   * Patch from James Westby to make the location of the estseek.cgi script
60     configurable.
61   * Add typography (SmartyPants) plugin by Recai.
62   * Add --render mode, which can be used to preview an edit at the command
63     line by test rendering a single page.
64   * Add a googlecalendar plugin. A bit special-purpose, but it shows
65     one way to to deal with user-supplied content that could cause XSS
66     issues w/o the htmlscrubber, and won't survive the scrubber.
67
68  -- Joey Hess <joeyh@debian.org>  Sun, 24 Sep 2006 00:02:21 -0400
69
70 ikiwiki (1.26) unstable; urgency=low
71
72   * Add a missing -n to tla undo call.
73   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
74     writes before consuming its whole stdin. Avoid this deadlock.
75   * Fix alt tags for outline checkboxes.
76
77  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
78
79 ikiwiki (1.25) unstable; urgency=low
80
81   * Add proper waitpid calls for open2ed processes throughout to avoid
82     zombies; this hit htmltidy especially badly.
83   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
84     subversion repos and fixing some other issues.
85   * Add support for tla, contributed by Clint Adams. Closes: #385936
86   * Add support for mercurial, contributed by Emanuele Aina.
87   * Include <link rel> tag for RSS feeds, used by some aggregators and
88     firefox to find the feed.
89   * Add a linkmap plugin (requires graphviz).
90
91  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
92
93 ikiwiki (1.24) unstable; urgency=low
94
95   * Simplify the data structure returned by rcs_recentchanges to avoid
96     each rcs plugin needing to form complex strings on its own.
97   * Fix another destpage issue in the inline directive. Closes: #385512
98     again.
99
100  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
101
102 ikiwiki (1.23) unstable; urgency=low
103
104   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
105
106  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
107
108 ikiwiki (1.22) unstable; urgency=low
109
110   * Change how the stylesheet url is determined in the templates: Remove
111     STYLEURL and add BASEURL to all templates (some already had it). This
112     new more general variable can be used to link to other things (eg, images)
113     from the template, as well as stylesheets.
114   * Fix a bug introduced last version to do with nested inlines.
115   * Allow preprocessor directives to span multiple lines, both to make
116     long ones with lots of values easier to write, and to allow for ones with
117     multi-line quoted values.
118   * Allow preprocessor directives to contain python-like triple-quoted
119     text blocks, for easy nesting of quotes inside.
120   * Add a template plugin.
121   * Make pagespec merge code smarter about merging duplicate pagespecs.
122   * Patch from Jordà Polo to make Setup::Standard support hashes in config
123     files.
124   * Change order of linkify and preprocess; first preprocess and then linkify.
125     This allows passing a wikilink inside a parameter to a preprocessor
126     directive without it being expanded to html, and leaking out of the
127     parameter, which had required some non-obvious use of triple-quoting
128     to avoid. Note that any preprocessor plugins that output something
129     that looks like a wikilink will now have it treated as such; AFAIK
130     this doesn't change any behavior though except for the template plugin.
131   * Enable preprocessor directives when previewing an edit.
132   * Make all pages pull in a local.css style sheet, if present. This won't
133     be included in ikiwiki, but can be created to make local styling changes
134     w/o needing to merge in every new change to the distributed style.css.
135   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
136   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
137     from a different directory.
138   * Generalised preprocesser loop protection code.
139   * Patch from James Westby to allow a description to be set for rss feeds.
140   * Patch from James Westby to add a template for the search form.
141   * Added a ddate plugin.
142   * Patch from James Westby to add a --sslcookie switch, which forces
143     cookies to only be sent over ssl connections to avoid interception.
144   * Fix preferences page on anonok wikis; still need to sign in to get
145     to the preferences page.
146   * Add toc (table of contents) plugin.
147   * Change htmlize, format, and sanitize hooks to use named parameters.
148   * Patch from James Westby to add an actions option to inline; this
149     adds Edit and Discussion links at the end of blog entries.
150   * Due to some css changes, you'll want to rebuild your wiki on upgrade
151     to this version. Will be handled automatically by the deb.
152   * Add processed date to aggregate preprocessor directive status output.
153
154  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
155
156 ikiwiki (1.21) unstable; urgency=low
157
158   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
159   * If a page links to itself, mark up the link text in a span with
160     class="selflink" so that it can be styled. I don't have a useful style
161     defined for that though.
162   * Call filter hooks on inlined page content.
163   * Support inlining pages raw, rather than creating a blog.
164   * Clean up yes/no parameter parsing in inline plugin.
165   * Implemented better cycle detection in the inline plugin; nested inlines
166     will now work.
167   * Add a map plugin contributed by Alessandro Dotti Contra.
168   * Add otl format plugin, which handles files as created by vimoutliner.
169   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
170   * Add first draft at a Restructured Text (rst) plugin, by Sergio
171     Talens-Oliag. Note that this has many known issues -- see the caveats on
172     the plugin's page.
173   * Credit everyone who wrote a plugin on the plugins' wiki pages.
174   * Fix utf-8 in blog post form.
175
176  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
177
178 ikiwiki (1.20) unstable; urgency=low
179
180   * Relicense the templates and basewiki under the 2-clause BSD license.
181     Since these can easily become part of other people's websites, they
182     should be under as permissive a license as possible.
183   * Add --syslog config option, to log to the syslog.
184   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
185     transient failure to fork (which I've seen happen in the wild).
186   * Fix a bug in the aggregator introduced last version that caused all
187     aggregator state to be lost during a non-aggregating build.
188
189  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
190
191 ikiwiki (1.19) unstable; urgency=low
192
193   * Fix several related bugs in page type determination during online editing.
194   * Add some locking to prevent 2 aggregators from running at once.
195   * Fix an infinite loop in the aggregator when finding a unique filename.
196
197  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
198
199 ikiwiki (1.18) unstable; urgency=low
200
201   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
202   * Add --version.
203   * Man page format fixups.
204   * If the meta plugin overides the page title, set a title_overridden
205     variable in the template to true. This allows doing things with the
206     templates conditional on the title being overriden.
207   * Add a %pagecase which maps lower-case page names to the actual case
208     used in the filename. Use this in bestlinks calculation instead of
209     forcing the link to lowercase.
210   * Also use %pagecase in various other places that want to check if a page
211     with a given name exists.
212   * This means that links to pages with mixed case names will now work,
213     even if the link is in some other case mixture, and mixed case pages
214     should be fully supported throughout ikiwiki.
215   * Recommend rebuilding wikis on upgrade to this version.
216
217  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
218
219 ikiwiki (1.17) unstable; urgency=low
220
221   * Disable tidy generator tag.
222   * Move tidy back to sanitize hook, found out how to only show body.
223   * Turn off tidy indentation too.
224   * Turn on HTML::Template loop_context_vars; not actually used in stock
225     templates but can be useful for things like making comma-delimited lists
226     of tags or what have you.
227   * Remove <br> from end of aggregate preprocessor directive output.
228   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
229     case-sensative filesystems like OSX.
230   * Improve markdown loading. First, try to load it as a proper perl module,
231     in case it was installed as one. Then fall back to trying
232     /usr/bin/markdown.
233   * Document in install page how to install markdown, since it has no
234     installation procedure in the upstream tarball.
235   * Set die_on_bad_params => 0 for all templates, to allow users to modify
236     them without annoyances.
237   * Suck in the page content when generating an inline archive page, to work
238     around the meta plugin's lack of caching of title metadata across runs.
239
240  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
241
242 ikiwiki (1.16) unstable; urgency=low
243
244   * Try to handle relative links in aggregated feeds. However,
245     the current support is a crude hack due to limitations of XML::Feed:
246     xml:base is not supported, neither is Content-Location. And of course,
247     relative links in RSS feeds are ill-undefined..
248   * Make aggregator save permalinks and author name to pages as metadata.
249   * Add permalink and author support to meta plugin, affecting RSS feeds
250     and blog pages.
251   * Various CSS and formatting changes.
252   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
253   * Add xhtml files to the default prune regexp.
254   * Also generate rel=bookmark links for permalinks.
255   * Fix the htmltidy plugin, which wasn't working due my breaking it when
256     I added it..
257   * Don't run tidy with -xml as that fails if the input is not well-formed.
258     Run it with -asxhtml instead, so it will output well-formed xhtml no
259     matter what the input.
260   * Disable tidy warnings too.
261   * Add a new format hook, and make tidy use it, since tidy can really only
262     operate on and output complete html documents, not the body chunks
263     that sanitise gets.
264   * Fix dates in rss feeds if running localised, so they're still rfc 822.
265
266  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
267
268 ikiwiki (1.15) unstable; urgency=low
269
270   * Remove CDPATH and other env vars perl taint checking doesn't like.
271     Closes: #381279
272   * Added created_before and created_after PageSpec limits.
273
274  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
275
276 ikiwiki (1.14) unstable; urgency=low
277
278   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
279     by 10% or so.
280   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
281   * Added many unit tests for pagespec_match.
282
283  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
284
285 ikiwiki (1.13) unstable; urgency=low
286
287   * ikiwiki can now download and aggregate feeds with its new aggregate
288     plugin, so it's possible to implement a Planet using ikiwiki!
289   * Add a run_hooks function for the common task of running all hooks of a
290     given type.
291   * Add a savestate hook.
292   * Don't put blog post forms on pages if there's no cgiurl set.
293   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
294     --wrappers to do that.
295   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
296     to update pages that haven't changed on disk.
297   * Change meta tags to use html entity-escaped text for values, so that
298     quotes and such can be represented in title tags.
299   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
300     for the above.
301   * Make --rebuild also cause --aggregate to re-download and write aggregated
302     pages.
303   * Avoid outputting duplicate meta info.
304   * Include title metadata on aggregated posts for capitalised and un-munged
305     titles.
306   * Title metadata of inlined pages now shows up in blogs and rss feeds.
307   * Fix issue with unicode filenames and updating the hyper estradier search
308     index. (Aka Please Please Please, let that be the last one.)
309   * Patch from Roland Mas to support an rss=no parameter to inline directives.
310     Closes: #380743
311   * Renamed GlobLists to PageSpecs.
312   * PageSpecs can now include nested parens, "and", and "or". This remains
313     backwards compatible to the old GlobList format. It's implemented by
314     treating the GlobList as a very limited microlanguage that is transformed
315     to perl code that does the matching.
316   * The old GlobList format is deprecated, and I encourage users to switch to
317     using the new PageSpec format. Compatability with the old format will be
318     removed at some point, possibly by 2.0.
319   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
320   * Add support for creation_month and creation_year to PageSpec.
321     Closes: #380680
322   * Changes to index file encoding.
323
324  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
325
326 ikiwiki (1.12) unstable; urgency=low
327
328   "Viva l'Italia!"
329   * New pagestats plugin from Enrico, which can generate a table counting
330     the backlinks for each page, or a del.icio.us style cloud.
331   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
332     the wikiformat plugin works. Thanks, Emanuele Aina.
333   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
334     display, running them through pagetitle. This removes ugly underscores and
335     other gunk from the display, much nicer. You may want to rebuild your wiki
336     when upgrading to get the cleanup globally.
337   * Polygen plugin from Enrico.
338   * htmltidy plugin from Faidon.
339   * Locale patch from Faidon:
340     - Adds a locale setting to setup files.
341     - Proper local time, if the locale configuration option is used.
342     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
343       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
344       impossible.
345   * Add getopt hook type, this allows plugins to add new command-line options.
346   * Add --tagbase option to tag plugin.
347   * Add exclude option in setup files, works same as --exclude.
348   * Put categories in rss feeds for tagged items.
349   * Allow preprocessor directives to be expanded in inlined blog pages.
350     However, to avoid inlining loops etc, don't expand inline directives in
351     inlined pages.
352   * fortune plugin (trivial)
353   * Tag plugins according to type.
354
355  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
356
357 ikiwiki (1.11) unstable; urgency=low
358
359   * Patch from Enrico that
360     - Adds a tag plugin that allows more easily tagging pages.
361       The meta plugin can also still be used for that, but the tag plugin
362       also lists a page's tags at the bottom of the page.
363     - Allows preprocessor directives to have parameters with no specified
364       value.
365     - Fixes preprocessor directive parameter parsing so that
366       foo=bar baz now means "foo=bar" and a "baz" with no value.
367   * Run pagetemplate hooks when inlining pages so that inlined pages also
368     list their tags.
369   * Make all plugins with pagetemplate hooks check that variables exist
370     on the template before setting them, for robustness.
371   * Switch pagetemplate hooks to using named parameters.
372   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
373     This will be the page that a source page will be part of, which is
374     different than the source page for inlined pages.
375   * Audited all plugins to endure they pass (page, destpage) to htmllink
376     appropriatly. This means inlining of various plugins will not work
377     properly, with correct links generated.
378
379  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
380
381 ikiwiki (1.10) unstable; urgency=low
382
383   * Run page through any relevant filters when generating a page preview.
384   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
385     default throughout the wiki, not only on wikitext pages. Decided to call
386     this a feature, and split the camelcase support out into a separate plugin
387     that is independant of wikitext.
388   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
389
390  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
391
392 ikiwiki (1.9) unstable; urgency=low
393
394   * Improve display of parentlinks and page title of toplevel index page.
395   * Patch from Faidon to use svn --limit when possible for recentchanges,
396     speeds up recentchanges a lot for wikis with more history.
397   * Patch from Recai to fix utf8 issues in git backend.
398   * Add wikitext markup plugin, which supports ".wiki" pages written in the
399     original wiki syntax, CamelCase links and all.
400   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
401     support, to edit pages etc without a web server.
402   * Display CGI processing errors if present.
403   * Fix from Faidon for a XML parser issue that breaks utf-8 for
404     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
405     area, and also way slow.
406   * Match 'web commit from' in SVN and git, these are web commits too.
407     (Faidon)
408   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
409     readable and avoid future mistakes. The patch seems to work and for the
410     first time I have a UTF-8 username ;-) (Faidon)
411   * Use form->field consistently, not form->param.
412   * Patch from Recai to allow selection of page type when creating a new page.
413     Default page type is inherited from the link clicked on to create the new
414     page.
415
416  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
417
418 ikiwiki (1.8) unstable; urgency=low
419
420   * Fix orphans plugin to not count a link to a nonexistant page as a reason
421     for a page not being an orphan.
422   * Support pinging services such as Technorati using XML-RPC to notify them
423     about changes to rss feeds.
424   * Parse svn log as xml for improved utf8 and security. Note that this makes
425     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
426   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
427     flagged string even if the locale causes it to generate utf8 output,
428     so make sure to let perl know it should be handled as utf8. Also,
429     the optimised version used for standard time formats won't work if the
430     user has changed locale, so drop it. Thanks, Faidon Liambotis.
431   * Fix re-encoding of the comments field to utf8 if a commit fails
432     due to a conflict. Thanks, Faidon Liambotis.
433   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
434     Liambotis.
435   * Add insane double encode/decode to utf8 around call to markdown.
436     This works around a truely strange bug, which is apparently a bug in
437     perl, #376329. Also added a test case for it.
438   * Improve layout of edit page so formatting help link is always visible w/o
439     getting in the way of the preview.
440   * Centralised all calls to HTML::Template and force all the templates
441     to be read as utf8.
442   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
443   * Introduce add_plugins and disable_plugins config options in setup files.
444     This allows adding or removing plugins w/o overriding the whole list of
445     default plugins, which makes it easier to upgrade when new default plugins
446     are added.
447   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
448     default (of course!). Based on a patch by Faidon Liambotis.
449   * Add a html plugin, which can be used to write wikis in raw html,
450     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
451     defaults to not processing .html files, since w/o this plugin they would
452     be copied unsanitised. With this plugin, it will process and html
453     sanitise them, like any other page type.
454   * Rebuilding wrappers is necessary on upgrade to this version.
455   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
456     will be automatically done on all upgrades.
457   * Don't send pings if the wiki is being rebuilt.
458   * Work around very innefficient behavior in File::Spec::abs2rel. Result
459     is a savings of 2 pointless fork/execs per link calculation, which
460     results in ~25% speedup of ikiwiki building its own doc wiki, and
461     about 35% speedup displaying RecentChanges!
462   * Make RecentChanges use a table and some CSS, should be much more readable.
463     No code changes involved.
464   * Encode & in diffurl in examples, to conform to pedantic rules.
465   * Speed up RecentChanges by another 40% or so with some memoization.
466   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
467     in time to build the doc wiki.
468
469  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
470
471 ikiwiki (1.7) unstable; urgency=low
472
473   * Updated logo from Recai with some kerning and alingment tuning.
474   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
475     changed some output.
476   * Copyright update.
477
478  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
479
480 ikiwiki (1.6) unstable; urgency=low
481
482   * YA utf-8 patch from Recai, this time to fix previewing a page so that
483     the text in the input box is re-encoded back to utf-8.
484   * -CSD does not affect modules, so readfile() was not using the utf-8 input
485     layer, which led to lots of problems; make it force read files as utf-8.
486     Closes: #373203
487   * Note that as a consequence, this version of ikiwiki will actually try to
488     parse utf8 in source files for the first time, which may expose broken
489     utf8 in wiki sources that was hidden before. Most common will be
490     perl warnings like "utf8 "\xE9" does not map to Unicode"
491   * writefile() likewise needs to use the utf8 output layer.
492   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
493     there.
494   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
495     given the readfile fix.
496   * Add utf-8 testcases for readfile and htmlize.
497   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
498     safe.
499   * More utf-8 fixes from Recai, partly to things I broke above:
500     - The serious problem is that writefile() saves the content in undecoded
501       format in CGI, hence all (non-ascii) chars are corrupted permanently.
502     - Comment field in edit page is not decoded and all the non-ascii chars in
503       this field are corrupted as the result.  We should decode it as we do it
504       for the content.
505     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
506       character in print.
507   * New SVG logo from Recai.
508
509  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
510
511 ikiwiki (1.5) unstable; urgency=low
512
513   * Add --timeformat config option to allow changing how dates are displayed.
514     Note that as a side effect, dates will now be displayed using the local
515     timezone, not as GMT.
516   * More security review.
517   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
518     for some handy stuff like:
519     - Using links as a kind of tag; creating blog pages that list all pages
520       containing a given tag/link or not containing some other tag.
521     - Subscribing to mail notifications whenever a change is made to a page
522       that is a backlink of page foo. Ie, "Please notify me of changes in all
523       pages that link to my home page in the wiki"
524     - Locking any pages that are linked to from a particular page, so that
525       lists of locks can be exposed in the wiki.
526   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
527     when a todo item is done, instead of the previous moving it to a different
528     subdir.
529   * Allow pagetemplate plugins to override *anything* in the template.
530   * Add a meta plugin, which allows specifying various metadata about pages,
531     like license and author. It also allows for inserting html link and meta
532     tags into html, overriding the title, and adding hidden WikiLinks, which
533     can be useful when using link-based globbing for page categorisation.
534   * Remove preprocessor directives from inlined pages.
535   * Allow simple preprocessor directive values to be specified w/o quotes.
536   * Add support for using git instead of subversion as the RCS backend,
537     tremendous thanks to Recai Oktaş for this.
538   * Doc updates for git.
539   * Fix absolute url munging in rss generation to support https, ftp, etc urls
540     not just http urls.
541   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
542     utf-8 for edit and other fields, and for recentchanges. There may still
543     be utf-8 issues with the preferences page though.
544
545  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
546
547 ikiwiki (1.4) unstable; urgency=low
548
549   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
550     very strange way of enabling proper XHTML <br /> type tags. Output html
551     should be always valid again now.
552   * The page name and parent links has switched from using a <h1> to a styled
553     <span>, so pages can use <h1> internally instead of needing to use <h2>.
554   * Updated all of ikiwiki's own wiki pages for that.
555   * Add pagetemplate hook, which can be used by plugins that want to mess
556     around with adding new stuff to the page template.
557   * Remove headercontent; the search plugin now adds the search box to the
558     header by registering a pagetemplate hook, and other plugins should do
559     similarly.
560   * Rebuilding on upgrade to this version is recommended.
561   * Add a html validity check to the test suite, using the wdg-html-validator,
562     if available.
563   * Make the html valid when there is nothing in the actions list.
564   * Reordered some function call parameters for consistency.
565   * Enable full utf-8 support for page input and output.
566   * Add a workaround for markdown, which does not work well with utf-8
567     strings.
568   * --getctime had bitrotted (well I only ever used it the once so far..),
569     fix and make it a bit more flexible
570   * rcs_getctime is changed, now rather than needing to loop over all pages,
571     it should just use the rcs to get the ctime of the passed file.
572   * When inlining a page in another one, links from the inlined page are now
573     expanded the same as they are when rendering the inlined page as a
574     standalone page. So rather than being expanded from the POV of the
575     inlining page, they are expanded from the POV of the inlined page.
576
577     For example, a link from blog/foo to "bar" will now link to blog/bar
578     if it exists. Previously this needed to be a link explicitly to
579     "blog/bar"; such links will also continue to work.
580
581     (This was slightly complex to do as the link still has to be constructed
582     relative to the inlining page.)
583   * Make page edit textarea resize to fit browser window.
584   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
585     do not need a full rebuild, in order to update any basewiki pages.
586
587  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
588
589 ikiwiki (1.3) unstable; urgency=low
590
591   * Fix the preinst introduced in the last version. Closes: #367458
592
593  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
594
595 ikiwiki (1.2) unstable; urgency=low
596
597   * Remove dups from the brokenlinks list.
598   * Add libc6-dev to dependencies, needed to build wrappers.
599   * Install wikilist in correct location. Closes: #367371
600
601  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
602
603 ikiwiki (1.1) unstable; urgency=low
604
605   * Rename inlinepage to depends, so that it can be used to refer to more
606     dependency relationships than just inlining. This will require a rebuild
607     on upgrade to this version.
608   * Move the rss link, put it in the blogpost form if there is one and at the
609     top if not. This is both nicer because easier to find, and it cleans up
610     the code which had used inlinepage as a flag for adding the link later.
611   * Allow the depends GlobList to be built up from multiple sources (such as
612     plugins) during a page render.
613   * Which means that more than one blog is now supported to appear on a
614     single page. (With some limitations, like only the last one getting an
615     rss file.)
616   * Added a plugin system.
617   * Added a pagecount plugin, enabled by default.
618   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
619   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
620     backlinks when the backlinks hadn't really changed.
621   * Moved inline page support, rss generation etc into the inline plugin,
622     enabled by default.
623   * Added brokenlinks plugin, not enabled by default, but rather handy.
624   * Fix several broken links in the doc wiki.
625   * Smarter behavior when creating a page and a page of the same name (but
626     different location) already exists.
627   * Add an orphans plugin for finding pages that nothing links to.
628   * Removed backlinks page, which it turns out nothing used.
629   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
630     it, this will allow for adding a unit test suite.
631   * Add unit tests for several core functions, including globlist_match,
632     dirname, basename, bestlink, linkify, pagetitle, titlepage.
633   * Smart globlist merging.
634   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
635     to pave the way for adding other RCS support. This also changes the
636     setup files, where before they had svn => 1 or svn => 0, now they have
637     rcs => "svn" or rcs => "".
638   * Add a debian/NEWS file with upgrade notes.
639   * Load whatever rcs module is specified, so new ones can be just dropped in
640     as plugins and work. (Well, in theory.)
641   * Add some basic docs about writing RCS modules.
642   * Broke search capability out into a plugin, removed the --hyperestraier
643     switch.
644   * Added smiley plugin, nicely controlled and documented by the smileys page.
645   * Copied in some smileys from Moin Moin.
646   * Allow links of the form [[some page|page]], with whitespace in the link
647     text.
648   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
649     and --disable-plugin htmlscrubber.
650   * Allow discussion links on pages to be turned off with --no-discussion.
651   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
652   * Add some new config items to the estseek.conf template, which are needed
653     by hyperestraier 1.2.3.
654
655  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
656
657 ikiwiki (1.0) unstable; urgency=low
658
659   * First official release.
660
661  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400