releasing version 1.16
[ikiwiki] / debian / changelog
1 ikiwiki (1.16) unstable; urgency=low
2
3   * Try to handle relative links in aggregated feeds. However,
4     the current support is a crude hack due to limitations of XML::Feed:
5     xml:base is not supported, neither is Content-Location. And of course,
6     relative links in RSS feeds are ill-undefined..
7   * Make aggregator save permalinks and author name to pages as metadata.
8   * Add permalink and author support to meta plugin, affecting RSS feeds
9     and blog pages.
10   * Various CSS and formatting changes.
11   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
12   * Add xhtml files to the default prune regexp.
13   * Also generate rel=bookmark links for permalinks.
14   * Fix the htmltidy plugin, which wasn't working due my breaking it when
15     I added it..
16   * Don't run tidy with -xml as that fails if the input is not well-formed.
17     Run it with -asxhtml instead, so it will output well-formed xhtml no
18     matter what the input.
19   * Disable tidy warnings too.
20   * Add a new format hook, and make tidy use it, since tidy can really only
21     operate on and output complete html documents, not the body chunks
22     that sanitise gets.
23   * Fix dates in rss feeds if running localised, so they're still rfc 822.
24
25  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
26
27 ikiwiki (1.15) unstable; urgency=low
28
29   * Remove CDPATH and other env vars perl taint checking doesn't like.
30     Closes: #381279
31   * Added created_before and created_after PageSpec limits.
32
33  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
34
35 ikiwiki (1.14) unstable; urgency=low
36
37   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
38     by 10% or so.
39   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
40   * Added many unit tests for pagespec_match.
41
42  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
43
44 ikiwiki (1.13) unstable; urgency=low
45
46   * ikiwiki can now download and aggregate feeds with its new aggregate
47     plugin, so it's possible to implement a Planet using ikiwiki!
48   * Add a run_hooks function for the common task of running all hooks of a
49     given type.
50   * Add a savestate hook.
51   * Don't put blog post forms on pages if there's no cgiurl set.
52   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
53     --wrappers to do that.
54   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
55     to update pages that haven't changed on disk.
56   * Change meta tags to use html entity-escaped text for values, so that
57     quotes and such can be represented in title tags.
58   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
59     for the above.
60   * Make --rebuild also cause --aggregate to re-download and write aggregated
61     pages.
62   * Avoid outputting duplicate meta info.
63   * Include title metadata on aggregated posts for capitalised and un-munged
64     titles.
65   * Title metadata of inlined pages now shows up in blogs and rss feeds.
66   * Fix issue with unicode filenames and updating the hyper estradier search
67     index. (Aka Please Please Please, let that be the last one.)
68   * Patch from Roland Mas to support an rss=no parameter to inline directives.
69     Closes: #380743
70   * Renamed GlobLists to PageSpecs.
71   * PageSpecs can now include nested parens, "and", and "or". This remains
72     backwards compatible to the old GlobList format. It's implemented by
73     treating the GlobList as a very limited microlanguage that is transformed
74     to perl code that does the matching.
75   * The old GlobList format is deprecated, and I encourage users to switch to
76     using the new PageSpec format. Compatability with the old format will be
77     removed at some point, possibly by 2.0.
78   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
79   * Add support for creation_month and creation_year to PageSpec.
80     Closes: #380680
81   * Changes to index file encoding.
82
83  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
84
85 ikiwiki (1.12) unstable; urgency=low
86
87   "Viva l'Italia!"
88   * New pagestats plugin from Enrico, which can generate a table counting
89     the backlinks for each page, or a del.icio.us style cloud.
90   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
91     the wikiformat plugin works. Thanks, Emanuele Aina.
92   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
93     display, running them through pagetitle. This removes ugly underscores and
94     other gunk from the display, much nicer. You may want to rebuild your wiki
95     when upgrading to get the cleanup globally.
96   * Polygen plugin from Enrico.
97   * htmltidy plugin from Faidon.
98   * Locale patch from Faidon:
99     - Adds a locale setting to setup files.
100     - Proper local time, if the locale configuration option is used.
101     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
102       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
103       impossible.
104   * Add getopt hook type, this allows plugins to add new command-line options.
105   * Add --tagbase option to tag plugin.
106   * Add exclude option in setup files, works same as --exclude.
107   * Put categories in rss feeds for tagged items.
108   * Allow preprocessor directives to be expanded in inlined blog pages.
109     However, to avoid inlining loops etc, don't expand inline directives in
110     inlined pages.
111   * fortune plugin (trivial)
112   * Tag plugins according to type.
113
114  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
115
116 ikiwiki (1.11) unstable; urgency=low
117
118   * Patch from Enrico that
119     - Adds a tag plugin that allows more easily tagging pages.
120       The meta plugin can also still be used for that, but the tag plugin
121       also lists a page's tags at the bottom of the page.
122     - Allows preprocessor directives to have parameters with no specified
123       value.
124     - Fixes preprocessor directive parameter parsing so that
125       foo=bar baz now means "foo=bar" and a "baz" with no value.
126   * Run pagetemplate hooks when inlining pages so that inlined pages also
127     list their tags.
128   * Make all plugins with pagetemplate hooks check that variables exist
129     on the template before setting them, for robustness.
130   * Switch pagetemplate hooks to using named parameters.
131   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
132     This will be the page that a source page will be part of, which is
133     different than the source page for inlined pages.
134   * Audited all plugins to endure they pass (page, destpage) to htmllink
135     appropriatly. This means inlining of various plugins will not work
136     properly, with correct links generated.
137
138  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
139
140 ikiwiki (1.10) unstable; urgency=low
141
142   * Run page through any relevant filters when generating a page preview.
143   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
144     default throughout the wiki, not only on wikitext pages. Decided to call
145     this a feature, and split the camelcase support out into a separate plugin
146     that is independant of wikitext.
147   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
148
149  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
150
151 ikiwiki (1.9) unstable; urgency=low
152
153   * Improve display of parentlinks and page title of toplevel index page.
154   * Patch from Faidon to use svn --limit when possible for recentchanges,
155     speeds up recentchanges a lot for wikis with more history.
156   * Patch from Recai to fix utf8 issues in git backend.
157   * Add wikitext markup plugin, which supports ".wiki" pages written in the
158     original wiki syntax, CamelCase links and all.
159   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
160     support, to edit pages etc without a web server.
161   * Display CGI processing errors if present.
162   * Fix from Faidon for a XML parser issue that breaks utf-8 for
163     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
164     area, and also way slow.
165   * Match 'web commit from' in SVN and git, these are web commits too.
166     (Faidon)
167   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
168     readable and avoid future mistakes. The patch seems to work and for the
169     first time I have a UTF-8 username ;-) (Faidon)
170   * Use form->field consistently, not form->param.
171   * Patch from Recai to allow selection of page type when creating a new page.
172     Default page type is inherited from the link clicked on to create the new
173     page.
174
175  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
176
177 ikiwiki (1.8) unstable; urgency=low
178
179   * Fix orphans plugin to not count a link to a nonexistant page as a reason
180     for a page not being an orphan.
181   * Support pinging services such as Technorati using XML-RPC to notify them
182     about changes to rss feeds.
183   * Parse svn log as xml for improved utf8 and security. Note that this makes
184     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
185   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
186     flagged string even if the locale causes it to generate utf8 output,
187     so make sure to let perl know it should be handled as utf8. Also,
188     the optimised version used for standard time formats won't work if the
189     user has changed locale, so drop it. Thanks, Faidon Liambotis.
190   * Fix re-encoding of the comments field to utf8 if a commit fails
191     due to a conflict. Thanks, Faidon Liambotis.
192   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
193     Liambotis.
194   * Add insane double encode/decode to utf8 around call to markdown.
195     This works around a truely strange bug, which is apparently a bug in
196     perl, #376329. Also added a test case for it.
197   * Improve layout of edit page so formatting help link is always visible w/o
198     getting in the way of the preview.
199   * Centralised all calls to HTML::Template and force all the templates
200     to be read as utf8.
201   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
202   * Introduce add_plugins and disable_plugins config options in setup files.
203     This allows adding or removing plugins w/o overriding the whole list of
204     default plugins, which makes it easier to upgrade when new default plugins
205     are added.
206   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
207     default (of course!). Based on a patch by Faidon Liambotis.
208   * Add a html plugin, which can be used to write wikis in raw html,
209     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
210     defaults to not processing .html files, since w/o this plugin they would
211     be copied unsanitised. With this plugin, it will process and html
212     sanitise them, like any other page type.
213   * Rebuilding wrappers is necessary on upgrade to this version.
214   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
215     will be automatically done on all upgrades.
216   * Don't send pings if the wiki is being rebuilt.
217   * Work around very innefficient behavior in File::Spec::abs2rel. Result
218     is a savings of 2 pointless fork/execs per link calculation, which
219     results in ~25% speedup of ikiwiki building its own doc wiki, and
220     about 35% speedup displaying RecentChanges!
221   * Make RecentChanges use a table and some CSS, should be much more readable.
222     No code changes involved.
223   * Encode & in diffurl in examples, to conform to pedantic rules.
224   * Speed up RecentChanges by another 40% or so with some memoization.
225   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
226     in time to build the doc wiki.
227
228  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
229
230 ikiwiki (1.7) unstable; urgency=low
231
232   * Updated logo from Recai with some kerning and alingment tuning.
233   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
234     changed some output.
235   * Copyright update.
236
237  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
238
239 ikiwiki (1.6) unstable; urgency=low
240
241   * YA utf-8 patch from Recai, this time to fix previewing a page so that
242     the text in the input box is re-encoded back to utf-8.
243   * -CSD does not affect modules, so readfile() was not using the utf-8 input
244     layer, which led to lots of problems; make it force read files as utf-8.
245     Closes: #373203
246   * Note that as a consequence, this version of ikiwiki will actually try to
247     parse utf8 in source files for the first time, which may expose broken
248     utf8 in wiki sources that was hidden before. Most common will be
249     perl warnings like "utf8 "\xE9" does not map to Unicode"
250   * writefile() likewise needs to use the utf8 output layer.
251   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
252     there.
253   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
254     given the readfile fix.
255   * Add utf-8 testcases for readfile and htmlize.
256   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
257     safe.
258   * More utf-8 fixes from Recai, partly to things I broke above:
259     - The serious problem is that writefile() saves the content in undecoded
260       format in CGI, hence all (non-ascii) chars are corrupted permanently.
261     - Comment field in edit page is not decoded and all the non-ascii chars in
262       this field are corrupted as the result.  We should decode it as we do it
263       for the content.
264     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
265       character in print.
266   * New SVG logo from Recai.
267
268  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
269
270 ikiwiki (1.5) unstable; urgency=low
271
272   * Add --timeformat config option to allow changing how dates are displayed.
273     Note that as a side effect, dates will now be displayed using the local
274     timezone, not as GMT.
275   * More security review.
276   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
277     for some handy stuff like:
278     - Using links as a kind of tag; creating blog pages that list all pages
279       containing a given tag/link or not containing some other tag.
280     - Subscribing to mail notifications whenever a change is made to a page
281       that is a backlink of page foo. Ie, "Please notify me of changes in all
282       pages that link to my home page in the wiki"
283     - Locking any pages that are linked to from a particular page, so that
284       lists of locks can be exposed in the wiki.
285   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
286     when a todo item is done, instead of the previous moving it to a different
287     subdir.
288   * Allow pagetemplate plugins to override *anything* in the template.
289   * Add a meta plugin, which allows specifying various metadata about pages,
290     like license and author. It also allows for inserting html link and meta
291     tags into html, overriding the title, and adding hidden WikiLinks, which
292     can be useful when using link-based globbing for page categorisation.
293   * Remove preprocessor directives from inlined pages.
294   * Allow simple preprocessor directive values to be specified w/o quotes.
295   * Add support for using git instead of subversion as the RCS backend,
296     tremendous thanks to Recai Oktaş for this.
297   * Doc updates for git.
298   * Fix absolute url munging in rss generation to support https, ftp, etc urls
299     not just http urls.
300   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
301     utf-8 for edit and other fields, and for recentchanges. There may still
302     be utf-8 issues with the preferences page though.
303
304  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
305
306 ikiwiki (1.4) unstable; urgency=low
307
308   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
309     very strange way of enabling proper XHTML <br /> type tags. Output html
310     should be always valid again now.
311   * The page name and parent links has switched from using a <h1> to a styled
312     <span>, so pages can use <h1> internally instead of needing to use <h2>.
313   * Updated all of ikiwiki's own wiki pages for that.
314   * Add pagetemplate hook, which can be used by plugins that want to mess
315     around with adding new stuff to the page template.
316   * Remove headercontent; the search plugin now adds the search box to the
317     header by registering a pagetemplate hook, and other plugins should do
318     similarly.
319   * Rebuilding on upgrade to this version is recommended.
320   * Add a html validity check to the test suite, using the wdg-html-validator,
321     if available.
322   * Make the html valid when there is nothing in the actions list.
323   * Reordered some function call parameters for consistency.
324   * Enable full utf-8 support for page input and output.
325   * Add a workaround for markdown, which does not work well with utf-8
326     strings.
327   * --getctime had bitrotted (well I only ever used it the once so far..),
328     fix and make it a bit more flexible
329   * rcs_getctime is changed, now rather than needing to loop over all pages,
330     it should just use the rcs to get the ctime of the passed file.
331   * When inlining a page in another one, links from the inlined page are now
332     expanded the same as they are when rendering the inlined page as a
333     standalone page. So rather than being expanded from the POV of the
334     inlining page, they are expanded from the POV of the inlined page.
335
336     For example, a link from blog/foo to "bar" will now link to blog/bar
337     if it exists. Previously this needed to be a link explicitly to
338     "blog/bar"; such links will also continue to work.
339
340     (This was slightly complex to do as the link still has to be constructed
341     relative to the inlining page.)
342   * Make page edit textarea resize to fit browser window.
343   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
344     do not need a full rebuild, in order to update any basewiki pages.
345
346  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
347
348 ikiwiki (1.3) unstable; urgency=low
349
350   * Fix the preinst introduced in the last version. Closes: #367458
351
352  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
353
354 ikiwiki (1.2) unstable; urgency=low
355
356   * Remove dups from the brokenlinks list.
357   * Add libc6-dev to dependencies, needed to build wrappers.
358   * Install wikilist in correct location. Closes: #367371
359
360  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
361
362 ikiwiki (1.1) unstable; urgency=low
363
364   * Rename inlinepage to depends, so that it can be used to refer to more
365     dependency relationships than just inlining. This will require a rebuild
366     on upgrade to this version.
367   * Move the rss link, put it in the blogpost form if there is one and at the
368     top if not. This is both nicer because easier to find, and it cleans up
369     the code which had used inlinepage as a flag for adding the link later.
370   * Allow the depends GlobList to be built up from multiple sources (such as
371     plugins) during a page render.
372   * Which means that more than one blog is now supported to appear on a
373     single page. (With some limitations, like only the last one getting an
374     rss file.)
375   * Added a plugin system.
376   * Added a pagecount plugin, enabled by default.
377   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
378   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
379     backlinks when the backlinks hadn't really changed.
380   * Moved inline page support, rss generation etc into the inline plugin,
381     enabled by default.
382   * Added brokenlinks plugin, not enabled by default, but rather handy.
383   * Fix several broken links in the doc wiki.
384   * Smarter behavior when creating a page and a page of the same name (but
385     different location) already exists.
386   * Add an orphans plugin for finding pages that nothing links to.
387   * Removed backlinks page, which it turns out nothing used.
388   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
389     it, this will allow for adding a unit test suite.
390   * Add unit tests for several core functions, including globlist_match,
391     dirname, basename, bestlink, linkify, pagetitle, titlepage.
392   * Smart globlist merging.
393   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
394     to pave the way for adding other RCS support. This also changes the
395     setup files, where before they had svn => 1 or svn => 0, now they have
396     rcs => "svn" or rcs => "".
397   * Add a debian/NEWS file with upgrade notes.
398   * Load whatever rcs module is specified, so new ones can be just dropped in
399     as plugins and work. (Well, in theory.)
400   * Add some basic docs about writing RCS modules.
401   * Broke search capability out into a plugin, removed the --hyperestraier
402     switch.
403   * Added smiley plugin, nicely controlled and documented by the smileys page.
404   * Copied in some smileys from Moin Moin.
405   * Allow links of the form [[some page|page]], with whitespace in the link
406     text.
407   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
408     and --disable-plugin htmlscrubber.
409   * Allow discussion links on pages to be turned off with --no-discussion.
410   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
411   * Add some new config items to the estseek.conf template, which are needed
412     by hyperestraier 1.2.3.
413
414  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
415
416 ikiwiki (1.0) unstable; urgency=low
417
418   * First official release.
419
420  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400