* Add a googlecalendar plugin. A bit special-purpose, but it shows
[ikiwiki] / debian / changelog
1 ikiwiki (1.27) UNRELEASED; urgency=low
2
3   * Add a googlecalendar plugin. A bit special-purpose, but it shows
4     one way to to deal with user-supplied content that could cause XSS
5     issues w/o the htmlscrubber, and won't survive the scrubber.
6
7  -- Joey Hess <joeyh@debian.org>  Sat,  9 Sep 2006 03:00:45 -0400
8
9 ikiwiki (1.26) unstable; urgency=low
10
11   * Add a missing -n to tla undo call.
12   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
13     writes before consuming its whole stdin. Avoid this deadlock.
14   * Fix alt tags for outline checkboxes.
15
16  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
17
18 ikiwiki (1.25) unstable; urgency=low
19
20   * Add proper waitpid calls for open2ed processes throughout to avoid
21     zombies; this hit htmltidy especially badly.
22   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
23     subversion repos and fixing some other issues.
24   * Add support for tla, contributed by Clint Adams. Closes: #385936
25   * Add support for mercurial, contributed by Emanuele Aina.
26   * Include <link rel> tag for RSS feeds, used by some aggregators and
27     firefox to find the feed.
28   * Add a linkmap plugin (requires graphviz).
29
30  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
31
32 ikiwiki (1.24) unstable; urgency=low
33
34   * Simplify the data structure returned by rcs_recentchanges to avoid
35     each rcs plugin needing to form complex strings on its own.
36   * Fix another destpage issue in the inline directive. Closes: #385512
37     again.
38
39  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
40
41 ikiwiki (1.23) unstable; urgency=low
42
43   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
44
45  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
46
47 ikiwiki (1.22) unstable; urgency=low
48
49   * Change how the stylesheet url is determined in the templates: Remove
50     STYLEURL and add BASEURL to all templates (some already had it). This
51     new more general variable can be used to link to other things (eg, images)
52     from the template, as well as stylesheets.
53   * Fix a bug introduced last version to do with nested inlines.
54   * Allow preprocessor directives to span multiple lines, both to make
55     long ones with lots of values easier to write, and to allow for ones with
56     multi-line quoted values.
57   * Allow preprocessor directives to contain python-like triple-quoted
58     text blocks, for easy nesting of quotes inside.
59   * Add a template plugin.
60   * Make pagespec merge code smarter about merging duplicate pagespecs.
61   * Patch from Jordà Polo to make Setup::Standard support hashes in config
62     files.
63   * Change order of linkify and preprocess; first preprocess and then linkify.
64     This allows passing a wikilink inside a parameter to a preprocessor
65     directive without it being expanded to html, and leaking out of the
66     parameter, which had required some non-obvious use of triple-quoting
67     to avoid. Note that any preprocessor plugins that output something
68     that looks like a wikilink will now have it treated as such; AFAIK
69     this doesn't change any behavior though except for the template plugin.
70   * Enable preprocessor directives when previewing an edit.
71   * Make all pages pull in a local.css style sheet, if present. This won't
72     be included in ikiwiki, but can be created to make local styling changes
73     w/o needing to merge in every new change to the distributed style.css.
74   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
75   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
76     from a different directory.
77   * Generalised preprocesser loop protection code.
78   * Patch from James Westby to allow a description to be set for rss feeds.
79   * Patch from James Westby to add a template for the search form.
80   * Added a ddate plugin.
81   * Patch from James Westby to add a --sslcookie switch, which forces
82     cookies to only be sent over ssl connections to avoid interception.
83   * Fix preferences page on anonok wikis; still need to sign in to get
84     to the preferences page.
85   * Add toc (table of contents) plugin.
86   * Change htmlize, format, and sanitize hooks to use named parameters.
87   * Patch from James Westby to add an actions option to inline; this
88     adds Edit and Discussion links at the end of blog entries.
89   * Due to some css changes, you'll want to rebuild your wiki on upgrade
90     to this version. Will be handled automatically by the deb.
91   * Add processed date to aggregate preprocessor directive status output.
92
93  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
94
95 ikiwiki (1.21) unstable; urgency=low
96
97   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
98   * If a page links to itself, mark up the link text in a span with
99     class="selflink" so that it can be styled. I don't have a useful style
100     defined for that though.
101   * Call filter hooks on inlined page content.
102   * Support inlining pages raw, rather than creating a blog.
103   * Clean up yes/no parameter parsing in inline plugin.
104   * Implemented better cycle detection in the inline plugin; nested inlines
105     will now work.
106   * Add a map plugin contributed by Alessandro Dotti Contra.
107   * Add otl format plugin, which handles files as created by vimoutliner.
108   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
109   * Add first draft at a Restructured Text (rst) plugin, by Sergio
110     Talens-Oliag. Note that this has many known issues -- see the caveats on
111     the plugin's page.
112   * Credit everyone who wrote a plugin on the plugins' wiki pages.
113   * Fix utf-8 in blog post form.
114
115  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
116
117 ikiwiki (1.20) unstable; urgency=low
118
119   * Relicense the templates and basewiki under the 2-clause BSD license.
120     Since these can easily become part of other people's websites, they
121     should be under as permissive a license as possible.
122   * Add --syslog config option, to log to the syslog.
123   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
124     transient failure to fork (which I've seen happen in the wild).
125   * Fix a bug in the aggregator introduced last version that caused all
126     aggregator state to be lost during a non-aggregating build.
127
128  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
129
130 ikiwiki (1.19) unstable; urgency=low
131
132   * Fix several related bugs in page type determination during online editing.
133   * Add some locking to prevent 2 aggregators from running at once.
134   * Fix an infinite loop in the aggregator when finding a unique filename.
135
136  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
137
138 ikiwiki (1.18) unstable; urgency=low
139
140   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
141   * Add --version.
142   * Man page format fixups.
143   * If the meta plugin overides the page title, set a title_overridden
144     variable in the template to true. This allows doing things with the
145     templates conditional on the title being overriden.
146   * Add a %pagecase which maps lower-case page names to the actual case
147     used in the filename. Use this in bestlinks calculation instead of
148     forcing the link to lowercase.
149   * Also use %pagecase in various other places that want to check if a page
150     with a given name exists.
151   * This means that links to pages with mixed case names will now work,
152     even if the link is in some other case mixture, and mixed case pages
153     should be fully supported throughout ikiwiki.
154   * Recommend rebuilding wikis on upgrade to this version.
155
156  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
157
158 ikiwiki (1.17) unstable; urgency=low
159
160   * Disable tidy generator tag.
161   * Move tidy back to sanitize hook, found out how to only show body.
162   * Turn off tidy indentation too.
163   * Turn on HTML::Template loop_context_vars; not actually used in stock
164     templates but can be useful for things like making comma-delimited lists
165     of tags or what have you.
166   * Remove <br> from end of aggregate preprocessor directive output.
167   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
168     case-sensative filesystems like OSX.
169   * Improve markdown loading. First, try to load it as a proper perl module,
170     in case it was installed as one. Then fall back to trying
171     /usr/bin/markdown.
172   * Document in install page how to install markdown, since it has no
173     installation procedure in the upstream tarball.
174   * Set die_on_bad_params => 0 for all templates, to allow users to modify
175     them without annoyances.
176   * Suck in the page content when generating an inline archive page, to work
177     around the meta plugin's lack of caching of title metadata across runs.
178
179  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
180
181 ikiwiki (1.16) unstable; urgency=low
182
183   * Try to handle relative links in aggregated feeds. However,
184     the current support is a crude hack due to limitations of XML::Feed:
185     xml:base is not supported, neither is Content-Location. And of course,
186     relative links in RSS feeds are ill-undefined..
187   * Make aggregator save permalinks and author name to pages as metadata.
188   * Add permalink and author support to meta plugin, affecting RSS feeds
189     and blog pages.
190   * Various CSS and formatting changes.
191   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
192   * Add xhtml files to the default prune regexp.
193   * Also generate rel=bookmark links for permalinks.
194   * Fix the htmltidy plugin, which wasn't working due my breaking it when
195     I added it..
196   * Don't run tidy with -xml as that fails if the input is not well-formed.
197     Run it with -asxhtml instead, so it will output well-formed xhtml no
198     matter what the input.
199   * Disable tidy warnings too.
200   * Add a new format hook, and make tidy use it, since tidy can really only
201     operate on and output complete html documents, not the body chunks
202     that sanitise gets.
203   * Fix dates in rss feeds if running localised, so they're still rfc 822.
204
205  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
206
207 ikiwiki (1.15) unstable; urgency=low
208
209   * Remove CDPATH and other env vars perl taint checking doesn't like.
210     Closes: #381279
211   * Added created_before and created_after PageSpec limits.
212
213  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
214
215 ikiwiki (1.14) unstable; urgency=low
216
217   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
218     by 10% or so.
219   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
220   * Added many unit tests for pagespec_match.
221
222  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
223
224 ikiwiki (1.13) unstable; urgency=low
225
226   * ikiwiki can now download and aggregate feeds with its new aggregate
227     plugin, so it's possible to implement a Planet using ikiwiki!
228   * Add a run_hooks function for the common task of running all hooks of a
229     given type.
230   * Add a savestate hook.
231   * Don't put blog post forms on pages if there's no cgiurl set.
232   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
233     --wrappers to do that.
234   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
235     to update pages that haven't changed on disk.
236   * Change meta tags to use html entity-escaped text for values, so that
237     quotes and such can be represented in title tags.
238   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
239     for the above.
240   * Make --rebuild also cause --aggregate to re-download and write aggregated
241     pages.
242   * Avoid outputting duplicate meta info.
243   * Include title metadata on aggregated posts for capitalised and un-munged
244     titles.
245   * Title metadata of inlined pages now shows up in blogs and rss feeds.
246   * Fix issue with unicode filenames and updating the hyper estradier search
247     index. (Aka Please Please Please, let that be the last one.)
248   * Patch from Roland Mas to support an rss=no parameter to inline directives.
249     Closes: #380743
250   * Renamed GlobLists to PageSpecs.
251   * PageSpecs can now include nested parens, "and", and "or". This remains
252     backwards compatible to the old GlobList format. It's implemented by
253     treating the GlobList as a very limited microlanguage that is transformed
254     to perl code that does the matching.
255   * The old GlobList format is deprecated, and I encourage users to switch to
256     using the new PageSpec format. Compatability with the old format will be
257     removed at some point, possibly by 2.0.
258   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
259   * Add support for creation_month and creation_year to PageSpec.
260     Closes: #380680
261   * Changes to index file encoding.
262
263  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
264
265 ikiwiki (1.12) unstable; urgency=low
266
267   "Viva l'Italia!"
268   * New pagestats plugin from Enrico, which can generate a table counting
269     the backlinks for each page, or a del.icio.us style cloud.
270   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
271     the wikiformat plugin works. Thanks, Emanuele Aina.
272   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
273     display, running them through pagetitle. This removes ugly underscores and
274     other gunk from the display, much nicer. You may want to rebuild your wiki
275     when upgrading to get the cleanup globally.
276   * Polygen plugin from Enrico.
277   * htmltidy plugin from Faidon.
278   * Locale patch from Faidon:
279     - Adds a locale setting to setup files.
280     - Proper local time, if the locale configuration option is used.
281     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
282       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
283       impossible.
284   * Add getopt hook type, this allows plugins to add new command-line options.
285   * Add --tagbase option to tag plugin.
286   * Add exclude option in setup files, works same as --exclude.
287   * Put categories in rss feeds for tagged items.
288   * Allow preprocessor directives to be expanded in inlined blog pages.
289     However, to avoid inlining loops etc, don't expand inline directives in
290     inlined pages.
291   * fortune plugin (trivial)
292   * Tag plugins according to type.
293
294  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
295
296 ikiwiki (1.11) unstable; urgency=low
297
298   * Patch from Enrico that
299     - Adds a tag plugin that allows more easily tagging pages.
300       The meta plugin can also still be used for that, but the tag plugin
301       also lists a page's tags at the bottom of the page.
302     - Allows preprocessor directives to have parameters with no specified
303       value.
304     - Fixes preprocessor directive parameter parsing so that
305       foo=bar baz now means "foo=bar" and a "baz" with no value.
306   * Run pagetemplate hooks when inlining pages so that inlined pages also
307     list their tags.
308   * Make all plugins with pagetemplate hooks check that variables exist
309     on the template before setting them, for robustness.
310   * Switch pagetemplate hooks to using named parameters.
311   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
312     This will be the page that a source page will be part of, which is
313     different than the source page for inlined pages.
314   * Audited all plugins to endure they pass (page, destpage) to htmllink
315     appropriatly. This means inlining of various plugins will not work
316     properly, with correct links generated.
317
318  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
319
320 ikiwiki (1.10) unstable; urgency=low
321
322   * Run page through any relevant filters when generating a page preview.
323   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
324     default throughout the wiki, not only on wikitext pages. Decided to call
325     this a feature, and split the camelcase support out into a separate plugin
326     that is independant of wikitext.
327   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
328
329  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
330
331 ikiwiki (1.9) unstable; urgency=low
332
333   * Improve display of parentlinks and page title of toplevel index page.
334   * Patch from Faidon to use svn --limit when possible for recentchanges,
335     speeds up recentchanges a lot for wikis with more history.
336   * Patch from Recai to fix utf8 issues in git backend.
337   * Add wikitext markup plugin, which supports ".wiki" pages written in the
338     original wiki syntax, CamelCase links and all.
339   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
340     support, to edit pages etc without a web server.
341   * Display CGI processing errors if present.
342   * Fix from Faidon for a XML parser issue that breaks utf-8 for
343     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
344     area, and also way slow.
345   * Match 'web commit from' in SVN and git, these are web commits too.
346     (Faidon)
347   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
348     readable and avoid future mistakes. The patch seems to work and for the
349     first time I have a UTF-8 username ;-) (Faidon)
350   * Use form->field consistently, not form->param.
351   * Patch from Recai to allow selection of page type when creating a new page.
352     Default page type is inherited from the link clicked on to create the new
353     page.
354
355  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
356
357 ikiwiki (1.8) unstable; urgency=low
358
359   * Fix orphans plugin to not count a link to a nonexistant page as a reason
360     for a page not being an orphan.
361   * Support pinging services such as Technorati using XML-RPC to notify them
362     about changes to rss feeds.
363   * Parse svn log as xml for improved utf8 and security. Note that this makes
364     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
365   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
366     flagged string even if the locale causes it to generate utf8 output,
367     so make sure to let perl know it should be handled as utf8. Also,
368     the optimised version used for standard time formats won't work if the
369     user has changed locale, so drop it. Thanks, Faidon Liambotis.
370   * Fix re-encoding of the comments field to utf8 if a commit fails
371     due to a conflict. Thanks, Faidon Liambotis.
372   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
373     Liambotis.
374   * Add insane double encode/decode to utf8 around call to markdown.
375     This works around a truely strange bug, which is apparently a bug in
376     perl, #376329. Also added a test case for it.
377   * Improve layout of edit page so formatting help link is always visible w/o
378     getting in the way of the preview.
379   * Centralised all calls to HTML::Template and force all the templates
380     to be read as utf8.
381   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
382   * Introduce add_plugins and disable_plugins config options in setup files.
383     This allows adding or removing plugins w/o overriding the whole list of
384     default plugins, which makes it easier to upgrade when new default plugins
385     are added.
386   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
387     default (of course!). Based on a patch by Faidon Liambotis.
388   * Add a html plugin, which can be used to write wikis in raw html,
389     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
390     defaults to not processing .html files, since w/o this plugin they would
391     be copied unsanitised. With this plugin, it will process and html
392     sanitise them, like any other page type.
393   * Rebuilding wrappers is necessary on upgrade to this version.
394   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
395     will be automatically done on all upgrades.
396   * Don't send pings if the wiki is being rebuilt.
397   * Work around very innefficient behavior in File::Spec::abs2rel. Result
398     is a savings of 2 pointless fork/execs per link calculation, which
399     results in ~25% speedup of ikiwiki building its own doc wiki, and
400     about 35% speedup displaying RecentChanges!
401   * Make RecentChanges use a table and some CSS, should be much more readable.
402     No code changes involved.
403   * Encode & in diffurl in examples, to conform to pedantic rules.
404   * Speed up RecentChanges by another 40% or so with some memoization.
405   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
406     in time to build the doc wiki.
407
408  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
409
410 ikiwiki (1.7) unstable; urgency=low
411
412   * Updated logo from Recai with some kerning and alingment tuning.
413   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
414     changed some output.
415   * Copyright update.
416
417  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
418
419 ikiwiki (1.6) unstable; urgency=low
420
421   * YA utf-8 patch from Recai, this time to fix previewing a page so that
422     the text in the input box is re-encoded back to utf-8.
423   * -CSD does not affect modules, so readfile() was not using the utf-8 input
424     layer, which led to lots of problems; make it force read files as utf-8.
425     Closes: #373203
426   * Note that as a consequence, this version of ikiwiki will actually try to
427     parse utf8 in source files for the first time, which may expose broken
428     utf8 in wiki sources that was hidden before. Most common will be
429     perl warnings like "utf8 "\xE9" does not map to Unicode"
430   * writefile() likewise needs to use the utf8 output layer.
431   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
432     there.
433   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
434     given the readfile fix.
435   * Add utf-8 testcases for readfile and htmlize.
436   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
437     safe.
438   * More utf-8 fixes from Recai, partly to things I broke above:
439     - The serious problem is that writefile() saves the content in undecoded
440       format in CGI, hence all (non-ascii) chars are corrupted permanently.
441     - Comment field in edit page is not decoded and all the non-ascii chars in
442       this field are corrupted as the result.  We should decode it as we do it
443       for the content.
444     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
445       character in print.
446   * New SVG logo from Recai.
447
448  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
449
450 ikiwiki (1.5) unstable; urgency=low
451
452   * Add --timeformat config option to allow changing how dates are displayed.
453     Note that as a side effect, dates will now be displayed using the local
454     timezone, not as GMT.
455   * More security review.
456   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
457     for some handy stuff like:
458     - Using links as a kind of tag; creating blog pages that list all pages
459       containing a given tag/link or not containing some other tag.
460     - Subscribing to mail notifications whenever a change is made to a page
461       that is a backlink of page foo. Ie, "Please notify me of changes in all
462       pages that link to my home page in the wiki"
463     - Locking any pages that are linked to from a particular page, so that
464       lists of locks can be exposed in the wiki.
465   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
466     when a todo item is done, instead of the previous moving it to a different
467     subdir.
468   * Allow pagetemplate plugins to override *anything* in the template.
469   * Add a meta plugin, which allows specifying various metadata about pages,
470     like license and author. It also allows for inserting html link and meta
471     tags into html, overriding the title, and adding hidden WikiLinks, which
472     can be useful when using link-based globbing for page categorisation.
473   * Remove preprocessor directives from inlined pages.
474   * Allow simple preprocessor directive values to be specified w/o quotes.
475   * Add support for using git instead of subversion as the RCS backend,
476     tremendous thanks to Recai Oktaş for this.
477   * Doc updates for git.
478   * Fix absolute url munging in rss generation to support https, ftp, etc urls
479     not just http urls.
480   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
481     utf-8 for edit and other fields, and for recentchanges. There may still
482     be utf-8 issues with the preferences page though.
483
484  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
485
486 ikiwiki (1.4) unstable; urgency=low
487
488   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
489     very strange way of enabling proper XHTML <br /> type tags. Output html
490     should be always valid again now.
491   * The page name and parent links has switched from using a <h1> to a styled
492     <span>, so pages can use <h1> internally instead of needing to use <h2>.
493   * Updated all of ikiwiki's own wiki pages for that.
494   * Add pagetemplate hook, which can be used by plugins that want to mess
495     around with adding new stuff to the page template.
496   * Remove headercontent; the search plugin now adds the search box to the
497     header by registering a pagetemplate hook, and other plugins should do
498     similarly.
499   * Rebuilding on upgrade to this version is recommended.
500   * Add a html validity check to the test suite, using the wdg-html-validator,
501     if available.
502   * Make the html valid when there is nothing in the actions list.
503   * Reordered some function call parameters for consistency.
504   * Enable full utf-8 support for page input and output.
505   * Add a workaround for markdown, which does not work well with utf-8
506     strings.
507   * --getctime had bitrotted (well I only ever used it the once so far..),
508     fix and make it a bit more flexible
509   * rcs_getctime is changed, now rather than needing to loop over all pages,
510     it should just use the rcs to get the ctime of the passed file.
511   * When inlining a page in another one, links from the inlined page are now
512     expanded the same as they are when rendering the inlined page as a
513     standalone page. So rather than being expanded from the POV of the
514     inlining page, they are expanded from the POV of the inlined page.
515
516     For example, a link from blog/foo to "bar" will now link to blog/bar
517     if it exists. Previously this needed to be a link explicitly to
518     "blog/bar"; such links will also continue to work.
519
520     (This was slightly complex to do as the link still has to be constructed
521     relative to the inlining page.)
522   * Make page edit textarea resize to fit browser window.
523   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
524     do not need a full rebuild, in order to update any basewiki pages.
525
526  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
527
528 ikiwiki (1.3) unstable; urgency=low
529
530   * Fix the preinst introduced in the last version. Closes: #367458
531
532  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
533
534 ikiwiki (1.2) unstable; urgency=low
535
536   * Remove dups from the brokenlinks list.
537   * Add libc6-dev to dependencies, needed to build wrappers.
538   * Install wikilist in correct location. Closes: #367371
539
540  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
541
542 ikiwiki (1.1) unstable; urgency=low
543
544   * Rename inlinepage to depends, so that it can be used to refer to more
545     dependency relationships than just inlining. This will require a rebuild
546     on upgrade to this version.
547   * Move the rss link, put it in the blogpost form if there is one and at the
548     top if not. This is both nicer because easier to find, and it cleans up
549     the code which had used inlinepage as a flag for adding the link later.
550   * Allow the depends GlobList to be built up from multiple sources (such as
551     plugins) during a page render.
552   * Which means that more than one blog is now supported to appear on a
553     single page. (With some limitations, like only the last one getting an
554     rss file.)
555   * Added a plugin system.
556   * Added a pagecount plugin, enabled by default.
557   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
558   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
559     backlinks when the backlinks hadn't really changed.
560   * Moved inline page support, rss generation etc into the inline plugin,
561     enabled by default.
562   * Added brokenlinks plugin, not enabled by default, but rather handy.
563   * Fix several broken links in the doc wiki.
564   * Smarter behavior when creating a page and a page of the same name (but
565     different location) already exists.
566   * Add an orphans plugin for finding pages that nothing links to.
567   * Removed backlinks page, which it turns out nothing used.
568   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
569     it, this will allow for adding a unit test suite.
570   * Add unit tests for several core functions, including globlist_match,
571     dirname, basename, bestlink, linkify, pagetitle, titlepage.
572   * Smart globlist merging.
573   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
574     to pave the way for adding other RCS support. This also changes the
575     setup files, where before they had svn => 1 or svn => 0, now they have
576     rcs => "svn" or rcs => "".
577   * Add a debian/NEWS file with upgrade notes.
578   * Load whatever rcs module is specified, so new ones can be just dropped in
579     as plugins and work. (Well, in theory.)
580   * Add some basic docs about writing RCS modules.
581   * Broke search capability out into a plugin, removed the --hyperestraier
582     switch.
583   * Added smiley plugin, nicely controlled and documented by the smileys page.
584   * Copied in some smileys from Moin Moin.
585   * Allow links of the form [[some page|page]], with whitespace in the link
586     text.
587   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
588     and --disable-plugin htmlscrubber.
589   * Allow discussion links on pages to be turned off with --no-discussion.
590   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
591   * Add some new config items to the estseek.conf template, which are needed
592     by hyperestraier 1.2.3.
593
594  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
595
596 ikiwiki (1.0) unstable; urgency=low
597
598   * First official release.
599
600  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400