* Match 'web commit from' in SVN and git, these are web commits too.
[ikiwiki] / debian / changelog
1 ikiwiki (1.9) UNRELEASED; urgency=low
2
3   * Improve display of parentlinks and page title of toplevel index page.
4   * Patch from Faidon to use svn --limit when possible for recentchanges,
5     speeds up recentchanges a lot for wikis with more history.
6   * Patch from Recai to fix utf8 issues in git backend.
7   * Add wikitext markup plugin, which supports ".wiki" pages written in the
8     original wiki syntax, CamelCase links and all.
9   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
10     support, to edit pages etc without a web server.
11   * Display CGI processing errors if present.
12   * Fix from Faidon for a XML parser issue that breaks utf-8 for
13     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
14     area, and also way slow.
15   * Match 'web commit from' in SVN and git, these are web commits too.
16     (Faidon)
17
18  -- Joey Hess <joeyh@debian.org>  Tue, 11 Jul 2006 16:54:00 -0400
19
20 ikiwiki (1.8) unstable; urgency=low
21
22   * Fix orphans plugin to not count a link to a nonexistant page as a reason
23     for a page not being an orphan.
24   * Support pinging services such as Technorati using XML-RPC to notify them
25     about changes to rss feeds.
26   * Parse svn log as xml for improved utf8 and security. Note that this makes
27     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
28   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
29     flagged string even if the locale causes it to generate utf8 output,
30     so make sure to let perl know it should be handled as utf8. Also,
31     the optimised version used for standard time formats won't work if the
32     user has changed locale, so drop it. Thanks, Faidon Liambotis.
33   * Fix re-encoding of the comments field to utf8 if a commit fails
34     due to a conflict. Thanks, Faidon Liambotis.
35   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
36     Liambotis.
37   * Add insane double encode/decode to utf8 around call to markdown.
38     This works around a truely strange bug, which is apparently a bug in
39     perl, #376329. Also added a test case for it.
40   * Improve layout of edit page so formatting help link is always visible w/o
41     getting in the way of the preview.
42   * Centralised all calls to HTML::Template and force all the templates
43     to be read as utf8.
44   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
45   * Introduce add_plugins and disable_plugins config options in setup files.
46     This allows adding or removing plugins w/o overriding the whole list of
47     default plugins, which makes it easier to upgrade when new default plugins
48     are added.
49   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
50     default (of course!). Based on a patch by Faidon Liambotis.
51   * Add a html plugin, which can be used to write wikis in raw html,
52     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
53     defaults to not processing .html files, since w/o this plugin they would
54     be copied unsanitised. With this plugin, it will process and html
55     sanitise them, like any other page type.
56   * Rebuilding wrappers is necessary on upgrade to this version.
57   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
58     will be automatically done on all upgrades.
59   * Don't send pings if the wiki is being rebuilt.
60   * Work around very innefficient behavior in File::Spec::abs2rel. Result
61     is a savings of 2 pointless fork/execs per link calculation, which
62     results in ~25% speedup of ikiwiki building its own doc wiki, and
63     about 35% speedup displaying RecentChanges!
64   * Make RecentChanges use a table and some CSS, should be much more readable.
65     No code changes involved.
66   * Encode & in diffurl in examples, to conform to pedantic rules.
67   * Speed up RecentChanges by another 40% or so with some memoization.
68   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
69     in time to build the doc wiki.
70
71  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
72
73 ikiwiki (1.7) unstable; urgency=low
74
75   * Updated logo from Recai with some kerning and alingment tuning.
76   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
77     changed some output.
78   * Copyright update.
79
80  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
81
82 ikiwiki (1.6) unstable; urgency=low
83
84   * YA utf-8 patch from Recai, this time to fix previewing a page so that
85     the text in the input box is re-encoded back to utf-8.
86   * -CSD does not affect modules, so readfile() was not using the utf-8 input
87     layer, which led to lots of problems; make it force read files as utf-8.
88     Closes: #373203
89   * Note that as a consequence, this version of ikiwiki will actually try to
90     parse utf8 in source files for the first time, which may expose broken
91     utf8 in wiki sources that was hidden before. Most common will be
92     perl warnings like "utf8 "\xE9" does not map to Unicode"
93   * writefile() likewise needs to use the utf8 output layer.
94   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
95     there.
96   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
97     given the readfile fix.
98   * Add utf-8 testcases for readfile and htmlize.
99   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
100     safe.
101   * More utf-8 fixes from Recai, partly to things I broke above:
102     - The serious problem is that writefile() saves the content in undecoded
103       format in CGI, hence all (non-ascii) chars are corrupted permanently.
104     - Comment field in edit page is not decoded and all the non-ascii chars in
105       this field are corrupted as the result.  We should decode it as we do it
106       for the content.
107     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
108       character in print.
109   * New SVG logo from Recai.
110
111  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
112
113 ikiwiki (1.5) unstable; urgency=low
114
115   * Add --timeformat config option to allow changing how dates are displayed.
116     Note that as a side effect, dates will now be displayed using the local
117     timezone, not as GMT.
118   * More security review.
119   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
120     for some handy stuff like:
121     - Using links as a kind of tag; creating blog pages that list all pages
122       containing a given tag/link or not containing some other tag.
123     - Subscribing to mail notifications whenever a change is made to a page
124       that is a backlink of page foo. Ie, "Please notify me of changes in all
125       pages that link to my home page in the wiki"
126     - Locking any pages that are linked to from a particular page, so that
127       lists of locks can be exposed in the wiki.
128   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
129     when a todo item is done, instead of the previous moving it to a different
130     subdir.
131   * Allow pagetemplate plugins to override *anything* in the template.
132   * Add a meta plugin, which allows specifying various metadata about pages,
133     like license and author. It also allows for inserting html link and meta
134     tags into html, overriding the title, and adding hidden WikiLinks, which
135     can be useful when using link-based globbing for page categorisation.
136   * Remove preprocessor directives from inlined pages.
137   * Allow simple preprocessor directive values to be specified w/o quotes.
138   * Add support for using git instead of subversion as the RCS backend,
139     tremendous thanks to Recai Oktaş for this.
140   * Doc updates for git.
141   * Fix absolute url munging in rss generation to support https, ftp, etc urls
142     not just http urls.
143   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
144     utf-8 for edit and other fields, and for recentchanges. There may still
145     be utf-8 issues with the preferences page though.
146
147  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
148
149 ikiwiki (1.4) unstable; urgency=low
150
151   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
152     very strange way of enabling proper XHTML <br /> type tags. Output html
153     should be always valid again now.
154   * The page name and parent links has switched from using a <h1> to a styled
155     <span>, so pages can use <h1> internally instead of needing to use <h2>.
156   * Updated all of ikiwiki's own wiki pages for that.
157   * Add pagetemplate hook, which can be used by plugins that want to mess
158     around with adding new stuff to the page template.
159   * Remove headercontent; the search plugin now adds the search box to the
160     header by registering a pagetemplate hook, and other plugins should do
161     similarly.
162   * Rebuilding on upgrade to this version is recommended.
163   * Add a html validity check to the test suite, using the wdg-html-validator,
164     if available.
165   * Make the html valid when there is nothing in the actions list.
166   * Reordered some function call parameters for consistency.
167   * Enable full utf-8 support for page input and output.
168   * Add a workaround for markdown, which does not work well with utf-8
169     strings.
170   * --getctime had bitrotted (well I only ever used it the once so far..),
171     fix and make it a bit more flexible
172   * rcs_getctime is changed, now rather than needing to loop over all pages,
173     it should just use the rcs to get the ctime of the passed file.
174   * When inlining a page in another one, links from the inlined page are now
175     expanded the same as they are when rendering the inlined page as a
176     standalone page. So rather than being expanded from the POV of the
177     inlining page, they are expanded from the POV of the inlined page.
178
179     For example, a link from blog/foo to "bar" will now link to blog/bar
180     if it exists. Previously this needed to be a link explicitly to
181     "blog/bar"; such links will also continue to work.
182
183     (This was slightly complex to do as the link still has to be constructed
184     relative to the inlining page.)
185   * Make page edit textarea resize to fit browser window.
186   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
187     do not need a full rebuild, in order to update any basewiki pages.
188
189  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
190
191 ikiwiki (1.3) unstable; urgency=low
192
193   * Fix the preinst introduced in the last version. Closes: #367458
194
195  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
196
197 ikiwiki (1.2) unstable; urgency=low
198
199   * Remove dups from the brokenlinks list.
200   * Add libc6-dev to dependencies, needed to build wrappers.
201   * Install wikilist in correct location. Closes: #367371
202
203  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
204
205 ikiwiki (1.1) unstable; urgency=low
206
207   * Rename inlinepage to depends, so that it can be used to refer to more
208     dependency relationships than just inlining. This will require a rebuild
209     on upgrade to this version.
210   * Move the rss link, put it in the blogpost form if there is one and at the
211     top if not. This is both nicer because easier to find, and it cleans up
212     the code which had used inlinepage as a flag for adding the link later.
213   * Allow the depends GlobList to be built up from multiple sources (such as
214     plugins) during a page render.
215   * Which means that more than one blog is now supported to appear on a
216     single page. (With some limitations, like only the last one getting an
217     rss file.)
218   * Added a plugin system.
219   * Added a pagecount plugin, enabled by default.
220   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
221   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
222     backlinks when the backlinks hadn't really changed.
223   * Moved inline page support, rss generation etc into the inline plugin,
224     enabled by default.
225   * Added brokenlinks plugin, not enabled by default, but rather handy.
226   * Fix several broken links in the doc wiki.
227   * Smarter behavior when creating a page and a page of the same name (but
228     different location) already exists.
229   * Add an orphans plugin for finding pages that nothing links to.
230   * Removed backlinks page, which it turns out nothing used.
231   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
232     it, this will allow for adding a unit test suite.
233   * Add unit tests for several core functions, including globlist_match,
234     dirname, basename, bestlink, linkify, pagetitle, titlepage.
235   * Smart globlist merging.
236   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
237     to pave the way for adding other RCS support. This also changes the
238     setup files, where before they had svn => 1 or svn => 0, now they have
239     rcs => "svn" or rcs => "".
240   * Add a debian/NEWS file with upgrade notes.
241   * Load whatever rcs module is specified, so new ones can be just dropped in
242     as plugins and work. (Well, in theory.)
243   * Add some basic docs about writing RCS modules.
244   * Broke search capability out into a plugin, removed the --hyperestraier
245     switch.
246   * Added smiley plugin, nicely controlled and documented by the smileys page.
247   * Copied in some smileys from Moin Moin.
248   * Allow links of the form [[some page|page]], with whitespace in the link
249     text.
250   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
251     and --disable-plugin htmlscrubber.
252   * Allow discussion links on pages to be turned off with --no-discussion.
253   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
254   * Add some new config items to the estseek.conf template, which are needed
255     by hyperestraier 1.2.3.
256
257  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
258
259 ikiwiki (1.0) unstable; urgency=low
260
261   * First official release.
262
263  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400