* Fix a subtle bug in will_render that broke some builds, by only clearing
[ikiwiki] / debian / changelog
1 ikiwiki (1.30) UNRELEASED; urgency=low
2
3   * Add no_override parameter to hook().
4   * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
5     plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
6     can be configured using a page in wiki.
7   * Fix support for --pingurl at the command line.
8   * Fix a subtle bug in will_render that broke some builds, by only clearing
9     items from renderedfiles the first time per build.
10
11  -- Joey Hess <joeyh@debian.org>  Mon, 16 Oct 2006 14:50:13 -0400
12
13 ikiwiki (1.29) unstable; urgency=low
14
15   * Patch from Paul Tötterman to use CP in the Makefile.
16   * Patch from Alec Berryman adding a http_auth config item that allows
17     using HTTP Authentication instead of ikiwiki's built in authentication.
18     Useful for eg, large sites with their own previously existing user auth
19     setup. Closes: #384534
20   * Change %renderedfiles to store an array of files rendered from a given
21     source file, to allow tracking of extra rendered files like rss feeds.
22   * Note that plugins that accessed this variable will need to be updated!
23     The plugin interface has been increased to version 1.01 for this change.
24     As few plugins use %renderedfiles I haven't done anything else to ensure
25     compatability of old plugins.
26   * Add will_render function to the plugin interface, used to register that a
27     page renders a destination file, and do some security checks. Previously
28     but no longer rendered files will be cleaned up.
29   * Use will_render in the inline and linkmap plugins.
30   * You will need to rebuild your wiki on upgrade to this version.
31   * Atom feed support based on a patch by Clint Adams.
32   * Add feeds=no option to inline preprocessor directive to turn off all types
33     of feeds.
34   * $IkiWiki::version now holds the program version, and is accessible to
35     plugins.
36   * Make the aggregate plugin emphasize error messages.
37   * Patch from Recai to limit recentchanges to displaying max 10 files for a
38     given changeset (to avoid large number of file changes excessively
39     bloating the page).
40
41  -- Joey Hess <joeyh@debian.org>  Fri, 13 Oct 2006 23:14:28 -0400
42
43 ikiwiki (1.28) unstable; urgency=low
44
45   * inline: Add ability to sort by page name, based on a patch from
46     Benjamin A'Lee.
47   * Fix a forkbomb in various calls to IPC::Open2, which has a highly
48     braindead interface. Closes: #389383
49   * Don't rm -rf ikiwiki on distclean, since a) there's no such file
50     and b) those poor Mac OSX users and their case insensative files!
51   * Don't fail syntax check if Text::Typography isn't installed.
52     Closes: #389406
53
54  -- Joey Hess <joeyh@debian.org>  Tue, 26 Sep 2006 02:08:17 -0400
55
56 ikiwiki (1.27) unstable; urgency=low
57
58   * Work on firming up the plugin interface:
59     - Plugins should not need to load IkiWiki::Render to get commonly
60       used functions, so moved some functions from there to IkiWiki.
61     - Picked out the set of functions and variables that most plugins
62       use, documented them, and made IkiWiki export them by default,
63       like a proper perl module should.
64     - Use the other functions at your own risk.
65     - This is not quite complete, I still have to decide whether to
66       export some other things.
67   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
68     referring to stuff now exported by the IkiWiki module.
69   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
70     to declare which version of the interface your plugin needs.
71   * Anyone with a third-party ikiwiki plugin is strongly encouraged
72     to make like changes to it and avoid use of non-exported symbols from
73     "IkiWiki::".
74   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
75   * Support hyperestradier version 1.4.2, which adds a new required phraseform
76     setting.
77   * If an inlined page has a permalink, link the page title to that.
78   * Patch from Recai to use utf8 when reading the setup file, so that
79     utf8 wikinames from there will be used properly.
80   * Patch from Recai to kill utf-8 on the wiki name when generating the
81     session cookie.
82   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
83   * Fix a baseurl problem in hyperestradier search results.
84   * Add a stub local.css to avoid problems with 404's.
85   * Patch from Recai to fix a wide character warning from the search plugin
86     during setup if the wikiname contains utf8.
87   * Yet another fix for those poor case-insensative OS X users.
88   * pagetemplate hooks are now also called when generating cgi pages.
89   * Add a favicon plugin, which simply adds a link tag for an icon to each
90     page (and cgis).
91   * Patch from James Westby to deal with the case where you're editing a
92     new page, hit cancel, and need to be redirected to somewhere sane.
93   * Various documentation improvements by various wiki users.
94   * Support Text::Markdown from CPAN, which has a different interface from
95     the original markdown or the one in Debian.
96   * Version the libcgi-session-perl dependency, some features that need
97     the new version are used in some cases (sslcookie).
98   * Numerous tla fixes from Clint.
99   * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
100     a multi-resolution favicon.ico.
101   * README.Debian: typo Closes: #388110
102   * chomp trailing newline at the end of templates read in by the template
103     plugin, to allow use of the template preprocessor directive in
104     whitespace-sensative situations. Closes: #387073
105   * Patch from James Westby to make the location of the estseek.cgi script
106     configurable.
107   * Add typography (SmartyPants) plugin by Recai.
108   * Add --render mode, which can be used to preview an edit at the command
109     line by test rendering a single page.
110   * Add a googlecalendar plugin. A bit special-purpose, but it shows
111     one way to to deal with user-supplied content that could cause XSS
112     issues w/o the htmlscrubber, and won't survive the scrubber.
113
114  -- Joey Hess <joeyh@debian.org>  Sun, 24 Sep 2006 00:02:21 -0400
115
116 ikiwiki (1.26) unstable; urgency=low
117
118   * Add a missing -n to tla undo call.
119   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
120     writes before consuming its whole stdin. Avoid this deadlock.
121   * Fix alt tags for outline checkboxes.
122
123  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
124
125 ikiwiki (1.25) unstable; urgency=low
126
127   * Add proper waitpid calls for open2ed processes throughout to avoid
128     zombies; this hit htmltidy especially badly.
129   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
130     subversion repos and fixing some other issues.
131   * Add support for tla, contributed by Clint Adams. Closes: #385936
132   * Add support for mercurial, contributed by Emanuele Aina.
133   * Include <link rel> tag for RSS feeds, used by some aggregators and
134     firefox to find the feed.
135   * Add a linkmap plugin (requires graphviz).
136
137  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
138
139 ikiwiki (1.24) unstable; urgency=low
140
141   * Simplify the data structure returned by rcs_recentchanges to avoid
142     each rcs plugin needing to form complex strings on its own.
143   * Fix another destpage issue in the inline directive. Closes: #385512
144     again.
145
146  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
147
148 ikiwiki (1.23) unstable; urgency=low
149
150   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
151
152  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
153
154 ikiwiki (1.22) unstable; urgency=low
155
156   * Change how the stylesheet url is determined in the templates: Remove
157     STYLEURL and add BASEURL to all templates (some already had it). This
158     new more general variable can be used to link to other things (eg, images)
159     from the template, as well as stylesheets.
160   * Fix a bug introduced last version to do with nested inlines.
161   * Allow preprocessor directives to span multiple lines, both to make
162     long ones with lots of values easier to write, and to allow for ones with
163     multi-line quoted values.
164   * Allow preprocessor directives to contain python-like triple-quoted
165     text blocks, for easy nesting of quotes inside.
166   * Add a template plugin.
167   * Make pagespec merge code smarter about merging duplicate pagespecs.
168   * Patch from Jordà Polo to make Setup::Standard support hashes in config
169     files.
170   * Change order of linkify and preprocess; first preprocess and then linkify.
171     This allows passing a wikilink inside a parameter to a preprocessor
172     directive without it being expanded to html, and leaking out of the
173     parameter, which had required some non-obvious use of triple-quoting
174     to avoid. Note that any preprocessor plugins that output something
175     that looks like a wikilink will now have it treated as such; AFAIK
176     this doesn't change any behavior though except for the template plugin.
177   * Enable preprocessor directives when previewing an edit.
178   * Make all pages pull in a local.css style sheet, if present. This won't
179     be included in ikiwiki, but can be created to make local styling changes
180     w/o needing to merge in every new change to the distributed style.css.
181   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
182   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
183     from a different directory.
184   * Generalised preprocesser loop protection code.
185   * Patch from James Westby to allow a description to be set for rss feeds.
186   * Patch from James Westby to add a template for the search form.
187   * Added a ddate plugin.
188   * Patch from James Westby to add a --sslcookie switch, which forces
189     cookies to only be sent over ssl connections to avoid interception.
190   * Fix preferences page on anonok wikis; still need to sign in to get
191     to the preferences page.
192   * Add toc (table of contents) plugin.
193   * Change htmlize, format, and sanitize hooks to use named parameters.
194   * Patch from James Westby to add an actions option to inline; this
195     adds Edit and Discussion links at the end of blog entries.
196   * Due to some css changes, you'll want to rebuild your wiki on upgrade
197     to this version. Will be handled automatically by the deb.
198   * Add processed date to aggregate preprocessor directive status output.
199
200  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
201
202 ikiwiki (1.21) unstable; urgency=low
203
204   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
205   * If a page links to itself, mark up the link text in a span with
206     class="selflink" so that it can be styled. I don't have a useful style
207     defined for that though.
208   * Call filter hooks on inlined page content.
209   * Support inlining pages raw, rather than creating a blog.
210   * Clean up yes/no parameter parsing in inline plugin.
211   * Implemented better cycle detection in the inline plugin; nested inlines
212     will now work.
213   * Add a map plugin contributed by Alessandro Dotti Contra.
214   * Add otl format plugin, which handles files as created by vimoutliner.
215   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
216   * Add first draft at a Restructured Text (rst) plugin, by Sergio
217     Talens-Oliag. Note that this has many known issues -- see the caveats on
218     the plugin's page.
219   * Credit everyone who wrote a plugin on the plugins' wiki pages.
220   * Fix utf-8 in blog post form.
221
222  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
223
224 ikiwiki (1.20) unstable; urgency=low
225
226   * Relicense the templates and basewiki under the 2-clause BSD license.
227     Since these can easily become part of other people's websites, they
228     should be under as permissive a license as possible.
229   * Add --syslog config option, to log to the syslog.
230   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
231     transient failure to fork (which I've seen happen in the wild).
232   * Fix a bug in the aggregator introduced last version that caused all
233     aggregator state to be lost during a non-aggregating build.
234
235  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
236
237 ikiwiki (1.19) unstable; urgency=low
238
239   * Fix several related bugs in page type determination during online editing.
240   * Add some locking to prevent 2 aggregators from running at once.
241   * Fix an infinite loop in the aggregator when finding a unique filename.
242
243  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
244
245 ikiwiki (1.18) unstable; urgency=low
246
247   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
248   * Add --version.
249   * Man page format fixups.
250   * If the meta plugin overides the page title, set a title_overridden
251     variable in the template to true. This allows doing things with the
252     templates conditional on the title being overriden.
253   * Add a %pagecase which maps lower-case page names to the actual case
254     used in the filename. Use this in bestlinks calculation instead of
255     forcing the link to lowercase.
256   * Also use %pagecase in various other places that want to check if a page
257     with a given name exists.
258   * This means that links to pages with mixed case names will now work,
259     even if the link is in some other case mixture, and mixed case pages
260     should be fully supported throughout ikiwiki.
261   * Recommend rebuilding wikis on upgrade to this version.
262
263  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
264
265 ikiwiki (1.17) unstable; urgency=low
266
267   * Disable tidy generator tag.
268   * Move tidy back to sanitize hook, found out how to only show body.
269   * Turn off tidy indentation too.
270   * Turn on HTML::Template loop_context_vars; not actually used in stock
271     templates but can be useful for things like making comma-delimited lists
272     of tags or what have you.
273   * Remove <br> from end of aggregate preprocessor directive output.
274   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
275     case-sensative filesystems like OSX.
276   * Improve markdown loading. First, try to load it as a proper perl module,
277     in case it was installed as one. Then fall back to trying
278     /usr/bin/markdown.
279   * Document in install page how to install markdown, since it has no
280     installation procedure in the upstream tarball.
281   * Set die_on_bad_params => 0 for all templates, to allow users to modify
282     them without annoyances.
283   * Suck in the page content when generating an inline archive page, to work
284     around the meta plugin's lack of caching of title metadata across runs.
285
286  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
287
288 ikiwiki (1.16) unstable; urgency=low
289
290   * Try to handle relative links in aggregated feeds. However,
291     the current support is a crude hack due to limitations of XML::Feed:
292     xml:base is not supported, neither is Content-Location. And of course,
293     relative links in RSS feeds are ill-undefined..
294   * Make aggregator save permalinks and author name to pages as metadata.
295   * Add permalink and author support to meta plugin, affecting RSS feeds
296     and blog pages.
297   * Various CSS and formatting changes.
298   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
299   * Add xhtml files to the default prune regexp.
300   * Also generate rel=bookmark links for permalinks.
301   * Fix the htmltidy plugin, which wasn't working due my breaking it when
302     I added it..
303   * Don't run tidy with -xml as that fails if the input is not well-formed.
304     Run it with -asxhtml instead, so it will output well-formed xhtml no
305     matter what the input.
306   * Disable tidy warnings too.
307   * Add a new format hook, and make tidy use it, since tidy can really only
308     operate on and output complete html documents, not the body chunks
309     that sanitise gets.
310   * Fix dates in rss feeds if running localised, so they're still rfc 822.
311
312  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
313
314 ikiwiki (1.15) unstable; urgency=low
315
316   * Remove CDPATH and other env vars perl taint checking doesn't like.
317     Closes: #381279
318   * Added created_before and created_after PageSpec limits.
319
320  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
321
322 ikiwiki (1.14) unstable; urgency=low
323
324   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
325     by 10% or so.
326   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
327   * Added many unit tests for pagespec_match.
328
329  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
330
331 ikiwiki (1.13) unstable; urgency=low
332
333   * ikiwiki can now download and aggregate feeds with its new aggregate
334     plugin, so it's possible to implement a Planet using ikiwiki!
335   * Add a run_hooks function for the common task of running all hooks of a
336     given type.
337   * Add a savestate hook.
338   * Don't put blog post forms on pages if there's no cgiurl set.
339   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
340     --wrappers to do that.
341   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
342     to update pages that haven't changed on disk.
343   * Change meta tags to use html entity-escaped text for values, so that
344     quotes and such can be represented in title tags.
345   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
346     for the above.
347   * Make --rebuild also cause --aggregate to re-download and write aggregated
348     pages.
349   * Avoid outputting duplicate meta info.
350   * Include title metadata on aggregated posts for capitalised and un-munged
351     titles.
352   * Title metadata of inlined pages now shows up in blogs and rss feeds.
353   * Fix issue with unicode filenames and updating the hyper estradier search
354     index. (Aka Please Please Please, let that be the last one.)
355   * Patch from Roland Mas to support an rss=no parameter to inline directives.
356     Closes: #380743
357   * Renamed GlobLists to PageSpecs.
358   * PageSpecs can now include nested parens, "and", and "or". This remains
359     backwards compatible to the old GlobList format. It's implemented by
360     treating the GlobList as a very limited microlanguage that is transformed
361     to perl code that does the matching.
362   * The old GlobList format is deprecated, and I encourage users to switch to
363     using the new PageSpec format. Compatability with the old format will be
364     removed at some point, possibly by 2.0.
365   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
366   * Add support for creation_month and creation_year to PageSpec.
367     Closes: #380680
368   * Changes to index file encoding.
369
370  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
371
372 ikiwiki (1.12) unstable; urgency=low
373
374   "Viva l'Italia!"
375   * New pagestats plugin from Enrico, which can generate a table counting
376     the backlinks for each page, or a del.icio.us style cloud.
377   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
378     the wikiformat plugin works. Thanks, Emanuele Aina.
379   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
380     display, running them through pagetitle. This removes ugly underscores and
381     other gunk from the display, much nicer. You may want to rebuild your wiki
382     when upgrading to get the cleanup globally.
383   * Polygen plugin from Enrico.
384   * htmltidy plugin from Faidon.
385   * Locale patch from Faidon:
386     - Adds a locale setting to setup files.
387     - Proper local time, if the locale configuration option is used.
388     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
389       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
390       impossible.
391   * Add getopt hook type, this allows plugins to add new command-line options.
392   * Add --tagbase option to tag plugin.
393   * Add exclude option in setup files, works same as --exclude.
394   * Put categories in rss feeds for tagged items.
395   * Allow preprocessor directives to be expanded in inlined blog pages.
396     However, to avoid inlining loops etc, don't expand inline directives in
397     inlined pages.
398   * fortune plugin (trivial)
399   * Tag plugins according to type.
400
401  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
402
403 ikiwiki (1.11) unstable; urgency=low
404
405   * Patch from Enrico that
406     - Adds a tag plugin that allows more easily tagging pages.
407       The meta plugin can also still be used for that, but the tag plugin
408       also lists a page's tags at the bottom of the page.
409     - Allows preprocessor directives to have parameters with no specified
410       value.
411     - Fixes preprocessor directive parameter parsing so that
412       foo=bar baz now means "foo=bar" and a "baz" with no value.
413   * Run pagetemplate hooks when inlining pages so that inlined pages also
414     list their tags.
415   * Make all plugins with pagetemplate hooks check that variables exist
416     on the template before setting them, for robustness.
417   * Switch pagetemplate hooks to using named parameters.
418   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
419     This will be the page that a source page will be part of, which is
420     different than the source page for inlined pages.
421   * Audited all plugins to endure they pass (page, destpage) to htmllink
422     appropriatly. This means inlining of various plugins will not work
423     properly, with correct links generated.
424
425  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
426
427 ikiwiki (1.10) unstable; urgency=low
428
429   * Run page through any relevant filters when generating a page preview.
430   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
431     default throughout the wiki, not only on wikitext pages. Decided to call
432     this a feature, and split the camelcase support out into a separate plugin
433     that is independant of wikitext.
434   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
435
436  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
437
438 ikiwiki (1.9) unstable; urgency=low
439
440   * Improve display of parentlinks and page title of toplevel index page.
441   * Patch from Faidon to use svn --limit when possible for recentchanges,
442     speeds up recentchanges a lot for wikis with more history.
443   * Patch from Recai to fix utf8 issues in git backend.
444   * Add wikitext markup plugin, which supports ".wiki" pages written in the
445     original wiki syntax, CamelCase links and all.
446   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
447     support, to edit pages etc without a web server.
448   * Display CGI processing errors if present.
449   * Fix from Faidon for a XML parser issue that breaks utf-8 for
450     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
451     area, and also way slow.
452   * Match 'web commit from' in SVN and git, these are web commits too.
453     (Faidon)
454   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
455     readable and avoid future mistakes. The patch seems to work and for the
456     first time I have a UTF-8 username ;-) (Faidon)
457   * Use form->field consistently, not form->param.
458   * Patch from Recai to allow selection of page type when creating a new page.
459     Default page type is inherited from the link clicked on to create the new
460     page.
461
462  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
463
464 ikiwiki (1.8) unstable; urgency=low
465
466   * Fix orphans plugin to not count a link to a nonexistant page as a reason
467     for a page not being an orphan.
468   * Support pinging services such as Technorati using XML-RPC to notify them
469     about changes to rss feeds.
470   * Parse svn log as xml for improved utf8 and security. Note that this makes
471     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
472   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
473     flagged string even if the locale causes it to generate utf8 output,
474     so make sure to let perl know it should be handled as utf8. Also,
475     the optimised version used for standard time formats won't work if the
476     user has changed locale, so drop it. Thanks, Faidon Liambotis.
477   * Fix re-encoding of the comments field to utf8 if a commit fails
478     due to a conflict. Thanks, Faidon Liambotis.
479   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
480     Liambotis.
481   * Add insane double encode/decode to utf8 around call to markdown.
482     This works around a truely strange bug, which is apparently a bug in
483     perl, #376329. Also added a test case for it.
484   * Improve layout of edit page so formatting help link is always visible w/o
485     getting in the way of the preview.
486   * Centralised all calls to HTML::Template and force all the templates
487     to be read as utf8.
488   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
489   * Introduce add_plugins and disable_plugins config options in setup files.
490     This allows adding or removing plugins w/o overriding the whole list of
491     default plugins, which makes it easier to upgrade when new default plugins
492     are added.
493   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
494     default (of course!). Based on a patch by Faidon Liambotis.
495   * Add a html plugin, which can be used to write wikis in raw html,
496     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
497     defaults to not processing .html files, since w/o this plugin they would
498     be copied unsanitised. With this plugin, it will process and html
499     sanitise them, like any other page type.
500   * Rebuilding wrappers is necessary on upgrade to this version.
501   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
502     will be automatically done on all upgrades.
503   * Don't send pings if the wiki is being rebuilt.
504   * Work around very innefficient behavior in File::Spec::abs2rel. Result
505     is a savings of 2 pointless fork/execs per link calculation, which
506     results in ~25% speedup of ikiwiki building its own doc wiki, and
507     about 35% speedup displaying RecentChanges!
508   * Make RecentChanges use a table and some CSS, should be much more readable.
509     No code changes involved.
510   * Encode & in diffurl in examples, to conform to pedantic rules.
511   * Speed up RecentChanges by another 40% or so with some memoization.
512   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
513     in time to build the doc wiki.
514
515  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
516
517 ikiwiki (1.7) unstable; urgency=low
518
519   * Updated logo from Recai with some kerning and alingment tuning.
520   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
521     changed some output.
522   * Copyright update.
523
524  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
525
526 ikiwiki (1.6) unstable; urgency=low
527
528   * YA utf-8 patch from Recai, this time to fix previewing a page so that
529     the text in the input box is re-encoded back to utf-8.
530   * -CSD does not affect modules, so readfile() was not using the utf-8 input
531     layer, which led to lots of problems; make it force read files as utf-8.
532     Closes: #373203
533   * Note that as a consequence, this version of ikiwiki will actually try to
534     parse utf8 in source files for the first time, which may expose broken
535     utf8 in wiki sources that was hidden before. Most common will be
536     perl warnings like "utf8 "\xE9" does not map to Unicode"
537   * writefile() likewise needs to use the utf8 output layer.
538   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
539     there.
540   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
541     given the readfile fix.
542   * Add utf-8 testcases for readfile and htmlize.
543   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
544     safe.
545   * More utf-8 fixes from Recai, partly to things I broke above:
546     - The serious problem is that writefile() saves the content in undecoded
547       format in CGI, hence all (non-ascii) chars are corrupted permanently.
548     - Comment field in edit page is not decoded and all the non-ascii chars in
549       this field are corrupted as the result.  We should decode it as we do it
550       for the content.
551     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
552       character in print.
553   * New SVG logo from Recai.
554
555  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
556
557 ikiwiki (1.5) unstable; urgency=low
558
559   * Add --timeformat config option to allow changing how dates are displayed.
560     Note that as a side effect, dates will now be displayed using the local
561     timezone, not as GMT.
562   * More security review.
563   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
564     for some handy stuff like:
565     - Using links as a kind of tag; creating blog pages that list all pages
566       containing a given tag/link or not containing some other tag.
567     - Subscribing to mail notifications whenever a change is made to a page
568       that is a backlink of page foo. Ie, "Please notify me of changes in all
569       pages that link to my home page in the wiki"
570     - Locking any pages that are linked to from a particular page, so that
571       lists of locks can be exposed in the wiki.
572   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
573     when a todo item is done, instead of the previous moving it to a different
574     subdir.
575   * Allow pagetemplate plugins to override *anything* in the template.
576   * Add a meta plugin, which allows specifying various metadata about pages,
577     like license and author. It also allows for inserting html link and meta
578     tags into html, overriding the title, and adding hidden WikiLinks, which
579     can be useful when using link-based globbing for page categorisation.
580   * Remove preprocessor directives from inlined pages.
581   * Allow simple preprocessor directive values to be specified w/o quotes.
582   * Add support for using git instead of subversion as the RCS backend,
583     tremendous thanks to Recai Oktaş for this.
584   * Doc updates for git.
585   * Fix absolute url munging in rss generation to support https, ftp, etc urls
586     not just http urls.
587   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
588     utf-8 for edit and other fields, and for recentchanges. There may still
589     be utf-8 issues with the preferences page though.
590
591  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
592
593 ikiwiki (1.4) unstable; urgency=low
594
595   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
596     very strange way of enabling proper XHTML <br /> type tags. Output html
597     should be always valid again now.
598   * The page name and parent links has switched from using a <h1> to a styled
599     <span>, so pages can use <h1> internally instead of needing to use <h2>.
600   * Updated all of ikiwiki's own wiki pages for that.
601   * Add pagetemplate hook, which can be used by plugins that want to mess
602     around with adding new stuff to the page template.
603   * Remove headercontent; the search plugin now adds the search box to the
604     header by registering a pagetemplate hook, and other plugins should do
605     similarly.
606   * Rebuilding on upgrade to this version is recommended.
607   * Add a html validity check to the test suite, using the wdg-html-validator,
608     if available.
609   * Make the html valid when there is nothing in the actions list.
610   * Reordered some function call parameters for consistency.
611   * Enable full utf-8 support for page input and output.
612   * Add a workaround for markdown, which does not work well with utf-8
613     strings.
614   * --getctime had bitrotted (well I only ever used it the once so far..),
615     fix and make it a bit more flexible
616   * rcs_getctime is changed, now rather than needing to loop over all pages,
617     it should just use the rcs to get the ctime of the passed file.
618   * When inlining a page in another one, links from the inlined page are now
619     expanded the same as they are when rendering the inlined page as a
620     standalone page. So rather than being expanded from the POV of the
621     inlining page, they are expanded from the POV of the inlined page.
622
623     For example, a link from blog/foo to "bar" will now link to blog/bar
624     if it exists. Previously this needed to be a link explicitly to
625     "blog/bar"; such links will also continue to work.
626
627     (This was slightly complex to do as the link still has to be constructed
628     relative to the inlining page.)
629   * Make page edit textarea resize to fit browser window.
630   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
631     do not need a full rebuild, in order to update any basewiki pages.
632
633  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
634
635 ikiwiki (1.3) unstable; urgency=low
636
637   * Fix the preinst introduced in the last version. Closes: #367458
638
639  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
640
641 ikiwiki (1.2) unstable; urgency=low
642
643   * Remove dups from the brokenlinks list.
644   * Add libc6-dev to dependencies, needed to build wrappers.
645   * Install wikilist in correct location. Closes: #367371
646
647  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
648
649 ikiwiki (1.1) unstable; urgency=low
650
651   * Rename inlinepage to depends, so that it can be used to refer to more
652     dependency relationships than just inlining. This will require a rebuild
653     on upgrade to this version.
654   * Move the rss link, put it in the blogpost form if there is one and at the
655     top if not. This is both nicer because easier to find, and it cleans up
656     the code which had used inlinepage as a flag for adding the link later.
657   * Allow the depends GlobList to be built up from multiple sources (such as
658     plugins) during a page render.
659   * Which means that more than one blog is now supported to appear on a
660     single page. (With some limitations, like only the last one getting an
661     rss file.)
662   * Added a plugin system.
663   * Added a pagecount plugin, enabled by default.
664   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
665   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
666     backlinks when the backlinks hadn't really changed.
667   * Moved inline page support, rss generation etc into the inline plugin,
668     enabled by default.
669   * Added brokenlinks plugin, not enabled by default, but rather handy.
670   * Fix several broken links in the doc wiki.
671   * Smarter behavior when creating a page and a page of the same name (but
672     different location) already exists.
673   * Add an orphans plugin for finding pages that nothing links to.
674   * Removed backlinks page, which it turns out nothing used.
675   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
676     it, this will allow for adding a unit test suite.
677   * Add unit tests for several core functions, including globlist_match,
678     dirname, basename, bestlink, linkify, pagetitle, titlepage.
679   * Smart globlist merging.
680   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
681     to pave the way for adding other RCS support. This also changes the
682     setup files, where before they had svn => 1 or svn => 0, now they have
683     rcs => "svn" or rcs => "".
684   * Add a debian/NEWS file with upgrade notes.
685   * Load whatever rcs module is specified, so new ones can be just dropped in
686     as plugins and work. (Well, in theory.)
687   * Add some basic docs about writing RCS modules.
688   * Broke search capability out into a plugin, removed the --hyperestraier
689     switch.
690   * Added smiley plugin, nicely controlled and documented by the smileys page.
691   * Copied in some smileys from Moin Moin.
692   * Allow links of the form [[some page|page]], with whitespace in the link
693     text.
694   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
695     and --disable-plugin htmlscrubber.
696   * Allow discussion links on pages to be turned off with --no-discussion.
697   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
698   * Add some new config items to the estseek.conf template, which are needed
699     by hyperestraier 1.2.3.
700
701  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
702
703 ikiwiki (1.0) unstable; urgency=low
704
705   * First official release.
706
707  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400