* Mercurial backend improvements, including --get-ctime support.
[ikiwiki] / debian / changelog
1 ikiwiki (1.34) UNRELEASED; urgency=low
2
3   * Add an openid plugin to support logging in using OpenID.
4   * Web commits by OpenID users will record the full OpenID url for the user,
5     but in recentchanges, these urls will be converted to a simplified display
6     form+link.
7   * Modified svn, git, tla backends to recognise such web commits.
8   * Move httpauth support to a plugin.
9   * Add openidsignup config option.
10   * Make the openid plugin support the callbacks from myopenid.com via its
11     affiliate program.
12   * Add toggle plugin.
13   * Introduce the goodstuff bundle. This is a kind of plugin, that just enables
14     many other plugins. It's an easy way to boost ikiwiki from its default,
15     basic wiki, to a full-featured wiki, without manually picking the right
16     set of plugins. New plugins will be added to goodstuff from time to
17     time.
18   * Change how post signin actions are propigated through the signin process;
19     they're now stored in the session.
20   * Add optional "desc" parameter to shortcut definitions.
21   * Avoid locking the wiki at all when handling some basic cgi stuff
22     (searches, recentchanges).
23   * Add "last" parameter to hook function. Very basic ordering, and hopefully
24     nothing more spohisticated will be needed.
25   * Add formbuilder_setup and formbuilder hooks.
26   * Split out a passwordauth module, that holds all the traditional password
27     based authentication etc code. It's enabled by default, but can be disabled
28     if you want only openid or some other auth method.
29   * Rename ikiwiki.pl so MakeMaker doesn't see it, and install it.
30   * Add some code to the build system that tries to determine if the
31     lib installation directory is in @INC. If it's not, munge ikiwiki
32     to hardcode the path to the lib directory. This should allow installing
33     ikiwiki in nonstandard locations, including home directories, by just
34     setting PREFIX at build time.
35   * Fix nested examples directory in deb.
36   * Add a test suite for the mercurial backend, contributed by Emanuele Aina.
37   * Add a test suite for the svn backend.
38   * Daemonize before sending RPC pings, since that can take a while
39     and/or hang.
40   * Daemonize before sending commit mails, as that can also take a long
41     time/hang if the mail server is unhappy.
42   * Factor out commit mail sending code into new function.
43   * Change rcs_commit, it is now passed the name of the user doing the commit
44     and their IP address, and needs to construct its own commit message
45     containing them, or do something more appropriate for the given RCS.
46   * Add softwaresite example.
47   * Add a poll plugin.
48   * Add quick mode for archive page generation.
49   * Mercurial backend improvements, including --get-ctime support.
50
51  -- Joey Hess <joeyh@debian.org>  Sun, 26 Nov 2006 15:01:14 -0500
52
53 ikiwiki (1.33) unstable; urgency=low
54
55   * Fix issue with aggregate plugin updating expired pages.
56   * Avoid syntax errors in templates used by the template plugin crashing
57     ikiwiki.
58   * Enable utf8 file IO in aggregate plugin.
59   * Fix some issues with the new registration form.
60   * Patch from Ethan Glasser Camp to add a skip option to the inline plugin.
61   * Make sure to check for errors from every eval.
62   * Fix img plugin's handling of adding dependencies for images that do not
63     yet exist.
64   * Work around a strange bug in CGI::FormBuilder 3.0401 that makes
65     FORM-SUBMIT unusable on customised formbuilder templates. For now,
66     hardcode the submit buttons in editpage.tmpl instead of using the
67     template variable, which is ok, since the buttons are static.
68   * Work with hyperestraier 1.4.9.
69
70  -- Joey Hess <joeyh@debian.org>  Wed, 15 Nov 2006 18:32:26 -0500
71
72 ikiwiki (1.32) unstable; urgency=low
73
74   * Add a separate pass to find page links, and only render each page once,
75     instead of over and over. Typical speedup is ~4x. Max possible speedup:
76     8x.
77   * Add "scan" parameter to hook(), which is used to make the hook be called
78     during the scanning pass, as well as the render pass. The meta and tag
79     plugins need to use the new scan parameter, so will any others that modify
80     %links.
81   * Now that links are calculated in a separate pass, it can also
82     precalculate backlinks in one pass, which is O(N^2) instead of the
83     previous code that was O(N^3). A very nice speedup for wikis with lots
84     (thousands) of pages.
85   * Stylish update to the ikiwiki logo, thanks to Recai Oktaş and Selçuk
86     Erdem.
87   * Add a default stylesheet entry for the pagecloud.
88   * Add examples page with some examples of things that can be done using
89     ikiwiki, like a weblog. The examples can be copied into a user's wiki
90     for a quick start, without needing to learn everything about how to put
91     them together.
92   * Install the source of the examples into /usr/share/doc/ikiwiki/examples.
93   * Add perlmagick to build-depends so syntax check of img plugin works.
94     Closes: #396702
95   * Improve login/register process, the login dialog has only name and
96     password fields, which allows more web browsers to regognise it as a login
97     field, and is less confusing.
98   * Implemented expiry options for aggregate plugin.
99   * Use precalculated backlinks info when determining if files need an update
100     due to a page they link to being added/removed. Mostly significant if
101     there are lots of pages.
102   * Remove duplicate link info when saving index. In some cases it could
103     pile up rather badly. (Probably not the best way to deal with this
104     problem.)
105   * Patch from James Westby to support podcasting, photoblogging, vidcasting,
106     or what have you, by creating enclosures for non-page items that are
107     included in feeds.
108
109  -- Joey Hess <joeyh@debian.org>  Fri,  3 Nov 2006 14:46:37 -0500
110
111 ikiwiki (1.31) unstable; urgency=low
112
113   * Patch from Pawel Tecza to cp -a the templates in the Makefile.
114   * Change the rss feed title from the wikiname to the page title, with
115     an exception for the wiki's toplevel index page, which will still use the
116     wikiname as the feed title.
117     Overriding the page title with meta title already overrode the rss feed
118     tittle.
119   * Add an img plugin, based on Christian Mock's img plugin, but stripped
120     down to the bare essentials. Useful for handling large images on websites.
121   * Sanitize possibly problimatic characters out of the polygen grammar names,
122     just in case. Should not be exploitable anyway, since it only tries to run
123     polygen after finding the specified grammar file.
124   * Add missing dependency on the URI perl module.
125   * Add basic spam fighting tool for admins: An admin's prefs page now allows
126     editing a list of banned users.
127
128  -- Joey Hess <joeyh@debian.org>  Fri, 27 Oct 2006 23:16:33 -0400
129
130 ikiwiki (1.30) unstable; urgency=low
131
132   * Add no_override parameter to hook().
133   * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
134     plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
135     can be configured using a page in wiki.
136   * Fix support for --pingurl at the command line.
137   * Fix a subtle bug in will_render that broke some builds, by only clearing
138     items from renderedfiles the first time per build.
139   * Wrap entire technortati ping operation in an eval to catch all possible
140     failure modes, after I observed a simple ->value crashing ikiwiki when
141     a ping failed.
142
143  -- Joey Hess <joeyh@debian.org>  Mon, 16 Oct 2006 15:17:38 -0400
144
145 ikiwiki (1.29) unstable; urgency=low
146
147   * Patch from Paul Tötterman to use CP in the Makefile.
148   * Patch from Alec Berryman adding a http_auth config item that allows
149     using HTTP Authentication instead of ikiwiki's built in authentication.
150     Useful for eg, large sites with their own previously existing user auth
151     setup. Closes: #384534
152   * Change %renderedfiles to store an array of files rendered from a given
153     source file, to allow tracking of extra rendered files like rss feeds.
154   * Note that plugins that accessed this variable will need to be updated!
155     The plugin interface has been increased to version 1.01 for this change.
156     As few plugins use %renderedfiles I haven't done anything else to ensure
157     compatability of old plugins.
158   * Add will_render function to the plugin interface, used to register that a
159     page renders a destination file, and do some security checks. Previously
160     but no longer rendered files will be cleaned up.
161   * Use will_render in the inline and linkmap plugins.
162   * You will need to rebuild your wiki on upgrade to this version.
163   * Atom feed support based on a patch by Clint Adams.
164   * Add feeds=no option to inline preprocessor directive to turn off all types
165     of feeds.
166   * $IkiWiki::version now holds the program version, and is accessible to
167     plugins.
168   * Make the aggregate plugin emphasize error messages.
169   * Patch from Recai to limit recentchanges to displaying max 10 files for a
170     given changeset (to avoid large number of file changes excessively
171     bloating the page).
172
173  -- Joey Hess <joeyh@debian.org>  Fri, 13 Oct 2006 23:14:28 -0400
174
175 ikiwiki (1.28) unstable; urgency=low
176
177   * inline: Add ability to sort by page name, based on a patch from
178     Benjamin A'Lee.
179   * Fix a forkbomb in various calls to IPC::Open2, which has a highly
180     braindead interface. Closes: #389383
181   * Don't rm -rf ikiwiki on distclean, since a) there's no such file
182     and b) those poor Mac OSX users and their case insensative files!
183   * Don't fail syntax check if Text::Typography isn't installed.
184     Closes: #389406
185
186  -- Joey Hess <joeyh@debian.org>  Tue, 26 Sep 2006 02:08:17 -0400
187
188 ikiwiki (1.27) unstable; urgency=low
189
190   * Work on firming up the plugin interface:
191     - Plugins should not need to load IkiWiki::Render to get commonly
192       used functions, so moved some functions from there to IkiWiki.
193     - Picked out the set of functions and variables that most plugins
194       use, documented them, and made IkiWiki export them by default,
195       like a proper perl module should.
196     - Use the other functions at your own risk.
197     - This is not quite complete, I still have to decide whether to
198       export some other things.
199   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
200     referring to stuff now exported by the IkiWiki module.
201   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
202     to declare which version of the interface your plugin needs.
203   * Anyone with a third-party ikiwiki plugin is strongly encouraged
204     to make like changes to it and avoid use of non-exported symbols from
205     "IkiWiki::".
206   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
207   * Support hyperestradier version 1.4.2, which adds a new required phraseform
208     setting.
209   * If an inlined page has a permalink, link the page title to that.
210   * Patch from Recai to use utf8 when reading the setup file, so that
211     utf8 wikinames from there will be used properly.
212   * Patch from Recai to kill utf-8 on the wiki name when generating the
213     session cookie.
214   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
215   * Fix a baseurl problem in hyperestradier search results.
216   * Add a stub local.css to avoid problems with 404's.
217   * Patch from Recai to fix a wide character warning from the search plugin
218     during setup if the wikiname contains utf8.
219   * Yet another fix for those poor case-insensative OS X users.
220   * pagetemplate hooks are now also called when generating cgi pages.
221   * Add a favicon plugin, which simply adds a link tag for an icon to each
222     page (and cgis).
223   * Patch from James Westby to deal with the case where you're editing a
224     new page, hit cancel, and need to be redirected to somewhere sane.
225   * Various documentation improvements by various wiki users.
226   * Support Text::Markdown from CPAN, which has a different interface from
227     the original markdown or the one in Debian.
228   * Version the libcgi-session-perl dependency, some features that need
229     the new version are used in some cases (sslcookie).
230   * Numerous tla fixes from Clint.
231   * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
232     a multi-resolution favicon.ico.
233   * README.Debian: typo Closes: #388110
234   * chomp trailing newline at the end of templates read in by the template
235     plugin, to allow use of the template preprocessor directive in
236     whitespace-sensative situations. Closes: #387073
237   * Patch from James Westby to make the location of the estseek.cgi script
238     configurable.
239   * Add typography (SmartyPants) plugin by Recai.
240   * Add --render mode, which can be used to preview an edit at the command
241     line by test rendering a single page.
242   * Add a googlecalendar plugin. A bit special-purpose, but it shows
243     one way to to deal with user-supplied content that could cause XSS
244     issues w/o the htmlscrubber, and won't survive the scrubber.
245
246  -- Joey Hess <joeyh@debian.org>  Sun, 24 Sep 2006 00:02:21 -0400
247
248 ikiwiki (1.26) unstable; urgency=low
249
250   * Add a missing -n to tla undo call.
251   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
252     writes before consuming its whole stdin. Avoid this deadlock.
253   * Fix alt tags for outline checkboxes.
254
255  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
256
257 ikiwiki (1.25) unstable; urgency=low
258
259   * Add proper waitpid calls for open2ed processes throughout to avoid
260     zombies; this hit htmltidy especially badly.
261   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
262     subversion repos and fixing some other issues.
263   * Add support for tla, contributed by Clint Adams. Closes: #385936
264   * Add support for mercurial, contributed by Emanuele Aina.
265   * Include <link rel> tag for RSS feeds, used by some aggregators and
266     firefox to find the feed.
267   * Add a linkmap plugin (requires graphviz).
268
269  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
270
271 ikiwiki (1.24) unstable; urgency=low
272
273   * Simplify the data structure returned by rcs_recentchanges to avoid
274     each rcs plugin needing to form complex strings on its own.
275   * Fix another destpage issue in the inline directive. Closes: #385512
276     again.
277
278  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
279
280 ikiwiki (1.23) unstable; urgency=low
281
282   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
283
284  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
285
286 ikiwiki (1.22) unstable; urgency=low
287
288   * Change how the stylesheet url is determined in the templates: Remove
289     STYLEURL and add BASEURL to all templates (some already had it). This
290     new more general variable can be used to link to other things (eg, images)
291     from the template, as well as stylesheets.
292   * Fix a bug introduced last version to do with nested inlines.
293   * Allow preprocessor directives to span multiple lines, both to make
294     long ones with lots of values easier to write, and to allow for ones with
295     multi-line quoted values.
296   * Allow preprocessor directives to contain python-like triple-quoted
297     text blocks, for easy nesting of quotes inside.
298   * Add a template plugin.
299   * Make pagespec merge code smarter about merging duplicate pagespecs.
300   * Patch from Jordà Polo to make Setup::Standard support hashes in config
301     files.
302   * Change order of linkify and preprocess; first preprocess and then linkify.
303     This allows passing a wikilink inside a parameter to a preprocessor
304     directive without it being expanded to html, and leaking out of the
305     parameter, which had required some non-obvious use of triple-quoting
306     to avoid. Note that any preprocessor plugins that output something
307     that looks like a wikilink will now have it treated as such; AFAIK
308     this doesn't change any behavior though except for the template plugin.
309   * Enable preprocessor directives when previewing an edit.
310   * Make all pages pull in a local.css style sheet, if present. This won't
311     be included in ikiwiki, but can be created to make local styling changes
312     w/o needing to merge in every new change to the distributed style.css.
313   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
314   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
315     from a different directory.
316   * Generalised preprocesser loop protection code.
317   * Patch from James Westby to allow a description to be set for rss feeds.
318   * Patch from James Westby to add a template for the search form.
319   * Added a ddate plugin.
320   * Patch from James Westby to add a --sslcookie switch, which forces
321     cookies to only be sent over ssl connections to avoid interception.
322   * Fix preferences page on anonok wikis; still need to sign in to get
323     to the preferences page.
324   * Add toc (table of contents) plugin.
325   * Change htmlize, format, and sanitize hooks to use named parameters.
326   * Patch from James Westby to add an actions option to inline; this
327     adds Edit and Discussion links at the end of blog entries.
328   * Due to some css changes, you'll want to rebuild your wiki on upgrade
329     to this version. Will be handled automatically by the deb.
330   * Add processed date to aggregate preprocessor directive status output.
331
332  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
333
334 ikiwiki (1.21) unstable; urgency=low
335
336   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
337   * If a page links to itself, mark up the link text in a span with
338     class="selflink" so that it can be styled. I don't have a useful style
339     defined for that though.
340   * Call filter hooks on inlined page content.
341   * Support inlining pages raw, rather than creating a blog.
342   * Clean up yes/no parameter parsing in inline plugin.
343   * Implemented better cycle detection in the inline plugin; nested inlines
344     will now work.
345   * Add a map plugin contributed by Alessandro Dotti Contra.
346   * Add otl format plugin, which handles files as created by vimoutliner.
347   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
348   * Add first draft at a Restructured Text (rst) plugin, by Sergio
349     Talens-Oliag. Note that this has many known issues -- see the caveats on
350     the plugin's page.
351   * Credit everyone who wrote a plugin on the plugins' wiki pages.
352   * Fix utf-8 in blog post form.
353
354  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
355
356 ikiwiki (1.20) unstable; urgency=low
357
358   * Relicense the templates and basewiki under the 2-clause BSD license.
359     Since these can easily become part of other people's websites, they
360     should be under as permissive a license as possible.
361   * Add --syslog config option, to log to the syslog.
362   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
363     transient failure to fork (which I've seen happen in the wild).
364   * Fix a bug in the aggregator introduced last version that caused all
365     aggregator state to be lost during a non-aggregating build.
366
367  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
368
369 ikiwiki (1.19) unstable; urgency=low
370
371   * Fix several related bugs in page type determination during online editing.
372   * Add some locking to prevent 2 aggregators from running at once.
373   * Fix an infinite loop in the aggregator when finding a unique filename.
374
375  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
376
377 ikiwiki (1.18) unstable; urgency=low
378
379   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
380   * Add --version.
381   * Man page format fixups.
382   * If the meta plugin overides the page title, set a title_overridden
383     variable in the template to true. This allows doing things with the
384     templates conditional on the title being overriden.
385   * Add a %pagecase which maps lower-case page names to the actual case
386     used in the filename. Use this in bestlinks calculation instead of
387     forcing the link to lowercase.
388   * Also use %pagecase in various other places that want to check if a page
389     with a given name exists.
390   * This means that links to pages with mixed case names will now work,
391     even if the link is in some other case mixture, and mixed case pages
392     should be fully supported throughout ikiwiki.
393   * Recommend rebuilding wikis on upgrade to this version.
394
395  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
396
397 ikiwiki (1.17) unstable; urgency=low
398
399   * Disable tidy generator tag.
400   * Move tidy back to sanitize hook, found out how to only show body.
401   * Turn off tidy indentation too.
402   * Turn on HTML::Template loop_context_vars; not actually used in stock
403     templates but can be useful for things like making comma-delimited lists
404     of tags or what have you.
405   * Remove <br> from end of aggregate preprocessor directive output.
406   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
407     case-sensative filesystems like OSX.
408   * Improve markdown loading. First, try to load it as a proper perl module,
409     in case it was installed as one. Then fall back to trying
410     /usr/bin/markdown.
411   * Document in install page how to install markdown, since it has no
412     installation procedure in the upstream tarball.
413   * Set die_on_bad_params => 0 for all templates, to allow users to modify
414     them without annoyances.
415   * Suck in the page content when generating an inline archive page, to work
416     around the meta plugin's lack of caching of title metadata across runs.
417
418  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
419
420 ikiwiki (1.16) unstable; urgency=low
421
422   * Try to handle relative links in aggregated feeds. However,
423     the current support is a crude hack due to limitations of XML::Feed:
424     xml:base is not supported, neither is Content-Location. And of course,
425     relative links in RSS feeds are ill-undefined..
426   * Make aggregator save permalinks and author name to pages as metadata.
427   * Add permalink and author support to meta plugin, affecting RSS feeds
428     and blog pages.
429   * Various CSS and formatting changes.
430   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
431   * Add xhtml files to the default prune regexp.
432   * Also generate rel=bookmark links for permalinks.
433   * Fix the htmltidy plugin, which wasn't working due my breaking it when
434     I added it..
435   * Don't run tidy with -xml as that fails if the input is not well-formed.
436     Run it with -asxhtml instead, so it will output well-formed xhtml no
437     matter what the input.
438   * Disable tidy warnings too.
439   * Add a new format hook, and make tidy use it, since tidy can really only
440     operate on and output complete html documents, not the body chunks
441     that sanitise gets.
442   * Fix dates in rss feeds if running localised, so they're still rfc 822.
443
444  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
445
446 ikiwiki (1.15) unstable; urgency=low
447
448   * Remove CDPATH and other env vars perl taint checking doesn't like.
449     Closes: #381279
450   * Added created_before and created_after PageSpec limits.
451
452  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
453
454 ikiwiki (1.14) unstable; urgency=low
455
456   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
457     by 10% or so.
458   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
459   * Added many unit tests for pagespec_match.
460
461  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
462
463 ikiwiki (1.13) unstable; urgency=low
464
465   * ikiwiki can now download and aggregate feeds with its new aggregate
466     plugin, so it's possible to implement a Planet using ikiwiki!
467   * Add a run_hooks function for the common task of running all hooks of a
468     given type.
469   * Add a savestate hook.
470   * Don't put blog post forms on pages if there's no cgiurl set.
471   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
472     --wrappers to do that.
473   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
474     to update pages that haven't changed on disk.
475   * Change meta tags to use html entity-escaped text for values, so that
476     quotes and such can be represented in title tags.
477   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
478     for the above.
479   * Make --rebuild also cause --aggregate to re-download and write aggregated
480     pages.
481   * Avoid outputting duplicate meta info.
482   * Include title metadata on aggregated posts for capitalised and un-munged
483     titles.
484   * Title metadata of inlined pages now shows up in blogs and rss feeds.
485   * Fix issue with unicode filenames and updating the hyper estradier search
486     index. (Aka Please Please Please, let that be the last one.)
487   * Patch from Roland Mas to support an rss=no parameter to inline directives.
488     Closes: #380743
489   * Renamed GlobLists to PageSpecs.
490   * PageSpecs can now include nested parens, "and", and "or". This remains
491     backwards compatible to the old GlobList format. It's implemented by
492     treating the GlobList as a very limited microlanguage that is transformed
493     to perl code that does the matching.
494   * The old GlobList format is deprecated, and I encourage users to switch to
495     using the new PageSpec format. Compatability with the old format will be
496     removed at some point, possibly by 2.0.
497   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
498   * Add support for creation_month and creation_year to PageSpec.
499     Closes: #380680
500   * Changes to index file encoding.
501
502  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
503
504 ikiwiki (1.12) unstable; urgency=low
505
506   "Viva l'Italia!"
507   * New pagestats plugin from Enrico, which can generate a table counting
508     the backlinks for each page, or a del.icio.us style cloud.
509   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
510     the wikiformat plugin works. Thanks, Emanuele Aina.
511   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
512     display, running them through pagetitle. This removes ugly underscores and
513     other gunk from the display, much nicer. You may want to rebuild your wiki
514     when upgrading to get the cleanup globally.
515   * Polygen plugin from Enrico.
516   * htmltidy plugin from Faidon.
517   * Locale patch from Faidon:
518     - Adds a locale setting to setup files.
519     - Proper local time, if the locale configuration option is used.
520     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
521       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
522       impossible.
523   * Add getopt hook type, this allows plugins to add new command-line options.
524   * Add --tagbase option to tag plugin.
525   * Add exclude option in setup files, works same as --exclude.
526   * Put categories in rss feeds for tagged items.
527   * Allow preprocessor directives to be expanded in inlined blog pages.
528     However, to avoid inlining loops etc, don't expand inline directives in
529     inlined pages.
530   * fortune plugin (trivial)
531   * Tag plugins according to type.
532
533  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
534
535 ikiwiki (1.11) unstable; urgency=low
536
537   * Patch from Enrico that
538     - Adds a tag plugin that allows more easily tagging pages.
539       The meta plugin can also still be used for that, but the tag plugin
540       also lists a page's tags at the bottom of the page.
541     - Allows preprocessor directives to have parameters with no specified
542       value.
543     - Fixes preprocessor directive parameter parsing so that
544       foo=bar baz now means "foo=bar" and a "baz" with no value.
545   * Run pagetemplate hooks when inlining pages so that inlined pages also
546     list their tags.
547   * Make all plugins with pagetemplate hooks check that variables exist
548     on the template before setting them, for robustness.
549   * Switch pagetemplate hooks to using named parameters.
550   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
551     This will be the page that a source page will be part of, which is
552     different than the source page for inlined pages.
553   * Audited all plugins to endure they pass (page, destpage) to htmllink
554     appropriatly. This means inlining of various plugins will not work
555     properly, with correct links generated.
556
557  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
558
559 ikiwiki (1.10) unstable; urgency=low
560
561   * Run page through any relevant filters when generating a page preview.
562   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
563     default throughout the wiki, not only on wikitext pages. Decided to call
564     this a feature, and split the camelcase support out into a separate plugin
565     that is independant of wikitext.
566   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
567
568  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
569
570 ikiwiki (1.9) unstable; urgency=low
571
572   * Improve display of parentlinks and page title of toplevel index page.
573   * Patch from Faidon to use svn --limit when possible for recentchanges,
574     speeds up recentchanges a lot for wikis with more history.
575   * Patch from Recai to fix utf8 issues in git backend.
576   * Add wikitext markup plugin, which supports ".wiki" pages written in the
577     original wiki syntax, CamelCase links and all.
578   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
579     support, to edit pages etc without a web server.
580   * Display CGI processing errors if present.
581   * Fix from Faidon for a XML parser issue that breaks utf-8 for
582     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
583     area, and also way slow.
584   * Match 'web commit from' in SVN and git, these are web commits too.
585     (Faidon)
586   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
587     readable and avoid future mistakes. The patch seems to work and for the
588     first time I have a UTF-8 username ;-) (Faidon)
589   * Use form->field consistently, not form->param.
590   * Patch from Recai to allow selection of page type when creating a new page.
591     Default page type is inherited from the link clicked on to create the new
592     page.
593
594  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
595
596 ikiwiki (1.8) unstable; urgency=low
597
598   * Fix orphans plugin to not count a link to a nonexistant page as a reason
599     for a page not being an orphan.
600   * Support pinging services such as Technorati using XML-RPC to notify them
601     about changes to rss feeds.
602   * Parse svn log as xml for improved utf8 and security. Note that this makes
603     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
604   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
605     flagged string even if the locale causes it to generate utf8 output,
606     so make sure to let perl know it should be handled as utf8. Also,
607     the optimised version used for standard time formats won't work if the
608     user has changed locale, so drop it. Thanks, Faidon Liambotis.
609   * Fix re-encoding of the comments field to utf8 if a commit fails
610     due to a conflict. Thanks, Faidon Liambotis.
611   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
612     Liambotis.
613   * Add insane double encode/decode to utf8 around call to markdown.
614     This works around a truely strange bug, which is apparently a bug in
615     perl, #376329. Also added a test case for it.
616   * Improve layout of edit page so formatting help link is always visible w/o
617     getting in the way of the preview.
618   * Centralised all calls to HTML::Template and force all the templates
619     to be read as utf8.
620   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
621   * Introduce add_plugins and disable_plugins config options in setup files.
622     This allows adding or removing plugins w/o overriding the whole list of
623     default plugins, which makes it easier to upgrade when new default plugins
624     are added.
625   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
626     default (of course!). Based on a patch by Faidon Liambotis.
627   * Add a html plugin, which can be used to write wikis in raw html,
628     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
629     defaults to not processing .html files, since w/o this plugin they would
630     be copied unsanitised. With this plugin, it will process and html
631     sanitise them, like any other page type.
632   * Rebuilding wrappers is necessary on upgrade to this version.
633   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
634     will be automatically done on all upgrades.
635   * Don't send pings if the wiki is being rebuilt.
636   * Work around very innefficient behavior in File::Spec::abs2rel. Result
637     is a savings of 2 pointless fork/execs per link calculation, which
638     results in ~25% speedup of ikiwiki building its own doc wiki, and
639     about 35% speedup displaying RecentChanges!
640   * Make RecentChanges use a table and some CSS, should be much more readable.
641     No code changes involved.
642   * Encode & in diffurl in examples, to conform to pedantic rules.
643   * Speed up RecentChanges by another 40% or so with some memoization.
644   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
645     in time to build the doc wiki.
646
647  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
648
649 ikiwiki (1.7) unstable; urgency=low
650
651   * Updated logo from Recai with some kerning and alingment tuning.
652   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
653     changed some output.
654   * Copyright update.
655
656  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
657
658 ikiwiki (1.6) unstable; urgency=low
659
660   * YA utf-8 patch from Recai, this time to fix previewing a page so that
661     the text in the input box is re-encoded back to utf-8.
662   * -CSD does not affect modules, so readfile() was not using the utf-8 input
663     layer, which led to lots of problems; make it force read files as utf-8.
664     Closes: #373203
665   * Note that as a consequence, this version of ikiwiki will actually try to
666     parse utf8 in source files for the first time, which may expose broken
667     utf8 in wiki sources that was hidden before. Most common will be
668     perl warnings like "utf8 "\xE9" does not map to Unicode"
669   * writefile() likewise needs to use the utf8 output layer.
670   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
671     there.
672   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
673     given the readfile fix.
674   * Add utf-8 testcases for readfile and htmlize.
675   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
676     safe.
677   * More utf-8 fixes from Recai, partly to things I broke above:
678     - The serious problem is that writefile() saves the content in undecoded
679       format in CGI, hence all (non-ascii) chars are corrupted permanently.
680     - Comment field in edit page is not decoded and all the non-ascii chars in
681       this field are corrupted as the result.  We should decode it as we do it
682       for the content.
683     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
684       character in print.
685   * New SVG logo from Recai.
686
687  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
688
689 ikiwiki (1.5) unstable; urgency=low
690
691   * Add --timeformat config option to allow changing how dates are displayed.
692     Note that as a side effect, dates will now be displayed using the local
693     timezone, not as GMT.
694   * More security review.
695   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
696     for some handy stuff like:
697     - Using links as a kind of tag; creating blog pages that list all pages
698       containing a given tag/link or not containing some other tag.
699     - Subscribing to mail notifications whenever a change is made to a page
700       that is a backlink of page foo. Ie, "Please notify me of changes in all
701       pages that link to my home page in the wiki"
702     - Locking any pages that are linked to from a particular page, so that
703       lists of locks can be exposed in the wiki.
704   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
705     when a todo item is done, instead of the previous moving it to a different
706     subdir.
707   * Allow pagetemplate plugins to override *anything* in the template.
708   * Add a meta plugin, which allows specifying various metadata about pages,
709     like license and author. It also allows for inserting html link and meta
710     tags into html, overriding the title, and adding hidden WikiLinks, which
711     can be useful when using link-based globbing for page categorisation.
712   * Remove preprocessor directives from inlined pages.
713   * Allow simple preprocessor directive values to be specified w/o quotes.
714   * Add support for using git instead of subversion as the RCS backend,
715     tremendous thanks to Recai Oktaş for this.
716   * Doc updates for git.
717   * Fix absolute url munging in rss generation to support https, ftp, etc urls
718     not just http urls.
719   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
720     utf-8 for edit and other fields, and for recentchanges. There may still
721     be utf-8 issues with the preferences page though.
722
723  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
724
725 ikiwiki (1.4) unstable; urgency=low
726
727   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
728     very strange way of enabling proper XHTML <br /> type tags. Output html
729     should be always valid again now.
730   * The page name and parent links has switched from using a <h1> to a styled
731     <span>, so pages can use <h1> internally instead of needing to use <h2>.
732   * Updated all of ikiwiki's own wiki pages for that.
733   * Add pagetemplate hook, which can be used by plugins that want to mess
734     around with adding new stuff to the page template.
735   * Remove headercontent; the search plugin now adds the search box to the
736     header by registering a pagetemplate hook, and other plugins should do
737     similarly.
738   * Rebuilding on upgrade to this version is recommended.
739   * Add a html validity check to the test suite, using the wdg-html-validator,
740     if available.
741   * Make the html valid when there is nothing in the actions list.
742   * Reordered some function call parameters for consistency.
743   * Enable full utf-8 support for page input and output.
744   * Add a workaround for markdown, which does not work well with utf-8
745     strings.
746   * --getctime had bitrotted (well I only ever used it the once so far..),
747     fix and make it a bit more flexible
748   * rcs_getctime is changed, now rather than needing to loop over all pages,
749     it should just use the rcs to get the ctime of the passed file.
750   * When inlining a page in another one, links from the inlined page are now
751     expanded the same as they are when rendering the inlined page as a
752     standalone page. So rather than being expanded from the POV of the
753     inlining page, they are expanded from the POV of the inlined page.
754
755     For example, a link from blog/foo to "bar" will now link to blog/bar
756     if it exists. Previously this needed to be a link explicitly to
757     "blog/bar"; such links will also continue to work.
758
759     (This was slightly complex to do as the link still has to be constructed
760     relative to the inlining page.)
761   * Make page edit textarea resize to fit browser window.
762   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
763     do not need a full rebuild, in order to update any basewiki pages.
764
765  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
766
767 ikiwiki (1.3) unstable; urgency=low
768
769   * Fix the preinst introduced in the last version. Closes: #367458
770
771  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
772
773 ikiwiki (1.2) unstable; urgency=low
774
775   * Remove dups from the brokenlinks list.
776   * Add libc6-dev to dependencies, needed to build wrappers.
777   * Install wikilist in correct location. Closes: #367371
778
779  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
780
781 ikiwiki (1.1) unstable; urgency=low
782
783   * Rename inlinepage to depends, so that it can be used to refer to more
784     dependency relationships than just inlining. This will require a rebuild
785     on upgrade to this version.
786   * Move the rss link, put it in the blogpost form if there is one and at the
787     top if not. This is both nicer because easier to find, and it cleans up
788     the code which had used inlinepage as a flag for adding the link later.
789   * Allow the depends GlobList to be built up from multiple sources (such as
790     plugins) during a page render.
791   * Which means that more than one blog is now supported to appear on a
792     single page. (With some limitations, like only the last one getting an
793     rss file.)
794   * Added a plugin system.
795   * Added a pagecount plugin, enabled by default.
796   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
797   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
798     backlinks when the backlinks hadn't really changed.
799   * Moved inline page support, rss generation etc into the inline plugin,
800     enabled by default.
801   * Added brokenlinks plugin, not enabled by default, but rather handy.
802   * Fix several broken links in the doc wiki.
803   * Smarter behavior when creating a page and a page of the same name (but
804     different location) already exists.
805   * Add an orphans plugin for finding pages that nothing links to.
806   * Removed backlinks page, which it turns out nothing used.
807   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
808     it, this will allow for adding a unit test suite.
809   * Add unit tests for several core functions, including globlist_match,
810     dirname, basename, bestlink, linkify, pagetitle, titlepage.
811   * Smart globlist merging.
812   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
813     to pave the way for adding other RCS support. This also changes the
814     setup files, where before they had svn => 1 or svn => 0, now they have
815     rcs => "svn" or rcs => "".
816   * Add a debian/NEWS file with upgrade notes.
817   * Load whatever rcs module is specified, so new ones can be just dropped in
818     as plugins and work. (Well, in theory.)
819   * Add some basic docs about writing RCS modules.
820   * Broke search capability out into a plugin, removed the --hyperestraier
821     switch.
822   * Added smiley plugin, nicely controlled and documented by the smileys page.
823   * Copied in some smileys from Moin Moin.
824   * Allow links of the form [[some page|page]], with whitespace in the link
825     text.
826   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
827     and --disable-plugin htmlscrubber.
828   * Allow discussion links on pages to be turned off with --no-discussion.
829   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
830   * Add some new config items to the estseek.conf template, which are needed
831     by hyperestraier 1.2.3.
832
833  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
834
835 ikiwiki (1.0) unstable; urgency=low
836
837   * First official release.
838
839  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400