perl bugnum and refix
[ikiwiki] / debian / changelog
1 ikiwiki (1.8) UNRELEASED; urgency=low
2
3   * Fix orphans plugin to not count a link to a nonexistant page as a reason
4     for a page not being an orphan.
5   * Support pinging services such as Technorati using XML-RPC to notify them
6     about changes to rss feeds.
7   * Parse svn log as xml for improved utf8 and security. Note that this makes
8     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
9   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
10     flagged string even if the locale causes it to generate utf8 output,
11     so make sure to let perl know it should be handled as utf8. Also,
12     the optimised version used for standard time formats won't work if the
13     user has changed locale, so drop it. Thanks, Faidon Liambotis.
14   * Fix re-encoding of the comments field to utf8 if a commit fails
15     due to a conflict. Thanks, Faidon Liambotis.
16   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
17     Liambotis.
18   * Add insane double encode/decode to utf8 around call to markdown.
19     This works around a truely strange bug, which is apparently a bug in
20     perl, #376329. Also added a test case for it.
21   * Improve layout of edit page so formatting help link is always visible w/o
22     getting in the way of the preview.
23
24  -- Joey Hess <joeyh@debian.org>  Sun,  2 Jul 2006 13:43:56 -0400
25
26 ikiwiki (1.7) unstable; urgency=low
27
28   * Updated logo from Recai with some kerning and alingment tuning.
29   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
30     changed some output.
31   * Copyright update.
32
33  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
34
35 ikiwiki (1.6) unstable; urgency=low
36
37   * YA utf-8 patch from Recai, this time to fix previewing a page so that
38     the text in the input box is re-encoded back to utf-8.
39   * -CSD does not affect modules, so readfile() was not using the utf-8 input
40     layer, which led to lots of problems; make it force read files as utf-8.
41     Closes: #373203
42   * Note that as a consequence, this version of ikiwiki will actually try to
43     parse utf8 in source files for the first time, which may expose broken
44     utf8 in wiki sources that was hidden before. Most common will be
45     perl warnings like "utf8 "\xE9" does not map to Unicode"
46   * writefile() likewise needs to use the utf8 output layer.
47   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
48     there.
49   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
50     given the readfile fix.
51   * Add utf-8 testcases for readfile and htmlize.
52   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
53     safe.
54   * More utf-8 fixes from Recai, partly to things I broke above:
55     - The serious problem is that writefile() saves the content in undecoded
56       format in CGI, hence all (non-ascii) chars are corrupted permanently.
57     - Comment field in edit page is not decoded and all the non-ascii chars in
58       this field are corrupted as the result.  We should decode it as we do it
59       for the content.
60     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
61       character in print.
62   * New SVG logo from Recai.
63
64  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
65
66 ikiwiki (1.5) unstable; urgency=low
67
68   * Add --timeformat config option to allow changing how dates are displayed.
69     Note that as a side effect, dates will now be displayed using the local
70     timezone, not as GMT.
71   * More security review.
72   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
73     for some handy stuff like:
74     - Using links as a kind of tag; creating blog pages that list all pages
75       containing a given tag/link or not containing some other tag.
76     - Subscribing to mail notifications whenever a change is made to a page
77       that is a backlink of page foo. Ie, "Please notify me of changes in all
78       pages that link to my home page in the wiki"
79     - Locking any pages that are linked to from a particular page, so that
80       lists of locks can be exposed in the wiki.
81   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
82     when a todo item is done, instead of the previous moving it to a different
83     subdir.
84   * Allow pagetemplate plugins to override *anything* in the template.
85   * Add a meta plugin, which allows specifying various metadata about pages,
86     like license and author. It also allows for inserting html link and meta
87     tags into html, overriding the title, and adding hidden WikiLinks, which
88     can be useful when using link-based globbing for page categorisation.
89   * Remove preprocessor directives from inlined pages.
90   * Allow simple preprocessor directive values to be specified w/o quotes.
91   * Add support for using git instead of subversion as the RCS backend,
92     tremendous thanks to Recai Oktaş for this.
93   * Doc updates for git.
94   * Fix absolute url munging in rss generation to support https, ftp, etc urls
95     not just http urls.
96   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
97     utf-8 for edit and other fields, and for recentchanges. There may still
98     be utf-8 issues with the preferences page though.
99
100  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
101
102 ikiwiki (1.4) unstable; urgency=low
103
104   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
105     very strange way of enabling proper XHTML <br /> type tags. Output html
106     should be always valid again now.
107   * The page name and parent links has switched from using a <h1> to a styled
108     <span>, so pages can use <h1> internally instead of needing to use <h2>.
109   * Updated all of ikiwiki's own wiki pages for that.
110   * Add pagetemplate hook, which can be used by plugins that want to mess
111     around with adding new stuff to the page template.
112   * Remove headercontent; the search plugin now adds the search box to the
113     header by registering a pagetemplate hook, and other plugins should do
114     similarly.
115   * Rebuilding on upgrade to this version is recommended.
116   * Add a html validity check to the test suite, using the wdg-html-validator,
117     if available.
118   * Make the html valid when there is nothing in the actions list.
119   * Reordered some function call parameters for consistency.
120   * Enable full utf-8 support for page input and output.
121   * Add a workaround for markdown, which does not work well with utf-8
122     strings.
123   * --getctime had bitrotted (well I only ever used it the once so far..),
124     fix and make it a bit more flexible
125   * rcs_getctime is changed, now rather than needing to loop over all pages,
126     it should just use the rcs to get the ctime of the passed file.
127   * When inlining a page in another one, links from the inlined page are now
128     expanded the same as they are when rendering the inlined page as a
129     standalone page. So rather than being expanded from the POV of the
130     inlining page, they are expanded from the POV of the inlined page.
131
132     For example, a link from blog/foo to "bar" will now link to blog/bar
133     if it exists. Previously this needed to be a link explicitly to
134     "blog/bar"; such links will also continue to work.
135
136     (This was slightly complex to do as the link still has to be constructed
137     relative to the inlining page.)
138   * Make page edit textarea resize to fit browser window.
139   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
140     do not need a full rebuild, in order to update any basewiki pages.
141
142  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
143
144 ikiwiki (1.3) unstable; urgency=low
145
146   * Fix the preinst introduced in the last version. Closes: #367458
147
148  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
149
150 ikiwiki (1.2) unstable; urgency=low
151
152   * Remove dups from the brokenlinks list.
153   * Add libc6-dev to dependencies, needed to build wrappers.
154   * Install wikilist in correct location. Closes: #367371
155
156  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
157
158 ikiwiki (1.1) unstable; urgency=low
159
160   * Rename inlinepage to depends, so that it can be used to refer to more
161     dependency relationships than just inlining. This will require a rebuild
162     on upgrade to this version.
163   * Move the rss link, put it in the blogpost form if there is one and at the
164     top if not. This is both nicer because easier to find, and it cleans up
165     the code which had used inlinepage as a flag for adding the link later.
166   * Allow the depends GlobList to be built up from multiple sources (such as
167     plugins) during a page render.
168   * Which means that more than one blog is now supported to appear on a
169     single page. (With some limitations, like only the last one getting an
170     rss file.)
171   * Added a plugin system.
172   * Added a pagecount plugin, enabled by default.
173   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
174   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
175     backlinks when the backlinks hadn't really changed.
176   * Moved inline page support, rss generation etc into the inline plugin,
177     enabled by default.
178   * Added brokenlinks plugin, not enabled by default, but rather handy.
179   * Fix several broken links in the doc wiki.
180   * Smarter behavior when creating a page and a page of the same name (but
181     different location) already exists.
182   * Add an orphans plugin for finding pages that nothing links to.
183   * Removed backlinks page, which it turns out nothing used.
184   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
185     it, this will allow for adding a unit test suite.
186   * Add unit tests for several core functions, including globlist_match,
187     dirname, basename, bestlink, linkify, pagetitle, titlepage.
188   * Smart globlist merging.
189   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
190     to pave the way for adding other RCS support. This also changes the
191     setup files, where before they had svn => 1 or svn => 0, now they have
192     rcs => "svn" or rcs => "".
193   * Add a debian/NEWS file with upgrade notes.
194   * Load whatever rcs module is specified, so new ones can be just dropped in
195     as plugins and work. (Well, in theory.)
196   * Add some basic docs about writing RCS modules.
197   * Broke search capability out into a plugin, removed the --hyperestraier
198     switch.
199   * Added smiley plugin, nicely controlled and documented by the smileys page.
200   * Copied in some smileys from Moin Moin.
201   * Allow links of the form [[some page|page]], with whitespace in the link
202     text.
203   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
204     and --disable-plugin htmlscrubber.
205   * Allow discussion links on pages to be turned off with --no-discussion.
206   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
207   * Add some new config items to the estseek.conf template, which are needed
208     by hyperestraier 1.2.3.
209
210  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
211
212 ikiwiki (1.0) unstable; urgency=low
213
214   * First official release.
215
216  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400