* Patch from Recai to use utf8 when reading the setup file, so that
[ikiwiki] / debian / changelog
1 ikiwiki (1.27) UNRELEASED; urgency=low
2
3   * Add a googlecalendar plugin. A bit special-purpose, but it shows
4     one way to to deal with user-supplied content that could cause XSS
5     issues w/o the htmlscrubber, and won't survive the scrubber.
6   * Work on firming up the plugin interface:
7     - Plugins should not need to load IkiWiki::Render to get commonly
8       used functions, so moved some functions from there to IkiWiki.
9     - Picked out the set of functions and variables that most plugins
10       use, documented them, and made IkiWiki export them by default,
11       like a proper perl module should.
12     - Use the other functions at your own risk.
13     - This is not quite complete, I still have to decide whether to
14       export some other things.
15   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
16     referring to stuff now exported by the IkiWiki module.
17   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
18     to declare which version of the interface your plugin needs.
19   * Anyone with a third-party ikiwiki plugin is strongly encouraged
20     to make like changes to it and avoid use of non-exported symboles from
21     "IkiWiki::".
22   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
23   * Support hyperestradier version 1.4.2, which adds a new required phraseform
24     setting.
25   * If an inlined page has a permalink, link the page title to that.
26   * Patch from Recai to use utf8 when reading the setup file, so that
27     utf8 wikinames from there will be used properly.
28
29  -- Joey Hess <joeyh@debian.org>  Sun, 10 Sep 2006 14:06:01 -0400
30
31 ikiwiki (1.26) unstable; urgency=low
32
33   * Add a missing -n to tla undo call.
34   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
35     writes before consuming its whole stdin. Avoid this deadlock.
36   * Fix alt tags for outline checkboxes.
37
38  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
39
40 ikiwiki (1.25) unstable; urgency=low
41
42   * Add proper waitpid calls for open2ed processes throughout to avoid
43     zombies; this hit htmltidy especially badly.
44   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
45     subversion repos and fixing some other issues.
46   * Add support for tla, contributed by Clint Adams. Closes: #385936
47   * Add support for mercurial, contributed by Emanuele Aina.
48   * Include <link rel> tag for RSS feeds, used by some aggregators and
49     firefox to find the feed.
50   * Add a linkmap plugin (requires graphviz).
51
52  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
53
54 ikiwiki (1.24) unstable; urgency=low
55
56   * Simplify the data structure returned by rcs_recentchanges to avoid
57     each rcs plugin needing to form complex strings on its own.
58   * Fix another destpage issue in the inline directive. Closes: #385512
59     again.
60
61  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
62
63 ikiwiki (1.23) unstable; urgency=low
64
65   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
66
67  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
68
69 ikiwiki (1.22) unstable; urgency=low
70
71   * Change how the stylesheet url is determined in the templates: Remove
72     STYLEURL and add BASEURL to all templates (some already had it). This
73     new more general variable can be used to link to other things (eg, images)
74     from the template, as well as stylesheets.
75   * Fix a bug introduced last version to do with nested inlines.
76   * Allow preprocessor directives to span multiple lines, both to make
77     long ones with lots of values easier to write, and to allow for ones with
78     multi-line quoted values.
79   * Allow preprocessor directives to contain python-like triple-quoted
80     text blocks, for easy nesting of quotes inside.
81   * Add a template plugin.
82   * Make pagespec merge code smarter about merging duplicate pagespecs.
83   * Patch from Jordà Polo to make Setup::Standard support hashes in config
84     files.
85   * Change order of linkify and preprocess; first preprocess and then linkify.
86     This allows passing a wikilink inside a parameter to a preprocessor
87     directive without it being expanded to html, and leaking out of the
88     parameter, which had required some non-obvious use of triple-quoting
89     to avoid. Note that any preprocessor plugins that output something
90     that looks like a wikilink will now have it treated as such; AFAIK
91     this doesn't change any behavior though except for the template plugin.
92   * Enable preprocessor directives when previewing an edit.
93   * Make all pages pull in a local.css style sheet, if present. This won't
94     be included in ikiwiki, but can be created to make local styling changes
95     w/o needing to merge in every new change to the distributed style.css.
96   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
97   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
98     from a different directory.
99   * Generalised preprocesser loop protection code.
100   * Patch from James Westby to allow a description to be set for rss feeds.
101   * Patch from James Westby to add a template for the search form.
102   * Added a ddate plugin.
103   * Patch from James Westby to add a --sslcookie switch, which forces
104     cookies to only be sent over ssl connections to avoid interception.
105   * Fix preferences page on anonok wikis; still need to sign in to get
106     to the preferences page.
107   * Add toc (table of contents) plugin.
108   * Change htmlize, format, and sanitize hooks to use named parameters.
109   * Patch from James Westby to add an actions option to inline; this
110     adds Edit and Discussion links at the end of blog entries.
111   * Due to some css changes, you'll want to rebuild your wiki on upgrade
112     to this version. Will be handled automatically by the deb.
113   * Add processed date to aggregate preprocessor directive status output.
114
115  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
116
117 ikiwiki (1.21) unstable; urgency=low
118
119   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
120   * If a page links to itself, mark up the link text in a span with
121     class="selflink" so that it can be styled. I don't have a useful style
122     defined for that though.
123   * Call filter hooks on inlined page content.
124   * Support inlining pages raw, rather than creating a blog.
125   * Clean up yes/no parameter parsing in inline plugin.
126   * Implemented better cycle detection in the inline plugin; nested inlines
127     will now work.
128   * Add a map plugin contributed by Alessandro Dotti Contra.
129   * Add otl format plugin, which handles files as created by vimoutliner.
130   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
131   * Add first draft at a Restructured Text (rst) plugin, by Sergio
132     Talens-Oliag. Note that this has many known issues -- see the caveats on
133     the plugin's page.
134   * Credit everyone who wrote a plugin on the plugins' wiki pages.
135   * Fix utf-8 in blog post form.
136
137  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
138
139 ikiwiki (1.20) unstable; urgency=low
140
141   * Relicense the templates and basewiki under the 2-clause BSD license.
142     Since these can easily become part of other people's websites, they
143     should be under as permissive a license as possible.
144   * Add --syslog config option, to log to the syslog.
145   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
146     transient failure to fork (which I've seen happen in the wild).
147   * Fix a bug in the aggregator introduced last version that caused all
148     aggregator state to be lost during a non-aggregating build.
149
150  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
151
152 ikiwiki (1.19) unstable; urgency=low
153
154   * Fix several related bugs in page type determination during online editing.
155   * Add some locking to prevent 2 aggregators from running at once.
156   * Fix an infinite loop in the aggregator when finding a unique filename.
157
158  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
159
160 ikiwiki (1.18) unstable; urgency=low
161
162   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
163   * Add --version.
164   * Man page format fixups.
165   * If the meta plugin overides the page title, set a title_overridden
166     variable in the template to true. This allows doing things with the
167     templates conditional on the title being overriden.
168   * Add a %pagecase which maps lower-case page names to the actual case
169     used in the filename. Use this in bestlinks calculation instead of
170     forcing the link to lowercase.
171   * Also use %pagecase in various other places that want to check if a page
172     with a given name exists.
173   * This means that links to pages with mixed case names will now work,
174     even if the link is in some other case mixture, and mixed case pages
175     should be fully supported throughout ikiwiki.
176   * Recommend rebuilding wikis on upgrade to this version.
177
178  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
179
180 ikiwiki (1.17) unstable; urgency=low
181
182   * Disable tidy generator tag.
183   * Move tidy back to sanitize hook, found out how to only show body.
184   * Turn off tidy indentation too.
185   * Turn on HTML::Template loop_context_vars; not actually used in stock
186     templates but can be useful for things like making comma-delimited lists
187     of tags or what have you.
188   * Remove <br> from end of aggregate preprocessor directive output.
189   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
190     case-sensative filesystems like OSX.
191   * Improve markdown loading. First, try to load it as a proper perl module,
192     in case it was installed as one. Then fall back to trying
193     /usr/bin/markdown.
194   * Document in install page how to install markdown, since it has no
195     installation procedure in the upstream tarball.
196   * Set die_on_bad_params => 0 for all templates, to allow users to modify
197     them without annoyances.
198   * Suck in the page content when generating an inline archive page, to work
199     around the meta plugin's lack of caching of title metadata across runs.
200
201  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
202
203 ikiwiki (1.16) unstable; urgency=low
204
205   * Try to handle relative links in aggregated feeds. However,
206     the current support is a crude hack due to limitations of XML::Feed:
207     xml:base is not supported, neither is Content-Location. And of course,
208     relative links in RSS feeds are ill-undefined..
209   * Make aggregator save permalinks and author name to pages as metadata.
210   * Add permalink and author support to meta plugin, affecting RSS feeds
211     and blog pages.
212   * Various CSS and formatting changes.
213   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
214   * Add xhtml files to the default prune regexp.
215   * Also generate rel=bookmark links for permalinks.
216   * Fix the htmltidy plugin, which wasn't working due my breaking it when
217     I added it..
218   * Don't run tidy with -xml as that fails if the input is not well-formed.
219     Run it with -asxhtml instead, so it will output well-formed xhtml no
220     matter what the input.
221   * Disable tidy warnings too.
222   * Add a new format hook, and make tidy use it, since tidy can really only
223     operate on and output complete html documents, not the body chunks
224     that sanitise gets.
225   * Fix dates in rss feeds if running localised, so they're still rfc 822.
226
227  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
228
229 ikiwiki (1.15) unstable; urgency=low
230
231   * Remove CDPATH and other env vars perl taint checking doesn't like.
232     Closes: #381279
233   * Added created_before and created_after PageSpec limits.
234
235  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
236
237 ikiwiki (1.14) unstable; urgency=low
238
239   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
240     by 10% or so.
241   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
242   * Added many unit tests for pagespec_match.
243
244  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
245
246 ikiwiki (1.13) unstable; urgency=low
247
248   * ikiwiki can now download and aggregate feeds with its new aggregate
249     plugin, so it's possible to implement a Planet using ikiwiki!
250   * Add a run_hooks function for the common task of running all hooks of a
251     given type.
252   * Add a savestate hook.
253   * Don't put blog post forms on pages if there's no cgiurl set.
254   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
255     --wrappers to do that.
256   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
257     to update pages that haven't changed on disk.
258   * Change meta tags to use html entity-escaped text for values, so that
259     quotes and such can be represented in title tags.
260   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
261     for the above.
262   * Make --rebuild also cause --aggregate to re-download and write aggregated
263     pages.
264   * Avoid outputting duplicate meta info.
265   * Include title metadata on aggregated posts for capitalised and un-munged
266     titles.
267   * Title metadata of inlined pages now shows up in blogs and rss feeds.
268   * Fix issue with unicode filenames and updating the hyper estradier search
269     index. (Aka Please Please Please, let that be the last one.)
270   * Patch from Roland Mas to support an rss=no parameter to inline directives.
271     Closes: #380743
272   * Renamed GlobLists to PageSpecs.
273   * PageSpecs can now include nested parens, "and", and "or". This remains
274     backwards compatible to the old GlobList format. It's implemented by
275     treating the GlobList as a very limited microlanguage that is transformed
276     to perl code that does the matching.
277   * The old GlobList format is deprecated, and I encourage users to switch to
278     using the new PageSpec format. Compatability with the old format will be
279     removed at some point, possibly by 2.0.
280   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
281   * Add support for creation_month and creation_year to PageSpec.
282     Closes: #380680
283   * Changes to index file encoding.
284
285  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
286
287 ikiwiki (1.12) unstable; urgency=low
288
289   "Viva l'Italia!"
290   * New pagestats plugin from Enrico, which can generate a table counting
291     the backlinks for each page, or a del.icio.us style cloud.
292   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
293     the wikiformat plugin works. Thanks, Emanuele Aina.
294   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
295     display, running them through pagetitle. This removes ugly underscores and
296     other gunk from the display, much nicer. You may want to rebuild your wiki
297     when upgrading to get the cleanup globally.
298   * Polygen plugin from Enrico.
299   * htmltidy plugin from Faidon.
300   * Locale patch from Faidon:
301     - Adds a locale setting to setup files.
302     - Proper local time, if the locale configuration option is used.
303     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
304       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
305       impossible.
306   * Add getopt hook type, this allows plugins to add new command-line options.
307   * Add --tagbase option to tag plugin.
308   * Add exclude option in setup files, works same as --exclude.
309   * Put categories in rss feeds for tagged items.
310   * Allow preprocessor directives to be expanded in inlined blog pages.
311     However, to avoid inlining loops etc, don't expand inline directives in
312     inlined pages.
313   * fortune plugin (trivial)
314   * Tag plugins according to type.
315
316  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
317
318 ikiwiki (1.11) unstable; urgency=low
319
320   * Patch from Enrico that
321     - Adds a tag plugin that allows more easily tagging pages.
322       The meta plugin can also still be used for that, but the tag plugin
323       also lists a page's tags at the bottom of the page.
324     - Allows preprocessor directives to have parameters with no specified
325       value.
326     - Fixes preprocessor directive parameter parsing so that
327       foo=bar baz now means "foo=bar" and a "baz" with no value.
328   * Run pagetemplate hooks when inlining pages so that inlined pages also
329     list their tags.
330   * Make all plugins with pagetemplate hooks check that variables exist
331     on the template before setting them, for robustness.
332   * Switch pagetemplate hooks to using named parameters.
333   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
334     This will be the page that a source page will be part of, which is
335     different than the source page for inlined pages.
336   * Audited all plugins to endure they pass (page, destpage) to htmllink
337     appropriatly. This means inlining of various plugins will not work
338     properly, with correct links generated.
339
340  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
341
342 ikiwiki (1.10) unstable; urgency=low
343
344   * Run page through any relevant filters when generating a page preview.
345   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
346     default throughout the wiki, not only on wikitext pages. Decided to call
347     this a feature, and split the camelcase support out into a separate plugin
348     that is independant of wikitext.
349   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
350
351  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
352
353 ikiwiki (1.9) unstable; urgency=low
354
355   * Improve display of parentlinks and page title of toplevel index page.
356   * Patch from Faidon to use svn --limit when possible for recentchanges,
357     speeds up recentchanges a lot for wikis with more history.
358   * Patch from Recai to fix utf8 issues in git backend.
359   * Add wikitext markup plugin, which supports ".wiki" pages written in the
360     original wiki syntax, CamelCase links and all.
361   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
362     support, to edit pages etc without a web server.
363   * Display CGI processing errors if present.
364   * Fix from Faidon for a XML parser issue that breaks utf-8 for
365     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
366     area, and also way slow.
367   * Match 'web commit from' in SVN and git, these are web commits too.
368     (Faidon)
369   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
370     readable and avoid future mistakes. The patch seems to work and for the
371     first time I have a UTF-8 username ;-) (Faidon)
372   * Use form->field consistently, not form->param.
373   * Patch from Recai to allow selection of page type when creating a new page.
374     Default page type is inherited from the link clicked on to create the new
375     page.
376
377  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
378
379 ikiwiki (1.8) unstable; urgency=low
380
381   * Fix orphans plugin to not count a link to a nonexistant page as a reason
382     for a page not being an orphan.
383   * Support pinging services such as Technorati using XML-RPC to notify them
384     about changes to rss feeds.
385   * Parse svn log as xml for improved utf8 and security. Note that this makes
386     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
387   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
388     flagged string even if the locale causes it to generate utf8 output,
389     so make sure to let perl know it should be handled as utf8. Also,
390     the optimised version used for standard time formats won't work if the
391     user has changed locale, so drop it. Thanks, Faidon Liambotis.
392   * Fix re-encoding of the comments field to utf8 if a commit fails
393     due to a conflict. Thanks, Faidon Liambotis.
394   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
395     Liambotis.
396   * Add insane double encode/decode to utf8 around call to markdown.
397     This works around a truely strange bug, which is apparently a bug in
398     perl, #376329. Also added a test case for it.
399   * Improve layout of edit page so formatting help link is always visible w/o
400     getting in the way of the preview.
401   * Centralised all calls to HTML::Template and force all the templates
402     to be read as utf8.
403   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
404   * Introduce add_plugins and disable_plugins config options in setup files.
405     This allows adding or removing plugins w/o overriding the whole list of
406     default plugins, which makes it easier to upgrade when new default plugins
407     are added.
408   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
409     default (of course!). Based on a patch by Faidon Liambotis.
410   * Add a html plugin, which can be used to write wikis in raw html,
411     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
412     defaults to not processing .html files, since w/o this plugin they would
413     be copied unsanitised. With this plugin, it will process and html
414     sanitise them, like any other page type.
415   * Rebuilding wrappers is necessary on upgrade to this version.
416   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
417     will be automatically done on all upgrades.
418   * Don't send pings if the wiki is being rebuilt.
419   * Work around very innefficient behavior in File::Spec::abs2rel. Result
420     is a savings of 2 pointless fork/execs per link calculation, which
421     results in ~25% speedup of ikiwiki building its own doc wiki, and
422     about 35% speedup displaying RecentChanges!
423   * Make RecentChanges use a table and some CSS, should be much more readable.
424     No code changes involved.
425   * Encode & in diffurl in examples, to conform to pedantic rules.
426   * Speed up RecentChanges by another 40% or so with some memoization.
427   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
428     in time to build the doc wiki.
429
430  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
431
432 ikiwiki (1.7) unstable; urgency=low
433
434   * Updated logo from Recai with some kerning and alingment tuning.
435   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
436     changed some output.
437   * Copyright update.
438
439  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
440
441 ikiwiki (1.6) unstable; urgency=low
442
443   * YA utf-8 patch from Recai, this time to fix previewing a page so that
444     the text in the input box is re-encoded back to utf-8.
445   * -CSD does not affect modules, so readfile() was not using the utf-8 input
446     layer, which led to lots of problems; make it force read files as utf-8.
447     Closes: #373203
448   * Note that as a consequence, this version of ikiwiki will actually try to
449     parse utf8 in source files for the first time, which may expose broken
450     utf8 in wiki sources that was hidden before. Most common will be
451     perl warnings like "utf8 "\xE9" does not map to Unicode"
452   * writefile() likewise needs to use the utf8 output layer.
453   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
454     there.
455   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
456     given the readfile fix.
457   * Add utf-8 testcases for readfile and htmlize.
458   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
459     safe.
460   * More utf-8 fixes from Recai, partly to things I broke above:
461     - The serious problem is that writefile() saves the content in undecoded
462       format in CGI, hence all (non-ascii) chars are corrupted permanently.
463     - Comment field in edit page is not decoded and all the non-ascii chars in
464       this field are corrupted as the result.  We should decode it as we do it
465       for the content.
466     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
467       character in print.
468   * New SVG logo from Recai.
469
470  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
471
472 ikiwiki (1.5) unstable; urgency=low
473
474   * Add --timeformat config option to allow changing how dates are displayed.
475     Note that as a side effect, dates will now be displayed using the local
476     timezone, not as GMT.
477   * More security review.
478   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
479     for some handy stuff like:
480     - Using links as a kind of tag; creating blog pages that list all pages
481       containing a given tag/link or not containing some other tag.
482     - Subscribing to mail notifications whenever a change is made to a page
483       that is a backlink of page foo. Ie, "Please notify me of changes in all
484       pages that link to my home page in the wiki"
485     - Locking any pages that are linked to from a particular page, so that
486       lists of locks can be exposed in the wiki.
487   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
488     when a todo item is done, instead of the previous moving it to a different
489     subdir.
490   * Allow pagetemplate plugins to override *anything* in the template.
491   * Add a meta plugin, which allows specifying various metadata about pages,
492     like license and author. It also allows for inserting html link and meta
493     tags into html, overriding the title, and adding hidden WikiLinks, which
494     can be useful when using link-based globbing for page categorisation.
495   * Remove preprocessor directives from inlined pages.
496   * Allow simple preprocessor directive values to be specified w/o quotes.
497   * Add support for using git instead of subversion as the RCS backend,
498     tremendous thanks to Recai Oktaş for this.
499   * Doc updates for git.
500   * Fix absolute url munging in rss generation to support https, ftp, etc urls
501     not just http urls.
502   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
503     utf-8 for edit and other fields, and for recentchanges. There may still
504     be utf-8 issues with the preferences page though.
505
506  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
507
508 ikiwiki (1.4) unstable; urgency=low
509
510   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
511     very strange way of enabling proper XHTML <br /> type tags. Output html
512     should be always valid again now.
513   * The page name and parent links has switched from using a <h1> to a styled
514     <span>, so pages can use <h1> internally instead of needing to use <h2>.
515   * Updated all of ikiwiki's own wiki pages for that.
516   * Add pagetemplate hook, which can be used by plugins that want to mess
517     around with adding new stuff to the page template.
518   * Remove headercontent; the search plugin now adds the search box to the
519     header by registering a pagetemplate hook, and other plugins should do
520     similarly.
521   * Rebuilding on upgrade to this version is recommended.
522   * Add a html validity check to the test suite, using the wdg-html-validator,
523     if available.
524   * Make the html valid when there is nothing in the actions list.
525   * Reordered some function call parameters for consistency.
526   * Enable full utf-8 support for page input and output.
527   * Add a workaround for markdown, which does not work well with utf-8
528     strings.
529   * --getctime had bitrotted (well I only ever used it the once so far..),
530     fix and make it a bit more flexible
531   * rcs_getctime is changed, now rather than needing to loop over all pages,
532     it should just use the rcs to get the ctime of the passed file.
533   * When inlining a page in another one, links from the inlined page are now
534     expanded the same as they are when rendering the inlined page as a
535     standalone page. So rather than being expanded from the POV of the
536     inlining page, they are expanded from the POV of the inlined page.
537
538     For example, a link from blog/foo to "bar" will now link to blog/bar
539     if it exists. Previously this needed to be a link explicitly to
540     "blog/bar"; such links will also continue to work.
541
542     (This was slightly complex to do as the link still has to be constructed
543     relative to the inlining page.)
544   * Make page edit textarea resize to fit browser window.
545   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
546     do not need a full rebuild, in order to update any basewiki pages.
547
548  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
549
550 ikiwiki (1.3) unstable; urgency=low
551
552   * Fix the preinst introduced in the last version. Closes: #367458
553
554  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
555
556 ikiwiki (1.2) unstable; urgency=low
557
558   * Remove dups from the brokenlinks list.
559   * Add libc6-dev to dependencies, needed to build wrappers.
560   * Install wikilist in correct location. Closes: #367371
561
562  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
563
564 ikiwiki (1.1) unstable; urgency=low
565
566   * Rename inlinepage to depends, so that it can be used to refer to more
567     dependency relationships than just inlining. This will require a rebuild
568     on upgrade to this version.
569   * Move the rss link, put it in the blogpost form if there is one and at the
570     top if not. This is both nicer because easier to find, and it cleans up
571     the code which had used inlinepage as a flag for adding the link later.
572   * Allow the depends GlobList to be built up from multiple sources (such as
573     plugins) during a page render.
574   * Which means that more than one blog is now supported to appear on a
575     single page. (With some limitations, like only the last one getting an
576     rss file.)
577   * Added a plugin system.
578   * Added a pagecount plugin, enabled by default.
579   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
580   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
581     backlinks when the backlinks hadn't really changed.
582   * Moved inline page support, rss generation etc into the inline plugin,
583     enabled by default.
584   * Added brokenlinks plugin, not enabled by default, but rather handy.
585   * Fix several broken links in the doc wiki.
586   * Smarter behavior when creating a page and a page of the same name (but
587     different location) already exists.
588   * Add an orphans plugin for finding pages that nothing links to.
589   * Removed backlinks page, which it turns out nothing used.
590   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
591     it, this will allow for adding a unit test suite.
592   * Add unit tests for several core functions, including globlist_match,
593     dirname, basename, bestlink, linkify, pagetitle, titlepage.
594   * Smart globlist merging.
595   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
596     to pave the way for adding other RCS support. This also changes the
597     setup files, where before they had svn => 1 or svn => 0, now they have
598     rcs => "svn" or rcs => "".
599   * Add a debian/NEWS file with upgrade notes.
600   * Load whatever rcs module is specified, so new ones can be just dropped in
601     as plugins and work. (Well, in theory.)
602   * Add some basic docs about writing RCS modules.
603   * Broke search capability out into a plugin, removed the --hyperestraier
604     switch.
605   * Added smiley plugin, nicely controlled and documented by the smileys page.
606   * Copied in some smileys from Moin Moin.
607   * Allow links of the form [[some page|page]], with whitespace in the link
608     text.
609   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
610     and --disable-plugin htmlscrubber.
611   * Allow discussion links on pages to be turned off with --no-discussion.
612   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
613   * Add some new config items to the estseek.conf template, which are needed
614     by hyperestraier 1.2.3.
615
616  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
617
618 ikiwiki (1.0) unstable; urgency=low
619
620   * First official release.
621
622  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400