* Don't rm -rf ikiwiki on distclean, since a) there's no such file
[ikiwiki] / debian / changelog
1 ikiwiki (1.28) UNRELEASED; urgency=low
2
3   * inline: Add ability to sort by page name, based on a patch from
4     Benjamin A'Lee.
5   * Fix a forkbomb in various calls to IPC::Open2, which has a highly
6     braindead interface. Closes: #389383
7   * Don't rm -rf ikiwiki on distclean, since a) there's no such file
8     and b) those poor Mac OSX users and their case insensative files!
9
10  -- Joey Hess <joeyh@debian.org>  Mon, 25 Sep 2006 17:40:48 -0400
11
12 ikiwiki (1.27) unstable; urgency=low
13
14   * Work on firming up the plugin interface:
15     - Plugins should not need to load IkiWiki::Render to get commonly
16       used functions, so moved some functions from there to IkiWiki.
17     - Picked out the set of functions and variables that most plugins
18       use, documented them, and made IkiWiki export them by default,
19       like a proper perl module should.
20     - Use the other functions at your own risk.
21     - This is not quite complete, I still have to decide whether to
22       export some other things.
23   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
24     referring to stuff now exported by the IkiWiki module.
25   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
26     to declare which version of the interface your plugin needs.
27   * Anyone with a third-party ikiwiki plugin is strongly encouraged
28     to make like changes to it and avoid use of non-exported symbols from
29     "IkiWiki::".
30   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
31   * Support hyperestradier version 1.4.2, which adds a new required phraseform
32     setting.
33   * If an inlined page has a permalink, link the page title to that.
34   * Patch from Recai to use utf8 when reading the setup file, so that
35     utf8 wikinames from there will be used properly.
36   * Patch from Recai to kill utf-8 on the wiki name when generating the
37     session cookie.
38   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
39   * Fix a baseurl problem in hyperestradier search results.
40   * Add a stub local.css to avoid problems with 404's.
41   * Patch from Recai to fix a wide character warning from the search plugin
42     during setup if the wikiname contains utf8.
43   * Yet another fix for those poor case-insensative OS X users.
44   * pagetemplate hooks are now also called when generating cgi pages.
45   * Add a favicon plugin, which simply adds a link tag for an icon to each
46     page (and cgis).
47   * Patch from James Westby to deal with the case where you're editing a
48     new page, hit cancel, and need to be redirected to somewhere sane.
49   * Various documentation improvements by various wiki users.
50   * Support Text::Markdown from CPAN, which has a different interface from
51     the original markdown or the one in Debian.
52   * Version the libcgi-session-perl dependency, some features that need
53     the new version are used in some cases (sslcookie).
54   * Numerous tla fixes from Clint.
55   * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
56     a multi-resolution favicon.ico.
57   * README.Debian: typo Closes: #388110
58   * chomp trailing newline at the end of templates read in by the template
59     plugin, to allow use of the template preprocessor directive in
60     whitespace-sensative situations. Closes: #387073
61   * Patch from James Westby to make the location of the estseek.cgi script
62     configurable.
63   * Add typography (SmartyPants) plugin by Recai.
64   * Add --render mode, which can be used to preview an edit at the command
65     line by test rendering a single page.
66   * Add a googlecalendar plugin. A bit special-purpose, but it shows
67     one way to to deal with user-supplied content that could cause XSS
68     issues w/o the htmlscrubber, and won't survive the scrubber.
69
70  -- Joey Hess <joeyh@debian.org>  Sun, 24 Sep 2006 00:02:21 -0400
71
72 ikiwiki (1.26) unstable; urgency=low
73
74   * Add a missing -n to tla undo call.
75   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
76     writes before consuming its whole stdin. Avoid this deadlock.
77   * Fix alt tags for outline checkboxes.
78
79  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
80
81 ikiwiki (1.25) unstable; urgency=low
82
83   * Add proper waitpid calls for open2ed processes throughout to avoid
84     zombies; this hit htmltidy especially badly.
85   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
86     subversion repos and fixing some other issues.
87   * Add support for tla, contributed by Clint Adams. Closes: #385936
88   * Add support for mercurial, contributed by Emanuele Aina.
89   * Include <link rel> tag for RSS feeds, used by some aggregators and
90     firefox to find the feed.
91   * Add a linkmap plugin (requires graphviz).
92
93  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
94
95 ikiwiki (1.24) unstable; urgency=low
96
97   * Simplify the data structure returned by rcs_recentchanges to avoid
98     each rcs plugin needing to form complex strings on its own.
99   * Fix another destpage issue in the inline directive. Closes: #385512
100     again.
101
102  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
103
104 ikiwiki (1.23) unstable; urgency=low
105
106   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
107
108  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
109
110 ikiwiki (1.22) unstable; urgency=low
111
112   * Change how the stylesheet url is determined in the templates: Remove
113     STYLEURL and add BASEURL to all templates (some already had it). This
114     new more general variable can be used to link to other things (eg, images)
115     from the template, as well as stylesheets.
116   * Fix a bug introduced last version to do with nested inlines.
117   * Allow preprocessor directives to span multiple lines, both to make
118     long ones with lots of values easier to write, and to allow for ones with
119     multi-line quoted values.
120   * Allow preprocessor directives to contain python-like triple-quoted
121     text blocks, for easy nesting of quotes inside.
122   * Add a template plugin.
123   * Make pagespec merge code smarter about merging duplicate pagespecs.
124   * Patch from Jordà Polo to make Setup::Standard support hashes in config
125     files.
126   * Change order of linkify and preprocess; first preprocess and then linkify.
127     This allows passing a wikilink inside a parameter to a preprocessor
128     directive without it being expanded to html, and leaking out of the
129     parameter, which had required some non-obvious use of triple-quoting
130     to avoid. Note that any preprocessor plugins that output something
131     that looks like a wikilink will now have it treated as such; AFAIK
132     this doesn't change any behavior though except for the template plugin.
133   * Enable preprocessor directives when previewing an edit.
134   * Make all pages pull in a local.css style sheet, if present. This won't
135     be included in ikiwiki, but can be created to make local styling changes
136     w/o needing to merge in every new change to the distributed style.css.
137   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
138   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
139     from a different directory.
140   * Generalised preprocesser loop protection code.
141   * Patch from James Westby to allow a description to be set for rss feeds.
142   * Patch from James Westby to add a template for the search form.
143   * Added a ddate plugin.
144   * Patch from James Westby to add a --sslcookie switch, which forces
145     cookies to only be sent over ssl connections to avoid interception.
146   * Fix preferences page on anonok wikis; still need to sign in to get
147     to the preferences page.
148   * Add toc (table of contents) plugin.
149   * Change htmlize, format, and sanitize hooks to use named parameters.
150   * Patch from James Westby to add an actions option to inline; this
151     adds Edit and Discussion links at the end of blog entries.
152   * Due to some css changes, you'll want to rebuild your wiki on upgrade
153     to this version. Will be handled automatically by the deb.
154   * Add processed date to aggregate preprocessor directive status output.
155
156  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
157
158 ikiwiki (1.21) unstable; urgency=low
159
160   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
161   * If a page links to itself, mark up the link text in a span with
162     class="selflink" so that it can be styled. I don't have a useful style
163     defined for that though.
164   * Call filter hooks on inlined page content.
165   * Support inlining pages raw, rather than creating a blog.
166   * Clean up yes/no parameter parsing in inline plugin.
167   * Implemented better cycle detection in the inline plugin; nested inlines
168     will now work.
169   * Add a map plugin contributed by Alessandro Dotti Contra.
170   * Add otl format plugin, which handles files as created by vimoutliner.
171   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
172   * Add first draft at a Restructured Text (rst) plugin, by Sergio
173     Talens-Oliag. Note that this has many known issues -- see the caveats on
174     the plugin's page.
175   * Credit everyone who wrote a plugin on the plugins' wiki pages.
176   * Fix utf-8 in blog post form.
177
178  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
179
180 ikiwiki (1.20) unstable; urgency=low
181
182   * Relicense the templates and basewiki under the 2-clause BSD license.
183     Since these can easily become part of other people's websites, they
184     should be under as permissive a license as possible.
185   * Add --syslog config option, to log to the syslog.
186   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
187     transient failure to fork (which I've seen happen in the wild).
188   * Fix a bug in the aggregator introduced last version that caused all
189     aggregator state to be lost during a non-aggregating build.
190
191  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
192
193 ikiwiki (1.19) unstable; urgency=low
194
195   * Fix several related bugs in page type determination during online editing.
196   * Add some locking to prevent 2 aggregators from running at once.
197   * Fix an infinite loop in the aggregator when finding a unique filename.
198
199  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
200
201 ikiwiki (1.18) unstable; urgency=low
202
203   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
204   * Add --version.
205   * Man page format fixups.
206   * If the meta plugin overides the page title, set a title_overridden
207     variable in the template to true. This allows doing things with the
208     templates conditional on the title being overriden.
209   * Add a %pagecase which maps lower-case page names to the actual case
210     used in the filename. Use this in bestlinks calculation instead of
211     forcing the link to lowercase.
212   * Also use %pagecase in various other places that want to check if a page
213     with a given name exists.
214   * This means that links to pages with mixed case names will now work,
215     even if the link is in some other case mixture, and mixed case pages
216     should be fully supported throughout ikiwiki.
217   * Recommend rebuilding wikis on upgrade to this version.
218
219  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
220
221 ikiwiki (1.17) unstable; urgency=low
222
223   * Disable tidy generator tag.
224   * Move tidy back to sanitize hook, found out how to only show body.
225   * Turn off tidy indentation too.
226   * Turn on HTML::Template loop_context_vars; not actually used in stock
227     templates but can be useful for things like making comma-delimited lists
228     of tags or what have you.
229   * Remove <br> from end of aggregate preprocessor directive output.
230   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
231     case-sensative filesystems like OSX.
232   * Improve markdown loading. First, try to load it as a proper perl module,
233     in case it was installed as one. Then fall back to trying
234     /usr/bin/markdown.
235   * Document in install page how to install markdown, since it has no
236     installation procedure in the upstream tarball.
237   * Set die_on_bad_params => 0 for all templates, to allow users to modify
238     them without annoyances.
239   * Suck in the page content when generating an inline archive page, to work
240     around the meta plugin's lack of caching of title metadata across runs.
241
242  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
243
244 ikiwiki (1.16) unstable; urgency=low
245
246   * Try to handle relative links in aggregated feeds. However,
247     the current support is a crude hack due to limitations of XML::Feed:
248     xml:base is not supported, neither is Content-Location. And of course,
249     relative links in RSS feeds are ill-undefined..
250   * Make aggregator save permalinks and author name to pages as metadata.
251   * Add permalink and author support to meta plugin, affecting RSS feeds
252     and blog pages.
253   * Various CSS and formatting changes.
254   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
255   * Add xhtml files to the default prune regexp.
256   * Also generate rel=bookmark links for permalinks.
257   * Fix the htmltidy plugin, which wasn't working due my breaking it when
258     I added it..
259   * Don't run tidy with -xml as that fails if the input is not well-formed.
260     Run it with -asxhtml instead, so it will output well-formed xhtml no
261     matter what the input.
262   * Disable tidy warnings too.
263   * Add a new format hook, and make tidy use it, since tidy can really only
264     operate on and output complete html documents, not the body chunks
265     that sanitise gets.
266   * Fix dates in rss feeds if running localised, so they're still rfc 822.
267
268  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
269
270 ikiwiki (1.15) unstable; urgency=low
271
272   * Remove CDPATH and other env vars perl taint checking doesn't like.
273     Closes: #381279
274   * Added created_before and created_after PageSpec limits.
275
276  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
277
278 ikiwiki (1.14) unstable; urgency=low
279
280   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
281     by 10% or so.
282   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
283   * Added many unit tests for pagespec_match.
284
285  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
286
287 ikiwiki (1.13) unstable; urgency=low
288
289   * ikiwiki can now download and aggregate feeds with its new aggregate
290     plugin, so it's possible to implement a Planet using ikiwiki!
291   * Add a run_hooks function for the common task of running all hooks of a
292     given type.
293   * Add a savestate hook.
294   * Don't put blog post forms on pages if there's no cgiurl set.
295   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
296     --wrappers to do that.
297   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
298     to update pages that haven't changed on disk.
299   * Change meta tags to use html entity-escaped text for values, so that
300     quotes and such can be represented in title tags.
301   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
302     for the above.
303   * Make --rebuild also cause --aggregate to re-download and write aggregated
304     pages.
305   * Avoid outputting duplicate meta info.
306   * Include title metadata on aggregated posts for capitalised and un-munged
307     titles.
308   * Title metadata of inlined pages now shows up in blogs and rss feeds.
309   * Fix issue with unicode filenames and updating the hyper estradier search
310     index. (Aka Please Please Please, let that be the last one.)
311   * Patch from Roland Mas to support an rss=no parameter to inline directives.
312     Closes: #380743
313   * Renamed GlobLists to PageSpecs.
314   * PageSpecs can now include nested parens, "and", and "or". This remains
315     backwards compatible to the old GlobList format. It's implemented by
316     treating the GlobList as a very limited microlanguage that is transformed
317     to perl code that does the matching.
318   * The old GlobList format is deprecated, and I encourage users to switch to
319     using the new PageSpec format. Compatability with the old format will be
320     removed at some point, possibly by 2.0.
321   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
322   * Add support for creation_month and creation_year to PageSpec.
323     Closes: #380680
324   * Changes to index file encoding.
325
326  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
327
328 ikiwiki (1.12) unstable; urgency=low
329
330   "Viva l'Italia!"
331   * New pagestats plugin from Enrico, which can generate a table counting
332     the backlinks for each page, or a del.icio.us style cloud.
333   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
334     the wikiformat plugin works. Thanks, Emanuele Aina.
335   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
336     display, running them through pagetitle. This removes ugly underscores and
337     other gunk from the display, much nicer. You may want to rebuild your wiki
338     when upgrading to get the cleanup globally.
339   * Polygen plugin from Enrico.
340   * htmltidy plugin from Faidon.
341   * Locale patch from Faidon:
342     - Adds a locale setting to setup files.
343     - Proper local time, if the locale configuration option is used.
344     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
345       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
346       impossible.
347   * Add getopt hook type, this allows plugins to add new command-line options.
348   * Add --tagbase option to tag plugin.
349   * Add exclude option in setup files, works same as --exclude.
350   * Put categories in rss feeds for tagged items.
351   * Allow preprocessor directives to be expanded in inlined blog pages.
352     However, to avoid inlining loops etc, don't expand inline directives in
353     inlined pages.
354   * fortune plugin (trivial)
355   * Tag plugins according to type.
356
357  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
358
359 ikiwiki (1.11) unstable; urgency=low
360
361   * Patch from Enrico that
362     - Adds a tag plugin that allows more easily tagging pages.
363       The meta plugin can also still be used for that, but the tag plugin
364       also lists a page's tags at the bottom of the page.
365     - Allows preprocessor directives to have parameters with no specified
366       value.
367     - Fixes preprocessor directive parameter parsing so that
368       foo=bar baz now means "foo=bar" and a "baz" with no value.
369   * Run pagetemplate hooks when inlining pages so that inlined pages also
370     list their tags.
371   * Make all plugins with pagetemplate hooks check that variables exist
372     on the template before setting them, for robustness.
373   * Switch pagetemplate hooks to using named parameters.
374   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
375     This will be the page that a source page will be part of, which is
376     different than the source page for inlined pages.
377   * Audited all plugins to endure they pass (page, destpage) to htmllink
378     appropriatly. This means inlining of various plugins will not work
379     properly, with correct links generated.
380
381  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
382
383 ikiwiki (1.10) unstable; urgency=low
384
385   * Run page through any relevant filters when generating a page preview.
386   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
387     default throughout the wiki, not only on wikitext pages. Decided to call
388     this a feature, and split the camelcase support out into a separate plugin
389     that is independant of wikitext.
390   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
391
392  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
393
394 ikiwiki (1.9) unstable; urgency=low
395
396   * Improve display of parentlinks and page title of toplevel index page.
397   * Patch from Faidon to use svn --limit when possible for recentchanges,
398     speeds up recentchanges a lot for wikis with more history.
399   * Patch from Recai to fix utf8 issues in git backend.
400   * Add wikitext markup plugin, which supports ".wiki" pages written in the
401     original wiki syntax, CamelCase links and all.
402   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
403     support, to edit pages etc without a web server.
404   * Display CGI processing errors if present.
405   * Fix from Faidon for a XML parser issue that breaks utf-8 for
406     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
407     area, and also way slow.
408   * Match 'web commit from' in SVN and git, these are web commits too.
409     (Faidon)
410   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
411     readable and avoid future mistakes. The patch seems to work and for the
412     first time I have a UTF-8 username ;-) (Faidon)
413   * Use form->field consistently, not form->param.
414   * Patch from Recai to allow selection of page type when creating a new page.
415     Default page type is inherited from the link clicked on to create the new
416     page.
417
418  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
419
420 ikiwiki (1.8) unstable; urgency=low
421
422   * Fix orphans plugin to not count a link to a nonexistant page as a reason
423     for a page not being an orphan.
424   * Support pinging services such as Technorati using XML-RPC to notify them
425     about changes to rss feeds.
426   * Parse svn log as xml for improved utf8 and security. Note that this makes
427     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
428   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
429     flagged string even if the locale causes it to generate utf8 output,
430     so make sure to let perl know it should be handled as utf8. Also,
431     the optimised version used for standard time formats won't work if the
432     user has changed locale, so drop it. Thanks, Faidon Liambotis.
433   * Fix re-encoding of the comments field to utf8 if a commit fails
434     due to a conflict. Thanks, Faidon Liambotis.
435   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
436     Liambotis.
437   * Add insane double encode/decode to utf8 around call to markdown.
438     This works around a truely strange bug, which is apparently a bug in
439     perl, #376329. Also added a test case for it.
440   * Improve layout of edit page so formatting help link is always visible w/o
441     getting in the way of the preview.
442   * Centralised all calls to HTML::Template and force all the templates
443     to be read as utf8.
444   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
445   * Introduce add_plugins and disable_plugins config options in setup files.
446     This allows adding or removing plugins w/o overriding the whole list of
447     default plugins, which makes it easier to upgrade when new default plugins
448     are added.
449   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
450     default (of course!). Based on a patch by Faidon Liambotis.
451   * Add a html plugin, which can be used to write wikis in raw html,
452     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
453     defaults to not processing .html files, since w/o this plugin they would
454     be copied unsanitised. With this plugin, it will process and html
455     sanitise them, like any other page type.
456   * Rebuilding wrappers is necessary on upgrade to this version.
457   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
458     will be automatically done on all upgrades.
459   * Don't send pings if the wiki is being rebuilt.
460   * Work around very innefficient behavior in File::Spec::abs2rel. Result
461     is a savings of 2 pointless fork/execs per link calculation, which
462     results in ~25% speedup of ikiwiki building its own doc wiki, and
463     about 35% speedup displaying RecentChanges!
464   * Make RecentChanges use a table and some CSS, should be much more readable.
465     No code changes involved.
466   * Encode & in diffurl in examples, to conform to pedantic rules.
467   * Speed up RecentChanges by another 40% or so with some memoization.
468   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
469     in time to build the doc wiki.
470
471  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
472
473 ikiwiki (1.7) unstable; urgency=low
474
475   * Updated logo from Recai with some kerning and alingment tuning.
476   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
477     changed some output.
478   * Copyright update.
479
480  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
481
482 ikiwiki (1.6) unstable; urgency=low
483
484   * YA utf-8 patch from Recai, this time to fix previewing a page so that
485     the text in the input box is re-encoded back to utf-8.
486   * -CSD does not affect modules, so readfile() was not using the utf-8 input
487     layer, which led to lots of problems; make it force read files as utf-8.
488     Closes: #373203
489   * Note that as a consequence, this version of ikiwiki will actually try to
490     parse utf8 in source files for the first time, which may expose broken
491     utf8 in wiki sources that was hidden before. Most common will be
492     perl warnings like "utf8 "\xE9" does not map to Unicode"
493   * writefile() likewise needs to use the utf8 output layer.
494   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
495     there.
496   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
497     given the readfile fix.
498   * Add utf-8 testcases for readfile and htmlize.
499   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
500     safe.
501   * More utf-8 fixes from Recai, partly to things I broke above:
502     - The serious problem is that writefile() saves the content in undecoded
503       format in CGI, hence all (non-ascii) chars are corrupted permanently.
504     - Comment field in edit page is not decoded and all the non-ascii chars in
505       this field are corrupted as the result.  We should decode it as we do it
506       for the content.
507     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
508       character in print.
509   * New SVG logo from Recai.
510
511  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
512
513 ikiwiki (1.5) unstable; urgency=low
514
515   * Add --timeformat config option to allow changing how dates are displayed.
516     Note that as a side effect, dates will now be displayed using the local
517     timezone, not as GMT.
518   * More security review.
519   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
520     for some handy stuff like:
521     - Using links as a kind of tag; creating blog pages that list all pages
522       containing a given tag/link or not containing some other tag.
523     - Subscribing to mail notifications whenever a change is made to a page
524       that is a backlink of page foo. Ie, "Please notify me of changes in all
525       pages that link to my home page in the wiki"
526     - Locking any pages that are linked to from a particular page, so that
527       lists of locks can be exposed in the wiki.
528   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
529     when a todo item is done, instead of the previous moving it to a different
530     subdir.
531   * Allow pagetemplate plugins to override *anything* in the template.
532   * Add a meta plugin, which allows specifying various metadata about pages,
533     like license and author. It also allows for inserting html link and meta
534     tags into html, overriding the title, and adding hidden WikiLinks, which
535     can be useful when using link-based globbing for page categorisation.
536   * Remove preprocessor directives from inlined pages.
537   * Allow simple preprocessor directive values to be specified w/o quotes.
538   * Add support for using git instead of subversion as the RCS backend,
539     tremendous thanks to Recai Oktaş for this.
540   * Doc updates for git.
541   * Fix absolute url munging in rss generation to support https, ftp, etc urls
542     not just http urls.
543   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
544     utf-8 for edit and other fields, and for recentchanges. There may still
545     be utf-8 issues with the preferences page though.
546
547  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
548
549 ikiwiki (1.4) unstable; urgency=low
550
551   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
552     very strange way of enabling proper XHTML <br /> type tags. Output html
553     should be always valid again now.
554   * The page name and parent links has switched from using a <h1> to a styled
555     <span>, so pages can use <h1> internally instead of needing to use <h2>.
556   * Updated all of ikiwiki's own wiki pages for that.
557   * Add pagetemplate hook, which can be used by plugins that want to mess
558     around with adding new stuff to the page template.
559   * Remove headercontent; the search plugin now adds the search box to the
560     header by registering a pagetemplate hook, and other plugins should do
561     similarly.
562   * Rebuilding on upgrade to this version is recommended.
563   * Add a html validity check to the test suite, using the wdg-html-validator,
564     if available.
565   * Make the html valid when there is nothing in the actions list.
566   * Reordered some function call parameters for consistency.
567   * Enable full utf-8 support for page input and output.
568   * Add a workaround for markdown, which does not work well with utf-8
569     strings.
570   * --getctime had bitrotted (well I only ever used it the once so far..),
571     fix and make it a bit more flexible
572   * rcs_getctime is changed, now rather than needing to loop over all pages,
573     it should just use the rcs to get the ctime of the passed file.
574   * When inlining a page in another one, links from the inlined page are now
575     expanded the same as they are when rendering the inlined page as a
576     standalone page. So rather than being expanded from the POV of the
577     inlining page, they are expanded from the POV of the inlined page.
578
579     For example, a link from blog/foo to "bar" will now link to blog/bar
580     if it exists. Previously this needed to be a link explicitly to
581     "blog/bar"; such links will also continue to work.
582
583     (This was slightly complex to do as the link still has to be constructed
584     relative to the inlining page.)
585   * Make page edit textarea resize to fit browser window.
586   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
587     do not need a full rebuild, in order to update any basewiki pages.
588
589  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
590
591 ikiwiki (1.3) unstable; urgency=low
592
593   * Fix the preinst introduced in the last version. Closes: #367458
594
595  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
596
597 ikiwiki (1.2) unstable; urgency=low
598
599   * Remove dups from the brokenlinks list.
600   * Add libc6-dev to dependencies, needed to build wrappers.
601   * Install wikilist in correct location. Closes: #367371
602
603  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
604
605 ikiwiki (1.1) unstable; urgency=low
606
607   * Rename inlinepage to depends, so that it can be used to refer to more
608     dependency relationships than just inlining. This will require a rebuild
609     on upgrade to this version.
610   * Move the rss link, put it in the blogpost form if there is one and at the
611     top if not. This is both nicer because easier to find, and it cleans up
612     the code which had used inlinepage as a flag for adding the link later.
613   * Allow the depends GlobList to be built up from multiple sources (such as
614     plugins) during a page render.
615   * Which means that more than one blog is now supported to appear on a
616     single page. (With some limitations, like only the last one getting an
617     rss file.)
618   * Added a plugin system.
619   * Added a pagecount plugin, enabled by default.
620   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
621   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
622     backlinks when the backlinks hadn't really changed.
623   * Moved inline page support, rss generation etc into the inline plugin,
624     enabled by default.
625   * Added brokenlinks plugin, not enabled by default, but rather handy.
626   * Fix several broken links in the doc wiki.
627   * Smarter behavior when creating a page and a page of the same name (but
628     different location) already exists.
629   * Add an orphans plugin for finding pages that nothing links to.
630   * Removed backlinks page, which it turns out nothing used.
631   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
632     it, this will allow for adding a unit test suite.
633   * Add unit tests for several core functions, including globlist_match,
634     dirname, basename, bestlink, linkify, pagetitle, titlepage.
635   * Smart globlist merging.
636   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
637     to pave the way for adding other RCS support. This also changes the
638     setup files, where before they had svn => 1 or svn => 0, now they have
639     rcs => "svn" or rcs => "".
640   * Add a debian/NEWS file with upgrade notes.
641   * Load whatever rcs module is specified, so new ones can be just dropped in
642     as plugins and work. (Well, in theory.)
643   * Add some basic docs about writing RCS modules.
644   * Broke search capability out into a plugin, removed the --hyperestraier
645     switch.
646   * Added smiley plugin, nicely controlled and documented by the smileys page.
647   * Copied in some smileys from Moin Moin.
648   * Allow links of the form [[some page|page]], with whitespace in the link
649     text.
650   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
651     and --disable-plugin htmlscrubber.
652   * Allow discussion links on pages to be turned off with --no-discussion.
653   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
654   * Add some new config items to the estseek.conf template, which are needed
655     by hyperestraier 1.2.3.
656
657  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
658
659 ikiwiki (1.0) unstable; urgency=low
660
661   * First official release.
662
663  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400