* ikiwiki can now download and aggregate feeds with its new aggregate
[ikiwiki] / debian / changelog
1 ikiwiki (1.13) UNRELEASED; urgency=low
2
3   * ikiwiki can now download and aggregate feeds with its new aggregate
4     plugin, so it's possible to implement a Planet using ikiwiki!
5   * Add a run_hooks function for the common task of running all hooks of a
6     given type.
7   * Add a savestate hook.
8   * Don't put blog post forms on pages if there's no cgiurl set.
9   * Reformat front page.
10   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
11     --wrappers to do that.
12   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
13     to update pages that haven't changed on disk.
14
15  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 20:10:51 -0400
16
17 ikiwiki (1.12) unstable; urgency=low
18
19   "Viva l'Italia!"
20   * New pagestats plugin from Enrico, which can generate a table counting
21     the backlinks for each page, or a del.icio.us style cloud.
22   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
23     the wikiformat plugin works. Thanks, Emanuele Aina.
24   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
25     display, running them through pagetitle. This removes ugly underscores and
26     other gunk from the display, much nicer. You may want to rebuild your wiki
27     when upgrading to get the cleanup globally.
28   * Polygen plugin from Enrico.
29   * htmltidy plugin from Faidon.
30   * Locale patch from Faidon:
31     - Adds a locale setting to setup files.
32     - Proper local time, if the locale configuration option is used.
33     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
34       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
35       impossible.
36   * Add getopt hook type, this allows plugins to add new command-line options.
37   * Add --tagbase option to tag plugin.
38   * Add exclude option in setup files, works same as --exclude.
39   * Put categories in rss feeds for tagged items.
40   * Allow preprocessor directives to be expanded in inlined blog pages.
41     However, to avoid inlining loops etc, don't expand inline directives in
42     inlined pages.
43   * fortune plugin (trivial)
44   * Tag plugins according to type.
45
46  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
47
48 ikiwiki (1.11) unstable; urgency=low
49
50   * Patch from Enrico that
51     - Adds a tag plugin that allows more easily tagging pages.
52       The meta plugin can also still be used for that, but the tag plugin
53       also lists a page's tags at the bottom of the page.
54     - Allows preprocessor directives to have parameters with no specified
55       value.
56     - Fixes preprocessor directive parameter parsing so that
57       foo=bar baz now means "foo=bar" and a "baz" with no value.
58   * Run pagetemplate hooks when inlining pages so that inlined pages also
59     list their tags.
60   * Make all plugins with pagetemplate hooks check that variables exist
61     on the template before setting them, for robustness.
62   * Switch pagetemplate hooks to using named parameters.
63   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
64     This will be the page that a source page will be part of, which is
65     different than the source page for inlined pages.
66   * Audited all plugins to endure they pass (page, destpage) to htmllink
67     appropriatly. This means inlining of various plugins will not work
68     properly, with correct links generated.
69
70  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
71
72 ikiwiki (1.10) unstable; urgency=low
73
74   * Run page through any relevant filters when generating a page preview.
75   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
76     default throughout the wiki, not only on wikitext pages. Decided to call
77     this a feature, and split the camelcase support out into a separate plugin
78     that is independant of wikitext.
79   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
80
81  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
82
83 ikiwiki (1.9) unstable; urgency=low
84
85   * Improve display of parentlinks and page title of toplevel index page.
86   * Patch from Faidon to use svn --limit when possible for recentchanges,
87     speeds up recentchanges a lot for wikis with more history.
88   * Patch from Recai to fix utf8 issues in git backend.
89   * Add wikitext markup plugin, which supports ".wiki" pages written in the
90     original wiki syntax, CamelCase links and all.
91   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
92     support, to edit pages etc without a web server.
93   * Display CGI processing errors if present.
94   * Fix from Faidon for a XML parser issue that breaks utf-8 for
95     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
96     area, and also way slow.
97   * Match 'web commit from' in SVN and git, these are web commits too.
98     (Faidon)
99   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
100     readable and avoid future mistakes. The patch seems to work and for the
101     first time I have a UTF-8 username ;-) (Faidon)
102   * Use form->field consistently, not form->param.
103   * Patch from Recai to allow selection of page type when creating a new page.
104     Default page type is inherited from the link clicked on to create the new
105     page.
106
107  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
108
109 ikiwiki (1.8) unstable; urgency=low
110
111   * Fix orphans plugin to not count a link to a nonexistant page as a reason
112     for a page not being an orphan.
113   * Support pinging services such as Technorati using XML-RPC to notify them
114     about changes to rss feeds.
115   * Parse svn log as xml for improved utf8 and security. Note that this makes
116     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
117   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
118     flagged string even if the locale causes it to generate utf8 output,
119     so make sure to let perl know it should be handled as utf8. Also,
120     the optimised version used for standard time formats won't work if the
121     user has changed locale, so drop it. Thanks, Faidon Liambotis.
122   * Fix re-encoding of the comments field to utf8 if a commit fails
123     due to a conflict. Thanks, Faidon Liambotis.
124   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
125     Liambotis.
126   * Add insane double encode/decode to utf8 around call to markdown.
127     This works around a truely strange bug, which is apparently a bug in
128     perl, #376329. Also added a test case for it.
129   * Improve layout of edit page so formatting help link is always visible w/o
130     getting in the way of the preview.
131   * Centralised all calls to HTML::Template and force all the templates
132     to be read as utf8.
133   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
134   * Introduce add_plugins and disable_plugins config options in setup files.
135     This allows adding or removing plugins w/o overriding the whole list of
136     default plugins, which makes it easier to upgrade when new default plugins
137     are added.
138   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
139     default (of course!). Based on a patch by Faidon Liambotis.
140   * Add a html plugin, which can be used to write wikis in raw html,
141     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
142     defaults to not processing .html files, since w/o this plugin they would
143     be copied unsanitised. With this plugin, it will process and html
144     sanitise them, like any other page type.
145   * Rebuilding wrappers is necessary on upgrade to this version.
146   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
147     will be automatically done on all upgrades.
148   * Don't send pings if the wiki is being rebuilt.
149   * Work around very innefficient behavior in File::Spec::abs2rel. Result
150     is a savings of 2 pointless fork/execs per link calculation, which
151     results in ~25% speedup of ikiwiki building its own doc wiki, and
152     about 35% speedup displaying RecentChanges!
153   * Make RecentChanges use a table and some CSS, should be much more readable.
154     No code changes involved.
155   * Encode & in diffurl in examples, to conform to pedantic rules.
156   * Speed up RecentChanges by another 40% or so with some memoization.
157   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
158     in time to build the doc wiki.
159
160  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
161
162 ikiwiki (1.7) unstable; urgency=low
163
164   * Updated logo from Recai with some kerning and alingment tuning.
165   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
166     changed some output.
167   * Copyright update.
168
169  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
170
171 ikiwiki (1.6) unstable; urgency=low
172
173   * YA utf-8 patch from Recai, this time to fix previewing a page so that
174     the text in the input box is re-encoded back to utf-8.
175   * -CSD does not affect modules, so readfile() was not using the utf-8 input
176     layer, which led to lots of problems; make it force read files as utf-8.
177     Closes: #373203
178   * Note that as a consequence, this version of ikiwiki will actually try to
179     parse utf8 in source files for the first time, which may expose broken
180     utf8 in wiki sources that was hidden before. Most common will be
181     perl warnings like "utf8 "\xE9" does not map to Unicode"
182   * writefile() likewise needs to use the utf8 output layer.
183   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
184     there.
185   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
186     given the readfile fix.
187   * Add utf-8 testcases for readfile and htmlize.
188   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
189     safe.
190   * More utf-8 fixes from Recai, partly to things I broke above:
191     - The serious problem is that writefile() saves the content in undecoded
192       format in CGI, hence all (non-ascii) chars are corrupted permanently.
193     - Comment field in edit page is not decoded and all the non-ascii chars in
194       this field are corrupted as the result.  We should decode it as we do it
195       for the content.
196     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
197       character in print.
198   * New SVG logo from Recai.
199
200  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
201
202 ikiwiki (1.5) unstable; urgency=low
203
204   * Add --timeformat config option to allow changing how dates are displayed.
205     Note that as a side effect, dates will now be displayed using the local
206     timezone, not as GMT.
207   * More security review.
208   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
209     for some handy stuff like:
210     - Using links as a kind of tag; creating blog pages that list all pages
211       containing a given tag/link or not containing some other tag.
212     - Subscribing to mail notifications whenever a change is made to a page
213       that is a backlink of page foo. Ie, "Please notify me of changes in all
214       pages that link to my home page in the wiki"
215     - Locking any pages that are linked to from a particular page, so that
216       lists of locks can be exposed in the wiki.
217   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
218     when a todo item is done, instead of the previous moving it to a different
219     subdir.
220   * Allow pagetemplate plugins to override *anything* in the template.
221   * Add a meta plugin, which allows specifying various metadata about pages,
222     like license and author. It also allows for inserting html link and meta
223     tags into html, overriding the title, and adding hidden WikiLinks, which
224     can be useful when using link-based globbing for page categorisation.
225   * Remove preprocessor directives from inlined pages.
226   * Allow simple preprocessor directive values to be specified w/o quotes.
227   * Add support for using git instead of subversion as the RCS backend,
228     tremendous thanks to Recai Oktaş for this.
229   * Doc updates for git.
230   * Fix absolute url munging in rss generation to support https, ftp, etc urls
231     not just http urls.
232   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
233     utf-8 for edit and other fields, and for recentchanges. There may still
234     be utf-8 issues with the preferences page though.
235
236  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
237
238 ikiwiki (1.4) unstable; urgency=low
239
240   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
241     very strange way of enabling proper XHTML <br /> type tags. Output html
242     should be always valid again now.
243   * The page name and parent links has switched from using a <h1> to a styled
244     <span>, so pages can use <h1> internally instead of needing to use <h2>.
245   * Updated all of ikiwiki's own wiki pages for that.
246   * Add pagetemplate hook, which can be used by plugins that want to mess
247     around with adding new stuff to the page template.
248   * Remove headercontent; the search plugin now adds the search box to the
249     header by registering a pagetemplate hook, and other plugins should do
250     similarly.
251   * Rebuilding on upgrade to this version is recommended.
252   * Add a html validity check to the test suite, using the wdg-html-validator,
253     if available.
254   * Make the html valid when there is nothing in the actions list.
255   * Reordered some function call parameters for consistency.
256   * Enable full utf-8 support for page input and output.
257   * Add a workaround for markdown, which does not work well with utf-8
258     strings.
259   * --getctime had bitrotted (well I only ever used it the once so far..),
260     fix and make it a bit more flexible
261   * rcs_getctime is changed, now rather than needing to loop over all pages,
262     it should just use the rcs to get the ctime of the passed file.
263   * When inlining a page in another one, links from the inlined page are now
264     expanded the same as they are when rendering the inlined page as a
265     standalone page. So rather than being expanded from the POV of the
266     inlining page, they are expanded from the POV of the inlined page.
267
268     For example, a link from blog/foo to "bar" will now link to blog/bar
269     if it exists. Previously this needed to be a link explicitly to
270     "blog/bar"; such links will also continue to work.
271
272     (This was slightly complex to do as the link still has to be constructed
273     relative to the inlining page.)
274   * Make page edit textarea resize to fit browser window.
275   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
276     do not need a full rebuild, in order to update any basewiki pages.
277
278  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
279
280 ikiwiki (1.3) unstable; urgency=low
281
282   * Fix the preinst introduced in the last version. Closes: #367458
283
284  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
285
286 ikiwiki (1.2) unstable; urgency=low
287
288   * Remove dups from the brokenlinks list.
289   * Add libc6-dev to dependencies, needed to build wrappers.
290   * Install wikilist in correct location. Closes: #367371
291
292  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
293
294 ikiwiki (1.1) unstable; urgency=low
295
296   * Rename inlinepage to depends, so that it can be used to refer to more
297     dependency relationships than just inlining. This will require a rebuild
298     on upgrade to this version.
299   * Move the rss link, put it in the blogpost form if there is one and at the
300     top if not. This is both nicer because easier to find, and it cleans up
301     the code which had used inlinepage as a flag for adding the link later.
302   * Allow the depends GlobList to be built up from multiple sources (such as
303     plugins) during a page render.
304   * Which means that more than one blog is now supported to appear on a
305     single page. (With some limitations, like only the last one getting an
306     rss file.)
307   * Added a plugin system.
308   * Added a pagecount plugin, enabled by default.
309   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
310   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
311     backlinks when the backlinks hadn't really changed.
312   * Moved inline page support, rss generation etc into the inline plugin,
313     enabled by default.
314   * Added brokenlinks plugin, not enabled by default, but rather handy.
315   * Fix several broken links in the doc wiki.
316   * Smarter behavior when creating a page and a page of the same name (but
317     different location) already exists.
318   * Add an orphans plugin for finding pages that nothing links to.
319   * Removed backlinks page, which it turns out nothing used.
320   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
321     it, this will allow for adding a unit test suite.
322   * Add unit tests for several core functions, including globlist_match,
323     dirname, basename, bestlink, linkify, pagetitle, titlepage.
324   * Smart globlist merging.
325   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
326     to pave the way for adding other RCS support. This also changes the
327     setup files, where before they had svn => 1 or svn => 0, now they have
328     rcs => "svn" or rcs => "".
329   * Add a debian/NEWS file with upgrade notes.
330   * Load whatever rcs module is specified, so new ones can be just dropped in
331     as plugins and work. (Well, in theory.)
332   * Add some basic docs about writing RCS modules.
333   * Broke search capability out into a plugin, removed the --hyperestraier
334     switch.
335   * Added smiley plugin, nicely controlled and documented by the smileys page.
336   * Copied in some smileys from Moin Moin.
337   * Allow links of the form [[some page|page]], with whitespace in the link
338     text.
339   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
340     and --disable-plugin htmlscrubber.
341   * Allow discussion links on pages to be turned off with --no-discussion.
342   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
343   * Add some new config items to the estseek.conf template, which are needed
344     by hyperestraier 1.2.3.
345
346  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
347
348 ikiwiki (1.0) unstable; urgency=low
349
350   * First official release.
351
352  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400