* Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
[ikiwiki] / debian / changelog
1 ikiwiki (1.14) UNRELEASED; urgency=low
2
3   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
4     by 10% or so.
5   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
6   * Added many unit tests for pagespec_match.
7
8  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:31:52 -0400
9
10 ikiwiki (1.13) unstable; urgency=low
11
12   * ikiwiki can now download and aggregate feeds with its new aggregate
13     plugin, so it's possible to implement a Planet using ikiwiki!
14   * Add a run_hooks function for the common task of running all hooks of a
15     given type.
16   * Add a savestate hook.
17   * Don't put blog post forms on pages if there's no cgiurl set.
18   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
19     --wrappers to do that.
20   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
21     to update pages that haven't changed on disk.
22   * Change meta tags to use html entity-escaped text for values, so that
23     quotes and such can be represented in title tags.
24   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
25     for the above.
26   * Make --rebuild also cause --aggregate to re-download and write aggregated
27     pages.
28   * Avoid outputting duplicate meta info.
29   * Include title metadata on aggregated posts for capitalised and un-munged
30     titles.
31   * Title metadata of inlined pages now shows up in blogs and rss feeds.
32   * Fix issue with unicode filenames and updating the hyper estradier search
33     index. (Aka Please Please Please, let that be the last one.)
34   * Patch from Roland Mas to support an rss=no parameter to inline directives.
35     Closes: #380743
36   * Renamed GlobLists to PageSpecs.
37   * PageSpecs can now include nested parens, "and", and "or". This remains
38     backwards compatible to the old GlobList format. It's implemented by
39     treating the GlobList as a very limited microlanguage that is transformed
40     to perl code that does the matching.
41   * The old GlobList format is deprecated, and I encourage users to switch to
42     using the new PageSpec format. Compatability with the old format will be
43     removed at some point, possibly by 2.0.
44   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
45   * Add support for creation_month and creation_year to PageSpec.
46     Closes: #380680
47   * Changes to index file encoding.
48
49  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
50
51 ikiwiki (1.12) unstable; urgency=low
52
53   "Viva l'Italia!"
54   * New pagestats plugin from Enrico, which can generate a table counting
55     the backlinks for each page, or a del.icio.us style cloud.
56   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
57     the wikiformat plugin works. Thanks, Emanuele Aina.
58   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
59     display, running them through pagetitle. This removes ugly underscores and
60     other gunk from the display, much nicer. You may want to rebuild your wiki
61     when upgrading to get the cleanup globally.
62   * Polygen plugin from Enrico.
63   * htmltidy plugin from Faidon.
64   * Locale patch from Faidon:
65     - Adds a locale setting to setup files.
66     - Proper local time, if the locale configuration option is used.
67     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
68       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
69       impossible.
70   * Add getopt hook type, this allows plugins to add new command-line options.
71   * Add --tagbase option to tag plugin.
72   * Add exclude option in setup files, works same as --exclude.
73   * Put categories in rss feeds for tagged items.
74   * Allow preprocessor directives to be expanded in inlined blog pages.
75     However, to avoid inlining loops etc, don't expand inline directives in
76     inlined pages.
77   * fortune plugin (trivial)
78   * Tag plugins according to type.
79
80  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
81
82 ikiwiki (1.11) unstable; urgency=low
83
84   * Patch from Enrico that
85     - Adds a tag plugin that allows more easily tagging pages.
86       The meta plugin can also still be used for that, but the tag plugin
87       also lists a page's tags at the bottom of the page.
88     - Allows preprocessor directives to have parameters with no specified
89       value.
90     - Fixes preprocessor directive parameter parsing so that
91       foo=bar baz now means "foo=bar" and a "baz" with no value.
92   * Run pagetemplate hooks when inlining pages so that inlined pages also
93     list their tags.
94   * Make all plugins with pagetemplate hooks check that variables exist
95     on the template before setting them, for robustness.
96   * Switch pagetemplate hooks to using named parameters.
97   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
98     This will be the page that a source page will be part of, which is
99     different than the source page for inlined pages.
100   * Audited all plugins to endure they pass (page, destpage) to htmllink
101     appropriatly. This means inlining of various plugins will not work
102     properly, with correct links generated.
103
104  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
105
106 ikiwiki (1.10) unstable; urgency=low
107
108   * Run page through any relevant filters when generating a page preview.
109   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
110     default throughout the wiki, not only on wikitext pages. Decided to call
111     this a feature, and split the camelcase support out into a separate plugin
112     that is independant of wikitext.
113   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
114
115  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
116
117 ikiwiki (1.9) unstable; urgency=low
118
119   * Improve display of parentlinks and page title of toplevel index page.
120   * Patch from Faidon to use svn --limit when possible for recentchanges,
121     speeds up recentchanges a lot for wikis with more history.
122   * Patch from Recai to fix utf8 issues in git backend.
123   * Add wikitext markup plugin, which supports ".wiki" pages written in the
124     original wiki syntax, CamelCase links and all.
125   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
126     support, to edit pages etc without a web server.
127   * Display CGI processing errors if present.
128   * Fix from Faidon for a XML parser issue that breaks utf-8 for
129     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
130     area, and also way slow.
131   * Match 'web commit from' in SVN and git, these are web commits too.
132     (Faidon)
133   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
134     readable and avoid future mistakes. The patch seems to work and for the
135     first time I have a UTF-8 username ;-) (Faidon)
136   * Use form->field consistently, not form->param.
137   * Patch from Recai to allow selection of page type when creating a new page.
138     Default page type is inherited from the link clicked on to create the new
139     page.
140
141  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
142
143 ikiwiki (1.8) unstable; urgency=low
144
145   * Fix orphans plugin to not count a link to a nonexistant page as a reason
146     for a page not being an orphan.
147   * Support pinging services such as Technorati using XML-RPC to notify them
148     about changes to rss feeds.
149   * Parse svn log as xml for improved utf8 and security. Note that this makes
150     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
151   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
152     flagged string even if the locale causes it to generate utf8 output,
153     so make sure to let perl know it should be handled as utf8. Also,
154     the optimised version used for standard time formats won't work if the
155     user has changed locale, so drop it. Thanks, Faidon Liambotis.
156   * Fix re-encoding of the comments field to utf8 if a commit fails
157     due to a conflict. Thanks, Faidon Liambotis.
158   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
159     Liambotis.
160   * Add insane double encode/decode to utf8 around call to markdown.
161     This works around a truely strange bug, which is apparently a bug in
162     perl, #376329. Also added a test case for it.
163   * Improve layout of edit page so formatting help link is always visible w/o
164     getting in the way of the preview.
165   * Centralised all calls to HTML::Template and force all the templates
166     to be read as utf8.
167   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
168   * Introduce add_plugins and disable_plugins config options in setup files.
169     This allows adding or removing plugins w/o overriding the whole list of
170     default plugins, which makes it easier to upgrade when new default plugins
171     are added.
172   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
173     default (of course!). Based on a patch by Faidon Liambotis.
174   * Add a html plugin, which can be used to write wikis in raw html,
175     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
176     defaults to not processing .html files, since w/o this plugin they would
177     be copied unsanitised. With this plugin, it will process and html
178     sanitise them, like any other page type.
179   * Rebuilding wrappers is necessary on upgrade to this version.
180   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
181     will be automatically done on all upgrades.
182   * Don't send pings if the wiki is being rebuilt.
183   * Work around very innefficient behavior in File::Spec::abs2rel. Result
184     is a savings of 2 pointless fork/execs per link calculation, which
185     results in ~25% speedup of ikiwiki building its own doc wiki, and
186     about 35% speedup displaying RecentChanges!
187   * Make RecentChanges use a table and some CSS, should be much more readable.
188     No code changes involved.
189   * Encode & in diffurl in examples, to conform to pedantic rules.
190   * Speed up RecentChanges by another 40% or so with some memoization.
191   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
192     in time to build the doc wiki.
193
194  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
195
196 ikiwiki (1.7) unstable; urgency=low
197
198   * Updated logo from Recai with some kerning and alingment tuning.
199   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
200     changed some output.
201   * Copyright update.
202
203  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
204
205 ikiwiki (1.6) unstable; urgency=low
206
207   * YA utf-8 patch from Recai, this time to fix previewing a page so that
208     the text in the input box is re-encoded back to utf-8.
209   * -CSD does not affect modules, so readfile() was not using the utf-8 input
210     layer, which led to lots of problems; make it force read files as utf-8.
211     Closes: #373203
212   * Note that as a consequence, this version of ikiwiki will actually try to
213     parse utf8 in source files for the first time, which may expose broken
214     utf8 in wiki sources that was hidden before. Most common will be
215     perl warnings like "utf8 "\xE9" does not map to Unicode"
216   * writefile() likewise needs to use the utf8 output layer.
217   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
218     there.
219   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
220     given the readfile fix.
221   * Add utf-8 testcases for readfile and htmlize.
222   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
223     safe.
224   * More utf-8 fixes from Recai, partly to things I broke above:
225     - The serious problem is that writefile() saves the content in undecoded
226       format in CGI, hence all (non-ascii) chars are corrupted permanently.
227     - Comment field in edit page is not decoded and all the non-ascii chars in
228       this field are corrupted as the result.  We should decode it as we do it
229       for the content.
230     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
231       character in print.
232   * New SVG logo from Recai.
233
234  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
235
236 ikiwiki (1.5) unstable; urgency=low
237
238   * Add --timeformat config option to allow changing how dates are displayed.
239     Note that as a side effect, dates will now be displayed using the local
240     timezone, not as GMT.
241   * More security review.
242   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
243     for some handy stuff like:
244     - Using links as a kind of tag; creating blog pages that list all pages
245       containing a given tag/link or not containing some other tag.
246     - Subscribing to mail notifications whenever a change is made to a page
247       that is a backlink of page foo. Ie, "Please notify me of changes in all
248       pages that link to my home page in the wiki"
249     - Locking any pages that are linked to from a particular page, so that
250       lists of locks can be exposed in the wiki.
251   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
252     when a todo item is done, instead of the previous moving it to a different
253     subdir.
254   * Allow pagetemplate plugins to override *anything* in the template.
255   * Add a meta plugin, which allows specifying various metadata about pages,
256     like license and author. It also allows for inserting html link and meta
257     tags into html, overriding the title, and adding hidden WikiLinks, which
258     can be useful when using link-based globbing for page categorisation.
259   * Remove preprocessor directives from inlined pages.
260   * Allow simple preprocessor directive values to be specified w/o quotes.
261   * Add support for using git instead of subversion as the RCS backend,
262     tremendous thanks to Recai Oktaş for this.
263   * Doc updates for git.
264   * Fix absolute url munging in rss generation to support https, ftp, etc urls
265     not just http urls.
266   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
267     utf-8 for edit and other fields, and for recentchanges. There may still
268     be utf-8 issues with the preferences page though.
269
270  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
271
272 ikiwiki (1.4) unstable; urgency=low
273
274   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
275     very strange way of enabling proper XHTML <br /> type tags. Output html
276     should be always valid again now.
277   * The page name and parent links has switched from using a <h1> to a styled
278     <span>, so pages can use <h1> internally instead of needing to use <h2>.
279   * Updated all of ikiwiki's own wiki pages for that.
280   * Add pagetemplate hook, which can be used by plugins that want to mess
281     around with adding new stuff to the page template.
282   * Remove headercontent; the search plugin now adds the search box to the
283     header by registering a pagetemplate hook, and other plugins should do
284     similarly.
285   * Rebuilding on upgrade to this version is recommended.
286   * Add a html validity check to the test suite, using the wdg-html-validator,
287     if available.
288   * Make the html valid when there is nothing in the actions list.
289   * Reordered some function call parameters for consistency.
290   * Enable full utf-8 support for page input and output.
291   * Add a workaround for markdown, which does not work well with utf-8
292     strings.
293   * --getctime had bitrotted (well I only ever used it the once so far..),
294     fix and make it a bit more flexible
295   * rcs_getctime is changed, now rather than needing to loop over all pages,
296     it should just use the rcs to get the ctime of the passed file.
297   * When inlining a page in another one, links from the inlined page are now
298     expanded the same as they are when rendering the inlined page as a
299     standalone page. So rather than being expanded from the POV of the
300     inlining page, they are expanded from the POV of the inlined page.
301
302     For example, a link from blog/foo to "bar" will now link to blog/bar
303     if it exists. Previously this needed to be a link explicitly to
304     "blog/bar"; such links will also continue to work.
305
306     (This was slightly complex to do as the link still has to be constructed
307     relative to the inlining page.)
308   * Make page edit textarea resize to fit browser window.
309   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
310     do not need a full rebuild, in order to update any basewiki pages.
311
312  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
313
314 ikiwiki (1.3) unstable; urgency=low
315
316   * Fix the preinst introduced in the last version. Closes: #367458
317
318  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
319
320 ikiwiki (1.2) unstable; urgency=low
321
322   * Remove dups from the brokenlinks list.
323   * Add libc6-dev to dependencies, needed to build wrappers.
324   * Install wikilist in correct location. Closes: #367371
325
326  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
327
328 ikiwiki (1.1) unstable; urgency=low
329
330   * Rename inlinepage to depends, so that it can be used to refer to more
331     dependency relationships than just inlining. This will require a rebuild
332     on upgrade to this version.
333   * Move the rss link, put it in the blogpost form if there is one and at the
334     top if not. This is both nicer because easier to find, and it cleans up
335     the code which had used inlinepage as a flag for adding the link later.
336   * Allow the depends GlobList to be built up from multiple sources (such as
337     plugins) during a page render.
338   * Which means that more than one blog is now supported to appear on a
339     single page. (With some limitations, like only the last one getting an
340     rss file.)
341   * Added a plugin system.
342   * Added a pagecount plugin, enabled by default.
343   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
344   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
345     backlinks when the backlinks hadn't really changed.
346   * Moved inline page support, rss generation etc into the inline plugin,
347     enabled by default.
348   * Added brokenlinks plugin, not enabled by default, but rather handy.
349   * Fix several broken links in the doc wiki.
350   * Smarter behavior when creating a page and a page of the same name (but
351     different location) already exists.
352   * Add an orphans plugin for finding pages that nothing links to.
353   * Removed backlinks page, which it turns out nothing used.
354   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
355     it, this will allow for adding a unit test suite.
356   * Add unit tests for several core functions, including globlist_match,
357     dirname, basename, bestlink, linkify, pagetitle, titlepage.
358   * Smart globlist merging.
359   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
360     to pave the way for adding other RCS support. This also changes the
361     setup files, where before they had svn => 1 or svn => 0, now they have
362     rcs => "svn" or rcs => "".
363   * Add a debian/NEWS file with upgrade notes.
364   * Load whatever rcs module is specified, so new ones can be just dropped in
365     as plugins and work. (Well, in theory.)
366   * Add some basic docs about writing RCS modules.
367   * Broke search capability out into a plugin, removed the --hyperestraier
368     switch.
369   * Added smiley plugin, nicely controlled and documented by the smileys page.
370   * Copied in some smileys from Moin Moin.
371   * Allow links of the form [[some page|page]], with whitespace in the link
372     text.
373   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
374     and --disable-plugin htmlscrubber.
375   * Allow discussion links on pages to be turned off with --no-discussion.
376   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
377   * Add some new config items to the estseek.conf template, which are needed
378     by hyperestraier 1.2.3.
379
380  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
381
382 ikiwiki (1.0) unstable; urgency=low
383
384   * First official release.
385
386  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400