add spec file
[ikiwiki] / ikiwiki.spec
1 Name:           ikiwiki
2 Version: 3.20091024
3 Release:        1%{?dist}
4 Summary:        A wiki compiler
5
6 Group:          Applications/Internet
7 License:        GPLv2+
8 URL:            http://ikiwiki.info/
9 Source0:        http://ftp.debian.org/debian/pool/main/i/%{name}/%{name}_%{version}.tar.gz
10 Patch0:         ikiwiki-3.00-libexecdir.patch
11 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
12 BuildArch:      noarch
13
14 BuildRequires:  perl(Text::Markdown)
15 BuildRequires:  perl(Mail::Sendmail)
16 BuildRequires:  perl(HTML::Scrubber)
17 BuildRequires:  perl(XML::Simple)
18 BuildRequires:  perl(Date::Parse)
19 BuildRequires:  perl(Date::Format)
20 BuildRequires:  perl(HTML::Template)
21 BuildRequires:  perl(CGI::FormBuilder)
22 BuildRequires:  perl(CGI::Session)
23 BuildRequires:  perl(File::MimeInfo)
24 BuildRequires:  gettext
25 BuildRequires:  po4a
26
27 Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
28
29 Requires:       perl(Text::Markdown)
30 Requires:       perl(Mail::Sendmail)
31 Requires:       perl(HTML::Scrubber)
32 Requires:       perl(XML::Simple)
33 Requires:       perl(CGI::FormBuilder)
34 Requires:       perl(CGI::Session)
35 Requires:       perl(Digest::SHA1)
36
37 Requires:       python-docutils
38
39 %define cgi_bin %{_libexecdir}/w3m/cgi-bin
40
41
42 %description
43 Ikiwiki is a wiki compiler. It converts wiki pages into HTML pages
44 suitable for publishing on a website. Ikiwiki stores pages and history
45 in a revision control system such as Subversion or Git. There are many
46 other features, including support for blogging, as well as a large
47 array of plugins.
48
49
50 %prep
51 %setup0 -q -n %{name}
52 %patch0 -p1 -b .libexecdir
53
54 # Filter unwanted Provides:
55 %{__cat} << \EOF > %{name}-prov
56 #!/bin/sh
57 %{__perl_provides} $* |\
58   %{__sed} -e '/perl(IkiWiki.*)/d'
59 EOF
60
61 %define __perl_provides %{_builddir}/%{name}/%{name}-prov
62 %{__chmod} +x %{__perl_provides}
63
64 # Filter Requires, all used by plugins
65 # - Monotone: see bz 450267
66 %{__cat} << \EOF > %{name}-req
67 #!/bin/sh
68 %{__perl_requires} $* |\
69   %{__sed} -e '/perl(IkiWiki.*)/d' \
70            -e '/perl(Monotone)/d'
71 EOF
72
73 %define __perl_requires %{_builddir}/%{name}/%{name}-req
74 %{__chmod} +x %{__perl_requires}
75
76 # goes into the -w3m subpackage
77 %{__cat} << \EOF > README.fedora
78 See http://ikiwiki.info/w3mmode/ for more information.
79 EOF
80
81
82 %build
83 %{__perl} Makefile.PL INSTALLDIRS=vendor PREFIX=%{_prefix}
84 # parallel builds currently don't work
85 %{__make} 
86
87
88 %install
89 %{__rm} -rf %{buildroot}
90 %{__make} pure_install DESTDIR=%{buildroot} W3M_CGI_BIN=%{cgi_bin}
91 %find_lang %{name}
92
93 # move external plugins
94 %{__mkdir_p} %{buildroot}%{_libexecdir}/ikiwiki/plugins
95 %{__mv} %{buildroot}%{_prefix}/lib/ikiwiki/plugins/* \
96         %{buildroot}%{_libexecdir}/ikiwiki/plugins
97
98 # remove shebang
99 %{__sed} -e '1{/^#!/d}' -i \
100         %{buildroot}%{_sysconfdir}/ikiwiki/auto.setup \
101         %{buildroot}%{_sysconfdir}/ikiwiki/auto-blog.setup \
102         %{buildroot}%{_libexecdir}/ikiwiki/plugins/proxy.py
103
104
105 %clean
106 %{__rm} -rf %{buildroot}
107
108
109 %files -f %{name}.lang
110 %defattr(-,root,root,-)
111 %{_bindir}/ikiwiki*
112 %{_sbindir}/ikiwiki*
113 %{_mandir}/man1/ikiwiki*
114 %{_mandir}/man8/ikiwiki*
115 %{_datadir}/ikiwiki
116 %dir %{_sysconfdir}/ikiwiki
117 %config(noreplace) %{_sysconfdir}/ikiwiki/*
118 # contains a packlist only
119 %exclude %{perl_vendorarch}
120 %{perl_vendorlib}/IkiWiki*
121 %exclude %{perl_vendorlib}/IkiWiki*/Plugin/skeleton.pm.example
122 %{_libexecdir}/ikiwiki
123 %doc README debian/changelog debian/NEWS html
124 %doc IkiWiki/Plugin/skeleton.pm.example
125
126
127 %package w3m
128 Summary:        Ikiwiki w3m cgi meta-wrapper
129 Group:          Applications/Internet
130 Requires:       w3m
131 Requires:       %{name} = %{version}-%{release}
132
133 %description w3m
134 Enable usage of all of ikiwiki's web features (page editing, etc) in
135 the w3m web browser without a web server. w3m supports local CGI
136 scripts, and ikiwiki can be set up to run that way using the
137 meta-wrapper in this package.
138
139
140 %files w3m
141 %defattr(-,root,root,-)
142 %doc README.fedora
143 %{cgi_bin}/ikiwiki-w3m.cgi
144
145
146 %changelog
147 * Thu Oct  8 2009 Thomas Moschny <thomas.moschny@gmx.de> - 3.14159265-1
148 - Update to 3.14159265.
149
150 * Tue Sep  1 2009 Thomas Moschny <thomas.moschny@gmx.de> - 3.1415926-1
151 - Update to 3.1415926 (fixes CVE-2009-2944, see bz 520543).
152
153 * Wed Aug 12 2009 Thomas Moschny <thomas.moschny@gmx.de> - 3.141592-1
154 - Update to 3.141592.
155 - po4a is needed now.
156
157 * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1415-2
158 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
159
160 * Fri Jul 17 2009 Thomas Moschny <thomas.moschny@gmx.de> - 3.1415-1
161 - Update to 3.1415.
162
163 * Thu Jun 11 2009 Thomas Moschny <thomas.moschny@gmx.de> - 3.14-1
164 - Update to 3.14.
165
166 * Fri May 15 2009 Thomas Moschny <thomas.moschny@gmx.de> - 3.12-1
167 - Update to 3.12.
168
169 * Tue May  5 2009 Thomas Moschny <thomas.moschny@gmx.de> - 3.11-1
170 - Update to 3.11.
171
172 * Sat Apr 25 2009 Thomas Moschny <thomas.moschny@gmx.de> - 3.10-1
173 - Update to 3.10.
174
175 * Tue Apr  7 2009 Thomas Moschny <thomas.moschny@gmx.de> - 3.09-1
176 - Update to 3.09.
177
178 * Fri Mar 27 2009 Thomas Moschny <thomas.moschny@gmx.de> - 3.08-1
179 - Update to 3.08.
180
181 * Mon Mar  9 2009 Thomas Moschny <thomas.moschny@gmx.de> - 3.07-1
182 - Update to 3.07.
183
184 * Thu Mar  5 2009 Thomas Moschny <thomas.moschny@gmx.de> - 3.06-1
185 - Update to 3.06.
186
187 * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.04-2
188 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
189
190 * Wed Feb 18 2009 Thomas Moschny <thomas.moschny@gmx.de> - 3.04-1
191 - Update to 3.04.
192
193 * Mon Feb  9 2009 Thomas Moschny <thomas.moschny@gmx.de> - 3.03-1
194 - Update to 3.03.
195
196 * Sat Jan 10 2009 Thomas Moschny <thomas.moschny@gmx.de> - 3.01-1
197 - Update to 3.01.
198
199 * Fri Jan  2 2009 Thomas Moschny <thomas.moschny@gmx.de> - 3.00-1
200 - Update to 3.00.
201
202 * Fri Jan  2 2009 Thomas Moschny <thomas.moschny@gmx.de> - 2.72-1
203 - Update to 2.72.
204 - Patch for mtn plugin has been applied upstream.
205 - Encoding of ikiwiki.vim has been changed to utf-8 upstream.
206 - Use new W3M_CGI_BIN option in %%install.
207
208 * Tue Dec 16 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.70-3
209 - Patch for monotone plugin: Prevent broken pipe message.
210 - Cosmetic changes to satisfy rpmlint.
211
212 * Mon Dec 01 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.70-2
213 - Rebuild for Python 2.6
214
215 * Thu Nov 20 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.70-1
216 - Update to 2.70.
217 - Install and enable the external rst plugin.
218 - Stop filtering perl(RPC::XML*) requires.
219
220 * Fri Oct 10 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.66-1
221 - Update to 2.66.
222
223 * Fri Sep 19 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.64-1
224 - Update to 2.64.
225
226 * Thu Sep 11 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.63-1
227 - Update to 2.63.
228
229 * Sat Aug 30 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.62.1-1
230 - Update to 2.62.1. Add /etc/ikiwiki.
231
232 * Thu Aug  7 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.56-1
233 - Update to 2.56.
234 - Stop filtering perl(Net::Amazon::S3), has been approved (bz436481).
235
236 * Thu Jul 31 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.55-1
237 - Update to 2.55.
238
239 * Thu Jul 24 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.54-1
240 - Update to 2.54.
241 - Move example plugin file to doc.
242
243 * Sat Jul 12 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.53-1
244 - Update to 2.53.
245
246 * Thu Jul 10 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.52-1
247 - Update to 2.52.
248
249 * Sun Jul  6 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.51-1
250 - Update to 2.51.
251 - Save iconv output to a temporary file.
252
253 * Sun Jun 15 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.50-1
254 - Update to 2.50.
255 - Move ikiwiki-w3m.cgi into a subpackage.
256 - Add ikiwiki's own documentation.
257 - Remove duplicate requirement perl(File::MimeInfo).
258 - Minor cleanups.
259
260 * Mon Jun  2 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.48-1
261 - Update to 2.48.
262
263 * Wed May 28 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.47-1
264 - Update to 2.47.
265
266 * Tue May 13 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.46-1
267 - Update to 2.46.
268
269 * Sat May 10 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.45-1
270 - New package.