"InternetAutoDial" should be "InternetAutodial".
[wine] / dlls / wininet / wininet.spec
1 @ stdcall InternetInitializeAutoProxyDll(long) InternetInitializeAutoProxyDll
2 @ stub ShowCertificate
3 @ stdcall CommitUrlCacheEntryA(str str long long long str long str str) CommitUrlCacheEntryA
4 @ stub CommitUrlCacheEntryW
5 @ stub CreateUrlCacheContainerA
6 @ stub CreateUrlCacheContainerW
7 @ stub CreateUrlCacheEntryA
8 @ stub CreateUrlCacheEntryW
9 @ stdcall CreateUrlCacheGroup(long ptr) CreateUrlCacheGroup
10 @ stub DeleteIE3Cache
11 @ stub DeleteUrlCacheContainerA
12 @ stub DeleteUrlCacheContainerW
13 @ stdcall DeleteUrlCacheEntry(str) DeleteUrlCacheEntry
14 @ stdcall DeleteUrlCacheGroup(long long ptr) DeleteUrlCacheGroup
15 @ stdcall DllInstall(long ptr) WININET_DllInstall
16 @ stub FindCloseUrlCache
17 @ stub FindFirstUrlCacheContainerA
18 @ stub FindFirstUrlCacheContainerW
19 @ stdcall FindFirstUrlCacheEntryA(str ptr ptr) FindFirstUrlCacheEntryA
20 @ stub FindFirstUrlCacheEntryExA
21 @ stub FindFirstUrlCacheEntryExW
22 @ stdcall FindFirstUrlCacheEntryW(wstr ptr ptr) FindFirstUrlCacheEntryW
23 @ stub FindNextUrlCacheContainerA
24 @ stub FindNextUrlCacheContainerW
25 @ stub FindNextUrlCacheEntryA
26 @ stub FindNextUrlCacheEntryExA
27 @ stub FindNextUrlCacheEntryExW
28 @ stub FindNextUrlCacheEntryW
29 @ stub FreeUrlCacheSpaceA
30 @ stub FreeUrlCacheSpaceW
31 @ stub FtpCommandA
32 @ stub FtpCommandW
33 @ stdcall FtpCreateDirectoryA(ptr str) FtpCreateDirectoryA
34 @ stdcall FtpCreateDirectoryW(ptr wstr) FtpCreateDirectoryW
35 @ stdcall FtpDeleteFileA(ptr str) FtpDeleteFileA
36 @ stub FtpDeleteFileW
37 @ stdcall FtpFindFirstFileA(ptr str str long long) FtpFindFirstFileA
38 @ stdcall FtpFindFirstFileW(ptr wstr wstr long long) FtpFindFirstFileW
39 @ stdcall FtpGetCurrentDirectoryA(ptr str ptr) FtpGetCurrentDirectoryA
40 @ stdcall FtpGetCurrentDirectoryW(ptr wstr ptr) FtpGetCurrentDirectoryW
41 @ stdcall FtpGetFileA(ptr str str long long long long) FtpGetFileA
42 @ stdcall FtpGetFileW(ptr wstr wstr long long long long) FtpGetFileW
43 @ stdcall FtpOpenFileA(ptr str long long long) FtpOpenFileA
44 @ stdcall FtpOpenFileW(ptr wstr long long long) FtpOpenFileW
45 @ stdcall FtpPutFileA(ptr str str long long) FtpPutFileA
46 @ stub FtpPutFileW
47 @ stdcall FtpRemoveDirectoryA(ptr str) FtpRemoveDirectoryA
48 @ stub FtpRemoveDirectoryW
49 @ stdcall FtpRenameFileA(ptr str str) FtpRenameFileA
50 @ stub FtpRenameFileW
51 @ stdcall FtpSetCurrentDirectoryA(ptr str) FtpSetCurrentDirectoryA
52 @ stdcall FtpSetCurrentDirectoryW(ptr wstr) FtpSetCurrentDirectoryW
53 @ stub GetUrlCacheConfigInfoA
54 @ stub GetUrlCacheConfigInfoW
55 @ stdcall GetUrlCacheEntryInfoA(str ptr long) GetUrlCacheEntryInfoA
56 @ stdcall GetUrlCacheEntryInfoExA(str ptr ptr str ptr ptr long) GetUrlCacheEntryInfoExA
57 @ stdcall GetUrlCacheEntryInfoExW(wstr ptr ptr wstr ptr ptr long) GetUrlCacheEntryInfoExW
58 @ stub GetUrlCacheEntryInfoW
59 @ stub GetUrlCacheHeaderData
60 @ stub GopherCreateLocatorA
61 @ stub GopherCreateLocatorW
62 @ stub GopherFindFirstFileA
63 @ stub GopherFindFirstFileW
64 @ stub GopherGetAttributeA
65 @ stub GopherGetAttributeW
66 @ stub GopherGetLocatorTypeA
67 @ stub GopherGetLocatorTypeW
68 @ stub GopherOpenFileA
69 @ stub GopherOpenFileW
70 @ stdcall HttpAddRequestHeadersA(ptr str long long) HttpAddRequestHeadersA
71 @ stub HttpAddRequestHeadersW
72 @ stdcall HttpEndRequestA(ptr ptr long long) HttpEndRequestA
73 @ stdcall HttpEndRequestW(ptr ptr long long) HttpEndRequestW
74 @ stdcall HttpOpenRequestA(ptr str str str str ptr long long) HttpOpenRequestA
75 @ stdcall HttpOpenRequestW(ptr wstr wstr wstr wstr ptr long long) HttpOpenRequestW
76 @ stdcall HttpQueryInfoA(ptr long ptr ptr ptr) HttpQueryInfoA
77 @ stdcall HttpQueryInfoW(ptr long ptr ptr ptr) HttpQueryInfoW
78 @ stdcall HttpSendRequestA(ptr str long ptr long) HttpSendRequestA
79 @ stdcall HttpSendRequestExA(long ptr ptr long long) HttpSendRequestExA
80 @ stub HttpSendRequestExW
81 @ stdcall HttpSendRequestW(ptr wstr long ptr long) HttpSendRequestW
82 @ stub IncrementUrlCacheHeaderData
83 @ stdcall InternetAttemptConnect(long) InternetAttemptConnect
84 @ stdcall InternetAutodial(long ptr) InternetAutodial
85 @ stub InternetAutodialCallback
86 @ stdcall InternetAutodialHangup(long) InternetAutodialHangup
87 @ stdcall InternetCanonicalizeUrlA(str str ptr long) InternetCanonicalizeUrlA
88 @ stdcall InternetCanonicalizeUrlW(wstr wstr ptr long) InternetCanonicalizeUrlW
89 @ stdcall InternetCheckConnectionA(ptr long long) InternetCheckConnectionA
90 @ stdcall InternetCheckConnectionW(ptr long long) InternetCheckConnectionW
91 @ stdcall InternetCloseHandle(long) InternetCloseHandle
92 @ stdcall InternetCombineUrlA(str str str ptr long) InternetCombineUrlA
93 @ stdcall InternetCombineUrlW(wstr wstr wstr ptr long) InternetCombineUrlW
94 @ stub InternetConfirmZoneCrossing
95 @ stdcall InternetConnectA(ptr str long str str long long long) InternetConnectA
96 @ stdcall InternetConnectW(ptr wstr long wstr wstr long long long) InternetConnectW
97 @ stdcall InternetCrackUrlA(str long long ptr) InternetCrackUrlA
98 @ stdcall InternetCrackUrlW(wstr long long ptr) InternetCrackUrlW
99 @ stub InternetCreateUrlA
100 @ stub InternetCreateUrlW
101 @ stub InternetDebugGetLocalTime
102 @ stub InternetDial
103 @ stub InternetErrorDlg
104 @ stdcall InternetFindNextFileA(ptr ptr) InternetFindNextFileA
105 @ stub InternetFindNextFileW
106 @ stub InternetGetCertByURL
107 @ stdcall InternetGetConnectedState(ptr long) InternetGetConnectedState
108 @ stdcall InternetGetCookieA(str str ptr long) InternetGetCookieA
109 @ stdcall InternetGetCookieW(wstr wstr ptr long) InternetGetCookieW
110 @ stdcall InternetGetLastResponseInfoA(ptr str ptr) InternetGetLastResponseInfoA
111 @ stub InternetGetLastResponseInfoW
112 @ stub InternetGoOnline
113 @ stub InternetHangUp
114 @ stdcall InternetLockRequestFile(ptr ptr) InternetLockRequestFile
115 @ stdcall InternetOpenA(str long str str long) InternetOpenA
116 @ stdcall InternetOpenW(wstr long wstr wstr long) InternetOpenW
117 @ stub InternetOpenServerPushParse
118 @ stdcall InternetOpenUrlA(ptr str str long long long) InternetOpenUrlA
119 @ stdcall InternetOpenUrlW(ptr wstr wstr long long long) InternetOpenUrlW
120 @ stdcall InternetQueryDataAvailable(ptr ptr long long) InternetQueryDataAvailable
121 @ stdcall InternetQueryOptionA(ptr long ptr ptr) InternetQueryOptionA
122 @ stdcall InternetQueryOptionW(ptr long ptr ptr) InternetQueryOptionW
123 @ stdcall InternetReadFile(ptr ptr long ptr) InternetReadFile
124 @ stdcall InternetReadFileExA(ptr ptr long long) InternetReadFileExA
125 @ stdcall InternetReadFileExW(ptr ptr long long) InternetReadFileExW
126 @ stub InternetServerPushParse
127 @ stdcall InternetSetCookieA(str str str) InternetSetCookieA
128 @ stdcall InternetSetCookieW(wstr wstr wstr) InternetSetCookieW
129 @ stub InternetSetDialState
130 @ stub InternetSetFilePointer
131 @ stdcall InternetSetOptionA(ptr long ptr long) InternetSetOptionA
132 @ stdcall InternetSetOptionW(ptr long ptr long) InternetSetOptionW
133 @ stub InternetSetOptionExA
134 @ stub InternetSetOptionExW
135 @ stdcall InternetSetStatusCallback(ptr ptr) InternetSetStatusCallback
136 @ stub InternetShowSecurityInfoByURL
137 @ stub InternetTimeFromSystemTime
138 @ stub InternetTimeToSystemTime
139 @ stdcall InternetUnlockRequestFile(ptr) InternetUnlockRequestFile
140 @ stdcall InternetWriteFile(ptr ptr long ptr) InternetWriteFile
141 @ stub InternetWriteFileExA
142 @ stub InternetWriteFileExW
143 @ stdcall IsHostInProxyBypassList(long str long) IsHostInProxyBypassList
144 @ stub LoadUrlCacheContent
145 @ stub ParseX509EncodedCertificateForListBoxEntry
146 @ stub ReadUrlCacheEntryStream
147 @ stdcall RetrieveUrlCacheEntryFileA(str ptr ptr long) RetrieveUrlCacheEntryFileA
148 @ stub RetrieveUrlCacheEntryFileW
149 @ stub RetrieveUrlCacheEntryStreamA
150 @ stub RetrieveUrlCacheEntryStreamW
151 @ stub RunOnceUrlCache
152 @ stub SetUrlCacheConfigInfoA
153 @ stub SetUrlCacheConfigInfoW
154 @ stdcall SetUrlCacheEntryGroup(str long long ptr long ptr) SetUrlCacheEntryGroup
155 @ stub SetUrlCacheEntryInfoA
156 @ stub SetUrlCacheEntryInfoW
157 @ stub SetUrlCacheHeaderData
158 @ stub ShowClientAuthCerts
159 @ stub ShowSecurityInfo
160 @ stub ShowX509EncodedCertificate
161 @ stub UnlockUrlCacheEntryFile
162 @ stub UnlockUrlCacheEntryStream
163 @ stub UpdateUrlCacheContentPath